blob: be0948e4111f6b34ba3a2b1e8015f2a9425fb172 [file] [log] [blame]
Pau Espin Pedrol55fe62f2023-02-07 14:29:48 +01001osmo-ggsn (1.10.0) unstable; urgency=medium
2
3 [ Max ]
4 * Set working directory in systemd service file
5 * Ignore .deb build byproducts
6 * ctrl: take both address and port from vty config
7
8 [ Pau Espin Pedrol ]
9 * cosmetic: gtp: Fix typo in comment
10 * Split gsn_t related APIs out of gtp.{c,h}
11 * Use rate_ctr for gsn_t available_counters
12 * ggsn: Introduce tdef and make it configurable over VTY
13 * gtp: Introduce VTY configurable GTP timer X3
14 * Fix typos in comments and VTY descriptions
15
16 [ arehbein ]
17 * osmo-ggsn: Transition to use of 'telnet_init_default'
18
19 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 07 Feb 2023 14:29:48 +0100
20
Pau Espin Pedrolbc583d92022-06-28 17:48:22 +020021osmo-ggsn (1.9.0) unstable; urgency=medium
22
23 [ Pau Espin Pedrol ]
24 * tests: in46a_test: Make coverity happy when calling in46a_from_eua
25 * vty: Fix cmd 'no echo-interval' doing nothing
26 * libgtp: Fix ggsn crash if pdp alloc array is full (PDP_MAX)
27 * libgtp: Define retransmit QUEUE_SIZE relative to PDP_MAX (increase)
28 * gtp: Use switch statement in gtp_create_pdp_ind()
29 * gtp: Log detection of rx duplicate
30 * gtp: Small log improvements in gtp_create_pdp_ind()
31 * gtp: Specify retrans queue name & seqnum in log lines
32 * gtp: Log retrans queue register&free entries
33 * gtp: Fix typo in comment
34 * pco.h: Fix typo in reference to spec
35
36 [ Vadim Yanitskiy ]
37 * tests: use 'check_PROGRAMS' instead of 'noinst_PROGRAMS'
38
39 [ Harald Welte ]
40 * update git URLs (git -> https; gitea)
41
42 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 28 Jun 2022 17:48:22 +0200
43
Pau Espin Pedrola3ca2d12021-11-16 13:49:16 +010044osmo-ggsn (1.8.0) unstable; urgency=medium
45
46 [ Oliver Smith ]
47 * doc/examples/Makefile.am: add sgsnemu.conf
48 * doc/examples/osmo-ggsn-kernel-gtp.cfg: new file
49 * doc/manuals: describe GTP-U kernel module
50 * gitignore: add ggsn_vty_reference.xml
51
52 [ Harald Welte ]
53 * Don't install osmo-ggsn-kernel-gtp.cfg to /etc/osmocom/
54 * Don't install sgsnemu.conf to /etc/osmocom/
55 * ggsn: Reject PDP CTX ACT for static IP addresses
56 * vty: Inform user that static IP addresses are not supported
57
58 [ Pau Espin Pedrol ]
59 * gtp: Update teic_confirmed only on resp success
60 * gtp: Rework parsing logic of UpdatePdpCtxResponse
61 * ggsn: Improve logging on incoming DL data packets
62 * gtp: Improve logging of failing pdp ctx resolution from TEI/TID
63 * cosmetic: gtpie.c: Fix trailing whitespace
64 * gtp: constify pointer arg
65 * gtp: Support tx/rx RAN Information Relay message
66 * ggsn: Log tun fd write errors
67 * ggsn: Fix heap-use-after-free during Recovery without associated PDP
68 * cosmetic: configure.ac: Fix tabulation in line
69 * Introduce program gtp-echo-responder
70 * gtp_echo_responder: report invalid chars present in node-feautres cmdline arg as error
71
72 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 16 Nov 2021 13:49:16 +0100
73
Pau Espin Pedrol18898b42021-02-23 17:31:24 +010074osmo-ggsn (1.7.1) unstable; urgency=medium
75
76 [ Harald Welte ]
77 * main: add --vty-ref-mode, use vty_dump_xml_ref_mode()
78 * manuals: generate vty reference xml at build time
79
80 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 23 Feb 2021 17:31:24 +0100
81
Pau Espin Pedrolb1f641b2021-02-23 13:34:39 +010082osmo-ggsn (1.7.0) unstable; urgency=medium
83
84 [ Vadim Yanitskiy ]
85 * debian/control: change maintainer to the Osmocom team / mailing list
86
87 [ Pau Espin Pedrol ]
88 * configure.ac: Fix trailing whitespace
89 * doc: Update VTY reference xml file
90 * Support setting rt-prio and cpu-affinity mask through VTY
91 * contrib/jenkins: Enable parallel make in make distcheck
92 * ggsn: generate coredump and exit upon SIGABRT received
93 * tests: Explicitly drop category from log
94 * tests: Replace deprecated API log_set_print_filename
95
96 [ Keith ]
97 * Fix vty PDP lookups by IMSI
98 * Prevent Crash in show pdp-context from vty
99 * Minor: remove code duplication
100 * Use imsi_str2gtp() in sgsnemu
101 * sgsnemu: relax check on length of IMSI cmdline arg.
102 * GTP: Replace recently introduced imsi_str2gtp()
103
104 [ Harald Welte ]
105 * Use OSMO_FD_* instead of deprecated BSC_FD_*
106 * gtp-kernel: Remove duplicate #include section
107 * gtp-kernel: don't #include libmnl headers
108
109 [ Oliver Smith ]
110 * contrib/jenkins: don't build osmo-gsm-manuals
111 * configure.ac: set -std=gnu11
112 * apn_start: avoid segfault if missing tun-device
113 * .gitignore: ignore debian/libgtp*
114 * deb/rpm: build with --enable-gtp-linux
115
116 -- Pau Espin Pedrol <pespin@espeweb.net> Tue, 23 Feb 2021 13:34:39 +0100
117
Harald Welte21546072020-08-13 12:26:20 +0200118osmo-ggsn (1.6.0) unstable; urgency=medium
119
120 [ Pau Espin Pedrol ]
121 * cosmetic: Fix comment typo
122 * netns: Improve error checking
123 * sgsnemu: cmdline: Drop unused function cmdline_parser_params_create()
124 * sgsnemu: Pass array of in64_addr to in46a_from_eua()
125 * sgsnemu: Rename sgsnemu's libgtp cb_conf
126 * sgsnemu: Set its default loglevel category to INFO
127 * Move icmpv6 and checksum files from ggsn/ dir to lib/
128 * netdev_addaddr6: Use prefixlen arg
129 * sgsnemu: Avoid adding extra autogenerated local link ipv6 addr to tun iface
130 * sgsnemu: Fix ping transmitted statistics output
131 * cosmetic: icmpv6.c: fix typo in comment
132 * icmpv6.c: Mark internal function as static
133 * sgsnemu: Get rid of duplicated options.destaddr
134 * sgsnemu: Get rid of duplicated options.net
135 * sgsnemu: tun_addaddr: Don't set local addr as dstaddr
136 * icmpv6.c: Move code generating ipv6 hdr to its own function
137 * Rename netdev_*route to end in route4
138 * sgsnemu: Fix build/run against linux < 4.11 (no sysctl addr_gen_mode support)
139 * sgsnemu: Handle IPv6 SLAAC in tun iface manually
140 * sgsnemu: Implement ping on IPv6 APNs
141 * sgsnemu: Fix assumption ipv6 Interface-Identifier of public addr == announced Prefix
142 * gtp: queue_test: Fix printf gcc warn under ARM
143
144 [ Andreas Schultz ]
145 * add Linux network namespace support for TUN device
146
147 [ Vadim Yanitskiy ]
148 * lib/netns: fix open_ns(): return fd from open()
149
150 [ Philipp Maier ]
151 * doc: do not use random ip address for dns in default conf
152 * doc: use 127.0.0.2 instead of 127.0.0.6 as bind ip.
153 * debug: use LOGL_NOTICE instead of LOGL_DEBUG
154
155 [ Eric ]
156 * configure.ac: fix libtool issue with clang and sanitizer
157
158 [ Harald Welte ]
159 * lib/netns.c: Add comments to the code, including doxygen API docs
160 * lib/netns: OSMO_ASSERT() if user doesn't call init_netns()
161 * lib/netns: Fix up error paths
162 * example config: use RFC1918 addresses for GGSN pools
163
164 [ Dmitri Kalashnik ]
165 * sgsnemu: use real tun device name after the device is up.
166
167 [ Oliver Smith ]
168 * osmo-ggsn.spec.in: remove
169 * contrib: import RPM spec
170 * contrib: integrate RPM spec
171 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
172
173 -- Harald Welte <laforge@osmocom.org> Thu, 13 Aug 2020 12:26:20 +0200
174
Pau Espin Pedrole71e0f22020-01-02 20:39:39 +0100175osmo-ggsn (1.5.0) unstable; urgency=medium
176
177 [ Jan Engelhardt ]
178 * build: switch AC_CANONICAL_TARGET for AC_CANONICAL_HOST
179
180 [ Pau Espin Pedrol ]
181 * libgtp: Remove packets in tx queue belonging pdp being freed
182 * libgtp: announce pdp ctx deletion upon CreatePdpCtx being rejected
183 * Introduce in46a_is_v{4,6}() helpers
184 * ggsn: Move PCO handling code into its own file
185 * in46_addr: Improve in46a_ntop documentation
186 * ggsn_vty.c: Fix wrong use of in46a_from_eua, print IPv6 euas
187 * ggsn: Split application lifecycle related code into ggsn_main.c
188 * Move pdp_get_peer_ipv() to lib/util.*
189 * gtp-kernel.c: Fix wrong use of in46a_from_eua, print IPv6 euas
190 * Introduce LOGTUN log helper
191 * ggsn_vty.c: Avoid printing duplicates for pdp context with v4v6 EUAs
192 * pdp: constify param in pdp_count_secondary()
193 * ggsn_vty.c: Improve output of VTY show pdp-context
194 * doc: Update vty reference xml file
195 * libgtp: Introduce cb_recovery3
196 * ggsn: Implement echo req/resp and recovery
197 * cosmetic: fix formatting in if line
198 * gtp: Log msg retransmits and timeouts
199 * cosmetic: gtp: Drop commented out code calling pdp_freepdp()
200 * cosmetic: gtp: Improve documentation of gtp_delete_context_req2()
201 * ggsn: rx DeletePdpReq confirmation: Improve documentation and use gtp_freepdp()
202 * gtp: Manage queue timers internally
203 * ggsn, sgsnemu: Drop use of no-op deprecated gtp_retrans* APIs
204
205 [ Vadim Yanitskiy ]
206 * gtp_update_pdp_ind(): fix NULL-pointer dereference
207 * gtp_error_ind_conf(): fix: guard against an unknown GTP version
208 * gtp/gtp.c: cosmetic: use get_tid() where we need TID
209 * manuals/configuration.adoc: fix Network Address without prefix length
210 * manuals/configuration.adoc: fix IPv4 address mismatch in <<ggsn_no_root>>
211 * contrib/systemd: add systemd-networkd examples from manuals
212
213 [ Harald Welte ]
214 * sgsnemu: Fix null-pointer format string argument
215 * manual: Fix copy+paste error
216
217 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 02 Jan 2020 20:39:39 +0100
218
Pau Espin Pedrol67aebc92019-08-07 21:28:30 +0200219osmo-ggsn (1.4.0) unstable; urgency=medium
220
221 [ Max ]
222 * Don't return error on normal shutdown
223
224 [ Harald Welte ]
225 * process_pco() const-ify 'apn' argument
226 * ggsn: Remove magic numbers from pco_contains_proto()
227 * ggsn: const-ify input / read-only arguments of PCO related functions
228 * ggsn: Remove magic numbers from ipcp_contains_option()
229 * ggsn: Fix build_ipcp_pco() in presence of invalid IPCP content
230 * ggsn.c: Refactor PCO processing during PDP activation
231 * ggsn: Add minimalistic PAP support
232 * ggsn: More logging from PCO handling (e.g. in case of malconfiguration)
233 * sgsnemu: Fix format string argument count
234
235 [ Vadim Yanitskiy ]
236 * osmo-ggsn: fix VTY command for getting PDP contexts by APN
237 * osmo-ggsn: add VTY command to show PDP context by IPv4
238 * osmo-ggsn: check result of osmo_apn_to_str()
239 * osmo-ggsn: print requested / actual APN in PDP info
240 * osmo-ggsn: properly show subscriber's MSISDN in the VTY
241
242 [ Pau Espin Pedrol ]
243 * ggsn: Drop unused param force in apn_stop()
244 * gtp: Document spec reasoning drop of Rx DeleteCtxReq
245 * ggsn: Start gtp retrans timer during startup
246 * gtp: Take queue_resp into account to schedule retrans timer
247 * gtp: Fix typo dublicate->duplicate
248 * pdp: Introduce new API pdp_count_secondary
249 * gtp_create_pdp_ind: simplify code by reordering and compacting parsing
250 * gtp: Refactor code to use gtp_freepdp(_teardown) APIs
251 * cosmetic: gtp: Document free pdp ctx in non-teardown scenario
252 * gtp: Re-arrange free pdp ctx code in non-teardown scenario
253 * pdp: Drop unused code for haship
254 * cosmetic: gtp.h: Remove trailing whitespaces
255 * ggsn: Fix undefined behaviour shifting beyond sign bit
256 * gtp: Introduce new pdp APIs (and deprecate old ones) to support multiple GSN
257 * gtp: Make use of new libgtp APIs with multi-gsn support
258 * ggsn_vty_reference.xml: Update from last code changes
259 * ggsn: vty: Require ggsn param in <show pdp-context> cmd
260 * sgsnemu: Replace use of deprecated libgtp API pdp_newpdp with new one
261 * cosmetic: gtp: queue: remove trailing whitespace
262 * gtp: Add missing headers
263 * gtp: queue.c: Document queue APIs
264 * gtp: queue: Add unit test queue_test
265 * ggsn: Avoid unaligned mem access reading PCO proto id
266 * ggsn: Use structures instead of raw arrays when parsing ipcp_hdr
267 * configure.ac: Replace obosolete macro AC_CANONICAL_SYSTEM
268 * configure.ac: Use brackets in AC_INIT params
269 * configure.ac: Use prefered AC_CONFIG_HEADERS over AM_CONFIG_HEADER
270 * configure.ac: some versions of linux/if.h require including sys/socket.h
271 * sgsnemu: Fix unaligned pointer access during ip/icmp checksum
272 * Remove undefined param passed to {logging,osmo_stats}_vty_add_cmds
273 * Require libosmocore 1.1.0
274
275 [ Oliver Smith ]
276 * debian: create -doc subpackage with pdf manuals
277 * ggsn: Use gtp_delete_context_req2() everywhere
278 * contrib/jenkins.sh: run "make maintainer-clean"
279
280 [ Daniel Willmann ]
281 * manuals: Add script to regenerate vty/counter documentation
282
283 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 21:28:30 +0200
284
Harald Weltef5a268a2019-01-20 21:34:23 +0100285osmo-ggsn (1.3.0) unstable; urgency=medium
286
287 [ Pau Espin Pedrol ]
288 * ggsn: ctrl iface: listen on IP configured by VTY
289 * gtp: Log type name of unexpected signalling message
290 * gtp: Allow recv DEL CTX REQ in sgsn and DEL CTX RSP in ggsn
291 * gtp: Log ignore CTX DEL REQ due to no teardown and only 1 ctx active
292 * gtp: Add new API to avoid freeing pdp contexts during DEL CTX REQ
293 * gtp: Add new replacement cb_recovery2 for cb_recovery
294 * Install systemd services with autotools
295 * Install sample cfg file to /etc/osmocom
296
297 [ Stefan Sperling ]
298 * fix unaligned access in build_ipcp_pco()
299 * fix support for multiple IPCP in PDP protocol configuration options
300 * check ioctl() call return value in tun_new()
301 * fix allocation of ippool's hash table
302 * replace bogus memcpy() call in ippool_newip()
303 * initialize local variable addr in ippool_new()
304 * fix format string error in ippool_printaddr()
305 * fix a format string directives in queue_seqset()
306 * properly store IPv6 addresses in struct tun_t
307
308 [ Harald Welte ]
309 * debian/rules: Don't overwrite .tarball-version
310 * osmo-ggsn.cfg: Ensure well-formed config file example
311 * sgsnemu: Fix printing of tun device name
312 * ippool.c: Use "%td" format string for ptrdiff_t
313 * initial version of OsmoGGSN user manual
314 * OsmoGGSN: Add VTY reference manual
315 * GGSN: Document how 'ip tuntap' is used for non-root; call netdev 'apn0'
316 * vty-ref: Update URI of docbook 5.0 schema
317
318 [ Alexander Couzens ]
319 * libgtp: implement gtp_clear_queues to clear req/resp queue
320
321 [ Neels Hofmeyr ]
322 * Importing history from osmo-gsm-manuals.git
323 * refactor Makefile build rules, don't use the FORCE
324 * GGSN: don't say 'NITB'
325 * OsmoGGSN: more info on non-root operation / tun creation
326 * OsmoGGSN: multiple instances: mention GTP port
327 * OsmoGGSN: add Routing section for IP forward and masquerading
328 * OsmoGGSN: typo: priveleges
329 * OsmoGGSN VTY ref: prep: convert newlines to unix
330 * OsmoGGSN vty: update VTY reference
331 * OsmoGGSN: fix VTY additions' node IDs
332 * OsmoGGSN: update vty reference
333 * ggsn: update vty reference
334
335 [ Max ]
336 * Expand OsmoGGSN manual
337
338 [ Oliver Smith ]
339 * build manuals moved here from osmo-gsm-manuals.git
340 * Fix DISTCHECK_CONFIGURE_FLAGS override
341 * contrib/jenkins.sh: build and publish manuals
342 * contrib: fix makedistcheck with disabled systemd
343
344 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 21:34:22 +0100
345
Pau Espin Pedrolb673d1c2018-05-31 12:44:54 +0200346osmo-ggsn (1.2.2) unstable; urgency=medium
347
348 [ Vadim Yanitskiy ]
349 * ggsn_vty.c: fix: use CONFIG_NODE as parent by default
350
351 [ Philipp Maier ]
352 * ggsn: fix misinterpreted length field in ipcp_contains_option()
353 * ggsn: make sure ipcp_option_hdr and and ipcp_hdr are packed
354
355 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 31 May 2018 12:44:54 +0200
356
Pau Espin Pedrolac076252018-05-04 12:19:58 +0200357osmo-ggsn (1.2.1) unstable; urgency=medium
358
359 * debian/rules: Fix debian packaging after 1.2.0 release
360
361 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 04 May 2018 12:19:58 +0200
362
Pau Espin Pedrola06b2d32018-05-03 16:05:28 +0200363osmo-ggsn (1.2.0) unstable; urgency=medium
364
365 [ Neels Hofmeyr ]
366 * fix compiler warnings: return 0 in main(), in 3 tests
367 * add --enable-sanitize config option
368 * sanitize build: ensure uint16/32 alignment in gtpie_test and in46a_test
369 * configure: add --enable-werror
370 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
371
372 [ Harald Welte ]
373 * sgsnemu: Don't leak FILE handle in proc_read()
374 * sgsnemu: Fix format string in printing tun-device name
375 * sgsnemu: Make sure buffer has space for terminating-NUL
376 * sgsnemu: Free strings in error path
377 * gtp: Fix buffer overflow in imsi_gtp2str()
378 * gtp: Explicit OSMO_ASSERT to ensure pdp variable is set
379 * tun: Don't copy 16byte IPv6 address to 'struct in_addr'
380 * ippool: Correctly compute size of static pool
381 * remove unused argument to alloc_ippool_blacklist()
382 * factor out netdev_ip_local_get() from tun_ip_local_get()
383 * Properly NULL-out blacklist in alloc_ippool_blacklist()
384 * gtp_kernel: Change gtp_kernel_init() function signature
385 * gtp-kernel: Re-add support for kernel GTP-U acceleration
386 * gtp-kernel: Get rid of hard-coded kernel GTP device name
387 * gtp-kernel: shut down kernel GTP device in apn_down()
388 * gtp-kernel: Align logging for APN start in kernel-gtp case with that of TUN
389 * gtp-kernel: Avoid global state variable
390 * gtp-kernel: Make sure repeated calls to gtp_kernel_init() are safe
391 * gtp-kernel: proper cleanup in error path
392 * gtp-kernel: Get rid of SYS_ERR where not applicable
393 * gtp-kernel: Add function name to pdp_debug() function calls
394 * gtp-kernel: Add device nime in pdp_debug() log statements
395 * contrib/jenkins.sh: Allow jenkins job to specify if kernel GTP is used
396 * ggsn.c: Fix byte order of IPCP IPv4 DNS servers
397 * ggsn: Ignore PCO with length 0, don't abort processing
398 * README.md: Remove misleading sentence on sgsnemu
399 * Add talloc context introspection via VTY
400 * fix segfault in case of kernel gtp-u
401 * lib/tun.c: Generalize tun_sifflags() to netdev_sifflags
402 * lib/tun.c: generalize tun_*route() to netdev_*route()
403 * lib/tun.c: Generalize tun_{set,add}addr*() functions
404 * lib/tun: split generic network device related stuff to lib/netdev
405 * lib/netdev.c: Cosmetic changes (coding style / cleanups)
406 * ggsn: Don't explicitly use tun_setaddr() API anymore
407 * sgsnemu: Convert from tun_setaddr() to tun_addaddr()
408 * lib/tun: Remove tun_setaddr() API, as everyone is using tun_addaddr() now
409 * Move kernel GTP support from ggsn/ to lib/
410 * ggsn: don't use gtp_kernel_tunnel_{add,del}() for userspace tun
411
412 [ Pau Espin Pedrol ]
413 * ggsn_vty: Stop using deprecated API vty_install_default
414 * contrib/jenkins.sh: Enable Werror in C(PP)FLAGS
415 * examples: Add secondary ipv6 google DNS to osmo-ggsn.cfg
416 * tun_setaddr6: Fix log typo
417 * cosmetic: Reorder tun_addaddr to get rid of decl of tun_setaddr4
418 * ggsn.c: Print version of unhandled ip packet
419 * Remove unused empty src/Makefile.in
420 * tests: Split ipv6 specific tests into a new test group
421 * Add support for IPv4v6 End User Addresses
422 * contrib: jenkins.sh: Build libgtpnl as dep when building with gtp kernel support
423 * cosmetic: sgsnemu.c: Fix trailing whitespace
424 * ggsn.c: Improve logging info on link-local ipv6 addr not found
425 * tun.c: tun_addaddr: Fix segfault and wrong usage of tun_nlattr
426 * Set tun_addaddr ipv agnostic and add support for ipv6
427 * ggsn: Add 'ipv6 link-local' vty cmd
428 * ggsn_vty.c: Print ipv6 link-local cmd when writing config to file
429 * gtp.c: Fix trailing whitespace
430 * gtp.c: Determine GTP version from header
431 * gtp.c: Log unsupported GTP version number
432 * gtp/pdp: Fix trailing whitespace
433 * gtp/pdp: Remove unused APIs pdp_ntoeua pdp_euaton
434 * gtp.c: gtp_gpdu_ind: Convert ifelse to switch statement
435 * gtp.c: gtp_gpdu_ind: Early return to avoid use of uninitialized var
436 * gtp/gtp.c: Remove unused function char2ul_t
437 * gtp/gtp.c: Mark non exported functions as static
438 * gtp/gtp.c: Use uint8_t for version param in static functions
439 * ggsn: encaps_tun: Avoid forwarding packet if EUA is unassigned, fix crash
440 * ggsn: Validate packet src addr from MS
441 * ggsn: Parse PCO_IPCP
442 * ggsn: Parse PCO_IPCP for IPv4v6 pdp ctx
443 * ggsn: Print all addresses on successful pdp ctx creation
444 * ggsn.c: cb_tun_ind: Convert ifelse to switch statement
445 * ggsn.c: cb_tun_ind: log dst addr of packet without pdp ctx
446 * ggsn.c: cb_tun_ind: Don't drop packets targeting pdp ctx ll addr
447 * sgsnemu: Fix bad ptr during context deallocation
448 * sgsnemu: listen param is a host, not an interface
449 * use osmo_init_logging2
450
451 [ Max ]
452 * Log APN and tun names for packets
453 * Enable sanitize for CI tests
454 * Fix stow-enabled jenkins build failure
455 * Add GTP message names
456
457 [ Viktor Tsymbalyuk ]
458 * sgsnemu: sgsnemu stopped after recieving "Request accepted" from ggsn
459 * sgsnemu: created "pinghost" and "createif" modes for mutual exclusion
460 * sgsnemu: fix: no outgoing GTP-U in "createif" mode
461
462 [ Martin Hauke ]
463 * build: Remove AC_PROG_CXX, C++ is never used
464
465 [ Stefan Sperling ]
466 * remove the -f option from osmo-ggsn.service
467
468 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:05:27 +0200
469
Harald Welteff069172017-10-28 19:00:23 +0200470osmo-ggsn (1.1.0) unstable; urgency=medium
471
472 * libgtp: pdp.h: Addition of new tx_gpdu_seq struct member member
473 * libgtp: pdp.h: add LOGPDPX() helper to public API
474
475 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 19:00:23 +0200
476
Harald Welteb5b02c22017-09-06 12:19:49 +0200477osmo-ggsn (1.0.0) unstable; urgency=medium
Harald Welte632e8432017-09-05 18:12:14 +0200478
479 * Transition to OsmoGGSN
480
Harald Welteb5b02c22017-09-06 12:19:49 +0200481 -- Harald Welte <laforge@gnumonks.org> Wed, 06 Sep 2017 12:19:48 +0200
Harald Welte632e8432017-09-05 18:12:14 +0200482
Maxbdc504e2017-08-28 12:15:03 +0200483openggsn (0.94.0) UNRELEASED; urgency=medium
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200484
Harald Welte367baa32017-08-13 09:41:33 +0200485 [ Holger Hans Peter Freyther ]
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200486 * Bump version to ease upgrading from Debian SID.
Holger Hans Peter Freyther68d244d2017-01-24 17:21:05 +0100487 * Bump libgtp SO version after ABI change.
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200488
Harald Welte367baa32017-08-13 09:41:33 +0200489 [ Harald Welte ]
490 * various documentation / README updates
491 * improve error logging and propagation
492 * endian-safe definition of IP header
493 * IPv6 user plane support
494
495 -- Harald Welte <laforge@gnumonks.org> Sun, 13 Aug 2017 09:34:20 +0200
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200496
Holger Hans Peter Freyther89dcb6142015-11-30 14:06:09 +0100497openggsn (0.92) precise; urgency=medium
498
499 * Release 0.92
500
501 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Mon, 30 Nov 2015 14:05:59 +0100
502
503openggsn (0.91+git34) precise; urgency=medium
Holger Hans Peter Freyther0b705bb2014-09-23 16:38:47 +0200504
505 * Non-maintainer upload.
506
507 -- Holger Hans Peter Freyther <holger@freyther.de> Tue, 23 Sep 2014 16:38:32 +0200
508
509openggsn (0.91+git33) precise; urgency=low
Eric Butlerab9ff092012-08-24 21:16:01 -0700510
511 * Fix init script.
512
513 -- Eric Butler <eric@codebutler.com> Fri, 24 Aug 2012 21:15:32 -0700
514
Eric Butler235a0952012-08-14 18:08:41 -0700515openggsn (0.91+git33) precise; urgency=low
516
517 * Update package for Ubuntu Precise.
518
519 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 16:48:59 -0700
520
Harald Welteb5022552011-05-10 17:32:02 +0200521openggsn (0.91-2) unstable; urgency=low
522
523 * Switch to source/format (git)
524
525 -- Harald Welte <laforge@gnumonks.org> Tue, 10 May 2011 17:31:37 +0200
526
Harald Weltee9168092010-08-24 15:23:33 +0200527openggsn (0.91-1) unstable; urgency=low
528
529 * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
530
531 -- Harald Welte <laforge@gnumonks.org> Tue, 24 Aug 2010 11:23:40 +0200