blob: 6588dcae3e1656b591a4b14a9866dbf2ea17aa95 [file] [log] [blame]
Pau Espin Pedrolac076252018-05-04 12:19:58 +02001osmo-ggsn (1.2.1) unstable; urgency=medium
2
3 * debian/rules: Fix debian packaging after 1.2.0 release
4
5 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 04 May 2018 12:19:58 +0200
6
Pau Espin Pedrola06b2d32018-05-03 16:05:28 +02007osmo-ggsn (1.2.0) unstable; urgency=medium
8
9 [ Neels Hofmeyr ]
10 * fix compiler warnings: return 0 in main(), in 3 tests
11 * add --enable-sanitize config option
12 * sanitize build: ensure uint16/32 alignment in gtpie_test and in46a_test
13 * configure: add --enable-werror
14 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
15
16 [ Harald Welte ]
17 * sgsnemu: Don't leak FILE handle in proc_read()
18 * sgsnemu: Fix format string in printing tun-device name
19 * sgsnemu: Make sure buffer has space for terminating-NUL
20 * sgsnemu: Free strings in error path
21 * gtp: Fix buffer overflow in imsi_gtp2str()
22 * gtp: Explicit OSMO_ASSERT to ensure pdp variable is set
23 * tun: Don't copy 16byte IPv6 address to 'struct in_addr'
24 * ippool: Correctly compute size of static pool
25 * remove unused argument to alloc_ippool_blacklist()
26 * factor out netdev_ip_local_get() from tun_ip_local_get()
27 * Properly NULL-out blacklist in alloc_ippool_blacklist()
28 * gtp_kernel: Change gtp_kernel_init() function signature
29 * gtp-kernel: Re-add support for kernel GTP-U acceleration
30 * gtp-kernel: Get rid of hard-coded kernel GTP device name
31 * gtp-kernel: shut down kernel GTP device in apn_down()
32 * gtp-kernel: Align logging for APN start in kernel-gtp case with that of TUN
33 * gtp-kernel: Avoid global state variable
34 * gtp-kernel: Make sure repeated calls to gtp_kernel_init() are safe
35 * gtp-kernel: proper cleanup in error path
36 * gtp-kernel: Get rid of SYS_ERR where not applicable
37 * gtp-kernel: Add function name to pdp_debug() function calls
38 * gtp-kernel: Add device nime in pdp_debug() log statements
39 * contrib/jenkins.sh: Allow jenkins job to specify if kernel GTP is used
40 * ggsn.c: Fix byte order of IPCP IPv4 DNS servers
41 * ggsn: Ignore PCO with length 0, don't abort processing
42 * README.md: Remove misleading sentence on sgsnemu
43 * Add talloc context introspection via VTY
44 * fix segfault in case of kernel gtp-u
45 * lib/tun.c: Generalize tun_sifflags() to netdev_sifflags
46 * lib/tun.c: generalize tun_*route() to netdev_*route()
47 * lib/tun.c: Generalize tun_{set,add}addr*() functions
48 * lib/tun: split generic network device related stuff to lib/netdev
49 * lib/netdev.c: Cosmetic changes (coding style / cleanups)
50 * ggsn: Don't explicitly use tun_setaddr() API anymore
51 * sgsnemu: Convert from tun_setaddr() to tun_addaddr()
52 * lib/tun: Remove tun_setaddr() API, as everyone is using tun_addaddr() now
53 * Move kernel GTP support from ggsn/ to lib/
54 * ggsn: don't use gtp_kernel_tunnel_{add,del}() for userspace tun
55
56 [ Pau Espin Pedrol ]
57 * ggsn_vty: Stop using deprecated API vty_install_default
58 * contrib/jenkins.sh: Enable Werror in C(PP)FLAGS
59 * examples: Add secondary ipv6 google DNS to osmo-ggsn.cfg
60 * tun_setaddr6: Fix log typo
61 * cosmetic: Reorder tun_addaddr to get rid of decl of tun_setaddr4
62 * ggsn.c: Print version of unhandled ip packet
63 * Remove unused empty src/Makefile.in
64 * tests: Split ipv6 specific tests into a new test group
65 * Add support for IPv4v6 End User Addresses
66 * contrib: jenkins.sh: Build libgtpnl as dep when building with gtp kernel support
67 * cosmetic: sgsnemu.c: Fix trailing whitespace
68 * ggsn.c: Improve logging info on link-local ipv6 addr not found
69 * tun.c: tun_addaddr: Fix segfault and wrong usage of tun_nlattr
70 * Set tun_addaddr ipv agnostic and add support for ipv6
71 * ggsn: Add 'ipv6 link-local' vty cmd
72 * ggsn_vty.c: Print ipv6 link-local cmd when writing config to file
73 * gtp.c: Fix trailing whitespace
74 * gtp.c: Determine GTP version from header
75 * gtp.c: Log unsupported GTP version number
76 * gtp/pdp: Fix trailing whitespace
77 * gtp/pdp: Remove unused APIs pdp_ntoeua pdp_euaton
78 * gtp.c: gtp_gpdu_ind: Convert ifelse to switch statement
79 * gtp.c: gtp_gpdu_ind: Early return to avoid use of uninitialized var
80 * gtp/gtp.c: Remove unused function char2ul_t
81 * gtp/gtp.c: Mark non exported functions as static
82 * gtp/gtp.c: Use uint8_t for version param in static functions
83 * ggsn: encaps_tun: Avoid forwarding packet if EUA is unassigned, fix crash
84 * ggsn: Validate packet src addr from MS
85 * ggsn: Parse PCO_IPCP
86 * ggsn: Parse PCO_IPCP for IPv4v6 pdp ctx
87 * ggsn: Print all addresses on successful pdp ctx creation
88 * ggsn.c: cb_tun_ind: Convert ifelse to switch statement
89 * ggsn.c: cb_tun_ind: log dst addr of packet without pdp ctx
90 * ggsn.c: cb_tun_ind: Don't drop packets targeting pdp ctx ll addr
91 * sgsnemu: Fix bad ptr during context deallocation
92 * sgsnemu: listen param is a host, not an interface
93 * use osmo_init_logging2
94
95 [ Max ]
96 * Log APN and tun names for packets
97 * Enable sanitize for CI tests
98 * Fix stow-enabled jenkins build failure
99 * Add GTP message names
100
101 [ Viktor Tsymbalyuk ]
102 * sgsnemu: sgsnemu stopped after recieving "Request accepted" from ggsn
103 * sgsnemu: created "pinghost" and "createif" modes for mutual exclusion
104 * sgsnemu: fix: no outgoing GTP-U in "createif" mode
105
106 [ Martin Hauke ]
107 * build: Remove AC_PROG_CXX, C++ is never used
108
109 [ Stefan Sperling ]
110 * remove the -f option from osmo-ggsn.service
111
112 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:05:27 +0200
113
Harald Welteff069172017-10-28 19:00:23 +0200114osmo-ggsn (1.1.0) unstable; urgency=medium
115
116 * libgtp: pdp.h: Addition of new tx_gpdu_seq struct member member
117 * libgtp: pdp.h: add LOGPDPX() helper to public API
118
119 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 19:00:23 +0200
120
Harald Welteb5b02c22017-09-06 12:19:49 +0200121osmo-ggsn (1.0.0) unstable; urgency=medium
Harald Welte632e8432017-09-05 18:12:14 +0200122
123 * Transition to OsmoGGSN
124
Harald Welteb5b02c22017-09-06 12:19:49 +0200125 -- Harald Welte <laforge@gnumonks.org> Wed, 06 Sep 2017 12:19:48 +0200
Harald Welte632e8432017-09-05 18:12:14 +0200126
Maxbdc504e2017-08-28 12:15:03 +0200127openggsn (0.94.0) UNRELEASED; urgency=medium
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200128
Harald Welte367baa32017-08-13 09:41:33 +0200129 [ Holger Hans Peter Freyther ]
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200130 * Bump version to ease upgrading from Debian SID.
Holger Hans Peter Freyther68d244d2017-01-24 17:21:05 +0100131 * Bump libgtp SO version after ABI change.
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200132
Harald Welte367baa32017-08-13 09:41:33 +0200133 [ Harald Welte ]
134 * various documentation / README updates
135 * improve error logging and propagation
136 * endian-safe definition of IP header
137 * IPv6 user plane support
138
139 -- Harald Welte <laforge@gnumonks.org> Sun, 13 Aug 2017 09:34:20 +0200
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200140
Holger Hans Peter Freyther89dcb6142015-11-30 14:06:09 +0100141openggsn (0.92) precise; urgency=medium
142
143 * Release 0.92
144
145 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Mon, 30 Nov 2015 14:05:59 +0100
146
147openggsn (0.91+git34) precise; urgency=medium
Holger Hans Peter Freyther0b705bb2014-09-23 16:38:47 +0200148
149 * Non-maintainer upload.
150
151 -- Holger Hans Peter Freyther <holger@freyther.de> Tue, 23 Sep 2014 16:38:32 +0200
152
153openggsn (0.91+git33) precise; urgency=low
Eric Butlerab9ff092012-08-24 21:16:01 -0700154
155 * Fix init script.
156
157 -- Eric Butler <eric@codebutler.com> Fri, 24 Aug 2012 21:15:32 -0700
158
Eric Butler235a0952012-08-14 18:08:41 -0700159openggsn (0.91+git33) precise; urgency=low
160
161 * Update package for Ubuntu Precise.
162
163 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 16:48:59 -0700
164
Harald Welteb5022552011-05-10 17:32:02 +0200165openggsn (0.91-2) unstable; urgency=low
166
167 * Switch to source/format (git)
168
169 -- Harald Welte <laforge@gnumonks.org> Tue, 10 May 2011 17:31:37 +0200
170
Harald Weltee9168092010-08-24 15:23:33 +0200171openggsn (0.91-1) unstable; urgency=low
172
173 * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
174
175 -- Harald Welte <laforge@gnumonks.org> Tue, 24 Aug 2010 11:23:40 +0200