blob: 83fd8230d468a1b4ff789ba8e148d76a516ee048 [file] [log] [blame]
Pau Espin Pedrola06b2d32018-05-03 16:05:28 +02001osmo-ggsn (1.2.0) unstable; urgency=medium
2
3 [ Neels Hofmeyr ]
4 * fix compiler warnings: return 0 in main(), in 3 tests
5 * add --enable-sanitize config option
6 * sanitize build: ensure uint16/32 alignment in gtpie_test and in46a_test
7 * configure: add --enable-werror
8 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
9
10 [ Harald Welte ]
11 * sgsnemu: Don't leak FILE handle in proc_read()
12 * sgsnemu: Fix format string in printing tun-device name
13 * sgsnemu: Make sure buffer has space for terminating-NUL
14 * sgsnemu: Free strings in error path
15 * gtp: Fix buffer overflow in imsi_gtp2str()
16 * gtp: Explicit OSMO_ASSERT to ensure pdp variable is set
17 * tun: Don't copy 16byte IPv6 address to 'struct in_addr'
18 * ippool: Correctly compute size of static pool
19 * remove unused argument to alloc_ippool_blacklist()
20 * factor out netdev_ip_local_get() from tun_ip_local_get()
21 * Properly NULL-out blacklist in alloc_ippool_blacklist()
22 * gtp_kernel: Change gtp_kernel_init() function signature
23 * gtp-kernel: Re-add support for kernel GTP-U acceleration
24 * gtp-kernel: Get rid of hard-coded kernel GTP device name
25 * gtp-kernel: shut down kernel GTP device in apn_down()
26 * gtp-kernel: Align logging for APN start in kernel-gtp case with that of TUN
27 * gtp-kernel: Avoid global state variable
28 * gtp-kernel: Make sure repeated calls to gtp_kernel_init() are safe
29 * gtp-kernel: proper cleanup in error path
30 * gtp-kernel: Get rid of SYS_ERR where not applicable
31 * gtp-kernel: Add function name to pdp_debug() function calls
32 * gtp-kernel: Add device nime in pdp_debug() log statements
33 * contrib/jenkins.sh: Allow jenkins job to specify if kernel GTP is used
34 * ggsn.c: Fix byte order of IPCP IPv4 DNS servers
35 * ggsn: Ignore PCO with length 0, don't abort processing
36 * README.md: Remove misleading sentence on sgsnemu
37 * Add talloc context introspection via VTY
38 * fix segfault in case of kernel gtp-u
39 * lib/tun.c: Generalize tun_sifflags() to netdev_sifflags
40 * lib/tun.c: generalize tun_*route() to netdev_*route()
41 * lib/tun.c: Generalize tun_{set,add}addr*() functions
42 * lib/tun: split generic network device related stuff to lib/netdev
43 * lib/netdev.c: Cosmetic changes (coding style / cleanups)
44 * ggsn: Don't explicitly use tun_setaddr() API anymore
45 * sgsnemu: Convert from tun_setaddr() to tun_addaddr()
46 * lib/tun: Remove tun_setaddr() API, as everyone is using tun_addaddr() now
47 * Move kernel GTP support from ggsn/ to lib/
48 * ggsn: don't use gtp_kernel_tunnel_{add,del}() for userspace tun
49
50 [ Pau Espin Pedrol ]
51 * ggsn_vty: Stop using deprecated API vty_install_default
52 * contrib/jenkins.sh: Enable Werror in C(PP)FLAGS
53 * examples: Add secondary ipv6 google DNS to osmo-ggsn.cfg
54 * tun_setaddr6: Fix log typo
55 * cosmetic: Reorder tun_addaddr to get rid of decl of tun_setaddr4
56 * ggsn.c: Print version of unhandled ip packet
57 * Remove unused empty src/Makefile.in
58 * tests: Split ipv6 specific tests into a new test group
59 * Add support for IPv4v6 End User Addresses
60 * contrib: jenkins.sh: Build libgtpnl as dep when building with gtp kernel support
61 * cosmetic: sgsnemu.c: Fix trailing whitespace
62 * ggsn.c: Improve logging info on link-local ipv6 addr not found
63 * tun.c: tun_addaddr: Fix segfault and wrong usage of tun_nlattr
64 * Set tun_addaddr ipv agnostic and add support for ipv6
65 * ggsn: Add 'ipv6 link-local' vty cmd
66 * ggsn_vty.c: Print ipv6 link-local cmd when writing config to file
67 * gtp.c: Fix trailing whitespace
68 * gtp.c: Determine GTP version from header
69 * gtp.c: Log unsupported GTP version number
70 * gtp/pdp: Fix trailing whitespace
71 * gtp/pdp: Remove unused APIs pdp_ntoeua pdp_euaton
72 * gtp.c: gtp_gpdu_ind: Convert ifelse to switch statement
73 * gtp.c: gtp_gpdu_ind: Early return to avoid use of uninitialized var
74 * gtp/gtp.c: Remove unused function char2ul_t
75 * gtp/gtp.c: Mark non exported functions as static
76 * gtp/gtp.c: Use uint8_t for version param in static functions
77 * ggsn: encaps_tun: Avoid forwarding packet if EUA is unassigned, fix crash
78 * ggsn: Validate packet src addr from MS
79 * ggsn: Parse PCO_IPCP
80 * ggsn: Parse PCO_IPCP for IPv4v6 pdp ctx
81 * ggsn: Print all addresses on successful pdp ctx creation
82 * ggsn.c: cb_tun_ind: Convert ifelse to switch statement
83 * ggsn.c: cb_tun_ind: log dst addr of packet without pdp ctx
84 * ggsn.c: cb_tun_ind: Don't drop packets targeting pdp ctx ll addr
85 * sgsnemu: Fix bad ptr during context deallocation
86 * sgsnemu: listen param is a host, not an interface
87 * use osmo_init_logging2
88
89 [ Max ]
90 * Log APN and tun names for packets
91 * Enable sanitize for CI tests
92 * Fix stow-enabled jenkins build failure
93 * Add GTP message names
94
95 [ Viktor Tsymbalyuk ]
96 * sgsnemu: sgsnemu stopped after recieving "Request accepted" from ggsn
97 * sgsnemu: created "pinghost" and "createif" modes for mutual exclusion
98 * sgsnemu: fix: no outgoing GTP-U in "createif" mode
99
100 [ Martin Hauke ]
101 * build: Remove AC_PROG_CXX, C++ is never used
102
103 [ Stefan Sperling ]
104 * remove the -f option from osmo-ggsn.service
105
106 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:05:27 +0200
107
Harald Welteff069172017-10-28 19:00:23 +0200108osmo-ggsn (1.1.0) unstable; urgency=medium
109
110 * libgtp: pdp.h: Addition of new tx_gpdu_seq struct member member
111 * libgtp: pdp.h: add LOGPDPX() helper to public API
112
113 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 19:00:23 +0200
114
Harald Welteb5b02c22017-09-06 12:19:49 +0200115osmo-ggsn (1.0.0) unstable; urgency=medium
Harald Welte632e8432017-09-05 18:12:14 +0200116
117 * Transition to OsmoGGSN
118
Harald Welteb5b02c22017-09-06 12:19:49 +0200119 -- Harald Welte <laforge@gnumonks.org> Wed, 06 Sep 2017 12:19:48 +0200
Harald Welte632e8432017-09-05 18:12:14 +0200120
Maxbdc504e2017-08-28 12:15:03 +0200121openggsn (0.94.0) UNRELEASED; urgency=medium
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200122
Harald Welte367baa32017-08-13 09:41:33 +0200123 [ Holger Hans Peter Freyther ]
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200124 * Bump version to ease upgrading from Debian SID.
Holger Hans Peter Freyther68d244d2017-01-24 17:21:05 +0100125 * Bump libgtp SO version after ABI change.
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200126
Harald Welte367baa32017-08-13 09:41:33 +0200127 [ Harald Welte ]
128 * various documentation / README updates
129 * improve error logging and propagation
130 * endian-safe definition of IP header
131 * IPv6 user plane support
132
133 -- Harald Welte <laforge@gnumonks.org> Sun, 13 Aug 2017 09:34:20 +0200
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200134
Holger Hans Peter Freyther89dcb6142015-11-30 14:06:09 +0100135openggsn (0.92) precise; urgency=medium
136
137 * Release 0.92
138
139 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Mon, 30 Nov 2015 14:05:59 +0100
140
141openggsn (0.91+git34) precise; urgency=medium
Holger Hans Peter Freyther0b705bb2014-09-23 16:38:47 +0200142
143 * Non-maintainer upload.
144
145 -- Holger Hans Peter Freyther <holger@freyther.de> Tue, 23 Sep 2014 16:38:32 +0200
146
147openggsn (0.91+git33) precise; urgency=low
Eric Butlerab9ff092012-08-24 21:16:01 -0700148
149 * Fix init script.
150
151 -- Eric Butler <eric@codebutler.com> Fri, 24 Aug 2012 21:15:32 -0700
152
Eric Butler235a0952012-08-14 18:08:41 -0700153openggsn (0.91+git33) precise; urgency=low
154
155 * Update package for Ubuntu Precise.
156
157 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 16:48:59 -0700
158
Harald Welteb5022552011-05-10 17:32:02 +0200159openggsn (0.91-2) unstable; urgency=low
160
161 * Switch to source/format (git)
162
163 -- Harald Welte <laforge@gnumonks.org> Tue, 10 May 2011 17:31:37 +0200
164
Harald Weltee9168092010-08-24 15:23:33 +0200165openggsn (0.91-1) unstable; urgency=low
166
167 * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
168
169 -- Harald Welte <laforge@gnumonks.org> Tue, 24 Aug 2010 11:23:40 +0200