blob: f65aaa8be41f988248052b52c43b2632de8fbd74 [file] [log] [blame]
Pau Espin Pedrolb1f641b2021-02-23 13:34:39 +01001osmo-ggsn (1.7.0) unstable; urgency=medium
2
3 [ Vadim Yanitskiy ]
4 * debian/control: change maintainer to the Osmocom team / mailing list
5
6 [ Pau Espin Pedrol ]
7 * configure.ac: Fix trailing whitespace
8 * doc: Update VTY reference xml file
9 * Support setting rt-prio and cpu-affinity mask through VTY
10 * contrib/jenkins: Enable parallel make in make distcheck
11 * ggsn: generate coredump and exit upon SIGABRT received
12 * tests: Explicitly drop category from log
13 * tests: Replace deprecated API log_set_print_filename
14
15 [ Keith ]
16 * Fix vty PDP lookups by IMSI
17 * Prevent Crash in show pdp-context from vty
18 * Minor: remove code duplication
19 * Use imsi_str2gtp() in sgsnemu
20 * sgsnemu: relax check on length of IMSI cmdline arg.
21 * GTP: Replace recently introduced imsi_str2gtp()
22
23 [ Harald Welte ]
24 * Use OSMO_FD_* instead of deprecated BSC_FD_*
25 * gtp-kernel: Remove duplicate #include section
26 * gtp-kernel: don't #include libmnl headers
27
28 [ Oliver Smith ]
29 * contrib/jenkins: don't build osmo-gsm-manuals
30 * configure.ac: set -std=gnu11
31 * apn_start: avoid segfault if missing tun-device
32 * .gitignore: ignore debian/libgtp*
33 * deb/rpm: build with --enable-gtp-linux
34
35 -- Pau Espin Pedrol <pespin@espeweb.net> Tue, 23 Feb 2021 13:34:39 +0100
36
Harald Welte21546072020-08-13 12:26:20 +020037osmo-ggsn (1.6.0) unstable; urgency=medium
38
39 [ Pau Espin Pedrol ]
40 * cosmetic: Fix comment typo
41 * netns: Improve error checking
42 * sgsnemu: cmdline: Drop unused function cmdline_parser_params_create()
43 * sgsnemu: Pass array of in64_addr to in46a_from_eua()
44 * sgsnemu: Rename sgsnemu's libgtp cb_conf
45 * sgsnemu: Set its default loglevel category to INFO
46 * Move icmpv6 and checksum files from ggsn/ dir to lib/
47 * netdev_addaddr6: Use prefixlen arg
48 * sgsnemu: Avoid adding extra autogenerated local link ipv6 addr to tun iface
49 * sgsnemu: Fix ping transmitted statistics output
50 * cosmetic: icmpv6.c: fix typo in comment
51 * icmpv6.c: Mark internal function as static
52 * sgsnemu: Get rid of duplicated options.destaddr
53 * sgsnemu: Get rid of duplicated options.net
54 * sgsnemu: tun_addaddr: Don't set local addr as dstaddr
55 * icmpv6.c: Move code generating ipv6 hdr to its own function
56 * Rename netdev_*route to end in route4
57 * sgsnemu: Fix build/run against linux < 4.11 (no sysctl addr_gen_mode support)
58 * sgsnemu: Handle IPv6 SLAAC in tun iface manually
59 * sgsnemu: Implement ping on IPv6 APNs
60 * sgsnemu: Fix assumption ipv6 Interface-Identifier of public addr == announced Prefix
61 * gtp: queue_test: Fix printf gcc warn under ARM
62
63 [ Andreas Schultz ]
64 * add Linux network namespace support for TUN device
65
66 [ Vadim Yanitskiy ]
67 * lib/netns: fix open_ns(): return fd from open()
68
69 [ Philipp Maier ]
70 * doc: do not use random ip address for dns in default conf
71 * doc: use 127.0.0.2 instead of 127.0.0.6 as bind ip.
72 * debug: use LOGL_NOTICE instead of LOGL_DEBUG
73
74 [ Eric ]
75 * configure.ac: fix libtool issue with clang and sanitizer
76
77 [ Harald Welte ]
78 * lib/netns.c: Add comments to the code, including doxygen API docs
79 * lib/netns: OSMO_ASSERT() if user doesn't call init_netns()
80 * lib/netns: Fix up error paths
81 * example config: use RFC1918 addresses for GGSN pools
82
83 [ Dmitri Kalashnik ]
84 * sgsnemu: use real tun device name after the device is up.
85
86 [ Oliver Smith ]
87 * osmo-ggsn.spec.in: remove
88 * contrib: import RPM spec
89 * contrib: integrate RPM spec
90 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
91
92 -- Harald Welte <laforge@osmocom.org> Thu, 13 Aug 2020 12:26:20 +0200
93
Pau Espin Pedrole71e0f22020-01-02 20:39:39 +010094osmo-ggsn (1.5.0) unstable; urgency=medium
95
96 [ Jan Engelhardt ]
97 * build: switch AC_CANONICAL_TARGET for AC_CANONICAL_HOST
98
99 [ Pau Espin Pedrol ]
100 * libgtp: Remove packets in tx queue belonging pdp being freed
101 * libgtp: announce pdp ctx deletion upon CreatePdpCtx being rejected
102 * Introduce in46a_is_v{4,6}() helpers
103 * ggsn: Move PCO handling code into its own file
104 * in46_addr: Improve in46a_ntop documentation
105 * ggsn_vty.c: Fix wrong use of in46a_from_eua, print IPv6 euas
106 * ggsn: Split application lifecycle related code into ggsn_main.c
107 * Move pdp_get_peer_ipv() to lib/util.*
108 * gtp-kernel.c: Fix wrong use of in46a_from_eua, print IPv6 euas
109 * Introduce LOGTUN log helper
110 * ggsn_vty.c: Avoid printing duplicates for pdp context with v4v6 EUAs
111 * pdp: constify param in pdp_count_secondary()
112 * ggsn_vty.c: Improve output of VTY show pdp-context
113 * doc: Update vty reference xml file
114 * libgtp: Introduce cb_recovery3
115 * ggsn: Implement echo req/resp and recovery
116 * cosmetic: fix formatting in if line
117 * gtp: Log msg retransmits and timeouts
118 * cosmetic: gtp: Drop commented out code calling pdp_freepdp()
119 * cosmetic: gtp: Improve documentation of gtp_delete_context_req2()
120 * ggsn: rx DeletePdpReq confirmation: Improve documentation and use gtp_freepdp()
121 * gtp: Manage queue timers internally
122 * ggsn, sgsnemu: Drop use of no-op deprecated gtp_retrans* APIs
123
124 [ Vadim Yanitskiy ]
125 * gtp_update_pdp_ind(): fix NULL-pointer dereference
126 * gtp_error_ind_conf(): fix: guard against an unknown GTP version
127 * gtp/gtp.c: cosmetic: use get_tid() where we need TID
128 * manuals/configuration.adoc: fix Network Address without prefix length
129 * manuals/configuration.adoc: fix IPv4 address mismatch in <<ggsn_no_root>>
130 * contrib/systemd: add systemd-networkd examples from manuals
131
132 [ Harald Welte ]
133 * sgsnemu: Fix null-pointer format string argument
134 * manual: Fix copy+paste error
135
136 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 02 Jan 2020 20:39:39 +0100
137
Pau Espin Pedrol67aebc92019-08-07 21:28:30 +0200138osmo-ggsn (1.4.0) unstable; urgency=medium
139
140 [ Max ]
141 * Don't return error on normal shutdown
142
143 [ Harald Welte ]
144 * process_pco() const-ify 'apn' argument
145 * ggsn: Remove magic numbers from pco_contains_proto()
146 * ggsn: const-ify input / read-only arguments of PCO related functions
147 * ggsn: Remove magic numbers from ipcp_contains_option()
148 * ggsn: Fix build_ipcp_pco() in presence of invalid IPCP content
149 * ggsn.c: Refactor PCO processing during PDP activation
150 * ggsn: Add minimalistic PAP support
151 * ggsn: More logging from PCO handling (e.g. in case of malconfiguration)
152 * sgsnemu: Fix format string argument count
153
154 [ Vadim Yanitskiy ]
155 * osmo-ggsn: fix VTY command for getting PDP contexts by APN
156 * osmo-ggsn: add VTY command to show PDP context by IPv4
157 * osmo-ggsn: check result of osmo_apn_to_str()
158 * osmo-ggsn: print requested / actual APN in PDP info
159 * osmo-ggsn: properly show subscriber's MSISDN in the VTY
160
161 [ Pau Espin Pedrol ]
162 * ggsn: Drop unused param force in apn_stop()
163 * gtp: Document spec reasoning drop of Rx DeleteCtxReq
164 * ggsn: Start gtp retrans timer during startup
165 * gtp: Take queue_resp into account to schedule retrans timer
166 * gtp: Fix typo dublicate->duplicate
167 * pdp: Introduce new API pdp_count_secondary
168 * gtp_create_pdp_ind: simplify code by reordering and compacting parsing
169 * gtp: Refactor code to use gtp_freepdp(_teardown) APIs
170 * cosmetic: gtp: Document free pdp ctx in non-teardown scenario
171 * gtp: Re-arrange free pdp ctx code in non-teardown scenario
172 * pdp: Drop unused code for haship
173 * cosmetic: gtp.h: Remove trailing whitespaces
174 * ggsn: Fix undefined behaviour shifting beyond sign bit
175 * gtp: Introduce new pdp APIs (and deprecate old ones) to support multiple GSN
176 * gtp: Make use of new libgtp APIs with multi-gsn support
177 * ggsn_vty_reference.xml: Update from last code changes
178 * ggsn: vty: Require ggsn param in <show pdp-context> cmd
179 * sgsnemu: Replace use of deprecated libgtp API pdp_newpdp with new one
180 * cosmetic: gtp: queue: remove trailing whitespace
181 * gtp: Add missing headers
182 * gtp: queue.c: Document queue APIs
183 * gtp: queue: Add unit test queue_test
184 * ggsn: Avoid unaligned mem access reading PCO proto id
185 * ggsn: Use structures instead of raw arrays when parsing ipcp_hdr
186 * configure.ac: Replace obosolete macro AC_CANONICAL_SYSTEM
187 * configure.ac: Use brackets in AC_INIT params
188 * configure.ac: Use prefered AC_CONFIG_HEADERS over AM_CONFIG_HEADER
189 * configure.ac: some versions of linux/if.h require including sys/socket.h
190 * sgsnemu: Fix unaligned pointer access during ip/icmp checksum
191 * Remove undefined param passed to {logging,osmo_stats}_vty_add_cmds
192 * Require libosmocore 1.1.0
193
194 [ Oliver Smith ]
195 * debian: create -doc subpackage with pdf manuals
196 * ggsn: Use gtp_delete_context_req2() everywhere
197 * contrib/jenkins.sh: run "make maintainer-clean"
198
199 [ Daniel Willmann ]
200 * manuals: Add script to regenerate vty/counter documentation
201
202 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 21:28:30 +0200
203
Harald Weltef5a268a2019-01-20 21:34:23 +0100204osmo-ggsn (1.3.0) unstable; urgency=medium
205
206 [ Pau Espin Pedrol ]
207 * ggsn: ctrl iface: listen on IP configured by VTY
208 * gtp: Log type name of unexpected signalling message
209 * gtp: Allow recv DEL CTX REQ in sgsn and DEL CTX RSP in ggsn
210 * gtp: Log ignore CTX DEL REQ due to no teardown and only 1 ctx active
211 * gtp: Add new API to avoid freeing pdp contexts during DEL CTX REQ
212 * gtp: Add new replacement cb_recovery2 for cb_recovery
213 * Install systemd services with autotools
214 * Install sample cfg file to /etc/osmocom
215
216 [ Stefan Sperling ]
217 * fix unaligned access in build_ipcp_pco()
218 * fix support for multiple IPCP in PDP protocol configuration options
219 * check ioctl() call return value in tun_new()
220 * fix allocation of ippool's hash table
221 * replace bogus memcpy() call in ippool_newip()
222 * initialize local variable addr in ippool_new()
223 * fix format string error in ippool_printaddr()
224 * fix a format string directives in queue_seqset()
225 * properly store IPv6 addresses in struct tun_t
226
227 [ Harald Welte ]
228 * debian/rules: Don't overwrite .tarball-version
229 * osmo-ggsn.cfg: Ensure well-formed config file example
230 * sgsnemu: Fix printing of tun device name
231 * ippool.c: Use "%td" format string for ptrdiff_t
232 * initial version of OsmoGGSN user manual
233 * OsmoGGSN: Add VTY reference manual
234 * GGSN: Document how 'ip tuntap' is used for non-root; call netdev 'apn0'
235 * vty-ref: Update URI of docbook 5.0 schema
236
237 [ Alexander Couzens ]
238 * libgtp: implement gtp_clear_queues to clear req/resp queue
239
240 [ Neels Hofmeyr ]
241 * Importing history from osmo-gsm-manuals.git
242 * refactor Makefile build rules, don't use the FORCE
243 * GGSN: don't say 'NITB'
244 * OsmoGGSN: more info on non-root operation / tun creation
245 * OsmoGGSN: multiple instances: mention GTP port
246 * OsmoGGSN: add Routing section for IP forward and masquerading
247 * OsmoGGSN: typo: priveleges
248 * OsmoGGSN VTY ref: prep: convert newlines to unix
249 * OsmoGGSN vty: update VTY reference
250 * OsmoGGSN: fix VTY additions' node IDs
251 * OsmoGGSN: update vty reference
252 * ggsn: update vty reference
253
254 [ Max ]
255 * Expand OsmoGGSN manual
256
257 [ Oliver Smith ]
258 * build manuals moved here from osmo-gsm-manuals.git
259 * Fix DISTCHECK_CONFIGURE_FLAGS override
260 * contrib/jenkins.sh: build and publish manuals
261 * contrib: fix makedistcheck with disabled systemd
262
263 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 21:34:22 +0100
264
Pau Espin Pedrolb673d1c2018-05-31 12:44:54 +0200265osmo-ggsn (1.2.2) unstable; urgency=medium
266
267 [ Vadim Yanitskiy ]
268 * ggsn_vty.c: fix: use CONFIG_NODE as parent by default
269
270 [ Philipp Maier ]
271 * ggsn: fix misinterpreted length field in ipcp_contains_option()
272 * ggsn: make sure ipcp_option_hdr and and ipcp_hdr are packed
273
274 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 31 May 2018 12:44:54 +0200
275
Pau Espin Pedrolac076252018-05-04 12:19:58 +0200276osmo-ggsn (1.2.1) unstable; urgency=medium
277
278 * debian/rules: Fix debian packaging after 1.2.0 release
279
280 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 04 May 2018 12:19:58 +0200
281
Pau Espin Pedrola06b2d32018-05-03 16:05:28 +0200282osmo-ggsn (1.2.0) unstable; urgency=medium
283
284 [ Neels Hofmeyr ]
285 * fix compiler warnings: return 0 in main(), in 3 tests
286 * add --enable-sanitize config option
287 * sanitize build: ensure uint16/32 alignment in gtpie_test and in46a_test
288 * configure: add --enable-werror
289 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
290
291 [ Harald Welte ]
292 * sgsnemu: Don't leak FILE handle in proc_read()
293 * sgsnemu: Fix format string in printing tun-device name
294 * sgsnemu: Make sure buffer has space for terminating-NUL
295 * sgsnemu: Free strings in error path
296 * gtp: Fix buffer overflow in imsi_gtp2str()
297 * gtp: Explicit OSMO_ASSERT to ensure pdp variable is set
298 * tun: Don't copy 16byte IPv6 address to 'struct in_addr'
299 * ippool: Correctly compute size of static pool
300 * remove unused argument to alloc_ippool_blacklist()
301 * factor out netdev_ip_local_get() from tun_ip_local_get()
302 * Properly NULL-out blacklist in alloc_ippool_blacklist()
303 * gtp_kernel: Change gtp_kernel_init() function signature
304 * gtp-kernel: Re-add support for kernel GTP-U acceleration
305 * gtp-kernel: Get rid of hard-coded kernel GTP device name
306 * gtp-kernel: shut down kernel GTP device in apn_down()
307 * gtp-kernel: Align logging for APN start in kernel-gtp case with that of TUN
308 * gtp-kernel: Avoid global state variable
309 * gtp-kernel: Make sure repeated calls to gtp_kernel_init() are safe
310 * gtp-kernel: proper cleanup in error path
311 * gtp-kernel: Get rid of SYS_ERR where not applicable
312 * gtp-kernel: Add function name to pdp_debug() function calls
313 * gtp-kernel: Add device nime in pdp_debug() log statements
314 * contrib/jenkins.sh: Allow jenkins job to specify if kernel GTP is used
315 * ggsn.c: Fix byte order of IPCP IPv4 DNS servers
316 * ggsn: Ignore PCO with length 0, don't abort processing
317 * README.md: Remove misleading sentence on sgsnemu
318 * Add talloc context introspection via VTY
319 * fix segfault in case of kernel gtp-u
320 * lib/tun.c: Generalize tun_sifflags() to netdev_sifflags
321 * lib/tun.c: generalize tun_*route() to netdev_*route()
322 * lib/tun.c: Generalize tun_{set,add}addr*() functions
323 * lib/tun: split generic network device related stuff to lib/netdev
324 * lib/netdev.c: Cosmetic changes (coding style / cleanups)
325 * ggsn: Don't explicitly use tun_setaddr() API anymore
326 * sgsnemu: Convert from tun_setaddr() to tun_addaddr()
327 * lib/tun: Remove tun_setaddr() API, as everyone is using tun_addaddr() now
328 * Move kernel GTP support from ggsn/ to lib/
329 * ggsn: don't use gtp_kernel_tunnel_{add,del}() for userspace tun
330
331 [ Pau Espin Pedrol ]
332 * ggsn_vty: Stop using deprecated API vty_install_default
333 * contrib/jenkins.sh: Enable Werror in C(PP)FLAGS
334 * examples: Add secondary ipv6 google DNS to osmo-ggsn.cfg
335 * tun_setaddr6: Fix log typo
336 * cosmetic: Reorder tun_addaddr to get rid of decl of tun_setaddr4
337 * ggsn.c: Print version of unhandled ip packet
338 * Remove unused empty src/Makefile.in
339 * tests: Split ipv6 specific tests into a new test group
340 * Add support for IPv4v6 End User Addresses
341 * contrib: jenkins.sh: Build libgtpnl as dep when building with gtp kernel support
342 * cosmetic: sgsnemu.c: Fix trailing whitespace
343 * ggsn.c: Improve logging info on link-local ipv6 addr not found
344 * tun.c: tun_addaddr: Fix segfault and wrong usage of tun_nlattr
345 * Set tun_addaddr ipv agnostic and add support for ipv6
346 * ggsn: Add 'ipv6 link-local' vty cmd
347 * ggsn_vty.c: Print ipv6 link-local cmd when writing config to file
348 * gtp.c: Fix trailing whitespace
349 * gtp.c: Determine GTP version from header
350 * gtp.c: Log unsupported GTP version number
351 * gtp/pdp: Fix trailing whitespace
352 * gtp/pdp: Remove unused APIs pdp_ntoeua pdp_euaton
353 * gtp.c: gtp_gpdu_ind: Convert ifelse to switch statement
354 * gtp.c: gtp_gpdu_ind: Early return to avoid use of uninitialized var
355 * gtp/gtp.c: Remove unused function char2ul_t
356 * gtp/gtp.c: Mark non exported functions as static
357 * gtp/gtp.c: Use uint8_t for version param in static functions
358 * ggsn: encaps_tun: Avoid forwarding packet if EUA is unassigned, fix crash
359 * ggsn: Validate packet src addr from MS
360 * ggsn: Parse PCO_IPCP
361 * ggsn: Parse PCO_IPCP for IPv4v6 pdp ctx
362 * ggsn: Print all addresses on successful pdp ctx creation
363 * ggsn.c: cb_tun_ind: Convert ifelse to switch statement
364 * ggsn.c: cb_tun_ind: log dst addr of packet without pdp ctx
365 * ggsn.c: cb_tun_ind: Don't drop packets targeting pdp ctx ll addr
366 * sgsnemu: Fix bad ptr during context deallocation
367 * sgsnemu: listen param is a host, not an interface
368 * use osmo_init_logging2
369
370 [ Max ]
371 * Log APN and tun names for packets
372 * Enable sanitize for CI tests
373 * Fix stow-enabled jenkins build failure
374 * Add GTP message names
375
376 [ Viktor Tsymbalyuk ]
377 * sgsnemu: sgsnemu stopped after recieving "Request accepted" from ggsn
378 * sgsnemu: created "pinghost" and "createif" modes for mutual exclusion
379 * sgsnemu: fix: no outgoing GTP-U in "createif" mode
380
381 [ Martin Hauke ]
382 * build: Remove AC_PROG_CXX, C++ is never used
383
384 [ Stefan Sperling ]
385 * remove the -f option from osmo-ggsn.service
386
387 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:05:27 +0200
388
Harald Welteff069172017-10-28 19:00:23 +0200389osmo-ggsn (1.1.0) unstable; urgency=medium
390
391 * libgtp: pdp.h: Addition of new tx_gpdu_seq struct member member
392 * libgtp: pdp.h: add LOGPDPX() helper to public API
393
394 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 19:00:23 +0200
395
Harald Welteb5b02c22017-09-06 12:19:49 +0200396osmo-ggsn (1.0.0) unstable; urgency=medium
Harald Welte632e8432017-09-05 18:12:14 +0200397
398 * Transition to OsmoGGSN
399
Harald Welteb5b02c22017-09-06 12:19:49 +0200400 -- Harald Welte <laforge@gnumonks.org> Wed, 06 Sep 2017 12:19:48 +0200
Harald Welte632e8432017-09-05 18:12:14 +0200401
Maxbdc504e2017-08-28 12:15:03 +0200402openggsn (0.94.0) UNRELEASED; urgency=medium
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200403
Harald Welte367baa32017-08-13 09:41:33 +0200404 [ Holger Hans Peter Freyther ]
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200405 * Bump version to ease upgrading from Debian SID.
Holger Hans Peter Freyther68d244d2017-01-24 17:21:05 +0100406 * Bump libgtp SO version after ABI change.
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200407
Harald Welte367baa32017-08-13 09:41:33 +0200408 [ Harald Welte ]
409 * various documentation / README updates
410 * improve error logging and propagation
411 * endian-safe definition of IP header
412 * IPv6 user plane support
413
414 -- Harald Welte <laforge@gnumonks.org> Sun, 13 Aug 2017 09:34:20 +0200
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200415
Holger Hans Peter Freyther89dcb6142015-11-30 14:06:09 +0100416openggsn (0.92) precise; urgency=medium
417
418 * Release 0.92
419
420 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Mon, 30 Nov 2015 14:05:59 +0100
421
422openggsn (0.91+git34) precise; urgency=medium
Holger Hans Peter Freyther0b705bb2014-09-23 16:38:47 +0200423
424 * Non-maintainer upload.
425
426 -- Holger Hans Peter Freyther <holger@freyther.de> Tue, 23 Sep 2014 16:38:32 +0200
427
428openggsn (0.91+git33) precise; urgency=low
Eric Butlerab9ff092012-08-24 21:16:01 -0700429
430 * Fix init script.
431
432 -- Eric Butler <eric@codebutler.com> Fri, 24 Aug 2012 21:15:32 -0700
433
Eric Butler235a0952012-08-14 18:08:41 -0700434openggsn (0.91+git33) precise; urgency=low
435
436 * Update package for Ubuntu Precise.
437
438 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 16:48:59 -0700
439
Harald Welteb5022552011-05-10 17:32:02 +0200440openggsn (0.91-2) unstable; urgency=low
441
442 * Switch to source/format (git)
443
444 -- Harald Welte <laforge@gnumonks.org> Tue, 10 May 2011 17:31:37 +0200
445
Harald Weltee9168092010-08-24 15:23:33 +0200446openggsn (0.91-1) unstable; urgency=low
447
448 * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
449
450 -- Harald Welte <laforge@gnumonks.org> Tue, 24 Aug 2010 11:23:40 +0200