blob: 921875a23d88bf3b24b4e8f17b6db9f985c14db6 [file] [log] [blame]
Pau Espin Pedrol67aebc92019-08-07 21:28:30 +02001osmo-ggsn (1.4.0) unstable; urgency=medium
2
3 [ Max ]
4 * Don't return error on normal shutdown
5
6 [ Harald Welte ]
7 * process_pco() const-ify 'apn' argument
8 * ggsn: Remove magic numbers from pco_contains_proto()
9 * ggsn: const-ify input / read-only arguments of PCO related functions
10 * ggsn: Remove magic numbers from ipcp_contains_option()
11 * ggsn: Fix build_ipcp_pco() in presence of invalid IPCP content
12 * ggsn.c: Refactor PCO processing during PDP activation
13 * ggsn: Add minimalistic PAP support
14 * ggsn: More logging from PCO handling (e.g. in case of malconfiguration)
15 * sgsnemu: Fix format string argument count
16
17 [ Vadim Yanitskiy ]
18 * osmo-ggsn: fix VTY command for getting PDP contexts by APN
19 * osmo-ggsn: add VTY command to show PDP context by IPv4
20 * osmo-ggsn: check result of osmo_apn_to_str()
21 * osmo-ggsn: print requested / actual APN in PDP info
22 * osmo-ggsn: properly show subscriber's MSISDN in the VTY
23
24 [ Pau Espin Pedrol ]
25 * ggsn: Drop unused param force in apn_stop()
26 * gtp: Document spec reasoning drop of Rx DeleteCtxReq
27 * ggsn: Start gtp retrans timer during startup
28 * gtp: Take queue_resp into account to schedule retrans timer
29 * gtp: Fix typo dublicate->duplicate
30 * pdp: Introduce new API pdp_count_secondary
31 * gtp_create_pdp_ind: simplify code by reordering and compacting parsing
32 * gtp: Refactor code to use gtp_freepdp(_teardown) APIs
33 * cosmetic: gtp: Document free pdp ctx in non-teardown scenario
34 * gtp: Re-arrange free pdp ctx code in non-teardown scenario
35 * pdp: Drop unused code for haship
36 * cosmetic: gtp.h: Remove trailing whitespaces
37 * ggsn: Fix undefined behaviour shifting beyond sign bit
38 * gtp: Introduce new pdp APIs (and deprecate old ones) to support multiple GSN
39 * gtp: Make use of new libgtp APIs with multi-gsn support
40 * ggsn_vty_reference.xml: Update from last code changes
41 * ggsn: vty: Require ggsn param in <show pdp-context> cmd
42 * sgsnemu: Replace use of deprecated libgtp API pdp_newpdp with new one
43 * cosmetic: gtp: queue: remove trailing whitespace
44 * gtp: Add missing headers
45 * gtp: queue.c: Document queue APIs
46 * gtp: queue: Add unit test queue_test
47 * ggsn: Avoid unaligned mem access reading PCO proto id
48 * ggsn: Use structures instead of raw arrays when parsing ipcp_hdr
49 * configure.ac: Replace obosolete macro AC_CANONICAL_SYSTEM
50 * configure.ac: Use brackets in AC_INIT params
51 * configure.ac: Use prefered AC_CONFIG_HEADERS over AM_CONFIG_HEADER
52 * configure.ac: some versions of linux/if.h require including sys/socket.h
53 * sgsnemu: Fix unaligned pointer access during ip/icmp checksum
54 * Remove undefined param passed to {logging,osmo_stats}_vty_add_cmds
55 * Require libosmocore 1.1.0
56
57 [ Oliver Smith ]
58 * debian: create -doc subpackage with pdf manuals
59 * ggsn: Use gtp_delete_context_req2() everywhere
60 * contrib/jenkins.sh: run "make maintainer-clean"
61
62 [ Daniel Willmann ]
63 * manuals: Add script to regenerate vty/counter documentation
64
65 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 21:28:30 +0200
66
Harald Weltef5a268a2019-01-20 21:34:23 +010067osmo-ggsn (1.3.0) unstable; urgency=medium
68
69 [ Pau Espin Pedrol ]
70 * ggsn: ctrl iface: listen on IP configured by VTY
71 * gtp: Log type name of unexpected signalling message
72 * gtp: Allow recv DEL CTX REQ in sgsn and DEL CTX RSP in ggsn
73 * gtp: Log ignore CTX DEL REQ due to no teardown and only 1 ctx active
74 * gtp: Add new API to avoid freeing pdp contexts during DEL CTX REQ
75 * gtp: Add new replacement cb_recovery2 for cb_recovery
76 * Install systemd services with autotools
77 * Install sample cfg file to /etc/osmocom
78
79 [ Stefan Sperling ]
80 * fix unaligned access in build_ipcp_pco()
81 * fix support for multiple IPCP in PDP protocol configuration options
82 * check ioctl() call return value in tun_new()
83 * fix allocation of ippool's hash table
84 * replace bogus memcpy() call in ippool_newip()
85 * initialize local variable addr in ippool_new()
86 * fix format string error in ippool_printaddr()
87 * fix a format string directives in queue_seqset()
88 * properly store IPv6 addresses in struct tun_t
89
90 [ Harald Welte ]
91 * debian/rules: Don't overwrite .tarball-version
92 * osmo-ggsn.cfg: Ensure well-formed config file example
93 * sgsnemu: Fix printing of tun device name
94 * ippool.c: Use "%td" format string for ptrdiff_t
95 * initial version of OsmoGGSN user manual
96 * OsmoGGSN: Add VTY reference manual
97 * GGSN: Document how 'ip tuntap' is used for non-root; call netdev 'apn0'
98 * vty-ref: Update URI of docbook 5.0 schema
99
100 [ Alexander Couzens ]
101 * libgtp: implement gtp_clear_queues to clear req/resp queue
102
103 [ Neels Hofmeyr ]
104 * Importing history from osmo-gsm-manuals.git
105 * refactor Makefile build rules, don't use the FORCE
106 * GGSN: don't say 'NITB'
107 * OsmoGGSN: more info on non-root operation / tun creation
108 * OsmoGGSN: multiple instances: mention GTP port
109 * OsmoGGSN: add Routing section for IP forward and masquerading
110 * OsmoGGSN: typo: priveleges
111 * OsmoGGSN VTY ref: prep: convert newlines to unix
112 * OsmoGGSN vty: update VTY reference
113 * OsmoGGSN: fix VTY additions' node IDs
114 * OsmoGGSN: update vty reference
115 * ggsn: update vty reference
116
117 [ Max ]
118 * Expand OsmoGGSN manual
119
120 [ Oliver Smith ]
121 * build manuals moved here from osmo-gsm-manuals.git
122 * Fix DISTCHECK_CONFIGURE_FLAGS override
123 * contrib/jenkins.sh: build and publish manuals
124 * contrib: fix makedistcheck with disabled systemd
125
126 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 21:34:22 +0100
127
Pau Espin Pedrolb673d1c2018-05-31 12:44:54 +0200128osmo-ggsn (1.2.2) unstable; urgency=medium
129
130 [ Vadim Yanitskiy ]
131 * ggsn_vty.c: fix: use CONFIG_NODE as parent by default
132
133 [ Philipp Maier ]
134 * ggsn: fix misinterpreted length field in ipcp_contains_option()
135 * ggsn: make sure ipcp_option_hdr and and ipcp_hdr are packed
136
137 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 31 May 2018 12:44:54 +0200
138
Pau Espin Pedrolac076252018-05-04 12:19:58 +0200139osmo-ggsn (1.2.1) unstable; urgency=medium
140
141 * debian/rules: Fix debian packaging after 1.2.0 release
142
143 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 04 May 2018 12:19:58 +0200
144
Pau Espin Pedrola06b2d32018-05-03 16:05:28 +0200145osmo-ggsn (1.2.0) unstable; urgency=medium
146
147 [ Neels Hofmeyr ]
148 * fix compiler warnings: return 0 in main(), in 3 tests
149 * add --enable-sanitize config option
150 * sanitize build: ensure uint16/32 alignment in gtpie_test and in46a_test
151 * configure: add --enable-werror
152 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
153
154 [ Harald Welte ]
155 * sgsnemu: Don't leak FILE handle in proc_read()
156 * sgsnemu: Fix format string in printing tun-device name
157 * sgsnemu: Make sure buffer has space for terminating-NUL
158 * sgsnemu: Free strings in error path
159 * gtp: Fix buffer overflow in imsi_gtp2str()
160 * gtp: Explicit OSMO_ASSERT to ensure pdp variable is set
161 * tun: Don't copy 16byte IPv6 address to 'struct in_addr'
162 * ippool: Correctly compute size of static pool
163 * remove unused argument to alloc_ippool_blacklist()
164 * factor out netdev_ip_local_get() from tun_ip_local_get()
165 * Properly NULL-out blacklist in alloc_ippool_blacklist()
166 * gtp_kernel: Change gtp_kernel_init() function signature
167 * gtp-kernel: Re-add support for kernel GTP-U acceleration
168 * gtp-kernel: Get rid of hard-coded kernel GTP device name
169 * gtp-kernel: shut down kernel GTP device in apn_down()
170 * gtp-kernel: Align logging for APN start in kernel-gtp case with that of TUN
171 * gtp-kernel: Avoid global state variable
172 * gtp-kernel: Make sure repeated calls to gtp_kernel_init() are safe
173 * gtp-kernel: proper cleanup in error path
174 * gtp-kernel: Get rid of SYS_ERR where not applicable
175 * gtp-kernel: Add function name to pdp_debug() function calls
176 * gtp-kernel: Add device nime in pdp_debug() log statements
177 * contrib/jenkins.sh: Allow jenkins job to specify if kernel GTP is used
178 * ggsn.c: Fix byte order of IPCP IPv4 DNS servers
179 * ggsn: Ignore PCO with length 0, don't abort processing
180 * README.md: Remove misleading sentence on sgsnemu
181 * Add talloc context introspection via VTY
182 * fix segfault in case of kernel gtp-u
183 * lib/tun.c: Generalize tun_sifflags() to netdev_sifflags
184 * lib/tun.c: generalize tun_*route() to netdev_*route()
185 * lib/tun.c: Generalize tun_{set,add}addr*() functions
186 * lib/tun: split generic network device related stuff to lib/netdev
187 * lib/netdev.c: Cosmetic changes (coding style / cleanups)
188 * ggsn: Don't explicitly use tun_setaddr() API anymore
189 * sgsnemu: Convert from tun_setaddr() to tun_addaddr()
190 * lib/tun: Remove tun_setaddr() API, as everyone is using tun_addaddr() now
191 * Move kernel GTP support from ggsn/ to lib/
192 * ggsn: don't use gtp_kernel_tunnel_{add,del}() for userspace tun
193
194 [ Pau Espin Pedrol ]
195 * ggsn_vty: Stop using deprecated API vty_install_default
196 * contrib/jenkins.sh: Enable Werror in C(PP)FLAGS
197 * examples: Add secondary ipv6 google DNS to osmo-ggsn.cfg
198 * tun_setaddr6: Fix log typo
199 * cosmetic: Reorder tun_addaddr to get rid of decl of tun_setaddr4
200 * ggsn.c: Print version of unhandled ip packet
201 * Remove unused empty src/Makefile.in
202 * tests: Split ipv6 specific tests into a new test group
203 * Add support for IPv4v6 End User Addresses
204 * contrib: jenkins.sh: Build libgtpnl as dep when building with gtp kernel support
205 * cosmetic: sgsnemu.c: Fix trailing whitespace
206 * ggsn.c: Improve logging info on link-local ipv6 addr not found
207 * tun.c: tun_addaddr: Fix segfault and wrong usage of tun_nlattr
208 * Set tun_addaddr ipv agnostic and add support for ipv6
209 * ggsn: Add 'ipv6 link-local' vty cmd
210 * ggsn_vty.c: Print ipv6 link-local cmd when writing config to file
211 * gtp.c: Fix trailing whitespace
212 * gtp.c: Determine GTP version from header
213 * gtp.c: Log unsupported GTP version number
214 * gtp/pdp: Fix trailing whitespace
215 * gtp/pdp: Remove unused APIs pdp_ntoeua pdp_euaton
216 * gtp.c: gtp_gpdu_ind: Convert ifelse to switch statement
217 * gtp.c: gtp_gpdu_ind: Early return to avoid use of uninitialized var
218 * gtp/gtp.c: Remove unused function char2ul_t
219 * gtp/gtp.c: Mark non exported functions as static
220 * gtp/gtp.c: Use uint8_t for version param in static functions
221 * ggsn: encaps_tun: Avoid forwarding packet if EUA is unassigned, fix crash
222 * ggsn: Validate packet src addr from MS
223 * ggsn: Parse PCO_IPCP
224 * ggsn: Parse PCO_IPCP for IPv4v6 pdp ctx
225 * ggsn: Print all addresses on successful pdp ctx creation
226 * ggsn.c: cb_tun_ind: Convert ifelse to switch statement
227 * ggsn.c: cb_tun_ind: log dst addr of packet without pdp ctx
228 * ggsn.c: cb_tun_ind: Don't drop packets targeting pdp ctx ll addr
229 * sgsnemu: Fix bad ptr during context deallocation
230 * sgsnemu: listen param is a host, not an interface
231 * use osmo_init_logging2
232
233 [ Max ]
234 * Log APN and tun names for packets
235 * Enable sanitize for CI tests
236 * Fix stow-enabled jenkins build failure
237 * Add GTP message names
238
239 [ Viktor Tsymbalyuk ]
240 * sgsnemu: sgsnemu stopped after recieving "Request accepted" from ggsn
241 * sgsnemu: created "pinghost" and "createif" modes for mutual exclusion
242 * sgsnemu: fix: no outgoing GTP-U in "createif" mode
243
244 [ Martin Hauke ]
245 * build: Remove AC_PROG_CXX, C++ is never used
246
247 [ Stefan Sperling ]
248 * remove the -f option from osmo-ggsn.service
249
250 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:05:27 +0200
251
Harald Welteff069172017-10-28 19:00:23 +0200252osmo-ggsn (1.1.0) unstable; urgency=medium
253
254 * libgtp: pdp.h: Addition of new tx_gpdu_seq struct member member
255 * libgtp: pdp.h: add LOGPDPX() helper to public API
256
257 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 19:00:23 +0200
258
Harald Welteb5b02c22017-09-06 12:19:49 +0200259osmo-ggsn (1.0.0) unstable; urgency=medium
Harald Welte632e8432017-09-05 18:12:14 +0200260
261 * Transition to OsmoGGSN
262
Harald Welteb5b02c22017-09-06 12:19:49 +0200263 -- Harald Welte <laforge@gnumonks.org> Wed, 06 Sep 2017 12:19:48 +0200
Harald Welte632e8432017-09-05 18:12:14 +0200264
Maxbdc504e2017-08-28 12:15:03 +0200265openggsn (0.94.0) UNRELEASED; urgency=medium
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200266
Harald Welte367baa32017-08-13 09:41:33 +0200267 [ Holger Hans Peter Freyther ]
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200268 * Bump version to ease upgrading from Debian SID.
Holger Hans Peter Freyther68d244d2017-01-24 17:21:05 +0100269 * Bump libgtp SO version after ABI change.
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200270
Harald Welte367baa32017-08-13 09:41:33 +0200271 [ Harald Welte ]
272 * various documentation / README updates
273 * improve error logging and propagation
274 * endian-safe definition of IP header
275 * IPv6 user plane support
276
277 -- Harald Welte <laforge@gnumonks.org> Sun, 13 Aug 2017 09:34:20 +0200
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200278
Holger Hans Peter Freyther89dcb6142015-11-30 14:06:09 +0100279openggsn (0.92) precise; urgency=medium
280
281 * Release 0.92
282
283 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Mon, 30 Nov 2015 14:05:59 +0100
284
285openggsn (0.91+git34) precise; urgency=medium
Holger Hans Peter Freyther0b705bb2014-09-23 16:38:47 +0200286
287 * Non-maintainer upload.
288
289 -- Holger Hans Peter Freyther <holger@freyther.de> Tue, 23 Sep 2014 16:38:32 +0200
290
291openggsn (0.91+git33) precise; urgency=low
Eric Butlerab9ff092012-08-24 21:16:01 -0700292
293 * Fix init script.
294
295 -- Eric Butler <eric@codebutler.com> Fri, 24 Aug 2012 21:15:32 -0700
296
Eric Butler235a0952012-08-14 18:08:41 -0700297openggsn (0.91+git33) precise; urgency=low
298
299 * Update package for Ubuntu Precise.
300
301 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 16:48:59 -0700
302
Harald Welteb5022552011-05-10 17:32:02 +0200303openggsn (0.91-2) unstable; urgency=low
304
305 * Switch to source/format (git)
306
307 -- Harald Welte <laforge@gnumonks.org> Tue, 10 May 2011 17:31:37 +0200
308
Harald Weltee9168092010-08-24 15:23:33 +0200309openggsn (0.91-1) unstable; urgency=low
310
311 * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
312
313 -- Harald Welte <laforge@gnumonks.org> Tue, 24 Aug 2010 11:23:40 +0200