blob: 21bd8ffd17560078dbc969443b162f4b1f0151e7 [file] [log] [blame]
Harald Weltef5a268a2019-01-20 21:34:23 +01001osmo-ggsn (1.3.0) unstable; urgency=medium
2
3 [ Pau Espin Pedrol ]
4 * ggsn: ctrl iface: listen on IP configured by VTY
5 * gtp: Log type name of unexpected signalling message
6 * gtp: Allow recv DEL CTX REQ in sgsn and DEL CTX RSP in ggsn
7 * gtp: Log ignore CTX DEL REQ due to no teardown and only 1 ctx active
8 * gtp: Add new API to avoid freeing pdp contexts during DEL CTX REQ
9 * gtp: Add new replacement cb_recovery2 for cb_recovery
10 * Install systemd services with autotools
11 * Install sample cfg file to /etc/osmocom
12
13 [ Stefan Sperling ]
14 * fix unaligned access in build_ipcp_pco()
15 * fix support for multiple IPCP in PDP protocol configuration options
16 * check ioctl() call return value in tun_new()
17 * fix allocation of ippool's hash table
18 * replace bogus memcpy() call in ippool_newip()
19 * initialize local variable addr in ippool_new()
20 * fix format string error in ippool_printaddr()
21 * fix a format string directives in queue_seqset()
22 * properly store IPv6 addresses in struct tun_t
23
24 [ Harald Welte ]
25 * debian/rules: Don't overwrite .tarball-version
26 * osmo-ggsn.cfg: Ensure well-formed config file example
27 * sgsnemu: Fix printing of tun device name
28 * ippool.c: Use "%td" format string for ptrdiff_t
29 * initial version of OsmoGGSN user manual
30 * OsmoGGSN: Add VTY reference manual
31 * GGSN: Document how 'ip tuntap' is used for non-root; call netdev 'apn0'
32 * vty-ref: Update URI of docbook 5.0 schema
33
34 [ Alexander Couzens ]
35 * libgtp: implement gtp_clear_queues to clear req/resp queue
36
37 [ Neels Hofmeyr ]
38 * Importing history from osmo-gsm-manuals.git
39 * refactor Makefile build rules, don't use the FORCE
40 * GGSN: don't say 'NITB'
41 * OsmoGGSN: more info on non-root operation / tun creation
42 * OsmoGGSN: multiple instances: mention GTP port
43 * OsmoGGSN: add Routing section for IP forward and masquerading
44 * OsmoGGSN: typo: priveleges
45 * OsmoGGSN VTY ref: prep: convert newlines to unix
46 * OsmoGGSN vty: update VTY reference
47 * OsmoGGSN: fix VTY additions' node IDs
48 * OsmoGGSN: update vty reference
49 * ggsn: update vty reference
50
51 [ Max ]
52 * Expand OsmoGGSN manual
53
54 [ Oliver Smith ]
55 * build manuals moved here from osmo-gsm-manuals.git
56 * Fix DISTCHECK_CONFIGURE_FLAGS override
57 * contrib/jenkins.sh: build and publish manuals
58 * contrib: fix makedistcheck with disabled systemd
59
60 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 21:34:22 +0100
61
Pau Espin Pedrolb673d1c2018-05-31 12:44:54 +020062osmo-ggsn (1.2.2) unstable; urgency=medium
63
64 [ Vadim Yanitskiy ]
65 * ggsn_vty.c: fix: use CONFIG_NODE as parent by default
66
67 [ Philipp Maier ]
68 * ggsn: fix misinterpreted length field in ipcp_contains_option()
69 * ggsn: make sure ipcp_option_hdr and and ipcp_hdr are packed
70
71 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 31 May 2018 12:44:54 +0200
72
Pau Espin Pedrolac076252018-05-04 12:19:58 +020073osmo-ggsn (1.2.1) unstable; urgency=medium
74
75 * debian/rules: Fix debian packaging after 1.2.0 release
76
77 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 04 May 2018 12:19:58 +0200
78
Pau Espin Pedrola06b2d32018-05-03 16:05:28 +020079osmo-ggsn (1.2.0) unstable; urgency=medium
80
81 [ Neels Hofmeyr ]
82 * fix compiler warnings: return 0 in main(), in 3 tests
83 * add --enable-sanitize config option
84 * sanitize build: ensure uint16/32 alignment in gtpie_test and in46a_test
85 * configure: add --enable-werror
86 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
87
88 [ Harald Welte ]
89 * sgsnemu: Don't leak FILE handle in proc_read()
90 * sgsnemu: Fix format string in printing tun-device name
91 * sgsnemu: Make sure buffer has space for terminating-NUL
92 * sgsnemu: Free strings in error path
93 * gtp: Fix buffer overflow in imsi_gtp2str()
94 * gtp: Explicit OSMO_ASSERT to ensure pdp variable is set
95 * tun: Don't copy 16byte IPv6 address to 'struct in_addr'
96 * ippool: Correctly compute size of static pool
97 * remove unused argument to alloc_ippool_blacklist()
98 * factor out netdev_ip_local_get() from tun_ip_local_get()
99 * Properly NULL-out blacklist in alloc_ippool_blacklist()
100 * gtp_kernel: Change gtp_kernel_init() function signature
101 * gtp-kernel: Re-add support for kernel GTP-U acceleration
102 * gtp-kernel: Get rid of hard-coded kernel GTP device name
103 * gtp-kernel: shut down kernel GTP device in apn_down()
104 * gtp-kernel: Align logging for APN start in kernel-gtp case with that of TUN
105 * gtp-kernel: Avoid global state variable
106 * gtp-kernel: Make sure repeated calls to gtp_kernel_init() are safe
107 * gtp-kernel: proper cleanup in error path
108 * gtp-kernel: Get rid of SYS_ERR where not applicable
109 * gtp-kernel: Add function name to pdp_debug() function calls
110 * gtp-kernel: Add device nime in pdp_debug() log statements
111 * contrib/jenkins.sh: Allow jenkins job to specify if kernel GTP is used
112 * ggsn.c: Fix byte order of IPCP IPv4 DNS servers
113 * ggsn: Ignore PCO with length 0, don't abort processing
114 * README.md: Remove misleading sentence on sgsnemu
115 * Add talloc context introspection via VTY
116 * fix segfault in case of kernel gtp-u
117 * lib/tun.c: Generalize tun_sifflags() to netdev_sifflags
118 * lib/tun.c: generalize tun_*route() to netdev_*route()
119 * lib/tun.c: Generalize tun_{set,add}addr*() functions
120 * lib/tun: split generic network device related stuff to lib/netdev
121 * lib/netdev.c: Cosmetic changes (coding style / cleanups)
122 * ggsn: Don't explicitly use tun_setaddr() API anymore
123 * sgsnemu: Convert from tun_setaddr() to tun_addaddr()
124 * lib/tun: Remove tun_setaddr() API, as everyone is using tun_addaddr() now
125 * Move kernel GTP support from ggsn/ to lib/
126 * ggsn: don't use gtp_kernel_tunnel_{add,del}() for userspace tun
127
128 [ Pau Espin Pedrol ]
129 * ggsn_vty: Stop using deprecated API vty_install_default
130 * contrib/jenkins.sh: Enable Werror in C(PP)FLAGS
131 * examples: Add secondary ipv6 google DNS to osmo-ggsn.cfg
132 * tun_setaddr6: Fix log typo
133 * cosmetic: Reorder tun_addaddr to get rid of decl of tun_setaddr4
134 * ggsn.c: Print version of unhandled ip packet
135 * Remove unused empty src/Makefile.in
136 * tests: Split ipv6 specific tests into a new test group
137 * Add support for IPv4v6 End User Addresses
138 * contrib: jenkins.sh: Build libgtpnl as dep when building with gtp kernel support
139 * cosmetic: sgsnemu.c: Fix trailing whitespace
140 * ggsn.c: Improve logging info on link-local ipv6 addr not found
141 * tun.c: tun_addaddr: Fix segfault and wrong usage of tun_nlattr
142 * Set tun_addaddr ipv agnostic and add support for ipv6
143 * ggsn: Add 'ipv6 link-local' vty cmd
144 * ggsn_vty.c: Print ipv6 link-local cmd when writing config to file
145 * gtp.c: Fix trailing whitespace
146 * gtp.c: Determine GTP version from header
147 * gtp.c: Log unsupported GTP version number
148 * gtp/pdp: Fix trailing whitespace
149 * gtp/pdp: Remove unused APIs pdp_ntoeua pdp_euaton
150 * gtp.c: gtp_gpdu_ind: Convert ifelse to switch statement
151 * gtp.c: gtp_gpdu_ind: Early return to avoid use of uninitialized var
152 * gtp/gtp.c: Remove unused function char2ul_t
153 * gtp/gtp.c: Mark non exported functions as static
154 * gtp/gtp.c: Use uint8_t for version param in static functions
155 * ggsn: encaps_tun: Avoid forwarding packet if EUA is unassigned, fix crash
156 * ggsn: Validate packet src addr from MS
157 * ggsn: Parse PCO_IPCP
158 * ggsn: Parse PCO_IPCP for IPv4v6 pdp ctx
159 * ggsn: Print all addresses on successful pdp ctx creation
160 * ggsn.c: cb_tun_ind: Convert ifelse to switch statement
161 * ggsn.c: cb_tun_ind: log dst addr of packet without pdp ctx
162 * ggsn.c: cb_tun_ind: Don't drop packets targeting pdp ctx ll addr
163 * sgsnemu: Fix bad ptr during context deallocation
164 * sgsnemu: listen param is a host, not an interface
165 * use osmo_init_logging2
166
167 [ Max ]
168 * Log APN and tun names for packets
169 * Enable sanitize for CI tests
170 * Fix stow-enabled jenkins build failure
171 * Add GTP message names
172
173 [ Viktor Tsymbalyuk ]
174 * sgsnemu: sgsnemu stopped after recieving "Request accepted" from ggsn
175 * sgsnemu: created "pinghost" and "createif" modes for mutual exclusion
176 * sgsnemu: fix: no outgoing GTP-U in "createif" mode
177
178 [ Martin Hauke ]
179 * build: Remove AC_PROG_CXX, C++ is never used
180
181 [ Stefan Sperling ]
182 * remove the -f option from osmo-ggsn.service
183
184 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:05:27 +0200
185
Harald Welteff069172017-10-28 19:00:23 +0200186osmo-ggsn (1.1.0) unstable; urgency=medium
187
188 * libgtp: pdp.h: Addition of new tx_gpdu_seq struct member member
189 * libgtp: pdp.h: add LOGPDPX() helper to public API
190
191 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 19:00:23 +0200
192
Harald Welteb5b02c22017-09-06 12:19:49 +0200193osmo-ggsn (1.0.0) unstable; urgency=medium
Harald Welte632e8432017-09-05 18:12:14 +0200194
195 * Transition to OsmoGGSN
196
Harald Welteb5b02c22017-09-06 12:19:49 +0200197 -- Harald Welte <laforge@gnumonks.org> Wed, 06 Sep 2017 12:19:48 +0200
Harald Welte632e8432017-09-05 18:12:14 +0200198
Maxbdc504e2017-08-28 12:15:03 +0200199openggsn (0.94.0) UNRELEASED; urgency=medium
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200200
Harald Welte367baa32017-08-13 09:41:33 +0200201 [ Holger Hans Peter Freyther ]
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200202 * Bump version to ease upgrading from Debian SID.
Holger Hans Peter Freyther68d244d2017-01-24 17:21:05 +0100203 * Bump libgtp SO version after ABI change.
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200204
Harald Welte367baa32017-08-13 09:41:33 +0200205 [ Harald Welte ]
206 * various documentation / README updates
207 * improve error logging and propagation
208 * endian-safe definition of IP header
209 * IPv6 user plane support
210
211 -- Harald Welte <laforge@gnumonks.org> Sun, 13 Aug 2017 09:34:20 +0200
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200212
Holger Hans Peter Freyther89dcb6142015-11-30 14:06:09 +0100213openggsn (0.92) precise; urgency=medium
214
215 * Release 0.92
216
217 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Mon, 30 Nov 2015 14:05:59 +0100
218
219openggsn (0.91+git34) precise; urgency=medium
Holger Hans Peter Freyther0b705bb2014-09-23 16:38:47 +0200220
221 * Non-maintainer upload.
222
223 -- Holger Hans Peter Freyther <holger@freyther.de> Tue, 23 Sep 2014 16:38:32 +0200
224
225openggsn (0.91+git33) precise; urgency=low
Eric Butlerab9ff092012-08-24 21:16:01 -0700226
227 * Fix init script.
228
229 -- Eric Butler <eric@codebutler.com> Fri, 24 Aug 2012 21:15:32 -0700
230
Eric Butler235a0952012-08-14 18:08:41 -0700231openggsn (0.91+git33) precise; urgency=low
232
233 * Update package for Ubuntu Precise.
234
235 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 16:48:59 -0700
236
Harald Welteb5022552011-05-10 17:32:02 +0200237openggsn (0.91-2) unstable; urgency=low
238
239 * Switch to source/format (git)
240
241 -- Harald Welte <laforge@gnumonks.org> Tue, 10 May 2011 17:31:37 +0200
242
Harald Weltee9168092010-08-24 15:23:33 +0200243openggsn (0.91-1) unstable; urgency=low
244
245 * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
246
247 -- Harald Welte <laforge@gnumonks.org> Tue, 24 Aug 2010 11:23:40 +0200