blob: 3db4bd718745880d61a115741e65c01b5cb4a4a6 [file] [log] [blame]
Pau Espin Pedrolb673d1c2018-05-31 12:44:54 +02001osmo-ggsn (1.2.2) unstable; urgency=medium
2
3 [ Vadim Yanitskiy ]
4 * ggsn_vty.c: fix: use CONFIG_NODE as parent by default
5
6 [ Philipp Maier ]
7 * ggsn: fix misinterpreted length field in ipcp_contains_option()
8 * ggsn: make sure ipcp_option_hdr and and ipcp_hdr are packed
9
10 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 31 May 2018 12:44:54 +0200
11
Pau Espin Pedrolac076252018-05-04 12:19:58 +020012osmo-ggsn (1.2.1) unstable; urgency=medium
13
14 * debian/rules: Fix debian packaging after 1.2.0 release
15
16 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 04 May 2018 12:19:58 +0200
17
Pau Espin Pedrola06b2d32018-05-03 16:05:28 +020018osmo-ggsn (1.2.0) unstable; urgency=medium
19
20 [ Neels Hofmeyr ]
21 * fix compiler warnings: return 0 in main(), in 3 tests
22 * add --enable-sanitize config option
23 * sanitize build: ensure uint16/32 alignment in gtpie_test and in46a_test
24 * configure: add --enable-werror
25 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
26
27 [ Harald Welte ]
28 * sgsnemu: Don't leak FILE handle in proc_read()
29 * sgsnemu: Fix format string in printing tun-device name
30 * sgsnemu: Make sure buffer has space for terminating-NUL
31 * sgsnemu: Free strings in error path
32 * gtp: Fix buffer overflow in imsi_gtp2str()
33 * gtp: Explicit OSMO_ASSERT to ensure pdp variable is set
34 * tun: Don't copy 16byte IPv6 address to 'struct in_addr'
35 * ippool: Correctly compute size of static pool
36 * remove unused argument to alloc_ippool_blacklist()
37 * factor out netdev_ip_local_get() from tun_ip_local_get()
38 * Properly NULL-out blacklist in alloc_ippool_blacklist()
39 * gtp_kernel: Change gtp_kernel_init() function signature
40 * gtp-kernel: Re-add support for kernel GTP-U acceleration
41 * gtp-kernel: Get rid of hard-coded kernel GTP device name
42 * gtp-kernel: shut down kernel GTP device in apn_down()
43 * gtp-kernel: Align logging for APN start in kernel-gtp case with that of TUN
44 * gtp-kernel: Avoid global state variable
45 * gtp-kernel: Make sure repeated calls to gtp_kernel_init() are safe
46 * gtp-kernel: proper cleanup in error path
47 * gtp-kernel: Get rid of SYS_ERR where not applicable
48 * gtp-kernel: Add function name to pdp_debug() function calls
49 * gtp-kernel: Add device nime in pdp_debug() log statements
50 * contrib/jenkins.sh: Allow jenkins job to specify if kernel GTP is used
51 * ggsn.c: Fix byte order of IPCP IPv4 DNS servers
52 * ggsn: Ignore PCO with length 0, don't abort processing
53 * README.md: Remove misleading sentence on sgsnemu
54 * Add talloc context introspection via VTY
55 * fix segfault in case of kernel gtp-u
56 * lib/tun.c: Generalize tun_sifflags() to netdev_sifflags
57 * lib/tun.c: generalize tun_*route() to netdev_*route()
58 * lib/tun.c: Generalize tun_{set,add}addr*() functions
59 * lib/tun: split generic network device related stuff to lib/netdev
60 * lib/netdev.c: Cosmetic changes (coding style / cleanups)
61 * ggsn: Don't explicitly use tun_setaddr() API anymore
62 * sgsnemu: Convert from tun_setaddr() to tun_addaddr()
63 * lib/tun: Remove tun_setaddr() API, as everyone is using tun_addaddr() now
64 * Move kernel GTP support from ggsn/ to lib/
65 * ggsn: don't use gtp_kernel_tunnel_{add,del}() for userspace tun
66
67 [ Pau Espin Pedrol ]
68 * ggsn_vty: Stop using deprecated API vty_install_default
69 * contrib/jenkins.sh: Enable Werror in C(PP)FLAGS
70 * examples: Add secondary ipv6 google DNS to osmo-ggsn.cfg
71 * tun_setaddr6: Fix log typo
72 * cosmetic: Reorder tun_addaddr to get rid of decl of tun_setaddr4
73 * ggsn.c: Print version of unhandled ip packet
74 * Remove unused empty src/Makefile.in
75 * tests: Split ipv6 specific tests into a new test group
76 * Add support for IPv4v6 End User Addresses
77 * contrib: jenkins.sh: Build libgtpnl as dep when building with gtp kernel support
78 * cosmetic: sgsnemu.c: Fix trailing whitespace
79 * ggsn.c: Improve logging info on link-local ipv6 addr not found
80 * tun.c: tun_addaddr: Fix segfault and wrong usage of tun_nlattr
81 * Set tun_addaddr ipv agnostic and add support for ipv6
82 * ggsn: Add 'ipv6 link-local' vty cmd
83 * ggsn_vty.c: Print ipv6 link-local cmd when writing config to file
84 * gtp.c: Fix trailing whitespace
85 * gtp.c: Determine GTP version from header
86 * gtp.c: Log unsupported GTP version number
87 * gtp/pdp: Fix trailing whitespace
88 * gtp/pdp: Remove unused APIs pdp_ntoeua pdp_euaton
89 * gtp.c: gtp_gpdu_ind: Convert ifelse to switch statement
90 * gtp.c: gtp_gpdu_ind: Early return to avoid use of uninitialized var
91 * gtp/gtp.c: Remove unused function char2ul_t
92 * gtp/gtp.c: Mark non exported functions as static
93 * gtp/gtp.c: Use uint8_t for version param in static functions
94 * ggsn: encaps_tun: Avoid forwarding packet if EUA is unassigned, fix crash
95 * ggsn: Validate packet src addr from MS
96 * ggsn: Parse PCO_IPCP
97 * ggsn: Parse PCO_IPCP for IPv4v6 pdp ctx
98 * ggsn: Print all addresses on successful pdp ctx creation
99 * ggsn.c: cb_tun_ind: Convert ifelse to switch statement
100 * ggsn.c: cb_tun_ind: log dst addr of packet without pdp ctx
101 * ggsn.c: cb_tun_ind: Don't drop packets targeting pdp ctx ll addr
102 * sgsnemu: Fix bad ptr during context deallocation
103 * sgsnemu: listen param is a host, not an interface
104 * use osmo_init_logging2
105
106 [ Max ]
107 * Log APN and tun names for packets
108 * Enable sanitize for CI tests
109 * Fix stow-enabled jenkins build failure
110 * Add GTP message names
111
112 [ Viktor Tsymbalyuk ]
113 * sgsnemu: sgsnemu stopped after recieving "Request accepted" from ggsn
114 * sgsnemu: created "pinghost" and "createif" modes for mutual exclusion
115 * sgsnemu: fix: no outgoing GTP-U in "createif" mode
116
117 [ Martin Hauke ]
118 * build: Remove AC_PROG_CXX, C++ is never used
119
120 [ Stefan Sperling ]
121 * remove the -f option from osmo-ggsn.service
122
123 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:05:27 +0200
124
Harald Welteff069172017-10-28 19:00:23 +0200125osmo-ggsn (1.1.0) unstable; urgency=medium
126
127 * libgtp: pdp.h: Addition of new tx_gpdu_seq struct member member
128 * libgtp: pdp.h: add LOGPDPX() helper to public API
129
130 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 19:00:23 +0200
131
Harald Welteb5b02c22017-09-06 12:19:49 +0200132osmo-ggsn (1.0.0) unstable; urgency=medium
Harald Welte632e8432017-09-05 18:12:14 +0200133
134 * Transition to OsmoGGSN
135
Harald Welteb5b02c22017-09-06 12:19:49 +0200136 -- Harald Welte <laforge@gnumonks.org> Wed, 06 Sep 2017 12:19:48 +0200
Harald Welte632e8432017-09-05 18:12:14 +0200137
Maxbdc504e2017-08-28 12:15:03 +0200138openggsn (0.94.0) UNRELEASED; urgency=medium
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200139
Harald Welte367baa32017-08-13 09:41:33 +0200140 [ Holger Hans Peter Freyther ]
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200141 * Bump version to ease upgrading from Debian SID.
Holger Hans Peter Freyther68d244d2017-01-24 17:21:05 +0100142 * Bump libgtp SO version after ABI change.
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200143
Harald Welte367baa32017-08-13 09:41:33 +0200144 [ Harald Welte ]
145 * various documentation / README updates
146 * improve error logging and propagation
147 * endian-safe definition of IP header
148 * IPv6 user plane support
149
150 -- Harald Welte <laforge@gnumonks.org> Sun, 13 Aug 2017 09:34:20 +0200
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200151
Holger Hans Peter Freyther89dcb6142015-11-30 14:06:09 +0100152openggsn (0.92) precise; urgency=medium
153
154 * Release 0.92
155
156 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Mon, 30 Nov 2015 14:05:59 +0100
157
158openggsn (0.91+git34) precise; urgency=medium
Holger Hans Peter Freyther0b705bb2014-09-23 16:38:47 +0200159
160 * Non-maintainer upload.
161
162 -- Holger Hans Peter Freyther <holger@freyther.de> Tue, 23 Sep 2014 16:38:32 +0200
163
164openggsn (0.91+git33) precise; urgency=low
Eric Butlerab9ff092012-08-24 21:16:01 -0700165
166 * Fix init script.
167
168 -- Eric Butler <eric@codebutler.com> Fri, 24 Aug 2012 21:15:32 -0700
169
Eric Butler235a0952012-08-14 18:08:41 -0700170openggsn (0.91+git33) precise; urgency=low
171
172 * Update package for Ubuntu Precise.
173
174 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 16:48:59 -0700
175
Harald Welteb5022552011-05-10 17:32:02 +0200176openggsn (0.91-2) unstable; urgency=low
177
178 * Switch to source/format (git)
179
180 -- Harald Welte <laforge@gnumonks.org> Tue, 10 May 2011 17:31:37 +0200
181
Harald Weltee9168092010-08-24 15:23:33 +0200182openggsn (0.91-1) unstable; urgency=low
183
184 * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
185
186 -- Harald Welte <laforge@gnumonks.org> Tue, 24 Aug 2010 11:23:40 +0200