blob: 6b8a3138db00c4c4e6d03b36b0d0fef22a6befc2 [file] [log] [blame]
Pau Espin Pedrole71e0f22020-01-02 20:39:39 +01001osmo-ggsn (1.5.0) unstable; urgency=medium
2
3 [ Jan Engelhardt ]
4 * build: switch AC_CANONICAL_TARGET for AC_CANONICAL_HOST
5
6 [ Pau Espin Pedrol ]
7 * libgtp: Remove packets in tx queue belonging pdp being freed
8 * libgtp: announce pdp ctx deletion upon CreatePdpCtx being rejected
9 * Introduce in46a_is_v{4,6}() helpers
10 * ggsn: Move PCO handling code into its own file
11 * in46_addr: Improve in46a_ntop documentation
12 * ggsn_vty.c: Fix wrong use of in46a_from_eua, print IPv6 euas
13 * ggsn: Split application lifecycle related code into ggsn_main.c
14 * Move pdp_get_peer_ipv() to lib/util.*
15 * gtp-kernel.c: Fix wrong use of in46a_from_eua, print IPv6 euas
16 * Introduce LOGTUN log helper
17 * ggsn_vty.c: Avoid printing duplicates for pdp context with v4v6 EUAs
18 * pdp: constify param in pdp_count_secondary()
19 * ggsn_vty.c: Improve output of VTY show pdp-context
20 * doc: Update vty reference xml file
21 * libgtp: Introduce cb_recovery3
22 * ggsn: Implement echo req/resp and recovery
23 * cosmetic: fix formatting in if line
24 * gtp: Log msg retransmits and timeouts
25 * cosmetic: gtp: Drop commented out code calling pdp_freepdp()
26 * cosmetic: gtp: Improve documentation of gtp_delete_context_req2()
27 * ggsn: rx DeletePdpReq confirmation: Improve documentation and use gtp_freepdp()
28 * gtp: Manage queue timers internally
29 * ggsn, sgsnemu: Drop use of no-op deprecated gtp_retrans* APIs
30
31 [ Vadim Yanitskiy ]
32 * gtp_update_pdp_ind(): fix NULL-pointer dereference
33 * gtp_error_ind_conf(): fix: guard against an unknown GTP version
34 * gtp/gtp.c: cosmetic: use get_tid() where we need TID
35 * manuals/configuration.adoc: fix Network Address without prefix length
36 * manuals/configuration.adoc: fix IPv4 address mismatch in <<ggsn_no_root>>
37 * contrib/systemd: add systemd-networkd examples from manuals
38
39 [ Harald Welte ]
40 * sgsnemu: Fix null-pointer format string argument
41 * manual: Fix copy+paste error
42
43 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 02 Jan 2020 20:39:39 +0100
44
Pau Espin Pedrol67aebc92019-08-07 21:28:30 +020045osmo-ggsn (1.4.0) unstable; urgency=medium
46
47 [ Max ]
48 * Don't return error on normal shutdown
49
50 [ Harald Welte ]
51 * process_pco() const-ify 'apn' argument
52 * ggsn: Remove magic numbers from pco_contains_proto()
53 * ggsn: const-ify input / read-only arguments of PCO related functions
54 * ggsn: Remove magic numbers from ipcp_contains_option()
55 * ggsn: Fix build_ipcp_pco() in presence of invalid IPCP content
56 * ggsn.c: Refactor PCO processing during PDP activation
57 * ggsn: Add minimalistic PAP support
58 * ggsn: More logging from PCO handling (e.g. in case of malconfiguration)
59 * sgsnemu: Fix format string argument count
60
61 [ Vadim Yanitskiy ]
62 * osmo-ggsn: fix VTY command for getting PDP contexts by APN
63 * osmo-ggsn: add VTY command to show PDP context by IPv4
64 * osmo-ggsn: check result of osmo_apn_to_str()
65 * osmo-ggsn: print requested / actual APN in PDP info
66 * osmo-ggsn: properly show subscriber's MSISDN in the VTY
67
68 [ Pau Espin Pedrol ]
69 * ggsn: Drop unused param force in apn_stop()
70 * gtp: Document spec reasoning drop of Rx DeleteCtxReq
71 * ggsn: Start gtp retrans timer during startup
72 * gtp: Take queue_resp into account to schedule retrans timer
73 * gtp: Fix typo dublicate->duplicate
74 * pdp: Introduce new API pdp_count_secondary
75 * gtp_create_pdp_ind: simplify code by reordering and compacting parsing
76 * gtp: Refactor code to use gtp_freepdp(_teardown) APIs
77 * cosmetic: gtp: Document free pdp ctx in non-teardown scenario
78 * gtp: Re-arrange free pdp ctx code in non-teardown scenario
79 * pdp: Drop unused code for haship
80 * cosmetic: gtp.h: Remove trailing whitespaces
81 * ggsn: Fix undefined behaviour shifting beyond sign bit
82 * gtp: Introduce new pdp APIs (and deprecate old ones) to support multiple GSN
83 * gtp: Make use of new libgtp APIs with multi-gsn support
84 * ggsn_vty_reference.xml: Update from last code changes
85 * ggsn: vty: Require ggsn param in <show pdp-context> cmd
86 * sgsnemu: Replace use of deprecated libgtp API pdp_newpdp with new one
87 * cosmetic: gtp: queue: remove trailing whitespace
88 * gtp: Add missing headers
89 * gtp: queue.c: Document queue APIs
90 * gtp: queue: Add unit test queue_test
91 * ggsn: Avoid unaligned mem access reading PCO proto id
92 * ggsn: Use structures instead of raw arrays when parsing ipcp_hdr
93 * configure.ac: Replace obosolete macro AC_CANONICAL_SYSTEM
94 * configure.ac: Use brackets in AC_INIT params
95 * configure.ac: Use prefered AC_CONFIG_HEADERS over AM_CONFIG_HEADER
96 * configure.ac: some versions of linux/if.h require including sys/socket.h
97 * sgsnemu: Fix unaligned pointer access during ip/icmp checksum
98 * Remove undefined param passed to {logging,osmo_stats}_vty_add_cmds
99 * Require libosmocore 1.1.0
100
101 [ Oliver Smith ]
102 * debian: create -doc subpackage with pdf manuals
103 * ggsn: Use gtp_delete_context_req2() everywhere
104 * contrib/jenkins.sh: run "make maintainer-clean"
105
106 [ Daniel Willmann ]
107 * manuals: Add script to regenerate vty/counter documentation
108
109 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 21:28:30 +0200
110
Harald Weltef5a268a2019-01-20 21:34:23 +0100111osmo-ggsn (1.3.0) unstable; urgency=medium
112
113 [ Pau Espin Pedrol ]
114 * ggsn: ctrl iface: listen on IP configured by VTY
115 * gtp: Log type name of unexpected signalling message
116 * gtp: Allow recv DEL CTX REQ in sgsn and DEL CTX RSP in ggsn
117 * gtp: Log ignore CTX DEL REQ due to no teardown and only 1 ctx active
118 * gtp: Add new API to avoid freeing pdp contexts during DEL CTX REQ
119 * gtp: Add new replacement cb_recovery2 for cb_recovery
120 * Install systemd services with autotools
121 * Install sample cfg file to /etc/osmocom
122
123 [ Stefan Sperling ]
124 * fix unaligned access in build_ipcp_pco()
125 * fix support for multiple IPCP in PDP protocol configuration options
126 * check ioctl() call return value in tun_new()
127 * fix allocation of ippool's hash table
128 * replace bogus memcpy() call in ippool_newip()
129 * initialize local variable addr in ippool_new()
130 * fix format string error in ippool_printaddr()
131 * fix a format string directives in queue_seqset()
132 * properly store IPv6 addresses in struct tun_t
133
134 [ Harald Welte ]
135 * debian/rules: Don't overwrite .tarball-version
136 * osmo-ggsn.cfg: Ensure well-formed config file example
137 * sgsnemu: Fix printing of tun device name
138 * ippool.c: Use "%td" format string for ptrdiff_t
139 * initial version of OsmoGGSN user manual
140 * OsmoGGSN: Add VTY reference manual
141 * GGSN: Document how 'ip tuntap' is used for non-root; call netdev 'apn0'
142 * vty-ref: Update URI of docbook 5.0 schema
143
144 [ Alexander Couzens ]
145 * libgtp: implement gtp_clear_queues to clear req/resp queue
146
147 [ Neels Hofmeyr ]
148 * Importing history from osmo-gsm-manuals.git
149 * refactor Makefile build rules, don't use the FORCE
150 * GGSN: don't say 'NITB'
151 * OsmoGGSN: more info on non-root operation / tun creation
152 * OsmoGGSN: multiple instances: mention GTP port
153 * OsmoGGSN: add Routing section for IP forward and masquerading
154 * OsmoGGSN: typo: priveleges
155 * OsmoGGSN VTY ref: prep: convert newlines to unix
156 * OsmoGGSN vty: update VTY reference
157 * OsmoGGSN: fix VTY additions' node IDs
158 * OsmoGGSN: update vty reference
159 * ggsn: update vty reference
160
161 [ Max ]
162 * Expand OsmoGGSN manual
163
164 [ Oliver Smith ]
165 * build manuals moved here from osmo-gsm-manuals.git
166 * Fix DISTCHECK_CONFIGURE_FLAGS override
167 * contrib/jenkins.sh: build and publish manuals
168 * contrib: fix makedistcheck with disabled systemd
169
170 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 21:34:22 +0100
171
Pau Espin Pedrolb673d1c2018-05-31 12:44:54 +0200172osmo-ggsn (1.2.2) unstable; urgency=medium
173
174 [ Vadim Yanitskiy ]
175 * ggsn_vty.c: fix: use CONFIG_NODE as parent by default
176
177 [ Philipp Maier ]
178 * ggsn: fix misinterpreted length field in ipcp_contains_option()
179 * ggsn: make sure ipcp_option_hdr and and ipcp_hdr are packed
180
181 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 31 May 2018 12:44:54 +0200
182
Pau Espin Pedrolac076252018-05-04 12:19:58 +0200183osmo-ggsn (1.2.1) unstable; urgency=medium
184
185 * debian/rules: Fix debian packaging after 1.2.0 release
186
187 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 04 May 2018 12:19:58 +0200
188
Pau Espin Pedrola06b2d32018-05-03 16:05:28 +0200189osmo-ggsn (1.2.0) unstable; urgency=medium
190
191 [ Neels Hofmeyr ]
192 * fix compiler warnings: return 0 in main(), in 3 tests
193 * add --enable-sanitize config option
194 * sanitize build: ensure uint16/32 alignment in gtpie_test and in46a_test
195 * configure: add --enable-werror
196 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
197
198 [ Harald Welte ]
199 * sgsnemu: Don't leak FILE handle in proc_read()
200 * sgsnemu: Fix format string in printing tun-device name
201 * sgsnemu: Make sure buffer has space for terminating-NUL
202 * sgsnemu: Free strings in error path
203 * gtp: Fix buffer overflow in imsi_gtp2str()
204 * gtp: Explicit OSMO_ASSERT to ensure pdp variable is set
205 * tun: Don't copy 16byte IPv6 address to 'struct in_addr'
206 * ippool: Correctly compute size of static pool
207 * remove unused argument to alloc_ippool_blacklist()
208 * factor out netdev_ip_local_get() from tun_ip_local_get()
209 * Properly NULL-out blacklist in alloc_ippool_blacklist()
210 * gtp_kernel: Change gtp_kernel_init() function signature
211 * gtp-kernel: Re-add support for kernel GTP-U acceleration
212 * gtp-kernel: Get rid of hard-coded kernel GTP device name
213 * gtp-kernel: shut down kernel GTP device in apn_down()
214 * gtp-kernel: Align logging for APN start in kernel-gtp case with that of TUN
215 * gtp-kernel: Avoid global state variable
216 * gtp-kernel: Make sure repeated calls to gtp_kernel_init() are safe
217 * gtp-kernel: proper cleanup in error path
218 * gtp-kernel: Get rid of SYS_ERR where not applicable
219 * gtp-kernel: Add function name to pdp_debug() function calls
220 * gtp-kernel: Add device nime in pdp_debug() log statements
221 * contrib/jenkins.sh: Allow jenkins job to specify if kernel GTP is used
222 * ggsn.c: Fix byte order of IPCP IPv4 DNS servers
223 * ggsn: Ignore PCO with length 0, don't abort processing
224 * README.md: Remove misleading sentence on sgsnemu
225 * Add talloc context introspection via VTY
226 * fix segfault in case of kernel gtp-u
227 * lib/tun.c: Generalize tun_sifflags() to netdev_sifflags
228 * lib/tun.c: generalize tun_*route() to netdev_*route()
229 * lib/tun.c: Generalize tun_{set,add}addr*() functions
230 * lib/tun: split generic network device related stuff to lib/netdev
231 * lib/netdev.c: Cosmetic changes (coding style / cleanups)
232 * ggsn: Don't explicitly use tun_setaddr() API anymore
233 * sgsnemu: Convert from tun_setaddr() to tun_addaddr()
234 * lib/tun: Remove tun_setaddr() API, as everyone is using tun_addaddr() now
235 * Move kernel GTP support from ggsn/ to lib/
236 * ggsn: don't use gtp_kernel_tunnel_{add,del}() for userspace tun
237
238 [ Pau Espin Pedrol ]
239 * ggsn_vty: Stop using deprecated API vty_install_default
240 * contrib/jenkins.sh: Enable Werror in C(PP)FLAGS
241 * examples: Add secondary ipv6 google DNS to osmo-ggsn.cfg
242 * tun_setaddr6: Fix log typo
243 * cosmetic: Reorder tun_addaddr to get rid of decl of tun_setaddr4
244 * ggsn.c: Print version of unhandled ip packet
245 * Remove unused empty src/Makefile.in
246 * tests: Split ipv6 specific tests into a new test group
247 * Add support for IPv4v6 End User Addresses
248 * contrib: jenkins.sh: Build libgtpnl as dep when building with gtp kernel support
249 * cosmetic: sgsnemu.c: Fix trailing whitespace
250 * ggsn.c: Improve logging info on link-local ipv6 addr not found
251 * tun.c: tun_addaddr: Fix segfault and wrong usage of tun_nlattr
252 * Set tun_addaddr ipv agnostic and add support for ipv6
253 * ggsn: Add 'ipv6 link-local' vty cmd
254 * ggsn_vty.c: Print ipv6 link-local cmd when writing config to file
255 * gtp.c: Fix trailing whitespace
256 * gtp.c: Determine GTP version from header
257 * gtp.c: Log unsupported GTP version number
258 * gtp/pdp: Fix trailing whitespace
259 * gtp/pdp: Remove unused APIs pdp_ntoeua pdp_euaton
260 * gtp.c: gtp_gpdu_ind: Convert ifelse to switch statement
261 * gtp.c: gtp_gpdu_ind: Early return to avoid use of uninitialized var
262 * gtp/gtp.c: Remove unused function char2ul_t
263 * gtp/gtp.c: Mark non exported functions as static
264 * gtp/gtp.c: Use uint8_t for version param in static functions
265 * ggsn: encaps_tun: Avoid forwarding packet if EUA is unassigned, fix crash
266 * ggsn: Validate packet src addr from MS
267 * ggsn: Parse PCO_IPCP
268 * ggsn: Parse PCO_IPCP for IPv4v6 pdp ctx
269 * ggsn: Print all addresses on successful pdp ctx creation
270 * ggsn.c: cb_tun_ind: Convert ifelse to switch statement
271 * ggsn.c: cb_tun_ind: log dst addr of packet without pdp ctx
272 * ggsn.c: cb_tun_ind: Don't drop packets targeting pdp ctx ll addr
273 * sgsnemu: Fix bad ptr during context deallocation
274 * sgsnemu: listen param is a host, not an interface
275 * use osmo_init_logging2
276
277 [ Max ]
278 * Log APN and tun names for packets
279 * Enable sanitize for CI tests
280 * Fix stow-enabled jenkins build failure
281 * Add GTP message names
282
283 [ Viktor Tsymbalyuk ]
284 * sgsnemu: sgsnemu stopped after recieving "Request accepted" from ggsn
285 * sgsnemu: created "pinghost" and "createif" modes for mutual exclusion
286 * sgsnemu: fix: no outgoing GTP-U in "createif" mode
287
288 [ Martin Hauke ]
289 * build: Remove AC_PROG_CXX, C++ is never used
290
291 [ Stefan Sperling ]
292 * remove the -f option from osmo-ggsn.service
293
294 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:05:27 +0200
295
Harald Welteff069172017-10-28 19:00:23 +0200296osmo-ggsn (1.1.0) unstable; urgency=medium
297
298 * libgtp: pdp.h: Addition of new tx_gpdu_seq struct member member
299 * libgtp: pdp.h: add LOGPDPX() helper to public API
300
301 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 19:00:23 +0200
302
Harald Welteb5b02c22017-09-06 12:19:49 +0200303osmo-ggsn (1.0.0) unstable; urgency=medium
Harald Welte632e8432017-09-05 18:12:14 +0200304
305 * Transition to OsmoGGSN
306
Harald Welteb5b02c22017-09-06 12:19:49 +0200307 -- Harald Welte <laforge@gnumonks.org> Wed, 06 Sep 2017 12:19:48 +0200
Harald Welte632e8432017-09-05 18:12:14 +0200308
Maxbdc504e2017-08-28 12:15:03 +0200309openggsn (0.94.0) UNRELEASED; urgency=medium
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200310
Harald Welte367baa32017-08-13 09:41:33 +0200311 [ Holger Hans Peter Freyther ]
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200312 * Bump version to ease upgrading from Debian SID.
Holger Hans Peter Freyther68d244d2017-01-24 17:21:05 +0100313 * Bump libgtp SO version after ABI change.
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200314
Harald Welte367baa32017-08-13 09:41:33 +0200315 [ Harald Welte ]
316 * various documentation / README updates
317 * improve error logging and propagation
318 * endian-safe definition of IP header
319 * IPv6 user plane support
320
321 -- Harald Welte <laforge@gnumonks.org> Sun, 13 Aug 2017 09:34:20 +0200
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200322
Holger Hans Peter Freyther89dcb6142015-11-30 14:06:09 +0100323openggsn (0.92) precise; urgency=medium
324
325 * Release 0.92
326
327 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Mon, 30 Nov 2015 14:05:59 +0100
328
329openggsn (0.91+git34) precise; urgency=medium
Holger Hans Peter Freyther0b705bb2014-09-23 16:38:47 +0200330
331 * Non-maintainer upload.
332
333 -- Holger Hans Peter Freyther <holger@freyther.de> Tue, 23 Sep 2014 16:38:32 +0200
334
335openggsn (0.91+git33) precise; urgency=low
Eric Butlerab9ff092012-08-24 21:16:01 -0700336
337 * Fix init script.
338
339 -- Eric Butler <eric@codebutler.com> Fri, 24 Aug 2012 21:15:32 -0700
340
Eric Butler235a0952012-08-14 18:08:41 -0700341openggsn (0.91+git33) precise; urgency=low
342
343 * Update package for Ubuntu Precise.
344
345 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 16:48:59 -0700
346
Harald Welteb5022552011-05-10 17:32:02 +0200347openggsn (0.91-2) unstable; urgency=low
348
349 * Switch to source/format (git)
350
351 -- Harald Welte <laforge@gnumonks.org> Tue, 10 May 2011 17:31:37 +0200
352
Harald Weltee9168092010-08-24 15:23:33 +0200353openggsn (0.91-1) unstable; urgency=low
354
355 * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
356
357 -- Harald Welte <laforge@gnumonks.org> Tue, 24 Aug 2010 11:23:40 +0200