blob: 445e75c8c988da19f5e53137f9b6a08e034f71cb [file] [log] [blame]
Harald Welte21546072020-08-13 12:26:20 +02001osmo-ggsn (1.6.0) unstable; urgency=medium
2
3 [ Pau Espin Pedrol ]
4 * cosmetic: Fix comment typo
5 * netns: Improve error checking
6 * sgsnemu: cmdline: Drop unused function cmdline_parser_params_create()
7 * sgsnemu: Pass array of in64_addr to in46a_from_eua()
8 * sgsnemu: Rename sgsnemu's libgtp cb_conf
9 * sgsnemu: Set its default loglevel category to INFO
10 * Move icmpv6 and checksum files from ggsn/ dir to lib/
11 * netdev_addaddr6: Use prefixlen arg
12 * sgsnemu: Avoid adding extra autogenerated local link ipv6 addr to tun iface
13 * sgsnemu: Fix ping transmitted statistics output
14 * cosmetic: icmpv6.c: fix typo in comment
15 * icmpv6.c: Mark internal function as static
16 * sgsnemu: Get rid of duplicated options.destaddr
17 * sgsnemu: Get rid of duplicated options.net
18 * sgsnemu: tun_addaddr: Don't set local addr as dstaddr
19 * icmpv6.c: Move code generating ipv6 hdr to its own function
20 * Rename netdev_*route to end in route4
21 * sgsnemu: Fix build/run against linux < 4.11 (no sysctl addr_gen_mode support)
22 * sgsnemu: Handle IPv6 SLAAC in tun iface manually
23 * sgsnemu: Implement ping on IPv6 APNs
24 * sgsnemu: Fix assumption ipv6 Interface-Identifier of public addr == announced Prefix
25 * gtp: queue_test: Fix printf gcc warn under ARM
26
27 [ Andreas Schultz ]
28 * add Linux network namespace support for TUN device
29
30 [ Vadim Yanitskiy ]
31 * lib/netns: fix open_ns(): return fd from open()
32
33 [ Philipp Maier ]
34 * doc: do not use random ip address for dns in default conf
35 * doc: use 127.0.0.2 instead of 127.0.0.6 as bind ip.
36 * debug: use LOGL_NOTICE instead of LOGL_DEBUG
37
38 [ Eric ]
39 * configure.ac: fix libtool issue with clang and sanitizer
40
41 [ Harald Welte ]
42 * lib/netns.c: Add comments to the code, including doxygen API docs
43 * lib/netns: OSMO_ASSERT() if user doesn't call init_netns()
44 * lib/netns: Fix up error paths
45 * example config: use RFC1918 addresses for GGSN pools
46
47 [ Dmitri Kalashnik ]
48 * sgsnemu: use real tun device name after the device is up.
49
50 [ Oliver Smith ]
51 * osmo-ggsn.spec.in: remove
52 * contrib: import RPM spec
53 * contrib: integrate RPM spec
54 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
55
56 -- Harald Welte <laforge@osmocom.org> Thu, 13 Aug 2020 12:26:20 +0200
57
Pau Espin Pedrole71e0f22020-01-02 20:39:39 +010058osmo-ggsn (1.5.0) unstable; urgency=medium
59
60 [ Jan Engelhardt ]
61 * build: switch AC_CANONICAL_TARGET for AC_CANONICAL_HOST
62
63 [ Pau Espin Pedrol ]
64 * libgtp: Remove packets in tx queue belonging pdp being freed
65 * libgtp: announce pdp ctx deletion upon CreatePdpCtx being rejected
66 * Introduce in46a_is_v{4,6}() helpers
67 * ggsn: Move PCO handling code into its own file
68 * in46_addr: Improve in46a_ntop documentation
69 * ggsn_vty.c: Fix wrong use of in46a_from_eua, print IPv6 euas
70 * ggsn: Split application lifecycle related code into ggsn_main.c
71 * Move pdp_get_peer_ipv() to lib/util.*
72 * gtp-kernel.c: Fix wrong use of in46a_from_eua, print IPv6 euas
73 * Introduce LOGTUN log helper
74 * ggsn_vty.c: Avoid printing duplicates for pdp context with v4v6 EUAs
75 * pdp: constify param in pdp_count_secondary()
76 * ggsn_vty.c: Improve output of VTY show pdp-context
77 * doc: Update vty reference xml file
78 * libgtp: Introduce cb_recovery3
79 * ggsn: Implement echo req/resp and recovery
80 * cosmetic: fix formatting in if line
81 * gtp: Log msg retransmits and timeouts
82 * cosmetic: gtp: Drop commented out code calling pdp_freepdp()
83 * cosmetic: gtp: Improve documentation of gtp_delete_context_req2()
84 * ggsn: rx DeletePdpReq confirmation: Improve documentation and use gtp_freepdp()
85 * gtp: Manage queue timers internally
86 * ggsn, sgsnemu: Drop use of no-op deprecated gtp_retrans* APIs
87
88 [ Vadim Yanitskiy ]
89 * gtp_update_pdp_ind(): fix NULL-pointer dereference
90 * gtp_error_ind_conf(): fix: guard against an unknown GTP version
91 * gtp/gtp.c: cosmetic: use get_tid() where we need TID
92 * manuals/configuration.adoc: fix Network Address without prefix length
93 * manuals/configuration.adoc: fix IPv4 address mismatch in <<ggsn_no_root>>
94 * contrib/systemd: add systemd-networkd examples from manuals
95
96 [ Harald Welte ]
97 * sgsnemu: Fix null-pointer format string argument
98 * manual: Fix copy+paste error
99
100 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 02 Jan 2020 20:39:39 +0100
101
Pau Espin Pedrol67aebc92019-08-07 21:28:30 +0200102osmo-ggsn (1.4.0) unstable; urgency=medium
103
104 [ Max ]
105 * Don't return error on normal shutdown
106
107 [ Harald Welte ]
108 * process_pco() const-ify 'apn' argument
109 * ggsn: Remove magic numbers from pco_contains_proto()
110 * ggsn: const-ify input / read-only arguments of PCO related functions
111 * ggsn: Remove magic numbers from ipcp_contains_option()
112 * ggsn: Fix build_ipcp_pco() in presence of invalid IPCP content
113 * ggsn.c: Refactor PCO processing during PDP activation
114 * ggsn: Add minimalistic PAP support
115 * ggsn: More logging from PCO handling (e.g. in case of malconfiguration)
116 * sgsnemu: Fix format string argument count
117
118 [ Vadim Yanitskiy ]
119 * osmo-ggsn: fix VTY command for getting PDP contexts by APN
120 * osmo-ggsn: add VTY command to show PDP context by IPv4
121 * osmo-ggsn: check result of osmo_apn_to_str()
122 * osmo-ggsn: print requested / actual APN in PDP info
123 * osmo-ggsn: properly show subscriber's MSISDN in the VTY
124
125 [ Pau Espin Pedrol ]
126 * ggsn: Drop unused param force in apn_stop()
127 * gtp: Document spec reasoning drop of Rx DeleteCtxReq
128 * ggsn: Start gtp retrans timer during startup
129 * gtp: Take queue_resp into account to schedule retrans timer
130 * gtp: Fix typo dublicate->duplicate
131 * pdp: Introduce new API pdp_count_secondary
132 * gtp_create_pdp_ind: simplify code by reordering and compacting parsing
133 * gtp: Refactor code to use gtp_freepdp(_teardown) APIs
134 * cosmetic: gtp: Document free pdp ctx in non-teardown scenario
135 * gtp: Re-arrange free pdp ctx code in non-teardown scenario
136 * pdp: Drop unused code for haship
137 * cosmetic: gtp.h: Remove trailing whitespaces
138 * ggsn: Fix undefined behaviour shifting beyond sign bit
139 * gtp: Introduce new pdp APIs (and deprecate old ones) to support multiple GSN
140 * gtp: Make use of new libgtp APIs with multi-gsn support
141 * ggsn_vty_reference.xml: Update from last code changes
142 * ggsn: vty: Require ggsn param in <show pdp-context> cmd
143 * sgsnemu: Replace use of deprecated libgtp API pdp_newpdp with new one
144 * cosmetic: gtp: queue: remove trailing whitespace
145 * gtp: Add missing headers
146 * gtp: queue.c: Document queue APIs
147 * gtp: queue: Add unit test queue_test
148 * ggsn: Avoid unaligned mem access reading PCO proto id
149 * ggsn: Use structures instead of raw arrays when parsing ipcp_hdr
150 * configure.ac: Replace obosolete macro AC_CANONICAL_SYSTEM
151 * configure.ac: Use brackets in AC_INIT params
152 * configure.ac: Use prefered AC_CONFIG_HEADERS over AM_CONFIG_HEADER
153 * configure.ac: some versions of linux/if.h require including sys/socket.h
154 * sgsnemu: Fix unaligned pointer access during ip/icmp checksum
155 * Remove undefined param passed to {logging,osmo_stats}_vty_add_cmds
156 * Require libosmocore 1.1.0
157
158 [ Oliver Smith ]
159 * debian: create -doc subpackage with pdf manuals
160 * ggsn: Use gtp_delete_context_req2() everywhere
161 * contrib/jenkins.sh: run "make maintainer-clean"
162
163 [ Daniel Willmann ]
164 * manuals: Add script to regenerate vty/counter documentation
165
166 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 21:28:30 +0200
167
Harald Weltef5a268a2019-01-20 21:34:23 +0100168osmo-ggsn (1.3.0) unstable; urgency=medium
169
170 [ Pau Espin Pedrol ]
171 * ggsn: ctrl iface: listen on IP configured by VTY
172 * gtp: Log type name of unexpected signalling message
173 * gtp: Allow recv DEL CTX REQ in sgsn and DEL CTX RSP in ggsn
174 * gtp: Log ignore CTX DEL REQ due to no teardown and only 1 ctx active
175 * gtp: Add new API to avoid freeing pdp contexts during DEL CTX REQ
176 * gtp: Add new replacement cb_recovery2 for cb_recovery
177 * Install systemd services with autotools
178 * Install sample cfg file to /etc/osmocom
179
180 [ Stefan Sperling ]
181 * fix unaligned access in build_ipcp_pco()
182 * fix support for multiple IPCP in PDP protocol configuration options
183 * check ioctl() call return value in tun_new()
184 * fix allocation of ippool's hash table
185 * replace bogus memcpy() call in ippool_newip()
186 * initialize local variable addr in ippool_new()
187 * fix format string error in ippool_printaddr()
188 * fix a format string directives in queue_seqset()
189 * properly store IPv6 addresses in struct tun_t
190
191 [ Harald Welte ]
192 * debian/rules: Don't overwrite .tarball-version
193 * osmo-ggsn.cfg: Ensure well-formed config file example
194 * sgsnemu: Fix printing of tun device name
195 * ippool.c: Use "%td" format string for ptrdiff_t
196 * initial version of OsmoGGSN user manual
197 * OsmoGGSN: Add VTY reference manual
198 * GGSN: Document how 'ip tuntap' is used for non-root; call netdev 'apn0'
199 * vty-ref: Update URI of docbook 5.0 schema
200
201 [ Alexander Couzens ]
202 * libgtp: implement gtp_clear_queues to clear req/resp queue
203
204 [ Neels Hofmeyr ]
205 * Importing history from osmo-gsm-manuals.git
206 * refactor Makefile build rules, don't use the FORCE
207 * GGSN: don't say 'NITB'
208 * OsmoGGSN: more info on non-root operation / tun creation
209 * OsmoGGSN: multiple instances: mention GTP port
210 * OsmoGGSN: add Routing section for IP forward and masquerading
211 * OsmoGGSN: typo: priveleges
212 * OsmoGGSN VTY ref: prep: convert newlines to unix
213 * OsmoGGSN vty: update VTY reference
214 * OsmoGGSN: fix VTY additions' node IDs
215 * OsmoGGSN: update vty reference
216 * ggsn: update vty reference
217
218 [ Max ]
219 * Expand OsmoGGSN manual
220
221 [ Oliver Smith ]
222 * build manuals moved here from osmo-gsm-manuals.git
223 * Fix DISTCHECK_CONFIGURE_FLAGS override
224 * contrib/jenkins.sh: build and publish manuals
225 * contrib: fix makedistcheck with disabled systemd
226
227 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 21:34:22 +0100
228
Pau Espin Pedrolb673d1c2018-05-31 12:44:54 +0200229osmo-ggsn (1.2.2) unstable; urgency=medium
230
231 [ Vadim Yanitskiy ]
232 * ggsn_vty.c: fix: use CONFIG_NODE as parent by default
233
234 [ Philipp Maier ]
235 * ggsn: fix misinterpreted length field in ipcp_contains_option()
236 * ggsn: make sure ipcp_option_hdr and and ipcp_hdr are packed
237
238 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 31 May 2018 12:44:54 +0200
239
Pau Espin Pedrolac076252018-05-04 12:19:58 +0200240osmo-ggsn (1.2.1) unstable; urgency=medium
241
242 * debian/rules: Fix debian packaging after 1.2.0 release
243
244 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 04 May 2018 12:19:58 +0200
245
Pau Espin Pedrola06b2d32018-05-03 16:05:28 +0200246osmo-ggsn (1.2.0) unstable; urgency=medium
247
248 [ Neels Hofmeyr ]
249 * fix compiler warnings: return 0 in main(), in 3 tests
250 * add --enable-sanitize config option
251 * sanitize build: ensure uint16/32 alignment in gtpie_test and in46a_test
252 * configure: add --enable-werror
253 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
254
255 [ Harald Welte ]
256 * sgsnemu: Don't leak FILE handle in proc_read()
257 * sgsnemu: Fix format string in printing tun-device name
258 * sgsnemu: Make sure buffer has space for terminating-NUL
259 * sgsnemu: Free strings in error path
260 * gtp: Fix buffer overflow in imsi_gtp2str()
261 * gtp: Explicit OSMO_ASSERT to ensure pdp variable is set
262 * tun: Don't copy 16byte IPv6 address to 'struct in_addr'
263 * ippool: Correctly compute size of static pool
264 * remove unused argument to alloc_ippool_blacklist()
265 * factor out netdev_ip_local_get() from tun_ip_local_get()
266 * Properly NULL-out blacklist in alloc_ippool_blacklist()
267 * gtp_kernel: Change gtp_kernel_init() function signature
268 * gtp-kernel: Re-add support for kernel GTP-U acceleration
269 * gtp-kernel: Get rid of hard-coded kernel GTP device name
270 * gtp-kernel: shut down kernel GTP device in apn_down()
271 * gtp-kernel: Align logging for APN start in kernel-gtp case with that of TUN
272 * gtp-kernel: Avoid global state variable
273 * gtp-kernel: Make sure repeated calls to gtp_kernel_init() are safe
274 * gtp-kernel: proper cleanup in error path
275 * gtp-kernel: Get rid of SYS_ERR where not applicable
276 * gtp-kernel: Add function name to pdp_debug() function calls
277 * gtp-kernel: Add device nime in pdp_debug() log statements
278 * contrib/jenkins.sh: Allow jenkins job to specify if kernel GTP is used
279 * ggsn.c: Fix byte order of IPCP IPv4 DNS servers
280 * ggsn: Ignore PCO with length 0, don't abort processing
281 * README.md: Remove misleading sentence on sgsnemu
282 * Add talloc context introspection via VTY
283 * fix segfault in case of kernel gtp-u
284 * lib/tun.c: Generalize tun_sifflags() to netdev_sifflags
285 * lib/tun.c: generalize tun_*route() to netdev_*route()
286 * lib/tun.c: Generalize tun_{set,add}addr*() functions
287 * lib/tun: split generic network device related stuff to lib/netdev
288 * lib/netdev.c: Cosmetic changes (coding style / cleanups)
289 * ggsn: Don't explicitly use tun_setaddr() API anymore
290 * sgsnemu: Convert from tun_setaddr() to tun_addaddr()
291 * lib/tun: Remove tun_setaddr() API, as everyone is using tun_addaddr() now
292 * Move kernel GTP support from ggsn/ to lib/
293 * ggsn: don't use gtp_kernel_tunnel_{add,del}() for userspace tun
294
295 [ Pau Espin Pedrol ]
296 * ggsn_vty: Stop using deprecated API vty_install_default
297 * contrib/jenkins.sh: Enable Werror in C(PP)FLAGS
298 * examples: Add secondary ipv6 google DNS to osmo-ggsn.cfg
299 * tun_setaddr6: Fix log typo
300 * cosmetic: Reorder tun_addaddr to get rid of decl of tun_setaddr4
301 * ggsn.c: Print version of unhandled ip packet
302 * Remove unused empty src/Makefile.in
303 * tests: Split ipv6 specific tests into a new test group
304 * Add support for IPv4v6 End User Addresses
305 * contrib: jenkins.sh: Build libgtpnl as dep when building with gtp kernel support
306 * cosmetic: sgsnemu.c: Fix trailing whitespace
307 * ggsn.c: Improve logging info on link-local ipv6 addr not found
308 * tun.c: tun_addaddr: Fix segfault and wrong usage of tun_nlattr
309 * Set tun_addaddr ipv agnostic and add support for ipv6
310 * ggsn: Add 'ipv6 link-local' vty cmd
311 * ggsn_vty.c: Print ipv6 link-local cmd when writing config to file
312 * gtp.c: Fix trailing whitespace
313 * gtp.c: Determine GTP version from header
314 * gtp.c: Log unsupported GTP version number
315 * gtp/pdp: Fix trailing whitespace
316 * gtp/pdp: Remove unused APIs pdp_ntoeua pdp_euaton
317 * gtp.c: gtp_gpdu_ind: Convert ifelse to switch statement
318 * gtp.c: gtp_gpdu_ind: Early return to avoid use of uninitialized var
319 * gtp/gtp.c: Remove unused function char2ul_t
320 * gtp/gtp.c: Mark non exported functions as static
321 * gtp/gtp.c: Use uint8_t for version param in static functions
322 * ggsn: encaps_tun: Avoid forwarding packet if EUA is unassigned, fix crash
323 * ggsn: Validate packet src addr from MS
324 * ggsn: Parse PCO_IPCP
325 * ggsn: Parse PCO_IPCP for IPv4v6 pdp ctx
326 * ggsn: Print all addresses on successful pdp ctx creation
327 * ggsn.c: cb_tun_ind: Convert ifelse to switch statement
328 * ggsn.c: cb_tun_ind: log dst addr of packet without pdp ctx
329 * ggsn.c: cb_tun_ind: Don't drop packets targeting pdp ctx ll addr
330 * sgsnemu: Fix bad ptr during context deallocation
331 * sgsnemu: listen param is a host, not an interface
332 * use osmo_init_logging2
333
334 [ Max ]
335 * Log APN and tun names for packets
336 * Enable sanitize for CI tests
337 * Fix stow-enabled jenkins build failure
338 * Add GTP message names
339
340 [ Viktor Tsymbalyuk ]
341 * sgsnemu: sgsnemu stopped after recieving "Request accepted" from ggsn
342 * sgsnemu: created "pinghost" and "createif" modes for mutual exclusion
343 * sgsnemu: fix: no outgoing GTP-U in "createif" mode
344
345 [ Martin Hauke ]
346 * build: Remove AC_PROG_CXX, C++ is never used
347
348 [ Stefan Sperling ]
349 * remove the -f option from osmo-ggsn.service
350
351 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:05:27 +0200
352
Harald Welteff069172017-10-28 19:00:23 +0200353osmo-ggsn (1.1.0) unstable; urgency=medium
354
355 * libgtp: pdp.h: Addition of new tx_gpdu_seq struct member member
356 * libgtp: pdp.h: add LOGPDPX() helper to public API
357
358 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 19:00:23 +0200
359
Harald Welteb5b02c22017-09-06 12:19:49 +0200360osmo-ggsn (1.0.0) unstable; urgency=medium
Harald Welte632e8432017-09-05 18:12:14 +0200361
362 * Transition to OsmoGGSN
363
Harald Welteb5b02c22017-09-06 12:19:49 +0200364 -- Harald Welte <laforge@gnumonks.org> Wed, 06 Sep 2017 12:19:48 +0200
Harald Welte632e8432017-09-05 18:12:14 +0200365
Maxbdc504e2017-08-28 12:15:03 +0200366openggsn (0.94.0) UNRELEASED; urgency=medium
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200367
Harald Welte367baa32017-08-13 09:41:33 +0200368 [ Holger Hans Peter Freyther ]
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200369 * Bump version to ease upgrading from Debian SID.
Holger Hans Peter Freyther68d244d2017-01-24 17:21:05 +0100370 * Bump libgtp SO version after ABI change.
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200371
Harald Welte367baa32017-08-13 09:41:33 +0200372 [ Harald Welte ]
373 * various documentation / README updates
374 * improve error logging and propagation
375 * endian-safe definition of IP header
376 * IPv6 user plane support
377
378 -- Harald Welte <laforge@gnumonks.org> Sun, 13 Aug 2017 09:34:20 +0200
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200379
Holger Hans Peter Freyther89dcb6142015-11-30 14:06:09 +0100380openggsn (0.92) precise; urgency=medium
381
382 * Release 0.92
383
384 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Mon, 30 Nov 2015 14:05:59 +0100
385
386openggsn (0.91+git34) precise; urgency=medium
Holger Hans Peter Freyther0b705bb2014-09-23 16:38:47 +0200387
388 * Non-maintainer upload.
389
390 -- Holger Hans Peter Freyther <holger@freyther.de> Tue, 23 Sep 2014 16:38:32 +0200
391
392openggsn (0.91+git33) precise; urgency=low
Eric Butlerab9ff092012-08-24 21:16:01 -0700393
394 * Fix init script.
395
396 -- Eric Butler <eric@codebutler.com> Fri, 24 Aug 2012 21:15:32 -0700
397
Eric Butler235a0952012-08-14 18:08:41 -0700398openggsn (0.91+git33) precise; urgency=low
399
400 * Update package for Ubuntu Precise.
401
402 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 16:48:59 -0700
403
Harald Welteb5022552011-05-10 17:32:02 +0200404openggsn (0.91-2) unstable; urgency=low
405
406 * Switch to source/format (git)
407
408 -- Harald Welte <laforge@gnumonks.org> Tue, 10 May 2011 17:31:37 +0200
409
Harald Weltee9168092010-08-24 15:23:33 +0200410openggsn (0.91-1) unstable; urgency=low
411
412 * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
413
414 -- Harald Welte <laforge@gnumonks.org> Tue, 24 Aug 2010 11:23:40 +0200