blob: 29f9d9ced1abc911603c5ad54bd60bb68dcb53f3 [file] [log] [blame]
Pau Espin Pedrol18898b42021-02-23 17:31:24 +01001osmo-ggsn (1.7.1) unstable; urgency=medium
2
3 [ Harald Welte ]
4 * main: add --vty-ref-mode, use vty_dump_xml_ref_mode()
5 * manuals: generate vty reference xml at build time
6
7 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 23 Feb 2021 17:31:24 +0100
8
Pau Espin Pedrolb1f641b2021-02-23 13:34:39 +01009osmo-ggsn (1.7.0) unstable; urgency=medium
10
11 [ Vadim Yanitskiy ]
12 * debian/control: change maintainer to the Osmocom team / mailing list
13
14 [ Pau Espin Pedrol ]
15 * configure.ac: Fix trailing whitespace
16 * doc: Update VTY reference xml file
17 * Support setting rt-prio and cpu-affinity mask through VTY
18 * contrib/jenkins: Enable parallel make in make distcheck
19 * ggsn: generate coredump and exit upon SIGABRT received
20 * tests: Explicitly drop category from log
21 * tests: Replace deprecated API log_set_print_filename
22
23 [ Keith ]
24 * Fix vty PDP lookups by IMSI
25 * Prevent Crash in show pdp-context from vty
26 * Minor: remove code duplication
27 * Use imsi_str2gtp() in sgsnemu
28 * sgsnemu: relax check on length of IMSI cmdline arg.
29 * GTP: Replace recently introduced imsi_str2gtp()
30
31 [ Harald Welte ]
32 * Use OSMO_FD_* instead of deprecated BSC_FD_*
33 * gtp-kernel: Remove duplicate #include section
34 * gtp-kernel: don't #include libmnl headers
35
36 [ Oliver Smith ]
37 * contrib/jenkins: don't build osmo-gsm-manuals
38 * configure.ac: set -std=gnu11
39 * apn_start: avoid segfault if missing tun-device
40 * .gitignore: ignore debian/libgtp*
41 * deb/rpm: build with --enable-gtp-linux
42
43 -- Pau Espin Pedrol <pespin@espeweb.net> Tue, 23 Feb 2021 13:34:39 +0100
44
Harald Welte21546072020-08-13 12:26:20 +020045osmo-ggsn (1.6.0) unstable; urgency=medium
46
47 [ Pau Espin Pedrol ]
48 * cosmetic: Fix comment typo
49 * netns: Improve error checking
50 * sgsnemu: cmdline: Drop unused function cmdline_parser_params_create()
51 * sgsnemu: Pass array of in64_addr to in46a_from_eua()
52 * sgsnemu: Rename sgsnemu's libgtp cb_conf
53 * sgsnemu: Set its default loglevel category to INFO
54 * Move icmpv6 and checksum files from ggsn/ dir to lib/
55 * netdev_addaddr6: Use prefixlen arg
56 * sgsnemu: Avoid adding extra autogenerated local link ipv6 addr to tun iface
57 * sgsnemu: Fix ping transmitted statistics output
58 * cosmetic: icmpv6.c: fix typo in comment
59 * icmpv6.c: Mark internal function as static
60 * sgsnemu: Get rid of duplicated options.destaddr
61 * sgsnemu: Get rid of duplicated options.net
62 * sgsnemu: tun_addaddr: Don't set local addr as dstaddr
63 * icmpv6.c: Move code generating ipv6 hdr to its own function
64 * Rename netdev_*route to end in route4
65 * sgsnemu: Fix build/run against linux < 4.11 (no sysctl addr_gen_mode support)
66 * sgsnemu: Handle IPv6 SLAAC in tun iface manually
67 * sgsnemu: Implement ping on IPv6 APNs
68 * sgsnemu: Fix assumption ipv6 Interface-Identifier of public addr == announced Prefix
69 * gtp: queue_test: Fix printf gcc warn under ARM
70
71 [ Andreas Schultz ]
72 * add Linux network namespace support for TUN device
73
74 [ Vadim Yanitskiy ]
75 * lib/netns: fix open_ns(): return fd from open()
76
77 [ Philipp Maier ]
78 * doc: do not use random ip address for dns in default conf
79 * doc: use 127.0.0.2 instead of 127.0.0.6 as bind ip.
80 * debug: use LOGL_NOTICE instead of LOGL_DEBUG
81
82 [ Eric ]
83 * configure.ac: fix libtool issue with clang and sanitizer
84
85 [ Harald Welte ]
86 * lib/netns.c: Add comments to the code, including doxygen API docs
87 * lib/netns: OSMO_ASSERT() if user doesn't call init_netns()
88 * lib/netns: Fix up error paths
89 * example config: use RFC1918 addresses for GGSN pools
90
91 [ Dmitri Kalashnik ]
92 * sgsnemu: use real tun device name after the device is up.
93
94 [ Oliver Smith ]
95 * osmo-ggsn.spec.in: remove
96 * contrib: import RPM spec
97 * contrib: integrate RPM spec
98 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
99
100 -- Harald Welte <laforge@osmocom.org> Thu, 13 Aug 2020 12:26:20 +0200
101
Pau Espin Pedrole71e0f22020-01-02 20:39:39 +0100102osmo-ggsn (1.5.0) unstable; urgency=medium
103
104 [ Jan Engelhardt ]
105 * build: switch AC_CANONICAL_TARGET for AC_CANONICAL_HOST
106
107 [ Pau Espin Pedrol ]
108 * libgtp: Remove packets in tx queue belonging pdp being freed
109 * libgtp: announce pdp ctx deletion upon CreatePdpCtx being rejected
110 * Introduce in46a_is_v{4,6}() helpers
111 * ggsn: Move PCO handling code into its own file
112 * in46_addr: Improve in46a_ntop documentation
113 * ggsn_vty.c: Fix wrong use of in46a_from_eua, print IPv6 euas
114 * ggsn: Split application lifecycle related code into ggsn_main.c
115 * Move pdp_get_peer_ipv() to lib/util.*
116 * gtp-kernel.c: Fix wrong use of in46a_from_eua, print IPv6 euas
117 * Introduce LOGTUN log helper
118 * ggsn_vty.c: Avoid printing duplicates for pdp context with v4v6 EUAs
119 * pdp: constify param in pdp_count_secondary()
120 * ggsn_vty.c: Improve output of VTY show pdp-context
121 * doc: Update vty reference xml file
122 * libgtp: Introduce cb_recovery3
123 * ggsn: Implement echo req/resp and recovery
124 * cosmetic: fix formatting in if line
125 * gtp: Log msg retransmits and timeouts
126 * cosmetic: gtp: Drop commented out code calling pdp_freepdp()
127 * cosmetic: gtp: Improve documentation of gtp_delete_context_req2()
128 * ggsn: rx DeletePdpReq confirmation: Improve documentation and use gtp_freepdp()
129 * gtp: Manage queue timers internally
130 * ggsn, sgsnemu: Drop use of no-op deprecated gtp_retrans* APIs
131
132 [ Vadim Yanitskiy ]
133 * gtp_update_pdp_ind(): fix NULL-pointer dereference
134 * gtp_error_ind_conf(): fix: guard against an unknown GTP version
135 * gtp/gtp.c: cosmetic: use get_tid() where we need TID
136 * manuals/configuration.adoc: fix Network Address without prefix length
137 * manuals/configuration.adoc: fix IPv4 address mismatch in <<ggsn_no_root>>
138 * contrib/systemd: add systemd-networkd examples from manuals
139
140 [ Harald Welte ]
141 * sgsnemu: Fix null-pointer format string argument
142 * manual: Fix copy+paste error
143
144 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 02 Jan 2020 20:39:39 +0100
145
Pau Espin Pedrol67aebc92019-08-07 21:28:30 +0200146osmo-ggsn (1.4.0) unstable; urgency=medium
147
148 [ Max ]
149 * Don't return error on normal shutdown
150
151 [ Harald Welte ]
152 * process_pco() const-ify 'apn' argument
153 * ggsn: Remove magic numbers from pco_contains_proto()
154 * ggsn: const-ify input / read-only arguments of PCO related functions
155 * ggsn: Remove magic numbers from ipcp_contains_option()
156 * ggsn: Fix build_ipcp_pco() in presence of invalid IPCP content
157 * ggsn.c: Refactor PCO processing during PDP activation
158 * ggsn: Add minimalistic PAP support
159 * ggsn: More logging from PCO handling (e.g. in case of malconfiguration)
160 * sgsnemu: Fix format string argument count
161
162 [ Vadim Yanitskiy ]
163 * osmo-ggsn: fix VTY command for getting PDP contexts by APN
164 * osmo-ggsn: add VTY command to show PDP context by IPv4
165 * osmo-ggsn: check result of osmo_apn_to_str()
166 * osmo-ggsn: print requested / actual APN in PDP info
167 * osmo-ggsn: properly show subscriber's MSISDN in the VTY
168
169 [ Pau Espin Pedrol ]
170 * ggsn: Drop unused param force in apn_stop()
171 * gtp: Document spec reasoning drop of Rx DeleteCtxReq
172 * ggsn: Start gtp retrans timer during startup
173 * gtp: Take queue_resp into account to schedule retrans timer
174 * gtp: Fix typo dublicate->duplicate
175 * pdp: Introduce new API pdp_count_secondary
176 * gtp_create_pdp_ind: simplify code by reordering and compacting parsing
177 * gtp: Refactor code to use gtp_freepdp(_teardown) APIs
178 * cosmetic: gtp: Document free pdp ctx in non-teardown scenario
179 * gtp: Re-arrange free pdp ctx code in non-teardown scenario
180 * pdp: Drop unused code for haship
181 * cosmetic: gtp.h: Remove trailing whitespaces
182 * ggsn: Fix undefined behaviour shifting beyond sign bit
183 * gtp: Introduce new pdp APIs (and deprecate old ones) to support multiple GSN
184 * gtp: Make use of new libgtp APIs with multi-gsn support
185 * ggsn_vty_reference.xml: Update from last code changes
186 * ggsn: vty: Require ggsn param in <show pdp-context> cmd
187 * sgsnemu: Replace use of deprecated libgtp API pdp_newpdp with new one
188 * cosmetic: gtp: queue: remove trailing whitespace
189 * gtp: Add missing headers
190 * gtp: queue.c: Document queue APIs
191 * gtp: queue: Add unit test queue_test
192 * ggsn: Avoid unaligned mem access reading PCO proto id
193 * ggsn: Use structures instead of raw arrays when parsing ipcp_hdr
194 * configure.ac: Replace obosolete macro AC_CANONICAL_SYSTEM
195 * configure.ac: Use brackets in AC_INIT params
196 * configure.ac: Use prefered AC_CONFIG_HEADERS over AM_CONFIG_HEADER
197 * configure.ac: some versions of linux/if.h require including sys/socket.h
198 * sgsnemu: Fix unaligned pointer access during ip/icmp checksum
199 * Remove undefined param passed to {logging,osmo_stats}_vty_add_cmds
200 * Require libosmocore 1.1.0
201
202 [ Oliver Smith ]
203 * debian: create -doc subpackage with pdf manuals
204 * ggsn: Use gtp_delete_context_req2() everywhere
205 * contrib/jenkins.sh: run "make maintainer-clean"
206
207 [ Daniel Willmann ]
208 * manuals: Add script to regenerate vty/counter documentation
209
210 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 21:28:30 +0200
211
Harald Weltef5a268a2019-01-20 21:34:23 +0100212osmo-ggsn (1.3.0) unstable; urgency=medium
213
214 [ Pau Espin Pedrol ]
215 * ggsn: ctrl iface: listen on IP configured by VTY
216 * gtp: Log type name of unexpected signalling message
217 * gtp: Allow recv DEL CTX REQ in sgsn and DEL CTX RSP in ggsn
218 * gtp: Log ignore CTX DEL REQ due to no teardown and only 1 ctx active
219 * gtp: Add new API to avoid freeing pdp contexts during DEL CTX REQ
220 * gtp: Add new replacement cb_recovery2 for cb_recovery
221 * Install systemd services with autotools
222 * Install sample cfg file to /etc/osmocom
223
224 [ Stefan Sperling ]
225 * fix unaligned access in build_ipcp_pco()
226 * fix support for multiple IPCP in PDP protocol configuration options
227 * check ioctl() call return value in tun_new()
228 * fix allocation of ippool's hash table
229 * replace bogus memcpy() call in ippool_newip()
230 * initialize local variable addr in ippool_new()
231 * fix format string error in ippool_printaddr()
232 * fix a format string directives in queue_seqset()
233 * properly store IPv6 addresses in struct tun_t
234
235 [ Harald Welte ]
236 * debian/rules: Don't overwrite .tarball-version
237 * osmo-ggsn.cfg: Ensure well-formed config file example
238 * sgsnemu: Fix printing of tun device name
239 * ippool.c: Use "%td" format string for ptrdiff_t
240 * initial version of OsmoGGSN user manual
241 * OsmoGGSN: Add VTY reference manual
242 * GGSN: Document how 'ip tuntap' is used for non-root; call netdev 'apn0'
243 * vty-ref: Update URI of docbook 5.0 schema
244
245 [ Alexander Couzens ]
246 * libgtp: implement gtp_clear_queues to clear req/resp queue
247
248 [ Neels Hofmeyr ]
249 * Importing history from osmo-gsm-manuals.git
250 * refactor Makefile build rules, don't use the FORCE
251 * GGSN: don't say 'NITB'
252 * OsmoGGSN: more info on non-root operation / tun creation
253 * OsmoGGSN: multiple instances: mention GTP port
254 * OsmoGGSN: add Routing section for IP forward and masquerading
255 * OsmoGGSN: typo: priveleges
256 * OsmoGGSN VTY ref: prep: convert newlines to unix
257 * OsmoGGSN vty: update VTY reference
258 * OsmoGGSN: fix VTY additions' node IDs
259 * OsmoGGSN: update vty reference
260 * ggsn: update vty reference
261
262 [ Max ]
263 * Expand OsmoGGSN manual
264
265 [ Oliver Smith ]
266 * build manuals moved here from osmo-gsm-manuals.git
267 * Fix DISTCHECK_CONFIGURE_FLAGS override
268 * contrib/jenkins.sh: build and publish manuals
269 * contrib: fix makedistcheck with disabled systemd
270
271 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 21:34:22 +0100
272
Pau Espin Pedrolb673d1c2018-05-31 12:44:54 +0200273osmo-ggsn (1.2.2) unstable; urgency=medium
274
275 [ Vadim Yanitskiy ]
276 * ggsn_vty.c: fix: use CONFIG_NODE as parent by default
277
278 [ Philipp Maier ]
279 * ggsn: fix misinterpreted length field in ipcp_contains_option()
280 * ggsn: make sure ipcp_option_hdr and and ipcp_hdr are packed
281
282 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 31 May 2018 12:44:54 +0200
283
Pau Espin Pedrolac076252018-05-04 12:19:58 +0200284osmo-ggsn (1.2.1) unstable; urgency=medium
285
286 * debian/rules: Fix debian packaging after 1.2.0 release
287
288 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 04 May 2018 12:19:58 +0200
289
Pau Espin Pedrola06b2d32018-05-03 16:05:28 +0200290osmo-ggsn (1.2.0) unstable; urgency=medium
291
292 [ Neels Hofmeyr ]
293 * fix compiler warnings: return 0 in main(), in 3 tests
294 * add --enable-sanitize config option
295 * sanitize build: ensure uint16/32 alignment in gtpie_test and in46a_test
296 * configure: add --enable-werror
297 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
298
299 [ Harald Welte ]
300 * sgsnemu: Don't leak FILE handle in proc_read()
301 * sgsnemu: Fix format string in printing tun-device name
302 * sgsnemu: Make sure buffer has space for terminating-NUL
303 * sgsnemu: Free strings in error path
304 * gtp: Fix buffer overflow in imsi_gtp2str()
305 * gtp: Explicit OSMO_ASSERT to ensure pdp variable is set
306 * tun: Don't copy 16byte IPv6 address to 'struct in_addr'
307 * ippool: Correctly compute size of static pool
308 * remove unused argument to alloc_ippool_blacklist()
309 * factor out netdev_ip_local_get() from tun_ip_local_get()
310 * Properly NULL-out blacklist in alloc_ippool_blacklist()
311 * gtp_kernel: Change gtp_kernel_init() function signature
312 * gtp-kernel: Re-add support for kernel GTP-U acceleration
313 * gtp-kernel: Get rid of hard-coded kernel GTP device name
314 * gtp-kernel: shut down kernel GTP device in apn_down()
315 * gtp-kernel: Align logging for APN start in kernel-gtp case with that of TUN
316 * gtp-kernel: Avoid global state variable
317 * gtp-kernel: Make sure repeated calls to gtp_kernel_init() are safe
318 * gtp-kernel: proper cleanup in error path
319 * gtp-kernel: Get rid of SYS_ERR where not applicable
320 * gtp-kernel: Add function name to pdp_debug() function calls
321 * gtp-kernel: Add device nime in pdp_debug() log statements
322 * contrib/jenkins.sh: Allow jenkins job to specify if kernel GTP is used
323 * ggsn.c: Fix byte order of IPCP IPv4 DNS servers
324 * ggsn: Ignore PCO with length 0, don't abort processing
325 * README.md: Remove misleading sentence on sgsnemu
326 * Add talloc context introspection via VTY
327 * fix segfault in case of kernel gtp-u
328 * lib/tun.c: Generalize tun_sifflags() to netdev_sifflags
329 * lib/tun.c: generalize tun_*route() to netdev_*route()
330 * lib/tun.c: Generalize tun_{set,add}addr*() functions
331 * lib/tun: split generic network device related stuff to lib/netdev
332 * lib/netdev.c: Cosmetic changes (coding style / cleanups)
333 * ggsn: Don't explicitly use tun_setaddr() API anymore
334 * sgsnemu: Convert from tun_setaddr() to tun_addaddr()
335 * lib/tun: Remove tun_setaddr() API, as everyone is using tun_addaddr() now
336 * Move kernel GTP support from ggsn/ to lib/
337 * ggsn: don't use gtp_kernel_tunnel_{add,del}() for userspace tun
338
339 [ Pau Espin Pedrol ]
340 * ggsn_vty: Stop using deprecated API vty_install_default
341 * contrib/jenkins.sh: Enable Werror in C(PP)FLAGS
342 * examples: Add secondary ipv6 google DNS to osmo-ggsn.cfg
343 * tun_setaddr6: Fix log typo
344 * cosmetic: Reorder tun_addaddr to get rid of decl of tun_setaddr4
345 * ggsn.c: Print version of unhandled ip packet
346 * Remove unused empty src/Makefile.in
347 * tests: Split ipv6 specific tests into a new test group
348 * Add support for IPv4v6 End User Addresses
349 * contrib: jenkins.sh: Build libgtpnl as dep when building with gtp kernel support
350 * cosmetic: sgsnemu.c: Fix trailing whitespace
351 * ggsn.c: Improve logging info on link-local ipv6 addr not found
352 * tun.c: tun_addaddr: Fix segfault and wrong usage of tun_nlattr
353 * Set tun_addaddr ipv agnostic and add support for ipv6
354 * ggsn: Add 'ipv6 link-local' vty cmd
355 * ggsn_vty.c: Print ipv6 link-local cmd when writing config to file
356 * gtp.c: Fix trailing whitespace
357 * gtp.c: Determine GTP version from header
358 * gtp.c: Log unsupported GTP version number
359 * gtp/pdp: Fix trailing whitespace
360 * gtp/pdp: Remove unused APIs pdp_ntoeua pdp_euaton
361 * gtp.c: gtp_gpdu_ind: Convert ifelse to switch statement
362 * gtp.c: gtp_gpdu_ind: Early return to avoid use of uninitialized var
363 * gtp/gtp.c: Remove unused function char2ul_t
364 * gtp/gtp.c: Mark non exported functions as static
365 * gtp/gtp.c: Use uint8_t for version param in static functions
366 * ggsn: encaps_tun: Avoid forwarding packet if EUA is unassigned, fix crash
367 * ggsn: Validate packet src addr from MS
368 * ggsn: Parse PCO_IPCP
369 * ggsn: Parse PCO_IPCP for IPv4v6 pdp ctx
370 * ggsn: Print all addresses on successful pdp ctx creation
371 * ggsn.c: cb_tun_ind: Convert ifelse to switch statement
372 * ggsn.c: cb_tun_ind: log dst addr of packet without pdp ctx
373 * ggsn.c: cb_tun_ind: Don't drop packets targeting pdp ctx ll addr
374 * sgsnemu: Fix bad ptr during context deallocation
375 * sgsnemu: listen param is a host, not an interface
376 * use osmo_init_logging2
377
378 [ Max ]
379 * Log APN and tun names for packets
380 * Enable sanitize for CI tests
381 * Fix stow-enabled jenkins build failure
382 * Add GTP message names
383
384 [ Viktor Tsymbalyuk ]
385 * sgsnemu: sgsnemu stopped after recieving "Request accepted" from ggsn
386 * sgsnemu: created "pinghost" and "createif" modes for mutual exclusion
387 * sgsnemu: fix: no outgoing GTP-U in "createif" mode
388
389 [ Martin Hauke ]
390 * build: Remove AC_PROG_CXX, C++ is never used
391
392 [ Stefan Sperling ]
393 * remove the -f option from osmo-ggsn.service
394
395 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:05:27 +0200
396
Harald Welteff069172017-10-28 19:00:23 +0200397osmo-ggsn (1.1.0) unstable; urgency=medium
398
399 * libgtp: pdp.h: Addition of new tx_gpdu_seq struct member member
400 * libgtp: pdp.h: add LOGPDPX() helper to public API
401
402 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 19:00:23 +0200
403
Harald Welteb5b02c22017-09-06 12:19:49 +0200404osmo-ggsn (1.0.0) unstable; urgency=medium
Harald Welte632e8432017-09-05 18:12:14 +0200405
406 * Transition to OsmoGGSN
407
Harald Welteb5b02c22017-09-06 12:19:49 +0200408 -- Harald Welte <laforge@gnumonks.org> Wed, 06 Sep 2017 12:19:48 +0200
Harald Welte632e8432017-09-05 18:12:14 +0200409
Maxbdc504e2017-08-28 12:15:03 +0200410openggsn (0.94.0) UNRELEASED; urgency=medium
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200411
Harald Welte367baa32017-08-13 09:41:33 +0200412 [ Holger Hans Peter Freyther ]
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200413 * Bump version to ease upgrading from Debian SID.
Holger Hans Peter Freyther68d244d2017-01-24 17:21:05 +0100414 * Bump libgtp SO version after ABI change.
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200415
Harald Welte367baa32017-08-13 09:41:33 +0200416 [ Harald Welte ]
417 * various documentation / README updates
418 * improve error logging and propagation
419 * endian-safe definition of IP header
420 * IPv6 user plane support
421
422 -- Harald Welte <laforge@gnumonks.org> Sun, 13 Aug 2017 09:34:20 +0200
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200423
Holger Hans Peter Freyther89dcb6142015-11-30 14:06:09 +0100424openggsn (0.92) precise; urgency=medium
425
426 * Release 0.92
427
428 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Mon, 30 Nov 2015 14:05:59 +0100
429
430openggsn (0.91+git34) precise; urgency=medium
Holger Hans Peter Freyther0b705bb2014-09-23 16:38:47 +0200431
432 * Non-maintainer upload.
433
434 -- Holger Hans Peter Freyther <holger@freyther.de> Tue, 23 Sep 2014 16:38:32 +0200
435
436openggsn (0.91+git33) precise; urgency=low
Eric Butlerab9ff092012-08-24 21:16:01 -0700437
438 * Fix init script.
439
440 -- Eric Butler <eric@codebutler.com> Fri, 24 Aug 2012 21:15:32 -0700
441
Eric Butler235a0952012-08-14 18:08:41 -0700442openggsn (0.91+git33) precise; urgency=low
443
444 * Update package for Ubuntu Precise.
445
446 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 16:48:59 -0700
447
Harald Welteb5022552011-05-10 17:32:02 +0200448openggsn (0.91-2) unstable; urgency=low
449
450 * Switch to source/format (git)
451
452 -- Harald Welte <laforge@gnumonks.org> Tue, 10 May 2011 17:31:37 +0200
453
Harald Weltee9168092010-08-24 15:23:33 +0200454openggsn (0.91-1) unstable; urgency=low
455
456 * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
457
458 -- Harald Welte <laforge@gnumonks.org> Tue, 24 Aug 2010 11:23:40 +0200