blob: 08cfb0bb6f529d59363ef6682e50d8365f2e5fe6 [file] [log] [blame]
Pau Espin Pedrolbc583d92022-06-28 17:48:22 +02001osmo-ggsn (1.9.0) unstable; urgency=medium
2
3 [ Pau Espin Pedrol ]
4 * tests: in46a_test: Make coverity happy when calling in46a_from_eua
5 * vty: Fix cmd 'no echo-interval' doing nothing
6 * libgtp: Fix ggsn crash if pdp alloc array is full (PDP_MAX)
7 * libgtp: Define retransmit QUEUE_SIZE relative to PDP_MAX (increase)
8 * gtp: Use switch statement in gtp_create_pdp_ind()
9 * gtp: Log detection of rx duplicate
10 * gtp: Small log improvements in gtp_create_pdp_ind()
11 * gtp: Specify retrans queue name & seqnum in log lines
12 * gtp: Log retrans queue register&free entries
13 * gtp: Fix typo in comment
14 * pco.h: Fix typo in reference to spec
15
16 [ Vadim Yanitskiy ]
17 * tests: use 'check_PROGRAMS' instead of 'noinst_PROGRAMS'
18
19 [ Harald Welte ]
20 * update git URLs (git -> https; gitea)
21
22 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 28 Jun 2022 17:48:22 +0200
23
Pau Espin Pedrola3ca2d12021-11-16 13:49:16 +010024osmo-ggsn (1.8.0) unstable; urgency=medium
25
26 [ Oliver Smith ]
27 * doc/examples/Makefile.am: add sgsnemu.conf
28 * doc/examples/osmo-ggsn-kernel-gtp.cfg: new file
29 * doc/manuals: describe GTP-U kernel module
30 * gitignore: add ggsn_vty_reference.xml
31
32 [ Harald Welte ]
33 * Don't install osmo-ggsn-kernel-gtp.cfg to /etc/osmocom/
34 * Don't install sgsnemu.conf to /etc/osmocom/
35 * ggsn: Reject PDP CTX ACT for static IP addresses
36 * vty: Inform user that static IP addresses are not supported
37
38 [ Pau Espin Pedrol ]
39 * gtp: Update teic_confirmed only on resp success
40 * gtp: Rework parsing logic of UpdatePdpCtxResponse
41 * ggsn: Improve logging on incoming DL data packets
42 * gtp: Improve logging of failing pdp ctx resolution from TEI/TID
43 * cosmetic: gtpie.c: Fix trailing whitespace
44 * gtp: constify pointer arg
45 * gtp: Support tx/rx RAN Information Relay message
46 * ggsn: Log tun fd write errors
47 * ggsn: Fix heap-use-after-free during Recovery without associated PDP
48 * cosmetic: configure.ac: Fix tabulation in line
49 * Introduce program gtp-echo-responder
50 * gtp_echo_responder: report invalid chars present in node-feautres cmdline arg as error
51
52 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 16 Nov 2021 13:49:16 +0100
53
Pau Espin Pedrol18898b42021-02-23 17:31:24 +010054osmo-ggsn (1.7.1) unstable; urgency=medium
55
56 [ Harald Welte ]
57 * main: add --vty-ref-mode, use vty_dump_xml_ref_mode()
58 * manuals: generate vty reference xml at build time
59
60 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 23 Feb 2021 17:31:24 +0100
61
Pau Espin Pedrolb1f641b2021-02-23 13:34:39 +010062osmo-ggsn (1.7.0) unstable; urgency=medium
63
64 [ Vadim Yanitskiy ]
65 * debian/control: change maintainer to the Osmocom team / mailing list
66
67 [ Pau Espin Pedrol ]
68 * configure.ac: Fix trailing whitespace
69 * doc: Update VTY reference xml file
70 * Support setting rt-prio and cpu-affinity mask through VTY
71 * contrib/jenkins: Enable parallel make in make distcheck
72 * ggsn: generate coredump and exit upon SIGABRT received
73 * tests: Explicitly drop category from log
74 * tests: Replace deprecated API log_set_print_filename
75
76 [ Keith ]
77 * Fix vty PDP lookups by IMSI
78 * Prevent Crash in show pdp-context from vty
79 * Minor: remove code duplication
80 * Use imsi_str2gtp() in sgsnemu
81 * sgsnemu: relax check on length of IMSI cmdline arg.
82 * GTP: Replace recently introduced imsi_str2gtp()
83
84 [ Harald Welte ]
85 * Use OSMO_FD_* instead of deprecated BSC_FD_*
86 * gtp-kernel: Remove duplicate #include section
87 * gtp-kernel: don't #include libmnl headers
88
89 [ Oliver Smith ]
90 * contrib/jenkins: don't build osmo-gsm-manuals
91 * configure.ac: set -std=gnu11
92 * apn_start: avoid segfault if missing tun-device
93 * .gitignore: ignore debian/libgtp*
94 * deb/rpm: build with --enable-gtp-linux
95
96 -- Pau Espin Pedrol <pespin@espeweb.net> Tue, 23 Feb 2021 13:34:39 +0100
97
Harald Welte21546072020-08-13 12:26:20 +020098osmo-ggsn (1.6.0) unstable; urgency=medium
99
100 [ Pau Espin Pedrol ]
101 * cosmetic: Fix comment typo
102 * netns: Improve error checking
103 * sgsnemu: cmdline: Drop unused function cmdline_parser_params_create()
104 * sgsnemu: Pass array of in64_addr to in46a_from_eua()
105 * sgsnemu: Rename sgsnemu's libgtp cb_conf
106 * sgsnemu: Set its default loglevel category to INFO
107 * Move icmpv6 and checksum files from ggsn/ dir to lib/
108 * netdev_addaddr6: Use prefixlen arg
109 * sgsnemu: Avoid adding extra autogenerated local link ipv6 addr to tun iface
110 * sgsnemu: Fix ping transmitted statistics output
111 * cosmetic: icmpv6.c: fix typo in comment
112 * icmpv6.c: Mark internal function as static
113 * sgsnemu: Get rid of duplicated options.destaddr
114 * sgsnemu: Get rid of duplicated options.net
115 * sgsnemu: tun_addaddr: Don't set local addr as dstaddr
116 * icmpv6.c: Move code generating ipv6 hdr to its own function
117 * Rename netdev_*route to end in route4
118 * sgsnemu: Fix build/run against linux < 4.11 (no sysctl addr_gen_mode support)
119 * sgsnemu: Handle IPv6 SLAAC in tun iface manually
120 * sgsnemu: Implement ping on IPv6 APNs
121 * sgsnemu: Fix assumption ipv6 Interface-Identifier of public addr == announced Prefix
122 * gtp: queue_test: Fix printf gcc warn under ARM
123
124 [ Andreas Schultz ]
125 * add Linux network namespace support for TUN device
126
127 [ Vadim Yanitskiy ]
128 * lib/netns: fix open_ns(): return fd from open()
129
130 [ Philipp Maier ]
131 * doc: do not use random ip address for dns in default conf
132 * doc: use 127.0.0.2 instead of 127.0.0.6 as bind ip.
133 * debug: use LOGL_NOTICE instead of LOGL_DEBUG
134
135 [ Eric ]
136 * configure.ac: fix libtool issue with clang and sanitizer
137
138 [ Harald Welte ]
139 * lib/netns.c: Add comments to the code, including doxygen API docs
140 * lib/netns: OSMO_ASSERT() if user doesn't call init_netns()
141 * lib/netns: Fix up error paths
142 * example config: use RFC1918 addresses for GGSN pools
143
144 [ Dmitri Kalashnik ]
145 * sgsnemu: use real tun device name after the device is up.
146
147 [ Oliver Smith ]
148 * osmo-ggsn.spec.in: remove
149 * contrib: import RPM spec
150 * contrib: integrate RPM spec
151 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
152
153 -- Harald Welte <laforge@osmocom.org> Thu, 13 Aug 2020 12:26:20 +0200
154
Pau Espin Pedrole71e0f22020-01-02 20:39:39 +0100155osmo-ggsn (1.5.0) unstable; urgency=medium
156
157 [ Jan Engelhardt ]
158 * build: switch AC_CANONICAL_TARGET for AC_CANONICAL_HOST
159
160 [ Pau Espin Pedrol ]
161 * libgtp: Remove packets in tx queue belonging pdp being freed
162 * libgtp: announce pdp ctx deletion upon CreatePdpCtx being rejected
163 * Introduce in46a_is_v{4,6}() helpers
164 * ggsn: Move PCO handling code into its own file
165 * in46_addr: Improve in46a_ntop documentation
166 * ggsn_vty.c: Fix wrong use of in46a_from_eua, print IPv6 euas
167 * ggsn: Split application lifecycle related code into ggsn_main.c
168 * Move pdp_get_peer_ipv() to lib/util.*
169 * gtp-kernel.c: Fix wrong use of in46a_from_eua, print IPv6 euas
170 * Introduce LOGTUN log helper
171 * ggsn_vty.c: Avoid printing duplicates for pdp context with v4v6 EUAs
172 * pdp: constify param in pdp_count_secondary()
173 * ggsn_vty.c: Improve output of VTY show pdp-context
174 * doc: Update vty reference xml file
175 * libgtp: Introduce cb_recovery3
176 * ggsn: Implement echo req/resp and recovery
177 * cosmetic: fix formatting in if line
178 * gtp: Log msg retransmits and timeouts
179 * cosmetic: gtp: Drop commented out code calling pdp_freepdp()
180 * cosmetic: gtp: Improve documentation of gtp_delete_context_req2()
181 * ggsn: rx DeletePdpReq confirmation: Improve documentation and use gtp_freepdp()
182 * gtp: Manage queue timers internally
183 * ggsn, sgsnemu: Drop use of no-op deprecated gtp_retrans* APIs
184
185 [ Vadim Yanitskiy ]
186 * gtp_update_pdp_ind(): fix NULL-pointer dereference
187 * gtp_error_ind_conf(): fix: guard against an unknown GTP version
188 * gtp/gtp.c: cosmetic: use get_tid() where we need TID
189 * manuals/configuration.adoc: fix Network Address without prefix length
190 * manuals/configuration.adoc: fix IPv4 address mismatch in <<ggsn_no_root>>
191 * contrib/systemd: add systemd-networkd examples from manuals
192
193 [ Harald Welte ]
194 * sgsnemu: Fix null-pointer format string argument
195 * manual: Fix copy+paste error
196
197 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 02 Jan 2020 20:39:39 +0100
198
Pau Espin Pedrol67aebc92019-08-07 21:28:30 +0200199osmo-ggsn (1.4.0) unstable; urgency=medium
200
201 [ Max ]
202 * Don't return error on normal shutdown
203
204 [ Harald Welte ]
205 * process_pco() const-ify 'apn' argument
206 * ggsn: Remove magic numbers from pco_contains_proto()
207 * ggsn: const-ify input / read-only arguments of PCO related functions
208 * ggsn: Remove magic numbers from ipcp_contains_option()
209 * ggsn: Fix build_ipcp_pco() in presence of invalid IPCP content
210 * ggsn.c: Refactor PCO processing during PDP activation
211 * ggsn: Add minimalistic PAP support
212 * ggsn: More logging from PCO handling (e.g. in case of malconfiguration)
213 * sgsnemu: Fix format string argument count
214
215 [ Vadim Yanitskiy ]
216 * osmo-ggsn: fix VTY command for getting PDP contexts by APN
217 * osmo-ggsn: add VTY command to show PDP context by IPv4
218 * osmo-ggsn: check result of osmo_apn_to_str()
219 * osmo-ggsn: print requested / actual APN in PDP info
220 * osmo-ggsn: properly show subscriber's MSISDN in the VTY
221
222 [ Pau Espin Pedrol ]
223 * ggsn: Drop unused param force in apn_stop()
224 * gtp: Document spec reasoning drop of Rx DeleteCtxReq
225 * ggsn: Start gtp retrans timer during startup
226 * gtp: Take queue_resp into account to schedule retrans timer
227 * gtp: Fix typo dublicate->duplicate
228 * pdp: Introduce new API pdp_count_secondary
229 * gtp_create_pdp_ind: simplify code by reordering and compacting parsing
230 * gtp: Refactor code to use gtp_freepdp(_teardown) APIs
231 * cosmetic: gtp: Document free pdp ctx in non-teardown scenario
232 * gtp: Re-arrange free pdp ctx code in non-teardown scenario
233 * pdp: Drop unused code for haship
234 * cosmetic: gtp.h: Remove trailing whitespaces
235 * ggsn: Fix undefined behaviour shifting beyond sign bit
236 * gtp: Introduce new pdp APIs (and deprecate old ones) to support multiple GSN
237 * gtp: Make use of new libgtp APIs with multi-gsn support
238 * ggsn_vty_reference.xml: Update from last code changes
239 * ggsn: vty: Require ggsn param in <show pdp-context> cmd
240 * sgsnemu: Replace use of deprecated libgtp API pdp_newpdp with new one
241 * cosmetic: gtp: queue: remove trailing whitespace
242 * gtp: Add missing headers
243 * gtp: queue.c: Document queue APIs
244 * gtp: queue: Add unit test queue_test
245 * ggsn: Avoid unaligned mem access reading PCO proto id
246 * ggsn: Use structures instead of raw arrays when parsing ipcp_hdr
247 * configure.ac: Replace obosolete macro AC_CANONICAL_SYSTEM
248 * configure.ac: Use brackets in AC_INIT params
249 * configure.ac: Use prefered AC_CONFIG_HEADERS over AM_CONFIG_HEADER
250 * configure.ac: some versions of linux/if.h require including sys/socket.h
251 * sgsnemu: Fix unaligned pointer access during ip/icmp checksum
252 * Remove undefined param passed to {logging,osmo_stats}_vty_add_cmds
253 * Require libosmocore 1.1.0
254
255 [ Oliver Smith ]
256 * debian: create -doc subpackage with pdf manuals
257 * ggsn: Use gtp_delete_context_req2() everywhere
258 * contrib/jenkins.sh: run "make maintainer-clean"
259
260 [ Daniel Willmann ]
261 * manuals: Add script to regenerate vty/counter documentation
262
263 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 21:28:30 +0200
264
Harald Weltef5a268a2019-01-20 21:34:23 +0100265osmo-ggsn (1.3.0) unstable; urgency=medium
266
267 [ Pau Espin Pedrol ]
268 * ggsn: ctrl iface: listen on IP configured by VTY
269 * gtp: Log type name of unexpected signalling message
270 * gtp: Allow recv DEL CTX REQ in sgsn and DEL CTX RSP in ggsn
271 * gtp: Log ignore CTX DEL REQ due to no teardown and only 1 ctx active
272 * gtp: Add new API to avoid freeing pdp contexts during DEL CTX REQ
273 * gtp: Add new replacement cb_recovery2 for cb_recovery
274 * Install systemd services with autotools
275 * Install sample cfg file to /etc/osmocom
276
277 [ Stefan Sperling ]
278 * fix unaligned access in build_ipcp_pco()
279 * fix support for multiple IPCP in PDP protocol configuration options
280 * check ioctl() call return value in tun_new()
281 * fix allocation of ippool's hash table
282 * replace bogus memcpy() call in ippool_newip()
283 * initialize local variable addr in ippool_new()
284 * fix format string error in ippool_printaddr()
285 * fix a format string directives in queue_seqset()
286 * properly store IPv6 addresses in struct tun_t
287
288 [ Harald Welte ]
289 * debian/rules: Don't overwrite .tarball-version
290 * osmo-ggsn.cfg: Ensure well-formed config file example
291 * sgsnemu: Fix printing of tun device name
292 * ippool.c: Use "%td" format string for ptrdiff_t
293 * initial version of OsmoGGSN user manual
294 * OsmoGGSN: Add VTY reference manual
295 * GGSN: Document how 'ip tuntap' is used for non-root; call netdev 'apn0'
296 * vty-ref: Update URI of docbook 5.0 schema
297
298 [ Alexander Couzens ]
299 * libgtp: implement gtp_clear_queues to clear req/resp queue
300
301 [ Neels Hofmeyr ]
302 * Importing history from osmo-gsm-manuals.git
303 * refactor Makefile build rules, don't use the FORCE
304 * GGSN: don't say 'NITB'
305 * OsmoGGSN: more info on non-root operation / tun creation
306 * OsmoGGSN: multiple instances: mention GTP port
307 * OsmoGGSN: add Routing section for IP forward and masquerading
308 * OsmoGGSN: typo: priveleges
309 * OsmoGGSN VTY ref: prep: convert newlines to unix
310 * OsmoGGSN vty: update VTY reference
311 * OsmoGGSN: fix VTY additions' node IDs
312 * OsmoGGSN: update vty reference
313 * ggsn: update vty reference
314
315 [ Max ]
316 * Expand OsmoGGSN manual
317
318 [ Oliver Smith ]
319 * build manuals moved here from osmo-gsm-manuals.git
320 * Fix DISTCHECK_CONFIGURE_FLAGS override
321 * contrib/jenkins.sh: build and publish manuals
322 * contrib: fix makedistcheck with disabled systemd
323
324 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 21:34:22 +0100
325
Pau Espin Pedrolb673d1c2018-05-31 12:44:54 +0200326osmo-ggsn (1.2.2) unstable; urgency=medium
327
328 [ Vadim Yanitskiy ]
329 * ggsn_vty.c: fix: use CONFIG_NODE as parent by default
330
331 [ Philipp Maier ]
332 * ggsn: fix misinterpreted length field in ipcp_contains_option()
333 * ggsn: make sure ipcp_option_hdr and and ipcp_hdr are packed
334
335 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 31 May 2018 12:44:54 +0200
336
Pau Espin Pedrolac076252018-05-04 12:19:58 +0200337osmo-ggsn (1.2.1) unstable; urgency=medium
338
339 * debian/rules: Fix debian packaging after 1.2.0 release
340
341 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 04 May 2018 12:19:58 +0200
342
Pau Espin Pedrola06b2d32018-05-03 16:05:28 +0200343osmo-ggsn (1.2.0) unstable; urgency=medium
344
345 [ Neels Hofmeyr ]
346 * fix compiler warnings: return 0 in main(), in 3 tests
347 * add --enable-sanitize config option
348 * sanitize build: ensure uint16/32 alignment in gtpie_test and in46a_test
349 * configure: add --enable-werror
350 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
351
352 [ Harald Welte ]
353 * sgsnemu: Don't leak FILE handle in proc_read()
354 * sgsnemu: Fix format string in printing tun-device name
355 * sgsnemu: Make sure buffer has space for terminating-NUL
356 * sgsnemu: Free strings in error path
357 * gtp: Fix buffer overflow in imsi_gtp2str()
358 * gtp: Explicit OSMO_ASSERT to ensure pdp variable is set
359 * tun: Don't copy 16byte IPv6 address to 'struct in_addr'
360 * ippool: Correctly compute size of static pool
361 * remove unused argument to alloc_ippool_blacklist()
362 * factor out netdev_ip_local_get() from tun_ip_local_get()
363 * Properly NULL-out blacklist in alloc_ippool_blacklist()
364 * gtp_kernel: Change gtp_kernel_init() function signature
365 * gtp-kernel: Re-add support for kernel GTP-U acceleration
366 * gtp-kernel: Get rid of hard-coded kernel GTP device name
367 * gtp-kernel: shut down kernel GTP device in apn_down()
368 * gtp-kernel: Align logging for APN start in kernel-gtp case with that of TUN
369 * gtp-kernel: Avoid global state variable
370 * gtp-kernel: Make sure repeated calls to gtp_kernel_init() are safe
371 * gtp-kernel: proper cleanup in error path
372 * gtp-kernel: Get rid of SYS_ERR where not applicable
373 * gtp-kernel: Add function name to pdp_debug() function calls
374 * gtp-kernel: Add device nime in pdp_debug() log statements
375 * contrib/jenkins.sh: Allow jenkins job to specify if kernel GTP is used
376 * ggsn.c: Fix byte order of IPCP IPv4 DNS servers
377 * ggsn: Ignore PCO with length 0, don't abort processing
378 * README.md: Remove misleading sentence on sgsnemu
379 * Add talloc context introspection via VTY
380 * fix segfault in case of kernel gtp-u
381 * lib/tun.c: Generalize tun_sifflags() to netdev_sifflags
382 * lib/tun.c: generalize tun_*route() to netdev_*route()
383 * lib/tun.c: Generalize tun_{set,add}addr*() functions
384 * lib/tun: split generic network device related stuff to lib/netdev
385 * lib/netdev.c: Cosmetic changes (coding style / cleanups)
386 * ggsn: Don't explicitly use tun_setaddr() API anymore
387 * sgsnemu: Convert from tun_setaddr() to tun_addaddr()
388 * lib/tun: Remove tun_setaddr() API, as everyone is using tun_addaddr() now
389 * Move kernel GTP support from ggsn/ to lib/
390 * ggsn: don't use gtp_kernel_tunnel_{add,del}() for userspace tun
391
392 [ Pau Espin Pedrol ]
393 * ggsn_vty: Stop using deprecated API vty_install_default
394 * contrib/jenkins.sh: Enable Werror in C(PP)FLAGS
395 * examples: Add secondary ipv6 google DNS to osmo-ggsn.cfg
396 * tun_setaddr6: Fix log typo
397 * cosmetic: Reorder tun_addaddr to get rid of decl of tun_setaddr4
398 * ggsn.c: Print version of unhandled ip packet
399 * Remove unused empty src/Makefile.in
400 * tests: Split ipv6 specific tests into a new test group
401 * Add support for IPv4v6 End User Addresses
402 * contrib: jenkins.sh: Build libgtpnl as dep when building with gtp kernel support
403 * cosmetic: sgsnemu.c: Fix trailing whitespace
404 * ggsn.c: Improve logging info on link-local ipv6 addr not found
405 * tun.c: tun_addaddr: Fix segfault and wrong usage of tun_nlattr
406 * Set tun_addaddr ipv agnostic and add support for ipv6
407 * ggsn: Add 'ipv6 link-local' vty cmd
408 * ggsn_vty.c: Print ipv6 link-local cmd when writing config to file
409 * gtp.c: Fix trailing whitespace
410 * gtp.c: Determine GTP version from header
411 * gtp.c: Log unsupported GTP version number
412 * gtp/pdp: Fix trailing whitespace
413 * gtp/pdp: Remove unused APIs pdp_ntoeua pdp_euaton
414 * gtp.c: gtp_gpdu_ind: Convert ifelse to switch statement
415 * gtp.c: gtp_gpdu_ind: Early return to avoid use of uninitialized var
416 * gtp/gtp.c: Remove unused function char2ul_t
417 * gtp/gtp.c: Mark non exported functions as static
418 * gtp/gtp.c: Use uint8_t for version param in static functions
419 * ggsn: encaps_tun: Avoid forwarding packet if EUA is unassigned, fix crash
420 * ggsn: Validate packet src addr from MS
421 * ggsn: Parse PCO_IPCP
422 * ggsn: Parse PCO_IPCP for IPv4v6 pdp ctx
423 * ggsn: Print all addresses on successful pdp ctx creation
424 * ggsn.c: cb_tun_ind: Convert ifelse to switch statement
425 * ggsn.c: cb_tun_ind: log dst addr of packet without pdp ctx
426 * ggsn.c: cb_tun_ind: Don't drop packets targeting pdp ctx ll addr
427 * sgsnemu: Fix bad ptr during context deallocation
428 * sgsnemu: listen param is a host, not an interface
429 * use osmo_init_logging2
430
431 [ Max ]
432 * Log APN and tun names for packets
433 * Enable sanitize for CI tests
434 * Fix stow-enabled jenkins build failure
435 * Add GTP message names
436
437 [ Viktor Tsymbalyuk ]
438 * sgsnemu: sgsnemu stopped after recieving "Request accepted" from ggsn
439 * sgsnemu: created "pinghost" and "createif" modes for mutual exclusion
440 * sgsnemu: fix: no outgoing GTP-U in "createif" mode
441
442 [ Martin Hauke ]
443 * build: Remove AC_PROG_CXX, C++ is never used
444
445 [ Stefan Sperling ]
446 * remove the -f option from osmo-ggsn.service
447
448 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:05:27 +0200
449
Harald Welteff069172017-10-28 19:00:23 +0200450osmo-ggsn (1.1.0) unstable; urgency=medium
451
452 * libgtp: pdp.h: Addition of new tx_gpdu_seq struct member member
453 * libgtp: pdp.h: add LOGPDPX() helper to public API
454
455 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 19:00:23 +0200
456
Harald Welteb5b02c22017-09-06 12:19:49 +0200457osmo-ggsn (1.0.0) unstable; urgency=medium
Harald Welte632e8432017-09-05 18:12:14 +0200458
459 * Transition to OsmoGGSN
460
Harald Welteb5b02c22017-09-06 12:19:49 +0200461 -- Harald Welte <laforge@gnumonks.org> Wed, 06 Sep 2017 12:19:48 +0200
Harald Welte632e8432017-09-05 18:12:14 +0200462
Maxbdc504e2017-08-28 12:15:03 +0200463openggsn (0.94.0) UNRELEASED; urgency=medium
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200464
Harald Welte367baa32017-08-13 09:41:33 +0200465 [ Holger Hans Peter Freyther ]
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200466 * Bump version to ease upgrading from Debian SID.
Holger Hans Peter Freyther68d244d2017-01-24 17:21:05 +0100467 * Bump libgtp SO version after ABI change.
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200468
Harald Welte367baa32017-08-13 09:41:33 +0200469 [ Harald Welte ]
470 * various documentation / README updates
471 * improve error logging and propagation
472 * endian-safe definition of IP header
473 * IPv6 user plane support
474
475 -- Harald Welte <laforge@gnumonks.org> Sun, 13 Aug 2017 09:34:20 +0200
Holger Hans Peter Freyther6bf2f052016-05-24 22:53:55 +0200476
Holger Hans Peter Freyther89dcb6142015-11-30 14:06:09 +0100477openggsn (0.92) precise; urgency=medium
478
479 * Release 0.92
480
481 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Mon, 30 Nov 2015 14:05:59 +0100
482
483openggsn (0.91+git34) precise; urgency=medium
Holger Hans Peter Freyther0b705bb2014-09-23 16:38:47 +0200484
485 * Non-maintainer upload.
486
487 -- Holger Hans Peter Freyther <holger@freyther.de> Tue, 23 Sep 2014 16:38:32 +0200
488
489openggsn (0.91+git33) precise; urgency=low
Eric Butlerab9ff092012-08-24 21:16:01 -0700490
491 * Fix init script.
492
493 -- Eric Butler <eric@codebutler.com> Fri, 24 Aug 2012 21:15:32 -0700
494
Eric Butler235a0952012-08-14 18:08:41 -0700495openggsn (0.91+git33) precise; urgency=low
496
497 * Update package for Ubuntu Precise.
498
499 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 16:48:59 -0700
500
Harald Welteb5022552011-05-10 17:32:02 +0200501openggsn (0.91-2) unstable; urgency=low
502
503 * Switch to source/format (git)
504
505 -- Harald Welte <laforge@gnumonks.org> Tue, 10 May 2011 17:31:37 +0200
506
Harald Weltee9168092010-08-24 15:23:33 +0200507openggsn (0.91-1) unstable; urgency=low
508
509 * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
510
511 -- Harald Welte <laforge@gnumonks.org> Tue, 24 Aug 2010 11:23:40 +0200