blob: 321855511112fc6022018ba69e0eec2730f02860 [file] [log] [blame]
Pau Espin Pedrol5e631512023-02-07 17:08:17 +01001osmo-trx (1.5.0) unstable; urgency=medium
2
3 [ Oliver Smith ]
4 * configure.ac: add -lboost_thread for uhd < 4.2.0
5 * gitignore: add uhddev_ipc.cpp
6 * contrib/jenkins: don't run "make distcheck" on arm
7
8 [ Vadim Yanitskiy ]
9 * threshold_timer_update_intv(): call osmo_timer_del() unconditionally
10 * Transceiver::expectedCorrType(): RACH is always 8-bit on PTCCH/U
11 * contrib/jenkins.sh: dump submodule status before building
12 * configure.ac: fix: properly check whether to enable ms-trx
13 * configure.ac: allow building without cloning submodules
14 * configure.ac: cosmetic: rearrange MS TRX related logic
15 * configure.ac: make use of AC_MSG_CHECKING and AC_MSG_RESULT
16
17 [ Max ]
18 * Set working directory in systemd service file
19 * Add realtime scheduling and set priority in service file
20 * ctrl: take both address and port from vty config
21
22 [ Eric ]
23 * ignore vscode dirs
24 * rename noisevector class -> avgvector
25 * osmocom-bb for ms-trx side trxcon integration
26 * add checkpatch config
27 * bladerf xa4 support
28 * update osmocom-bb submodule to fix make distcheck
29 * vita demod by piotr krysik, modified
30 * properly update osmocom-bb submodule, for real this time..
31 * ms-trx support
32 * clean up mutex, scopedlock, and signal classes
33 * ipc: add missing override
34 * clang-format: proper c++ standard
35 * ipc: remove old autotools workaround
36 * ms: init trash used to escape the usb callbacks
37 * radio interface: fix init
38
39 [ Eric Wild ]
40 * mstrx: do not wait forever if clock locking fails
41
42 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 07 Feb 2023 17:08:17 +0100
43
Pau Espin Pedrola39fa872022-06-29 09:32:56 +020044osmo-trx (1.4.1) unstable; urgency=medium
45
46 [ Oliver Smith ]
47 * treewide: remove FSF address
48
49 [ Vadim Yanitskiy ]
50 * tests: use 'check_PROGRAMS' instead of 'noinst_PROGRAMS'
51
52 [ Harald Welte ]
53 * update git URLs (git -> https; gitea)
54
55 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 29 Jun 2022 09:32:56 +0200
56
Pau Espin Pedrola7143d32021-11-16 16:27:26 +010057osmo-trx (1.4.0) unstable; urgency=medium
58
59 [ Pau Espin Pedrol ]
60 * Threads.cpp: Fix missing extern C around libosmocore include
61 * Drop logging pthread ID
62 * Threads: Avoid printing pthread_self()
63 * ipc: Makefile.am: Clean LDADD variable
64 * Use new stat item/ctr getter APIs
65 * detectBurst(): Clear downsampling code path
66 * detectBurst(): constify parameter
67 * computeCI(): Constify param and pass it as reference
68 * computeCI(): Rename verbose repeated getter to constant
69 * computeCI(): Constify read-only variable
70 * detectGeneralBurst(): Increase log level about clipping to INFO
71 * cosmetic: Fix typo in comment
72 * computeCI: Document hardcoded multiplier
73 * lms: Drop duplicated check
74 * lms,uhd: Validate band of RxFreq too
75 * lms,uhd: Skip re-assigning same band
76 * lms,uhd: Allow changing band between poweroff & poweron
77
78 [ Vadim Yanitskiy ]
79 * gitignore: remove non-existing 'doc/manuals/osmomsc-usermanual.xml'
80 * ctrl_sock_handle_rx(): fix missing space in LOGCHAN() statement
81 * trx_rate_ctr: use thread safe strerror() in device_sig_cb()
82 * IPCDevice: use thread safe strerror_r() instead of strerror()
83 * IPCDevice: check value returned from select()
84 * LMSDevice: LMS_GetDeviceList() may return a negative number
85
86 [ Eric ]
87 * add hidden fn adjustment command
88 * uhd: ensure configured clock source is actually used
89 * vty: printing fn offset should be signed
90 * lms: init band
91
92 [ Oliver Smith ]
93 * d/patches/build-for-debian8.patch: remove
94
95 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 16 Nov 2021 16:27:26 +0100
96
Harald Welte90d84172021-02-28 11:32:12 +010097osmo-trx (1.3.1) unstable; urgency=medium
98
99 * mark uhddev_ipc.cpp as BUILT_SOURCES
100
101 -- Harald Welte <laforge@osmocom.org> Sun, 28 Feb 2021 11:32:11 +0100
102
Pau Espin Pedrol309ad4d2021-02-23 14:27:15 +0100103osmo-trx (1.3.0) unstable; urgency=medium
104
105 [ Pau Espin Pedrol ]
106 * Make logging category DLMS generic and reusable for other backends
107 * uhd: Use DEVDRV log category and support UHD >=3.11 logging framework
108 * uhd: Improve some logging lines printing UHD pretty-print output
109 * doc: clarify number of channels on B210 with multi-arfcn enabled
110 * radioInterfaceMulti: Fail to tune on freq not following multi-arfcn restrictions
111 * doc: Update vty reference xml file
112 * lms: Move initialization of field started to constructor
113 * lms: Drop unused define
114 * smpl_buf: Fix str_code() param and print unknown error val
115 * lms: Improve smpl_buf error logging
116 * lms: Change radioDevice constructor arg name to avoid masking instance attr
117 * lms: Make reference to std::vector unambiguous
118 * lms: Move rx_buffers allocation to constructor
119 * lms: Store device type specific parameters in one place
120 * lms: Make ts_offset and smpl rate coefs device-specific
121 * lms: Initial multi-arfcn support
122 * contrib/jenkins.sh: Reorder sanity checks
123 * debug.h: Avoid printing pthread_t type
124 * debug.h: Fix print format of chan in CLOGCHAN
125 * cosmetic: fix several typos found by codespell
126 * radioDevice: Drop unused RSSI param from readSamples API
127 * radioDevice: Drop unused isControl param from WriteSamples API
128 * Use OSMO_FD_READ instead of deprecated BSC_FD_READ
129 * Transceiver: Fix extra space in RSP NOISELEV error
130 * Transceiver: Implement TRXC cmd NOMTXPOWER
131 * UHDDevice: Implement getNominalTxPower() based on TxFrequency
132 * radioInterface: Operate on real Tx power attenuation rather than on device specific gains
133 * UHDDevice: Compute TxGain on UHD API based on expected Tx output power
134 * proto_trxd: Fix UndefinedBehaviorSanitizer from ubsan
135 * Transceiver: Allow sending negative nominal tx power in RSP NOMTXPOWER
136 * LMSDevice: Compute TxGain on LimeSuite API based on expected Tx output power
137 * Drop old TxGain APIs from parent radioDevice abstract class
138 * {UHD,LMS}Dervice: Log expected resulting TxPower when setting device specific TxGain
139 * cosmetic: trx_rate_ctr: Fix whitespace
140 * trx_rate_ctr: Fix immediate rescheduling on per-sec thresholds
141 * Rename device specific rate counter multi-thread helpers
142 * Introduce rate counter tx_stale_bursts
143 * TransceiverState: Initialize ctrs field in constructor
144 * doc/manuals: Update thread documentation after dropping CTRL sock threads
145 * trx_rate_ctr: Fix locking wrong mutex
146 * Introduce rate counters to detect issues in received Dl bursts from TRXD
147 * Transceiver: Fix race condition obtaining Dl burst from Upper layer
148 * Add rate counter for missing Txbursts when scheduled towards the radioInterface
149 * Transceiver: Provide initial value for TransceiverState::mFiller in constructor
150 * Transceiver: Use already obtained value from Rx msg structure
151 * Transceiver: Restrict conditions where FN gaps are detected
152 * trx_rate_ctr: Lower some log levels
153 * Introduce CTR log category
154 * Transceiver: Lower some log levels which have an associated counter
155 * Transceiver: Check log level before generating burst str representation
156 * Transceiver: Add several rate_ctr for rx error conditions
157 * Use new libosmovty cpu sched config features
158 * debian: Update debian8 osmo-trx specific patch
159 * jenkins.sh: Verify distro-specific patches apply
160 * ipc: fix var declaration in for loop
161 * Add support for TRXC MUTE command
162 * arch: x86: Fix convolve optimizations breaking signal
163 * contrib/jenkins: Enable parallel make in make distcheck
164 * Transceiver: Pass config struct instead of large list of params
165 * Calculate RSSI offset based on RxGain configuration
166 * main: generate coredump and exit upon SIGABRT received
167 * ipc: Fix wrong reference to BTS in log line
168 * ipc-driver-test: Allow setting dir prefix for UD socket
169 * radioInterfaceMulti: Fix memory leak upon close()
170 * ChannelizerBase: Fix memory leak
171 * Threads.cpp: Use already existing gettid wrapper function
172 * Replace my_gettid with libosmocore osmo_gettid API
173 * tests: Explicitly drop category from log
174 * tests: Replace deprecated API log_set_print_filename
175
176 [ Philipp Maier ]
177 * debug: use LOGL_NOTICE for log category DDEV
178 * doc: do not set the base-port of the trx
179 * doc: apply an rssi-offset of 28 by default.
180 * doc: switch log levels to notice
181 * Transceiver: Log when sending of CLK indications begins
182 * vty: add attributes to VTY commands indicating when they apply
183 * osmo-trx: add commandline option --vty-ref-xml
184
185 [ Eric ]
186 * configure.ac: fix libtool issue with clang and sanitizer
187 * transceiver: check the right vector
188 * transceiver: get rid of the ctrl threads
189 * add kernel style .clang-format with 120 chars per line limit
190 * devices: reset internal smart sample buffers upon stop
191 * transceiver: optimize code if optimizations are enabled
192 * transceiver: initialize reorder flag so we don't miscount
193
194 [ Harald Welte ]
195 * PRBS tool sending PRBS sequence to TRX
196 * prbs-tool: Add error simulation capabilities
197 * utils: Ensure content of this directory is included in 'make dist'
198 * prbs-tool: Don't require C99
199 * RPM spec file: Require uhd-firmware for osmo-trx-uhd
200 * osmo-trx.spec.in: Use %config(noreplace) to retain current config file
201 * Fix build on Debian8
202 * [cosmetic] radioInterfaceMulti: More comments
203 * [cosmetic] radioIntefaceMulti: Fix whitespace / indent
204 * ipc: Use OSMO_FD_* instead of deprecated BSC_FD_*
205 * Use osmo_fd_setup() wherever applicable
206 * Use osmo_fd_*_{disable,enable}
207 * README update
208 * manual: Fix typo OsmTRX -> OsmoTRX
209
210 [ Oliver Smith ]
211 * contrib: import RPM spec
212 * contrib: integrate RPM spec
213 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
214 * contrib/jenkins: don't build osmo-gsm-manuals
215 * configure.ac: set -std=gnu11
216
217 [ Vadim Yanitskiy ]
218 * UHDDevice: catch LookupError/IndexError in set{Rx,Tx}Antenna()
219 * debian/control: change maintainer to the Osmocom team / mailing list
220 * proto_trxd: cosmetic: 'if' is not a function, add space
221 * vty: add multi-ARFCN specific warning for chan N > 0
222 * radioDevice: fix set_antennas(): consider MULTI_ARFCN mode
223 * device/lms: fix: 'trx_vty.h' header requires C linkage
224 * device/lms: fix missing semicolon in LMSDevice::assign_band_desc()
225 * device/lms: get rid of 'using namespace std'
226 * device/common/Makefile.am: remove $(LMS_CFLAGS) from AM_CXXFLAGS
227 * main: add --vty-ref-mode, use vty_dump_xml_ref_mode()
228 * device: drop unreasonable LIBOSMO{CTRL,VTY}_{CFLAGS,LIBS}
229 * Transceiver: use size_t and ARRAY_SIZE() in constructor
230 * Transceiver: explicitly init m{Rx,Tx}LowerLoopThread
231 * vty: fix documentation for 'swap-channels (disable|enable)'
232 * vty: fix documentation for 'egprs (disable|enable)'
233 * vty: fix documentation for 'rx-sps (1|4)' and 'tx-sps (1|4)'
234 * vty: cosmetic: use VTY_IPV4_CMD in 'bind-ip' / 'remote-ip'
235 * vty: fix documentation for 'multi-arfcn (disable|enable)'
236 * vty: remove groundless statement about filler type 'dummy'
237 * vty: auto-generate cmd and doc strings for cfg_filler_type_cmd
238 * vty: fix documentation for 'ext-rach (disable|enable)'
239 * main: use logging API to print SIMD info instead of printf()
240 * doc/manuals: generate XML VTY reference at build-time
241 * vty: fix swapped documentation for 'filler type' command
242 * Transceiver: fix integer division in addRadioVector()
243 * Transceiver: use proper factor for amplitude scaling
244 * Add a (hidden) VTY parameter for Rx/Tx freq. shifting
245
246 [ Eric Wild ]
247 * osmo-trx-ipc
248
249 [ Alexander Couzens ]
250 * osmo-trx.spec: move ipc-driver-test into package ipc-test
251
252 [ Sylvain Munaut ]
253 * sigProcLib: fix C/I computation for 8-PSK modulated bursts
254
255 -- Pau Espin Pedrol <pespin@espeweb.net> Tue, 23 Feb 2021 14:27:15 +0100
256
Pau Espin Pedrolda7fee82020-01-03 19:54:00 +0100257osmo-trx (1.2.0) unstable; urgency=medium
258
259 [ Pau Espin Pedrol ]
260 * osmo-trx: log to stderr on signal received
261 * Drop old setPriority related code
262 * Transceiver: fix segfault during init if IP addr binding fails
263 * Transceiver: Check return value when binding IP addr for clock socket
264 * Transceiver: Clean up receival of downlink bursts
265 * Transceiver: Fix idle ul burst indications being dropped
266 * Transceiver: exit process when BTS drops connection
267 * Transceiver: Enable EDGE detection only on PDCH timeslots
268 * lms: Log available antennas if requested antenna fails
269 * device: Use LOGCHAN in set_antennas()
270 * Transceiver: Fix logging TN and version
271 * Transceiver: Use LOGCHAN in logRxBurst to unify log format
272 * Transceiver: Log error condition no burst in pullRadioVector()
273 * Transceiver: pullRadioVector(): Fix use of uninitialized value bi->tn
274 * Transceiver: Don't stop TRX if pulling from OFF timeslot
275 * radioInterface: Rename mRadio to mDevice
276 * radioInterfaceMulti: Check equals zero explicitly
277 * USRPDevice: Fix setRxGain return on error and getRxGain() returning always 0
278 * USRPDevice: Return previous txGain if setting value failed
279 * LMSDevice: Return previous txGain/rxGain if setting value failed
280 * radioInterface: Remove unusued getRxGain()
281 * radioDevice: Introduce getTxGain() API
282 * radioInterfaceMulti: Override setTxGain() to avoid chan!=0 calls
283 * UHDDevice: Drop unneeded MULTI_ARFCN checks
284 * radioInterface{Multi,Resamp}: Fix successful writeSamples() masking underrun from readSamples()
285 * radioInterface: Mark setRxGain as virtual
286 * Move multi-ARFCN chan amount modification from UHDDevice to parent class
287 * radioInterface: Atomically fetch and change underrun variable
288 * radioInterfaceMulti: write frequency offset direction (rx/tx) in log line
289 * Use new libosmocore logging lock API
290 * Transceiver: Fix wrong response upon CMD HANDOVER failure
291 * uhd: use value already cached in tmp variable
292 * Transceiver.cpp: Introduce and use new logging categories
293
294 [ Timo Jacobus ]
295 * Transceiver: Fixed copying of history into and from channelizer buffer.
296
297 [ Alexander Chemeris ]
298 * vty: Don't enable random filler bursts automatically with EDGE.
299 * vty: Simplify filler burst settings and improve help and readability.
300
301 [ Martin Hauke ]
302 * Fix common misspellings and typos
303
304 [ Harald Welte ]
305 * trx: exit() on unsupported positional arguments on command line
306
307 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 19:54:00 +0100
308
Pau Espin Pedrold0cbb162019-08-08 13:00:06 +0200309osmo-trx (1.1.1) unstable; urgency=medium
310
311 * UNRELEASED
312
313 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 08 Aug 2019 13:00:05 +0200
314
Pau Espin Pedrole774d522019-08-07 21:12:56 +0200315osmo-trx (1.1.0) unstable; urgency=medium
316
317 [ Sylvain Munaut ]
318 * arm/convolve: Fix the vfp4 real convolution for h_len=12
319 * convolve: Remove support for step, offset parameters
320 * tests: Rework the convolve_test
321 * tests: Re-enable the convolve_test by default
322 * sigProcLib: Add C/I (Carrier-to-Interference ratio) computation
323
324 [ Vadim Yanitskiy ]
325 * VTY: add extended (11-bit) RACH detection toggle
326 * doc/configuration.adoc: fix incorrect number of physical RF channels for B210
327 * driveTxPriorityQueue(): cosmetic: use proper type for TDMA TN
328 * driveTxPriorityQueue(): use trxd_hdr_common for message parsing
329 * driveTxPriorityQueue(): check if message header format is supported
330 * driveTxPriorityQueue(): enrich logging message
331 * trxd_fill_common(): fix TRXD header version coding
332 * manuals/configuration.adoc: fix copy-paste error in config example
333
334 [ Pau Espin Pedrol ]
335 * osmo-trx: Avoid handling signals after shutdown triggered
336 * osmo-trx: Use signalfd to serialize signals in main thread ctx
337 * osmo-trx: Check return code of osmo_fd_register
338 * lms: flush_recv: alloc buf on stack instead of heap
339 * lms: Improve log during flush recv error
340 * cosmetic: Threads.h: Remove trailing whitespace
341 * Move duplicated thread_enable_cancel to CommonLibs
342 * lms: Log underrun/overrun events
343 * lms: Remove references to ALERT loglevel
344 * lms: Remove unused var m_last_tx_overruns
345 * lms: Catch and log dropped packets by HW during recv
346 * cosmetic: uhd: Move smpl_buf out of UHDDevice, move UHDDevice class definition to .h
347 * uhd: smpl_buf: Drop UHD specifics out back to UHDDevice
348 * uhd: smpl_buf: Use TIMESTAMP type in str_status
349 * cosmetic: uhd: Use loglevel ERROR instead of ERR
350 * uhd: Avoid reallocation of buffers every read
351 * Move smpl_buf out of uhd dir to re-use it in other devices
352 * device: Drop unused numberRead/numberWritten APIs
353 * smpl_buf: Remove unused clk_rt variable
354 * smpl_buf: Remove unused clk_rt variable (fixup)
355 * smpl_buf: Remove dbg log line with duplicated info
356 * Introduce LOGCHAN macro to standarize logging channel info
357 * smpl_buf: Move it to device/common and create libdevice_common.la
358 * lms: Use smpl_buf to recover from timestamp jumps
359 * lms: Fix stream_stats checks with droppedPackets
360 * Add rate_ctr support to store/retrieve SDR errors through VTY
361 * Rename and move STOP signal from Transceiver to main
362 * doc: vty: Update trx_vty_reference.xml
363 * lms: Drop unusued variable masterClockRate
364 * lms: Fix stream_stats checks with overrun/underrun
365 * Add VTY commands to set error ctr thresholds
366 * Remove AUTHORS file
367 * trx_{vty,rate_ctr}: Set proper license AGPLv3+
368 * Introduce structs to encode TRXD packets
369 * Transceiver: refactor: gather uplink burst parameters in struct
370 * Transceiver: Drop unused rssi_valid struct field
371 * Transceiver: Move nbits burst size calculation to pullRadioVector()
372 * Transceiver: Move calculation of normalized values (rssiOffset) to pullRadioVector()
373 * Transceiver: Move soft bits normalization to pullRadioVector()
374 * Transceiver: Drop use of GSM::Time from trx_ul_burst_ind
375 * Transceiver: Get rid of SoftVector in struct trx_ul_burst_ind
376 * Transceiver: replace UDPSocket with libosmocore socket API
377 * Transceiver: Avoid noise calculation formula in 2 branches in pullRadioVector
378 * Transceiver: Simplify code on early error return when calling detectAnyBurst
379 * Transceiver: pullRadioVector(): Move initialization of var to start of function
380 * Transceiver: Support pulling idle frames in pullRadioVector()
381 * sigProcLib: detectAnyBurst() family: Use struct to gather all out params
382 * sigProcLib: detectAnyBurst(): make TSC used to detect burst available to caller
383 * Logger: global Log mutex is now available from C code
384 * Transceiver: Move out TRXD socket send code to prepare for TRXDv1
385 * Transceiver: Support SETFORMAT command
386 * Transceiver: Support TRXD v1
387 * Transceiver: Initialize mExtRACH in constructor
388 * debian/copyright: Remove non existent radioInterfaceDiversity.cpp from list
389 * debian/copyright: Update wrong paths in license list
390 * debian/copyright: Add missing file Utils.* to LGPL-2.1+ list
391 * cosmetic: Fix trailing whitespace in several files
392 * Add SPDX annotation
393 * Bind CTRL port to IP addr specified in VTY config
394 * Transceiver: Store TRXD version per channel
395 * Transceiver: Clean up code passing parameters to threads
396 * Remove empty ChangeLog fnd NEWS files
397 * Remove unused autogen.sh
398 * radioInterface: Clarify how underruns are handled driving a radioDevice
399 * usrp1: don't check for non-null underrun pointer
400 * jenkins.sh: Workaround libusrp build race conditon
401 * lms: Drop rx_underruns rate ctr, add tx_drop_* rate ctr
402 * Move inband-signaling-usb documentation to UserManual
403 * Move matlab files under utils/matlab
404 * Move Transceiver52/README to UserManual
405 * Move README.DFEsymbolspaced to utils/matlab
406 * Move std_inband.rbf under device/usrp1/ dir
407 * Drop old README information, provide new updated README
408 * Transceiver: Add missing include netinet/in.h
409 * Require newer version of libosmocore to avoid build failure
410
411 [ Tom Tsou ]
412 * multi-ARFCN: fix maximum number of carriers limitation
413
414 [ Harald Welte ]
415 * use BSC_FD_READ and not OSMO_FD_READ
416 * proto_trxd.c: Use bit-wise AND, not boolean AND
417 * Timeval: Restore output stream flags after changing them
418 * ChannelizerBase: fix initialization of class members
419 * CorrelationSequence: fix initialization of class members
420 * radioInterface.cpp: Fix missing member initialization of RadioInterface()
421
422 [ Joachim Steiger ]
423 * lms: Remove wrong unused code copied from -uhd
424 * lms: move LMS_EnableChannel from Start/Stop to Open/Close device
425 * lms: move LMS_GetLPFBWRange and LMS_Calibrate calls from open to start
426 * lms: add device type detection and device specific gains
427 * lms: properly call close if set_antennas() fails, add some comments
428
429 [ Oliver Smith ]
430 * debian: create -doc subpackage with pdf manuals
431 * contrib/jenkins.sh: run "make maintainer-clean"
432
433 [ Eric Wild ]
434 * Add option to set stack size in config file, default == 0 == OS default
435
436 [ Ruben Undheim ]
437 * Fix spelling discovered by lintian
438
439 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 21:12:56 +0200
440
Harald Welted20b7fa2019-01-20 19:35:05 +0100441osmo-trx (1.0.0) unstable; urgency=medium
442
443 [ Pau Espin Pedrol ]
444 * doc: examples: Add umtrx sample config
445 * UHDDevice: Fix setup failure with LimeSuite > 18.04.1
446 * examples: Set rt-prio 18 and print file basename
447 * lms: Several improvements and compilation/runtime fixes
448 * build: Add support for LimeSuite device backend
449 * LMSDevice: Set correct values for Max{Tx,Rx}Gain
450 * LMSDevice: Fix setup failure with LimeSuite > 18.04.1
451 * lms: Makefile.am: Reorder params to fix link issue
452 * lms: Check LPBFW to set is within supported range
453 * debian: Add package osmo-trx-lms
454 * contrib: Add systemd services for all backends
455 * debian: Add cfg file examples for osmo-trx-{lms,uhd}
456 * Add -V param to print version
457 * lms: Allow values diff than 34dB to be set by setRxGain()
458 * Use correct paths when installing example files
459 * debian: Enable build of osmo-trx-lms
460 * debian: Explicitly enable osmo-trx-uhd build
461 * configure.ac: Fix typo in with-lms help string
462 * vty: Fix typo in gpsdo clock reference type
463 * configure.ac: Add --enable-werror option
464 * Logger: Disable pthread cancel point inside Logger destructor
465 * cosmetic: Fix trailing whitespace
466 * radioInterface: forward errors from RadioDevice to Transceiver in recv path
467 * lms: Return error on device read timeout
468 * osmo-trx: Add osmo_signal to stop whole transceiver chain correctly on error
469 * radioInterface: Fix variable storing integer return value
470 * configure.ac: Specify default language as C++
471 * UHHDDevice: Replace deprecated header uhd/utils/thread_priority.hpp
472 * SigProcLib: Use available copyTo Vector API instead of memcopy
473 * cosmetic: Fix trailing whitespace in several files
474 * radioInterfaceMulti:pullBuffer: Sanely convert float array to complex array
475 * Vector: Copy arrays in a sane way for non-trivially copyable types
476 * jenkins.sh: Add --enable-werror flag to osmo-trx configure step
477 * Install systemd services with autotools
478 * Install sample cfg file to /etc/osmocom
479 * cosmetic: Use proper whitespace in several for loops
480 * Use pthread_setname_np to name threads
481 * CommonLibs/Makefile.am: Specify libcommon_la_LIBADD
482 * Transciever: Log values causing Tx underrun
483 * examples: Use logging level 'set-all' instead of 'all'
484 * jenkins.sh: Enable build of osmo-trx-lms
485 * ChannelizerBase: Fix ASan alloc-dealloc-mismatch
486 * UHDDevice: setRxGain on chan 0 when using multi-arfcn
487 * lms: Use LimeSuite.h log level defines instead of hardcoded values
488 * lms: Apply LMS->OSMO log level conversion
489 * Introduce OsmoTRX manual
490 * Introduce chapter trx_if.adoc and add it to OsmoTRX and OsmoBTS
491 * trx: Add reference to project wiki page in overfiew section
492 * trx: Add Hardware architecture support section
493 * trx: Add Hardware device support section
494 * osmotrx: Split Device specific section from backend one
495 * osmotrx: Write initial documentation for several supported devices
496 * osmotrx: configuration: Add section to document multi-arfcn feature
497 * osmotrx: Create a common chapter for section documenting backends
498 * osmotrx: Introduce code architecture chapter
499 * lms: Fix start after stop of device
500 * lms: Destroy streams on device stop
501 * radioInterface: Fix memleak during close()
502 * PointerFIFO: Fix memleak of ListNode
503 * lms: Make sure LMS_Close is called when Device is torn down
504 * osmo-trx: Change some lines to use libosmocore logging instead of cout
505 * lms: Close device on LMS_Init failure
506 * SigProcLib: Improve Vector buffer allocation mess
507 * lms: Allow setting Tx/RxGain for chan!=0
508 * lms: Allow setting Tx/RxFreq for lchan!=0
509 * lms: Improve Set{Rx,Tx}{Gain,Freq} logging
510 * transceiver: log chan on CTRL command received
511 * Add TRXCTRL log category
512 * transceiver: Log TRXCTRL iface responses towards osmo-bts-trx
513 * lms: Move {under,over}run checks into separate method
514 * lms: Do {under,over}run checks even if LMS_RecvStream fails
515 * Timeval: passed() returns true if time is equal
516 * Timeval: Move implementation to use clock_gettime and timespec
517 * Timeval: Move to osmo_clock_gettime
518 * TimevalTest: Make test deterministic with fake time
519 * lms: Fix build against LimeSuite > 18.10
520 * configure.ac: check boost only if USRP1 support is enabled
521
522 [ Vadim Yanitskiy ]
523 * trx_vty.c: fix: use CONFIG_NODE as parent by default
524 * device/lms/LMSDevice.cpp: fix compilation warning
525 * sigProcLib: introduce both TS1 and TS2 RACH synch. sequences
526 * sigProcLib: add a CorrType for extended (11-bit) RACH
527
528 [ Harald Welte ]
529 * Initial work towards direct LimeSuite support in OsmoTRX
530 * update .gitignore to include osmo-trx-lms
531 * LMSDevice: Call LMS_Init() before setting sample rate
532 * LMSDevice: Print sample rate range + actual sample rate after setting it
533 * LMSDevice: Typo fix: s/Internal/External
534 * LMSDevice: Set low-pass filters to smallest possible option
535 * LMSDevice: Fix initial timestamp offset of 2500
536 * LMS_Device: Set ts_offset to 0.
537 * LMSDevice: Reduce Rx logging verbosity: Only log unexpected timestamps
538 * move set_antennas() from UHD to generic radioDevice base class
539 * lms: Fix support for rx_paths / tx_paths
540 * lms: Call set_antennas() during open() method
541 * radioDevice: Move tx_sps from derived into base class
542 * radioDevice: better encapsulation in base class
543 * lms: Fix coding style
544 * lms: Fail in case of unsupported configuration
545 * usrp1: Fail in case of unsupported configuration
546 * Fix config file saving of {tx,rx}-path VTY config strings
547 * logging: Introduce new "DDEV" category for device-specific code
548 * update git-version-gen to generate proper version numbers
549 * ensure well-formed example config files
550 * SocketsTest.testReaderIP(): Zero terminate received buffer
551 * trx_validate_config(): Fix validation of rx_sps
552 * vty-ref: Update URI of docbook 5.0 schema
553 * lms: User correct scale factor for transmit samples
554 * lms: Set Rx gain to midpoint, as comment suggests.
555 * usrp1: Remove uninitialized skipRx logic
556 * usrp1: Fix formatting of log message (missing space)
557 * cosmetic: Don't call the SDR "USRP" in error message
558
559 [ Zydrunas Tamosevicius ]
560 * lms: Use same timestamp offset like when using LimeSDR via UHD
561 * lms: Reduce log level of "send buffer of len ..."
562 * lms: fix LMS_StartStream() handling for multiple channels
563 * lms: Reduce Rx gain from 47 to 34 dB
564
565 [ Alexander Couzens ]
566 * debian: add patches for debian8
567
568 [ Oliver Smith ]
569 * Add long parameters (--help, --version, ...)
570 * build manuals moved here from osmo-gsm-manuals.git
571 * Fix DISTCHECK_CONFIGURE_FLAGS override
572 * contrib/jenkins.sh: build and publish manuals
573 * jenkins.sh: run "make distcheck"
574 * contrib: fix makedistcheck with disabled systemd
575 * osmo-trx.cpp: move comma_delimited_to_vector() to Utils.cpp
576 * LMSDevice: make use of dev-args in osmo-trx.cfg
577 * LMSDeviceTest: fix link errors on OBS
578
579 [ Neels Hofmeyr ]
580 * Importing history from osmo-gsm-manuals.git
581
582 [ d0gtail ]
583 * UHDDevice: log exception information on device open failure
584
585 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 19:35:04 +0100
586
Pau Espin Pedrold0ac9262018-05-03 16:23:30 +0200587osmo-trx (0.4.0) unstable; urgency=medium
588
589 [ Neels Hofmeyr ]
590 * jenkins: use osmo-clean-workspace.sh before and after build
591
592 [ Harald Welte ]
593 * SocketsTest: Fix printing of non-nul-terminated string
594 * Revert "debian: Remove osmo-trx-usrp1 until we can build libusrp1.deb"
595 * debian/control: Remove "Maintainer" from binary package section
596 * debian/rules: Make sure we always require libusrp
597 * debian: Ensure USRP1 firmware is part of osmo-trx-usrp1
598 * debian/control: Add build dependency to libusrp-dev
599 * update .gitignore for new executable names
600 * osmo-trx: s/GSM Core Address/GSM BTS Address/
601
602 [ Piotr Krysik ]
603 * UHDDevice.cpp: add USRP B205mini support
604
605 [ Max ]
606 * Mark release target as virtual
607 * Remove outdated references to OpenBTS
608 * Remove unused headers
609 * Update installation instructions
610 * Update legal disclaimer
611 * Update license notes
612 * tests: null-terminate buffer
613
614 [ Pau Espin Pedrol ]
615 * cosmetic: Remove trailing whitespace
616 * Logger: Stop using Log.Alarms.Max from config
617 * Logger: Stop using Log.File and Log.Level from config
618 * Drop use of ConfigurationTable gConfig
619 * Remove Configuration module and libsqlite dependency
620 * cosmetic: AUTHORS: fix trailing whitespace
621 * Set up GNU Autotest infrastructure
622 * tests: InterThread: adapt to have reproducible output and enable autotest
623 * tests: Timeval: adapt to have reproducible output and enable autotest
624 * tests: Log: adapt to have reproducible output and enable autotest
625 * Sockets.cpp: Fix initialization of UDD socket
626 * tests: Sockets: adapt to have reproducible output and enable autotest
627 * utils/convolvtest: Remove uneeded libosmocore dependency
628 * Move ARCH_LA to Makefile.common
629 * tests: Migrate convtest util to autotest infrastructure
630 * arm/convert.c: Fix compilation error
631 * arm/convert.c: Add missing convert_init implementation
632 * .gitignore: Add missing test related files
633 * Remove UDDSocket class
634 * tests: SocketTests: Pick OS-assigned instead of setting one manually
635 * tests: SocketsTest: Avoid hang forever if test fails
636 * tests: SocketsTest: Fail test on write fail
637 * tests: TimevalTest: refactor and avoid double comparison
638 * contrib/jenkins.sh: Use qemu+proot+debootstrap to run tests with ARM instruction set
639 * tests: convolve: Disable due to difference in output in different archs
640 * Remove unneeded libdl dependency
641 * Fix whitespace
642 * Add support to set Rx/TxAntenna
643 * UHDDevice: Initialize async_event_thrd in constructor
644 * Logger: Drop unused gLogEarly
645 * Logger: Remove unused logging macros
646 * Logger: get rid of alarm APIs
647 * Logger: Drop syslog support
648 * Logger: Drop support to log into file
649 * Logger: Remove unused includes
650 * Logger: Remove gLogToConsole flag
651 * configure.ac: Check for pkg-config
652 * Depend on libosmocore
653 * osmo-trx: set up signals using libosmocore helpers
654 * osmo-trx: Set up talloc ctx
655 * debian: Depend on libtalloc and libosmocore
656 * Add initial support for logging, vty, ctrl
657 * Logger: Use libosmocore logging system
658 * osmo-trx.cpp: Move trx start and stop to helper functions
659 * Move enums required by VTY to a separate header
660 * vty: Implement VTY cfg parsing for current parameters
661 * doc: Add sample cfg file for LimeSDR
662 * osmo-trx: Use VTY cfg structures while still allowing cmd line options
663 * osmo-trx: Re-introduce -l cmd line parameter
664 * Makefile.am: Avoid using subdir if arch is not required
665 * Build Transceiver52M/common as an .la lib
666 * use osmo_init_logging2()
667 * tests: Makefile.am: Fix typo in include path
668 * configure.ac: Add --enable-sanitize option
669 * Move arch specific fiels to arch subdir
670 * Move device specific files to device subdir
671 * Change configure define USRP1 to DEVICE_USRP1
672 * Move device specific code out of radioInterface
673 * Transceiver: Move device specific code to radioDevice class
674 * Build one osmo-trx binary for each device support enabled
675 * Logger: Print correct source file and line number
676 * Transceiver: log timing info of stale bursts
677 * build: Fix make distcheck
678 * build: More OBS build failure fixes
679 * jenkins.sh: Enable build of osmo-trx-usrp1
680 * debian: Remove osmo-trx-usrp1 until we can build libusrp1.deb
681 * debian: Fix OBS build
682 * build: Fix OBS build for ARM
683 * git-version-gen: Take into account tags not in master
684
685 [ Alexander Huemer ]
686 * Unbreak `./configure --with-usrp1` build
687 * Fix USRP1 build with support for setting Rx/TxAntenna
688
689 [ Alexander Couzens ]
690 * jenkins.sh: fix the download url if the qemu image wasn't setup
691 * jenkins.sh: cleanup always the workspace
692 * jenkins.sh: change qemu-img default location to $HOME/qemu-img instead of /opt/qemu-img
693
694 [ Vadim Yanitskiy ]
695 * Transceiver.cpp: use a define for the MAX_PACKET_LENGTH
696 * Transceiver.cpp: properly zero-terminate received commands
697 * Transceiver.cpp: use pointer arithmetics for CMD parsing
698 * Transceiver.cpp: fix incorrect format string for SETTSC
699 * Transceiver.cpp: prevent out-of-range array access
700
701 [ Martin Hauke ]
702 * configure.ac: Fix typo
703
704 [ Philipp Maier ]
705 * doc: add example config for usrp B200 series
706
707 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:23:29 +0200
708
Harald Welte78e1cd22017-10-28 17:52:32 +0200709osmo-trx (0.2.0) unstable; urgency=medium
710
711 [ Alexander Chemeris ]
712 * EDGE: Add support for UmTRX.
713 * Common: Get rid of a compilation warning.
714 * Common: Make sure gLogEarly() log to the same facilities as the normal log.
715 * transceiver: Properly handle MAXDLY.
716 * transceiver: Add an option to generate random Access Bursts.
717 * osmo-trx: Output Rx SPS as a part of configuration output.
718 * transceiver: Do not pass transceiver state struct to function where it's not used.
719 * makefile: Fix build from an external path.
720 * radioDevice: GSMRATE macro must have parentheses around its definition.
721 * uhd: Fix comment.
722 * radioInterface: Initialize power scale with a meaningful default.
723 * transceiver: Log channel number in DEBUG output of demoded bursts.
724 * transceiver: Add an option to emulate a RACH delay in random filler mode.
725 * UHD: Initial LimeSDR support.
726 * CommonLibs: Remove unused files.
727 * sigProcLib: Typo sybols -> symbols
728 * radioBuffer: Remove extra ; at the end of inline function definitions.
729 * sigProcLib: Fix documentation, sync argument names in .cpp and .h files.
730 * sigProcLib: make energyDetect() simpler by returning actual energy.
731 * sigProcLib: Rename demodulateBurst() to demodGmskBurst() for clarity.
732 * sigProcLib: Slice SoftVector instead of signalVector for GMSK demod.
733 * Call vectorSlicer() right before packing bits for transmission to osmo-bts.
734 * CommonLibs: Print soft bits with less confidence to console when printing a soft vector.
735 * BitVector: Remove convolutional codec - we don't use it in osmo-trx.
736 * BitVector: Convert SoftVector from 0..1 to -1..+1 soft bits.
737 * signalVector: Implement segment().
738 * vector: Introduce segmentMove() method to move data inside of a vector.
739 * vector: Introduce shrink() function to shrink vector size without loosing data.
740 * Move CorrType type from Transceiver to sigProcLib.
741 * sigProcLib: rename signalError type to SignalError.
742 * Move Transceiver::detectBurst() to sigProcLib to make it reusable.
743 * Move BURST_THRESH from Transceiver.cpp to sigProcLib.h to make it reusable.
744 * sigProcLib: Add operator<< to print CorrType to a string.
745 * sigProcLib.h: Fix whitespaces. No non-whitespace changes.
746 * Move Transceiver::demodulate() to sigProcLib to make it reusable.
747 * sigProcLib: constify signalVector arguments for detectBurst() functions.
748 * sigProcLib: Constify demodulation functions burst argument.
749 * sigProcLib: Fix number of tail bits in random Normal Bursts and zero Stealing Bits.
750 * Configuration: Variables allocated with 'new' must be freed with 'delete'.
751 * BitVector: Remove Generator class.
752 * PRBS: a Pseudo-random binary sequence (PRBS) generator class.
753
754 [ Tom Tsou ]
755 * EDGE: Fix USRP B210 device support
756 * uhd: Correct timing alignment in 8-PSK and GMSK downlink bursts
757 * EDGE: Fix demodulation slicer input
758 * common: Restrict UDP binding to localhost only
759 * common: Add mandatory length field to UDP receive calls
760 * uhd: Update default E3XX settings
761 * uhd: Set default Tx sampling to 4 sps
762 * uhd: Make device offset check a private method
763 * uhd: Set minimum UHD version requirement for E3XX
764 * sigproc: Expand RACH, TSC, and EDGE correlation windows
765 * transceiver: Do not report error on SETTSC when radio is on
766 * transceiver: Add Rx samples-per-symbol option
767 * radioInterface: Convert diversity argument to general type
768 * iface: Add inner ring-buffer implementation
769 * mcbts: Add multi-ARFCN channelizing filters
770 * mcbts: Add multi-ARFCN radio support
771 * sigproc: Adjust burst detection threshold criteria
772 * egprs: Enable 8-PSK length vectors on the Tx interface
773 * egprs: Enable 8-PSK burst detection when EDGE is enabled
774 * transceiver: Remove HANDOVER warnings
775 * mcbts: Allow out of order channel setup
776 * radioInterface: Fix multi-channel buffer index bug
777 * uhd: Add command line option for GPS reference
778 * transceiver: Fix mixed GSMK / 8-PSK transmission
779 * transceiver: Fix 4 SPS receive TOA value
780 * sigproc: Fix missing 8-PSK tail symbols
781 * uhd: Update USRP2/N200/N210 for 4 SPS Rx
782 * sigproc: Match differential GMSK start/end bits to tail bits
783 * uhd: Add missing B200 sample timing for 4 SPS receive
784 * transceiver: Fix command build warning
785 * uhd: Set minimum supported version to 3.9.0
786 * uhd: Add X300 sample timing for 4 SPS
787 * Revert "uhd: Set minimum supported version to 3.9.0"
788 * uhd: Add support for UHD-3.11 logging control
789 * uhd: Increase MC-BTS FPGA clock rate to 51.2 MHz
790 * Resampler: Fix initialization return checking
791 * sigProcLib: Remove unreachable code and no-effect checks
792 * sigProcLib: Check return status on downsampling
793 * sigProcLib: Fix negative value check on unsigned value
794 * Resampler: Fix non-array delete for filter taps
795 * Transceiver: Remove unsigned negative compares
796 * Configuration: Fix const and signedness compile warnings
797 * config: Remove OpenBTS style sqlite configuration
798 * radioInterface: Remove UmTRX 'diversity' option
799 * build: Require and check for gcc C++11 support
800 * uhd: Use map container for for device parameter access
801 * sigProcLib: Remove unused functions from public interface
802 * uhd: Add non-UmTRX channel swap support
803 * uhd: Fix Tx-RX timing offset setting
804 * uhd: Fix USRP2/N200/N210 device detection
805 * transceiver: Fix POWEROFF crash on USRP2/N200/X300 devices
806 * sigProcLib: Fix complex/real vector flag in Laurent modulator
807 * sigProcLib: Remove heap based signal vector allocations
808 * common: Declare explicit Vector move constructor
809 * sigProcLib: Remove trigonometric tables
810 * sigProcLib: Use explicit NaN check in sinc table generation
811 * sigProcLib: Replace dynamically allocated resampling buffers
812 * sigProcLib: Specify standard namespace for isnan()
813 * uhd: Always specify samples-per-symbol for device lookup
814 * LimeSDR: set approximate tx offset value to make GSM work
815
816 [ Neels Hofmeyr ]
817 * add basic .gitignore
818 * configure.ac: check for boost/config.hpp header
819 * The INSTALL file is being overwritten by autoreconf, but it is committed as empty file. As a result, the INSTALL file always shows as modified. Instead, remove INSTALL from git and ignore it.
820 * add contrib/jenkins.sh, for gerrit build bot
821
822 [ pierre.baudry ]
823 * transceiver: Fix mismatched allocations and deallocations
824
825 [ Holger Hans Peter Freyther ]
826 * debian: Require fftw3 header files for osmo-trx
827
828 [ Max ]
829 * Add gerrit settings
830 * Integrate Debian packaging changes
831 * Remove embedded sqlite3
832 * Fix building against sqlite3
833 * Add autoconf-archive to dependencies
834 * debian: remove obsolete dependency
835 * deb: remove unused dependency
836 * Remove redundant explicit dependency
837 * Use release helper from libosmocore
838
839 [ Ruben Undheim ]
840 * Do not embed sqlite3 when building
841
842 [ Philipp Maier ]
843 * buildenv: Turn off native architecture builds
844 * cosmetic: Make parameter lists uniform
845 * Add test program to verify convolution implementation
846 * ssedetect: Add runtime CPU detection
847 * cosmetic: remove code duplication
848 * buildenv: Make build CPU invariant
849 * buildenv: Split up SSE3 and SSE4.1 code
850 * cosmetic: Add info about SSE support
851
852 [ Vadim Yanitskiy ]
853 * buildenv: correct the ax_sse macro description
854 * buildenv: actually strip unused cpuid functionality
855 * buildenv: fix build on systems without SIMD support
856 * buildenv: cosmetic changes
857 * buildenv: check for __builtin_cpu_supports call support
858 * ssedetect: call __builtin_cpu_supports() only if supported
859
860 [ Pau Espin Pedrol ]
861 * cosmetic: transciever: Remove trailing whitespaces
862 * transceiver: Avoid sending clock indications when trx is not powered on
863 * Add -j option to bind to specific address
864
865 [ ignasj ]
866 * LimeSDR: Change device detection to work with USB and PCIe versions
867 * LimeSDR: change tx window type to TX_WINDOW_FIXED
868 * LimeSDR: Fix sample value range
869
870 [ Harald Welte ]
871 * Add '-t' command line option to enable SCHED_RR
872 * Import git-version-gen and update AC_INIT()
873
874 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 17:52:32 +0200
875
Holger Hans Peter Freytherd17b1892016-03-18 20:13:23 +0100876osmo-trx (0.1.9) trusty; urgency=medium
877
878 * Ask Ivan, really
879
880 -- Kirill Zakharenko <earwin@gmail.com> Thu, 16 Jul 2015 12:13:46 +0000
881
882osmo-trx (0.1.8) precise; urgency=low
883
884 * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP
885
886 -- Ivan Klyuchnikov <Ivan.Kluchnikov@fairwaves.ru> Sun, 9 Mar 2014 14:10:10 +0400