blob: 024777fccc76676bc3a9c7144d5bd24c6b6ab45d [file] [log] [blame]
Pau Espin Pedrola39fa872022-06-29 09:32:56 +02001osmo-trx (1.4.1) unstable; urgency=medium
2
3 [ Oliver Smith ]
4 * treewide: remove FSF address
5
6 [ Vadim Yanitskiy ]
7 * tests: use 'check_PROGRAMS' instead of 'noinst_PROGRAMS'
8
9 [ Harald Welte ]
10 * update git URLs (git -> https; gitea)
11
12 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 29 Jun 2022 09:32:56 +0200
13
Pau Espin Pedrola7143d32021-11-16 16:27:26 +010014osmo-trx (1.4.0) unstable; urgency=medium
15
16 [ Pau Espin Pedrol ]
17 * Threads.cpp: Fix missing extern C around libosmocore include
18 * Drop logging pthread ID
19 * Threads: Avoid printing pthread_self()
20 * ipc: Makefile.am: Clean LDADD variable
21 * Use new stat item/ctr getter APIs
22 * detectBurst(): Clear downsampling code path
23 * detectBurst(): constify parameter
24 * computeCI(): Constify param and pass it as reference
25 * computeCI(): Rename verbose repeated getter to constant
26 * computeCI(): Constify read-only variable
27 * detectGeneralBurst(): Increase log level about clipping to INFO
28 * cosmetic: Fix typo in comment
29 * computeCI: Document hardcoded multiplier
30 * lms: Drop duplicated check
31 * lms,uhd: Validate band of RxFreq too
32 * lms,uhd: Skip re-assigning same band
33 * lms,uhd: Allow changing band between poweroff & poweron
34
35 [ Vadim Yanitskiy ]
36 * gitignore: remove non-existing 'doc/manuals/osmomsc-usermanual.xml'
37 * ctrl_sock_handle_rx(): fix missing space in LOGCHAN() statement
38 * trx_rate_ctr: use thread safe strerror() in device_sig_cb()
39 * IPCDevice: use thread safe strerror_r() instead of strerror()
40 * IPCDevice: check value returned from select()
41 * LMSDevice: LMS_GetDeviceList() may return a negative number
42
43 [ Eric ]
44 * add hidden fn adjustment command
45 * uhd: ensure configured clock source is actually used
46 * vty: printing fn offset should be signed
47 * lms: init band
48
49 [ Oliver Smith ]
50 * d/patches/build-for-debian8.patch: remove
51
52 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 16 Nov 2021 16:27:26 +0100
53
Harald Welte90d84172021-02-28 11:32:12 +010054osmo-trx (1.3.1) unstable; urgency=medium
55
56 * mark uhddev_ipc.cpp as BUILT_SOURCES
57
58 -- Harald Welte <laforge@osmocom.org> Sun, 28 Feb 2021 11:32:11 +0100
59
Pau Espin Pedrol309ad4d2021-02-23 14:27:15 +010060osmo-trx (1.3.0) unstable; urgency=medium
61
62 [ Pau Espin Pedrol ]
63 * Make logging category DLMS generic and reusable for other backends
64 * uhd: Use DEVDRV log category and support UHD >=3.11 logging framework
65 * uhd: Improve some logging lines printing UHD pretty-print output
66 * doc: clarify number of channels on B210 with multi-arfcn enabled
67 * radioInterfaceMulti: Fail to tune on freq not following multi-arfcn restrictions
68 * doc: Update vty reference xml file
69 * lms: Move initialization of field started to constructor
70 * lms: Drop unused define
71 * smpl_buf: Fix str_code() param and print unknown error val
72 * lms: Improve smpl_buf error logging
73 * lms: Change radioDevice constructor arg name to avoid masking instance attr
74 * lms: Make reference to std::vector unambiguous
75 * lms: Move rx_buffers allocation to constructor
76 * lms: Store device type specific parameters in one place
77 * lms: Make ts_offset and smpl rate coefs device-specific
78 * lms: Initial multi-arfcn support
79 * contrib/jenkins.sh: Reorder sanity checks
80 * debug.h: Avoid printing pthread_t type
81 * debug.h: Fix print format of chan in CLOGCHAN
82 * cosmetic: fix several typos found by codespell
83 * radioDevice: Drop unused RSSI param from readSamples API
84 * radioDevice: Drop unused isControl param from WriteSamples API
85 * Use OSMO_FD_READ instead of deprecated BSC_FD_READ
86 * Transceiver: Fix extra space in RSP NOISELEV error
87 * Transceiver: Implement TRXC cmd NOMTXPOWER
88 * UHDDevice: Implement getNominalTxPower() based on TxFrequency
89 * radioInterface: Operate on real Tx power attenuation rather than on device specific gains
90 * UHDDevice: Compute TxGain on UHD API based on expected Tx output power
91 * proto_trxd: Fix UndefinedBehaviorSanitizer from ubsan
92 * Transceiver: Allow sending negative nominal tx power in RSP NOMTXPOWER
93 * LMSDevice: Compute TxGain on LimeSuite API based on expected Tx output power
94 * Drop old TxGain APIs from parent radioDevice abstract class
95 * {UHD,LMS}Dervice: Log expected resulting TxPower when setting device specific TxGain
96 * cosmetic: trx_rate_ctr: Fix whitespace
97 * trx_rate_ctr: Fix immediate rescheduling on per-sec thresholds
98 * Rename device specific rate counter multi-thread helpers
99 * Introduce rate counter tx_stale_bursts
100 * TransceiverState: Initialize ctrs field in constructor
101 * doc/manuals: Update thread documentation after dropping CTRL sock threads
102 * trx_rate_ctr: Fix locking wrong mutex
103 * Introduce rate counters to detect issues in received Dl bursts from TRXD
104 * Transceiver: Fix race condition obtaining Dl burst from Upper layer
105 * Add rate counter for missing Txbursts when scheduled towards the radioInterface
106 * Transceiver: Provide initial value for TransceiverState::mFiller in constructor
107 * Transceiver: Use already obtained value from Rx msg structure
108 * Transceiver: Restrict conditions where FN gaps are detected
109 * trx_rate_ctr: Lower some log levels
110 * Introduce CTR log category
111 * Transceiver: Lower some log levels which have an associated counter
112 * Transceiver: Check log level before generating burst str representation
113 * Transceiver: Add several rate_ctr for rx error conditions
114 * Use new libosmovty cpu sched config features
115 * debian: Update debian8 osmo-trx specific patch
116 * jenkins.sh: Verify distro-specific patches apply
117 * ipc: fix var declaration in for loop
118 * Add support for TRXC MUTE command
119 * arch: x86: Fix convolve optimizations breaking signal
120 * contrib/jenkins: Enable parallel make in make distcheck
121 * Transceiver: Pass config struct instead of large list of params
122 * Calculate RSSI offset based on RxGain configuration
123 * main: generate coredump and exit upon SIGABRT received
124 * ipc: Fix wrong reference to BTS in log line
125 * ipc-driver-test: Allow setting dir prefix for UD socket
126 * radioInterfaceMulti: Fix memory leak upon close()
127 * ChannelizerBase: Fix memory leak
128 * Threads.cpp: Use already existing gettid wrapper function
129 * Replace my_gettid with libosmocore osmo_gettid API
130 * tests: Explicitly drop category from log
131 * tests: Replace deprecated API log_set_print_filename
132
133 [ Philipp Maier ]
134 * debug: use LOGL_NOTICE for log category DDEV
135 * doc: do not set the base-port of the trx
136 * doc: apply an rssi-offset of 28 by default.
137 * doc: switch log levels to notice
138 * Transceiver: Log when sending of CLK indications begins
139 * vty: add attributes to VTY commands indicating when they apply
140 * osmo-trx: add commandline option --vty-ref-xml
141
142 [ Eric ]
143 * configure.ac: fix libtool issue with clang and sanitizer
144 * transceiver: check the right vector
145 * transceiver: get rid of the ctrl threads
146 * add kernel style .clang-format with 120 chars per line limit
147 * devices: reset internal smart sample buffers upon stop
148 * transceiver: optimize code if optimizations are enabled
149 * transceiver: initialize reorder flag so we don't miscount
150
151 [ Harald Welte ]
152 * PRBS tool sending PRBS sequence to TRX
153 * prbs-tool: Add error simulation capabilities
154 * utils: Ensure content of this directory is included in 'make dist'
155 * prbs-tool: Don't require C99
156 * RPM spec file: Require uhd-firmware for osmo-trx-uhd
157 * osmo-trx.spec.in: Use %config(noreplace) to retain current config file
158 * Fix build on Debian8
159 * [cosmetic] radioInterfaceMulti: More comments
160 * [cosmetic] radioIntefaceMulti: Fix whitespace / indent
161 * ipc: Use OSMO_FD_* instead of deprecated BSC_FD_*
162 * Use osmo_fd_setup() wherever applicable
163 * Use osmo_fd_*_{disable,enable}
164 * README update
165 * manual: Fix typo OsmTRX -> OsmoTRX
166
167 [ Oliver Smith ]
168 * contrib: import RPM spec
169 * contrib: integrate RPM spec
170 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
171 * contrib/jenkins: don't build osmo-gsm-manuals
172 * configure.ac: set -std=gnu11
173
174 [ Vadim Yanitskiy ]
175 * UHDDevice: catch LookupError/IndexError in set{Rx,Tx}Antenna()
176 * debian/control: change maintainer to the Osmocom team / mailing list
177 * proto_trxd: cosmetic: 'if' is not a function, add space
178 * vty: add multi-ARFCN specific warning for chan N > 0
179 * radioDevice: fix set_antennas(): consider MULTI_ARFCN mode
180 * device/lms: fix: 'trx_vty.h' header requires C linkage
181 * device/lms: fix missing semicolon in LMSDevice::assign_band_desc()
182 * device/lms: get rid of 'using namespace std'
183 * device/common/Makefile.am: remove $(LMS_CFLAGS) from AM_CXXFLAGS
184 * main: add --vty-ref-mode, use vty_dump_xml_ref_mode()
185 * device: drop unreasonable LIBOSMO{CTRL,VTY}_{CFLAGS,LIBS}
186 * Transceiver: use size_t and ARRAY_SIZE() in constructor
187 * Transceiver: explicitly init m{Rx,Tx}LowerLoopThread
188 * vty: fix documentation for 'swap-channels (disable|enable)'
189 * vty: fix documentation for 'egprs (disable|enable)'
190 * vty: fix documentation for 'rx-sps (1|4)' and 'tx-sps (1|4)'
191 * vty: cosmetic: use VTY_IPV4_CMD in 'bind-ip' / 'remote-ip'
192 * vty: fix documentation for 'multi-arfcn (disable|enable)'
193 * vty: remove groundless statement about filler type 'dummy'
194 * vty: auto-generate cmd and doc strings for cfg_filler_type_cmd
195 * vty: fix documentation for 'ext-rach (disable|enable)'
196 * main: use logging API to print SIMD info instead of printf()
197 * doc/manuals: generate XML VTY reference at build-time
198 * vty: fix swapped documentation for 'filler type' command
199 * Transceiver: fix integer division in addRadioVector()
200 * Transceiver: use proper factor for amplitude scaling
201 * Add a (hidden) VTY parameter for Rx/Tx freq. shifting
202
203 [ Eric Wild ]
204 * osmo-trx-ipc
205
206 [ Alexander Couzens ]
207 * osmo-trx.spec: move ipc-driver-test into package ipc-test
208
209 [ Sylvain Munaut ]
210 * sigProcLib: fix C/I computation for 8-PSK modulated bursts
211
212 -- Pau Espin Pedrol <pespin@espeweb.net> Tue, 23 Feb 2021 14:27:15 +0100
213
Pau Espin Pedrolda7fee82020-01-03 19:54:00 +0100214osmo-trx (1.2.0) unstable; urgency=medium
215
216 [ Pau Espin Pedrol ]
217 * osmo-trx: log to stderr on signal received
218 * Drop old setPriority related code
219 * Transceiver: fix segfault during init if IP addr binding fails
220 * Transceiver: Check return value when binding IP addr for clock socket
221 * Transceiver: Clean up receival of downlink bursts
222 * Transceiver: Fix idle ul burst indications being dropped
223 * Transceiver: exit process when BTS drops connection
224 * Transceiver: Enable EDGE detection only on PDCH timeslots
225 * lms: Log available antennas if requested antenna fails
226 * device: Use LOGCHAN in set_antennas()
227 * Transceiver: Fix logging TN and version
228 * Transceiver: Use LOGCHAN in logRxBurst to unify log format
229 * Transceiver: Log error condition no burst in pullRadioVector()
230 * Transceiver: pullRadioVector(): Fix use of uninitialized value bi->tn
231 * Transceiver: Don't stop TRX if pulling from OFF timeslot
232 * radioInterface: Rename mRadio to mDevice
233 * radioInterfaceMulti: Check equals zero explicitly
234 * USRPDevice: Fix setRxGain return on error and getRxGain() returning always 0
235 * USRPDevice: Return previous txGain if setting value failed
236 * LMSDevice: Return previous txGain/rxGain if setting value failed
237 * radioInterface: Remove unusued getRxGain()
238 * radioDevice: Introduce getTxGain() API
239 * radioInterfaceMulti: Override setTxGain() to avoid chan!=0 calls
240 * UHDDevice: Drop unneeded MULTI_ARFCN checks
241 * radioInterface{Multi,Resamp}: Fix successful writeSamples() masking underrun from readSamples()
242 * radioInterface: Mark setRxGain as virtual
243 * Move multi-ARFCN chan amount modification from UHDDevice to parent class
244 * radioInterface: Atomically fetch and change underrun variable
245 * radioInterfaceMulti: write frequency offset direction (rx/tx) in log line
246 * Use new libosmocore logging lock API
247 * Transceiver: Fix wrong response upon CMD HANDOVER failure
248 * uhd: use value already cached in tmp variable
249 * Transceiver.cpp: Introduce and use new logging categories
250
251 [ Timo Jacobus ]
252 * Transceiver: Fixed copying of history into and from channelizer buffer.
253
254 [ Alexander Chemeris ]
255 * vty: Don't enable random filler bursts automatically with EDGE.
256 * vty: Simplify filler burst settings and improve help and readability.
257
258 [ Martin Hauke ]
259 * Fix common misspellings and typos
260
261 [ Harald Welte ]
262 * trx: exit() on unsupported positional arguments on command line
263
264 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 19:54:00 +0100
265
Pau Espin Pedrold0cbb162019-08-08 13:00:06 +0200266osmo-trx (1.1.1) unstable; urgency=medium
267
268 * UNRELEASED
269
270 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 08 Aug 2019 13:00:05 +0200
271
Pau Espin Pedrole774d522019-08-07 21:12:56 +0200272osmo-trx (1.1.0) unstable; urgency=medium
273
274 [ Sylvain Munaut ]
275 * arm/convolve: Fix the vfp4 real convolution for h_len=12
276 * convolve: Remove support for step, offset parameters
277 * tests: Rework the convolve_test
278 * tests: Re-enable the convolve_test by default
279 * sigProcLib: Add C/I (Carrier-to-Interference ratio) computation
280
281 [ Vadim Yanitskiy ]
282 * VTY: add extended (11-bit) RACH detection toggle
283 * doc/configuration.adoc: fix incorrect number of physical RF channels for B210
284 * driveTxPriorityQueue(): cosmetic: use proper type for TDMA TN
285 * driveTxPriorityQueue(): use trxd_hdr_common for message parsing
286 * driveTxPriorityQueue(): check if message header format is supported
287 * driveTxPriorityQueue(): enrich logging message
288 * trxd_fill_common(): fix TRXD header version coding
289 * manuals/configuration.adoc: fix copy-paste error in config example
290
291 [ Pau Espin Pedrol ]
292 * osmo-trx: Avoid handling signals after shutdown triggered
293 * osmo-trx: Use signalfd to serialize signals in main thread ctx
294 * osmo-trx: Check return code of osmo_fd_register
295 * lms: flush_recv: alloc buf on stack instead of heap
296 * lms: Improve log during flush recv error
297 * cosmetic: Threads.h: Remove trailing whitespace
298 * Move duplicated thread_enable_cancel to CommonLibs
299 * lms: Log underrun/overrun events
300 * lms: Remove references to ALERT loglevel
301 * lms: Remove unused var m_last_tx_overruns
302 * lms: Catch and log dropped packets by HW during recv
303 * cosmetic: uhd: Move smpl_buf out of UHDDevice, move UHDDevice class definition to .h
304 * uhd: smpl_buf: Drop UHD specifics out back to UHDDevice
305 * uhd: smpl_buf: Use TIMESTAMP type in str_status
306 * cosmetic: uhd: Use loglevel ERROR instead of ERR
307 * uhd: Avoid reallocation of buffers every read
308 * Move smpl_buf out of uhd dir to re-use it in other devices
309 * device: Drop unused numberRead/numberWritten APIs
310 * smpl_buf: Remove unused clk_rt variable
311 * smpl_buf: Remove unused clk_rt variable (fixup)
312 * smpl_buf: Remove dbg log line with duplicated info
313 * Introduce LOGCHAN macro to standarize logging channel info
314 * smpl_buf: Move it to device/common and create libdevice_common.la
315 * lms: Use smpl_buf to recover from timestamp jumps
316 * lms: Fix stream_stats checks with droppedPackets
317 * Add rate_ctr support to store/retrieve SDR errors through VTY
318 * Rename and move STOP signal from Transceiver to main
319 * doc: vty: Update trx_vty_reference.xml
320 * lms: Drop unusued variable masterClockRate
321 * lms: Fix stream_stats checks with overrun/underrun
322 * Add VTY commands to set error ctr thresholds
323 * Remove AUTHORS file
324 * trx_{vty,rate_ctr}: Set proper license AGPLv3+
325 * Introduce structs to encode TRXD packets
326 * Transceiver: refactor: gather uplink burst parameters in struct
327 * Transceiver: Drop unused rssi_valid struct field
328 * Transceiver: Move nbits burst size calculation to pullRadioVector()
329 * Transceiver: Move calculation of normalized values (rssiOffset) to pullRadioVector()
330 * Transceiver: Move soft bits normalization to pullRadioVector()
331 * Transceiver: Drop use of GSM::Time from trx_ul_burst_ind
332 * Transceiver: Get rid of SoftVector in struct trx_ul_burst_ind
333 * Transceiver: replace UDPSocket with libosmocore socket API
334 * Transceiver: Avoid noise calculation formula in 2 branches in pullRadioVector
335 * Transceiver: Simplify code on early error return when calling detectAnyBurst
336 * Transceiver: pullRadioVector(): Move initialization of var to start of function
337 * Transceiver: Support pulling idle frames in pullRadioVector()
338 * sigProcLib: detectAnyBurst() family: Use struct to gather all out params
339 * sigProcLib: detectAnyBurst(): make TSC used to detect burst available to caller
340 * Logger: global Log mutex is now available from C code
341 * Transceiver: Move out TRXD socket send code to prepare for TRXDv1
342 * Transceiver: Support SETFORMAT command
343 * Transceiver: Support TRXD v1
344 * Transceiver: Initialize mExtRACH in constructor
345 * debian/copyright: Remove non existent radioInterfaceDiversity.cpp from list
346 * debian/copyright: Update wrong paths in license list
347 * debian/copyright: Add missing file Utils.* to LGPL-2.1+ list
348 * cosmetic: Fix trailing whitespace in several files
349 * Add SPDX annotation
350 * Bind CTRL port to IP addr specified in VTY config
351 * Transceiver: Store TRXD version per channel
352 * Transceiver: Clean up code passing parameters to threads
353 * Remove empty ChangeLog fnd NEWS files
354 * Remove unused autogen.sh
355 * radioInterface: Clarify how underruns are handled driving a radioDevice
356 * usrp1: don't check for non-null underrun pointer
357 * jenkins.sh: Workaround libusrp build race conditon
358 * lms: Drop rx_underruns rate ctr, add tx_drop_* rate ctr
359 * Move inband-signaling-usb documentation to UserManual
360 * Move matlab files under utils/matlab
361 * Move Transceiver52/README to UserManual
362 * Move README.DFEsymbolspaced to utils/matlab
363 * Move std_inband.rbf under device/usrp1/ dir
364 * Drop old README information, provide new updated README
365 * Transceiver: Add missing include netinet/in.h
366 * Require newer version of libosmocore to avoid build failure
367
368 [ Tom Tsou ]
369 * multi-ARFCN: fix maximum number of carriers limitation
370
371 [ Harald Welte ]
372 * use BSC_FD_READ and not OSMO_FD_READ
373 * proto_trxd.c: Use bit-wise AND, not boolean AND
374 * Timeval: Restore output stream flags after changing them
375 * ChannelizerBase: fix initialization of class members
376 * CorrelationSequence: fix initialization of class members
377 * radioInterface.cpp: Fix missing member initialization of RadioInterface()
378
379 [ Joachim Steiger ]
380 * lms: Remove wrong unused code copied from -uhd
381 * lms: move LMS_EnableChannel from Start/Stop to Open/Close device
382 * lms: move LMS_GetLPFBWRange and LMS_Calibrate calls from open to start
383 * lms: add device type detection and device specific gains
384 * lms: properly call close if set_antennas() fails, add some comments
385
386 [ Oliver Smith ]
387 * debian: create -doc subpackage with pdf manuals
388 * contrib/jenkins.sh: run "make maintainer-clean"
389
390 [ Eric Wild ]
391 * Add option to set stack size in config file, default == 0 == OS default
392
393 [ Ruben Undheim ]
394 * Fix spelling discovered by lintian
395
396 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 21:12:56 +0200
397
Harald Welted20b7fa2019-01-20 19:35:05 +0100398osmo-trx (1.0.0) unstable; urgency=medium
399
400 [ Pau Espin Pedrol ]
401 * doc: examples: Add umtrx sample config
402 * UHDDevice: Fix setup failure with LimeSuite > 18.04.1
403 * examples: Set rt-prio 18 and print file basename
404 * lms: Several improvements and compilation/runtime fixes
405 * build: Add support for LimeSuite device backend
406 * LMSDevice: Set correct values for Max{Tx,Rx}Gain
407 * LMSDevice: Fix setup failure with LimeSuite > 18.04.1
408 * lms: Makefile.am: Reorder params to fix link issue
409 * lms: Check LPBFW to set is within supported range
410 * debian: Add package osmo-trx-lms
411 * contrib: Add systemd services for all backends
412 * debian: Add cfg file examples for osmo-trx-{lms,uhd}
413 * Add -V param to print version
414 * lms: Allow values diff than 34dB to be set by setRxGain()
415 * Use correct paths when installing example files
416 * debian: Enable build of osmo-trx-lms
417 * debian: Explicitly enable osmo-trx-uhd build
418 * configure.ac: Fix typo in with-lms help string
419 * vty: Fix typo in gpsdo clock reference type
420 * configure.ac: Add --enable-werror option
421 * Logger: Disable pthread cancel point inside Logger destructor
422 * cosmetic: Fix trailing whitespace
423 * radioInterface: forward errors from RadioDevice to Transceiver in recv path
424 * lms: Return error on device read timeout
425 * osmo-trx: Add osmo_signal to stop whole transceiver chain correctly on error
426 * radioInterface: Fix variable storing integer return value
427 * configure.ac: Specify default language as C++
428 * UHHDDevice: Replace deprecated header uhd/utils/thread_priority.hpp
429 * SigProcLib: Use available copyTo Vector API instead of memcopy
430 * cosmetic: Fix trailing whitespace in several files
431 * radioInterfaceMulti:pullBuffer: Sanely convert float array to complex array
432 * Vector: Copy arrays in a sane way for non-trivially copyable types
433 * jenkins.sh: Add --enable-werror flag to osmo-trx configure step
434 * Install systemd services with autotools
435 * Install sample cfg file to /etc/osmocom
436 * cosmetic: Use proper whitespace in several for loops
437 * Use pthread_setname_np to name threads
438 * CommonLibs/Makefile.am: Specify libcommon_la_LIBADD
439 * Transciever: Log values causing Tx underrun
440 * examples: Use logging level 'set-all' instead of 'all'
441 * jenkins.sh: Enable build of osmo-trx-lms
442 * ChannelizerBase: Fix ASan alloc-dealloc-mismatch
443 * UHDDevice: setRxGain on chan 0 when using multi-arfcn
444 * lms: Use LimeSuite.h log level defines instead of hardcoded values
445 * lms: Apply LMS->OSMO log level conversion
446 * Introduce OsmoTRX manual
447 * Introduce chapter trx_if.adoc and add it to OsmoTRX and OsmoBTS
448 * trx: Add reference to project wiki page in overfiew section
449 * trx: Add Hardware architecture support section
450 * trx: Add Hardware device support section
451 * osmotrx: Split Device specific section from backend one
452 * osmotrx: Write initial documentation for several supported devices
453 * osmotrx: configuration: Add section to document multi-arfcn feature
454 * osmotrx: Create a common chapter for section documenting backends
455 * osmotrx: Introduce code architecture chapter
456 * lms: Fix start after stop of device
457 * lms: Destroy streams on device stop
458 * radioInterface: Fix memleak during close()
459 * PointerFIFO: Fix memleak of ListNode
460 * lms: Make sure LMS_Close is called when Device is torn down
461 * osmo-trx: Change some lines to use libosmocore logging instead of cout
462 * lms: Close device on LMS_Init failure
463 * SigProcLib: Improve Vector buffer allocation mess
464 * lms: Allow setting Tx/RxGain for chan!=0
465 * lms: Allow setting Tx/RxFreq for lchan!=0
466 * lms: Improve Set{Rx,Tx}{Gain,Freq} logging
467 * transceiver: log chan on CTRL command received
468 * Add TRXCTRL log category
469 * transceiver: Log TRXCTRL iface responses towards osmo-bts-trx
470 * lms: Move {under,over}run checks into separate method
471 * lms: Do {under,over}run checks even if LMS_RecvStream fails
472 * Timeval: passed() returns true if time is equal
473 * Timeval: Move implementation to use clock_gettime and timespec
474 * Timeval: Move to osmo_clock_gettime
475 * TimevalTest: Make test deterministic with fake time
476 * lms: Fix build against LimeSuite > 18.10
477 * configure.ac: check boost only if USRP1 support is enabled
478
479 [ Vadim Yanitskiy ]
480 * trx_vty.c: fix: use CONFIG_NODE as parent by default
481 * device/lms/LMSDevice.cpp: fix compilation warning
482 * sigProcLib: introduce both TS1 and TS2 RACH synch. sequences
483 * sigProcLib: add a CorrType for extended (11-bit) RACH
484
485 [ Harald Welte ]
486 * Initial work towards direct LimeSuite support in OsmoTRX
487 * update .gitignore to include osmo-trx-lms
488 * LMSDevice: Call LMS_Init() before setting sample rate
489 * LMSDevice: Print sample rate range + actual sample rate after setting it
490 * LMSDevice: Typo fix: s/Internal/External
491 * LMSDevice: Set low-pass filters to smallest possible option
492 * LMSDevice: Fix initial timestamp offset of 2500
493 * LMS_Device: Set ts_offset to 0.
494 * LMSDevice: Reduce Rx logging verbosity: Only log unexpected timestamps
495 * move set_antennas() from UHD to generic radioDevice base class
496 * lms: Fix support for rx_paths / tx_paths
497 * lms: Call set_antennas() during open() method
498 * radioDevice: Move tx_sps from derived into base class
499 * radioDevice: better encapsulation in base class
500 * lms: Fix coding style
501 * lms: Fail in case of unsupported configuration
502 * usrp1: Fail in case of unsupported configuration
503 * Fix config file saving of {tx,rx}-path VTY config strings
504 * logging: Introduce new "DDEV" category for device-specific code
505 * update git-version-gen to generate proper version numbers
506 * ensure well-formed example config files
507 * SocketsTest.testReaderIP(): Zero terminate received buffer
508 * trx_validate_config(): Fix validation of rx_sps
509 * vty-ref: Update URI of docbook 5.0 schema
510 * lms: User correct scale factor for transmit samples
511 * lms: Set Rx gain to midpoint, as comment suggests.
512 * usrp1: Remove uninitialized skipRx logic
513 * usrp1: Fix formatting of log message (missing space)
514 * cosmetic: Don't call the SDR "USRP" in error message
515
516 [ Zydrunas Tamosevicius ]
517 * lms: Use same timestamp offset like when using LimeSDR via UHD
518 * lms: Reduce log level of "send buffer of len ..."
519 * lms: fix LMS_StartStream() handling for multiple channels
520 * lms: Reduce Rx gain from 47 to 34 dB
521
522 [ Alexander Couzens ]
523 * debian: add patches for debian8
524
525 [ Oliver Smith ]
526 * Add long parameters (--help, --version, ...)
527 * build manuals moved here from osmo-gsm-manuals.git
528 * Fix DISTCHECK_CONFIGURE_FLAGS override
529 * contrib/jenkins.sh: build and publish manuals
530 * jenkins.sh: run "make distcheck"
531 * contrib: fix makedistcheck with disabled systemd
532 * osmo-trx.cpp: move comma_delimited_to_vector() to Utils.cpp
533 * LMSDevice: make use of dev-args in osmo-trx.cfg
534 * LMSDeviceTest: fix link errors on OBS
535
536 [ Neels Hofmeyr ]
537 * Importing history from osmo-gsm-manuals.git
538
539 [ d0gtail ]
540 * UHDDevice: log exception information on device open failure
541
542 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 19:35:04 +0100
543
Pau Espin Pedrold0ac9262018-05-03 16:23:30 +0200544osmo-trx (0.4.0) unstable; urgency=medium
545
546 [ Neels Hofmeyr ]
547 * jenkins: use osmo-clean-workspace.sh before and after build
548
549 [ Harald Welte ]
550 * SocketsTest: Fix printing of non-nul-terminated string
551 * Revert "debian: Remove osmo-trx-usrp1 until we can build libusrp1.deb"
552 * debian/control: Remove "Maintainer" from binary package section
553 * debian/rules: Make sure we always require libusrp
554 * debian: Ensure USRP1 firmware is part of osmo-trx-usrp1
555 * debian/control: Add build dependency to libusrp-dev
556 * update .gitignore for new executable names
557 * osmo-trx: s/GSM Core Address/GSM BTS Address/
558
559 [ Piotr Krysik ]
560 * UHDDevice.cpp: add USRP B205mini support
561
562 [ Max ]
563 * Mark release target as virtual
564 * Remove outdated references to OpenBTS
565 * Remove unused headers
566 * Update installation instructions
567 * Update legal disclaimer
568 * Update license notes
569 * tests: null-terminate buffer
570
571 [ Pau Espin Pedrol ]
572 * cosmetic: Remove trailing whitespace
573 * Logger: Stop using Log.Alarms.Max from config
574 * Logger: Stop using Log.File and Log.Level from config
575 * Drop use of ConfigurationTable gConfig
576 * Remove Configuration module and libsqlite dependency
577 * cosmetic: AUTHORS: fix trailing whitespace
578 * Set up GNU Autotest infrastructure
579 * tests: InterThread: adapt to have reproducible output and enable autotest
580 * tests: Timeval: adapt to have reproducible output and enable autotest
581 * tests: Log: adapt to have reproducible output and enable autotest
582 * Sockets.cpp: Fix initialization of UDD socket
583 * tests: Sockets: adapt to have reproducible output and enable autotest
584 * utils/convolvtest: Remove uneeded libosmocore dependency
585 * Move ARCH_LA to Makefile.common
586 * tests: Migrate convtest util to autotest infrastructure
587 * arm/convert.c: Fix compilation error
588 * arm/convert.c: Add missing convert_init implementation
589 * .gitignore: Add missing test related files
590 * Remove UDDSocket class
591 * tests: SocketTests: Pick OS-assigned instead of setting one manually
592 * tests: SocketsTest: Avoid hang forever if test fails
593 * tests: SocketsTest: Fail test on write fail
594 * tests: TimevalTest: refactor and avoid double comparison
595 * contrib/jenkins.sh: Use qemu+proot+debootstrap to run tests with ARM instruction set
596 * tests: convolve: Disable due to difference in output in different archs
597 * Remove unneeded libdl dependency
598 * Fix whitespace
599 * Add support to set Rx/TxAntenna
600 * UHDDevice: Initialize async_event_thrd in constructor
601 * Logger: Drop unused gLogEarly
602 * Logger: Remove unused logging macros
603 * Logger: get rid of alarm APIs
604 * Logger: Drop syslog support
605 * Logger: Drop support to log into file
606 * Logger: Remove unused includes
607 * Logger: Remove gLogToConsole flag
608 * configure.ac: Check for pkg-config
609 * Depend on libosmocore
610 * osmo-trx: set up signals using libosmocore helpers
611 * osmo-trx: Set up talloc ctx
612 * debian: Depend on libtalloc and libosmocore
613 * Add initial support for logging, vty, ctrl
614 * Logger: Use libosmocore logging system
615 * osmo-trx.cpp: Move trx start and stop to helper functions
616 * Move enums required by VTY to a separate header
617 * vty: Implement VTY cfg parsing for current parameters
618 * doc: Add sample cfg file for LimeSDR
619 * osmo-trx: Use VTY cfg structures while still allowing cmd line options
620 * osmo-trx: Re-introduce -l cmd line parameter
621 * Makefile.am: Avoid using subdir if arch is not required
622 * Build Transceiver52M/common as an .la lib
623 * use osmo_init_logging2()
624 * tests: Makefile.am: Fix typo in include path
625 * configure.ac: Add --enable-sanitize option
626 * Move arch specific fiels to arch subdir
627 * Move device specific files to device subdir
628 * Change configure define USRP1 to DEVICE_USRP1
629 * Move device specific code out of radioInterface
630 * Transceiver: Move device specific code to radioDevice class
631 * Build one osmo-trx binary for each device support enabled
632 * Logger: Print correct source file and line number
633 * Transceiver: log timing info of stale bursts
634 * build: Fix make distcheck
635 * build: More OBS build failure fixes
636 * jenkins.sh: Enable build of osmo-trx-usrp1
637 * debian: Remove osmo-trx-usrp1 until we can build libusrp1.deb
638 * debian: Fix OBS build
639 * build: Fix OBS build for ARM
640 * git-version-gen: Take into account tags not in master
641
642 [ Alexander Huemer ]
643 * Unbreak `./configure --with-usrp1` build
644 * Fix USRP1 build with support for setting Rx/TxAntenna
645
646 [ Alexander Couzens ]
647 * jenkins.sh: fix the download url if the qemu image wasn't setup
648 * jenkins.sh: cleanup always the workspace
649 * jenkins.sh: change qemu-img default location to $HOME/qemu-img instead of /opt/qemu-img
650
651 [ Vadim Yanitskiy ]
652 * Transceiver.cpp: use a define for the MAX_PACKET_LENGTH
653 * Transceiver.cpp: properly zero-terminate received commands
654 * Transceiver.cpp: use pointer arithmetics for CMD parsing
655 * Transceiver.cpp: fix incorrect format string for SETTSC
656 * Transceiver.cpp: prevent out-of-range array access
657
658 [ Martin Hauke ]
659 * configure.ac: Fix typo
660
661 [ Philipp Maier ]
662 * doc: add example config for usrp B200 series
663
664 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:23:29 +0200
665
Harald Welte78e1cd22017-10-28 17:52:32 +0200666osmo-trx (0.2.0) unstable; urgency=medium
667
668 [ Alexander Chemeris ]
669 * EDGE: Add support for UmTRX.
670 * Common: Get rid of a compilation warning.
671 * Common: Make sure gLogEarly() log to the same facilities as the normal log.
672 * transceiver: Properly handle MAXDLY.
673 * transceiver: Add an option to generate random Access Bursts.
674 * osmo-trx: Output Rx SPS as a part of configuration output.
675 * transceiver: Do not pass transceiver state struct to function where it's not used.
676 * makefile: Fix build from an external path.
677 * radioDevice: GSMRATE macro must have parentheses around its definition.
678 * uhd: Fix comment.
679 * radioInterface: Initialize power scale with a meaningful default.
680 * transceiver: Log channel number in DEBUG output of demoded bursts.
681 * transceiver: Add an option to emulate a RACH delay in random filler mode.
682 * UHD: Initial LimeSDR support.
683 * CommonLibs: Remove unused files.
684 * sigProcLib: Typo sybols -> symbols
685 * radioBuffer: Remove extra ; at the end of inline function definitions.
686 * sigProcLib: Fix documentation, sync argument names in .cpp and .h files.
687 * sigProcLib: make energyDetect() simpler by returning actual energy.
688 * sigProcLib: Rename demodulateBurst() to demodGmskBurst() for clarity.
689 * sigProcLib: Slice SoftVector instead of signalVector for GMSK demod.
690 * Call vectorSlicer() right before packing bits for transmission to osmo-bts.
691 * CommonLibs: Print soft bits with less confidence to console when printing a soft vector.
692 * BitVector: Remove convolutional codec - we don't use it in osmo-trx.
693 * BitVector: Convert SoftVector from 0..1 to -1..+1 soft bits.
694 * signalVector: Implement segment().
695 * vector: Introduce segmentMove() method to move data inside of a vector.
696 * vector: Introduce shrink() function to shrink vector size without loosing data.
697 * Move CorrType type from Transceiver to sigProcLib.
698 * sigProcLib: rename signalError type to SignalError.
699 * Move Transceiver::detectBurst() to sigProcLib to make it reusable.
700 * Move BURST_THRESH from Transceiver.cpp to sigProcLib.h to make it reusable.
701 * sigProcLib: Add operator<< to print CorrType to a string.
702 * sigProcLib.h: Fix whitespaces. No non-whitespace changes.
703 * Move Transceiver::demodulate() to sigProcLib to make it reusable.
704 * sigProcLib: constify signalVector arguments for detectBurst() functions.
705 * sigProcLib: Constify demodulation functions burst argument.
706 * sigProcLib: Fix number of tail bits in random Normal Bursts and zero Stealing Bits.
707 * Configuration: Variables allocated with 'new' must be freed with 'delete'.
708 * BitVector: Remove Generator class.
709 * PRBS: a Pseudo-random binary sequence (PRBS) generator class.
710
711 [ Tom Tsou ]
712 * EDGE: Fix USRP B210 device support
713 * uhd: Correct timing alignment in 8-PSK and GMSK downlink bursts
714 * EDGE: Fix demodulation slicer input
715 * common: Restrict UDP binding to localhost only
716 * common: Add mandatory length field to UDP receive calls
717 * uhd: Update default E3XX settings
718 * uhd: Set default Tx sampling to 4 sps
719 * uhd: Make device offset check a private method
720 * uhd: Set minimum UHD version requirement for E3XX
721 * sigproc: Expand RACH, TSC, and EDGE correlation windows
722 * transceiver: Do not report error on SETTSC when radio is on
723 * transceiver: Add Rx samples-per-symbol option
724 * radioInterface: Convert diversity argument to general type
725 * iface: Add inner ring-buffer implementation
726 * mcbts: Add multi-ARFCN channelizing filters
727 * mcbts: Add multi-ARFCN radio support
728 * sigproc: Adjust burst detection threshold criteria
729 * egprs: Enable 8-PSK length vectors on the Tx interface
730 * egprs: Enable 8-PSK burst detection when EDGE is enabled
731 * transceiver: Remove HANDOVER warnings
732 * mcbts: Allow out of order channel setup
733 * radioInterface: Fix multi-channel buffer index bug
734 * uhd: Add command line option for GPS reference
735 * transceiver: Fix mixed GSMK / 8-PSK transmission
736 * transceiver: Fix 4 SPS receive TOA value
737 * sigproc: Fix missing 8-PSK tail symbols
738 * uhd: Update USRP2/N200/N210 for 4 SPS Rx
739 * sigproc: Match differential GMSK start/end bits to tail bits
740 * uhd: Add missing B200 sample timing for 4 SPS receive
741 * transceiver: Fix command build warning
742 * uhd: Set minimum supported version to 3.9.0
743 * uhd: Add X300 sample timing for 4 SPS
744 * Revert "uhd: Set minimum supported version to 3.9.0"
745 * uhd: Add support for UHD-3.11 logging control
746 * uhd: Increase MC-BTS FPGA clock rate to 51.2 MHz
747 * Resampler: Fix initialization return checking
748 * sigProcLib: Remove unreachable code and no-effect checks
749 * sigProcLib: Check return status on downsampling
750 * sigProcLib: Fix negative value check on unsigned value
751 * Resampler: Fix non-array delete for filter taps
752 * Transceiver: Remove unsigned negative compares
753 * Configuration: Fix const and signedness compile warnings
754 * config: Remove OpenBTS style sqlite configuration
755 * radioInterface: Remove UmTRX 'diversity' option
756 * build: Require and check for gcc C++11 support
757 * uhd: Use map container for for device parameter access
758 * sigProcLib: Remove unused functions from public interface
759 * uhd: Add non-UmTRX channel swap support
760 * uhd: Fix Tx-RX timing offset setting
761 * uhd: Fix USRP2/N200/N210 device detection
762 * transceiver: Fix POWEROFF crash on USRP2/N200/X300 devices
763 * sigProcLib: Fix complex/real vector flag in Laurent modulator
764 * sigProcLib: Remove heap based signal vector allocations
765 * common: Declare explicit Vector move constructor
766 * sigProcLib: Remove trigonometric tables
767 * sigProcLib: Use explicit NaN check in sinc table generation
768 * sigProcLib: Replace dynamically allocated resampling buffers
769 * sigProcLib: Specify standard namespace for isnan()
770 * uhd: Always specify samples-per-symbol for device lookup
771 * LimeSDR: set approximate tx offset value to make GSM work
772
773 [ Neels Hofmeyr ]
774 * add basic .gitignore
775 * configure.ac: check for boost/config.hpp header
776 * The INSTALL file is being overwritten by autoreconf, but it is committed as empty file. As a result, the INSTALL file always shows as modified. Instead, remove INSTALL from git and ignore it.
777 * add contrib/jenkins.sh, for gerrit build bot
778
779 [ pierre.baudry ]
780 * transceiver: Fix mismatched allocations and deallocations
781
782 [ Holger Hans Peter Freyther ]
783 * debian: Require fftw3 header files for osmo-trx
784
785 [ Max ]
786 * Add gerrit settings
787 * Integrate Debian packaging changes
788 * Remove embedded sqlite3
789 * Fix building against sqlite3
790 * Add autoconf-archive to dependencies
791 * debian: remove obsolete dependency
792 * deb: remove unused dependency
793 * Remove redundant explicit dependency
794 * Use release helper from libosmocore
795
796 [ Ruben Undheim ]
797 * Do not embed sqlite3 when building
798
799 [ Philipp Maier ]
800 * buildenv: Turn off native architecture builds
801 * cosmetic: Make parameter lists uniform
802 * Add test program to verify convolution implementation
803 * ssedetect: Add runtime CPU detection
804 * cosmetic: remove code duplication
805 * buildenv: Make build CPU invariant
806 * buildenv: Split up SSE3 and SSE4.1 code
807 * cosmetic: Add info about SSE support
808
809 [ Vadim Yanitskiy ]
810 * buildenv: correct the ax_sse macro description
811 * buildenv: actually strip unused cpuid functionality
812 * buildenv: fix build on systems without SIMD support
813 * buildenv: cosmetic changes
814 * buildenv: check for __builtin_cpu_supports call support
815 * ssedetect: call __builtin_cpu_supports() only if supported
816
817 [ Pau Espin Pedrol ]
818 * cosmetic: transciever: Remove trailing whitespaces
819 * transceiver: Avoid sending clock indications when trx is not powered on
820 * Add -j option to bind to specific address
821
822 [ ignasj ]
823 * LimeSDR: Change device detection to work with USB and PCIe versions
824 * LimeSDR: change tx window type to TX_WINDOW_FIXED
825 * LimeSDR: Fix sample value range
826
827 [ Harald Welte ]
828 * Add '-t' command line option to enable SCHED_RR
829 * Import git-version-gen and update AC_INIT()
830
831 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 17:52:32 +0200
832
Holger Hans Peter Freytherd17b1892016-03-18 20:13:23 +0100833osmo-trx (0.1.9) trusty; urgency=medium
834
835 * Ask Ivan, really
836
837 -- Kirill Zakharenko <earwin@gmail.com> Thu, 16 Jul 2015 12:13:46 +0000
838
839osmo-trx (0.1.8) precise; urgency=low
840
841 * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP
842
843 -- Ivan Klyuchnikov <Ivan.Kluchnikov@fairwaves.ru> Sun, 9 Mar 2014 14:10:10 +0400