blob: f69b2d33233a86884049a4819acb39d4a4ce9df2 [file] [log] [blame]
Pau Espin Pedrol309ad4d2021-02-23 14:27:15 +01001osmo-trx (1.3.0) unstable; urgency=medium
2
3 [ Pau Espin Pedrol ]
4 * Make logging category DLMS generic and reusable for other backends
5 * uhd: Use DEVDRV log category and support UHD >=3.11 logging framework
6 * uhd: Improve some logging lines printing UHD pretty-print output
7 * doc: clarify number of channels on B210 with multi-arfcn enabled
8 * radioInterfaceMulti: Fail to tune on freq not following multi-arfcn restrictions
9 * doc: Update vty reference xml file
10 * lms: Move initialization of field started to constructor
11 * lms: Drop unused define
12 * smpl_buf: Fix str_code() param and print unknown error val
13 * lms: Improve smpl_buf error logging
14 * lms: Change radioDevice constructor arg name to avoid masking instance attr
15 * lms: Make reference to std::vector unambiguous
16 * lms: Move rx_buffers allocation to constructor
17 * lms: Store device type specific parameters in one place
18 * lms: Make ts_offset and smpl rate coefs device-specific
19 * lms: Initial multi-arfcn support
20 * contrib/jenkins.sh: Reorder sanity checks
21 * debug.h: Avoid printing pthread_t type
22 * debug.h: Fix print format of chan in CLOGCHAN
23 * cosmetic: fix several typos found by codespell
24 * radioDevice: Drop unused RSSI param from readSamples API
25 * radioDevice: Drop unused isControl param from WriteSamples API
26 * Use OSMO_FD_READ instead of deprecated BSC_FD_READ
27 * Transceiver: Fix extra space in RSP NOISELEV error
28 * Transceiver: Implement TRXC cmd NOMTXPOWER
29 * UHDDevice: Implement getNominalTxPower() based on TxFrequency
30 * radioInterface: Operate on real Tx power attenuation rather than on device specific gains
31 * UHDDevice: Compute TxGain on UHD API based on expected Tx output power
32 * proto_trxd: Fix UndefinedBehaviorSanitizer from ubsan
33 * Transceiver: Allow sending negative nominal tx power in RSP NOMTXPOWER
34 * LMSDevice: Compute TxGain on LimeSuite API based on expected Tx output power
35 * Drop old TxGain APIs from parent radioDevice abstract class
36 * {UHD,LMS}Dervice: Log expected resulting TxPower when setting device specific TxGain
37 * cosmetic: trx_rate_ctr: Fix whitespace
38 * trx_rate_ctr: Fix immediate rescheduling on per-sec thresholds
39 * Rename device specific rate counter multi-thread helpers
40 * Introduce rate counter tx_stale_bursts
41 * TransceiverState: Initialize ctrs field in constructor
42 * doc/manuals: Update thread documentation after dropping CTRL sock threads
43 * trx_rate_ctr: Fix locking wrong mutex
44 * Introduce rate counters to detect issues in received Dl bursts from TRXD
45 * Transceiver: Fix race condition obtaining Dl burst from Upper layer
46 * Add rate counter for missing Txbursts when scheduled towards the radioInterface
47 * Transceiver: Provide initial value for TransceiverState::mFiller in constructor
48 * Transceiver: Use already obtained value from Rx msg structure
49 * Transceiver: Restrict conditions where FN gaps are detected
50 * trx_rate_ctr: Lower some log levels
51 * Introduce CTR log category
52 * Transceiver: Lower some log levels which have an associated counter
53 * Transceiver: Check log level before generating burst str representation
54 * Transceiver: Add several rate_ctr for rx error conditions
55 * Use new libosmovty cpu sched config features
56 * debian: Update debian8 osmo-trx specific patch
57 * jenkins.sh: Verify distro-specific patches apply
58 * ipc: fix var declaration in for loop
59 * Add support for TRXC MUTE command
60 * arch: x86: Fix convolve optimizations breaking signal
61 * contrib/jenkins: Enable parallel make in make distcheck
62 * Transceiver: Pass config struct instead of large list of params
63 * Calculate RSSI offset based on RxGain configuration
64 * main: generate coredump and exit upon SIGABRT received
65 * ipc: Fix wrong reference to BTS in log line
66 * ipc-driver-test: Allow setting dir prefix for UD socket
67 * radioInterfaceMulti: Fix memory leak upon close()
68 * ChannelizerBase: Fix memory leak
69 * Threads.cpp: Use already existing gettid wrapper function
70 * Replace my_gettid with libosmocore osmo_gettid API
71 * tests: Explicitly drop category from log
72 * tests: Replace deprecated API log_set_print_filename
73
74 [ Philipp Maier ]
75 * debug: use LOGL_NOTICE for log category DDEV
76 * doc: do not set the base-port of the trx
77 * doc: apply an rssi-offset of 28 by default.
78 * doc: switch log levels to notice
79 * Transceiver: Log when sending of CLK indications begins
80 * vty: add attributes to VTY commands indicating when they apply
81 * osmo-trx: add commandline option --vty-ref-xml
82
83 [ Eric ]
84 * configure.ac: fix libtool issue with clang and sanitizer
85 * transceiver: check the right vector
86 * transceiver: get rid of the ctrl threads
87 * add kernel style .clang-format with 120 chars per line limit
88 * devices: reset internal smart sample buffers upon stop
89 * transceiver: optimize code if optimizations are enabled
90 * transceiver: initialize reorder flag so we don't miscount
91
92 [ Harald Welte ]
93 * PRBS tool sending PRBS sequence to TRX
94 * prbs-tool: Add error simulation capabilities
95 * utils: Ensure content of this directory is included in 'make dist'
96 * prbs-tool: Don't require C99
97 * RPM spec file: Require uhd-firmware for osmo-trx-uhd
98 * osmo-trx.spec.in: Use %config(noreplace) to retain current config file
99 * Fix build on Debian8
100 * [cosmetic] radioInterfaceMulti: More comments
101 * [cosmetic] radioIntefaceMulti: Fix whitespace / indent
102 * ipc: Use OSMO_FD_* instead of deprecated BSC_FD_*
103 * Use osmo_fd_setup() wherever applicable
104 * Use osmo_fd_*_{disable,enable}
105 * README update
106 * manual: Fix typo OsmTRX -> OsmoTRX
107
108 [ Oliver Smith ]
109 * contrib: import RPM spec
110 * contrib: integrate RPM spec
111 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
112 * contrib/jenkins: don't build osmo-gsm-manuals
113 * configure.ac: set -std=gnu11
114
115 [ Vadim Yanitskiy ]
116 * UHDDevice: catch LookupError/IndexError in set{Rx,Tx}Antenna()
117 * debian/control: change maintainer to the Osmocom team / mailing list
118 * proto_trxd: cosmetic: 'if' is not a function, add space
119 * vty: add multi-ARFCN specific warning for chan N > 0
120 * radioDevice: fix set_antennas(): consider MULTI_ARFCN mode
121 * device/lms: fix: 'trx_vty.h' header requires C linkage
122 * device/lms: fix missing semicolon in LMSDevice::assign_band_desc()
123 * device/lms: get rid of 'using namespace std'
124 * device/common/Makefile.am: remove $(LMS_CFLAGS) from AM_CXXFLAGS
125 * main: add --vty-ref-mode, use vty_dump_xml_ref_mode()
126 * device: drop unreasonable LIBOSMO{CTRL,VTY}_{CFLAGS,LIBS}
127 * Transceiver: use size_t and ARRAY_SIZE() in constructor
128 * Transceiver: explicitly init m{Rx,Tx}LowerLoopThread
129 * vty: fix documentation for 'swap-channels (disable|enable)'
130 * vty: fix documentation for 'egprs (disable|enable)'
131 * vty: fix documentation for 'rx-sps (1|4)' and 'tx-sps (1|4)'
132 * vty: cosmetic: use VTY_IPV4_CMD in 'bind-ip' / 'remote-ip'
133 * vty: fix documentation for 'multi-arfcn (disable|enable)'
134 * vty: remove groundless statement about filler type 'dummy'
135 * vty: auto-generate cmd and doc strings for cfg_filler_type_cmd
136 * vty: fix documentation for 'ext-rach (disable|enable)'
137 * main: use logging API to print SIMD info instead of printf()
138 * doc/manuals: generate XML VTY reference at build-time
139 * vty: fix swapped documentation for 'filler type' command
140 * Transceiver: fix integer division in addRadioVector()
141 * Transceiver: use proper factor for amplitude scaling
142 * Add a (hidden) VTY parameter for Rx/Tx freq. shifting
143
144 [ Eric Wild ]
145 * osmo-trx-ipc
146
147 [ Alexander Couzens ]
148 * osmo-trx.spec: move ipc-driver-test into package ipc-test
149
150 [ Sylvain Munaut ]
151 * sigProcLib: fix C/I computation for 8-PSK modulated bursts
152
153 -- Pau Espin Pedrol <pespin@espeweb.net> Tue, 23 Feb 2021 14:27:15 +0100
154
Pau Espin Pedrolda7fee82020-01-03 19:54:00 +0100155osmo-trx (1.2.0) unstable; urgency=medium
156
157 [ Pau Espin Pedrol ]
158 * osmo-trx: log to stderr on signal received
159 * Drop old setPriority related code
160 * Transceiver: fix segfault during init if IP addr binding fails
161 * Transceiver: Check return value when binding IP addr for clock socket
162 * Transceiver: Clean up receival of downlink bursts
163 * Transceiver: Fix idle ul burst indications being dropped
164 * Transceiver: exit process when BTS drops connection
165 * Transceiver: Enable EDGE detection only on PDCH timeslots
166 * lms: Log available antennas if requested antenna fails
167 * device: Use LOGCHAN in set_antennas()
168 * Transceiver: Fix logging TN and version
169 * Transceiver: Use LOGCHAN in logRxBurst to unify log format
170 * Transceiver: Log error condition no burst in pullRadioVector()
171 * Transceiver: pullRadioVector(): Fix use of uninitialized value bi->tn
172 * Transceiver: Don't stop TRX if pulling from OFF timeslot
173 * radioInterface: Rename mRadio to mDevice
174 * radioInterfaceMulti: Check equals zero explicitly
175 * USRPDevice: Fix setRxGain return on error and getRxGain() returning always 0
176 * USRPDevice: Return previous txGain if setting value failed
177 * LMSDevice: Return previous txGain/rxGain if setting value failed
178 * radioInterface: Remove unusued getRxGain()
179 * radioDevice: Introduce getTxGain() API
180 * radioInterfaceMulti: Override setTxGain() to avoid chan!=0 calls
181 * UHDDevice: Drop unneeded MULTI_ARFCN checks
182 * radioInterface{Multi,Resamp}: Fix successful writeSamples() masking underrun from readSamples()
183 * radioInterface: Mark setRxGain as virtual
184 * Move multi-ARFCN chan amount modification from UHDDevice to parent class
185 * radioInterface: Atomically fetch and change underrun variable
186 * radioInterfaceMulti: write frequency offset direction (rx/tx) in log line
187 * Use new libosmocore logging lock API
188 * Transceiver: Fix wrong response upon CMD HANDOVER failure
189 * uhd: use value already cached in tmp variable
190 * Transceiver.cpp: Introduce and use new logging categories
191
192 [ Timo Jacobus ]
193 * Transceiver: Fixed copying of history into and from channelizer buffer.
194
195 [ Alexander Chemeris ]
196 * vty: Don't enable random filler bursts automatically with EDGE.
197 * vty: Simplify filler burst settings and improve help and readability.
198
199 [ Martin Hauke ]
200 * Fix common misspellings and typos
201
202 [ Harald Welte ]
203 * trx: exit() on unsupported positional arguments on command line
204
205 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 19:54:00 +0100
206
Pau Espin Pedrold0cbb162019-08-08 13:00:06 +0200207osmo-trx (1.1.1) unstable; urgency=medium
208
209 * UNRELEASED
210
211 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 08 Aug 2019 13:00:05 +0200
212
Pau Espin Pedrole774d522019-08-07 21:12:56 +0200213osmo-trx (1.1.0) unstable; urgency=medium
214
215 [ Sylvain Munaut ]
216 * arm/convolve: Fix the vfp4 real convolution for h_len=12
217 * convolve: Remove support for step, offset parameters
218 * tests: Rework the convolve_test
219 * tests: Re-enable the convolve_test by default
220 * sigProcLib: Add C/I (Carrier-to-Interference ratio) computation
221
222 [ Vadim Yanitskiy ]
223 * VTY: add extended (11-bit) RACH detection toggle
224 * doc/configuration.adoc: fix incorrect number of physical RF channels for B210
225 * driveTxPriorityQueue(): cosmetic: use proper type for TDMA TN
226 * driveTxPriorityQueue(): use trxd_hdr_common for message parsing
227 * driveTxPriorityQueue(): check if message header format is supported
228 * driveTxPriorityQueue(): enrich logging message
229 * trxd_fill_common(): fix TRXD header version coding
230 * manuals/configuration.adoc: fix copy-paste error in config example
231
232 [ Pau Espin Pedrol ]
233 * osmo-trx: Avoid handling signals after shutdown triggered
234 * osmo-trx: Use signalfd to serialize signals in main thread ctx
235 * osmo-trx: Check return code of osmo_fd_register
236 * lms: flush_recv: alloc buf on stack instead of heap
237 * lms: Improve log during flush recv error
238 * cosmetic: Threads.h: Remove trailing whitespace
239 * Move duplicated thread_enable_cancel to CommonLibs
240 * lms: Log underrun/overrun events
241 * lms: Remove references to ALERT loglevel
242 * lms: Remove unused var m_last_tx_overruns
243 * lms: Catch and log dropped packets by HW during recv
244 * cosmetic: uhd: Move smpl_buf out of UHDDevice, move UHDDevice class definition to .h
245 * uhd: smpl_buf: Drop UHD specifics out back to UHDDevice
246 * uhd: smpl_buf: Use TIMESTAMP type in str_status
247 * cosmetic: uhd: Use loglevel ERROR instead of ERR
248 * uhd: Avoid reallocation of buffers every read
249 * Move smpl_buf out of uhd dir to re-use it in other devices
250 * device: Drop unused numberRead/numberWritten APIs
251 * smpl_buf: Remove unused clk_rt variable
252 * smpl_buf: Remove unused clk_rt variable (fixup)
253 * smpl_buf: Remove dbg log line with duplicated info
254 * Introduce LOGCHAN macro to standarize logging channel info
255 * smpl_buf: Move it to device/common and create libdevice_common.la
256 * lms: Use smpl_buf to recover from timestamp jumps
257 * lms: Fix stream_stats checks with droppedPackets
258 * Add rate_ctr support to store/retrieve SDR errors through VTY
259 * Rename and move STOP signal from Transceiver to main
260 * doc: vty: Update trx_vty_reference.xml
261 * lms: Drop unusued variable masterClockRate
262 * lms: Fix stream_stats checks with overrun/underrun
263 * Add VTY commands to set error ctr thresholds
264 * Remove AUTHORS file
265 * trx_{vty,rate_ctr}: Set proper license AGPLv3+
266 * Introduce structs to encode TRXD packets
267 * Transceiver: refactor: gather uplink burst parameters in struct
268 * Transceiver: Drop unused rssi_valid struct field
269 * Transceiver: Move nbits burst size calculation to pullRadioVector()
270 * Transceiver: Move calculation of normalized values (rssiOffset) to pullRadioVector()
271 * Transceiver: Move soft bits normalization to pullRadioVector()
272 * Transceiver: Drop use of GSM::Time from trx_ul_burst_ind
273 * Transceiver: Get rid of SoftVector in struct trx_ul_burst_ind
274 * Transceiver: replace UDPSocket with libosmocore socket API
275 * Transceiver: Avoid noise calculation formula in 2 branches in pullRadioVector
276 * Transceiver: Simplify code on early error return when calling detectAnyBurst
277 * Transceiver: pullRadioVector(): Move initialization of var to start of function
278 * Transceiver: Support pulling idle frames in pullRadioVector()
279 * sigProcLib: detectAnyBurst() family: Use struct to gather all out params
280 * sigProcLib: detectAnyBurst(): make TSC used to detect burst available to caller
281 * Logger: global Log mutex is now available from C code
282 * Transceiver: Move out TRXD socket send code to prepare for TRXDv1
283 * Transceiver: Support SETFORMAT command
284 * Transceiver: Support TRXD v1
285 * Transceiver: Initialize mExtRACH in constructor
286 * debian/copyright: Remove non existent radioInterfaceDiversity.cpp from list
287 * debian/copyright: Update wrong paths in license list
288 * debian/copyright: Add missing file Utils.* to LGPL-2.1+ list
289 * cosmetic: Fix trailing whitespace in several files
290 * Add SPDX annotation
291 * Bind CTRL port to IP addr specified in VTY config
292 * Transceiver: Store TRXD version per channel
293 * Transceiver: Clean up code passing parameters to threads
294 * Remove empty ChangeLog fnd NEWS files
295 * Remove unused autogen.sh
296 * radioInterface: Clarify how underruns are handled driving a radioDevice
297 * usrp1: don't check for non-null underrun pointer
298 * jenkins.sh: Workaround libusrp build race conditon
299 * lms: Drop rx_underruns rate ctr, add tx_drop_* rate ctr
300 * Move inband-signaling-usb documentation to UserManual
301 * Move matlab files under utils/matlab
302 * Move Transceiver52/README to UserManual
303 * Move README.DFEsymbolspaced to utils/matlab
304 * Move std_inband.rbf under device/usrp1/ dir
305 * Drop old README information, provide new updated README
306 * Transceiver: Add missing include netinet/in.h
307 * Require newer version of libosmocore to avoid build failure
308
309 [ Tom Tsou ]
310 * multi-ARFCN: fix maximum number of carriers limitation
311
312 [ Harald Welte ]
313 * use BSC_FD_READ and not OSMO_FD_READ
314 * proto_trxd.c: Use bit-wise AND, not boolean AND
315 * Timeval: Restore output stream flags after changing them
316 * ChannelizerBase: fix initialization of class members
317 * CorrelationSequence: fix initialization of class members
318 * radioInterface.cpp: Fix missing member initialization of RadioInterface()
319
320 [ Joachim Steiger ]
321 * lms: Remove wrong unused code copied from -uhd
322 * lms: move LMS_EnableChannel from Start/Stop to Open/Close device
323 * lms: move LMS_GetLPFBWRange and LMS_Calibrate calls from open to start
324 * lms: add device type detection and device specific gains
325 * lms: properly call close if set_antennas() fails, add some comments
326
327 [ Oliver Smith ]
328 * debian: create -doc subpackage with pdf manuals
329 * contrib/jenkins.sh: run "make maintainer-clean"
330
331 [ Eric Wild ]
332 * Add option to set stack size in config file, default == 0 == OS default
333
334 [ Ruben Undheim ]
335 * Fix spelling discovered by lintian
336
337 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 21:12:56 +0200
338
Harald Welted20b7fa2019-01-20 19:35:05 +0100339osmo-trx (1.0.0) unstable; urgency=medium
340
341 [ Pau Espin Pedrol ]
342 * doc: examples: Add umtrx sample config
343 * UHDDevice: Fix setup failure with LimeSuite > 18.04.1
344 * examples: Set rt-prio 18 and print file basename
345 * lms: Several improvements and compilation/runtime fixes
346 * build: Add support for LimeSuite device backend
347 * LMSDevice: Set correct values for Max{Tx,Rx}Gain
348 * LMSDevice: Fix setup failure with LimeSuite > 18.04.1
349 * lms: Makefile.am: Reorder params to fix link issue
350 * lms: Check LPBFW to set is within supported range
351 * debian: Add package osmo-trx-lms
352 * contrib: Add systemd services for all backends
353 * debian: Add cfg file examples for osmo-trx-{lms,uhd}
354 * Add -V param to print version
355 * lms: Allow values diff than 34dB to be set by setRxGain()
356 * Use correct paths when installing example files
357 * debian: Enable build of osmo-trx-lms
358 * debian: Explicitly enable osmo-trx-uhd build
359 * configure.ac: Fix typo in with-lms help string
360 * vty: Fix typo in gpsdo clock reference type
361 * configure.ac: Add --enable-werror option
362 * Logger: Disable pthread cancel point inside Logger destructor
363 * cosmetic: Fix trailing whitespace
364 * radioInterface: forward errors from RadioDevice to Transceiver in recv path
365 * lms: Return error on device read timeout
366 * osmo-trx: Add osmo_signal to stop whole transceiver chain correctly on error
367 * radioInterface: Fix variable storing integer return value
368 * configure.ac: Specify default language as C++
369 * UHHDDevice: Replace deprecated header uhd/utils/thread_priority.hpp
370 * SigProcLib: Use available copyTo Vector API instead of memcopy
371 * cosmetic: Fix trailing whitespace in several files
372 * radioInterfaceMulti:pullBuffer: Sanely convert float array to complex array
373 * Vector: Copy arrays in a sane way for non-trivially copyable types
374 * jenkins.sh: Add --enable-werror flag to osmo-trx configure step
375 * Install systemd services with autotools
376 * Install sample cfg file to /etc/osmocom
377 * cosmetic: Use proper whitespace in several for loops
378 * Use pthread_setname_np to name threads
379 * CommonLibs/Makefile.am: Specify libcommon_la_LIBADD
380 * Transciever: Log values causing Tx underrun
381 * examples: Use logging level 'set-all' instead of 'all'
382 * jenkins.sh: Enable build of osmo-trx-lms
383 * ChannelizerBase: Fix ASan alloc-dealloc-mismatch
384 * UHDDevice: setRxGain on chan 0 when using multi-arfcn
385 * lms: Use LimeSuite.h log level defines instead of hardcoded values
386 * lms: Apply LMS->OSMO log level conversion
387 * Introduce OsmoTRX manual
388 * Introduce chapter trx_if.adoc and add it to OsmoTRX and OsmoBTS
389 * trx: Add reference to project wiki page in overfiew section
390 * trx: Add Hardware architecture support section
391 * trx: Add Hardware device support section
392 * osmotrx: Split Device specific section from backend one
393 * osmotrx: Write initial documentation for several supported devices
394 * osmotrx: configuration: Add section to document multi-arfcn feature
395 * osmotrx: Create a common chapter for section documenting backends
396 * osmotrx: Introduce code architecture chapter
397 * lms: Fix start after stop of device
398 * lms: Destroy streams on device stop
399 * radioInterface: Fix memleak during close()
400 * PointerFIFO: Fix memleak of ListNode
401 * lms: Make sure LMS_Close is called when Device is torn down
402 * osmo-trx: Change some lines to use libosmocore logging instead of cout
403 * lms: Close device on LMS_Init failure
404 * SigProcLib: Improve Vector buffer allocation mess
405 * lms: Allow setting Tx/RxGain for chan!=0
406 * lms: Allow setting Tx/RxFreq for lchan!=0
407 * lms: Improve Set{Rx,Tx}{Gain,Freq} logging
408 * transceiver: log chan on CTRL command received
409 * Add TRXCTRL log category
410 * transceiver: Log TRXCTRL iface responses towards osmo-bts-trx
411 * lms: Move {under,over}run checks into separate method
412 * lms: Do {under,over}run checks even if LMS_RecvStream fails
413 * Timeval: passed() returns true if time is equal
414 * Timeval: Move implementation to use clock_gettime and timespec
415 * Timeval: Move to osmo_clock_gettime
416 * TimevalTest: Make test deterministic with fake time
417 * lms: Fix build against LimeSuite > 18.10
418 * configure.ac: check boost only if USRP1 support is enabled
419
420 [ Vadim Yanitskiy ]
421 * trx_vty.c: fix: use CONFIG_NODE as parent by default
422 * device/lms/LMSDevice.cpp: fix compilation warning
423 * sigProcLib: introduce both TS1 and TS2 RACH synch. sequences
424 * sigProcLib: add a CorrType for extended (11-bit) RACH
425
426 [ Harald Welte ]
427 * Initial work towards direct LimeSuite support in OsmoTRX
428 * update .gitignore to include osmo-trx-lms
429 * LMSDevice: Call LMS_Init() before setting sample rate
430 * LMSDevice: Print sample rate range + actual sample rate after setting it
431 * LMSDevice: Typo fix: s/Internal/External
432 * LMSDevice: Set low-pass filters to smallest possible option
433 * LMSDevice: Fix initial timestamp offset of 2500
434 * LMS_Device: Set ts_offset to 0.
435 * LMSDevice: Reduce Rx logging verbosity: Only log unexpected timestamps
436 * move set_antennas() from UHD to generic radioDevice base class
437 * lms: Fix support for rx_paths / tx_paths
438 * lms: Call set_antennas() during open() method
439 * radioDevice: Move tx_sps from derived into base class
440 * radioDevice: better encapsulation in base class
441 * lms: Fix coding style
442 * lms: Fail in case of unsupported configuration
443 * usrp1: Fail in case of unsupported configuration
444 * Fix config file saving of {tx,rx}-path VTY config strings
445 * logging: Introduce new "DDEV" category for device-specific code
446 * update git-version-gen to generate proper version numbers
447 * ensure well-formed example config files
448 * SocketsTest.testReaderIP(): Zero terminate received buffer
449 * trx_validate_config(): Fix validation of rx_sps
450 * vty-ref: Update URI of docbook 5.0 schema
451 * lms: User correct scale factor for transmit samples
452 * lms: Set Rx gain to midpoint, as comment suggests.
453 * usrp1: Remove uninitialized skipRx logic
454 * usrp1: Fix formatting of log message (missing space)
455 * cosmetic: Don't call the SDR "USRP" in error message
456
457 [ Zydrunas Tamosevicius ]
458 * lms: Use same timestamp offset like when using LimeSDR via UHD
459 * lms: Reduce log level of "send buffer of len ..."
460 * lms: fix LMS_StartStream() handling for multiple channels
461 * lms: Reduce Rx gain from 47 to 34 dB
462
463 [ Alexander Couzens ]
464 * debian: add patches for debian8
465
466 [ Oliver Smith ]
467 * Add long parameters (--help, --version, ...)
468 * build manuals moved here from osmo-gsm-manuals.git
469 * Fix DISTCHECK_CONFIGURE_FLAGS override
470 * contrib/jenkins.sh: build and publish manuals
471 * jenkins.sh: run "make distcheck"
472 * contrib: fix makedistcheck with disabled systemd
473 * osmo-trx.cpp: move comma_delimited_to_vector() to Utils.cpp
474 * LMSDevice: make use of dev-args in osmo-trx.cfg
475 * LMSDeviceTest: fix link errors on OBS
476
477 [ Neels Hofmeyr ]
478 * Importing history from osmo-gsm-manuals.git
479
480 [ d0gtail ]
481 * UHDDevice: log exception information on device open failure
482
483 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 19:35:04 +0100
484
Pau Espin Pedrold0ac9262018-05-03 16:23:30 +0200485osmo-trx (0.4.0) unstable; urgency=medium
486
487 [ Neels Hofmeyr ]
488 * jenkins: use osmo-clean-workspace.sh before and after build
489
490 [ Harald Welte ]
491 * SocketsTest: Fix printing of non-nul-terminated string
492 * Revert "debian: Remove osmo-trx-usrp1 until we can build libusrp1.deb"
493 * debian/control: Remove "Maintainer" from binary package section
494 * debian/rules: Make sure we always require libusrp
495 * debian: Ensure USRP1 firmware is part of osmo-trx-usrp1
496 * debian/control: Add build dependency to libusrp-dev
497 * update .gitignore for new executable names
498 * osmo-trx: s/GSM Core Address/GSM BTS Address/
499
500 [ Piotr Krysik ]
501 * UHDDevice.cpp: add USRP B205mini support
502
503 [ Max ]
504 * Mark release target as virtual
505 * Remove outdated references to OpenBTS
506 * Remove unused headers
507 * Update installation instructions
508 * Update legal disclaimer
509 * Update license notes
510 * tests: null-terminate buffer
511
512 [ Pau Espin Pedrol ]
513 * cosmetic: Remove trailing whitespace
514 * Logger: Stop using Log.Alarms.Max from config
515 * Logger: Stop using Log.File and Log.Level from config
516 * Drop use of ConfigurationTable gConfig
517 * Remove Configuration module and libsqlite dependency
518 * cosmetic: AUTHORS: fix trailing whitespace
519 * Set up GNU Autotest infrastructure
520 * tests: InterThread: adapt to have reproducible output and enable autotest
521 * tests: Timeval: adapt to have reproducible output and enable autotest
522 * tests: Log: adapt to have reproducible output and enable autotest
523 * Sockets.cpp: Fix initialization of UDD socket
524 * tests: Sockets: adapt to have reproducible output and enable autotest
525 * utils/convolvtest: Remove uneeded libosmocore dependency
526 * Move ARCH_LA to Makefile.common
527 * tests: Migrate convtest util to autotest infrastructure
528 * arm/convert.c: Fix compilation error
529 * arm/convert.c: Add missing convert_init implementation
530 * .gitignore: Add missing test related files
531 * Remove UDDSocket class
532 * tests: SocketTests: Pick OS-assigned instead of setting one manually
533 * tests: SocketsTest: Avoid hang forever if test fails
534 * tests: SocketsTest: Fail test on write fail
535 * tests: TimevalTest: refactor and avoid double comparison
536 * contrib/jenkins.sh: Use qemu+proot+debootstrap to run tests with ARM instruction set
537 * tests: convolve: Disable due to difference in output in different archs
538 * Remove unneeded libdl dependency
539 * Fix whitespace
540 * Add support to set Rx/TxAntenna
541 * UHDDevice: Initialize async_event_thrd in constructor
542 * Logger: Drop unused gLogEarly
543 * Logger: Remove unused logging macros
544 * Logger: get rid of alarm APIs
545 * Logger: Drop syslog support
546 * Logger: Drop support to log into file
547 * Logger: Remove unused includes
548 * Logger: Remove gLogToConsole flag
549 * configure.ac: Check for pkg-config
550 * Depend on libosmocore
551 * osmo-trx: set up signals using libosmocore helpers
552 * osmo-trx: Set up talloc ctx
553 * debian: Depend on libtalloc and libosmocore
554 * Add initial support for logging, vty, ctrl
555 * Logger: Use libosmocore logging system
556 * osmo-trx.cpp: Move trx start and stop to helper functions
557 * Move enums required by VTY to a separate header
558 * vty: Implement VTY cfg parsing for current parameters
559 * doc: Add sample cfg file for LimeSDR
560 * osmo-trx: Use VTY cfg structures while still allowing cmd line options
561 * osmo-trx: Re-introduce -l cmd line parameter
562 * Makefile.am: Avoid using subdir if arch is not required
563 * Build Transceiver52M/common as an .la lib
564 * use osmo_init_logging2()
565 * tests: Makefile.am: Fix typo in include path
566 * configure.ac: Add --enable-sanitize option
567 * Move arch specific fiels to arch subdir
568 * Move device specific files to device subdir
569 * Change configure define USRP1 to DEVICE_USRP1
570 * Move device specific code out of radioInterface
571 * Transceiver: Move device specific code to radioDevice class
572 * Build one osmo-trx binary for each device support enabled
573 * Logger: Print correct source file and line number
574 * Transceiver: log timing info of stale bursts
575 * build: Fix make distcheck
576 * build: More OBS build failure fixes
577 * jenkins.sh: Enable build of osmo-trx-usrp1
578 * debian: Remove osmo-trx-usrp1 until we can build libusrp1.deb
579 * debian: Fix OBS build
580 * build: Fix OBS build for ARM
581 * git-version-gen: Take into account tags not in master
582
583 [ Alexander Huemer ]
584 * Unbreak `./configure --with-usrp1` build
585 * Fix USRP1 build with support for setting Rx/TxAntenna
586
587 [ Alexander Couzens ]
588 * jenkins.sh: fix the download url if the qemu image wasn't setup
589 * jenkins.sh: cleanup always the workspace
590 * jenkins.sh: change qemu-img default location to $HOME/qemu-img instead of /opt/qemu-img
591
592 [ Vadim Yanitskiy ]
593 * Transceiver.cpp: use a define for the MAX_PACKET_LENGTH
594 * Transceiver.cpp: properly zero-terminate received commands
595 * Transceiver.cpp: use pointer arithmetics for CMD parsing
596 * Transceiver.cpp: fix incorrect format string for SETTSC
597 * Transceiver.cpp: prevent out-of-range array access
598
599 [ Martin Hauke ]
600 * configure.ac: Fix typo
601
602 [ Philipp Maier ]
603 * doc: add example config for usrp B200 series
604
605 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:23:29 +0200
606
Harald Welte78e1cd22017-10-28 17:52:32 +0200607osmo-trx (0.2.0) unstable; urgency=medium
608
609 [ Alexander Chemeris ]
610 * EDGE: Add support for UmTRX.
611 * Common: Get rid of a compilation warning.
612 * Common: Make sure gLogEarly() log to the same facilities as the normal log.
613 * transceiver: Properly handle MAXDLY.
614 * transceiver: Add an option to generate random Access Bursts.
615 * osmo-trx: Output Rx SPS as a part of configuration output.
616 * transceiver: Do not pass transceiver state struct to function where it's not used.
617 * makefile: Fix build from an external path.
618 * radioDevice: GSMRATE macro must have parentheses around its definition.
619 * uhd: Fix comment.
620 * radioInterface: Initialize power scale with a meaningful default.
621 * transceiver: Log channel number in DEBUG output of demoded bursts.
622 * transceiver: Add an option to emulate a RACH delay in random filler mode.
623 * UHD: Initial LimeSDR support.
624 * CommonLibs: Remove unused files.
625 * sigProcLib: Typo sybols -> symbols
626 * radioBuffer: Remove extra ; at the end of inline function definitions.
627 * sigProcLib: Fix documentation, sync argument names in .cpp and .h files.
628 * sigProcLib: make energyDetect() simpler by returning actual energy.
629 * sigProcLib: Rename demodulateBurst() to demodGmskBurst() for clarity.
630 * sigProcLib: Slice SoftVector instead of signalVector for GMSK demod.
631 * Call vectorSlicer() right before packing bits for transmission to osmo-bts.
632 * CommonLibs: Print soft bits with less confidence to console when printing a soft vector.
633 * BitVector: Remove convolutional codec - we don't use it in osmo-trx.
634 * BitVector: Convert SoftVector from 0..1 to -1..+1 soft bits.
635 * signalVector: Implement segment().
636 * vector: Introduce segmentMove() method to move data inside of a vector.
637 * vector: Introduce shrink() function to shrink vector size without loosing data.
638 * Move CorrType type from Transceiver to sigProcLib.
639 * sigProcLib: rename signalError type to SignalError.
640 * Move Transceiver::detectBurst() to sigProcLib to make it reusable.
641 * Move BURST_THRESH from Transceiver.cpp to sigProcLib.h to make it reusable.
642 * sigProcLib: Add operator<< to print CorrType to a string.
643 * sigProcLib.h: Fix whitespaces. No non-whitespace changes.
644 * Move Transceiver::demodulate() to sigProcLib to make it reusable.
645 * sigProcLib: constify signalVector arguments for detectBurst() functions.
646 * sigProcLib: Constify demodulation functions burst argument.
647 * sigProcLib: Fix number of tail bits in random Normal Bursts and zero Stealing Bits.
648 * Configuration: Variables allocated with 'new' must be freed with 'delete'.
649 * BitVector: Remove Generator class.
650 * PRBS: a Pseudo-random binary sequence (PRBS) generator class.
651
652 [ Tom Tsou ]
653 * EDGE: Fix USRP B210 device support
654 * uhd: Correct timing alignment in 8-PSK and GMSK downlink bursts
655 * EDGE: Fix demodulation slicer input
656 * common: Restrict UDP binding to localhost only
657 * common: Add mandatory length field to UDP receive calls
658 * uhd: Update default E3XX settings
659 * uhd: Set default Tx sampling to 4 sps
660 * uhd: Make device offset check a private method
661 * uhd: Set minimum UHD version requirement for E3XX
662 * sigproc: Expand RACH, TSC, and EDGE correlation windows
663 * transceiver: Do not report error on SETTSC when radio is on
664 * transceiver: Add Rx samples-per-symbol option
665 * radioInterface: Convert diversity argument to general type
666 * iface: Add inner ring-buffer implementation
667 * mcbts: Add multi-ARFCN channelizing filters
668 * mcbts: Add multi-ARFCN radio support
669 * sigproc: Adjust burst detection threshold criteria
670 * egprs: Enable 8-PSK length vectors on the Tx interface
671 * egprs: Enable 8-PSK burst detection when EDGE is enabled
672 * transceiver: Remove HANDOVER warnings
673 * mcbts: Allow out of order channel setup
674 * radioInterface: Fix multi-channel buffer index bug
675 * uhd: Add command line option for GPS reference
676 * transceiver: Fix mixed GSMK / 8-PSK transmission
677 * transceiver: Fix 4 SPS receive TOA value
678 * sigproc: Fix missing 8-PSK tail symbols
679 * uhd: Update USRP2/N200/N210 for 4 SPS Rx
680 * sigproc: Match differential GMSK start/end bits to tail bits
681 * uhd: Add missing B200 sample timing for 4 SPS receive
682 * transceiver: Fix command build warning
683 * uhd: Set minimum supported version to 3.9.0
684 * uhd: Add X300 sample timing for 4 SPS
685 * Revert "uhd: Set minimum supported version to 3.9.0"
686 * uhd: Add support for UHD-3.11 logging control
687 * uhd: Increase MC-BTS FPGA clock rate to 51.2 MHz
688 * Resampler: Fix initialization return checking
689 * sigProcLib: Remove unreachable code and no-effect checks
690 * sigProcLib: Check return status on downsampling
691 * sigProcLib: Fix negative value check on unsigned value
692 * Resampler: Fix non-array delete for filter taps
693 * Transceiver: Remove unsigned negative compares
694 * Configuration: Fix const and signedness compile warnings
695 * config: Remove OpenBTS style sqlite configuration
696 * radioInterface: Remove UmTRX 'diversity' option
697 * build: Require and check for gcc C++11 support
698 * uhd: Use map container for for device parameter access
699 * sigProcLib: Remove unused functions from public interface
700 * uhd: Add non-UmTRX channel swap support
701 * uhd: Fix Tx-RX timing offset setting
702 * uhd: Fix USRP2/N200/N210 device detection
703 * transceiver: Fix POWEROFF crash on USRP2/N200/X300 devices
704 * sigProcLib: Fix complex/real vector flag in Laurent modulator
705 * sigProcLib: Remove heap based signal vector allocations
706 * common: Declare explicit Vector move constructor
707 * sigProcLib: Remove trigonometric tables
708 * sigProcLib: Use explicit NaN check in sinc table generation
709 * sigProcLib: Replace dynamically allocated resampling buffers
710 * sigProcLib: Specify standard namespace for isnan()
711 * uhd: Always specify samples-per-symbol for device lookup
712 * LimeSDR: set approximate tx offset value to make GSM work
713
714 [ Neels Hofmeyr ]
715 * add basic .gitignore
716 * configure.ac: check for boost/config.hpp header
717 * The INSTALL file is being overwritten by autoreconf, but it is committed as empty file. As a result, the INSTALL file always shows as modified. Instead, remove INSTALL from git and ignore it.
718 * add contrib/jenkins.sh, for gerrit build bot
719
720 [ pierre.baudry ]
721 * transceiver: Fix mismatched allocations and deallocations
722
723 [ Holger Hans Peter Freyther ]
724 * debian: Require fftw3 header files for osmo-trx
725
726 [ Max ]
727 * Add gerrit settings
728 * Integrate Debian packaging changes
729 * Remove embedded sqlite3
730 * Fix building against sqlite3
731 * Add autoconf-archive to dependencies
732 * debian: remove obsolete dependency
733 * deb: remove unused dependency
734 * Remove redundant explicit dependency
735 * Use release helper from libosmocore
736
737 [ Ruben Undheim ]
738 * Do not embed sqlite3 when building
739
740 [ Philipp Maier ]
741 * buildenv: Turn off native architecture builds
742 * cosmetic: Make parameter lists uniform
743 * Add test program to verify convolution implementation
744 * ssedetect: Add runtime CPU detection
745 * cosmetic: remove code duplication
746 * buildenv: Make build CPU invariant
747 * buildenv: Split up SSE3 and SSE4.1 code
748 * cosmetic: Add info about SSE support
749
750 [ Vadim Yanitskiy ]
751 * buildenv: correct the ax_sse macro description
752 * buildenv: actually strip unused cpuid functionality
753 * buildenv: fix build on systems without SIMD support
754 * buildenv: cosmetic changes
755 * buildenv: check for __builtin_cpu_supports call support
756 * ssedetect: call __builtin_cpu_supports() only if supported
757
758 [ Pau Espin Pedrol ]
759 * cosmetic: transciever: Remove trailing whitespaces
760 * transceiver: Avoid sending clock indications when trx is not powered on
761 * Add -j option to bind to specific address
762
763 [ ignasj ]
764 * LimeSDR: Change device detection to work with USB and PCIe versions
765 * LimeSDR: change tx window type to TX_WINDOW_FIXED
766 * LimeSDR: Fix sample value range
767
768 [ Harald Welte ]
769 * Add '-t' command line option to enable SCHED_RR
770 * Import git-version-gen and update AC_INIT()
771
772 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 17:52:32 +0200
773
Holger Hans Peter Freytherd17b1892016-03-18 20:13:23 +0100774osmo-trx (0.1.9) trusty; urgency=medium
775
776 * Ask Ivan, really
777
778 -- Kirill Zakharenko <earwin@gmail.com> Thu, 16 Jul 2015 12:13:46 +0000
779
780osmo-trx (0.1.8) precise; urgency=low
781
782 * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP
783
784 -- Ivan Klyuchnikov <Ivan.Kluchnikov@fairwaves.ru> Sun, 9 Mar 2014 14:10:10 +0400