blob: ec6503640fc2e20f402184cf9f4fc68feaee709f [file] [log] [blame]
Harald Welte78e1cd22017-10-28 17:52:32 +02001osmo-trx (0.2.0) unstable; urgency=medium
2
3 [ Alexander Chemeris ]
4 * EDGE: Add support for UmTRX.
5 * Common: Get rid of a compilation warning.
6 * Common: Make sure gLogEarly() log to the same facilities as the normal log.
7 * transceiver: Properly handle MAXDLY.
8 * transceiver: Add an option to generate random Access Bursts.
9 * osmo-trx: Output Rx SPS as a part of configuration output.
10 * transceiver: Do not pass transceiver state struct to function where it's not used.
11 * makefile: Fix build from an external path.
12 * radioDevice: GSMRATE macro must have parentheses around its definition.
13 * uhd: Fix comment.
14 * radioInterface: Initialize power scale with a meaningful default.
15 * transceiver: Log channel number in DEBUG output of demoded bursts.
16 * transceiver: Add an option to emulate a RACH delay in random filler mode.
17 * UHD: Initial LimeSDR support.
18 * CommonLibs: Remove unused files.
19 * sigProcLib: Typo sybols -> symbols
20 * radioBuffer: Remove extra ; at the end of inline function definitions.
21 * sigProcLib: Fix documentation, sync argument names in .cpp and .h files.
22 * sigProcLib: make energyDetect() simpler by returning actual energy.
23 * sigProcLib: Rename demodulateBurst() to demodGmskBurst() for clarity.
24 * sigProcLib: Slice SoftVector instead of signalVector for GMSK demod.
25 * Call vectorSlicer() right before packing bits for transmission to osmo-bts.
26 * CommonLibs: Print soft bits with less confidence to console when printing a soft vector.
27 * BitVector: Remove convolutional codec - we don't use it in osmo-trx.
28 * BitVector: Convert SoftVector from 0..1 to -1..+1 soft bits.
29 * signalVector: Implement segment().
30 * vector: Introduce segmentMove() method to move data inside of a vector.
31 * vector: Introduce shrink() function to shrink vector size without loosing data.
32 * Move CorrType type from Transceiver to sigProcLib.
33 * sigProcLib: rename signalError type to SignalError.
34 * Move Transceiver::detectBurst() to sigProcLib to make it reusable.
35 * Move BURST_THRESH from Transceiver.cpp to sigProcLib.h to make it reusable.
36 * sigProcLib: Add operator<< to print CorrType to a string.
37 * sigProcLib.h: Fix whitespaces. No non-whitespace changes.
38 * Move Transceiver::demodulate() to sigProcLib to make it reusable.
39 * sigProcLib: constify signalVector arguments for detectBurst() functions.
40 * sigProcLib: Constify demodulation functions burst argument.
41 * sigProcLib: Fix number of tail bits in random Normal Bursts and zero Stealing Bits.
42 * Configuration: Variables allocated with 'new' must be freed with 'delete'.
43 * BitVector: Remove Generator class.
44 * PRBS: a Pseudo-random binary sequence (PRBS) generator class.
45
46 [ Tom Tsou ]
47 * EDGE: Fix USRP B210 device support
48 * uhd: Correct timing alignment in 8-PSK and GMSK downlink bursts
49 * EDGE: Fix demodulation slicer input
50 * common: Restrict UDP binding to localhost only
51 * common: Add mandatory length field to UDP receive calls
52 * uhd: Update default E3XX settings
53 * uhd: Set default Tx sampling to 4 sps
54 * uhd: Make device offset check a private method
55 * uhd: Set minimum UHD version requirement for E3XX
56 * sigproc: Expand RACH, TSC, and EDGE correlation windows
57 * transceiver: Do not report error on SETTSC when radio is on
58 * transceiver: Add Rx samples-per-symbol option
59 * radioInterface: Convert diversity argument to general type
60 * iface: Add inner ring-buffer implementation
61 * mcbts: Add multi-ARFCN channelizing filters
62 * mcbts: Add multi-ARFCN radio support
63 * sigproc: Adjust burst detection threshold criteria
64 * egprs: Enable 8-PSK length vectors on the Tx interface
65 * egprs: Enable 8-PSK burst detection when EDGE is enabled
66 * transceiver: Remove HANDOVER warnings
67 * mcbts: Allow out of order channel setup
68 * radioInterface: Fix multi-channel buffer index bug
69 * uhd: Add command line option for GPS reference
70 * transceiver: Fix mixed GSMK / 8-PSK transmission
71 * transceiver: Fix 4 SPS receive TOA value
72 * sigproc: Fix missing 8-PSK tail symbols
73 * uhd: Update USRP2/N200/N210 for 4 SPS Rx
74 * sigproc: Match differential GMSK start/end bits to tail bits
75 * uhd: Add missing B200 sample timing for 4 SPS receive
76 * transceiver: Fix command build warning
77 * uhd: Set minimum supported version to 3.9.0
78 * uhd: Add X300 sample timing for 4 SPS
79 * Revert "uhd: Set minimum supported version to 3.9.0"
80 * uhd: Add support for UHD-3.11 logging control
81 * uhd: Increase MC-BTS FPGA clock rate to 51.2 MHz
82 * Resampler: Fix initialization return checking
83 * sigProcLib: Remove unreachable code and no-effect checks
84 * sigProcLib: Check return status on downsampling
85 * sigProcLib: Fix negative value check on unsigned value
86 * Resampler: Fix non-array delete for filter taps
87 * Transceiver: Remove unsigned negative compares
88 * Configuration: Fix const and signedness compile warnings
89 * config: Remove OpenBTS style sqlite configuration
90 * radioInterface: Remove UmTRX 'diversity' option
91 * build: Require and check for gcc C++11 support
92 * uhd: Use map container for for device parameter access
93 * sigProcLib: Remove unused functions from public interface
94 * uhd: Add non-UmTRX channel swap support
95 * uhd: Fix Tx-RX timing offset setting
96 * uhd: Fix USRP2/N200/N210 device detection
97 * transceiver: Fix POWEROFF crash on USRP2/N200/X300 devices
98 * sigProcLib: Fix complex/real vector flag in Laurent modulator
99 * sigProcLib: Remove heap based signal vector allocations
100 * common: Declare explicit Vector move constructor
101 * sigProcLib: Remove trigonometric tables
102 * sigProcLib: Use explicit NaN check in sinc table generation
103 * sigProcLib: Replace dynamically allocated resampling buffers
104 * sigProcLib: Specify standard namespace for isnan()
105 * uhd: Always specify samples-per-symbol for device lookup
106 * LimeSDR: set approximate tx offset value to make GSM work
107
108 [ Neels Hofmeyr ]
109 * add basic .gitignore
110 * configure.ac: check for boost/config.hpp header
111 * The INSTALL file is being overwritten by autoreconf, but it is committed as empty file. As a result, the INSTALL file always shows as modified. Instead, remove INSTALL from git and ignore it.
112 * add contrib/jenkins.sh, for gerrit build bot
113
114 [ pierre.baudry ]
115 * transceiver: Fix mismatched allocations and deallocations
116
117 [ Holger Hans Peter Freyther ]
118 * debian: Require fftw3 header files for osmo-trx
119
120 [ Max ]
121 * Add gerrit settings
122 * Integrate Debian packaging changes
123 * Remove embedded sqlite3
124 * Fix building against sqlite3
125 * Add autoconf-archive to dependencies
126 * debian: remove obsolete dependency
127 * deb: remove unused dependency
128 * Remove redundant explicit dependency
129 * Use release helper from libosmocore
130
131 [ Ruben Undheim ]
132 * Do not embed sqlite3 when building
133
134 [ Philipp Maier ]
135 * buildenv: Turn off native architecture builds
136 * cosmetic: Make parameter lists uniform
137 * Add test program to verify convolution implementation
138 * ssedetect: Add runtime CPU detection
139 * cosmetic: remove code duplication
140 * buildenv: Make build CPU invariant
141 * buildenv: Split up SSE3 and SSE4.1 code
142 * cosmetic: Add info about SSE support
143
144 [ Vadim Yanitskiy ]
145 * buildenv: correct the ax_sse macro description
146 * buildenv: actually strip unused cpuid functionality
147 * buildenv: fix build on systems without SIMD support
148 * buildenv: cosmetic changes
149 * buildenv: check for __builtin_cpu_supports call support
150 * ssedetect: call __builtin_cpu_supports() only if supported
151
152 [ Pau Espin Pedrol ]
153 * cosmetic: transciever: Remove trailing whitespaces
154 * transceiver: Avoid sending clock indications when trx is not powered on
155 * Add -j option to bind to specific address
156
157 [ ignasj ]
158 * LimeSDR: Change device detection to work with USB and PCIe versions
159 * LimeSDR: change tx window type to TX_WINDOW_FIXED
160 * LimeSDR: Fix sample value range
161
162 [ Harald Welte ]
163 * Add '-t' command line option to enable SCHED_RR
164 * Import git-version-gen and update AC_INIT()
165
166 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 17:52:32 +0200
167
Holger Hans Peter Freytherd17b1892016-03-18 20:13:23 +0100168osmo-trx (0.1.9) trusty; urgency=medium
169
170 * Ask Ivan, really
171
172 -- Kirill Zakharenko <earwin@gmail.com> Thu, 16 Jul 2015 12:13:46 +0000
173
174osmo-trx (0.1.8) precise; urgency=low
175
176 * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP
177
178 -- Ivan Klyuchnikov <Ivan.Kluchnikov@fairwaves.ru> Sun, 9 Mar 2014 14:10:10 +0400