blob: c88b703cde3271538153db21b58c18eb264b547d [file] [log] [blame]
Pau Espin Pedrole774d522019-08-07 21:12:56 +02001osmo-trx (1.1.0) unstable; urgency=medium
2
3 [ Sylvain Munaut ]
4 * arm/convolve: Fix the vfp4 real convolution for h_len=12
5 * convolve: Remove support for step, offset parameters
6 * tests: Rework the convolve_test
7 * tests: Re-enable the convolve_test by default
8 * sigProcLib: Add C/I (Carrier-to-Interference ratio) computation
9
10 [ Vadim Yanitskiy ]
11 * VTY: add extended (11-bit) RACH detection toggle
12 * doc/configuration.adoc: fix incorrect number of physical RF channels for B210
13 * driveTxPriorityQueue(): cosmetic: use proper type for TDMA TN
14 * driveTxPriorityQueue(): use trxd_hdr_common for message parsing
15 * driveTxPriorityQueue(): check if message header format is supported
16 * driveTxPriorityQueue(): enrich logging message
17 * trxd_fill_common(): fix TRXD header version coding
18 * manuals/configuration.adoc: fix copy-paste error in config example
19
20 [ Pau Espin Pedrol ]
21 * osmo-trx: Avoid handling signals after shutdown triggered
22 * osmo-trx: Use signalfd to serialize signals in main thread ctx
23 * osmo-trx: Check return code of osmo_fd_register
24 * lms: flush_recv: alloc buf on stack instead of heap
25 * lms: Improve log during flush recv error
26 * cosmetic: Threads.h: Remove trailing whitespace
27 * Move duplicated thread_enable_cancel to CommonLibs
28 * lms: Log underrun/overrun events
29 * lms: Remove references to ALERT loglevel
30 * lms: Remove unused var m_last_tx_overruns
31 * lms: Catch and log dropped packets by HW during recv
32 * cosmetic: uhd: Move smpl_buf out of UHDDevice, move UHDDevice class definition to .h
33 * uhd: smpl_buf: Drop UHD specifics out back to UHDDevice
34 * uhd: smpl_buf: Use TIMESTAMP type in str_status
35 * cosmetic: uhd: Use loglevel ERROR instead of ERR
36 * uhd: Avoid reallocation of buffers every read
37 * Move smpl_buf out of uhd dir to re-use it in other devices
38 * device: Drop unused numberRead/numberWritten APIs
39 * smpl_buf: Remove unused clk_rt variable
40 * smpl_buf: Remove unused clk_rt variable (fixup)
41 * smpl_buf: Remove dbg log line with duplicated info
42 * Introduce LOGCHAN macro to standarize logging channel info
43 * smpl_buf: Move it to device/common and create libdevice_common.la
44 * lms: Use smpl_buf to recover from timestamp jumps
45 * lms: Fix stream_stats checks with droppedPackets
46 * Add rate_ctr support to store/retrieve SDR errors through VTY
47 * Rename and move STOP signal from Transceiver to main
48 * doc: vty: Update trx_vty_reference.xml
49 * lms: Drop unusued variable masterClockRate
50 * lms: Fix stream_stats checks with overrun/underrun
51 * Add VTY commands to set error ctr thresholds
52 * Remove AUTHORS file
53 * trx_{vty,rate_ctr}: Set proper license AGPLv3+
54 * Introduce structs to encode TRXD packets
55 * Transceiver: refactor: gather uplink burst parameters in struct
56 * Transceiver: Drop unused rssi_valid struct field
57 * Transceiver: Move nbits burst size calculation to pullRadioVector()
58 * Transceiver: Move calculation of normalized values (rssiOffset) to pullRadioVector()
59 * Transceiver: Move soft bits normalization to pullRadioVector()
60 * Transceiver: Drop use of GSM::Time from trx_ul_burst_ind
61 * Transceiver: Get rid of SoftVector in struct trx_ul_burst_ind
62 * Transceiver: replace UDPSocket with libosmocore socket API
63 * Transceiver: Avoid noise calculation formula in 2 branches in pullRadioVector
64 * Transceiver: Simplify code on early error return when calling detectAnyBurst
65 * Transceiver: pullRadioVector(): Move initialization of var to start of function
66 * Transceiver: Support pulling idle frames in pullRadioVector()
67 * sigProcLib: detectAnyBurst() family: Use struct to gather all out params
68 * sigProcLib: detectAnyBurst(): make TSC used to detect burst available to caller
69 * Logger: global Log mutex is now available from C code
70 * Transceiver: Move out TRXD socket send code to prepare for TRXDv1
71 * Transceiver: Support SETFORMAT command
72 * Transceiver: Support TRXD v1
73 * Transceiver: Initialize mExtRACH in constructor
74 * debian/copyright: Remove non existent radioInterfaceDiversity.cpp from list
75 * debian/copyright: Update wrong paths in license list
76 * debian/copyright: Add missing file Utils.* to LGPL-2.1+ list
77 * cosmetic: Fix trailing whitespace in several files
78 * Add SPDX annotation
79 * Bind CTRL port to IP addr specified in VTY config
80 * Transceiver: Store TRXD version per channel
81 * Transceiver: Clean up code passing parameters to threads
82 * Remove empty ChangeLog fnd NEWS files
83 * Remove unused autogen.sh
84 * radioInterface: Clarify how underruns are handled driving a radioDevice
85 * usrp1: don't check for non-null underrun pointer
86 * jenkins.sh: Workaround libusrp build race conditon
87 * lms: Drop rx_underruns rate ctr, add tx_drop_* rate ctr
88 * Move inband-signaling-usb documentation to UserManual
89 * Move matlab files under utils/matlab
90 * Move Transceiver52/README to UserManual
91 * Move README.DFEsymbolspaced to utils/matlab
92 * Move std_inband.rbf under device/usrp1/ dir
93 * Drop old README information, provide new updated README
94 * Transceiver: Add missing include netinet/in.h
95 * Require newer version of libosmocore to avoid build failure
96
97 [ Tom Tsou ]
98 * multi-ARFCN: fix maximum number of carriers limitation
99
100 [ Harald Welte ]
101 * use BSC_FD_READ and not OSMO_FD_READ
102 * proto_trxd.c: Use bit-wise AND, not boolean AND
103 * Timeval: Restore output stream flags after changing them
104 * ChannelizerBase: fix initialization of class members
105 * CorrelationSequence: fix initialization of class members
106 * radioInterface.cpp: Fix missing member initialization of RadioInterface()
107
108 [ Joachim Steiger ]
109 * lms: Remove wrong unused code copied from -uhd
110 * lms: move LMS_EnableChannel from Start/Stop to Open/Close device
111 * lms: move LMS_GetLPFBWRange and LMS_Calibrate calls from open to start
112 * lms: add device type detection and device specific gains
113 * lms: properly call close if set_antennas() fails, add some comments
114
115 [ Oliver Smith ]
116 * debian: create -doc subpackage with pdf manuals
117 * contrib/jenkins.sh: run "make maintainer-clean"
118
119 [ Eric Wild ]
120 * Add option to set stack size in config file, default == 0 == OS default
121
122 [ Ruben Undheim ]
123 * Fix spelling discovered by lintian
124
125 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 21:12:56 +0200
126
Harald Welted20b7fa2019-01-20 19:35:05 +0100127osmo-trx (1.0.0) unstable; urgency=medium
128
129 [ Pau Espin Pedrol ]
130 * doc: examples: Add umtrx sample config
131 * UHDDevice: Fix setup failure with LimeSuite > 18.04.1
132 * examples: Set rt-prio 18 and print file basename
133 * lms: Several improvements and compilation/runtime fixes
134 * build: Add support for LimeSuite device backend
135 * LMSDevice: Set correct values for Max{Tx,Rx}Gain
136 * LMSDevice: Fix setup failure with LimeSuite > 18.04.1
137 * lms: Makefile.am: Reorder params to fix link issue
138 * lms: Check LPBFW to set is within supported range
139 * debian: Add package osmo-trx-lms
140 * contrib: Add systemd services for all backends
141 * debian: Add cfg file examples for osmo-trx-{lms,uhd}
142 * Add -V param to print version
143 * lms: Allow values diff than 34dB to be set by setRxGain()
144 * Use correct paths when installing example files
145 * debian: Enable build of osmo-trx-lms
146 * debian: Explicitly enable osmo-trx-uhd build
147 * configure.ac: Fix typo in with-lms help string
148 * vty: Fix typo in gpsdo clock reference type
149 * configure.ac: Add --enable-werror option
150 * Logger: Disable pthread cancel point inside Logger destructor
151 * cosmetic: Fix trailing whitespace
152 * radioInterface: forward errors from RadioDevice to Transceiver in recv path
153 * lms: Return error on device read timeout
154 * osmo-trx: Add osmo_signal to stop whole transceiver chain correctly on error
155 * radioInterface: Fix variable storing integer return value
156 * configure.ac: Specify default language as C++
157 * UHHDDevice: Replace deprecated header uhd/utils/thread_priority.hpp
158 * SigProcLib: Use available copyTo Vector API instead of memcopy
159 * cosmetic: Fix trailing whitespace in several files
160 * radioInterfaceMulti:pullBuffer: Sanely convert float array to complex array
161 * Vector: Copy arrays in a sane way for non-trivially copyable types
162 * jenkins.sh: Add --enable-werror flag to osmo-trx configure step
163 * Install systemd services with autotools
164 * Install sample cfg file to /etc/osmocom
165 * cosmetic: Use proper whitespace in several for loops
166 * Use pthread_setname_np to name threads
167 * CommonLibs/Makefile.am: Specify libcommon_la_LIBADD
168 * Transciever: Log values causing Tx underrun
169 * examples: Use logging level 'set-all' instead of 'all'
170 * jenkins.sh: Enable build of osmo-trx-lms
171 * ChannelizerBase: Fix ASan alloc-dealloc-mismatch
172 * UHDDevice: setRxGain on chan 0 when using multi-arfcn
173 * lms: Use LimeSuite.h log level defines instead of hardcoded values
174 * lms: Apply LMS->OSMO log level conversion
175 * Introduce OsmoTRX manual
176 * Introduce chapter trx_if.adoc and add it to OsmoTRX and OsmoBTS
177 * trx: Add reference to project wiki page in overfiew section
178 * trx: Add Hardware architecture support section
179 * trx: Add Hardware device support section
180 * osmotrx: Split Device specific section from backend one
181 * osmotrx: Write initial documentation for several supported devices
182 * osmotrx: configuration: Add section to document multi-arfcn feature
183 * osmotrx: Create a common chapter for section documenting backends
184 * osmotrx: Introduce code architecture chapter
185 * lms: Fix start after stop of device
186 * lms: Destroy streams on device stop
187 * radioInterface: Fix memleak during close()
188 * PointerFIFO: Fix memleak of ListNode
189 * lms: Make sure LMS_Close is called when Device is torn down
190 * osmo-trx: Change some lines to use libosmocore logging instead of cout
191 * lms: Close device on LMS_Init failure
192 * SigProcLib: Improve Vector buffer allocation mess
193 * lms: Allow setting Tx/RxGain for chan!=0
194 * lms: Allow setting Tx/RxFreq for lchan!=0
195 * lms: Improve Set{Rx,Tx}{Gain,Freq} logging
196 * transceiver: log chan on CTRL command received
197 * Add TRXCTRL log category
198 * transceiver: Log TRXCTRL iface responses towards osmo-bts-trx
199 * lms: Move {under,over}run checks into separate method
200 * lms: Do {under,over}run checks even if LMS_RecvStream fails
201 * Timeval: passed() returns true if time is equal
202 * Timeval: Move implementation to use clock_gettime and timespec
203 * Timeval: Move to osmo_clock_gettime
204 * TimevalTest: Make test deterministic with fake time
205 * lms: Fix build against LimeSuite > 18.10
206 * configure.ac: check boost only if USRP1 support is enabled
207
208 [ Vadim Yanitskiy ]
209 * trx_vty.c: fix: use CONFIG_NODE as parent by default
210 * device/lms/LMSDevice.cpp: fix compilation warning
211 * sigProcLib: introduce both TS1 and TS2 RACH synch. sequences
212 * sigProcLib: add a CorrType for extended (11-bit) RACH
213
214 [ Harald Welte ]
215 * Initial work towards direct LimeSuite support in OsmoTRX
216 * update .gitignore to include osmo-trx-lms
217 * LMSDevice: Call LMS_Init() before setting sample rate
218 * LMSDevice: Print sample rate range + actual sample rate after setting it
219 * LMSDevice: Typo fix: s/Internal/External
220 * LMSDevice: Set low-pass filters to smallest possible option
221 * LMSDevice: Fix initial timestamp offset of 2500
222 * LMS_Device: Set ts_offset to 0.
223 * LMSDevice: Reduce Rx logging verbosity: Only log unexpected timestamps
224 * move set_antennas() from UHD to generic radioDevice base class
225 * lms: Fix support for rx_paths / tx_paths
226 * lms: Call set_antennas() during open() method
227 * radioDevice: Move tx_sps from derived into base class
228 * radioDevice: better encapsulation in base class
229 * lms: Fix coding style
230 * lms: Fail in case of unsupported configuration
231 * usrp1: Fail in case of unsupported configuration
232 * Fix config file saving of {tx,rx}-path VTY config strings
233 * logging: Introduce new "DDEV" category for device-specific code
234 * update git-version-gen to generate proper version numbers
235 * ensure well-formed example config files
236 * SocketsTest.testReaderIP(): Zero terminate received buffer
237 * trx_validate_config(): Fix validation of rx_sps
238 * vty-ref: Update URI of docbook 5.0 schema
239 * lms: User correct scale factor for transmit samples
240 * lms: Set Rx gain to midpoint, as comment suggests.
241 * usrp1: Remove uninitialized skipRx logic
242 * usrp1: Fix formatting of log message (missing space)
243 * cosmetic: Don't call the SDR "USRP" in error message
244
245 [ Zydrunas Tamosevicius ]
246 * lms: Use same timestamp offset like when using LimeSDR via UHD
247 * lms: Reduce log level of "send buffer of len ..."
248 * lms: fix LMS_StartStream() handling for multiple channels
249 * lms: Reduce Rx gain from 47 to 34 dB
250
251 [ Alexander Couzens ]
252 * debian: add patches for debian8
253
254 [ Oliver Smith ]
255 * Add long parameters (--help, --version, ...)
256 * build manuals moved here from osmo-gsm-manuals.git
257 * Fix DISTCHECK_CONFIGURE_FLAGS override
258 * contrib/jenkins.sh: build and publish manuals
259 * jenkins.sh: run "make distcheck"
260 * contrib: fix makedistcheck with disabled systemd
261 * osmo-trx.cpp: move comma_delimited_to_vector() to Utils.cpp
262 * LMSDevice: make use of dev-args in osmo-trx.cfg
263 * LMSDeviceTest: fix link errors on OBS
264
265 [ Neels Hofmeyr ]
266 * Importing history from osmo-gsm-manuals.git
267
268 [ d0gtail ]
269 * UHDDevice: log exception information on device open failure
270
271 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 19:35:04 +0100
272
Pau Espin Pedrold0ac9262018-05-03 16:23:30 +0200273osmo-trx (0.4.0) unstable; urgency=medium
274
275 [ Neels Hofmeyr ]
276 * jenkins: use osmo-clean-workspace.sh before and after build
277
278 [ Harald Welte ]
279 * SocketsTest: Fix printing of non-nul-terminated string
280 * Revert "debian: Remove osmo-trx-usrp1 until we can build libusrp1.deb"
281 * debian/control: Remove "Maintainer" from binary package section
282 * debian/rules: Make sure we always require libusrp
283 * debian: Ensure USRP1 firmware is part of osmo-trx-usrp1
284 * debian/control: Add build dependency to libusrp-dev
285 * update .gitignore for new executable names
286 * osmo-trx: s/GSM Core Address/GSM BTS Address/
287
288 [ Piotr Krysik ]
289 * UHDDevice.cpp: add USRP B205mini support
290
291 [ Max ]
292 * Mark release target as virtual
293 * Remove outdated references to OpenBTS
294 * Remove unused headers
295 * Update installation instructions
296 * Update legal disclaimer
297 * Update license notes
298 * tests: null-terminate buffer
299
300 [ Pau Espin Pedrol ]
301 * cosmetic: Remove trailing whitespace
302 * Logger: Stop using Log.Alarms.Max from config
303 * Logger: Stop using Log.File and Log.Level from config
304 * Drop use of ConfigurationTable gConfig
305 * Remove Configuration module and libsqlite dependency
306 * cosmetic: AUTHORS: fix trailing whitespace
307 * Set up GNU Autotest infrastructure
308 * tests: InterThread: adapt to have reproducible output and enable autotest
309 * tests: Timeval: adapt to have reproducible output and enable autotest
310 * tests: Log: adapt to have reproducible output and enable autotest
311 * Sockets.cpp: Fix initialization of UDD socket
312 * tests: Sockets: adapt to have reproducible output and enable autotest
313 * utils/convolvtest: Remove uneeded libosmocore dependency
314 * Move ARCH_LA to Makefile.common
315 * tests: Migrate convtest util to autotest infrastructure
316 * arm/convert.c: Fix compilation error
317 * arm/convert.c: Add missing convert_init implementation
318 * .gitignore: Add missing test related files
319 * Remove UDDSocket class
320 * tests: SocketTests: Pick OS-assigned instead of setting one manually
321 * tests: SocketsTest: Avoid hang forever if test fails
322 * tests: SocketsTest: Fail test on write fail
323 * tests: TimevalTest: refactor and avoid double comparison
324 * contrib/jenkins.sh: Use qemu+proot+debootstrap to run tests with ARM instruction set
325 * tests: convolve: Disable due to difference in output in different archs
326 * Remove unneeded libdl dependency
327 * Fix whitespace
328 * Add support to set Rx/TxAntenna
329 * UHDDevice: Initialize async_event_thrd in constructor
330 * Logger: Drop unused gLogEarly
331 * Logger: Remove unused logging macros
332 * Logger: get rid of alarm APIs
333 * Logger: Drop syslog support
334 * Logger: Drop support to log into file
335 * Logger: Remove unused includes
336 * Logger: Remove gLogToConsole flag
337 * configure.ac: Check for pkg-config
338 * Depend on libosmocore
339 * osmo-trx: set up signals using libosmocore helpers
340 * osmo-trx: Set up talloc ctx
341 * debian: Depend on libtalloc and libosmocore
342 * Add initial support for logging, vty, ctrl
343 * Logger: Use libosmocore logging system
344 * osmo-trx.cpp: Move trx start and stop to helper functions
345 * Move enums required by VTY to a separate header
346 * vty: Implement VTY cfg parsing for current parameters
347 * doc: Add sample cfg file for LimeSDR
348 * osmo-trx: Use VTY cfg structures while still allowing cmd line options
349 * osmo-trx: Re-introduce -l cmd line parameter
350 * Makefile.am: Avoid using subdir if arch is not required
351 * Build Transceiver52M/common as an .la lib
352 * use osmo_init_logging2()
353 * tests: Makefile.am: Fix typo in include path
354 * configure.ac: Add --enable-sanitize option
355 * Move arch specific fiels to arch subdir
356 * Move device specific files to device subdir
357 * Change configure define USRP1 to DEVICE_USRP1
358 * Move device specific code out of radioInterface
359 * Transceiver: Move device specific code to radioDevice class
360 * Build one osmo-trx binary for each device support enabled
361 * Logger: Print correct source file and line number
362 * Transceiver: log timing info of stale bursts
363 * build: Fix make distcheck
364 * build: More OBS build failure fixes
365 * jenkins.sh: Enable build of osmo-trx-usrp1
366 * debian: Remove osmo-trx-usrp1 until we can build libusrp1.deb
367 * debian: Fix OBS build
368 * build: Fix OBS build for ARM
369 * git-version-gen: Take into account tags not in master
370
371 [ Alexander Huemer ]
372 * Unbreak `./configure --with-usrp1` build
373 * Fix USRP1 build with support for setting Rx/TxAntenna
374
375 [ Alexander Couzens ]
376 * jenkins.sh: fix the download url if the qemu image wasn't setup
377 * jenkins.sh: cleanup always the workspace
378 * jenkins.sh: change qemu-img default location to $HOME/qemu-img instead of /opt/qemu-img
379
380 [ Vadim Yanitskiy ]
381 * Transceiver.cpp: use a define for the MAX_PACKET_LENGTH
382 * Transceiver.cpp: properly zero-terminate received commands
383 * Transceiver.cpp: use pointer arithmetics for CMD parsing
384 * Transceiver.cpp: fix incorrect format string for SETTSC
385 * Transceiver.cpp: prevent out-of-range array access
386
387 [ Martin Hauke ]
388 * configure.ac: Fix typo
389
390 [ Philipp Maier ]
391 * doc: add example config for usrp B200 series
392
393 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:23:29 +0200
394
Harald Welte78e1cd22017-10-28 17:52:32 +0200395osmo-trx (0.2.0) unstable; urgency=medium
396
397 [ Alexander Chemeris ]
398 * EDGE: Add support for UmTRX.
399 * Common: Get rid of a compilation warning.
400 * Common: Make sure gLogEarly() log to the same facilities as the normal log.
401 * transceiver: Properly handle MAXDLY.
402 * transceiver: Add an option to generate random Access Bursts.
403 * osmo-trx: Output Rx SPS as a part of configuration output.
404 * transceiver: Do not pass transceiver state struct to function where it's not used.
405 * makefile: Fix build from an external path.
406 * radioDevice: GSMRATE macro must have parentheses around its definition.
407 * uhd: Fix comment.
408 * radioInterface: Initialize power scale with a meaningful default.
409 * transceiver: Log channel number in DEBUG output of demoded bursts.
410 * transceiver: Add an option to emulate a RACH delay in random filler mode.
411 * UHD: Initial LimeSDR support.
412 * CommonLibs: Remove unused files.
413 * sigProcLib: Typo sybols -> symbols
414 * radioBuffer: Remove extra ; at the end of inline function definitions.
415 * sigProcLib: Fix documentation, sync argument names in .cpp and .h files.
416 * sigProcLib: make energyDetect() simpler by returning actual energy.
417 * sigProcLib: Rename demodulateBurst() to demodGmskBurst() for clarity.
418 * sigProcLib: Slice SoftVector instead of signalVector for GMSK demod.
419 * Call vectorSlicer() right before packing bits for transmission to osmo-bts.
420 * CommonLibs: Print soft bits with less confidence to console when printing a soft vector.
421 * BitVector: Remove convolutional codec - we don't use it in osmo-trx.
422 * BitVector: Convert SoftVector from 0..1 to -1..+1 soft bits.
423 * signalVector: Implement segment().
424 * vector: Introduce segmentMove() method to move data inside of a vector.
425 * vector: Introduce shrink() function to shrink vector size without loosing data.
426 * Move CorrType type from Transceiver to sigProcLib.
427 * sigProcLib: rename signalError type to SignalError.
428 * Move Transceiver::detectBurst() to sigProcLib to make it reusable.
429 * Move BURST_THRESH from Transceiver.cpp to sigProcLib.h to make it reusable.
430 * sigProcLib: Add operator<< to print CorrType to a string.
431 * sigProcLib.h: Fix whitespaces. No non-whitespace changes.
432 * Move Transceiver::demodulate() to sigProcLib to make it reusable.
433 * sigProcLib: constify signalVector arguments for detectBurst() functions.
434 * sigProcLib: Constify demodulation functions burst argument.
435 * sigProcLib: Fix number of tail bits in random Normal Bursts and zero Stealing Bits.
436 * Configuration: Variables allocated with 'new' must be freed with 'delete'.
437 * BitVector: Remove Generator class.
438 * PRBS: a Pseudo-random binary sequence (PRBS) generator class.
439
440 [ Tom Tsou ]
441 * EDGE: Fix USRP B210 device support
442 * uhd: Correct timing alignment in 8-PSK and GMSK downlink bursts
443 * EDGE: Fix demodulation slicer input
444 * common: Restrict UDP binding to localhost only
445 * common: Add mandatory length field to UDP receive calls
446 * uhd: Update default E3XX settings
447 * uhd: Set default Tx sampling to 4 sps
448 * uhd: Make device offset check a private method
449 * uhd: Set minimum UHD version requirement for E3XX
450 * sigproc: Expand RACH, TSC, and EDGE correlation windows
451 * transceiver: Do not report error on SETTSC when radio is on
452 * transceiver: Add Rx samples-per-symbol option
453 * radioInterface: Convert diversity argument to general type
454 * iface: Add inner ring-buffer implementation
455 * mcbts: Add multi-ARFCN channelizing filters
456 * mcbts: Add multi-ARFCN radio support
457 * sigproc: Adjust burst detection threshold criteria
458 * egprs: Enable 8-PSK length vectors on the Tx interface
459 * egprs: Enable 8-PSK burst detection when EDGE is enabled
460 * transceiver: Remove HANDOVER warnings
461 * mcbts: Allow out of order channel setup
462 * radioInterface: Fix multi-channel buffer index bug
463 * uhd: Add command line option for GPS reference
464 * transceiver: Fix mixed GSMK / 8-PSK transmission
465 * transceiver: Fix 4 SPS receive TOA value
466 * sigproc: Fix missing 8-PSK tail symbols
467 * uhd: Update USRP2/N200/N210 for 4 SPS Rx
468 * sigproc: Match differential GMSK start/end bits to tail bits
469 * uhd: Add missing B200 sample timing for 4 SPS receive
470 * transceiver: Fix command build warning
471 * uhd: Set minimum supported version to 3.9.0
472 * uhd: Add X300 sample timing for 4 SPS
473 * Revert "uhd: Set minimum supported version to 3.9.0"
474 * uhd: Add support for UHD-3.11 logging control
475 * uhd: Increase MC-BTS FPGA clock rate to 51.2 MHz
476 * Resampler: Fix initialization return checking
477 * sigProcLib: Remove unreachable code and no-effect checks
478 * sigProcLib: Check return status on downsampling
479 * sigProcLib: Fix negative value check on unsigned value
480 * Resampler: Fix non-array delete for filter taps
481 * Transceiver: Remove unsigned negative compares
482 * Configuration: Fix const and signedness compile warnings
483 * config: Remove OpenBTS style sqlite configuration
484 * radioInterface: Remove UmTRX 'diversity' option
485 * build: Require and check for gcc C++11 support
486 * uhd: Use map container for for device parameter access
487 * sigProcLib: Remove unused functions from public interface
488 * uhd: Add non-UmTRX channel swap support
489 * uhd: Fix Tx-RX timing offset setting
490 * uhd: Fix USRP2/N200/N210 device detection
491 * transceiver: Fix POWEROFF crash on USRP2/N200/X300 devices
492 * sigProcLib: Fix complex/real vector flag in Laurent modulator
493 * sigProcLib: Remove heap based signal vector allocations
494 * common: Declare explicit Vector move constructor
495 * sigProcLib: Remove trigonometric tables
496 * sigProcLib: Use explicit NaN check in sinc table generation
497 * sigProcLib: Replace dynamically allocated resampling buffers
498 * sigProcLib: Specify standard namespace for isnan()
499 * uhd: Always specify samples-per-symbol for device lookup
500 * LimeSDR: set approximate tx offset value to make GSM work
501
502 [ Neels Hofmeyr ]
503 * add basic .gitignore
504 * configure.ac: check for boost/config.hpp header
505 * The INSTALL file is being overwritten by autoreconf, but it is committed as empty file. As a result, the INSTALL file always shows as modified. Instead, remove INSTALL from git and ignore it.
506 * add contrib/jenkins.sh, for gerrit build bot
507
508 [ pierre.baudry ]
509 * transceiver: Fix mismatched allocations and deallocations
510
511 [ Holger Hans Peter Freyther ]
512 * debian: Require fftw3 header files for osmo-trx
513
514 [ Max ]
515 * Add gerrit settings
516 * Integrate Debian packaging changes
517 * Remove embedded sqlite3
518 * Fix building against sqlite3
519 * Add autoconf-archive to dependencies
520 * debian: remove obsolete dependency
521 * deb: remove unused dependency
522 * Remove redundant explicit dependency
523 * Use release helper from libosmocore
524
525 [ Ruben Undheim ]
526 * Do not embed sqlite3 when building
527
528 [ Philipp Maier ]
529 * buildenv: Turn off native architecture builds
530 * cosmetic: Make parameter lists uniform
531 * Add test program to verify convolution implementation
532 * ssedetect: Add runtime CPU detection
533 * cosmetic: remove code duplication
534 * buildenv: Make build CPU invariant
535 * buildenv: Split up SSE3 and SSE4.1 code
536 * cosmetic: Add info about SSE support
537
538 [ Vadim Yanitskiy ]
539 * buildenv: correct the ax_sse macro description
540 * buildenv: actually strip unused cpuid functionality
541 * buildenv: fix build on systems without SIMD support
542 * buildenv: cosmetic changes
543 * buildenv: check for __builtin_cpu_supports call support
544 * ssedetect: call __builtin_cpu_supports() only if supported
545
546 [ Pau Espin Pedrol ]
547 * cosmetic: transciever: Remove trailing whitespaces
548 * transceiver: Avoid sending clock indications when trx is not powered on
549 * Add -j option to bind to specific address
550
551 [ ignasj ]
552 * LimeSDR: Change device detection to work with USB and PCIe versions
553 * LimeSDR: change tx window type to TX_WINDOW_FIXED
554 * LimeSDR: Fix sample value range
555
556 [ Harald Welte ]
557 * Add '-t' command line option to enable SCHED_RR
558 * Import git-version-gen and update AC_INIT()
559
560 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 17:52:32 +0200
561
Holger Hans Peter Freytherd17b1892016-03-18 20:13:23 +0100562osmo-trx (0.1.9) trusty; urgency=medium
563
564 * Ask Ivan, really
565
566 -- Kirill Zakharenko <earwin@gmail.com> Thu, 16 Jul 2015 12:13:46 +0000
567
568osmo-trx (0.1.8) precise; urgency=low
569
570 * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP
571
572 -- Ivan Klyuchnikov <Ivan.Kluchnikov@fairwaves.ru> Sun, 9 Mar 2014 14:10:10 +0400