blob: 96cd20808954a17fd13e17356777207ffe2d1650 [file] [log] [blame]
Pau Espin Pedrold0cbb162019-08-08 13:00:06 +02001osmo-trx (1.1.1) unstable; urgency=medium
2
3 * UNRELEASED
4
5 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 08 Aug 2019 13:00:05 +0200
6
Pau Espin Pedrole774d522019-08-07 21:12:56 +02007osmo-trx (1.1.0) unstable; urgency=medium
8
9 [ Sylvain Munaut ]
10 * arm/convolve: Fix the vfp4 real convolution for h_len=12
11 * convolve: Remove support for step, offset parameters
12 * tests: Rework the convolve_test
13 * tests: Re-enable the convolve_test by default
14 * sigProcLib: Add C/I (Carrier-to-Interference ratio) computation
15
16 [ Vadim Yanitskiy ]
17 * VTY: add extended (11-bit) RACH detection toggle
18 * doc/configuration.adoc: fix incorrect number of physical RF channels for B210
19 * driveTxPriorityQueue(): cosmetic: use proper type for TDMA TN
20 * driveTxPriorityQueue(): use trxd_hdr_common for message parsing
21 * driveTxPriorityQueue(): check if message header format is supported
22 * driveTxPriorityQueue(): enrich logging message
23 * trxd_fill_common(): fix TRXD header version coding
24 * manuals/configuration.adoc: fix copy-paste error in config example
25
26 [ Pau Espin Pedrol ]
27 * osmo-trx: Avoid handling signals after shutdown triggered
28 * osmo-trx: Use signalfd to serialize signals in main thread ctx
29 * osmo-trx: Check return code of osmo_fd_register
30 * lms: flush_recv: alloc buf on stack instead of heap
31 * lms: Improve log during flush recv error
32 * cosmetic: Threads.h: Remove trailing whitespace
33 * Move duplicated thread_enable_cancel to CommonLibs
34 * lms: Log underrun/overrun events
35 * lms: Remove references to ALERT loglevel
36 * lms: Remove unused var m_last_tx_overruns
37 * lms: Catch and log dropped packets by HW during recv
38 * cosmetic: uhd: Move smpl_buf out of UHDDevice, move UHDDevice class definition to .h
39 * uhd: smpl_buf: Drop UHD specifics out back to UHDDevice
40 * uhd: smpl_buf: Use TIMESTAMP type in str_status
41 * cosmetic: uhd: Use loglevel ERROR instead of ERR
42 * uhd: Avoid reallocation of buffers every read
43 * Move smpl_buf out of uhd dir to re-use it in other devices
44 * device: Drop unused numberRead/numberWritten APIs
45 * smpl_buf: Remove unused clk_rt variable
46 * smpl_buf: Remove unused clk_rt variable (fixup)
47 * smpl_buf: Remove dbg log line with duplicated info
48 * Introduce LOGCHAN macro to standarize logging channel info
49 * smpl_buf: Move it to device/common and create libdevice_common.la
50 * lms: Use smpl_buf to recover from timestamp jumps
51 * lms: Fix stream_stats checks with droppedPackets
52 * Add rate_ctr support to store/retrieve SDR errors through VTY
53 * Rename and move STOP signal from Transceiver to main
54 * doc: vty: Update trx_vty_reference.xml
55 * lms: Drop unusued variable masterClockRate
56 * lms: Fix stream_stats checks with overrun/underrun
57 * Add VTY commands to set error ctr thresholds
58 * Remove AUTHORS file
59 * trx_{vty,rate_ctr}: Set proper license AGPLv3+
60 * Introduce structs to encode TRXD packets
61 * Transceiver: refactor: gather uplink burst parameters in struct
62 * Transceiver: Drop unused rssi_valid struct field
63 * Transceiver: Move nbits burst size calculation to pullRadioVector()
64 * Transceiver: Move calculation of normalized values (rssiOffset) to pullRadioVector()
65 * Transceiver: Move soft bits normalization to pullRadioVector()
66 * Transceiver: Drop use of GSM::Time from trx_ul_burst_ind
67 * Transceiver: Get rid of SoftVector in struct trx_ul_burst_ind
68 * Transceiver: replace UDPSocket with libosmocore socket API
69 * Transceiver: Avoid noise calculation formula in 2 branches in pullRadioVector
70 * Transceiver: Simplify code on early error return when calling detectAnyBurst
71 * Transceiver: pullRadioVector(): Move initialization of var to start of function
72 * Transceiver: Support pulling idle frames in pullRadioVector()
73 * sigProcLib: detectAnyBurst() family: Use struct to gather all out params
74 * sigProcLib: detectAnyBurst(): make TSC used to detect burst available to caller
75 * Logger: global Log mutex is now available from C code
76 * Transceiver: Move out TRXD socket send code to prepare for TRXDv1
77 * Transceiver: Support SETFORMAT command
78 * Transceiver: Support TRXD v1
79 * Transceiver: Initialize mExtRACH in constructor
80 * debian/copyright: Remove non existent radioInterfaceDiversity.cpp from list
81 * debian/copyright: Update wrong paths in license list
82 * debian/copyright: Add missing file Utils.* to LGPL-2.1+ list
83 * cosmetic: Fix trailing whitespace in several files
84 * Add SPDX annotation
85 * Bind CTRL port to IP addr specified in VTY config
86 * Transceiver: Store TRXD version per channel
87 * Transceiver: Clean up code passing parameters to threads
88 * Remove empty ChangeLog fnd NEWS files
89 * Remove unused autogen.sh
90 * radioInterface: Clarify how underruns are handled driving a radioDevice
91 * usrp1: don't check for non-null underrun pointer
92 * jenkins.sh: Workaround libusrp build race conditon
93 * lms: Drop rx_underruns rate ctr, add tx_drop_* rate ctr
94 * Move inband-signaling-usb documentation to UserManual
95 * Move matlab files under utils/matlab
96 * Move Transceiver52/README to UserManual
97 * Move README.DFEsymbolspaced to utils/matlab
98 * Move std_inband.rbf under device/usrp1/ dir
99 * Drop old README information, provide new updated README
100 * Transceiver: Add missing include netinet/in.h
101 * Require newer version of libosmocore to avoid build failure
102
103 [ Tom Tsou ]
104 * multi-ARFCN: fix maximum number of carriers limitation
105
106 [ Harald Welte ]
107 * use BSC_FD_READ and not OSMO_FD_READ
108 * proto_trxd.c: Use bit-wise AND, not boolean AND
109 * Timeval: Restore output stream flags after changing them
110 * ChannelizerBase: fix initialization of class members
111 * CorrelationSequence: fix initialization of class members
112 * radioInterface.cpp: Fix missing member initialization of RadioInterface()
113
114 [ Joachim Steiger ]
115 * lms: Remove wrong unused code copied from -uhd
116 * lms: move LMS_EnableChannel from Start/Stop to Open/Close device
117 * lms: move LMS_GetLPFBWRange and LMS_Calibrate calls from open to start
118 * lms: add device type detection and device specific gains
119 * lms: properly call close if set_antennas() fails, add some comments
120
121 [ Oliver Smith ]
122 * debian: create -doc subpackage with pdf manuals
123 * contrib/jenkins.sh: run "make maintainer-clean"
124
125 [ Eric Wild ]
126 * Add option to set stack size in config file, default == 0 == OS default
127
128 [ Ruben Undheim ]
129 * Fix spelling discovered by lintian
130
131 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 21:12:56 +0200
132
Harald Welted20b7fa2019-01-20 19:35:05 +0100133osmo-trx (1.0.0) unstable; urgency=medium
134
135 [ Pau Espin Pedrol ]
136 * doc: examples: Add umtrx sample config
137 * UHDDevice: Fix setup failure with LimeSuite > 18.04.1
138 * examples: Set rt-prio 18 and print file basename
139 * lms: Several improvements and compilation/runtime fixes
140 * build: Add support for LimeSuite device backend
141 * LMSDevice: Set correct values for Max{Tx,Rx}Gain
142 * LMSDevice: Fix setup failure with LimeSuite > 18.04.1
143 * lms: Makefile.am: Reorder params to fix link issue
144 * lms: Check LPBFW to set is within supported range
145 * debian: Add package osmo-trx-lms
146 * contrib: Add systemd services for all backends
147 * debian: Add cfg file examples for osmo-trx-{lms,uhd}
148 * Add -V param to print version
149 * lms: Allow values diff than 34dB to be set by setRxGain()
150 * Use correct paths when installing example files
151 * debian: Enable build of osmo-trx-lms
152 * debian: Explicitly enable osmo-trx-uhd build
153 * configure.ac: Fix typo in with-lms help string
154 * vty: Fix typo in gpsdo clock reference type
155 * configure.ac: Add --enable-werror option
156 * Logger: Disable pthread cancel point inside Logger destructor
157 * cosmetic: Fix trailing whitespace
158 * radioInterface: forward errors from RadioDevice to Transceiver in recv path
159 * lms: Return error on device read timeout
160 * osmo-trx: Add osmo_signal to stop whole transceiver chain correctly on error
161 * radioInterface: Fix variable storing integer return value
162 * configure.ac: Specify default language as C++
163 * UHHDDevice: Replace deprecated header uhd/utils/thread_priority.hpp
164 * SigProcLib: Use available copyTo Vector API instead of memcopy
165 * cosmetic: Fix trailing whitespace in several files
166 * radioInterfaceMulti:pullBuffer: Sanely convert float array to complex array
167 * Vector: Copy arrays in a sane way for non-trivially copyable types
168 * jenkins.sh: Add --enable-werror flag to osmo-trx configure step
169 * Install systemd services with autotools
170 * Install sample cfg file to /etc/osmocom
171 * cosmetic: Use proper whitespace in several for loops
172 * Use pthread_setname_np to name threads
173 * CommonLibs/Makefile.am: Specify libcommon_la_LIBADD
174 * Transciever: Log values causing Tx underrun
175 * examples: Use logging level 'set-all' instead of 'all'
176 * jenkins.sh: Enable build of osmo-trx-lms
177 * ChannelizerBase: Fix ASan alloc-dealloc-mismatch
178 * UHDDevice: setRxGain on chan 0 when using multi-arfcn
179 * lms: Use LimeSuite.h log level defines instead of hardcoded values
180 * lms: Apply LMS->OSMO log level conversion
181 * Introduce OsmoTRX manual
182 * Introduce chapter trx_if.adoc and add it to OsmoTRX and OsmoBTS
183 * trx: Add reference to project wiki page in overfiew section
184 * trx: Add Hardware architecture support section
185 * trx: Add Hardware device support section
186 * osmotrx: Split Device specific section from backend one
187 * osmotrx: Write initial documentation for several supported devices
188 * osmotrx: configuration: Add section to document multi-arfcn feature
189 * osmotrx: Create a common chapter for section documenting backends
190 * osmotrx: Introduce code architecture chapter
191 * lms: Fix start after stop of device
192 * lms: Destroy streams on device stop
193 * radioInterface: Fix memleak during close()
194 * PointerFIFO: Fix memleak of ListNode
195 * lms: Make sure LMS_Close is called when Device is torn down
196 * osmo-trx: Change some lines to use libosmocore logging instead of cout
197 * lms: Close device on LMS_Init failure
198 * SigProcLib: Improve Vector buffer allocation mess
199 * lms: Allow setting Tx/RxGain for chan!=0
200 * lms: Allow setting Tx/RxFreq for lchan!=0
201 * lms: Improve Set{Rx,Tx}{Gain,Freq} logging
202 * transceiver: log chan on CTRL command received
203 * Add TRXCTRL log category
204 * transceiver: Log TRXCTRL iface responses towards osmo-bts-trx
205 * lms: Move {under,over}run checks into separate method
206 * lms: Do {under,over}run checks even if LMS_RecvStream fails
207 * Timeval: passed() returns true if time is equal
208 * Timeval: Move implementation to use clock_gettime and timespec
209 * Timeval: Move to osmo_clock_gettime
210 * TimevalTest: Make test deterministic with fake time
211 * lms: Fix build against LimeSuite > 18.10
212 * configure.ac: check boost only if USRP1 support is enabled
213
214 [ Vadim Yanitskiy ]
215 * trx_vty.c: fix: use CONFIG_NODE as parent by default
216 * device/lms/LMSDevice.cpp: fix compilation warning
217 * sigProcLib: introduce both TS1 and TS2 RACH synch. sequences
218 * sigProcLib: add a CorrType for extended (11-bit) RACH
219
220 [ Harald Welte ]
221 * Initial work towards direct LimeSuite support in OsmoTRX
222 * update .gitignore to include osmo-trx-lms
223 * LMSDevice: Call LMS_Init() before setting sample rate
224 * LMSDevice: Print sample rate range + actual sample rate after setting it
225 * LMSDevice: Typo fix: s/Internal/External
226 * LMSDevice: Set low-pass filters to smallest possible option
227 * LMSDevice: Fix initial timestamp offset of 2500
228 * LMS_Device: Set ts_offset to 0.
229 * LMSDevice: Reduce Rx logging verbosity: Only log unexpected timestamps
230 * move set_antennas() from UHD to generic radioDevice base class
231 * lms: Fix support for rx_paths / tx_paths
232 * lms: Call set_antennas() during open() method
233 * radioDevice: Move tx_sps from derived into base class
234 * radioDevice: better encapsulation in base class
235 * lms: Fix coding style
236 * lms: Fail in case of unsupported configuration
237 * usrp1: Fail in case of unsupported configuration
238 * Fix config file saving of {tx,rx}-path VTY config strings
239 * logging: Introduce new "DDEV" category for device-specific code
240 * update git-version-gen to generate proper version numbers
241 * ensure well-formed example config files
242 * SocketsTest.testReaderIP(): Zero terminate received buffer
243 * trx_validate_config(): Fix validation of rx_sps
244 * vty-ref: Update URI of docbook 5.0 schema
245 * lms: User correct scale factor for transmit samples
246 * lms: Set Rx gain to midpoint, as comment suggests.
247 * usrp1: Remove uninitialized skipRx logic
248 * usrp1: Fix formatting of log message (missing space)
249 * cosmetic: Don't call the SDR "USRP" in error message
250
251 [ Zydrunas Tamosevicius ]
252 * lms: Use same timestamp offset like when using LimeSDR via UHD
253 * lms: Reduce log level of "send buffer of len ..."
254 * lms: fix LMS_StartStream() handling for multiple channels
255 * lms: Reduce Rx gain from 47 to 34 dB
256
257 [ Alexander Couzens ]
258 * debian: add patches for debian8
259
260 [ Oliver Smith ]
261 * Add long parameters (--help, --version, ...)
262 * build manuals moved here from osmo-gsm-manuals.git
263 * Fix DISTCHECK_CONFIGURE_FLAGS override
264 * contrib/jenkins.sh: build and publish manuals
265 * jenkins.sh: run "make distcheck"
266 * contrib: fix makedistcheck with disabled systemd
267 * osmo-trx.cpp: move comma_delimited_to_vector() to Utils.cpp
268 * LMSDevice: make use of dev-args in osmo-trx.cfg
269 * LMSDeviceTest: fix link errors on OBS
270
271 [ Neels Hofmeyr ]
272 * Importing history from osmo-gsm-manuals.git
273
274 [ d0gtail ]
275 * UHDDevice: log exception information on device open failure
276
277 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 19:35:04 +0100
278
Pau Espin Pedrold0ac9262018-05-03 16:23:30 +0200279osmo-trx (0.4.0) unstable; urgency=medium
280
281 [ Neels Hofmeyr ]
282 * jenkins: use osmo-clean-workspace.sh before and after build
283
284 [ Harald Welte ]
285 * SocketsTest: Fix printing of non-nul-terminated string
286 * Revert "debian: Remove osmo-trx-usrp1 until we can build libusrp1.deb"
287 * debian/control: Remove "Maintainer" from binary package section
288 * debian/rules: Make sure we always require libusrp
289 * debian: Ensure USRP1 firmware is part of osmo-trx-usrp1
290 * debian/control: Add build dependency to libusrp-dev
291 * update .gitignore for new executable names
292 * osmo-trx: s/GSM Core Address/GSM BTS Address/
293
294 [ Piotr Krysik ]
295 * UHDDevice.cpp: add USRP B205mini support
296
297 [ Max ]
298 * Mark release target as virtual
299 * Remove outdated references to OpenBTS
300 * Remove unused headers
301 * Update installation instructions
302 * Update legal disclaimer
303 * Update license notes
304 * tests: null-terminate buffer
305
306 [ Pau Espin Pedrol ]
307 * cosmetic: Remove trailing whitespace
308 * Logger: Stop using Log.Alarms.Max from config
309 * Logger: Stop using Log.File and Log.Level from config
310 * Drop use of ConfigurationTable gConfig
311 * Remove Configuration module and libsqlite dependency
312 * cosmetic: AUTHORS: fix trailing whitespace
313 * Set up GNU Autotest infrastructure
314 * tests: InterThread: adapt to have reproducible output and enable autotest
315 * tests: Timeval: adapt to have reproducible output and enable autotest
316 * tests: Log: adapt to have reproducible output and enable autotest
317 * Sockets.cpp: Fix initialization of UDD socket
318 * tests: Sockets: adapt to have reproducible output and enable autotest
319 * utils/convolvtest: Remove uneeded libosmocore dependency
320 * Move ARCH_LA to Makefile.common
321 * tests: Migrate convtest util to autotest infrastructure
322 * arm/convert.c: Fix compilation error
323 * arm/convert.c: Add missing convert_init implementation
324 * .gitignore: Add missing test related files
325 * Remove UDDSocket class
326 * tests: SocketTests: Pick OS-assigned instead of setting one manually
327 * tests: SocketsTest: Avoid hang forever if test fails
328 * tests: SocketsTest: Fail test on write fail
329 * tests: TimevalTest: refactor and avoid double comparison
330 * contrib/jenkins.sh: Use qemu+proot+debootstrap to run tests with ARM instruction set
331 * tests: convolve: Disable due to difference in output in different archs
332 * Remove unneeded libdl dependency
333 * Fix whitespace
334 * Add support to set Rx/TxAntenna
335 * UHDDevice: Initialize async_event_thrd in constructor
336 * Logger: Drop unused gLogEarly
337 * Logger: Remove unused logging macros
338 * Logger: get rid of alarm APIs
339 * Logger: Drop syslog support
340 * Logger: Drop support to log into file
341 * Logger: Remove unused includes
342 * Logger: Remove gLogToConsole flag
343 * configure.ac: Check for pkg-config
344 * Depend on libosmocore
345 * osmo-trx: set up signals using libosmocore helpers
346 * osmo-trx: Set up talloc ctx
347 * debian: Depend on libtalloc and libosmocore
348 * Add initial support for logging, vty, ctrl
349 * Logger: Use libosmocore logging system
350 * osmo-trx.cpp: Move trx start and stop to helper functions
351 * Move enums required by VTY to a separate header
352 * vty: Implement VTY cfg parsing for current parameters
353 * doc: Add sample cfg file for LimeSDR
354 * osmo-trx: Use VTY cfg structures while still allowing cmd line options
355 * osmo-trx: Re-introduce -l cmd line parameter
356 * Makefile.am: Avoid using subdir if arch is not required
357 * Build Transceiver52M/common as an .la lib
358 * use osmo_init_logging2()
359 * tests: Makefile.am: Fix typo in include path
360 * configure.ac: Add --enable-sanitize option
361 * Move arch specific fiels to arch subdir
362 * Move device specific files to device subdir
363 * Change configure define USRP1 to DEVICE_USRP1
364 * Move device specific code out of radioInterface
365 * Transceiver: Move device specific code to radioDevice class
366 * Build one osmo-trx binary for each device support enabled
367 * Logger: Print correct source file and line number
368 * Transceiver: log timing info of stale bursts
369 * build: Fix make distcheck
370 * build: More OBS build failure fixes
371 * jenkins.sh: Enable build of osmo-trx-usrp1
372 * debian: Remove osmo-trx-usrp1 until we can build libusrp1.deb
373 * debian: Fix OBS build
374 * build: Fix OBS build for ARM
375 * git-version-gen: Take into account tags not in master
376
377 [ Alexander Huemer ]
378 * Unbreak `./configure --with-usrp1` build
379 * Fix USRP1 build with support for setting Rx/TxAntenna
380
381 [ Alexander Couzens ]
382 * jenkins.sh: fix the download url if the qemu image wasn't setup
383 * jenkins.sh: cleanup always the workspace
384 * jenkins.sh: change qemu-img default location to $HOME/qemu-img instead of /opt/qemu-img
385
386 [ Vadim Yanitskiy ]
387 * Transceiver.cpp: use a define for the MAX_PACKET_LENGTH
388 * Transceiver.cpp: properly zero-terminate received commands
389 * Transceiver.cpp: use pointer arithmetics for CMD parsing
390 * Transceiver.cpp: fix incorrect format string for SETTSC
391 * Transceiver.cpp: prevent out-of-range array access
392
393 [ Martin Hauke ]
394 * configure.ac: Fix typo
395
396 [ Philipp Maier ]
397 * doc: add example config for usrp B200 series
398
399 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:23:29 +0200
400
Harald Welte78e1cd22017-10-28 17:52:32 +0200401osmo-trx (0.2.0) unstable; urgency=medium
402
403 [ Alexander Chemeris ]
404 * EDGE: Add support for UmTRX.
405 * Common: Get rid of a compilation warning.
406 * Common: Make sure gLogEarly() log to the same facilities as the normal log.
407 * transceiver: Properly handle MAXDLY.
408 * transceiver: Add an option to generate random Access Bursts.
409 * osmo-trx: Output Rx SPS as a part of configuration output.
410 * transceiver: Do not pass transceiver state struct to function where it's not used.
411 * makefile: Fix build from an external path.
412 * radioDevice: GSMRATE macro must have parentheses around its definition.
413 * uhd: Fix comment.
414 * radioInterface: Initialize power scale with a meaningful default.
415 * transceiver: Log channel number in DEBUG output of demoded bursts.
416 * transceiver: Add an option to emulate a RACH delay in random filler mode.
417 * UHD: Initial LimeSDR support.
418 * CommonLibs: Remove unused files.
419 * sigProcLib: Typo sybols -> symbols
420 * radioBuffer: Remove extra ; at the end of inline function definitions.
421 * sigProcLib: Fix documentation, sync argument names in .cpp and .h files.
422 * sigProcLib: make energyDetect() simpler by returning actual energy.
423 * sigProcLib: Rename demodulateBurst() to demodGmskBurst() for clarity.
424 * sigProcLib: Slice SoftVector instead of signalVector for GMSK demod.
425 * Call vectorSlicer() right before packing bits for transmission to osmo-bts.
426 * CommonLibs: Print soft bits with less confidence to console when printing a soft vector.
427 * BitVector: Remove convolutional codec - we don't use it in osmo-trx.
428 * BitVector: Convert SoftVector from 0..1 to -1..+1 soft bits.
429 * signalVector: Implement segment().
430 * vector: Introduce segmentMove() method to move data inside of a vector.
431 * vector: Introduce shrink() function to shrink vector size without loosing data.
432 * Move CorrType type from Transceiver to sigProcLib.
433 * sigProcLib: rename signalError type to SignalError.
434 * Move Transceiver::detectBurst() to sigProcLib to make it reusable.
435 * Move BURST_THRESH from Transceiver.cpp to sigProcLib.h to make it reusable.
436 * sigProcLib: Add operator<< to print CorrType to a string.
437 * sigProcLib.h: Fix whitespaces. No non-whitespace changes.
438 * Move Transceiver::demodulate() to sigProcLib to make it reusable.
439 * sigProcLib: constify signalVector arguments for detectBurst() functions.
440 * sigProcLib: Constify demodulation functions burst argument.
441 * sigProcLib: Fix number of tail bits in random Normal Bursts and zero Stealing Bits.
442 * Configuration: Variables allocated with 'new' must be freed with 'delete'.
443 * BitVector: Remove Generator class.
444 * PRBS: a Pseudo-random binary sequence (PRBS) generator class.
445
446 [ Tom Tsou ]
447 * EDGE: Fix USRP B210 device support
448 * uhd: Correct timing alignment in 8-PSK and GMSK downlink bursts
449 * EDGE: Fix demodulation slicer input
450 * common: Restrict UDP binding to localhost only
451 * common: Add mandatory length field to UDP receive calls
452 * uhd: Update default E3XX settings
453 * uhd: Set default Tx sampling to 4 sps
454 * uhd: Make device offset check a private method
455 * uhd: Set minimum UHD version requirement for E3XX
456 * sigproc: Expand RACH, TSC, and EDGE correlation windows
457 * transceiver: Do not report error on SETTSC when radio is on
458 * transceiver: Add Rx samples-per-symbol option
459 * radioInterface: Convert diversity argument to general type
460 * iface: Add inner ring-buffer implementation
461 * mcbts: Add multi-ARFCN channelizing filters
462 * mcbts: Add multi-ARFCN radio support
463 * sigproc: Adjust burst detection threshold criteria
464 * egprs: Enable 8-PSK length vectors on the Tx interface
465 * egprs: Enable 8-PSK burst detection when EDGE is enabled
466 * transceiver: Remove HANDOVER warnings
467 * mcbts: Allow out of order channel setup
468 * radioInterface: Fix multi-channel buffer index bug
469 * uhd: Add command line option for GPS reference
470 * transceiver: Fix mixed GSMK / 8-PSK transmission
471 * transceiver: Fix 4 SPS receive TOA value
472 * sigproc: Fix missing 8-PSK tail symbols
473 * uhd: Update USRP2/N200/N210 for 4 SPS Rx
474 * sigproc: Match differential GMSK start/end bits to tail bits
475 * uhd: Add missing B200 sample timing for 4 SPS receive
476 * transceiver: Fix command build warning
477 * uhd: Set minimum supported version to 3.9.0
478 * uhd: Add X300 sample timing for 4 SPS
479 * Revert "uhd: Set minimum supported version to 3.9.0"
480 * uhd: Add support for UHD-3.11 logging control
481 * uhd: Increase MC-BTS FPGA clock rate to 51.2 MHz
482 * Resampler: Fix initialization return checking
483 * sigProcLib: Remove unreachable code and no-effect checks
484 * sigProcLib: Check return status on downsampling
485 * sigProcLib: Fix negative value check on unsigned value
486 * Resampler: Fix non-array delete for filter taps
487 * Transceiver: Remove unsigned negative compares
488 * Configuration: Fix const and signedness compile warnings
489 * config: Remove OpenBTS style sqlite configuration
490 * radioInterface: Remove UmTRX 'diversity' option
491 * build: Require and check for gcc C++11 support
492 * uhd: Use map container for for device parameter access
493 * sigProcLib: Remove unused functions from public interface
494 * uhd: Add non-UmTRX channel swap support
495 * uhd: Fix Tx-RX timing offset setting
496 * uhd: Fix USRP2/N200/N210 device detection
497 * transceiver: Fix POWEROFF crash on USRP2/N200/X300 devices
498 * sigProcLib: Fix complex/real vector flag in Laurent modulator
499 * sigProcLib: Remove heap based signal vector allocations
500 * common: Declare explicit Vector move constructor
501 * sigProcLib: Remove trigonometric tables
502 * sigProcLib: Use explicit NaN check in sinc table generation
503 * sigProcLib: Replace dynamically allocated resampling buffers
504 * sigProcLib: Specify standard namespace for isnan()
505 * uhd: Always specify samples-per-symbol for device lookup
506 * LimeSDR: set approximate tx offset value to make GSM work
507
508 [ Neels Hofmeyr ]
509 * add basic .gitignore
510 * configure.ac: check for boost/config.hpp header
511 * The INSTALL file is being overwritten by autoreconf, but it is committed as empty file. As a result, the INSTALL file always shows as modified. Instead, remove INSTALL from git and ignore it.
512 * add contrib/jenkins.sh, for gerrit build bot
513
514 [ pierre.baudry ]
515 * transceiver: Fix mismatched allocations and deallocations
516
517 [ Holger Hans Peter Freyther ]
518 * debian: Require fftw3 header files for osmo-trx
519
520 [ Max ]
521 * Add gerrit settings
522 * Integrate Debian packaging changes
523 * Remove embedded sqlite3
524 * Fix building against sqlite3
525 * Add autoconf-archive to dependencies
526 * debian: remove obsolete dependency
527 * deb: remove unused dependency
528 * Remove redundant explicit dependency
529 * Use release helper from libosmocore
530
531 [ Ruben Undheim ]
532 * Do not embed sqlite3 when building
533
534 [ Philipp Maier ]
535 * buildenv: Turn off native architecture builds
536 * cosmetic: Make parameter lists uniform
537 * Add test program to verify convolution implementation
538 * ssedetect: Add runtime CPU detection
539 * cosmetic: remove code duplication
540 * buildenv: Make build CPU invariant
541 * buildenv: Split up SSE3 and SSE4.1 code
542 * cosmetic: Add info about SSE support
543
544 [ Vadim Yanitskiy ]
545 * buildenv: correct the ax_sse macro description
546 * buildenv: actually strip unused cpuid functionality
547 * buildenv: fix build on systems without SIMD support
548 * buildenv: cosmetic changes
549 * buildenv: check for __builtin_cpu_supports call support
550 * ssedetect: call __builtin_cpu_supports() only if supported
551
552 [ Pau Espin Pedrol ]
553 * cosmetic: transciever: Remove trailing whitespaces
554 * transceiver: Avoid sending clock indications when trx is not powered on
555 * Add -j option to bind to specific address
556
557 [ ignasj ]
558 * LimeSDR: Change device detection to work with USB and PCIe versions
559 * LimeSDR: change tx window type to TX_WINDOW_FIXED
560 * LimeSDR: Fix sample value range
561
562 [ Harald Welte ]
563 * Add '-t' command line option to enable SCHED_RR
564 * Import git-version-gen and update AC_INIT()
565
566 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 17:52:32 +0200
567
Holger Hans Peter Freytherd17b1892016-03-18 20:13:23 +0100568osmo-trx (0.1.9) trusty; urgency=medium
569
570 * Ask Ivan, really
571
572 -- Kirill Zakharenko <earwin@gmail.com> Thu, 16 Jul 2015 12:13:46 +0000
573
574osmo-trx (0.1.8) precise; urgency=low
575
576 * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP
577
578 -- Ivan Klyuchnikov <Ivan.Kluchnikov@fairwaves.ru> Sun, 9 Mar 2014 14:10:10 +0400