blob: 0ec7b9f4c372fcee507e751acee087ce5cf1f73b [file] [log] [blame]
Pau Espin Pedrolda7fee82020-01-03 19:54:00 +01001osmo-trx (1.2.0) unstable; urgency=medium
2
3 [ Pau Espin Pedrol ]
4 * osmo-trx: log to stderr on signal received
5 * Drop old setPriority related code
6 * Transceiver: fix segfault during init if IP addr binding fails
7 * Transceiver: Check return value when binding IP addr for clock socket
8 * Transceiver: Clean up receival of downlink bursts
9 * Transceiver: Fix idle ul burst indications being dropped
10 * Transceiver: exit process when BTS drops connection
11 * Transceiver: Enable EDGE detection only on PDCH timeslots
12 * lms: Log available antennas if requested antenna fails
13 * device: Use LOGCHAN in set_antennas()
14 * Transceiver: Fix logging TN and version
15 * Transceiver: Use LOGCHAN in logRxBurst to unify log format
16 * Transceiver: Log error condition no burst in pullRadioVector()
17 * Transceiver: pullRadioVector(): Fix use of uninitialized value bi->tn
18 * Transceiver: Don't stop TRX if pulling from OFF timeslot
19 * radioInterface: Rename mRadio to mDevice
20 * radioInterfaceMulti: Check equals zero explicitly
21 * USRPDevice: Fix setRxGain return on error and getRxGain() returning always 0
22 * USRPDevice: Return previous txGain if setting value failed
23 * LMSDevice: Return previous txGain/rxGain if setting value failed
24 * radioInterface: Remove unusued getRxGain()
25 * radioDevice: Introduce getTxGain() API
26 * radioInterfaceMulti: Override setTxGain() to avoid chan!=0 calls
27 * UHDDevice: Drop unneeded MULTI_ARFCN checks
28 * radioInterface{Multi,Resamp}: Fix successful writeSamples() masking underrun from readSamples()
29 * radioInterface: Mark setRxGain as virtual
30 * Move multi-ARFCN chan amount modification from UHDDevice to parent class
31 * radioInterface: Atomically fetch and change underrun variable
32 * radioInterfaceMulti: write frequency offset direction (rx/tx) in log line
33 * Use new libosmocore logging lock API
34 * Transceiver: Fix wrong response upon CMD HANDOVER failure
35 * uhd: use value already cached in tmp variable
36 * Transceiver.cpp: Introduce and use new logging categories
37
38 [ Timo Jacobus ]
39 * Transceiver: Fixed copying of history into and from channelizer buffer.
40
41 [ Alexander Chemeris ]
42 * vty: Don't enable random filler bursts automatically with EDGE.
43 * vty: Simplify filler burst settings and improve help and readability.
44
45 [ Martin Hauke ]
46 * Fix common misspellings and typos
47
48 [ Harald Welte ]
49 * trx: exit() on unsupported positional arguments on command line
50
51 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 19:54:00 +0100
52
Pau Espin Pedrold0cbb162019-08-08 13:00:06 +020053osmo-trx (1.1.1) unstable; urgency=medium
54
55 * UNRELEASED
56
57 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 08 Aug 2019 13:00:05 +0200
58
Pau Espin Pedrole774d522019-08-07 21:12:56 +020059osmo-trx (1.1.0) unstable; urgency=medium
60
61 [ Sylvain Munaut ]
62 * arm/convolve: Fix the vfp4 real convolution for h_len=12
63 * convolve: Remove support for step, offset parameters
64 * tests: Rework the convolve_test
65 * tests: Re-enable the convolve_test by default
66 * sigProcLib: Add C/I (Carrier-to-Interference ratio) computation
67
68 [ Vadim Yanitskiy ]
69 * VTY: add extended (11-bit) RACH detection toggle
70 * doc/configuration.adoc: fix incorrect number of physical RF channels for B210
71 * driveTxPriorityQueue(): cosmetic: use proper type for TDMA TN
72 * driveTxPriorityQueue(): use trxd_hdr_common for message parsing
73 * driveTxPriorityQueue(): check if message header format is supported
74 * driveTxPriorityQueue(): enrich logging message
75 * trxd_fill_common(): fix TRXD header version coding
76 * manuals/configuration.adoc: fix copy-paste error in config example
77
78 [ Pau Espin Pedrol ]
79 * osmo-trx: Avoid handling signals after shutdown triggered
80 * osmo-trx: Use signalfd to serialize signals in main thread ctx
81 * osmo-trx: Check return code of osmo_fd_register
82 * lms: flush_recv: alloc buf on stack instead of heap
83 * lms: Improve log during flush recv error
84 * cosmetic: Threads.h: Remove trailing whitespace
85 * Move duplicated thread_enable_cancel to CommonLibs
86 * lms: Log underrun/overrun events
87 * lms: Remove references to ALERT loglevel
88 * lms: Remove unused var m_last_tx_overruns
89 * lms: Catch and log dropped packets by HW during recv
90 * cosmetic: uhd: Move smpl_buf out of UHDDevice, move UHDDevice class definition to .h
91 * uhd: smpl_buf: Drop UHD specifics out back to UHDDevice
92 * uhd: smpl_buf: Use TIMESTAMP type in str_status
93 * cosmetic: uhd: Use loglevel ERROR instead of ERR
94 * uhd: Avoid reallocation of buffers every read
95 * Move smpl_buf out of uhd dir to re-use it in other devices
96 * device: Drop unused numberRead/numberWritten APIs
97 * smpl_buf: Remove unused clk_rt variable
98 * smpl_buf: Remove unused clk_rt variable (fixup)
99 * smpl_buf: Remove dbg log line with duplicated info
100 * Introduce LOGCHAN macro to standarize logging channel info
101 * smpl_buf: Move it to device/common and create libdevice_common.la
102 * lms: Use smpl_buf to recover from timestamp jumps
103 * lms: Fix stream_stats checks with droppedPackets
104 * Add rate_ctr support to store/retrieve SDR errors through VTY
105 * Rename and move STOP signal from Transceiver to main
106 * doc: vty: Update trx_vty_reference.xml
107 * lms: Drop unusued variable masterClockRate
108 * lms: Fix stream_stats checks with overrun/underrun
109 * Add VTY commands to set error ctr thresholds
110 * Remove AUTHORS file
111 * trx_{vty,rate_ctr}: Set proper license AGPLv3+
112 * Introduce structs to encode TRXD packets
113 * Transceiver: refactor: gather uplink burst parameters in struct
114 * Transceiver: Drop unused rssi_valid struct field
115 * Transceiver: Move nbits burst size calculation to pullRadioVector()
116 * Transceiver: Move calculation of normalized values (rssiOffset) to pullRadioVector()
117 * Transceiver: Move soft bits normalization to pullRadioVector()
118 * Transceiver: Drop use of GSM::Time from trx_ul_burst_ind
119 * Transceiver: Get rid of SoftVector in struct trx_ul_burst_ind
120 * Transceiver: replace UDPSocket with libosmocore socket API
121 * Transceiver: Avoid noise calculation formula in 2 branches in pullRadioVector
122 * Transceiver: Simplify code on early error return when calling detectAnyBurst
123 * Transceiver: pullRadioVector(): Move initialization of var to start of function
124 * Transceiver: Support pulling idle frames in pullRadioVector()
125 * sigProcLib: detectAnyBurst() family: Use struct to gather all out params
126 * sigProcLib: detectAnyBurst(): make TSC used to detect burst available to caller
127 * Logger: global Log mutex is now available from C code
128 * Transceiver: Move out TRXD socket send code to prepare for TRXDv1
129 * Transceiver: Support SETFORMAT command
130 * Transceiver: Support TRXD v1
131 * Transceiver: Initialize mExtRACH in constructor
132 * debian/copyright: Remove non existent radioInterfaceDiversity.cpp from list
133 * debian/copyright: Update wrong paths in license list
134 * debian/copyright: Add missing file Utils.* to LGPL-2.1+ list
135 * cosmetic: Fix trailing whitespace in several files
136 * Add SPDX annotation
137 * Bind CTRL port to IP addr specified in VTY config
138 * Transceiver: Store TRXD version per channel
139 * Transceiver: Clean up code passing parameters to threads
140 * Remove empty ChangeLog fnd NEWS files
141 * Remove unused autogen.sh
142 * radioInterface: Clarify how underruns are handled driving a radioDevice
143 * usrp1: don't check for non-null underrun pointer
144 * jenkins.sh: Workaround libusrp build race conditon
145 * lms: Drop rx_underruns rate ctr, add tx_drop_* rate ctr
146 * Move inband-signaling-usb documentation to UserManual
147 * Move matlab files under utils/matlab
148 * Move Transceiver52/README to UserManual
149 * Move README.DFEsymbolspaced to utils/matlab
150 * Move std_inband.rbf under device/usrp1/ dir
151 * Drop old README information, provide new updated README
152 * Transceiver: Add missing include netinet/in.h
153 * Require newer version of libosmocore to avoid build failure
154
155 [ Tom Tsou ]
156 * multi-ARFCN: fix maximum number of carriers limitation
157
158 [ Harald Welte ]
159 * use BSC_FD_READ and not OSMO_FD_READ
160 * proto_trxd.c: Use bit-wise AND, not boolean AND
161 * Timeval: Restore output stream flags after changing them
162 * ChannelizerBase: fix initialization of class members
163 * CorrelationSequence: fix initialization of class members
164 * radioInterface.cpp: Fix missing member initialization of RadioInterface()
165
166 [ Joachim Steiger ]
167 * lms: Remove wrong unused code copied from -uhd
168 * lms: move LMS_EnableChannel from Start/Stop to Open/Close device
169 * lms: move LMS_GetLPFBWRange and LMS_Calibrate calls from open to start
170 * lms: add device type detection and device specific gains
171 * lms: properly call close if set_antennas() fails, add some comments
172
173 [ Oliver Smith ]
174 * debian: create -doc subpackage with pdf manuals
175 * contrib/jenkins.sh: run "make maintainer-clean"
176
177 [ Eric Wild ]
178 * Add option to set stack size in config file, default == 0 == OS default
179
180 [ Ruben Undheim ]
181 * Fix spelling discovered by lintian
182
183 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 21:12:56 +0200
184
Harald Welted20b7fa2019-01-20 19:35:05 +0100185osmo-trx (1.0.0) unstable; urgency=medium
186
187 [ Pau Espin Pedrol ]
188 * doc: examples: Add umtrx sample config
189 * UHDDevice: Fix setup failure with LimeSuite > 18.04.1
190 * examples: Set rt-prio 18 and print file basename
191 * lms: Several improvements and compilation/runtime fixes
192 * build: Add support for LimeSuite device backend
193 * LMSDevice: Set correct values for Max{Tx,Rx}Gain
194 * LMSDevice: Fix setup failure with LimeSuite > 18.04.1
195 * lms: Makefile.am: Reorder params to fix link issue
196 * lms: Check LPBFW to set is within supported range
197 * debian: Add package osmo-trx-lms
198 * contrib: Add systemd services for all backends
199 * debian: Add cfg file examples for osmo-trx-{lms,uhd}
200 * Add -V param to print version
201 * lms: Allow values diff than 34dB to be set by setRxGain()
202 * Use correct paths when installing example files
203 * debian: Enable build of osmo-trx-lms
204 * debian: Explicitly enable osmo-trx-uhd build
205 * configure.ac: Fix typo in with-lms help string
206 * vty: Fix typo in gpsdo clock reference type
207 * configure.ac: Add --enable-werror option
208 * Logger: Disable pthread cancel point inside Logger destructor
209 * cosmetic: Fix trailing whitespace
210 * radioInterface: forward errors from RadioDevice to Transceiver in recv path
211 * lms: Return error on device read timeout
212 * osmo-trx: Add osmo_signal to stop whole transceiver chain correctly on error
213 * radioInterface: Fix variable storing integer return value
214 * configure.ac: Specify default language as C++
215 * UHHDDevice: Replace deprecated header uhd/utils/thread_priority.hpp
216 * SigProcLib: Use available copyTo Vector API instead of memcopy
217 * cosmetic: Fix trailing whitespace in several files
218 * radioInterfaceMulti:pullBuffer: Sanely convert float array to complex array
219 * Vector: Copy arrays in a sane way for non-trivially copyable types
220 * jenkins.sh: Add --enable-werror flag to osmo-trx configure step
221 * Install systemd services with autotools
222 * Install sample cfg file to /etc/osmocom
223 * cosmetic: Use proper whitespace in several for loops
224 * Use pthread_setname_np to name threads
225 * CommonLibs/Makefile.am: Specify libcommon_la_LIBADD
226 * Transciever: Log values causing Tx underrun
227 * examples: Use logging level 'set-all' instead of 'all'
228 * jenkins.sh: Enable build of osmo-trx-lms
229 * ChannelizerBase: Fix ASan alloc-dealloc-mismatch
230 * UHDDevice: setRxGain on chan 0 when using multi-arfcn
231 * lms: Use LimeSuite.h log level defines instead of hardcoded values
232 * lms: Apply LMS->OSMO log level conversion
233 * Introduce OsmoTRX manual
234 * Introduce chapter trx_if.adoc and add it to OsmoTRX and OsmoBTS
235 * trx: Add reference to project wiki page in overfiew section
236 * trx: Add Hardware architecture support section
237 * trx: Add Hardware device support section
238 * osmotrx: Split Device specific section from backend one
239 * osmotrx: Write initial documentation for several supported devices
240 * osmotrx: configuration: Add section to document multi-arfcn feature
241 * osmotrx: Create a common chapter for section documenting backends
242 * osmotrx: Introduce code architecture chapter
243 * lms: Fix start after stop of device
244 * lms: Destroy streams on device stop
245 * radioInterface: Fix memleak during close()
246 * PointerFIFO: Fix memleak of ListNode
247 * lms: Make sure LMS_Close is called when Device is torn down
248 * osmo-trx: Change some lines to use libosmocore logging instead of cout
249 * lms: Close device on LMS_Init failure
250 * SigProcLib: Improve Vector buffer allocation mess
251 * lms: Allow setting Tx/RxGain for chan!=0
252 * lms: Allow setting Tx/RxFreq for lchan!=0
253 * lms: Improve Set{Rx,Tx}{Gain,Freq} logging
254 * transceiver: log chan on CTRL command received
255 * Add TRXCTRL log category
256 * transceiver: Log TRXCTRL iface responses towards osmo-bts-trx
257 * lms: Move {under,over}run checks into separate method
258 * lms: Do {under,over}run checks even if LMS_RecvStream fails
259 * Timeval: passed() returns true if time is equal
260 * Timeval: Move implementation to use clock_gettime and timespec
261 * Timeval: Move to osmo_clock_gettime
262 * TimevalTest: Make test deterministic with fake time
263 * lms: Fix build against LimeSuite > 18.10
264 * configure.ac: check boost only if USRP1 support is enabled
265
266 [ Vadim Yanitskiy ]
267 * trx_vty.c: fix: use CONFIG_NODE as parent by default
268 * device/lms/LMSDevice.cpp: fix compilation warning
269 * sigProcLib: introduce both TS1 and TS2 RACH synch. sequences
270 * sigProcLib: add a CorrType for extended (11-bit) RACH
271
272 [ Harald Welte ]
273 * Initial work towards direct LimeSuite support in OsmoTRX
274 * update .gitignore to include osmo-trx-lms
275 * LMSDevice: Call LMS_Init() before setting sample rate
276 * LMSDevice: Print sample rate range + actual sample rate after setting it
277 * LMSDevice: Typo fix: s/Internal/External
278 * LMSDevice: Set low-pass filters to smallest possible option
279 * LMSDevice: Fix initial timestamp offset of 2500
280 * LMS_Device: Set ts_offset to 0.
281 * LMSDevice: Reduce Rx logging verbosity: Only log unexpected timestamps
282 * move set_antennas() from UHD to generic radioDevice base class
283 * lms: Fix support for rx_paths / tx_paths
284 * lms: Call set_antennas() during open() method
285 * radioDevice: Move tx_sps from derived into base class
286 * radioDevice: better encapsulation in base class
287 * lms: Fix coding style
288 * lms: Fail in case of unsupported configuration
289 * usrp1: Fail in case of unsupported configuration
290 * Fix config file saving of {tx,rx}-path VTY config strings
291 * logging: Introduce new "DDEV" category for device-specific code
292 * update git-version-gen to generate proper version numbers
293 * ensure well-formed example config files
294 * SocketsTest.testReaderIP(): Zero terminate received buffer
295 * trx_validate_config(): Fix validation of rx_sps
296 * vty-ref: Update URI of docbook 5.0 schema
297 * lms: User correct scale factor for transmit samples
298 * lms: Set Rx gain to midpoint, as comment suggests.
299 * usrp1: Remove uninitialized skipRx logic
300 * usrp1: Fix formatting of log message (missing space)
301 * cosmetic: Don't call the SDR "USRP" in error message
302
303 [ Zydrunas Tamosevicius ]
304 * lms: Use same timestamp offset like when using LimeSDR via UHD
305 * lms: Reduce log level of "send buffer of len ..."
306 * lms: fix LMS_StartStream() handling for multiple channels
307 * lms: Reduce Rx gain from 47 to 34 dB
308
309 [ Alexander Couzens ]
310 * debian: add patches for debian8
311
312 [ Oliver Smith ]
313 * Add long parameters (--help, --version, ...)
314 * build manuals moved here from osmo-gsm-manuals.git
315 * Fix DISTCHECK_CONFIGURE_FLAGS override
316 * contrib/jenkins.sh: build and publish manuals
317 * jenkins.sh: run "make distcheck"
318 * contrib: fix makedistcheck with disabled systemd
319 * osmo-trx.cpp: move comma_delimited_to_vector() to Utils.cpp
320 * LMSDevice: make use of dev-args in osmo-trx.cfg
321 * LMSDeviceTest: fix link errors on OBS
322
323 [ Neels Hofmeyr ]
324 * Importing history from osmo-gsm-manuals.git
325
326 [ d0gtail ]
327 * UHDDevice: log exception information on device open failure
328
329 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 19:35:04 +0100
330
Pau Espin Pedrold0ac9262018-05-03 16:23:30 +0200331osmo-trx (0.4.0) unstable; urgency=medium
332
333 [ Neels Hofmeyr ]
334 * jenkins: use osmo-clean-workspace.sh before and after build
335
336 [ Harald Welte ]
337 * SocketsTest: Fix printing of non-nul-terminated string
338 * Revert "debian: Remove osmo-trx-usrp1 until we can build libusrp1.deb"
339 * debian/control: Remove "Maintainer" from binary package section
340 * debian/rules: Make sure we always require libusrp
341 * debian: Ensure USRP1 firmware is part of osmo-trx-usrp1
342 * debian/control: Add build dependency to libusrp-dev
343 * update .gitignore for new executable names
344 * osmo-trx: s/GSM Core Address/GSM BTS Address/
345
346 [ Piotr Krysik ]
347 * UHDDevice.cpp: add USRP B205mini support
348
349 [ Max ]
350 * Mark release target as virtual
351 * Remove outdated references to OpenBTS
352 * Remove unused headers
353 * Update installation instructions
354 * Update legal disclaimer
355 * Update license notes
356 * tests: null-terminate buffer
357
358 [ Pau Espin Pedrol ]
359 * cosmetic: Remove trailing whitespace
360 * Logger: Stop using Log.Alarms.Max from config
361 * Logger: Stop using Log.File and Log.Level from config
362 * Drop use of ConfigurationTable gConfig
363 * Remove Configuration module and libsqlite dependency
364 * cosmetic: AUTHORS: fix trailing whitespace
365 * Set up GNU Autotest infrastructure
366 * tests: InterThread: adapt to have reproducible output and enable autotest
367 * tests: Timeval: adapt to have reproducible output and enable autotest
368 * tests: Log: adapt to have reproducible output and enable autotest
369 * Sockets.cpp: Fix initialization of UDD socket
370 * tests: Sockets: adapt to have reproducible output and enable autotest
371 * utils/convolvtest: Remove uneeded libosmocore dependency
372 * Move ARCH_LA to Makefile.common
373 * tests: Migrate convtest util to autotest infrastructure
374 * arm/convert.c: Fix compilation error
375 * arm/convert.c: Add missing convert_init implementation
376 * .gitignore: Add missing test related files
377 * Remove UDDSocket class
378 * tests: SocketTests: Pick OS-assigned instead of setting one manually
379 * tests: SocketsTest: Avoid hang forever if test fails
380 * tests: SocketsTest: Fail test on write fail
381 * tests: TimevalTest: refactor and avoid double comparison
382 * contrib/jenkins.sh: Use qemu+proot+debootstrap to run tests with ARM instruction set
383 * tests: convolve: Disable due to difference in output in different archs
384 * Remove unneeded libdl dependency
385 * Fix whitespace
386 * Add support to set Rx/TxAntenna
387 * UHDDevice: Initialize async_event_thrd in constructor
388 * Logger: Drop unused gLogEarly
389 * Logger: Remove unused logging macros
390 * Logger: get rid of alarm APIs
391 * Logger: Drop syslog support
392 * Logger: Drop support to log into file
393 * Logger: Remove unused includes
394 * Logger: Remove gLogToConsole flag
395 * configure.ac: Check for pkg-config
396 * Depend on libosmocore
397 * osmo-trx: set up signals using libosmocore helpers
398 * osmo-trx: Set up talloc ctx
399 * debian: Depend on libtalloc and libosmocore
400 * Add initial support for logging, vty, ctrl
401 * Logger: Use libosmocore logging system
402 * osmo-trx.cpp: Move trx start and stop to helper functions
403 * Move enums required by VTY to a separate header
404 * vty: Implement VTY cfg parsing for current parameters
405 * doc: Add sample cfg file for LimeSDR
406 * osmo-trx: Use VTY cfg structures while still allowing cmd line options
407 * osmo-trx: Re-introduce -l cmd line parameter
408 * Makefile.am: Avoid using subdir if arch is not required
409 * Build Transceiver52M/common as an .la lib
410 * use osmo_init_logging2()
411 * tests: Makefile.am: Fix typo in include path
412 * configure.ac: Add --enable-sanitize option
413 * Move arch specific fiels to arch subdir
414 * Move device specific files to device subdir
415 * Change configure define USRP1 to DEVICE_USRP1
416 * Move device specific code out of radioInterface
417 * Transceiver: Move device specific code to radioDevice class
418 * Build one osmo-trx binary for each device support enabled
419 * Logger: Print correct source file and line number
420 * Transceiver: log timing info of stale bursts
421 * build: Fix make distcheck
422 * build: More OBS build failure fixes
423 * jenkins.sh: Enable build of osmo-trx-usrp1
424 * debian: Remove osmo-trx-usrp1 until we can build libusrp1.deb
425 * debian: Fix OBS build
426 * build: Fix OBS build for ARM
427 * git-version-gen: Take into account tags not in master
428
429 [ Alexander Huemer ]
430 * Unbreak `./configure --with-usrp1` build
431 * Fix USRP1 build with support for setting Rx/TxAntenna
432
433 [ Alexander Couzens ]
434 * jenkins.sh: fix the download url if the qemu image wasn't setup
435 * jenkins.sh: cleanup always the workspace
436 * jenkins.sh: change qemu-img default location to $HOME/qemu-img instead of /opt/qemu-img
437
438 [ Vadim Yanitskiy ]
439 * Transceiver.cpp: use a define for the MAX_PACKET_LENGTH
440 * Transceiver.cpp: properly zero-terminate received commands
441 * Transceiver.cpp: use pointer arithmetics for CMD parsing
442 * Transceiver.cpp: fix incorrect format string for SETTSC
443 * Transceiver.cpp: prevent out-of-range array access
444
445 [ Martin Hauke ]
446 * configure.ac: Fix typo
447
448 [ Philipp Maier ]
449 * doc: add example config for usrp B200 series
450
451 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:23:29 +0200
452
Harald Welte78e1cd22017-10-28 17:52:32 +0200453osmo-trx (0.2.0) unstable; urgency=medium
454
455 [ Alexander Chemeris ]
456 * EDGE: Add support for UmTRX.
457 * Common: Get rid of a compilation warning.
458 * Common: Make sure gLogEarly() log to the same facilities as the normal log.
459 * transceiver: Properly handle MAXDLY.
460 * transceiver: Add an option to generate random Access Bursts.
461 * osmo-trx: Output Rx SPS as a part of configuration output.
462 * transceiver: Do not pass transceiver state struct to function where it's not used.
463 * makefile: Fix build from an external path.
464 * radioDevice: GSMRATE macro must have parentheses around its definition.
465 * uhd: Fix comment.
466 * radioInterface: Initialize power scale with a meaningful default.
467 * transceiver: Log channel number in DEBUG output of demoded bursts.
468 * transceiver: Add an option to emulate a RACH delay in random filler mode.
469 * UHD: Initial LimeSDR support.
470 * CommonLibs: Remove unused files.
471 * sigProcLib: Typo sybols -> symbols
472 * radioBuffer: Remove extra ; at the end of inline function definitions.
473 * sigProcLib: Fix documentation, sync argument names in .cpp and .h files.
474 * sigProcLib: make energyDetect() simpler by returning actual energy.
475 * sigProcLib: Rename demodulateBurst() to demodGmskBurst() for clarity.
476 * sigProcLib: Slice SoftVector instead of signalVector for GMSK demod.
477 * Call vectorSlicer() right before packing bits for transmission to osmo-bts.
478 * CommonLibs: Print soft bits with less confidence to console when printing a soft vector.
479 * BitVector: Remove convolutional codec - we don't use it in osmo-trx.
480 * BitVector: Convert SoftVector from 0..1 to -1..+1 soft bits.
481 * signalVector: Implement segment().
482 * vector: Introduce segmentMove() method to move data inside of a vector.
483 * vector: Introduce shrink() function to shrink vector size without loosing data.
484 * Move CorrType type from Transceiver to sigProcLib.
485 * sigProcLib: rename signalError type to SignalError.
486 * Move Transceiver::detectBurst() to sigProcLib to make it reusable.
487 * Move BURST_THRESH from Transceiver.cpp to sigProcLib.h to make it reusable.
488 * sigProcLib: Add operator<< to print CorrType to a string.
489 * sigProcLib.h: Fix whitespaces. No non-whitespace changes.
490 * Move Transceiver::demodulate() to sigProcLib to make it reusable.
491 * sigProcLib: constify signalVector arguments for detectBurst() functions.
492 * sigProcLib: Constify demodulation functions burst argument.
493 * sigProcLib: Fix number of tail bits in random Normal Bursts and zero Stealing Bits.
494 * Configuration: Variables allocated with 'new' must be freed with 'delete'.
495 * BitVector: Remove Generator class.
496 * PRBS: a Pseudo-random binary sequence (PRBS) generator class.
497
498 [ Tom Tsou ]
499 * EDGE: Fix USRP B210 device support
500 * uhd: Correct timing alignment in 8-PSK and GMSK downlink bursts
501 * EDGE: Fix demodulation slicer input
502 * common: Restrict UDP binding to localhost only
503 * common: Add mandatory length field to UDP receive calls
504 * uhd: Update default E3XX settings
505 * uhd: Set default Tx sampling to 4 sps
506 * uhd: Make device offset check a private method
507 * uhd: Set minimum UHD version requirement for E3XX
508 * sigproc: Expand RACH, TSC, and EDGE correlation windows
509 * transceiver: Do not report error on SETTSC when radio is on
510 * transceiver: Add Rx samples-per-symbol option
511 * radioInterface: Convert diversity argument to general type
512 * iface: Add inner ring-buffer implementation
513 * mcbts: Add multi-ARFCN channelizing filters
514 * mcbts: Add multi-ARFCN radio support
515 * sigproc: Adjust burst detection threshold criteria
516 * egprs: Enable 8-PSK length vectors on the Tx interface
517 * egprs: Enable 8-PSK burst detection when EDGE is enabled
518 * transceiver: Remove HANDOVER warnings
519 * mcbts: Allow out of order channel setup
520 * radioInterface: Fix multi-channel buffer index bug
521 * uhd: Add command line option for GPS reference
522 * transceiver: Fix mixed GSMK / 8-PSK transmission
523 * transceiver: Fix 4 SPS receive TOA value
524 * sigproc: Fix missing 8-PSK tail symbols
525 * uhd: Update USRP2/N200/N210 for 4 SPS Rx
526 * sigproc: Match differential GMSK start/end bits to tail bits
527 * uhd: Add missing B200 sample timing for 4 SPS receive
528 * transceiver: Fix command build warning
529 * uhd: Set minimum supported version to 3.9.0
530 * uhd: Add X300 sample timing for 4 SPS
531 * Revert "uhd: Set minimum supported version to 3.9.0"
532 * uhd: Add support for UHD-3.11 logging control
533 * uhd: Increase MC-BTS FPGA clock rate to 51.2 MHz
534 * Resampler: Fix initialization return checking
535 * sigProcLib: Remove unreachable code and no-effect checks
536 * sigProcLib: Check return status on downsampling
537 * sigProcLib: Fix negative value check on unsigned value
538 * Resampler: Fix non-array delete for filter taps
539 * Transceiver: Remove unsigned negative compares
540 * Configuration: Fix const and signedness compile warnings
541 * config: Remove OpenBTS style sqlite configuration
542 * radioInterface: Remove UmTRX 'diversity' option
543 * build: Require and check for gcc C++11 support
544 * uhd: Use map container for for device parameter access
545 * sigProcLib: Remove unused functions from public interface
546 * uhd: Add non-UmTRX channel swap support
547 * uhd: Fix Tx-RX timing offset setting
548 * uhd: Fix USRP2/N200/N210 device detection
549 * transceiver: Fix POWEROFF crash on USRP2/N200/X300 devices
550 * sigProcLib: Fix complex/real vector flag in Laurent modulator
551 * sigProcLib: Remove heap based signal vector allocations
552 * common: Declare explicit Vector move constructor
553 * sigProcLib: Remove trigonometric tables
554 * sigProcLib: Use explicit NaN check in sinc table generation
555 * sigProcLib: Replace dynamically allocated resampling buffers
556 * sigProcLib: Specify standard namespace for isnan()
557 * uhd: Always specify samples-per-symbol for device lookup
558 * LimeSDR: set approximate tx offset value to make GSM work
559
560 [ Neels Hofmeyr ]
561 * add basic .gitignore
562 * configure.ac: check for boost/config.hpp header
563 * The INSTALL file is being overwritten by autoreconf, but it is committed as empty file. As a result, the INSTALL file always shows as modified. Instead, remove INSTALL from git and ignore it.
564 * add contrib/jenkins.sh, for gerrit build bot
565
566 [ pierre.baudry ]
567 * transceiver: Fix mismatched allocations and deallocations
568
569 [ Holger Hans Peter Freyther ]
570 * debian: Require fftw3 header files for osmo-trx
571
572 [ Max ]
573 * Add gerrit settings
574 * Integrate Debian packaging changes
575 * Remove embedded sqlite3
576 * Fix building against sqlite3
577 * Add autoconf-archive to dependencies
578 * debian: remove obsolete dependency
579 * deb: remove unused dependency
580 * Remove redundant explicit dependency
581 * Use release helper from libosmocore
582
583 [ Ruben Undheim ]
584 * Do not embed sqlite3 when building
585
586 [ Philipp Maier ]
587 * buildenv: Turn off native architecture builds
588 * cosmetic: Make parameter lists uniform
589 * Add test program to verify convolution implementation
590 * ssedetect: Add runtime CPU detection
591 * cosmetic: remove code duplication
592 * buildenv: Make build CPU invariant
593 * buildenv: Split up SSE3 and SSE4.1 code
594 * cosmetic: Add info about SSE support
595
596 [ Vadim Yanitskiy ]
597 * buildenv: correct the ax_sse macro description
598 * buildenv: actually strip unused cpuid functionality
599 * buildenv: fix build on systems without SIMD support
600 * buildenv: cosmetic changes
601 * buildenv: check for __builtin_cpu_supports call support
602 * ssedetect: call __builtin_cpu_supports() only if supported
603
604 [ Pau Espin Pedrol ]
605 * cosmetic: transciever: Remove trailing whitespaces
606 * transceiver: Avoid sending clock indications when trx is not powered on
607 * Add -j option to bind to specific address
608
609 [ ignasj ]
610 * LimeSDR: Change device detection to work with USB and PCIe versions
611 * LimeSDR: change tx window type to TX_WINDOW_FIXED
612 * LimeSDR: Fix sample value range
613
614 [ Harald Welte ]
615 * Add '-t' command line option to enable SCHED_RR
616 * Import git-version-gen and update AC_INIT()
617
618 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 17:52:32 +0200
619
Holger Hans Peter Freytherd17b1892016-03-18 20:13:23 +0100620osmo-trx (0.1.9) trusty; urgency=medium
621
622 * Ask Ivan, really
623
624 -- Kirill Zakharenko <earwin@gmail.com> Thu, 16 Jul 2015 12:13:46 +0000
625
626osmo-trx (0.1.8) precise; urgency=low
627
628 * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP
629
630 -- Ivan Klyuchnikov <Ivan.Kluchnikov@fairwaves.ru> Sun, 9 Mar 2014 14:10:10 +0400