blob: 019fdf810a7d4202ccd235f478d55a5f29059788 [file] [log] [blame]
Harald Welte90d84172021-02-28 11:32:12 +01001osmo-trx (1.3.1) unstable; urgency=medium
2
3 * mark uhddev_ipc.cpp as BUILT_SOURCES
4
5 -- Harald Welte <laforge@osmocom.org> Sun, 28 Feb 2021 11:32:11 +0100
6
Pau Espin Pedrol309ad4d2021-02-23 14:27:15 +01007osmo-trx (1.3.0) unstable; urgency=medium
8
9 [ Pau Espin Pedrol ]
10 * Make logging category DLMS generic and reusable for other backends
11 * uhd: Use DEVDRV log category and support UHD >=3.11 logging framework
12 * uhd: Improve some logging lines printing UHD pretty-print output
13 * doc: clarify number of channels on B210 with multi-arfcn enabled
14 * radioInterfaceMulti: Fail to tune on freq not following multi-arfcn restrictions
15 * doc: Update vty reference xml file
16 * lms: Move initialization of field started to constructor
17 * lms: Drop unused define
18 * smpl_buf: Fix str_code() param and print unknown error val
19 * lms: Improve smpl_buf error logging
20 * lms: Change radioDevice constructor arg name to avoid masking instance attr
21 * lms: Make reference to std::vector unambiguous
22 * lms: Move rx_buffers allocation to constructor
23 * lms: Store device type specific parameters in one place
24 * lms: Make ts_offset and smpl rate coefs device-specific
25 * lms: Initial multi-arfcn support
26 * contrib/jenkins.sh: Reorder sanity checks
27 * debug.h: Avoid printing pthread_t type
28 * debug.h: Fix print format of chan in CLOGCHAN
29 * cosmetic: fix several typos found by codespell
30 * radioDevice: Drop unused RSSI param from readSamples API
31 * radioDevice: Drop unused isControl param from WriteSamples API
32 * Use OSMO_FD_READ instead of deprecated BSC_FD_READ
33 * Transceiver: Fix extra space in RSP NOISELEV error
34 * Transceiver: Implement TRXC cmd NOMTXPOWER
35 * UHDDevice: Implement getNominalTxPower() based on TxFrequency
36 * radioInterface: Operate on real Tx power attenuation rather than on device specific gains
37 * UHDDevice: Compute TxGain on UHD API based on expected Tx output power
38 * proto_trxd: Fix UndefinedBehaviorSanitizer from ubsan
39 * Transceiver: Allow sending negative nominal tx power in RSP NOMTXPOWER
40 * LMSDevice: Compute TxGain on LimeSuite API based on expected Tx output power
41 * Drop old TxGain APIs from parent radioDevice abstract class
42 * {UHD,LMS}Dervice: Log expected resulting TxPower when setting device specific TxGain
43 * cosmetic: trx_rate_ctr: Fix whitespace
44 * trx_rate_ctr: Fix immediate rescheduling on per-sec thresholds
45 * Rename device specific rate counter multi-thread helpers
46 * Introduce rate counter tx_stale_bursts
47 * TransceiverState: Initialize ctrs field in constructor
48 * doc/manuals: Update thread documentation after dropping CTRL sock threads
49 * trx_rate_ctr: Fix locking wrong mutex
50 * Introduce rate counters to detect issues in received Dl bursts from TRXD
51 * Transceiver: Fix race condition obtaining Dl burst from Upper layer
52 * Add rate counter for missing Txbursts when scheduled towards the radioInterface
53 * Transceiver: Provide initial value for TransceiverState::mFiller in constructor
54 * Transceiver: Use already obtained value from Rx msg structure
55 * Transceiver: Restrict conditions where FN gaps are detected
56 * trx_rate_ctr: Lower some log levels
57 * Introduce CTR log category
58 * Transceiver: Lower some log levels which have an associated counter
59 * Transceiver: Check log level before generating burst str representation
60 * Transceiver: Add several rate_ctr for rx error conditions
61 * Use new libosmovty cpu sched config features
62 * debian: Update debian8 osmo-trx specific patch
63 * jenkins.sh: Verify distro-specific patches apply
64 * ipc: fix var declaration in for loop
65 * Add support for TRXC MUTE command
66 * arch: x86: Fix convolve optimizations breaking signal
67 * contrib/jenkins: Enable parallel make in make distcheck
68 * Transceiver: Pass config struct instead of large list of params
69 * Calculate RSSI offset based on RxGain configuration
70 * main: generate coredump and exit upon SIGABRT received
71 * ipc: Fix wrong reference to BTS in log line
72 * ipc-driver-test: Allow setting dir prefix for UD socket
73 * radioInterfaceMulti: Fix memory leak upon close()
74 * ChannelizerBase: Fix memory leak
75 * Threads.cpp: Use already existing gettid wrapper function
76 * Replace my_gettid with libosmocore osmo_gettid API
77 * tests: Explicitly drop category from log
78 * tests: Replace deprecated API log_set_print_filename
79
80 [ Philipp Maier ]
81 * debug: use LOGL_NOTICE for log category DDEV
82 * doc: do not set the base-port of the trx
83 * doc: apply an rssi-offset of 28 by default.
84 * doc: switch log levels to notice
85 * Transceiver: Log when sending of CLK indications begins
86 * vty: add attributes to VTY commands indicating when they apply
87 * osmo-trx: add commandline option --vty-ref-xml
88
89 [ Eric ]
90 * configure.ac: fix libtool issue with clang and sanitizer
91 * transceiver: check the right vector
92 * transceiver: get rid of the ctrl threads
93 * add kernel style .clang-format with 120 chars per line limit
94 * devices: reset internal smart sample buffers upon stop
95 * transceiver: optimize code if optimizations are enabled
96 * transceiver: initialize reorder flag so we don't miscount
97
98 [ Harald Welte ]
99 * PRBS tool sending PRBS sequence to TRX
100 * prbs-tool: Add error simulation capabilities
101 * utils: Ensure content of this directory is included in 'make dist'
102 * prbs-tool: Don't require C99
103 * RPM spec file: Require uhd-firmware for osmo-trx-uhd
104 * osmo-trx.spec.in: Use %config(noreplace) to retain current config file
105 * Fix build on Debian8
106 * [cosmetic] radioInterfaceMulti: More comments
107 * [cosmetic] radioIntefaceMulti: Fix whitespace / indent
108 * ipc: Use OSMO_FD_* instead of deprecated BSC_FD_*
109 * Use osmo_fd_setup() wherever applicable
110 * Use osmo_fd_*_{disable,enable}
111 * README update
112 * manual: Fix typo OsmTRX -> OsmoTRX
113
114 [ Oliver Smith ]
115 * contrib: import RPM spec
116 * contrib: integrate RPM spec
117 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
118 * contrib/jenkins: don't build osmo-gsm-manuals
119 * configure.ac: set -std=gnu11
120
121 [ Vadim Yanitskiy ]
122 * UHDDevice: catch LookupError/IndexError in set{Rx,Tx}Antenna()
123 * debian/control: change maintainer to the Osmocom team / mailing list
124 * proto_trxd: cosmetic: 'if' is not a function, add space
125 * vty: add multi-ARFCN specific warning for chan N > 0
126 * radioDevice: fix set_antennas(): consider MULTI_ARFCN mode
127 * device/lms: fix: 'trx_vty.h' header requires C linkage
128 * device/lms: fix missing semicolon in LMSDevice::assign_band_desc()
129 * device/lms: get rid of 'using namespace std'
130 * device/common/Makefile.am: remove $(LMS_CFLAGS) from AM_CXXFLAGS
131 * main: add --vty-ref-mode, use vty_dump_xml_ref_mode()
132 * device: drop unreasonable LIBOSMO{CTRL,VTY}_{CFLAGS,LIBS}
133 * Transceiver: use size_t and ARRAY_SIZE() in constructor
134 * Transceiver: explicitly init m{Rx,Tx}LowerLoopThread
135 * vty: fix documentation for 'swap-channels (disable|enable)'
136 * vty: fix documentation for 'egprs (disable|enable)'
137 * vty: fix documentation for 'rx-sps (1|4)' and 'tx-sps (1|4)'
138 * vty: cosmetic: use VTY_IPV4_CMD in 'bind-ip' / 'remote-ip'
139 * vty: fix documentation for 'multi-arfcn (disable|enable)'
140 * vty: remove groundless statement about filler type 'dummy'
141 * vty: auto-generate cmd and doc strings for cfg_filler_type_cmd
142 * vty: fix documentation for 'ext-rach (disable|enable)'
143 * main: use logging API to print SIMD info instead of printf()
144 * doc/manuals: generate XML VTY reference at build-time
145 * vty: fix swapped documentation for 'filler type' command
146 * Transceiver: fix integer division in addRadioVector()
147 * Transceiver: use proper factor for amplitude scaling
148 * Add a (hidden) VTY parameter for Rx/Tx freq. shifting
149
150 [ Eric Wild ]
151 * osmo-trx-ipc
152
153 [ Alexander Couzens ]
154 * osmo-trx.spec: move ipc-driver-test into package ipc-test
155
156 [ Sylvain Munaut ]
157 * sigProcLib: fix C/I computation for 8-PSK modulated bursts
158
159 -- Pau Espin Pedrol <pespin@espeweb.net> Tue, 23 Feb 2021 14:27:15 +0100
160
Pau Espin Pedrolda7fee82020-01-03 19:54:00 +0100161osmo-trx (1.2.0) unstable; urgency=medium
162
163 [ Pau Espin Pedrol ]
164 * osmo-trx: log to stderr on signal received
165 * Drop old setPriority related code
166 * Transceiver: fix segfault during init if IP addr binding fails
167 * Transceiver: Check return value when binding IP addr for clock socket
168 * Transceiver: Clean up receival of downlink bursts
169 * Transceiver: Fix idle ul burst indications being dropped
170 * Transceiver: exit process when BTS drops connection
171 * Transceiver: Enable EDGE detection only on PDCH timeslots
172 * lms: Log available antennas if requested antenna fails
173 * device: Use LOGCHAN in set_antennas()
174 * Transceiver: Fix logging TN and version
175 * Transceiver: Use LOGCHAN in logRxBurst to unify log format
176 * Transceiver: Log error condition no burst in pullRadioVector()
177 * Transceiver: pullRadioVector(): Fix use of uninitialized value bi->tn
178 * Transceiver: Don't stop TRX if pulling from OFF timeslot
179 * radioInterface: Rename mRadio to mDevice
180 * radioInterfaceMulti: Check equals zero explicitly
181 * USRPDevice: Fix setRxGain return on error and getRxGain() returning always 0
182 * USRPDevice: Return previous txGain if setting value failed
183 * LMSDevice: Return previous txGain/rxGain if setting value failed
184 * radioInterface: Remove unusued getRxGain()
185 * radioDevice: Introduce getTxGain() API
186 * radioInterfaceMulti: Override setTxGain() to avoid chan!=0 calls
187 * UHDDevice: Drop unneeded MULTI_ARFCN checks
188 * radioInterface{Multi,Resamp}: Fix successful writeSamples() masking underrun from readSamples()
189 * radioInterface: Mark setRxGain as virtual
190 * Move multi-ARFCN chan amount modification from UHDDevice to parent class
191 * radioInterface: Atomically fetch and change underrun variable
192 * radioInterfaceMulti: write frequency offset direction (rx/tx) in log line
193 * Use new libosmocore logging lock API
194 * Transceiver: Fix wrong response upon CMD HANDOVER failure
195 * uhd: use value already cached in tmp variable
196 * Transceiver.cpp: Introduce and use new logging categories
197
198 [ Timo Jacobus ]
199 * Transceiver: Fixed copying of history into and from channelizer buffer.
200
201 [ Alexander Chemeris ]
202 * vty: Don't enable random filler bursts automatically with EDGE.
203 * vty: Simplify filler burst settings and improve help and readability.
204
205 [ Martin Hauke ]
206 * Fix common misspellings and typos
207
208 [ Harald Welte ]
209 * trx: exit() on unsupported positional arguments on command line
210
211 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 19:54:00 +0100
212
Pau Espin Pedrold0cbb162019-08-08 13:00:06 +0200213osmo-trx (1.1.1) unstable; urgency=medium
214
215 * UNRELEASED
216
217 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 08 Aug 2019 13:00:05 +0200
218
Pau Espin Pedrole774d522019-08-07 21:12:56 +0200219osmo-trx (1.1.0) unstable; urgency=medium
220
221 [ Sylvain Munaut ]
222 * arm/convolve: Fix the vfp4 real convolution for h_len=12
223 * convolve: Remove support for step, offset parameters
224 * tests: Rework the convolve_test
225 * tests: Re-enable the convolve_test by default
226 * sigProcLib: Add C/I (Carrier-to-Interference ratio) computation
227
228 [ Vadim Yanitskiy ]
229 * VTY: add extended (11-bit) RACH detection toggle
230 * doc/configuration.adoc: fix incorrect number of physical RF channels for B210
231 * driveTxPriorityQueue(): cosmetic: use proper type for TDMA TN
232 * driveTxPriorityQueue(): use trxd_hdr_common for message parsing
233 * driveTxPriorityQueue(): check if message header format is supported
234 * driveTxPriorityQueue(): enrich logging message
235 * trxd_fill_common(): fix TRXD header version coding
236 * manuals/configuration.adoc: fix copy-paste error in config example
237
238 [ Pau Espin Pedrol ]
239 * osmo-trx: Avoid handling signals after shutdown triggered
240 * osmo-trx: Use signalfd to serialize signals in main thread ctx
241 * osmo-trx: Check return code of osmo_fd_register
242 * lms: flush_recv: alloc buf on stack instead of heap
243 * lms: Improve log during flush recv error
244 * cosmetic: Threads.h: Remove trailing whitespace
245 * Move duplicated thread_enable_cancel to CommonLibs
246 * lms: Log underrun/overrun events
247 * lms: Remove references to ALERT loglevel
248 * lms: Remove unused var m_last_tx_overruns
249 * lms: Catch and log dropped packets by HW during recv
250 * cosmetic: uhd: Move smpl_buf out of UHDDevice, move UHDDevice class definition to .h
251 * uhd: smpl_buf: Drop UHD specifics out back to UHDDevice
252 * uhd: smpl_buf: Use TIMESTAMP type in str_status
253 * cosmetic: uhd: Use loglevel ERROR instead of ERR
254 * uhd: Avoid reallocation of buffers every read
255 * Move smpl_buf out of uhd dir to re-use it in other devices
256 * device: Drop unused numberRead/numberWritten APIs
257 * smpl_buf: Remove unused clk_rt variable
258 * smpl_buf: Remove unused clk_rt variable (fixup)
259 * smpl_buf: Remove dbg log line with duplicated info
260 * Introduce LOGCHAN macro to standarize logging channel info
261 * smpl_buf: Move it to device/common and create libdevice_common.la
262 * lms: Use smpl_buf to recover from timestamp jumps
263 * lms: Fix stream_stats checks with droppedPackets
264 * Add rate_ctr support to store/retrieve SDR errors through VTY
265 * Rename and move STOP signal from Transceiver to main
266 * doc: vty: Update trx_vty_reference.xml
267 * lms: Drop unusued variable masterClockRate
268 * lms: Fix stream_stats checks with overrun/underrun
269 * Add VTY commands to set error ctr thresholds
270 * Remove AUTHORS file
271 * trx_{vty,rate_ctr}: Set proper license AGPLv3+
272 * Introduce structs to encode TRXD packets
273 * Transceiver: refactor: gather uplink burst parameters in struct
274 * Transceiver: Drop unused rssi_valid struct field
275 * Transceiver: Move nbits burst size calculation to pullRadioVector()
276 * Transceiver: Move calculation of normalized values (rssiOffset) to pullRadioVector()
277 * Transceiver: Move soft bits normalization to pullRadioVector()
278 * Transceiver: Drop use of GSM::Time from trx_ul_burst_ind
279 * Transceiver: Get rid of SoftVector in struct trx_ul_burst_ind
280 * Transceiver: replace UDPSocket with libosmocore socket API
281 * Transceiver: Avoid noise calculation formula in 2 branches in pullRadioVector
282 * Transceiver: Simplify code on early error return when calling detectAnyBurst
283 * Transceiver: pullRadioVector(): Move initialization of var to start of function
284 * Transceiver: Support pulling idle frames in pullRadioVector()
285 * sigProcLib: detectAnyBurst() family: Use struct to gather all out params
286 * sigProcLib: detectAnyBurst(): make TSC used to detect burst available to caller
287 * Logger: global Log mutex is now available from C code
288 * Transceiver: Move out TRXD socket send code to prepare for TRXDv1
289 * Transceiver: Support SETFORMAT command
290 * Transceiver: Support TRXD v1
291 * Transceiver: Initialize mExtRACH in constructor
292 * debian/copyright: Remove non existent radioInterfaceDiversity.cpp from list
293 * debian/copyright: Update wrong paths in license list
294 * debian/copyright: Add missing file Utils.* to LGPL-2.1+ list
295 * cosmetic: Fix trailing whitespace in several files
296 * Add SPDX annotation
297 * Bind CTRL port to IP addr specified in VTY config
298 * Transceiver: Store TRXD version per channel
299 * Transceiver: Clean up code passing parameters to threads
300 * Remove empty ChangeLog fnd NEWS files
301 * Remove unused autogen.sh
302 * radioInterface: Clarify how underruns are handled driving a radioDevice
303 * usrp1: don't check for non-null underrun pointer
304 * jenkins.sh: Workaround libusrp build race conditon
305 * lms: Drop rx_underruns rate ctr, add tx_drop_* rate ctr
306 * Move inband-signaling-usb documentation to UserManual
307 * Move matlab files under utils/matlab
308 * Move Transceiver52/README to UserManual
309 * Move README.DFEsymbolspaced to utils/matlab
310 * Move std_inband.rbf under device/usrp1/ dir
311 * Drop old README information, provide new updated README
312 * Transceiver: Add missing include netinet/in.h
313 * Require newer version of libosmocore to avoid build failure
314
315 [ Tom Tsou ]
316 * multi-ARFCN: fix maximum number of carriers limitation
317
318 [ Harald Welte ]
319 * use BSC_FD_READ and not OSMO_FD_READ
320 * proto_trxd.c: Use bit-wise AND, not boolean AND
321 * Timeval: Restore output stream flags after changing them
322 * ChannelizerBase: fix initialization of class members
323 * CorrelationSequence: fix initialization of class members
324 * radioInterface.cpp: Fix missing member initialization of RadioInterface()
325
326 [ Joachim Steiger ]
327 * lms: Remove wrong unused code copied from -uhd
328 * lms: move LMS_EnableChannel from Start/Stop to Open/Close device
329 * lms: move LMS_GetLPFBWRange and LMS_Calibrate calls from open to start
330 * lms: add device type detection and device specific gains
331 * lms: properly call close if set_antennas() fails, add some comments
332
333 [ Oliver Smith ]
334 * debian: create -doc subpackage with pdf manuals
335 * contrib/jenkins.sh: run "make maintainer-clean"
336
337 [ Eric Wild ]
338 * Add option to set stack size in config file, default == 0 == OS default
339
340 [ Ruben Undheim ]
341 * Fix spelling discovered by lintian
342
343 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 21:12:56 +0200
344
Harald Welted20b7fa2019-01-20 19:35:05 +0100345osmo-trx (1.0.0) unstable; urgency=medium
346
347 [ Pau Espin Pedrol ]
348 * doc: examples: Add umtrx sample config
349 * UHDDevice: Fix setup failure with LimeSuite > 18.04.1
350 * examples: Set rt-prio 18 and print file basename
351 * lms: Several improvements and compilation/runtime fixes
352 * build: Add support for LimeSuite device backend
353 * LMSDevice: Set correct values for Max{Tx,Rx}Gain
354 * LMSDevice: Fix setup failure with LimeSuite > 18.04.1
355 * lms: Makefile.am: Reorder params to fix link issue
356 * lms: Check LPBFW to set is within supported range
357 * debian: Add package osmo-trx-lms
358 * contrib: Add systemd services for all backends
359 * debian: Add cfg file examples for osmo-trx-{lms,uhd}
360 * Add -V param to print version
361 * lms: Allow values diff than 34dB to be set by setRxGain()
362 * Use correct paths when installing example files
363 * debian: Enable build of osmo-trx-lms
364 * debian: Explicitly enable osmo-trx-uhd build
365 * configure.ac: Fix typo in with-lms help string
366 * vty: Fix typo in gpsdo clock reference type
367 * configure.ac: Add --enable-werror option
368 * Logger: Disable pthread cancel point inside Logger destructor
369 * cosmetic: Fix trailing whitespace
370 * radioInterface: forward errors from RadioDevice to Transceiver in recv path
371 * lms: Return error on device read timeout
372 * osmo-trx: Add osmo_signal to stop whole transceiver chain correctly on error
373 * radioInterface: Fix variable storing integer return value
374 * configure.ac: Specify default language as C++
375 * UHHDDevice: Replace deprecated header uhd/utils/thread_priority.hpp
376 * SigProcLib: Use available copyTo Vector API instead of memcopy
377 * cosmetic: Fix trailing whitespace in several files
378 * radioInterfaceMulti:pullBuffer: Sanely convert float array to complex array
379 * Vector: Copy arrays in a sane way for non-trivially copyable types
380 * jenkins.sh: Add --enable-werror flag to osmo-trx configure step
381 * Install systemd services with autotools
382 * Install sample cfg file to /etc/osmocom
383 * cosmetic: Use proper whitespace in several for loops
384 * Use pthread_setname_np to name threads
385 * CommonLibs/Makefile.am: Specify libcommon_la_LIBADD
386 * Transciever: Log values causing Tx underrun
387 * examples: Use logging level 'set-all' instead of 'all'
388 * jenkins.sh: Enable build of osmo-trx-lms
389 * ChannelizerBase: Fix ASan alloc-dealloc-mismatch
390 * UHDDevice: setRxGain on chan 0 when using multi-arfcn
391 * lms: Use LimeSuite.h log level defines instead of hardcoded values
392 * lms: Apply LMS->OSMO log level conversion
393 * Introduce OsmoTRX manual
394 * Introduce chapter trx_if.adoc and add it to OsmoTRX and OsmoBTS
395 * trx: Add reference to project wiki page in overfiew section
396 * trx: Add Hardware architecture support section
397 * trx: Add Hardware device support section
398 * osmotrx: Split Device specific section from backend one
399 * osmotrx: Write initial documentation for several supported devices
400 * osmotrx: configuration: Add section to document multi-arfcn feature
401 * osmotrx: Create a common chapter for section documenting backends
402 * osmotrx: Introduce code architecture chapter
403 * lms: Fix start after stop of device
404 * lms: Destroy streams on device stop
405 * radioInterface: Fix memleak during close()
406 * PointerFIFO: Fix memleak of ListNode
407 * lms: Make sure LMS_Close is called when Device is torn down
408 * osmo-trx: Change some lines to use libosmocore logging instead of cout
409 * lms: Close device on LMS_Init failure
410 * SigProcLib: Improve Vector buffer allocation mess
411 * lms: Allow setting Tx/RxGain for chan!=0
412 * lms: Allow setting Tx/RxFreq for lchan!=0
413 * lms: Improve Set{Rx,Tx}{Gain,Freq} logging
414 * transceiver: log chan on CTRL command received
415 * Add TRXCTRL log category
416 * transceiver: Log TRXCTRL iface responses towards osmo-bts-trx
417 * lms: Move {under,over}run checks into separate method
418 * lms: Do {under,over}run checks even if LMS_RecvStream fails
419 * Timeval: passed() returns true if time is equal
420 * Timeval: Move implementation to use clock_gettime and timespec
421 * Timeval: Move to osmo_clock_gettime
422 * TimevalTest: Make test deterministic with fake time
423 * lms: Fix build against LimeSuite > 18.10
424 * configure.ac: check boost only if USRP1 support is enabled
425
426 [ Vadim Yanitskiy ]
427 * trx_vty.c: fix: use CONFIG_NODE as parent by default
428 * device/lms/LMSDevice.cpp: fix compilation warning
429 * sigProcLib: introduce both TS1 and TS2 RACH synch. sequences
430 * sigProcLib: add a CorrType for extended (11-bit) RACH
431
432 [ Harald Welte ]
433 * Initial work towards direct LimeSuite support in OsmoTRX
434 * update .gitignore to include osmo-trx-lms
435 * LMSDevice: Call LMS_Init() before setting sample rate
436 * LMSDevice: Print sample rate range + actual sample rate after setting it
437 * LMSDevice: Typo fix: s/Internal/External
438 * LMSDevice: Set low-pass filters to smallest possible option
439 * LMSDevice: Fix initial timestamp offset of 2500
440 * LMS_Device: Set ts_offset to 0.
441 * LMSDevice: Reduce Rx logging verbosity: Only log unexpected timestamps
442 * move set_antennas() from UHD to generic radioDevice base class
443 * lms: Fix support for rx_paths / tx_paths
444 * lms: Call set_antennas() during open() method
445 * radioDevice: Move tx_sps from derived into base class
446 * radioDevice: better encapsulation in base class
447 * lms: Fix coding style
448 * lms: Fail in case of unsupported configuration
449 * usrp1: Fail in case of unsupported configuration
450 * Fix config file saving of {tx,rx}-path VTY config strings
451 * logging: Introduce new "DDEV" category for device-specific code
452 * update git-version-gen to generate proper version numbers
453 * ensure well-formed example config files
454 * SocketsTest.testReaderIP(): Zero terminate received buffer
455 * trx_validate_config(): Fix validation of rx_sps
456 * vty-ref: Update URI of docbook 5.0 schema
457 * lms: User correct scale factor for transmit samples
458 * lms: Set Rx gain to midpoint, as comment suggests.
459 * usrp1: Remove uninitialized skipRx logic
460 * usrp1: Fix formatting of log message (missing space)
461 * cosmetic: Don't call the SDR "USRP" in error message
462
463 [ Zydrunas Tamosevicius ]
464 * lms: Use same timestamp offset like when using LimeSDR via UHD
465 * lms: Reduce log level of "send buffer of len ..."
466 * lms: fix LMS_StartStream() handling for multiple channels
467 * lms: Reduce Rx gain from 47 to 34 dB
468
469 [ Alexander Couzens ]
470 * debian: add patches for debian8
471
472 [ Oliver Smith ]
473 * Add long parameters (--help, --version, ...)
474 * build manuals moved here from osmo-gsm-manuals.git
475 * Fix DISTCHECK_CONFIGURE_FLAGS override
476 * contrib/jenkins.sh: build and publish manuals
477 * jenkins.sh: run "make distcheck"
478 * contrib: fix makedistcheck with disabled systemd
479 * osmo-trx.cpp: move comma_delimited_to_vector() to Utils.cpp
480 * LMSDevice: make use of dev-args in osmo-trx.cfg
481 * LMSDeviceTest: fix link errors on OBS
482
483 [ Neels Hofmeyr ]
484 * Importing history from osmo-gsm-manuals.git
485
486 [ d0gtail ]
487 * UHDDevice: log exception information on device open failure
488
489 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 19:35:04 +0100
490
Pau Espin Pedrold0ac9262018-05-03 16:23:30 +0200491osmo-trx (0.4.0) unstable; urgency=medium
492
493 [ Neels Hofmeyr ]
494 * jenkins: use osmo-clean-workspace.sh before and after build
495
496 [ Harald Welte ]
497 * SocketsTest: Fix printing of non-nul-terminated string
498 * Revert "debian: Remove osmo-trx-usrp1 until we can build libusrp1.deb"
499 * debian/control: Remove "Maintainer" from binary package section
500 * debian/rules: Make sure we always require libusrp
501 * debian: Ensure USRP1 firmware is part of osmo-trx-usrp1
502 * debian/control: Add build dependency to libusrp-dev
503 * update .gitignore for new executable names
504 * osmo-trx: s/GSM Core Address/GSM BTS Address/
505
506 [ Piotr Krysik ]
507 * UHDDevice.cpp: add USRP B205mini support
508
509 [ Max ]
510 * Mark release target as virtual
511 * Remove outdated references to OpenBTS
512 * Remove unused headers
513 * Update installation instructions
514 * Update legal disclaimer
515 * Update license notes
516 * tests: null-terminate buffer
517
518 [ Pau Espin Pedrol ]
519 * cosmetic: Remove trailing whitespace
520 * Logger: Stop using Log.Alarms.Max from config
521 * Logger: Stop using Log.File and Log.Level from config
522 * Drop use of ConfigurationTable gConfig
523 * Remove Configuration module and libsqlite dependency
524 * cosmetic: AUTHORS: fix trailing whitespace
525 * Set up GNU Autotest infrastructure
526 * tests: InterThread: adapt to have reproducible output and enable autotest
527 * tests: Timeval: adapt to have reproducible output and enable autotest
528 * tests: Log: adapt to have reproducible output and enable autotest
529 * Sockets.cpp: Fix initialization of UDD socket
530 * tests: Sockets: adapt to have reproducible output and enable autotest
531 * utils/convolvtest: Remove uneeded libosmocore dependency
532 * Move ARCH_LA to Makefile.common
533 * tests: Migrate convtest util to autotest infrastructure
534 * arm/convert.c: Fix compilation error
535 * arm/convert.c: Add missing convert_init implementation
536 * .gitignore: Add missing test related files
537 * Remove UDDSocket class
538 * tests: SocketTests: Pick OS-assigned instead of setting one manually
539 * tests: SocketsTest: Avoid hang forever if test fails
540 * tests: SocketsTest: Fail test on write fail
541 * tests: TimevalTest: refactor and avoid double comparison
542 * contrib/jenkins.sh: Use qemu+proot+debootstrap to run tests with ARM instruction set
543 * tests: convolve: Disable due to difference in output in different archs
544 * Remove unneeded libdl dependency
545 * Fix whitespace
546 * Add support to set Rx/TxAntenna
547 * UHDDevice: Initialize async_event_thrd in constructor
548 * Logger: Drop unused gLogEarly
549 * Logger: Remove unused logging macros
550 * Logger: get rid of alarm APIs
551 * Logger: Drop syslog support
552 * Logger: Drop support to log into file
553 * Logger: Remove unused includes
554 * Logger: Remove gLogToConsole flag
555 * configure.ac: Check for pkg-config
556 * Depend on libosmocore
557 * osmo-trx: set up signals using libosmocore helpers
558 * osmo-trx: Set up talloc ctx
559 * debian: Depend on libtalloc and libosmocore
560 * Add initial support for logging, vty, ctrl
561 * Logger: Use libosmocore logging system
562 * osmo-trx.cpp: Move trx start and stop to helper functions
563 * Move enums required by VTY to a separate header
564 * vty: Implement VTY cfg parsing for current parameters
565 * doc: Add sample cfg file for LimeSDR
566 * osmo-trx: Use VTY cfg structures while still allowing cmd line options
567 * osmo-trx: Re-introduce -l cmd line parameter
568 * Makefile.am: Avoid using subdir if arch is not required
569 * Build Transceiver52M/common as an .la lib
570 * use osmo_init_logging2()
571 * tests: Makefile.am: Fix typo in include path
572 * configure.ac: Add --enable-sanitize option
573 * Move arch specific fiels to arch subdir
574 * Move device specific files to device subdir
575 * Change configure define USRP1 to DEVICE_USRP1
576 * Move device specific code out of radioInterface
577 * Transceiver: Move device specific code to radioDevice class
578 * Build one osmo-trx binary for each device support enabled
579 * Logger: Print correct source file and line number
580 * Transceiver: log timing info of stale bursts
581 * build: Fix make distcheck
582 * build: More OBS build failure fixes
583 * jenkins.sh: Enable build of osmo-trx-usrp1
584 * debian: Remove osmo-trx-usrp1 until we can build libusrp1.deb
585 * debian: Fix OBS build
586 * build: Fix OBS build for ARM
587 * git-version-gen: Take into account tags not in master
588
589 [ Alexander Huemer ]
590 * Unbreak `./configure --with-usrp1` build
591 * Fix USRP1 build with support for setting Rx/TxAntenna
592
593 [ Alexander Couzens ]
594 * jenkins.sh: fix the download url if the qemu image wasn't setup
595 * jenkins.sh: cleanup always the workspace
596 * jenkins.sh: change qemu-img default location to $HOME/qemu-img instead of /opt/qemu-img
597
598 [ Vadim Yanitskiy ]
599 * Transceiver.cpp: use a define for the MAX_PACKET_LENGTH
600 * Transceiver.cpp: properly zero-terminate received commands
601 * Transceiver.cpp: use pointer arithmetics for CMD parsing
602 * Transceiver.cpp: fix incorrect format string for SETTSC
603 * Transceiver.cpp: prevent out-of-range array access
604
605 [ Martin Hauke ]
606 * configure.ac: Fix typo
607
608 [ Philipp Maier ]
609 * doc: add example config for usrp B200 series
610
611 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:23:29 +0200
612
Harald Welte78e1cd22017-10-28 17:52:32 +0200613osmo-trx (0.2.0) unstable; urgency=medium
614
615 [ Alexander Chemeris ]
616 * EDGE: Add support for UmTRX.
617 * Common: Get rid of a compilation warning.
618 * Common: Make sure gLogEarly() log to the same facilities as the normal log.
619 * transceiver: Properly handle MAXDLY.
620 * transceiver: Add an option to generate random Access Bursts.
621 * osmo-trx: Output Rx SPS as a part of configuration output.
622 * transceiver: Do not pass transceiver state struct to function where it's not used.
623 * makefile: Fix build from an external path.
624 * radioDevice: GSMRATE macro must have parentheses around its definition.
625 * uhd: Fix comment.
626 * radioInterface: Initialize power scale with a meaningful default.
627 * transceiver: Log channel number in DEBUG output of demoded bursts.
628 * transceiver: Add an option to emulate a RACH delay in random filler mode.
629 * UHD: Initial LimeSDR support.
630 * CommonLibs: Remove unused files.
631 * sigProcLib: Typo sybols -> symbols
632 * radioBuffer: Remove extra ; at the end of inline function definitions.
633 * sigProcLib: Fix documentation, sync argument names in .cpp and .h files.
634 * sigProcLib: make energyDetect() simpler by returning actual energy.
635 * sigProcLib: Rename demodulateBurst() to demodGmskBurst() for clarity.
636 * sigProcLib: Slice SoftVector instead of signalVector for GMSK demod.
637 * Call vectorSlicer() right before packing bits for transmission to osmo-bts.
638 * CommonLibs: Print soft bits with less confidence to console when printing a soft vector.
639 * BitVector: Remove convolutional codec - we don't use it in osmo-trx.
640 * BitVector: Convert SoftVector from 0..1 to -1..+1 soft bits.
641 * signalVector: Implement segment().
642 * vector: Introduce segmentMove() method to move data inside of a vector.
643 * vector: Introduce shrink() function to shrink vector size without loosing data.
644 * Move CorrType type from Transceiver to sigProcLib.
645 * sigProcLib: rename signalError type to SignalError.
646 * Move Transceiver::detectBurst() to sigProcLib to make it reusable.
647 * Move BURST_THRESH from Transceiver.cpp to sigProcLib.h to make it reusable.
648 * sigProcLib: Add operator<< to print CorrType to a string.
649 * sigProcLib.h: Fix whitespaces. No non-whitespace changes.
650 * Move Transceiver::demodulate() to sigProcLib to make it reusable.
651 * sigProcLib: constify signalVector arguments for detectBurst() functions.
652 * sigProcLib: Constify demodulation functions burst argument.
653 * sigProcLib: Fix number of tail bits in random Normal Bursts and zero Stealing Bits.
654 * Configuration: Variables allocated with 'new' must be freed with 'delete'.
655 * BitVector: Remove Generator class.
656 * PRBS: a Pseudo-random binary sequence (PRBS) generator class.
657
658 [ Tom Tsou ]
659 * EDGE: Fix USRP B210 device support
660 * uhd: Correct timing alignment in 8-PSK and GMSK downlink bursts
661 * EDGE: Fix demodulation slicer input
662 * common: Restrict UDP binding to localhost only
663 * common: Add mandatory length field to UDP receive calls
664 * uhd: Update default E3XX settings
665 * uhd: Set default Tx sampling to 4 sps
666 * uhd: Make device offset check a private method
667 * uhd: Set minimum UHD version requirement for E3XX
668 * sigproc: Expand RACH, TSC, and EDGE correlation windows
669 * transceiver: Do not report error on SETTSC when radio is on
670 * transceiver: Add Rx samples-per-symbol option
671 * radioInterface: Convert diversity argument to general type
672 * iface: Add inner ring-buffer implementation
673 * mcbts: Add multi-ARFCN channelizing filters
674 * mcbts: Add multi-ARFCN radio support
675 * sigproc: Adjust burst detection threshold criteria
676 * egprs: Enable 8-PSK length vectors on the Tx interface
677 * egprs: Enable 8-PSK burst detection when EDGE is enabled
678 * transceiver: Remove HANDOVER warnings
679 * mcbts: Allow out of order channel setup
680 * radioInterface: Fix multi-channel buffer index bug
681 * uhd: Add command line option for GPS reference
682 * transceiver: Fix mixed GSMK / 8-PSK transmission
683 * transceiver: Fix 4 SPS receive TOA value
684 * sigproc: Fix missing 8-PSK tail symbols
685 * uhd: Update USRP2/N200/N210 for 4 SPS Rx
686 * sigproc: Match differential GMSK start/end bits to tail bits
687 * uhd: Add missing B200 sample timing for 4 SPS receive
688 * transceiver: Fix command build warning
689 * uhd: Set minimum supported version to 3.9.0
690 * uhd: Add X300 sample timing for 4 SPS
691 * Revert "uhd: Set minimum supported version to 3.9.0"
692 * uhd: Add support for UHD-3.11 logging control
693 * uhd: Increase MC-BTS FPGA clock rate to 51.2 MHz
694 * Resampler: Fix initialization return checking
695 * sigProcLib: Remove unreachable code and no-effect checks
696 * sigProcLib: Check return status on downsampling
697 * sigProcLib: Fix negative value check on unsigned value
698 * Resampler: Fix non-array delete for filter taps
699 * Transceiver: Remove unsigned negative compares
700 * Configuration: Fix const and signedness compile warnings
701 * config: Remove OpenBTS style sqlite configuration
702 * radioInterface: Remove UmTRX 'diversity' option
703 * build: Require and check for gcc C++11 support
704 * uhd: Use map container for for device parameter access
705 * sigProcLib: Remove unused functions from public interface
706 * uhd: Add non-UmTRX channel swap support
707 * uhd: Fix Tx-RX timing offset setting
708 * uhd: Fix USRP2/N200/N210 device detection
709 * transceiver: Fix POWEROFF crash on USRP2/N200/X300 devices
710 * sigProcLib: Fix complex/real vector flag in Laurent modulator
711 * sigProcLib: Remove heap based signal vector allocations
712 * common: Declare explicit Vector move constructor
713 * sigProcLib: Remove trigonometric tables
714 * sigProcLib: Use explicit NaN check in sinc table generation
715 * sigProcLib: Replace dynamically allocated resampling buffers
716 * sigProcLib: Specify standard namespace for isnan()
717 * uhd: Always specify samples-per-symbol for device lookup
718 * LimeSDR: set approximate tx offset value to make GSM work
719
720 [ Neels Hofmeyr ]
721 * add basic .gitignore
722 * configure.ac: check for boost/config.hpp header
723 * The INSTALL file is being overwritten by autoreconf, but it is committed as empty file. As a result, the INSTALL file always shows as modified. Instead, remove INSTALL from git and ignore it.
724 * add contrib/jenkins.sh, for gerrit build bot
725
726 [ pierre.baudry ]
727 * transceiver: Fix mismatched allocations and deallocations
728
729 [ Holger Hans Peter Freyther ]
730 * debian: Require fftw3 header files for osmo-trx
731
732 [ Max ]
733 * Add gerrit settings
734 * Integrate Debian packaging changes
735 * Remove embedded sqlite3
736 * Fix building against sqlite3
737 * Add autoconf-archive to dependencies
738 * debian: remove obsolete dependency
739 * deb: remove unused dependency
740 * Remove redundant explicit dependency
741 * Use release helper from libosmocore
742
743 [ Ruben Undheim ]
744 * Do not embed sqlite3 when building
745
746 [ Philipp Maier ]
747 * buildenv: Turn off native architecture builds
748 * cosmetic: Make parameter lists uniform
749 * Add test program to verify convolution implementation
750 * ssedetect: Add runtime CPU detection
751 * cosmetic: remove code duplication
752 * buildenv: Make build CPU invariant
753 * buildenv: Split up SSE3 and SSE4.1 code
754 * cosmetic: Add info about SSE support
755
756 [ Vadim Yanitskiy ]
757 * buildenv: correct the ax_sse macro description
758 * buildenv: actually strip unused cpuid functionality
759 * buildenv: fix build on systems without SIMD support
760 * buildenv: cosmetic changes
761 * buildenv: check for __builtin_cpu_supports call support
762 * ssedetect: call __builtin_cpu_supports() only if supported
763
764 [ Pau Espin Pedrol ]
765 * cosmetic: transciever: Remove trailing whitespaces
766 * transceiver: Avoid sending clock indications when trx is not powered on
767 * Add -j option to bind to specific address
768
769 [ ignasj ]
770 * LimeSDR: Change device detection to work with USB and PCIe versions
771 * LimeSDR: change tx window type to TX_WINDOW_FIXED
772 * LimeSDR: Fix sample value range
773
774 [ Harald Welte ]
775 * Add '-t' command line option to enable SCHED_RR
776 * Import git-version-gen and update AC_INIT()
777
778 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 17:52:32 +0200
779
Holger Hans Peter Freytherd17b1892016-03-18 20:13:23 +0100780osmo-trx (0.1.9) trusty; urgency=medium
781
782 * Ask Ivan, really
783
784 -- Kirill Zakharenko <earwin@gmail.com> Thu, 16 Jul 2015 12:13:46 +0000
785
786osmo-trx (0.1.8) precise; urgency=low
787
788 * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP
789
790 -- Ivan Klyuchnikov <Ivan.Kluchnikov@fairwaves.ru> Sun, 9 Mar 2014 14:10:10 +0400