blob: a6f6b703e2fce01adc7e9de341ea6db8f23615b7 [file] [log] [blame]
Pau Espin Pedrola7143d32021-11-16 16:27:26 +01001osmo-trx (1.4.0) unstable; urgency=medium
2
3 [ Pau Espin Pedrol ]
4 * Threads.cpp: Fix missing extern C around libosmocore include
5 * Drop logging pthread ID
6 * Threads: Avoid printing pthread_self()
7 * ipc: Makefile.am: Clean LDADD variable
8 * Use new stat item/ctr getter APIs
9 * detectBurst(): Clear downsampling code path
10 * detectBurst(): constify parameter
11 * computeCI(): Constify param and pass it as reference
12 * computeCI(): Rename verbose repeated getter to constant
13 * computeCI(): Constify read-only variable
14 * detectGeneralBurst(): Increase log level about clipping to INFO
15 * cosmetic: Fix typo in comment
16 * computeCI: Document hardcoded multiplier
17 * lms: Drop duplicated check
18 * lms,uhd: Validate band of RxFreq too
19 * lms,uhd: Skip re-assigning same band
20 * lms,uhd: Allow changing band between poweroff & poweron
21
22 [ Vadim Yanitskiy ]
23 * gitignore: remove non-existing 'doc/manuals/osmomsc-usermanual.xml'
24 * ctrl_sock_handle_rx(): fix missing space in LOGCHAN() statement
25 * trx_rate_ctr: use thread safe strerror() in device_sig_cb()
26 * IPCDevice: use thread safe strerror_r() instead of strerror()
27 * IPCDevice: check value returned from select()
28 * LMSDevice: LMS_GetDeviceList() may return a negative number
29
30 [ Eric ]
31 * add hidden fn adjustment command
32 * uhd: ensure configured clock source is actually used
33 * vty: printing fn offset should be signed
34 * lms: init band
35
36 [ Oliver Smith ]
37 * d/patches/build-for-debian8.patch: remove
38
39 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 16 Nov 2021 16:27:26 +0100
40
Harald Welte90d84172021-02-28 11:32:12 +010041osmo-trx (1.3.1) unstable; urgency=medium
42
43 * mark uhddev_ipc.cpp as BUILT_SOURCES
44
45 -- Harald Welte <laforge@osmocom.org> Sun, 28 Feb 2021 11:32:11 +0100
46
Pau Espin Pedrol309ad4d2021-02-23 14:27:15 +010047osmo-trx (1.3.0) unstable; urgency=medium
48
49 [ Pau Espin Pedrol ]
50 * Make logging category DLMS generic and reusable for other backends
51 * uhd: Use DEVDRV log category and support UHD >=3.11 logging framework
52 * uhd: Improve some logging lines printing UHD pretty-print output
53 * doc: clarify number of channels on B210 with multi-arfcn enabled
54 * radioInterfaceMulti: Fail to tune on freq not following multi-arfcn restrictions
55 * doc: Update vty reference xml file
56 * lms: Move initialization of field started to constructor
57 * lms: Drop unused define
58 * smpl_buf: Fix str_code() param and print unknown error val
59 * lms: Improve smpl_buf error logging
60 * lms: Change radioDevice constructor arg name to avoid masking instance attr
61 * lms: Make reference to std::vector unambiguous
62 * lms: Move rx_buffers allocation to constructor
63 * lms: Store device type specific parameters in one place
64 * lms: Make ts_offset and smpl rate coefs device-specific
65 * lms: Initial multi-arfcn support
66 * contrib/jenkins.sh: Reorder sanity checks
67 * debug.h: Avoid printing pthread_t type
68 * debug.h: Fix print format of chan in CLOGCHAN
69 * cosmetic: fix several typos found by codespell
70 * radioDevice: Drop unused RSSI param from readSamples API
71 * radioDevice: Drop unused isControl param from WriteSamples API
72 * Use OSMO_FD_READ instead of deprecated BSC_FD_READ
73 * Transceiver: Fix extra space in RSP NOISELEV error
74 * Transceiver: Implement TRXC cmd NOMTXPOWER
75 * UHDDevice: Implement getNominalTxPower() based on TxFrequency
76 * radioInterface: Operate on real Tx power attenuation rather than on device specific gains
77 * UHDDevice: Compute TxGain on UHD API based on expected Tx output power
78 * proto_trxd: Fix UndefinedBehaviorSanitizer from ubsan
79 * Transceiver: Allow sending negative nominal tx power in RSP NOMTXPOWER
80 * LMSDevice: Compute TxGain on LimeSuite API based on expected Tx output power
81 * Drop old TxGain APIs from parent radioDevice abstract class
82 * {UHD,LMS}Dervice: Log expected resulting TxPower when setting device specific TxGain
83 * cosmetic: trx_rate_ctr: Fix whitespace
84 * trx_rate_ctr: Fix immediate rescheduling on per-sec thresholds
85 * Rename device specific rate counter multi-thread helpers
86 * Introduce rate counter tx_stale_bursts
87 * TransceiverState: Initialize ctrs field in constructor
88 * doc/manuals: Update thread documentation after dropping CTRL sock threads
89 * trx_rate_ctr: Fix locking wrong mutex
90 * Introduce rate counters to detect issues in received Dl bursts from TRXD
91 * Transceiver: Fix race condition obtaining Dl burst from Upper layer
92 * Add rate counter for missing Txbursts when scheduled towards the radioInterface
93 * Transceiver: Provide initial value for TransceiverState::mFiller in constructor
94 * Transceiver: Use already obtained value from Rx msg structure
95 * Transceiver: Restrict conditions where FN gaps are detected
96 * trx_rate_ctr: Lower some log levels
97 * Introduce CTR log category
98 * Transceiver: Lower some log levels which have an associated counter
99 * Transceiver: Check log level before generating burst str representation
100 * Transceiver: Add several rate_ctr for rx error conditions
101 * Use new libosmovty cpu sched config features
102 * debian: Update debian8 osmo-trx specific patch
103 * jenkins.sh: Verify distro-specific patches apply
104 * ipc: fix var declaration in for loop
105 * Add support for TRXC MUTE command
106 * arch: x86: Fix convolve optimizations breaking signal
107 * contrib/jenkins: Enable parallel make in make distcheck
108 * Transceiver: Pass config struct instead of large list of params
109 * Calculate RSSI offset based on RxGain configuration
110 * main: generate coredump and exit upon SIGABRT received
111 * ipc: Fix wrong reference to BTS in log line
112 * ipc-driver-test: Allow setting dir prefix for UD socket
113 * radioInterfaceMulti: Fix memory leak upon close()
114 * ChannelizerBase: Fix memory leak
115 * Threads.cpp: Use already existing gettid wrapper function
116 * Replace my_gettid with libosmocore osmo_gettid API
117 * tests: Explicitly drop category from log
118 * tests: Replace deprecated API log_set_print_filename
119
120 [ Philipp Maier ]
121 * debug: use LOGL_NOTICE for log category DDEV
122 * doc: do not set the base-port of the trx
123 * doc: apply an rssi-offset of 28 by default.
124 * doc: switch log levels to notice
125 * Transceiver: Log when sending of CLK indications begins
126 * vty: add attributes to VTY commands indicating when they apply
127 * osmo-trx: add commandline option --vty-ref-xml
128
129 [ Eric ]
130 * configure.ac: fix libtool issue with clang and sanitizer
131 * transceiver: check the right vector
132 * transceiver: get rid of the ctrl threads
133 * add kernel style .clang-format with 120 chars per line limit
134 * devices: reset internal smart sample buffers upon stop
135 * transceiver: optimize code if optimizations are enabled
136 * transceiver: initialize reorder flag so we don't miscount
137
138 [ Harald Welte ]
139 * PRBS tool sending PRBS sequence to TRX
140 * prbs-tool: Add error simulation capabilities
141 * utils: Ensure content of this directory is included in 'make dist'
142 * prbs-tool: Don't require C99
143 * RPM spec file: Require uhd-firmware for osmo-trx-uhd
144 * osmo-trx.spec.in: Use %config(noreplace) to retain current config file
145 * Fix build on Debian8
146 * [cosmetic] radioInterfaceMulti: More comments
147 * [cosmetic] radioIntefaceMulti: Fix whitespace / indent
148 * ipc: Use OSMO_FD_* instead of deprecated BSC_FD_*
149 * Use osmo_fd_setup() wherever applicable
150 * Use osmo_fd_*_{disable,enable}
151 * README update
152 * manual: Fix typo OsmTRX -> OsmoTRX
153
154 [ Oliver Smith ]
155 * contrib: import RPM spec
156 * contrib: integrate RPM spec
157 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
158 * contrib/jenkins: don't build osmo-gsm-manuals
159 * configure.ac: set -std=gnu11
160
161 [ Vadim Yanitskiy ]
162 * UHDDevice: catch LookupError/IndexError in set{Rx,Tx}Antenna()
163 * debian/control: change maintainer to the Osmocom team / mailing list
164 * proto_trxd: cosmetic: 'if' is not a function, add space
165 * vty: add multi-ARFCN specific warning for chan N > 0
166 * radioDevice: fix set_antennas(): consider MULTI_ARFCN mode
167 * device/lms: fix: 'trx_vty.h' header requires C linkage
168 * device/lms: fix missing semicolon in LMSDevice::assign_band_desc()
169 * device/lms: get rid of 'using namespace std'
170 * device/common/Makefile.am: remove $(LMS_CFLAGS) from AM_CXXFLAGS
171 * main: add --vty-ref-mode, use vty_dump_xml_ref_mode()
172 * device: drop unreasonable LIBOSMO{CTRL,VTY}_{CFLAGS,LIBS}
173 * Transceiver: use size_t and ARRAY_SIZE() in constructor
174 * Transceiver: explicitly init m{Rx,Tx}LowerLoopThread
175 * vty: fix documentation for 'swap-channels (disable|enable)'
176 * vty: fix documentation for 'egprs (disable|enable)'
177 * vty: fix documentation for 'rx-sps (1|4)' and 'tx-sps (1|4)'
178 * vty: cosmetic: use VTY_IPV4_CMD in 'bind-ip' / 'remote-ip'
179 * vty: fix documentation for 'multi-arfcn (disable|enable)'
180 * vty: remove groundless statement about filler type 'dummy'
181 * vty: auto-generate cmd and doc strings for cfg_filler_type_cmd
182 * vty: fix documentation for 'ext-rach (disable|enable)'
183 * main: use logging API to print SIMD info instead of printf()
184 * doc/manuals: generate XML VTY reference at build-time
185 * vty: fix swapped documentation for 'filler type' command
186 * Transceiver: fix integer division in addRadioVector()
187 * Transceiver: use proper factor for amplitude scaling
188 * Add a (hidden) VTY parameter for Rx/Tx freq. shifting
189
190 [ Eric Wild ]
191 * osmo-trx-ipc
192
193 [ Alexander Couzens ]
194 * osmo-trx.spec: move ipc-driver-test into package ipc-test
195
196 [ Sylvain Munaut ]
197 * sigProcLib: fix C/I computation for 8-PSK modulated bursts
198
199 -- Pau Espin Pedrol <pespin@espeweb.net> Tue, 23 Feb 2021 14:27:15 +0100
200
Pau Espin Pedrolda7fee82020-01-03 19:54:00 +0100201osmo-trx (1.2.0) unstable; urgency=medium
202
203 [ Pau Espin Pedrol ]
204 * osmo-trx: log to stderr on signal received
205 * Drop old setPriority related code
206 * Transceiver: fix segfault during init if IP addr binding fails
207 * Transceiver: Check return value when binding IP addr for clock socket
208 * Transceiver: Clean up receival of downlink bursts
209 * Transceiver: Fix idle ul burst indications being dropped
210 * Transceiver: exit process when BTS drops connection
211 * Transceiver: Enable EDGE detection only on PDCH timeslots
212 * lms: Log available antennas if requested antenna fails
213 * device: Use LOGCHAN in set_antennas()
214 * Transceiver: Fix logging TN and version
215 * Transceiver: Use LOGCHAN in logRxBurst to unify log format
216 * Transceiver: Log error condition no burst in pullRadioVector()
217 * Transceiver: pullRadioVector(): Fix use of uninitialized value bi->tn
218 * Transceiver: Don't stop TRX if pulling from OFF timeslot
219 * radioInterface: Rename mRadio to mDevice
220 * radioInterfaceMulti: Check equals zero explicitly
221 * USRPDevice: Fix setRxGain return on error and getRxGain() returning always 0
222 * USRPDevice: Return previous txGain if setting value failed
223 * LMSDevice: Return previous txGain/rxGain if setting value failed
224 * radioInterface: Remove unusued getRxGain()
225 * radioDevice: Introduce getTxGain() API
226 * radioInterfaceMulti: Override setTxGain() to avoid chan!=0 calls
227 * UHDDevice: Drop unneeded MULTI_ARFCN checks
228 * radioInterface{Multi,Resamp}: Fix successful writeSamples() masking underrun from readSamples()
229 * radioInterface: Mark setRxGain as virtual
230 * Move multi-ARFCN chan amount modification from UHDDevice to parent class
231 * radioInterface: Atomically fetch and change underrun variable
232 * radioInterfaceMulti: write frequency offset direction (rx/tx) in log line
233 * Use new libosmocore logging lock API
234 * Transceiver: Fix wrong response upon CMD HANDOVER failure
235 * uhd: use value already cached in tmp variable
236 * Transceiver.cpp: Introduce and use new logging categories
237
238 [ Timo Jacobus ]
239 * Transceiver: Fixed copying of history into and from channelizer buffer.
240
241 [ Alexander Chemeris ]
242 * vty: Don't enable random filler bursts automatically with EDGE.
243 * vty: Simplify filler burst settings and improve help and readability.
244
245 [ Martin Hauke ]
246 * Fix common misspellings and typos
247
248 [ Harald Welte ]
249 * trx: exit() on unsupported positional arguments on command line
250
251 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 19:54:00 +0100
252
Pau Espin Pedrold0cbb162019-08-08 13:00:06 +0200253osmo-trx (1.1.1) unstable; urgency=medium
254
255 * UNRELEASED
256
257 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 08 Aug 2019 13:00:05 +0200
258
Pau Espin Pedrole774d522019-08-07 21:12:56 +0200259osmo-trx (1.1.0) unstable; urgency=medium
260
261 [ Sylvain Munaut ]
262 * arm/convolve: Fix the vfp4 real convolution for h_len=12
263 * convolve: Remove support for step, offset parameters
264 * tests: Rework the convolve_test
265 * tests: Re-enable the convolve_test by default
266 * sigProcLib: Add C/I (Carrier-to-Interference ratio) computation
267
268 [ Vadim Yanitskiy ]
269 * VTY: add extended (11-bit) RACH detection toggle
270 * doc/configuration.adoc: fix incorrect number of physical RF channels for B210
271 * driveTxPriorityQueue(): cosmetic: use proper type for TDMA TN
272 * driveTxPriorityQueue(): use trxd_hdr_common for message parsing
273 * driveTxPriorityQueue(): check if message header format is supported
274 * driveTxPriorityQueue(): enrich logging message
275 * trxd_fill_common(): fix TRXD header version coding
276 * manuals/configuration.adoc: fix copy-paste error in config example
277
278 [ Pau Espin Pedrol ]
279 * osmo-trx: Avoid handling signals after shutdown triggered
280 * osmo-trx: Use signalfd to serialize signals in main thread ctx
281 * osmo-trx: Check return code of osmo_fd_register
282 * lms: flush_recv: alloc buf on stack instead of heap
283 * lms: Improve log during flush recv error
284 * cosmetic: Threads.h: Remove trailing whitespace
285 * Move duplicated thread_enable_cancel to CommonLibs
286 * lms: Log underrun/overrun events
287 * lms: Remove references to ALERT loglevel
288 * lms: Remove unused var m_last_tx_overruns
289 * lms: Catch and log dropped packets by HW during recv
290 * cosmetic: uhd: Move smpl_buf out of UHDDevice, move UHDDevice class definition to .h
291 * uhd: smpl_buf: Drop UHD specifics out back to UHDDevice
292 * uhd: smpl_buf: Use TIMESTAMP type in str_status
293 * cosmetic: uhd: Use loglevel ERROR instead of ERR
294 * uhd: Avoid reallocation of buffers every read
295 * Move smpl_buf out of uhd dir to re-use it in other devices
296 * device: Drop unused numberRead/numberWritten APIs
297 * smpl_buf: Remove unused clk_rt variable
298 * smpl_buf: Remove unused clk_rt variable (fixup)
299 * smpl_buf: Remove dbg log line with duplicated info
300 * Introduce LOGCHAN macro to standarize logging channel info
301 * smpl_buf: Move it to device/common and create libdevice_common.la
302 * lms: Use smpl_buf to recover from timestamp jumps
303 * lms: Fix stream_stats checks with droppedPackets
304 * Add rate_ctr support to store/retrieve SDR errors through VTY
305 * Rename and move STOP signal from Transceiver to main
306 * doc: vty: Update trx_vty_reference.xml
307 * lms: Drop unusued variable masterClockRate
308 * lms: Fix stream_stats checks with overrun/underrun
309 * Add VTY commands to set error ctr thresholds
310 * Remove AUTHORS file
311 * trx_{vty,rate_ctr}: Set proper license AGPLv3+
312 * Introduce structs to encode TRXD packets
313 * Transceiver: refactor: gather uplink burst parameters in struct
314 * Transceiver: Drop unused rssi_valid struct field
315 * Transceiver: Move nbits burst size calculation to pullRadioVector()
316 * Transceiver: Move calculation of normalized values (rssiOffset) to pullRadioVector()
317 * Transceiver: Move soft bits normalization to pullRadioVector()
318 * Transceiver: Drop use of GSM::Time from trx_ul_burst_ind
319 * Transceiver: Get rid of SoftVector in struct trx_ul_burst_ind
320 * Transceiver: replace UDPSocket with libosmocore socket API
321 * Transceiver: Avoid noise calculation formula in 2 branches in pullRadioVector
322 * Transceiver: Simplify code on early error return when calling detectAnyBurst
323 * Transceiver: pullRadioVector(): Move initialization of var to start of function
324 * Transceiver: Support pulling idle frames in pullRadioVector()
325 * sigProcLib: detectAnyBurst() family: Use struct to gather all out params
326 * sigProcLib: detectAnyBurst(): make TSC used to detect burst available to caller
327 * Logger: global Log mutex is now available from C code
328 * Transceiver: Move out TRXD socket send code to prepare for TRXDv1
329 * Transceiver: Support SETFORMAT command
330 * Transceiver: Support TRXD v1
331 * Transceiver: Initialize mExtRACH in constructor
332 * debian/copyright: Remove non existent radioInterfaceDiversity.cpp from list
333 * debian/copyright: Update wrong paths in license list
334 * debian/copyright: Add missing file Utils.* to LGPL-2.1+ list
335 * cosmetic: Fix trailing whitespace in several files
336 * Add SPDX annotation
337 * Bind CTRL port to IP addr specified in VTY config
338 * Transceiver: Store TRXD version per channel
339 * Transceiver: Clean up code passing parameters to threads
340 * Remove empty ChangeLog fnd NEWS files
341 * Remove unused autogen.sh
342 * radioInterface: Clarify how underruns are handled driving a radioDevice
343 * usrp1: don't check for non-null underrun pointer
344 * jenkins.sh: Workaround libusrp build race conditon
345 * lms: Drop rx_underruns rate ctr, add tx_drop_* rate ctr
346 * Move inband-signaling-usb documentation to UserManual
347 * Move matlab files under utils/matlab
348 * Move Transceiver52/README to UserManual
349 * Move README.DFEsymbolspaced to utils/matlab
350 * Move std_inband.rbf under device/usrp1/ dir
351 * Drop old README information, provide new updated README
352 * Transceiver: Add missing include netinet/in.h
353 * Require newer version of libosmocore to avoid build failure
354
355 [ Tom Tsou ]
356 * multi-ARFCN: fix maximum number of carriers limitation
357
358 [ Harald Welte ]
359 * use BSC_FD_READ and not OSMO_FD_READ
360 * proto_trxd.c: Use bit-wise AND, not boolean AND
361 * Timeval: Restore output stream flags after changing them
362 * ChannelizerBase: fix initialization of class members
363 * CorrelationSequence: fix initialization of class members
364 * radioInterface.cpp: Fix missing member initialization of RadioInterface()
365
366 [ Joachim Steiger ]
367 * lms: Remove wrong unused code copied from -uhd
368 * lms: move LMS_EnableChannel from Start/Stop to Open/Close device
369 * lms: move LMS_GetLPFBWRange and LMS_Calibrate calls from open to start
370 * lms: add device type detection and device specific gains
371 * lms: properly call close if set_antennas() fails, add some comments
372
373 [ Oliver Smith ]
374 * debian: create -doc subpackage with pdf manuals
375 * contrib/jenkins.sh: run "make maintainer-clean"
376
377 [ Eric Wild ]
378 * Add option to set stack size in config file, default == 0 == OS default
379
380 [ Ruben Undheim ]
381 * Fix spelling discovered by lintian
382
383 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 21:12:56 +0200
384
Harald Welted20b7fa2019-01-20 19:35:05 +0100385osmo-trx (1.0.0) unstable; urgency=medium
386
387 [ Pau Espin Pedrol ]
388 * doc: examples: Add umtrx sample config
389 * UHDDevice: Fix setup failure with LimeSuite > 18.04.1
390 * examples: Set rt-prio 18 and print file basename
391 * lms: Several improvements and compilation/runtime fixes
392 * build: Add support for LimeSuite device backend
393 * LMSDevice: Set correct values for Max{Tx,Rx}Gain
394 * LMSDevice: Fix setup failure with LimeSuite > 18.04.1
395 * lms: Makefile.am: Reorder params to fix link issue
396 * lms: Check LPBFW to set is within supported range
397 * debian: Add package osmo-trx-lms
398 * contrib: Add systemd services for all backends
399 * debian: Add cfg file examples for osmo-trx-{lms,uhd}
400 * Add -V param to print version
401 * lms: Allow values diff than 34dB to be set by setRxGain()
402 * Use correct paths when installing example files
403 * debian: Enable build of osmo-trx-lms
404 * debian: Explicitly enable osmo-trx-uhd build
405 * configure.ac: Fix typo in with-lms help string
406 * vty: Fix typo in gpsdo clock reference type
407 * configure.ac: Add --enable-werror option
408 * Logger: Disable pthread cancel point inside Logger destructor
409 * cosmetic: Fix trailing whitespace
410 * radioInterface: forward errors from RadioDevice to Transceiver in recv path
411 * lms: Return error on device read timeout
412 * osmo-trx: Add osmo_signal to stop whole transceiver chain correctly on error
413 * radioInterface: Fix variable storing integer return value
414 * configure.ac: Specify default language as C++
415 * UHHDDevice: Replace deprecated header uhd/utils/thread_priority.hpp
416 * SigProcLib: Use available copyTo Vector API instead of memcopy
417 * cosmetic: Fix trailing whitespace in several files
418 * radioInterfaceMulti:pullBuffer: Sanely convert float array to complex array
419 * Vector: Copy arrays in a sane way for non-trivially copyable types
420 * jenkins.sh: Add --enable-werror flag to osmo-trx configure step
421 * Install systemd services with autotools
422 * Install sample cfg file to /etc/osmocom
423 * cosmetic: Use proper whitespace in several for loops
424 * Use pthread_setname_np to name threads
425 * CommonLibs/Makefile.am: Specify libcommon_la_LIBADD
426 * Transciever: Log values causing Tx underrun
427 * examples: Use logging level 'set-all' instead of 'all'
428 * jenkins.sh: Enable build of osmo-trx-lms
429 * ChannelizerBase: Fix ASan alloc-dealloc-mismatch
430 * UHDDevice: setRxGain on chan 0 when using multi-arfcn
431 * lms: Use LimeSuite.h log level defines instead of hardcoded values
432 * lms: Apply LMS->OSMO log level conversion
433 * Introduce OsmoTRX manual
434 * Introduce chapter trx_if.adoc and add it to OsmoTRX and OsmoBTS
435 * trx: Add reference to project wiki page in overfiew section
436 * trx: Add Hardware architecture support section
437 * trx: Add Hardware device support section
438 * osmotrx: Split Device specific section from backend one
439 * osmotrx: Write initial documentation for several supported devices
440 * osmotrx: configuration: Add section to document multi-arfcn feature
441 * osmotrx: Create a common chapter for section documenting backends
442 * osmotrx: Introduce code architecture chapter
443 * lms: Fix start after stop of device
444 * lms: Destroy streams on device stop
445 * radioInterface: Fix memleak during close()
446 * PointerFIFO: Fix memleak of ListNode
447 * lms: Make sure LMS_Close is called when Device is torn down
448 * osmo-trx: Change some lines to use libosmocore logging instead of cout
449 * lms: Close device on LMS_Init failure
450 * SigProcLib: Improve Vector buffer allocation mess
451 * lms: Allow setting Tx/RxGain for chan!=0
452 * lms: Allow setting Tx/RxFreq for lchan!=0
453 * lms: Improve Set{Rx,Tx}{Gain,Freq} logging
454 * transceiver: log chan on CTRL command received
455 * Add TRXCTRL log category
456 * transceiver: Log TRXCTRL iface responses towards osmo-bts-trx
457 * lms: Move {under,over}run checks into separate method
458 * lms: Do {under,over}run checks even if LMS_RecvStream fails
459 * Timeval: passed() returns true if time is equal
460 * Timeval: Move implementation to use clock_gettime and timespec
461 * Timeval: Move to osmo_clock_gettime
462 * TimevalTest: Make test deterministic with fake time
463 * lms: Fix build against LimeSuite > 18.10
464 * configure.ac: check boost only if USRP1 support is enabled
465
466 [ Vadim Yanitskiy ]
467 * trx_vty.c: fix: use CONFIG_NODE as parent by default
468 * device/lms/LMSDevice.cpp: fix compilation warning
469 * sigProcLib: introduce both TS1 and TS2 RACH synch. sequences
470 * sigProcLib: add a CorrType for extended (11-bit) RACH
471
472 [ Harald Welte ]
473 * Initial work towards direct LimeSuite support in OsmoTRX
474 * update .gitignore to include osmo-trx-lms
475 * LMSDevice: Call LMS_Init() before setting sample rate
476 * LMSDevice: Print sample rate range + actual sample rate after setting it
477 * LMSDevice: Typo fix: s/Internal/External
478 * LMSDevice: Set low-pass filters to smallest possible option
479 * LMSDevice: Fix initial timestamp offset of 2500
480 * LMS_Device: Set ts_offset to 0.
481 * LMSDevice: Reduce Rx logging verbosity: Only log unexpected timestamps
482 * move set_antennas() from UHD to generic radioDevice base class
483 * lms: Fix support for rx_paths / tx_paths
484 * lms: Call set_antennas() during open() method
485 * radioDevice: Move tx_sps from derived into base class
486 * radioDevice: better encapsulation in base class
487 * lms: Fix coding style
488 * lms: Fail in case of unsupported configuration
489 * usrp1: Fail in case of unsupported configuration
490 * Fix config file saving of {tx,rx}-path VTY config strings
491 * logging: Introduce new "DDEV" category for device-specific code
492 * update git-version-gen to generate proper version numbers
493 * ensure well-formed example config files
494 * SocketsTest.testReaderIP(): Zero terminate received buffer
495 * trx_validate_config(): Fix validation of rx_sps
496 * vty-ref: Update URI of docbook 5.0 schema
497 * lms: User correct scale factor for transmit samples
498 * lms: Set Rx gain to midpoint, as comment suggests.
499 * usrp1: Remove uninitialized skipRx logic
500 * usrp1: Fix formatting of log message (missing space)
501 * cosmetic: Don't call the SDR "USRP" in error message
502
503 [ Zydrunas Tamosevicius ]
504 * lms: Use same timestamp offset like when using LimeSDR via UHD
505 * lms: Reduce log level of "send buffer of len ..."
506 * lms: fix LMS_StartStream() handling for multiple channels
507 * lms: Reduce Rx gain from 47 to 34 dB
508
509 [ Alexander Couzens ]
510 * debian: add patches for debian8
511
512 [ Oliver Smith ]
513 * Add long parameters (--help, --version, ...)
514 * build manuals moved here from osmo-gsm-manuals.git
515 * Fix DISTCHECK_CONFIGURE_FLAGS override
516 * contrib/jenkins.sh: build and publish manuals
517 * jenkins.sh: run "make distcheck"
518 * contrib: fix makedistcheck with disabled systemd
519 * osmo-trx.cpp: move comma_delimited_to_vector() to Utils.cpp
520 * LMSDevice: make use of dev-args in osmo-trx.cfg
521 * LMSDeviceTest: fix link errors on OBS
522
523 [ Neels Hofmeyr ]
524 * Importing history from osmo-gsm-manuals.git
525
526 [ d0gtail ]
527 * UHDDevice: log exception information on device open failure
528
529 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 19:35:04 +0100
530
Pau Espin Pedrold0ac9262018-05-03 16:23:30 +0200531osmo-trx (0.4.0) unstable; urgency=medium
532
533 [ Neels Hofmeyr ]
534 * jenkins: use osmo-clean-workspace.sh before and after build
535
536 [ Harald Welte ]
537 * SocketsTest: Fix printing of non-nul-terminated string
538 * Revert "debian: Remove osmo-trx-usrp1 until we can build libusrp1.deb"
539 * debian/control: Remove "Maintainer" from binary package section
540 * debian/rules: Make sure we always require libusrp
541 * debian: Ensure USRP1 firmware is part of osmo-trx-usrp1
542 * debian/control: Add build dependency to libusrp-dev
543 * update .gitignore for new executable names
544 * osmo-trx: s/GSM Core Address/GSM BTS Address/
545
546 [ Piotr Krysik ]
547 * UHDDevice.cpp: add USRP B205mini support
548
549 [ Max ]
550 * Mark release target as virtual
551 * Remove outdated references to OpenBTS
552 * Remove unused headers
553 * Update installation instructions
554 * Update legal disclaimer
555 * Update license notes
556 * tests: null-terminate buffer
557
558 [ Pau Espin Pedrol ]
559 * cosmetic: Remove trailing whitespace
560 * Logger: Stop using Log.Alarms.Max from config
561 * Logger: Stop using Log.File and Log.Level from config
562 * Drop use of ConfigurationTable gConfig
563 * Remove Configuration module and libsqlite dependency
564 * cosmetic: AUTHORS: fix trailing whitespace
565 * Set up GNU Autotest infrastructure
566 * tests: InterThread: adapt to have reproducible output and enable autotest
567 * tests: Timeval: adapt to have reproducible output and enable autotest
568 * tests: Log: adapt to have reproducible output and enable autotest
569 * Sockets.cpp: Fix initialization of UDD socket
570 * tests: Sockets: adapt to have reproducible output and enable autotest
571 * utils/convolvtest: Remove uneeded libosmocore dependency
572 * Move ARCH_LA to Makefile.common
573 * tests: Migrate convtest util to autotest infrastructure
574 * arm/convert.c: Fix compilation error
575 * arm/convert.c: Add missing convert_init implementation
576 * .gitignore: Add missing test related files
577 * Remove UDDSocket class
578 * tests: SocketTests: Pick OS-assigned instead of setting one manually
579 * tests: SocketsTest: Avoid hang forever if test fails
580 * tests: SocketsTest: Fail test on write fail
581 * tests: TimevalTest: refactor and avoid double comparison
582 * contrib/jenkins.sh: Use qemu+proot+debootstrap to run tests with ARM instruction set
583 * tests: convolve: Disable due to difference in output in different archs
584 * Remove unneeded libdl dependency
585 * Fix whitespace
586 * Add support to set Rx/TxAntenna
587 * UHDDevice: Initialize async_event_thrd in constructor
588 * Logger: Drop unused gLogEarly
589 * Logger: Remove unused logging macros
590 * Logger: get rid of alarm APIs
591 * Logger: Drop syslog support
592 * Logger: Drop support to log into file
593 * Logger: Remove unused includes
594 * Logger: Remove gLogToConsole flag
595 * configure.ac: Check for pkg-config
596 * Depend on libosmocore
597 * osmo-trx: set up signals using libosmocore helpers
598 * osmo-trx: Set up talloc ctx
599 * debian: Depend on libtalloc and libosmocore
600 * Add initial support for logging, vty, ctrl
601 * Logger: Use libosmocore logging system
602 * osmo-trx.cpp: Move trx start and stop to helper functions
603 * Move enums required by VTY to a separate header
604 * vty: Implement VTY cfg parsing for current parameters
605 * doc: Add sample cfg file for LimeSDR
606 * osmo-trx: Use VTY cfg structures while still allowing cmd line options
607 * osmo-trx: Re-introduce -l cmd line parameter
608 * Makefile.am: Avoid using subdir if arch is not required
609 * Build Transceiver52M/common as an .la lib
610 * use osmo_init_logging2()
611 * tests: Makefile.am: Fix typo in include path
612 * configure.ac: Add --enable-sanitize option
613 * Move arch specific fiels to arch subdir
614 * Move device specific files to device subdir
615 * Change configure define USRP1 to DEVICE_USRP1
616 * Move device specific code out of radioInterface
617 * Transceiver: Move device specific code to radioDevice class
618 * Build one osmo-trx binary for each device support enabled
619 * Logger: Print correct source file and line number
620 * Transceiver: log timing info of stale bursts
621 * build: Fix make distcheck
622 * build: More OBS build failure fixes
623 * jenkins.sh: Enable build of osmo-trx-usrp1
624 * debian: Remove osmo-trx-usrp1 until we can build libusrp1.deb
625 * debian: Fix OBS build
626 * build: Fix OBS build for ARM
627 * git-version-gen: Take into account tags not in master
628
629 [ Alexander Huemer ]
630 * Unbreak `./configure --with-usrp1` build
631 * Fix USRP1 build with support for setting Rx/TxAntenna
632
633 [ Alexander Couzens ]
634 * jenkins.sh: fix the download url if the qemu image wasn't setup
635 * jenkins.sh: cleanup always the workspace
636 * jenkins.sh: change qemu-img default location to $HOME/qemu-img instead of /opt/qemu-img
637
638 [ Vadim Yanitskiy ]
639 * Transceiver.cpp: use a define for the MAX_PACKET_LENGTH
640 * Transceiver.cpp: properly zero-terminate received commands
641 * Transceiver.cpp: use pointer arithmetics for CMD parsing
642 * Transceiver.cpp: fix incorrect format string for SETTSC
643 * Transceiver.cpp: prevent out-of-range array access
644
645 [ Martin Hauke ]
646 * configure.ac: Fix typo
647
648 [ Philipp Maier ]
649 * doc: add example config for usrp B200 series
650
651 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:23:29 +0200
652
Harald Welte78e1cd22017-10-28 17:52:32 +0200653osmo-trx (0.2.0) unstable; urgency=medium
654
655 [ Alexander Chemeris ]
656 * EDGE: Add support for UmTRX.
657 * Common: Get rid of a compilation warning.
658 * Common: Make sure gLogEarly() log to the same facilities as the normal log.
659 * transceiver: Properly handle MAXDLY.
660 * transceiver: Add an option to generate random Access Bursts.
661 * osmo-trx: Output Rx SPS as a part of configuration output.
662 * transceiver: Do not pass transceiver state struct to function where it's not used.
663 * makefile: Fix build from an external path.
664 * radioDevice: GSMRATE macro must have parentheses around its definition.
665 * uhd: Fix comment.
666 * radioInterface: Initialize power scale with a meaningful default.
667 * transceiver: Log channel number in DEBUG output of demoded bursts.
668 * transceiver: Add an option to emulate a RACH delay in random filler mode.
669 * UHD: Initial LimeSDR support.
670 * CommonLibs: Remove unused files.
671 * sigProcLib: Typo sybols -> symbols
672 * radioBuffer: Remove extra ; at the end of inline function definitions.
673 * sigProcLib: Fix documentation, sync argument names in .cpp and .h files.
674 * sigProcLib: make energyDetect() simpler by returning actual energy.
675 * sigProcLib: Rename demodulateBurst() to demodGmskBurst() for clarity.
676 * sigProcLib: Slice SoftVector instead of signalVector for GMSK demod.
677 * Call vectorSlicer() right before packing bits for transmission to osmo-bts.
678 * CommonLibs: Print soft bits with less confidence to console when printing a soft vector.
679 * BitVector: Remove convolutional codec - we don't use it in osmo-trx.
680 * BitVector: Convert SoftVector from 0..1 to -1..+1 soft bits.
681 * signalVector: Implement segment().
682 * vector: Introduce segmentMove() method to move data inside of a vector.
683 * vector: Introduce shrink() function to shrink vector size without loosing data.
684 * Move CorrType type from Transceiver to sigProcLib.
685 * sigProcLib: rename signalError type to SignalError.
686 * Move Transceiver::detectBurst() to sigProcLib to make it reusable.
687 * Move BURST_THRESH from Transceiver.cpp to sigProcLib.h to make it reusable.
688 * sigProcLib: Add operator<< to print CorrType to a string.
689 * sigProcLib.h: Fix whitespaces. No non-whitespace changes.
690 * Move Transceiver::demodulate() to sigProcLib to make it reusable.
691 * sigProcLib: constify signalVector arguments for detectBurst() functions.
692 * sigProcLib: Constify demodulation functions burst argument.
693 * sigProcLib: Fix number of tail bits in random Normal Bursts and zero Stealing Bits.
694 * Configuration: Variables allocated with 'new' must be freed with 'delete'.
695 * BitVector: Remove Generator class.
696 * PRBS: a Pseudo-random binary sequence (PRBS) generator class.
697
698 [ Tom Tsou ]
699 * EDGE: Fix USRP B210 device support
700 * uhd: Correct timing alignment in 8-PSK and GMSK downlink bursts
701 * EDGE: Fix demodulation slicer input
702 * common: Restrict UDP binding to localhost only
703 * common: Add mandatory length field to UDP receive calls
704 * uhd: Update default E3XX settings
705 * uhd: Set default Tx sampling to 4 sps
706 * uhd: Make device offset check a private method
707 * uhd: Set minimum UHD version requirement for E3XX
708 * sigproc: Expand RACH, TSC, and EDGE correlation windows
709 * transceiver: Do not report error on SETTSC when radio is on
710 * transceiver: Add Rx samples-per-symbol option
711 * radioInterface: Convert diversity argument to general type
712 * iface: Add inner ring-buffer implementation
713 * mcbts: Add multi-ARFCN channelizing filters
714 * mcbts: Add multi-ARFCN radio support
715 * sigproc: Adjust burst detection threshold criteria
716 * egprs: Enable 8-PSK length vectors on the Tx interface
717 * egprs: Enable 8-PSK burst detection when EDGE is enabled
718 * transceiver: Remove HANDOVER warnings
719 * mcbts: Allow out of order channel setup
720 * radioInterface: Fix multi-channel buffer index bug
721 * uhd: Add command line option for GPS reference
722 * transceiver: Fix mixed GSMK / 8-PSK transmission
723 * transceiver: Fix 4 SPS receive TOA value
724 * sigproc: Fix missing 8-PSK tail symbols
725 * uhd: Update USRP2/N200/N210 for 4 SPS Rx
726 * sigproc: Match differential GMSK start/end bits to tail bits
727 * uhd: Add missing B200 sample timing for 4 SPS receive
728 * transceiver: Fix command build warning
729 * uhd: Set minimum supported version to 3.9.0
730 * uhd: Add X300 sample timing for 4 SPS
731 * Revert "uhd: Set minimum supported version to 3.9.0"
732 * uhd: Add support for UHD-3.11 logging control
733 * uhd: Increase MC-BTS FPGA clock rate to 51.2 MHz
734 * Resampler: Fix initialization return checking
735 * sigProcLib: Remove unreachable code and no-effect checks
736 * sigProcLib: Check return status on downsampling
737 * sigProcLib: Fix negative value check on unsigned value
738 * Resampler: Fix non-array delete for filter taps
739 * Transceiver: Remove unsigned negative compares
740 * Configuration: Fix const and signedness compile warnings
741 * config: Remove OpenBTS style sqlite configuration
742 * radioInterface: Remove UmTRX 'diversity' option
743 * build: Require and check for gcc C++11 support
744 * uhd: Use map container for for device parameter access
745 * sigProcLib: Remove unused functions from public interface
746 * uhd: Add non-UmTRX channel swap support
747 * uhd: Fix Tx-RX timing offset setting
748 * uhd: Fix USRP2/N200/N210 device detection
749 * transceiver: Fix POWEROFF crash on USRP2/N200/X300 devices
750 * sigProcLib: Fix complex/real vector flag in Laurent modulator
751 * sigProcLib: Remove heap based signal vector allocations
752 * common: Declare explicit Vector move constructor
753 * sigProcLib: Remove trigonometric tables
754 * sigProcLib: Use explicit NaN check in sinc table generation
755 * sigProcLib: Replace dynamically allocated resampling buffers
756 * sigProcLib: Specify standard namespace for isnan()
757 * uhd: Always specify samples-per-symbol for device lookup
758 * LimeSDR: set approximate tx offset value to make GSM work
759
760 [ Neels Hofmeyr ]
761 * add basic .gitignore
762 * configure.ac: check for boost/config.hpp header
763 * The INSTALL file is being overwritten by autoreconf, but it is committed as empty file. As a result, the INSTALL file always shows as modified. Instead, remove INSTALL from git and ignore it.
764 * add contrib/jenkins.sh, for gerrit build bot
765
766 [ pierre.baudry ]
767 * transceiver: Fix mismatched allocations and deallocations
768
769 [ Holger Hans Peter Freyther ]
770 * debian: Require fftw3 header files for osmo-trx
771
772 [ Max ]
773 * Add gerrit settings
774 * Integrate Debian packaging changes
775 * Remove embedded sqlite3
776 * Fix building against sqlite3
777 * Add autoconf-archive to dependencies
778 * debian: remove obsolete dependency
779 * deb: remove unused dependency
780 * Remove redundant explicit dependency
781 * Use release helper from libosmocore
782
783 [ Ruben Undheim ]
784 * Do not embed sqlite3 when building
785
786 [ Philipp Maier ]
787 * buildenv: Turn off native architecture builds
788 * cosmetic: Make parameter lists uniform
789 * Add test program to verify convolution implementation
790 * ssedetect: Add runtime CPU detection
791 * cosmetic: remove code duplication
792 * buildenv: Make build CPU invariant
793 * buildenv: Split up SSE3 and SSE4.1 code
794 * cosmetic: Add info about SSE support
795
796 [ Vadim Yanitskiy ]
797 * buildenv: correct the ax_sse macro description
798 * buildenv: actually strip unused cpuid functionality
799 * buildenv: fix build on systems without SIMD support
800 * buildenv: cosmetic changes
801 * buildenv: check for __builtin_cpu_supports call support
802 * ssedetect: call __builtin_cpu_supports() only if supported
803
804 [ Pau Espin Pedrol ]
805 * cosmetic: transciever: Remove trailing whitespaces
806 * transceiver: Avoid sending clock indications when trx is not powered on
807 * Add -j option to bind to specific address
808
809 [ ignasj ]
810 * LimeSDR: Change device detection to work with USB and PCIe versions
811 * LimeSDR: change tx window type to TX_WINDOW_FIXED
812 * LimeSDR: Fix sample value range
813
814 [ Harald Welte ]
815 * Add '-t' command line option to enable SCHED_RR
816 * Import git-version-gen and update AC_INIT()
817
818 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 17:52:32 +0200
819
Holger Hans Peter Freytherd17b1892016-03-18 20:13:23 +0100820osmo-trx (0.1.9) trusty; urgency=medium
821
822 * Ask Ivan, really
823
824 -- Kirill Zakharenko <earwin@gmail.com> Thu, 16 Jul 2015 12:13:46 +0000
825
826osmo-trx (0.1.8) precise; urgency=low
827
828 * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP
829
830 -- Ivan Klyuchnikov <Ivan.Kluchnikov@fairwaves.ru> Sun, 9 Mar 2014 14:10:10 +0400