blob: 668c77f8c630250a8c759dad8709b4fb16870ac0 [file] [log] [blame]
Pau Espin Pedrolcfef3682022-06-28 18:50:25 +02001osmo-mgw (1.10.0) unstable; urgency=medium
2
3 [ Eric ]
4 * adjust mgcp response context
5 * rework message handling
6 * add a lock-free bounded spsc interthread queue
7 * clang-format: remove foreach macros
8 * fix mgcp_conn_free_all ubsan complaints
9
10 [ Philipp Maier ]
11 * configuration: point out difference between trunk-nr and e1 line nr
12 * mgcp_client: add new codec IUFP as VND.3GPP.IUFP
13 * mgcp_codec: do not differentiate between oa and bwe when comparing codec
14 * mgcp_network: do not try to convert RTCP packets
15 * mgcp_network: fix typo RTPC -> RTCP
16
17 [ Oliver Smith ]
18 * treewide: remove FSF address
19
20 [ Pau Espin Pedrol ]
21 * mgcp_network.c: Set proper CRC Header for ACK Initialization
22 * cosmetic: Rename variable payload=>payload_type
23 * mgcp_network.c: Fix byte alignment of CRC Header for ACK Initialization
24 * Define mgcp_rtp_end.output_enabled as bool
25 * cosmetic: mgcp_codec.c: Fix typo in comment
26 * Drop unneeded ax_check_compile_flag.m4
27 * Make function amr_is_octet_aligned publicly available
28 * Initial IuUP support using proper FSMs
29 * IuUP: Support RFCI ID != RFCI Index
30 * iuup: Fix caps in logging message
31 * iuup: Check for IuUP Initialization retrans
32
33 [ Alexander Couzens ]
34 * doc/overview: fix wrong project page link
35
36 [ Vadim Yanitskiy ]
37 * tests: use 'check_PROGRAMS' instead of 'noinst_PROGRAMS'
38 * libosmo-mgcp: e1: fix memleaks in e1_recv_cb()
39
40 [ Harald Welte ]
41 * update git URLs (git -> https; gitea)
42
43 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 28 Jun 2022 18:50:25 +0200
44
Pau Espin Pedrol58dc88b2021-11-16 16:59:21 +010045osmo-mgw (1.9.0) unstable; urgency=medium
46
47 [ Harald Welte ]
48 * TOS bits != DSCP
49 * manual: don't define fig-bsc twice
50 * switch from osmo_sock_set_dscp() to OSMO_SOCK_F_DSCP()
51 * mgw: Add support for setting socket priority from VTY
52 * manual: Include QoS chapter and add osmo-mgw specific example
53
54 [ Keith ]
55 * Add vty command 'show mgcp active'
56 * Log some useful messages at ERROR/INFO instead of DEBUG
57
58 [ Neels Hofmeyr ]
59 * send DLCX only once
60 * tweak termination DLCX log msg
61 * add osmo_mgcpc_ep_ci_get_remote_rtp_info()
62 * check_rtp_destin(): clarify log msg
63 * mgcp_client_fsm delete: set mgcp_client as ctx, not NULL
64 * mgcp_client_endpoint_fsm: on term, still let conns wait for DLCX OK
65 * mgcp_client_fsm: add missing log_subsys
66 * mgcp_client: add logging on received MGCP messages
67
68 [ Philipp Maier ]
69 * mgcp_network: fix implicit address loopback
70 * mgcp_common, mgcp_udp_send: make parameter buf const
71 * mgcp_network: refactor MGCP_DUMMY_LOAD
72 * mgcp_client: drop nunnecessary else statement
73 * mgcp_client: fix error handling in mgcp message generation
74 * mgcp_protocol: fix loop that sends dummy RTP packets
75 * mgw_main: fix loop that resets all endpoints
76 * mgcp_trunk: drop ws line
77 * mgcp_ratectr: drop ws line
78 * mgcp_ratectr: fix sourcecode formatting
79 * mgcp_trunk: add value string for trunk type.
80 * mgcp_ratectr: refactor rate counter and set group name
81 * mgcp_protocol: forward declare mgcp_endpoint
82 * mgcp_endp: make wildcarded detection separate
83 * mgcp_protocol: refactor request handler array
84 * mgcp_trunk: use unsigned int instead of int as trunk_nr
85 * mgcp_protocol: refactor MGCP request handling
86 * mgcp_ratectr: add stats items to monitor trunk usage
87 * mgcp_msg: add trunk parameter to mgcp_check_param for logging
88 * mgcp_protocol: refactor function create_response_with_sdp
89 * mgcp_protocol: add support for wildcarded DLCX
90 * remove struct member wildcarded_req from struct mgcp_endpoint
91 * mgcp_lient: remove unsubstantial FIXME note
92 * mgcp_protocol: assert endp when it becomes mandatory
93 * mgcp_trunk: check MGW domain name earlier
94 * mgcp_ratectr: add stats items to monitor trunk usage
95 * mgcp_client: fix typo Initalize -> Initialize
96 * mgcp_protocol: get rid of policy_cb and change_cb
97 * mgcp_ratectr: do not set talloc destructor on library allocated item
98 * mgcp_client: allow to reset endpoints on startup
99 * mgcp_client_vty: remove unnecessary checks
100 * mgcp_client: do not print (null) when address is ANY
101 * mgcp_client: refactor function init_socket
102 * libosmo-mgcp-client: extend the mgcp_client for MGW pooling
103 * mgcp_client_vty: add missing docstrings
104 * mgcp_client_vty: add OSMO_ASSERT on pool parameter
105 * mgcp_client_vty: fix docstrings for mgw-pool
106 * mgcp_client_vty: cosmetic: doc string should terminated with \n
107 * mgcp_client_vty: fixing docstring
108 * mgcp_ratectr: remove unusued rate counters
109 * mgcp_client: fix typo in doxygen comment
110 * mgcp_client: add MGW name as logging context
111
112 [ Pau Espin Pedrol ]
113 * Use new stat item/ctr getter APIs
114 * constify arg in addr_is_any()
115 * Define patch_ssrc as bool type
116 * constify some function arg pointers
117 * mgcp_network.c: Reorder some functions in file
118 * mgcp_send_dummy: Check RTP destination is available before attempt tx
119 * mgw: rx CRCX: Avoid sending dummy rtp if remote address not provided
120 * Fail rx MDCX sendrecv with invalid remote addr
121 * Take into account Marker bit when patching RTP stream
122 * Use DLMGCP instead of DLGLOBAL in log lines
123 * Fix attribute parsing on gcc 11.1.0
124
125 [ neels ]
126 * Revert "mgcp_ratectr: add stats items to monitor trunk usage"
127
128 [ Daniel Willmann ]
129 * contrib/jenkins: Use ASAN for osmo-mgw
130
131 [ Oliver Smith ]
132 * mgcp_client_vty: add missing NO_STR
133 * Revert "Turn some compiler warnings into errors"
134
135 [ Eric ]
136 * add vscode stuff to gitignore
137 * configure.ac: fix maybe-uninitialized for clang
138 * fix missing includes and forward declarations
139 * rename do_retransmission
140 * mgcp_sdp: fix potential leak
141 * stats: make sanitizers happy
142 * libosmo-mgcp: cleanup audio codex alloc
143 * libosmo-mgcp: atomic rate counter group indexes
144 * libosmo-mgcp: do not use the default msgb talloc context
145 * globally lock the portrange when trying to grab a port to prep for multithreading
146 * embed strings into structs
147 * adjust talloc context
148 * endp: do not cache cfg pointer
149 * add modified .clang-format
150 * rename strip_epname and find_specific_endpoint and make them available
151 * fix mgcp_conn_free_all
152 * fix up some docstrings that lost their dot
153
154 [ Vadim Yanitskiy ]
155 * libosmo-mgcp: use OSMO_STRLCPY_ARRAY in mgcp_codec_add()
156
157 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 16 Nov 2021 16:59:21 +0100
158
Harald Welte9ffaba72021-02-24 10:56:17 +0100159osmo-mgw (1.8.1) unstable; urgency=medium
160
161 * attempt to fix RPM spec file after recent soversion bump
162
163 -- Harald Welte <laforge@osmocom.org> Wed, 24 Feb 2021 10:56:17 +0100
164
Pau Espin Pedrol6ccdaa22021-02-23 18:28:45 +0100165osmo-mgw (1.8.0) unstable; urgency=medium
166
167 [ Harald Welte ]
168 * Fix number of endpoints of default trunk
169 * Add CTRL interface to osmo-mgw
170 * Update per-trunk global packet/byte counters in real-time
171 * remove accidential TODO-RELEASE entry
172 * mgcp_protocol: Avoid code duplication between virtual + other trunks
173 * osmo-mgw.spec.in: Use %config(noreplace) to retain current config file
174 * mgcp_client_init(): consider "talloc returns NULL" case
175 * mgcp_client_pending_add(): Consider "talloc returns NULL" case
176 * libosmo-mgcp-client: fix memleak in case if no response is received
177 * debian/control + SPEC: Add missing build dependency to libosmo-abis
178 * osmo-mgw.spec.in: Fix dependency to libosmoabis
179 * osmo-mgw.spec.in: Add missing dependency to libosmotrau
180 * Add example osmo-mgw configuration file for Abis/E1
181 * use osmo_fd_setup() whenever applicable
182
183 [ Neels Hofmeyr ]
184 * fix vty dump_trunk: start from zero, do not omit first CONN
185 * allow larger MGCP client wqueue: 10 -> 1024
186 * add osmo-mgw --vty-ref-xml: dump VTY ref XML to stdout
187 * manuals: generate vty reference xml at build time
188 * refactor: use msgb to receive, pass and send RTP packets
189 * change timer T2427001 to X2427
190
191 [ Philipp Maier ]
192 * doc: do not bind osmo-mgw to random ip-address
193 * cosmetic: remove excess newlines
194 * mgcp: remove unused callback pointer
195 * mgcp: find better locations for LOGPCONN and LOGPENDP
196 * vty: fix unreachable code (error msg on trunk alloc fail)
197 * mgcp_vty: fix indentation
198 * osmo-mgw: rename struct mgcp_trunk_config and symbol tcfg
199 * mgcp_vty: fix indentation in VTY config write
200 * osmo-mgw: refactor endpoint and trunk handling
201 * mgcp_trunk: remove audio_name and audio_payload
202 * ratectr: move rate counter definitions into mgcp_ratectr.h
203 * cosmetic: fix doxygen
204 * cosmetic: fix doxygen
205 * cosmetic: fix doxygen for mgcp_cleanup_rtp_bridge_cb()
206 * trunk: get rid of virt_trunk pointer
207 * cosmetic: remove excess space
208 * endp: move endpoint name generation into mgcp_endp.c
209 * endp: add name generator function for E1 endpoints
210 * mgcp_client: add docstring for mgcp_client_rtpbridge_wildcard()
211 * mgcp_trunk: fix docstring for mgcp_trunk_alloc()
212 * mgcp_osmux: remove unused define constants
213 * mgcp_trunk: move enum mgcp_trunk_type to mgcp_trunk.h
214 * mgcp_trunk: use enum type for trunk type variable
215 * trunk: parse E1 trunk number
216 * endp: add typeset for e1-endpoints
217 * mgcp_conn: move struct mgcp_conn mgcp_conn.h
218 * mgcp_internal: remove forward declaration struct mgcp_endpoint_type
219 * endp: add E1 endpoint interlocking
220 * endp: require domain name also for E1 endpoints
221 * mgcp_trunk: pick trunk by number and type
222 * mgcp_client: add function to generate e1-endpoint names
223 * mgcp_endp: use define constant to define max number of E1 subslots
224 * mgcp_endp.c: cosmetic: fix sourcecode formatting
225 * mgcp_trunk: remove double check
226 * mgcp_test: do not access endpoint array elements directly
227 * mgcp_vty: fix endpoint number configuration
228 * mgcp_test: remove trunk2 from unit-test
229 * mgcp_trunk: use talloc_zero_array instead of _talloc_zero_array
230 * mgcp_protocol: remove unused variable
231 * mgcp_e1: finish E1 support, add E1 support from libosmoabis
232 * get rid of mgcp_internal.h
233 * mgcp_ratectr: fix comments in header file
234 * mgcp_e1: use return value of e1inp_line_update()
235 * mgcp_protocol: log when endpoint is unavailable
236 * cosmetic: add missing new-line
237 * mgcp_trunk: drop "trunk 0" limitation
238 * mgcp_e1: make E1 ts initalization more debugable
239 * mgcp_e1: remove unused struct member trunk->e1.line
240 * mgcp_endp: use NUM_E1_TS from e1_input.h
241 * mgcp_trunk: increase default number of virtual endpoints
242 * cosmetic: mgcp_client_fsm: change error message.
243 * mgcp_vty: remove remains of loopback functionality
244 * mgcp_vty: deprecate bind early command
245 * mgcp_e1: do not expose function mgcp_e1_init()
246 * mgcp_vty: add user attributes to configuration commands
247 * overview: update section limitations.
248 * overview: fix graph "OsmoMGW used with OsmoBSC"
249 * overview: fix graph "OsmoMGW used with OsmoMSC"
250 * overview: add graph to show E1 integration
251 * configuration: remove hint towards trunk 0 limit
252 * configuration: drop note about lackin E1 support
253 * configuration: add note that changes to trunks need a restart
254 * mgcp_vty: fix config write for trunk 0
255 * mgcp_vty: add missing VTY commands for E1 trunks
256 * mgcp_trunk: get rid of magic numbers for E1 slots
257 * configuration: add section about E1 trunks
258 * usermanual: add chapter about mgcp endpoints
259 * mgcp_client: get rid of magic numbers for E1 slots
260
261 [ Eric ]
262 * tests: dlopen does not imply availability of dlsym..
263 * configure.ac: fix libtool issue with clang and sanitizer
264
265 [ Alexander Chemeris ]
266 * vty: Prepend VTY output of counters for better visual separation.
267 * counters: Implement more useful counters.
268 * mgcp_network: Fix a typo in the comment bahviour -> behaviour
269 * rtp_bridge: Demote a chatty ERROR log message to DEBUG level.
270
271 [ Pau Espin Pedrol ]
272 * Use OSMO_FD_* instead of deprecated BSC_FD_*
273 * Support setting rt-prio and cpu-affinity mask through VTY
274 * cosmetic: Rename main talloc ctx
275 * mgcp-client: Support IPv6 in osmo_mgcpc_ep_ci_get_crcx_info_to_sockaddr() implementation
276 * mgcp-client: Fix trailing whitespace in mgcp_client_fsm.h
277 * mgcp_client: Use INET6_ADDRSTRLEN to store addresses in str format
278 * mgcp_client: Allow submitting and parsing IPv6 addr in SDP
279 * mgcp_client: Allow setting IPv6 addresses
280 * mgcp_client: Make MGCP_CLIENT_LOCAL_ADDR_DEFAULT IPv6 compatible
281 * mgcp_client: Support validating IPv6 addresses in CRCX and MDCX commands
282 * mgcp_client: Deprecate unused IPv4-only API
283 * mgcp_client: copy back Connection Information from MDCX ACK
284 * mgw: Fix mgcp_rtp_end field description comment
285 * mgw: Initial IPv6 support
286 * mgw: Introduce VTY cmd 'rtp bind-ip-v6' command
287 * mgw: Find and store RTP conn local_addr once during CRCX handling
288 * mgw: Announce and rebind new local address if change required during MDCX
289 * mgw: osmux: Avoid sending packets on recvonly connection
290 * mgw: Release endpoint after last conn times out
291 * mgw: osmux: Fix conn watchdog timeout not updated
292 * mgw: Don't be case-sensitive when parsing X-Osmo-IGN param
293 * cosmetic: Fix typo in comment
294 * mgw: Avoid logging notice message each time we receive nt param in LCO
295 * mgw: Fix return value documentation for API mgcp_verify_call_id
296 * cosmetic: Fix typo in comment
297 * contrib/jenkins: Enable parallel make in make distcheck
298 * .gitignore: Ignore new autofoo tmp files
299 * tests: Replace deprecated API log_set_print_filename
300
301 [ Oliver Smith ]
302 * contrib: import RPM spec
303 * contrib: integrate RPM spec
304 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
305 * contrib/jenkins: don't build osmo-gsm-manuals
306 * configure.ac: set -std=gnu11
307
308 [ Vadim Yanitskiy ]
309 * libosmo-mgcp-client: fix use-after-free in mgcp_client_tx()
310 * libosmo-mgcp-client: fix use-after-free in mgcp_msg_gen()
311 * libosmo-mgcp: fix unsigned compared against 0 in mgcp_trunk_by_name()
312 * libosmo-mgcp: fix unused extra argument to printf() in add_fmtp()
313 * libosmo-mgcp: always check result of msgb_printf() in add_fmtp()
314 * libosmo-mgcp-client: mgcp_client_tx(): return rc on error
315 * debian/control: change maintainer to the Osmocom team / mailing list
316 * vty: use install_lib_element() and install_lib_element_ve()
317 * main: add --vty-ref-mode, use vty_dump_xml_ref_mode()
318 * fixup mgcp_trunk: increase default number of virtual endpoints
319
320 [ Alexander Couzens ]
321 * configure.ac: require libosmoabis + libosmotrau >= 1.0.0
322
323 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 23 Feb 2021 18:28:45 +0100
324
Pau Espin Pedrolec450682020-01-03 13:35:10 +0100325osmo-mgw (1.7.0) unstable; urgency=medium
326
327 [ Neels Hofmeyr ]
328 * rename codecs_cmp() to codecs_same()
329 * mgcp_codec: constify 'param' arg
330 * fix crashes: don't assert on incoming RTP packet size
331 * mgcp_send(): stop looping on conversion error
332 * mgcp_codec: split codec_free() off of codec_init()
333 * fix memleak: actually free strings in mgcp_codec_reset_all()
334 * mgcp_test: extend / rewrite test_mgcp_codec_pt_translate()
335 * test_mgcp_codec_pt_translate(): more tests
336 * differentiate AMR octet-aligned=0 vs =1
337 * ptmap: implicitly match '/8000' and '/8000/1'
338 * mgcp_codec: codec_set(): log about all possible errors
339 * mgcp_codec_add: fix audio_name size check
340 * explicitly free codecs in mgcp_rtp_conn_cleanup()
341 * tweak mgcp_parse_audio_ptime_rtpmap()
342 * SDP: store all ptmap entries
343 * mgcp_client_fsm cleanup: Do not assert on DLCX failure
344 * clear pending requests on MGCP failure
345 * client: endp fsm: add notify struct, prep for cancel-notify
346 * client: endp fsm: clear ci[] before dispatching DLCX success
347 * client: endp fsm: allow cancelling a notify event
348 * client: endp fsm: add osmo_mgcpc_ep_ci_ep()
349 * accept MGCP without SDP
350 * fix use-after-free: require new fsm deferred dealloc, check for term
351
352 [ Pau Espin Pedrol ]
353 * mgcp_test: Correctly release all endpoints allocated
354 * mgw: Allocate mgcp_conn instance under tcfg->endpoints
355
356 [ Harald Welte ]
357 * manual: Fix copy+paste error
358 * mgcp_client: Check for osmo_fsm_register() error return value
359 * Move fsm_mgcp_client regstration to __attribute__((contructor))
360 * exit(2) on unsupported positional arguments on command line
361
362 [ Oliver Smith ]
363 * osmoappdesc.py: switch to python 3
364
365 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 13:35:09 +0100
366
Pau Espin Pedrol50e52e42019-08-07 16:52:58 +0200367osmo-mgw (1.6.0) unstable; urgency=medium
368
369 [ Oliver Smith ]
370 * Cosmetic: fix spaces/tabs in mgcp_requests[]
371 * Inactive connection cleanup (disabled by default)
372 * debian: create -doc subpackage with pdf manuals
373 * vty: allow 0 as conn-timeout to disable it
374 * vty: update desc of conn-timeout
375 * manuals: update VTY documentation
376 * "make dist" fix for: no rule to make mgcp_common.h
377 * contrib/jenkins.sh: run "make maintainer-clean"
378
379 [ Philipp Maier ]
380 * Add option to GSM HR frames to RFC5593 representation
381 * mgcp_sdp: cosmetic: correct typo in comment
382 * mgco_client: cosmetic: remove excess whitespace
383 * mgcp_sdp: mgcp_sdp.c does not include own header file
384 * mgcp_sdp: untangle parsing of a= parameters
385 * mgcp_network: use mgcp_rtp_codec in downlink format callback
386 * AMR: Add function to convert between bw-effient and octet aligned mode
387
388 [ Neels Hofmeyr ]
389 * log: don't spam with "can not patch PT" messages
390 * mgcp client: allow setting conn mode for CRCX and MDCX
391 * make codec_table public as osmo_mgcpc_codec_names
392 * move MGW endpoint FSM from osmo-bsc to here
393 * fix: multiple initial CRCX
394 * constify map_codec_to_pt() ptmap arg
395
396 [ Pau Espin Pedrol ]
397 * mgcp-client: whitespace cleanup in mgcp_client.c
398 * mgcp-client: Sanitize implementation of mgcp_client_rtpbridge_wildcard
399 * libosmo-mgcp: Use trunk type during endpoint allocation
400 * cosmetic: Fix typos in comment
401 * cosmetic: tests: mgcp_client_test: clean trailing whitespace
402 * mgcp_msg: Log faulty line on Osmux parsing error
403 * cosmetic: handle_modify_con: Fix indentation level
404 * Introduce log fmt helpers LOGPENDP and LOGPCONN
405 * create_response_with_sdp: Fix inclusion of X-Osmux
406 * osmux: Cleanup of CID alloc pool APIs
407 * mgcp_osmux.c: osmux_enable_endpoint: Fix incorrect return check
408 * osmux: Log osmux socket during osmux_init
409 * mgcp-cli: Change osmo_mgcpc_ep_fsm name to avoid collision with old osmo-bsc
410 * osmux: Document func and return different rc upon osmux init failure
411 * osmux: Fix reception of legacy dummy payloads
412 * osmux: Use LOGPCONN in several log calls
413 * cosmetic: mgcp_udp_send: Document port param is in network byte order
414 * cosmetic: osmux: Document network byte order in port variable
415 * vty: Allow enabling Osmux
416 * osmux: Allocate CID during CRCX
417 * osmux: Introduce mgcp_conn_rtp_is_osmux() helper
418 * osmux: Mark conn_rtp->type as osmux during CRCX
419 * mgcp-cli: Allow submitting X-Osmux on CRCX request
420 * mgcp-cli: Parse X-Osmux on CRCX response
421 * osmux: Handle Osmux MGCP extension in MDCX messages
422 * mgcp-cli: Allow submitting X-Osmux on MDCX request
423 * mgcp-cli: Parse X-Osmux on MDCX response
424 * osmux: Drop unneeded OSMUX_STATE_NEGOTIATING
425 * mgcp-cli: endpoint_fsm: Add API to retrieve Osmux CID from MGW
426 * osmux: Provide correct local port during mgcp resp
427 * osmux: Use remote port to send osmux frames
428 * osmux: Improve logging around osmux enabling events
429 * osmux: Delay osmux enable of conn until remote addr is configured by MDCX
430 * osmux: Redo read/write osmux glue code to have data routed correctly
431 * mgw, mgcp-li: Handle X-Osmux param name as case insensitive
432 * osmux: Use DUMMY ft msg as per Osmux spec
433 * osmux: Fix loopback for Osmux connections
434 * osmux: Fix CID release for non-enabled connections
435 * osmux: Fix hardcoded rtp payload_type 98 in osmux conn
436 * mgcp-cli: Validate osmux cid value during mgcp_msg_gen
437 * mgw: Support uppercase LCO options
438 * mgw: Support lowercase header parameters
439 * mgcp-cli: Support lowercase header parameters
440 * mgw: Support receiving uppercase connection mode
441 * mgw: Support receiving lowercase LCO codec
442 * mgw: Make check of duplicated LCO fields case insensitive
443 * mgw: Allow receiving lowercase MGCP header keyword
444 * mgw: Allow receiving lowercase X-Osmo-Ign Callid field
445 * mgw: Allow receiving uppercase noanswer keyword
446 * doc: X-Osmo-IGN: small formatting and typo fixes
447 * doc: Add Osmux documentation to OsmoMGW User Manual
448 * Catch unsigned integer MGCP parsing errors with strtoul
449 * Fix return variable of strtoul()
450 * Remove undefined param passed to {logging,osmo_stats}_vty_add_cmds
451 * configure.ac: Require libosmo-netif 0.6.0
452
453 [ Alexander Couzens ]
454 * mgcp_internal: LOGPENDP: ensure *endp is not NULL
455
456 [ Harald Welte ]
457 * handle NULL return of rate_ctr_group_alloc()
458 * update .gitignore
459 * mgcp_sdp: Don't check if an unsigned int is below 0
460
461 [ Vadim Yanitskiy ]
462 * configure.ac: drop useless check for -fvisibility=hidden
463
464 [ Daniel Willmann ]
465 * manuals: Add script to regenerate vty/counter documentation
466 * manuals: Update vty/counter documentation
467
468 [ Hoernchen ]
469 * turn -Werror=null-dereference into a warning
470
471 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 16:52:58 +0200
472
Harald Weltee81c1172019-01-20 15:02:19 +0100473osmo-mgw (1.5.0) unstable; urgency=medium
474
475 [ Pau Espin Pedrol ]
476 * gitignore: Filter *.pc
477 * configure: Find correct libgsm's gsm.h header
478 * vty: Fix typo writing bts-jitter-buffer-delay-{min,max}
479 * Remove libosmo-legacy-mgcp and osmo-bsc-mgcp
480 * debian: Remove dangling symlink to osmo-bsc-mgcp.service
481 * Install systemd services with autotools
482 * Install sample cfg file to /etc/osmocom
483 * mgcp: Fix osmux_cid_bitmap static array size calculation
484 * mgcp_osmux: Use define to calculate rtp_ssrc_winlen
485 * osmux: Avoid initing output without enabling osmux
486 * mgcp: Log endpoint nr consistently as hex
487 * osmux_send_dummy: Avoid logging incorrectly and sending if osmux not enabled
488 * osmux: Don't process regular osmux frames if disabled by cfg
489 * osmux: Move parse_cid of legacy dummy frames to own function
490 * osmux: Make func handling dummy frames independent of endp type
491 * osmux: allow enabling osmux only on correct activating state
492 * osmux: Improve checks around activating and using enabled osmux
493 * osmux.h: Document enum osmux_state
494 * osmux: Avoid processing further frames if conn not found
495
496 [ Philipp Maier ]
497 * mgcp_client_fsm: allow ptmap in mgcp_client_fsm as well
498 * mgcp_network: translate payload type numbers in RTP packets
499 * mgcp_client: use IETF source port as for MGCP
500 * mgcp_client: increment local port number when port is in use
501 * mgcp_test: release endpoints after use
502 * network: do not patch PT of RTCP packets
503 * network: check packets before further processing
504 * Cosmetic: remove misplaced line break
505 * mgcp_sdp: restructure mgcp_write_response_sdp() (rtpmap)
506 * mgcp_sdp: restructure mgcp_write_response_sdp() (audio)
507 * mgcp_client: check local port only once
508 * mgcp_client_fsm: switch to MGCP_CONN_RECV_SEND in add_audio()
509 * mgcp_protocol: increase buffer space for codec name in LCO
510 * osmo-mgw: Add vty reference manual
511
512 [ Neels Hofmeyr ]
513 * fix handling of "Wrong domain name" error
514 * interpret domain '*' as 'allow any domain'
515 * cosmetic: log: fix "CallIDs does not match"
516 * fix 3G hack: allow any IP for loopback and 0.0.0.0
517 * cosmetic: drop code dup in mgcp_client_fsm.c CRCX
518 * add X-Osmo-IGN MGCP header to ignore CallID
519 * X-Osmo-IGN: rather parse items by token, not char
520 * mgcp_test: fix log of conn_id presence
521 * mgcp_test: fix get_conn_id_from_response() CI length
522 * mgcp_client_test: cosmetically re-arrange reply_to() args
523 * mgcp_client_test: use "\r\n\r\n" instead of "\n\n"
524 * mgcp_client_test: also verify received conn_id
525 * mgcp_client_test: test long conn_id
526 * mgcp_client: error on too long conn id
527 * mgcp_common: rename to MGCP_CONN_ID_MAXLEN
528 * doc: fix mgcp_verify_ci() return val doc
529 * mgcp_verify_ci(): return meaningful error codes
530 * fix mgcp_verify_ci(): off-by-one in max len check
531 * generate shorter 'I:' conn IDs
532 * mgcp_conn_get(): compare conn Id ('I:') case insensitively
533 * mgcp_conn_get(): match conn Id ('I:') despite leading zeros
534 * cosmetic: mgcp_test: fix get_conn_id_from_response()
535 * comment: indicate struct type for mgcp_endpoint.conns
536 * log: avoid logging early media as error
537 * fix osmo-mgw -s; fixes osmo-mgw.service using -s
538 * Importing history from osmo-gsm-manuals.git
539 * OsmoMGW: update VTY reference
540 * OsmoMGW: document the 'X-Osmo-IGN' MGCP extension
541 * mgw: update vty reference
542 * drop/replace very weird logging in mgcp_client.c
543 * check_rtp: on IP:port errors, log the IP and port
544 * osmo-mgw: err-log: include expected domain name
545 * mgcp_client_vty: fix missing talloc_free
546 * mgcp_client: drop a bunch of dead code
547 * mgcp_client: logging tweaks
548 * mgcp_client: make domain part of endpoint configurable
549 * mgcp_client: tweak some log levels INFO -> {DEBUG,ERROR}
550
551 [ Stefan Sperling ]
552 * add VTY commands which show specific mgcp endpoints
553 * add MGCP CRCX command statistics to osmo-mgw
554 * show RTP TX/RX stats in 'mgcp show stats' output
555 * use local variable for rate counters in handle_create_con()
556 * add more mgcp crxc error counters
557 * add MDCX command statistics to osmo-mgw
558 * add aggregated rtp connection stats to osmo-mgw
559 * add DLCX command statistics to osmo-mgw
560
561 [ Harald Welte ]
562 * debian/rules: Don't overwrite .tarball-version
563 * check_rtp_origin(): Don't memcmp sockadd_in and in_addr
564 * check_rtp_origin(): Avoid using memcmp for comparing integer types
565 * vty-ref: Update URI of docbook 5.0 schema
566
567 [ Daniel Willmann ]
568 * mgw: Add new VTY reference
569 * Add initial OsmoMGW manual
570
571 [ Oliver Smith ]
572 * build manuals moved here from osmo-gsm-manuals.git
573 * jenkins.sh: remove leftover MGCP env variable
574 * Fix DISTCHECK_CONFIGURE_FLAGS override
575 * contrib/jenkins.sh: build and publish manuals
576 * contrib: fix makedistcheck with disabled systemd
577
578 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 15:02:18 +0100
579
Pau Espin Pedrol304b3eb2018-07-27 19:05:23 +0200580osmo-mgw (1.4.0) unstable; urgency=medium
581
582 [ Philipp Maier ]
583 * network: independently initalize state->out_stream
584 * stats: use libosmocore rate counter for in/out_stream.err_ts_counter
585 * mgcp_sdp: correct apidoc of mgcp_parse_sdp_data
586 * vty: clean up rtp port-range command
587 * sdp: remove unused alt_codec field from struct mgcp_rtp_end
588 * sdp: remove circular inclusion
589 * protocol: Try whole port range on port allocation
590 * client: do not start connections in loopback mode
591 * mgcp_network: do not log destination invalid ip/port as error
592 * cosmetic: fix log output
593 * conn: call talloc_free before setting the pointer to NULL
594 * protocol: do not change LCO, when no LCO are present
595 * protocol: reject illegal lco options
596 * cosmetic: fix typo
597 * mgw: clean up codec negotiation (sdp)
598 * client: add features to generate and parse codec information
599 * mgcp_internal: remove unused struct member
600 * stats: replace packet statistic counters with libosmocore rate counters
601 * stat+vty: fix printing of rate counter values
602 * protocol: prevent unnecessary null pointer deref
603
604 [ Pau Espin Pedrol ]
605 * legacy-mgcp: Add jitter buffer on the uplink receiver
606 * legacy-mgcp: switch to new osmux output APIs
607 * mgcp: mgcp_osmux: use conn_bts when forwarding pkts from bsc_nat
608 * mgcp: switch to new osmux output APIs
609 * debian: Package installed example doc files
610 * gitignore: Add m4 scripts from m4 subdir
611
612 [ Neels Hofmeyr ]
613 * api doc: fix parameter name for mgcp_conn_create()
614 * mgcp-client: add mgcp_conn_get_ci()
615 * mgcp_client_fsm: improve error logging
616 * cosmetic: fix doxygen comment markers
617 * cosmetic: mgcp_network.c: merge one LOGPC to its preceding LOGP
618 * IuUP hack: make RTP patching less general
619
620 [ Harald Welte ]
621 * cosmetic: fix typo in log message: 'abrupt' instead of 'aprupt'
622
623 [ Daniel Willmann ]
624 * git-version-gen: Don't check for .git directory
625
626 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 27 Jul 2018 19:05:22 +0200
627
Pau Espin Pedrold761d352018-05-03 17:40:35 +0200628osmo-mgw (1.3.0) unstable; urgency=medium
629
630 [ Pau Espin Pedrol ]
631 * contrib: Add osmo-mgw systemd service
632 * legacy: mgcp_protocol: Don't print osmux stats if it is off
633 * mgcp_stat: Don't print osmux stats if it is off
634
635 [ Neels Hofmeyr ]
636 * fix segfault: DLCX for unknown endpoint: dont try to log NULL endpoint
637 * MGCP endpoints: parse as decimal, not hex
638 * add --enable-sanitize config option
639 * legacy_mgcp: mgcp_test: sanitize: free msgb_ctx
640 * mgcp_test: test_packet_error_detection: sanitize: free all conns
641 * mgcp_test: test_no_cycle: sanitize: free endp
642 * mgcp_test: sanitize: free msgb_ctx
643 * mgcp_client: don't configure "bts base"
644 * Revert "mgcp_client: don't configure "bts base"" until osmo-msc is ready
645 * mgcp_client: add transaction cleanup
646 * mgcp_client_test makefile: add update_exp target
647 * cosmetic: mgcp_network: typo in log
648 * osmo-mgw: Add talloc context introspection via VTY
649 * mgcp_client: show failure by MGCP SDP section parsing test
650 * mgcp_client: cosmetic: clean up SDP params parsing
651 * mgcp_client: detect SDP section-start parsing errors
652 * compiler warning: ignore deprecated in mgcp_client_test.c
653 * configure: add --enable-werror
654 * jenkins.sh: add --enable-werror to configure flags
655 * cosmetic: mgcp, legacy_mgcp: drop unused vty.h definitions
656 * use osmo_init_logging2() with proper talloc ctx
657
658 [ Philipp Maier ]
659 * osmux: fix nullpointer dereference
660 * cosmetic: guard dead osmux vty code with ifdef
661 * cosmetic: remove prefix "net" from rtp related vty commands
662 * doc: update sample config file
663 * cosmetic: use correct VTY port number constant
664 * vty: simplify endpoint allocation
665 * vty: do not change number_endpoints at runtime
666 * MGCP: Connection Identifiers are hex strings
667 * libosmo-mgcp: Connection Identifiers are allocated by MGW, not CA
668 * client: use osmo_strlcpy instead of strncpy
669 * cosmetic: fix sourcecode formatting
670 * cosmetic: clearly mark endpoint numbers as hex
671 * client: use string as connection identifier
672 * conn: remove assertions
673 * mgcp_test: fix wrong strcmp() parameters
674 * mgcp_test: fix nullpointer dereference
675 * mgcp_test: add returncode check
676 * mgcp_test: fix possible double free
677 * mcgp_client: mgcp_msg_gen(): add checks to verify params
678 * network: use originating RTP packet address for loopback
679 * client: mgcp_response_parse_params: check rtp port
680 * mgcp: allow endpoints beginning from zero
681 * client/common: move constant MGCP_ENDPOINT_MAXLEN
682 * mgcp: make domain name configurable
683 * cosmetic: protocol: remove unnecessary nul termination
684 * client: do not insist on \n\n when parsing MGCP messages
685 * main: display mgcp ip/port
686 * client: make callid in MDCX mandatory
687 * client: add missing mandatory SDP fields
688 * mgcp: permit wildcarded endpoint assignment (CRCX)
689 * mgcp: add prefix to virtual trunk
690 * client: eliminate destructive parameter parsing
691 * client: eliminate destructive head parsing
692 * cosmetic: client: add doxygen comments
693 * protocol: fix problem with line break and OSMUX
694 * protocol: fix missing carriage return
695 * client: fix sdp parameter ordering
696 * protocol: check the packetization in local cx options
697 * cosmetic: remove spaces from pointer symbol
698 * client: Do not accept endpoint ids with wildcards in responses
699 * client: do not accept endpoint ids without @ character in responses
700 * client: prohibit endpoint ids without @ character
701 * protocol: on wildcarded CRCX return endpoint number as hex
702 * msg: fix response code on exhausted endp resources
703 * cosmetic: move mgcp_release_endp() to mgcp_ep.c
704 * client: use heap to store mgcp_response
705 * ep: move endpoint struct and define to mgcp_ep.h
706 * cosmetic: rename mgcp_release_endp to mgcp_endp_release
707 * cosmetic: rename mgcp_ep.c/h to mgcp_endp.c/h
708 * protocol: reject DLCX/CRCX/MDCX on unsupported parameters
709 * protocol: exit cleanly when local cx options check fails
710 * cosmetic: Add missing \n on log line
711 * protocol: check requested connection mode
712 * protocol: fix tagging of wildcarded requests
713 * protocol: prohibit wildcarded requests for MDCX and DLCX
714 * mgcp: fix use-after-free and add callback for endpoint cleanup
715 * client: add an optional FSM interface
716 * mgcp_client_fsm: Add FSM event names
717 * cosmetic: mgcp_client_fsm: rename enums
718 * cosmetic: rename function .._conn_reset() to .._conn_init()
719 * mgcp_conn: do not touch u.rtp in mgcp_conn_alloc()
720 * cosmetic: rename .._codec_reset() to .._codec_init()
721 * mgcp_conn: add function mgcp_rtp_conn_cleanup()
722 * stats: use libosmocore rate counter for in/out_stream.err_ts_counter
723
724 [ Alexander Couzens ]
725 * debian/control: correct library dependency of osmo-mgw against libosmo-mgcp1
726 * debian: include systemd service osmo-mgw.service
727 * Revert "stats: use libosmocore rate counter for in/out_stream.err_ts_counter"
728
729 [ Harald Welte ]
730 * cosmetic: fix whitespaces; we use tabs for indentation
731 * Fix possible buffer overflow in mgcp_conn_dump()
732 * osmo-mgw: Update copyright statement
733 * osmo-mgw: Config file is osmo-mgw.cfg, and not mgcp.cfg
734 * osmo-mgw: Fix copyright notice
735 * strct mgcp_rtp_state: Group + document struct members related to patching
736 * mgcp_rtp_state: grup 'stats' members into sub-structure
737 * mgcp_rtp_end: Group statistics members into 'stats' sub-struct
738 * libosmo-mgcp: Cosmetic spelling fixes in comments
739 * mgcp_msg: We must parse endpoint numbers as hex, not decimal!
740 * mgcp_internal.h: document more struct members with comments
741 * centralize handling of common errors like "endpoint not found"
742 * Return proper MGCP Error codes, as per spec
743 * osmo-mgw: Use libosmocore socket abstraction
744 * osmo-bsc_mgcp: Add LIBOSMONETIF_{CFLAGS,LIBS}
745 * libosmo-mgcp-client is GPLv2+, not AGPLv3+
746 * Turn libosmo-mgcp into local, non-installed library
747
748 [ Stefan Sperling ]
749 * enable osmo_fsm vty commands in libosmo-mgcp-client vty
750
751 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 17:40:35 +0200
752
Harald Weltee7d27ae2017-11-10 11:21:40 +0900753osmo-mgw (1.2.0) unstable; urgency=medium
754
755 [ Neels Hofmeyr ]
756 * jenkins: use osmo-clean-workspace.sh before and after build
757 * vty: skip installing cmds now always installed by default
758 * mgcp-client vty: use name 'mgw' instead of 'mgcpgw'
759 * mgcp client: vty: tweak doc strings
760
761 [ Philipp Maier ]
762 * sdp: refactoring sdp parser/generator
763 * cosmetic: rename bts_codec to codec_str
764 * cosmetic: fix coding style for mgcp_parse_sdp_data()
765 * cosmetic: fix commenting style
766 * cosmetic: correct whitespaces
767 * client: fix stderror logging in unit-test
768 * client: add unified function to generate MGCP messages
769 * client: add ip address parsing to the client
770 * protocol: allow wildcarded DLCX
771 * mgcp: remove port/timeslot calculator functions from mgcp.h
772 * network: add separate log category
773 * cosmetic: make dummy packet handling more explicit
774 * network: autdetect rtp bind ip-address
775 * network: fix rtp packet length
776 * network: remove unused return code
777
778 [ Pau Espin Pedrol ]
779 * mgcp_client_vty.c: Fix VTY compatibility with 'mgcpgw bts-base'
780
781 -- Harald Welte <laforge@gnumonks.org> Fri, 10 Nov 2017 11:10:23 +0900
782
Harald Welte1ae2d5e2017-10-28 12:48:42 +0200783osmo-mgw (1.1.0) unstable; urgency=medium
784
785 * New upstream release
786
787 -- Harald Welte <lafore@gnumonks.org> Sat, 28 Oct 2017 12:48:41 +0200
788
Maxf19acc92017-09-14 18:35:06 +0200789osmo-mgw (1.0.2) unstable; urgency=low
790
791 * First release after major rename.
792
793 -- Max Suraev <msuraev@sysmocom.de> Thu, 14 Sep 2017 18:41:05 +0200
794
795
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000796osmo-mgw (0.1.0) unstable; urgency=low
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200797
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000798 * Initial release.
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200799
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000800 -- Alexander Couzens <lynxis@fe80.eu> Tue, 08 Aug 2017 01:12:53 +0000