blob: 9f04449a311f3dd26f432df51afbf2589fb7dcbc [file] [log] [blame]
Pau Espin Pedrol6ccdaa22021-02-23 18:28:45 +01001osmo-mgw (1.8.0) unstable; urgency=medium
2
3 [ Harald Welte ]
4 * Fix number of endpoints of default trunk
5 * Add CTRL interface to osmo-mgw
6 * Update per-trunk global packet/byte counters in real-time
7 * remove accidential TODO-RELEASE entry
8 * mgcp_protocol: Avoid code duplication between virtual + other trunks
9 * osmo-mgw.spec.in: Use %config(noreplace) to retain current config file
10 * mgcp_client_init(): consider "talloc returns NULL" case
11 * mgcp_client_pending_add(): Consider "talloc returns NULL" case
12 * libosmo-mgcp-client: fix memleak in case if no response is received
13 * debian/control + SPEC: Add missing build dependency to libosmo-abis
14 * osmo-mgw.spec.in: Fix dependency to libosmoabis
15 * osmo-mgw.spec.in: Add missing dependency to libosmotrau
16 * Add example osmo-mgw configuration file for Abis/E1
17 * use osmo_fd_setup() whenever applicable
18
19 [ Neels Hofmeyr ]
20 * fix vty dump_trunk: start from zero, do not omit first CONN
21 * allow larger MGCP client wqueue: 10 -> 1024
22 * add osmo-mgw --vty-ref-xml: dump VTY ref XML to stdout
23 * manuals: generate vty reference xml at build time
24 * refactor: use msgb to receive, pass and send RTP packets
25 * change timer T2427001 to X2427
26
27 [ Philipp Maier ]
28 * doc: do not bind osmo-mgw to random ip-address
29 * cosmetic: remove excess newlines
30 * mgcp: remove unused callback pointer
31 * mgcp: find better locations for LOGPCONN and LOGPENDP
32 * vty: fix unreachable code (error msg on trunk alloc fail)
33 * mgcp_vty: fix indentation
34 * osmo-mgw: rename struct mgcp_trunk_config and symbol tcfg
35 * mgcp_vty: fix indentation in VTY config write
36 * osmo-mgw: refactor endpoint and trunk handling
37 * mgcp_trunk: remove audio_name and audio_payload
38 * ratectr: move rate counter definitions into mgcp_ratectr.h
39 * cosmetic: fix doxygen
40 * cosmetic: fix doxygen
41 * cosmetic: fix doxygen for mgcp_cleanup_rtp_bridge_cb()
42 * trunk: get rid of virt_trunk pointer
43 * cosmetic: remove excess space
44 * endp: move endpoint name generation into mgcp_endp.c
45 * endp: add name generator function for E1 endpoints
46 * mgcp_client: add docstring for mgcp_client_rtpbridge_wildcard()
47 * mgcp_trunk: fix docstring for mgcp_trunk_alloc()
48 * mgcp_osmux: remove unused define constants
49 * mgcp_trunk: move enum mgcp_trunk_type to mgcp_trunk.h
50 * mgcp_trunk: use enum type for trunk type variable
51 * trunk: parse E1 trunk number
52 * endp: add typeset for e1-endpoints
53 * mgcp_conn: move struct mgcp_conn mgcp_conn.h
54 * mgcp_internal: remove forward declaration struct mgcp_endpoint_type
55 * endp: add E1 endpoint interlocking
56 * endp: require domain name also for E1 endpoints
57 * mgcp_trunk: pick trunk by number and type
58 * mgcp_client: add function to generate e1-endpoint names
59 * mgcp_endp: use define constant to define max number of E1 subslots
60 * mgcp_endp.c: cosmetic: fix sourcecode formatting
61 * mgcp_trunk: remove double check
62 * mgcp_test: do not access endpoint array elements directly
63 * mgcp_vty: fix endpoint number configuration
64 * mgcp_test: remove trunk2 from unit-test
65 * mgcp_trunk: use talloc_zero_array instead of _talloc_zero_array
66 * mgcp_protocol: remove unused variable
67 * mgcp_e1: finish E1 support, add E1 support from libosmoabis
68 * get rid of mgcp_internal.h
69 * mgcp_ratectr: fix comments in header file
70 * mgcp_e1: use return value of e1inp_line_update()
71 * mgcp_protocol: log when endpoint is unavailable
72 * cosmetic: add missing new-line
73 * mgcp_trunk: drop "trunk 0" limitation
74 * mgcp_e1: make E1 ts initalization more debugable
75 * mgcp_e1: remove unused struct member trunk->e1.line
76 * mgcp_endp: use NUM_E1_TS from e1_input.h
77 * mgcp_trunk: increase default number of virtual endpoints
78 * cosmetic: mgcp_client_fsm: change error message.
79 * mgcp_vty: remove remains of loopback functionality
80 * mgcp_vty: deprecate bind early command
81 * mgcp_e1: do not expose function mgcp_e1_init()
82 * mgcp_vty: add user attributes to configuration commands
83 * overview: update section limitations.
84 * overview: fix graph "OsmoMGW used with OsmoBSC"
85 * overview: fix graph "OsmoMGW used with OsmoMSC"
86 * overview: add graph to show E1 integration
87 * configuration: remove hint towards trunk 0 limit
88 * configuration: drop note about lackin E1 support
89 * configuration: add note that changes to trunks need a restart
90 * mgcp_vty: fix config write for trunk 0
91 * mgcp_vty: add missing VTY commands for E1 trunks
92 * mgcp_trunk: get rid of magic numbers for E1 slots
93 * configuration: add section about E1 trunks
94 * usermanual: add chapter about mgcp endpoints
95 * mgcp_client: get rid of magic numbers for E1 slots
96
97 [ Eric ]
98 * tests: dlopen does not imply availability of dlsym..
99 * configure.ac: fix libtool issue with clang and sanitizer
100
101 [ Alexander Chemeris ]
102 * vty: Prepend VTY output of counters for better visual separation.
103 * counters: Implement more useful counters.
104 * mgcp_network: Fix a typo in the comment bahviour -> behaviour
105 * rtp_bridge: Demote a chatty ERROR log message to DEBUG level.
106
107 [ Pau Espin Pedrol ]
108 * Use OSMO_FD_* instead of deprecated BSC_FD_*
109 * Support setting rt-prio and cpu-affinity mask through VTY
110 * cosmetic: Rename main talloc ctx
111 * mgcp-client: Support IPv6 in osmo_mgcpc_ep_ci_get_crcx_info_to_sockaddr() implementation
112 * mgcp-client: Fix trailing whitespace in mgcp_client_fsm.h
113 * mgcp_client: Use INET6_ADDRSTRLEN to store addresses in str format
114 * mgcp_client: Allow submitting and parsing IPv6 addr in SDP
115 * mgcp_client: Allow setting IPv6 addresses
116 * mgcp_client: Make MGCP_CLIENT_LOCAL_ADDR_DEFAULT IPv6 compatible
117 * mgcp_client: Support validating IPv6 addresses in CRCX and MDCX commands
118 * mgcp_client: Deprecate unused IPv4-only API
119 * mgcp_client: copy back Connection Information from MDCX ACK
120 * mgw: Fix mgcp_rtp_end field description comment
121 * mgw: Initial IPv6 support
122 * mgw: Introduce VTY cmd 'rtp bind-ip-v6' command
123 * mgw: Find and store RTP conn local_addr once during CRCX handling
124 * mgw: Announce and rebind new local address if change required during MDCX
125 * mgw: osmux: Avoid sending packets on recvonly connection
126 * mgw: Release endpoint after last conn times out
127 * mgw: osmux: Fix conn watchdog timeout not updated
128 * mgw: Don't be case-sensitive when parsing X-Osmo-IGN param
129 * cosmetic: Fix typo in comment
130 * mgw: Avoid logging notice message each time we receive nt param in LCO
131 * mgw: Fix return value documentation for API mgcp_verify_call_id
132 * cosmetic: Fix typo in comment
133 * contrib/jenkins: Enable parallel make in make distcheck
134 * .gitignore: Ignore new autofoo tmp files
135 * tests: Replace deprecated API log_set_print_filename
136
137 [ Oliver Smith ]
138 * contrib: import RPM spec
139 * contrib: integrate RPM spec
140 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
141 * contrib/jenkins: don't build osmo-gsm-manuals
142 * configure.ac: set -std=gnu11
143
144 [ Vadim Yanitskiy ]
145 * libosmo-mgcp-client: fix use-after-free in mgcp_client_tx()
146 * libosmo-mgcp-client: fix use-after-free in mgcp_msg_gen()
147 * libosmo-mgcp: fix unsigned compared against 0 in mgcp_trunk_by_name()
148 * libosmo-mgcp: fix unused extra argument to printf() in add_fmtp()
149 * libosmo-mgcp: always check result of msgb_printf() in add_fmtp()
150 * libosmo-mgcp-client: mgcp_client_tx(): return rc on error
151 * debian/control: change maintainer to the Osmocom team / mailing list
152 * vty: use install_lib_element() and install_lib_element_ve()
153 * main: add --vty-ref-mode, use vty_dump_xml_ref_mode()
154 * fixup mgcp_trunk: increase default number of virtual endpoints
155
156 [ Alexander Couzens ]
157 * configure.ac: require libosmoabis + libosmotrau >= 1.0.0
158
159 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 23 Feb 2021 18:28:45 +0100
160
Pau Espin Pedrolec450682020-01-03 13:35:10 +0100161osmo-mgw (1.7.0) unstable; urgency=medium
162
163 [ Neels Hofmeyr ]
164 * rename codecs_cmp() to codecs_same()
165 * mgcp_codec: constify 'param' arg
166 * fix crashes: don't assert on incoming RTP packet size
167 * mgcp_send(): stop looping on conversion error
168 * mgcp_codec: split codec_free() off of codec_init()
169 * fix memleak: actually free strings in mgcp_codec_reset_all()
170 * mgcp_test: extend / rewrite test_mgcp_codec_pt_translate()
171 * test_mgcp_codec_pt_translate(): more tests
172 * differentiate AMR octet-aligned=0 vs =1
173 * ptmap: implicitly match '/8000' and '/8000/1'
174 * mgcp_codec: codec_set(): log about all possible errors
175 * mgcp_codec_add: fix audio_name size check
176 * explicitly free codecs in mgcp_rtp_conn_cleanup()
177 * tweak mgcp_parse_audio_ptime_rtpmap()
178 * SDP: store all ptmap entries
179 * mgcp_client_fsm cleanup: Do not assert on DLCX failure
180 * clear pending requests on MGCP failure
181 * client: endp fsm: add notify struct, prep for cancel-notify
182 * client: endp fsm: clear ci[] before dispatching DLCX success
183 * client: endp fsm: allow cancelling a notify event
184 * client: endp fsm: add osmo_mgcpc_ep_ci_ep()
185 * accept MGCP without SDP
186 * fix use-after-free: require new fsm deferred dealloc, check for term
187
188 [ Pau Espin Pedrol ]
189 * mgcp_test: Correctly release all endpoints allocated
190 * mgw: Allocate mgcp_conn instance under tcfg->endpoints
191
192 [ Harald Welte ]
193 * manual: Fix copy+paste error
194 * mgcp_client: Check for osmo_fsm_register() error return value
195 * Move fsm_mgcp_client regstration to __attribute__((contructor))
196 * exit(2) on unsupported positional arguments on command line
197
198 [ Oliver Smith ]
199 * osmoappdesc.py: switch to python 3
200
201 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 13:35:09 +0100
202
Pau Espin Pedrol50e52e42019-08-07 16:52:58 +0200203osmo-mgw (1.6.0) unstable; urgency=medium
204
205 [ Oliver Smith ]
206 * Cosmetic: fix spaces/tabs in mgcp_requests[]
207 * Inactive connection cleanup (disabled by default)
208 * debian: create -doc subpackage with pdf manuals
209 * vty: allow 0 as conn-timeout to disable it
210 * vty: update desc of conn-timeout
211 * manuals: update VTY documentation
212 * "make dist" fix for: no rule to make mgcp_common.h
213 * contrib/jenkins.sh: run "make maintainer-clean"
214
215 [ Philipp Maier ]
216 * Add option to GSM HR frames to RFC5593 representation
217 * mgcp_sdp: cosmetic: correct typo in comment
218 * mgco_client: cosmetic: remove excess whitespace
219 * mgcp_sdp: mgcp_sdp.c does not include own header file
220 * mgcp_sdp: untangle parsing of a= parameters
221 * mgcp_network: use mgcp_rtp_codec in downlink format callback
222 * AMR: Add function to convert between bw-effient and octet aligned mode
223
224 [ Neels Hofmeyr ]
225 * log: don't spam with "can not patch PT" messages
226 * mgcp client: allow setting conn mode for CRCX and MDCX
227 * make codec_table public as osmo_mgcpc_codec_names
228 * move MGW endpoint FSM from osmo-bsc to here
229 * fix: multiple initial CRCX
230 * constify map_codec_to_pt() ptmap arg
231
232 [ Pau Espin Pedrol ]
233 * mgcp-client: whitespace cleanup in mgcp_client.c
234 * mgcp-client: Sanitize implementation of mgcp_client_rtpbridge_wildcard
235 * libosmo-mgcp: Use trunk type during endpoint allocation
236 * cosmetic: Fix typos in comment
237 * cosmetic: tests: mgcp_client_test: clean trailing whitespace
238 * mgcp_msg: Log faulty line on Osmux parsing error
239 * cosmetic: handle_modify_con: Fix indentation level
240 * Introduce log fmt helpers LOGPENDP and LOGPCONN
241 * create_response_with_sdp: Fix inclusion of X-Osmux
242 * osmux: Cleanup of CID alloc pool APIs
243 * mgcp_osmux.c: osmux_enable_endpoint: Fix incorrect return check
244 * osmux: Log osmux socket during osmux_init
245 * mgcp-cli: Change osmo_mgcpc_ep_fsm name to avoid collision with old osmo-bsc
246 * osmux: Document func and return different rc upon osmux init failure
247 * osmux: Fix reception of legacy dummy payloads
248 * osmux: Use LOGPCONN in several log calls
249 * cosmetic: mgcp_udp_send: Document port param is in network byte order
250 * cosmetic: osmux: Document network byte order in port variable
251 * vty: Allow enabling Osmux
252 * osmux: Allocate CID during CRCX
253 * osmux: Introduce mgcp_conn_rtp_is_osmux() helper
254 * osmux: Mark conn_rtp->type as osmux during CRCX
255 * mgcp-cli: Allow submitting X-Osmux on CRCX request
256 * mgcp-cli: Parse X-Osmux on CRCX response
257 * osmux: Handle Osmux MGCP extension in MDCX messages
258 * mgcp-cli: Allow submitting X-Osmux on MDCX request
259 * mgcp-cli: Parse X-Osmux on MDCX response
260 * osmux: Drop unneeded OSMUX_STATE_NEGOTIATING
261 * mgcp-cli: endpoint_fsm: Add API to retrieve Osmux CID from MGW
262 * osmux: Provide correct local port during mgcp resp
263 * osmux: Use remote port to send osmux frames
264 * osmux: Improve logging around osmux enabling events
265 * osmux: Delay osmux enable of conn until remote addr is configured by MDCX
266 * osmux: Redo read/write osmux glue code to have data routed correctly
267 * mgw, mgcp-li: Handle X-Osmux param name as case insensitive
268 * osmux: Use DUMMY ft msg as per Osmux spec
269 * osmux: Fix loopback for Osmux connections
270 * osmux: Fix CID release for non-enabled connections
271 * osmux: Fix hardcoded rtp payload_type 98 in osmux conn
272 * mgcp-cli: Validate osmux cid value during mgcp_msg_gen
273 * mgw: Support uppercase LCO options
274 * mgw: Support lowercase header parameters
275 * mgcp-cli: Support lowercase header parameters
276 * mgw: Support receiving uppercase connection mode
277 * mgw: Support receiving lowercase LCO codec
278 * mgw: Make check of duplicated LCO fields case insensitive
279 * mgw: Allow receiving lowercase MGCP header keyword
280 * mgw: Allow receiving lowercase X-Osmo-Ign Callid field
281 * mgw: Allow receiving uppercase noanswer keyword
282 * doc: X-Osmo-IGN: small formatting and typo fixes
283 * doc: Add Osmux documentation to OsmoMGW User Manual
284 * Catch unsigned integer MGCP parsing errors with strtoul
285 * Fix return variable of strtoul()
286 * Remove undefined param passed to {logging,osmo_stats}_vty_add_cmds
287 * configure.ac: Require libosmo-netif 0.6.0
288
289 [ Alexander Couzens ]
290 * mgcp_internal: LOGPENDP: ensure *endp is not NULL
291
292 [ Harald Welte ]
293 * handle NULL return of rate_ctr_group_alloc()
294 * update .gitignore
295 * mgcp_sdp: Don't check if an unsigned int is below 0
296
297 [ Vadim Yanitskiy ]
298 * configure.ac: drop useless check for -fvisibility=hidden
299
300 [ Daniel Willmann ]
301 * manuals: Add script to regenerate vty/counter documentation
302 * manuals: Update vty/counter documentation
303
304 [ Hoernchen ]
305 * turn -Werror=null-dereference into a warning
306
307 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 16:52:58 +0200
308
Harald Weltee81c1172019-01-20 15:02:19 +0100309osmo-mgw (1.5.0) unstable; urgency=medium
310
311 [ Pau Espin Pedrol ]
312 * gitignore: Filter *.pc
313 * configure: Find correct libgsm's gsm.h header
314 * vty: Fix typo writing bts-jitter-buffer-delay-{min,max}
315 * Remove libosmo-legacy-mgcp and osmo-bsc-mgcp
316 * debian: Remove dangling symlink to osmo-bsc-mgcp.service
317 * Install systemd services with autotools
318 * Install sample cfg file to /etc/osmocom
319 * mgcp: Fix osmux_cid_bitmap static array size calculation
320 * mgcp_osmux: Use define to calculate rtp_ssrc_winlen
321 * osmux: Avoid initing output without enabling osmux
322 * mgcp: Log endpoint nr consistently as hex
323 * osmux_send_dummy: Avoid logging incorrectly and sending if osmux not enabled
324 * osmux: Don't process regular osmux frames if disabled by cfg
325 * osmux: Move parse_cid of legacy dummy frames to own function
326 * osmux: Make func handling dummy frames independent of endp type
327 * osmux: allow enabling osmux only on correct activating state
328 * osmux: Improve checks around activating and using enabled osmux
329 * osmux.h: Document enum osmux_state
330 * osmux: Avoid processing further frames if conn not found
331
332 [ Philipp Maier ]
333 * mgcp_client_fsm: allow ptmap in mgcp_client_fsm as well
334 * mgcp_network: translate payload type numbers in RTP packets
335 * mgcp_client: use IETF source port as for MGCP
336 * mgcp_client: increment local port number when port is in use
337 * mgcp_test: release endpoints after use
338 * network: do not patch PT of RTCP packets
339 * network: check packets before further processing
340 * Cosmetic: remove misplaced line break
341 * mgcp_sdp: restructure mgcp_write_response_sdp() (rtpmap)
342 * mgcp_sdp: restructure mgcp_write_response_sdp() (audio)
343 * mgcp_client: check local port only once
344 * mgcp_client_fsm: switch to MGCP_CONN_RECV_SEND in add_audio()
345 * mgcp_protocol: increase buffer space for codec name in LCO
346 * osmo-mgw: Add vty reference manual
347
348 [ Neels Hofmeyr ]
349 * fix handling of "Wrong domain name" error
350 * interpret domain '*' as 'allow any domain'
351 * cosmetic: log: fix "CallIDs does not match"
352 * fix 3G hack: allow any IP for loopback and 0.0.0.0
353 * cosmetic: drop code dup in mgcp_client_fsm.c CRCX
354 * add X-Osmo-IGN MGCP header to ignore CallID
355 * X-Osmo-IGN: rather parse items by token, not char
356 * mgcp_test: fix log of conn_id presence
357 * mgcp_test: fix get_conn_id_from_response() CI length
358 * mgcp_client_test: cosmetically re-arrange reply_to() args
359 * mgcp_client_test: use "\r\n\r\n" instead of "\n\n"
360 * mgcp_client_test: also verify received conn_id
361 * mgcp_client_test: test long conn_id
362 * mgcp_client: error on too long conn id
363 * mgcp_common: rename to MGCP_CONN_ID_MAXLEN
364 * doc: fix mgcp_verify_ci() return val doc
365 * mgcp_verify_ci(): return meaningful error codes
366 * fix mgcp_verify_ci(): off-by-one in max len check
367 * generate shorter 'I:' conn IDs
368 * mgcp_conn_get(): compare conn Id ('I:') case insensitively
369 * mgcp_conn_get(): match conn Id ('I:') despite leading zeros
370 * cosmetic: mgcp_test: fix get_conn_id_from_response()
371 * comment: indicate struct type for mgcp_endpoint.conns
372 * log: avoid logging early media as error
373 * fix osmo-mgw -s; fixes osmo-mgw.service using -s
374 * Importing history from osmo-gsm-manuals.git
375 * OsmoMGW: update VTY reference
376 * OsmoMGW: document the 'X-Osmo-IGN' MGCP extension
377 * mgw: update vty reference
378 * drop/replace very weird logging in mgcp_client.c
379 * check_rtp: on IP:port errors, log the IP and port
380 * osmo-mgw: err-log: include expected domain name
381 * mgcp_client_vty: fix missing talloc_free
382 * mgcp_client: drop a bunch of dead code
383 * mgcp_client: logging tweaks
384 * mgcp_client: make domain part of endpoint configurable
385 * mgcp_client: tweak some log levels INFO -> {DEBUG,ERROR}
386
387 [ Stefan Sperling ]
388 * add VTY commands which show specific mgcp endpoints
389 * add MGCP CRCX command statistics to osmo-mgw
390 * show RTP TX/RX stats in 'mgcp show stats' output
391 * use local variable for rate counters in handle_create_con()
392 * add more mgcp crxc error counters
393 * add MDCX command statistics to osmo-mgw
394 * add aggregated rtp connection stats to osmo-mgw
395 * add DLCX command statistics to osmo-mgw
396
397 [ Harald Welte ]
398 * debian/rules: Don't overwrite .tarball-version
399 * check_rtp_origin(): Don't memcmp sockadd_in and in_addr
400 * check_rtp_origin(): Avoid using memcmp for comparing integer types
401 * vty-ref: Update URI of docbook 5.0 schema
402
403 [ Daniel Willmann ]
404 * mgw: Add new VTY reference
405 * Add initial OsmoMGW manual
406
407 [ Oliver Smith ]
408 * build manuals moved here from osmo-gsm-manuals.git
409 * jenkins.sh: remove leftover MGCP env variable
410 * Fix DISTCHECK_CONFIGURE_FLAGS override
411 * contrib/jenkins.sh: build and publish manuals
412 * contrib: fix makedistcheck with disabled systemd
413
414 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 15:02:18 +0100
415
Pau Espin Pedrol304b3eb2018-07-27 19:05:23 +0200416osmo-mgw (1.4.0) unstable; urgency=medium
417
418 [ Philipp Maier ]
419 * network: independently initalize state->out_stream
420 * stats: use libosmocore rate counter for in/out_stream.err_ts_counter
421 * mgcp_sdp: correct apidoc of mgcp_parse_sdp_data
422 * vty: clean up rtp port-range command
423 * sdp: remove unused alt_codec field from struct mgcp_rtp_end
424 * sdp: remove circular inclusion
425 * protocol: Try whole port range on port allocation
426 * client: do not start connections in loopback mode
427 * mgcp_network: do not log destination invalid ip/port as error
428 * cosmetic: fix log output
429 * conn: call talloc_free before setting the pointer to NULL
430 * protocol: do not change LCO, when no LCO are present
431 * protocol: reject illegal lco options
432 * cosmetic: fix typo
433 * mgw: clean up codec negotiation (sdp)
434 * client: add features to generate and parse codec information
435 * mgcp_internal: remove unused struct member
436 * stats: replace packet statistic counters with libosmocore rate counters
437 * stat+vty: fix printing of rate counter values
438 * protocol: prevent unnecessary null pointer deref
439
440 [ Pau Espin Pedrol ]
441 * legacy-mgcp: Add jitter buffer on the uplink receiver
442 * legacy-mgcp: switch to new osmux output APIs
443 * mgcp: mgcp_osmux: use conn_bts when forwarding pkts from bsc_nat
444 * mgcp: switch to new osmux output APIs
445 * debian: Package installed example doc files
446 * gitignore: Add m4 scripts from m4 subdir
447
448 [ Neels Hofmeyr ]
449 * api doc: fix parameter name for mgcp_conn_create()
450 * mgcp-client: add mgcp_conn_get_ci()
451 * mgcp_client_fsm: improve error logging
452 * cosmetic: fix doxygen comment markers
453 * cosmetic: mgcp_network.c: merge one LOGPC to its preceding LOGP
454 * IuUP hack: make RTP patching less general
455
456 [ Harald Welte ]
457 * cosmetic: fix typo in log message: 'abrupt' instead of 'aprupt'
458
459 [ Daniel Willmann ]
460 * git-version-gen: Don't check for .git directory
461
462 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 27 Jul 2018 19:05:22 +0200
463
Pau Espin Pedrold761d352018-05-03 17:40:35 +0200464osmo-mgw (1.3.0) unstable; urgency=medium
465
466 [ Pau Espin Pedrol ]
467 * contrib: Add osmo-mgw systemd service
468 * legacy: mgcp_protocol: Don't print osmux stats if it is off
469 * mgcp_stat: Don't print osmux stats if it is off
470
471 [ Neels Hofmeyr ]
472 * fix segfault: DLCX for unknown endpoint: dont try to log NULL endpoint
473 * MGCP endpoints: parse as decimal, not hex
474 * add --enable-sanitize config option
475 * legacy_mgcp: mgcp_test: sanitize: free msgb_ctx
476 * mgcp_test: test_packet_error_detection: sanitize: free all conns
477 * mgcp_test: test_no_cycle: sanitize: free endp
478 * mgcp_test: sanitize: free msgb_ctx
479 * mgcp_client: don't configure "bts base"
480 * Revert "mgcp_client: don't configure "bts base"" until osmo-msc is ready
481 * mgcp_client: add transaction cleanup
482 * mgcp_client_test makefile: add update_exp target
483 * cosmetic: mgcp_network: typo in log
484 * osmo-mgw: Add talloc context introspection via VTY
485 * mgcp_client: show failure by MGCP SDP section parsing test
486 * mgcp_client: cosmetic: clean up SDP params parsing
487 * mgcp_client: detect SDP section-start parsing errors
488 * compiler warning: ignore deprecated in mgcp_client_test.c
489 * configure: add --enable-werror
490 * jenkins.sh: add --enable-werror to configure flags
491 * cosmetic: mgcp, legacy_mgcp: drop unused vty.h definitions
492 * use osmo_init_logging2() with proper talloc ctx
493
494 [ Philipp Maier ]
495 * osmux: fix nullpointer dereference
496 * cosmetic: guard dead osmux vty code with ifdef
497 * cosmetic: remove prefix "net" from rtp related vty commands
498 * doc: update sample config file
499 * cosmetic: use correct VTY port number constant
500 * vty: simplify endpoint allocation
501 * vty: do not change number_endpoints at runtime
502 * MGCP: Connection Identifiers are hex strings
503 * libosmo-mgcp: Connection Identifiers are allocated by MGW, not CA
504 * client: use osmo_strlcpy instead of strncpy
505 * cosmetic: fix sourcecode formatting
506 * cosmetic: clearly mark endpoint numbers as hex
507 * client: use string as connection identifier
508 * conn: remove assertions
509 * mgcp_test: fix wrong strcmp() parameters
510 * mgcp_test: fix nullpointer dereference
511 * mgcp_test: add returncode check
512 * mgcp_test: fix possible double free
513 * mcgp_client: mgcp_msg_gen(): add checks to verify params
514 * network: use originating RTP packet address for loopback
515 * client: mgcp_response_parse_params: check rtp port
516 * mgcp: allow endpoints beginning from zero
517 * client/common: move constant MGCP_ENDPOINT_MAXLEN
518 * mgcp: make domain name configurable
519 * cosmetic: protocol: remove unnecessary nul termination
520 * client: do not insist on \n\n when parsing MGCP messages
521 * main: display mgcp ip/port
522 * client: make callid in MDCX mandatory
523 * client: add missing mandatory SDP fields
524 * mgcp: permit wildcarded endpoint assignment (CRCX)
525 * mgcp: add prefix to virtual trunk
526 * client: eliminate destructive parameter parsing
527 * client: eliminate destructive head parsing
528 * cosmetic: client: add doxygen comments
529 * protocol: fix problem with line break and OSMUX
530 * protocol: fix missing carriage return
531 * client: fix sdp parameter ordering
532 * protocol: check the packetization in local cx options
533 * cosmetic: remove spaces from pointer symbol
534 * client: Do not accept endpoint ids with wildcards in responses
535 * client: do not accept endpoint ids without @ character in responses
536 * client: prohibit endpoint ids without @ character
537 * protocol: on wildcarded CRCX return endpoint number as hex
538 * msg: fix response code on exhausted endp resources
539 * cosmetic: move mgcp_release_endp() to mgcp_ep.c
540 * client: use heap to store mgcp_response
541 * ep: move endpoint struct and define to mgcp_ep.h
542 * cosmetic: rename mgcp_release_endp to mgcp_endp_release
543 * cosmetic: rename mgcp_ep.c/h to mgcp_endp.c/h
544 * protocol: reject DLCX/CRCX/MDCX on unsupported parameters
545 * protocol: exit cleanly when local cx options check fails
546 * cosmetic: Add missing \n on log line
547 * protocol: check requested connection mode
548 * protocol: fix tagging of wildcarded requests
549 * protocol: prohibit wildcarded requests for MDCX and DLCX
550 * mgcp: fix use-after-free and add callback for endpoint cleanup
551 * client: add an optional FSM interface
552 * mgcp_client_fsm: Add FSM event names
553 * cosmetic: mgcp_client_fsm: rename enums
554 * cosmetic: rename function .._conn_reset() to .._conn_init()
555 * mgcp_conn: do not touch u.rtp in mgcp_conn_alloc()
556 * cosmetic: rename .._codec_reset() to .._codec_init()
557 * mgcp_conn: add function mgcp_rtp_conn_cleanup()
558 * stats: use libosmocore rate counter for in/out_stream.err_ts_counter
559
560 [ Alexander Couzens ]
561 * debian/control: correct library dependency of osmo-mgw against libosmo-mgcp1
562 * debian: include systemd service osmo-mgw.service
563 * Revert "stats: use libosmocore rate counter for in/out_stream.err_ts_counter"
564
565 [ Harald Welte ]
566 * cosmetic: fix whitespaces; we use tabs for indentation
567 * Fix possible buffer overflow in mgcp_conn_dump()
568 * osmo-mgw: Update copyright statement
569 * osmo-mgw: Config file is osmo-mgw.cfg, and not mgcp.cfg
570 * osmo-mgw: Fix copyright notice
571 * strct mgcp_rtp_state: Group + document struct members related to patching
572 * mgcp_rtp_state: grup 'stats' members into sub-structure
573 * mgcp_rtp_end: Group statistics members into 'stats' sub-struct
574 * libosmo-mgcp: Cosmetic spelling fixes in comments
575 * mgcp_msg: We must parse endpoint numbers as hex, not decimal!
576 * mgcp_internal.h: document more struct members with comments
577 * centralize handling of common errors like "endpoint not found"
578 * Return proper MGCP Error codes, as per spec
579 * osmo-mgw: Use libosmocore socket abstraction
580 * osmo-bsc_mgcp: Add LIBOSMONETIF_{CFLAGS,LIBS}
581 * libosmo-mgcp-client is GPLv2+, not AGPLv3+
582 * Turn libosmo-mgcp into local, non-installed library
583
584 [ Stefan Sperling ]
585 * enable osmo_fsm vty commands in libosmo-mgcp-client vty
586
587 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 17:40:35 +0200
588
Harald Weltee7d27ae2017-11-10 11:21:40 +0900589osmo-mgw (1.2.0) unstable; urgency=medium
590
591 [ Neels Hofmeyr ]
592 * jenkins: use osmo-clean-workspace.sh before and after build
593 * vty: skip installing cmds now always installed by default
594 * mgcp-client vty: use name 'mgw' instead of 'mgcpgw'
595 * mgcp client: vty: tweak doc strings
596
597 [ Philipp Maier ]
598 * sdp: refactoring sdp parser/generator
599 * cosmetic: rename bts_codec to codec_str
600 * cosmetic: fix coding style for mgcp_parse_sdp_data()
601 * cosmetic: fix commenting style
602 * cosmetic: correct whitespaces
603 * client: fix stderror logging in unit-test
604 * client: add unified function to generate MGCP messages
605 * client: add ip address parsing to the client
606 * protocol: allow wildcarded DLCX
607 * mgcp: remove port/timeslot calculator functions from mgcp.h
608 * network: add separate log category
609 * cosmetic: make dummy packet handling more explicit
610 * network: autdetect rtp bind ip-address
611 * network: fix rtp packet length
612 * network: remove unused return code
613
614 [ Pau Espin Pedrol ]
615 * mgcp_client_vty.c: Fix VTY compatibility with 'mgcpgw bts-base'
616
617 -- Harald Welte <laforge@gnumonks.org> Fri, 10 Nov 2017 11:10:23 +0900
618
Harald Welte1ae2d5e2017-10-28 12:48:42 +0200619osmo-mgw (1.1.0) unstable; urgency=medium
620
621 * New upstream release
622
623 -- Harald Welte <lafore@gnumonks.org> Sat, 28 Oct 2017 12:48:41 +0200
624
Maxf19acc92017-09-14 18:35:06 +0200625osmo-mgw (1.0.2) unstable; urgency=low
626
627 * First release after major rename.
628
629 -- Max Suraev <msuraev@sysmocom.de> Thu, 14 Sep 2017 18:41:05 +0200
630
631
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000632osmo-mgw (0.1.0) unstable; urgency=low
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200633
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000634 * Initial release.
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200635
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000636 -- Alexander Couzens <lynxis@fe80.eu> Tue, 08 Aug 2017 01:12:53 +0000