blob: c1708faaf5e8563a011c01a9b74d97f1ad362020 [file] [log] [blame]
Harald Weltee81c1172019-01-20 15:02:19 +01001osmo-mgw (1.5.0) unstable; urgency=medium
2
3 [ Pau Espin Pedrol ]
4 * gitignore: Filter *.pc
5 * configure: Find correct libgsm's gsm.h header
6 * vty: Fix typo writing bts-jitter-buffer-delay-{min,max}
7 * Remove libosmo-legacy-mgcp and osmo-bsc-mgcp
8 * debian: Remove dangling symlink to osmo-bsc-mgcp.service
9 * Install systemd services with autotools
10 * Install sample cfg file to /etc/osmocom
11 * mgcp: Fix osmux_cid_bitmap static array size calculation
12 * mgcp_osmux: Use define to calculate rtp_ssrc_winlen
13 * osmux: Avoid initing output without enabling osmux
14 * mgcp: Log endpoint nr consistently as hex
15 * osmux_send_dummy: Avoid logging incorrectly and sending if osmux not enabled
16 * osmux: Don't process regular osmux frames if disabled by cfg
17 * osmux: Move parse_cid of legacy dummy frames to own function
18 * osmux: Make func handling dummy frames independent of endp type
19 * osmux: allow enabling osmux only on correct activating state
20 * osmux: Improve checks around activating and using enabled osmux
21 * osmux.h: Document enum osmux_state
22 * osmux: Avoid processing further frames if conn not found
23
24 [ Philipp Maier ]
25 * mgcp_client_fsm: allow ptmap in mgcp_client_fsm as well
26 * mgcp_network: translate payload type numbers in RTP packets
27 * mgcp_client: use IETF source port as for MGCP
28 * mgcp_client: increment local port number when port is in use
29 * mgcp_test: release endpoints after use
30 * network: do not patch PT of RTCP packets
31 * network: check packets before further processing
32 * Cosmetic: remove misplaced line break
33 * mgcp_sdp: restructure mgcp_write_response_sdp() (rtpmap)
34 * mgcp_sdp: restructure mgcp_write_response_sdp() (audio)
35 * mgcp_client: check local port only once
36 * mgcp_client_fsm: switch to MGCP_CONN_RECV_SEND in add_audio()
37 * mgcp_protocol: increase buffer space for codec name in LCO
38 * osmo-mgw: Add vty reference manual
39
40 [ Neels Hofmeyr ]
41 * fix handling of "Wrong domain name" error
42 * interpret domain '*' as 'allow any domain'
43 * cosmetic: log: fix "CallIDs does not match"
44 * fix 3G hack: allow any IP for loopback and 0.0.0.0
45 * cosmetic: drop code dup in mgcp_client_fsm.c CRCX
46 * add X-Osmo-IGN MGCP header to ignore CallID
47 * X-Osmo-IGN: rather parse items by token, not char
48 * mgcp_test: fix log of conn_id presence
49 * mgcp_test: fix get_conn_id_from_response() CI length
50 * mgcp_client_test: cosmetically re-arrange reply_to() args
51 * mgcp_client_test: use "\r\n\r\n" instead of "\n\n"
52 * mgcp_client_test: also verify received conn_id
53 * mgcp_client_test: test long conn_id
54 * mgcp_client: error on too long conn id
55 * mgcp_common: rename to MGCP_CONN_ID_MAXLEN
56 * doc: fix mgcp_verify_ci() return val doc
57 * mgcp_verify_ci(): return meaningful error codes
58 * fix mgcp_verify_ci(): off-by-one in max len check
59 * generate shorter 'I:' conn IDs
60 * mgcp_conn_get(): compare conn Id ('I:') case insensitively
61 * mgcp_conn_get(): match conn Id ('I:') despite leading zeros
62 * cosmetic: mgcp_test: fix get_conn_id_from_response()
63 * comment: indicate struct type for mgcp_endpoint.conns
64 * log: avoid logging early media as error
65 * fix osmo-mgw -s; fixes osmo-mgw.service using -s
66 * Importing history from osmo-gsm-manuals.git
67 * OsmoMGW: update VTY reference
68 * OsmoMGW: document the 'X-Osmo-IGN' MGCP extension
69 * mgw: update vty reference
70 * drop/replace very weird logging in mgcp_client.c
71 * check_rtp: on IP:port errors, log the IP and port
72 * osmo-mgw: err-log: include expected domain name
73 * mgcp_client_vty: fix missing talloc_free
74 * mgcp_client: drop a bunch of dead code
75 * mgcp_client: logging tweaks
76 * mgcp_client: make domain part of endpoint configurable
77 * mgcp_client: tweak some log levels INFO -> {DEBUG,ERROR}
78
79 [ Stefan Sperling ]
80 * add VTY commands which show specific mgcp endpoints
81 * add MGCP CRCX command statistics to osmo-mgw
82 * show RTP TX/RX stats in 'mgcp show stats' output
83 * use local variable for rate counters in handle_create_con()
84 * add more mgcp crxc error counters
85 * add MDCX command statistics to osmo-mgw
86 * add aggregated rtp connection stats to osmo-mgw
87 * add DLCX command statistics to osmo-mgw
88
89 [ Harald Welte ]
90 * debian/rules: Don't overwrite .tarball-version
91 * check_rtp_origin(): Don't memcmp sockadd_in and in_addr
92 * check_rtp_origin(): Avoid using memcmp for comparing integer types
93 * vty-ref: Update URI of docbook 5.0 schema
94
95 [ Daniel Willmann ]
96 * mgw: Add new VTY reference
97 * Add initial OsmoMGW manual
98
99 [ Oliver Smith ]
100 * build manuals moved here from osmo-gsm-manuals.git
101 * jenkins.sh: remove leftover MGCP env variable
102 * Fix DISTCHECK_CONFIGURE_FLAGS override
103 * contrib/jenkins.sh: build and publish manuals
104 * contrib: fix makedistcheck with disabled systemd
105
106 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 15:02:18 +0100
107
Pau Espin Pedrol304b3eb2018-07-27 19:05:23 +0200108osmo-mgw (1.4.0) unstable; urgency=medium
109
110 [ Philipp Maier ]
111 * network: independently initalize state->out_stream
112 * stats: use libosmocore rate counter for in/out_stream.err_ts_counter
113 * mgcp_sdp: correct apidoc of mgcp_parse_sdp_data
114 * vty: clean up rtp port-range command
115 * sdp: remove unused alt_codec field from struct mgcp_rtp_end
116 * sdp: remove circular inclusion
117 * protocol: Try whole port range on port allocation
118 * client: do not start connections in loopback mode
119 * mgcp_network: do not log destination invalid ip/port as error
120 * cosmetic: fix log output
121 * conn: call talloc_free before setting the pointer to NULL
122 * protocol: do not change LCO, when no LCO are present
123 * protocol: reject illegal lco options
124 * cosmetic: fix typo
125 * mgw: clean up codec negotiation (sdp)
126 * client: add features to generate and parse codec information
127 * mgcp_internal: remove unused struct member
128 * stats: replace packet statistic counters with libosmocore rate counters
129 * stat+vty: fix printing of rate counter values
130 * protocol: prevent unnecessary null pointer deref
131
132 [ Pau Espin Pedrol ]
133 * legacy-mgcp: Add jitter buffer on the uplink receiver
134 * legacy-mgcp: switch to new osmux output APIs
135 * mgcp: mgcp_osmux: use conn_bts when forwarding pkts from bsc_nat
136 * mgcp: switch to new osmux output APIs
137 * debian: Package installed example doc files
138 * gitignore: Add m4 scripts from m4 subdir
139
140 [ Neels Hofmeyr ]
141 * api doc: fix parameter name for mgcp_conn_create()
142 * mgcp-client: add mgcp_conn_get_ci()
143 * mgcp_client_fsm: improve error logging
144 * cosmetic: fix doxygen comment markers
145 * cosmetic: mgcp_network.c: merge one LOGPC to its preceding LOGP
146 * IuUP hack: make RTP patching less general
147
148 [ Harald Welte ]
149 * cosmetic: fix typo in log message: 'abrupt' instead of 'aprupt'
150
151 [ Daniel Willmann ]
152 * git-version-gen: Don't check for .git directory
153
154 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 27 Jul 2018 19:05:22 +0200
155
Pau Espin Pedrold761d352018-05-03 17:40:35 +0200156osmo-mgw (1.3.0) unstable; urgency=medium
157
158 [ Pau Espin Pedrol ]
159 * contrib: Add osmo-mgw systemd service
160 * legacy: mgcp_protocol: Don't print osmux stats if it is off
161 * mgcp_stat: Don't print osmux stats if it is off
162
163 [ Neels Hofmeyr ]
164 * fix segfault: DLCX for unknown endpoint: dont try to log NULL endpoint
165 * MGCP endpoints: parse as decimal, not hex
166 * add --enable-sanitize config option
167 * legacy_mgcp: mgcp_test: sanitize: free msgb_ctx
168 * mgcp_test: test_packet_error_detection: sanitize: free all conns
169 * mgcp_test: test_no_cycle: sanitize: free endp
170 * mgcp_test: sanitize: free msgb_ctx
171 * mgcp_client: don't configure "bts base"
172 * Revert "mgcp_client: don't configure "bts base"" until osmo-msc is ready
173 * mgcp_client: add transaction cleanup
174 * mgcp_client_test makefile: add update_exp target
175 * cosmetic: mgcp_network: typo in log
176 * osmo-mgw: Add talloc context introspection via VTY
177 * mgcp_client: show failure by MGCP SDP section parsing test
178 * mgcp_client: cosmetic: clean up SDP params parsing
179 * mgcp_client: detect SDP section-start parsing errors
180 * compiler warning: ignore deprecated in mgcp_client_test.c
181 * configure: add --enable-werror
182 * jenkins.sh: add --enable-werror to configure flags
183 * cosmetic: mgcp, legacy_mgcp: drop unused vty.h definitions
184 * use osmo_init_logging2() with proper talloc ctx
185
186 [ Philipp Maier ]
187 * osmux: fix nullpointer dereference
188 * cosmetic: guard dead osmux vty code with ifdef
189 * cosmetic: remove prefix "net" from rtp related vty commands
190 * doc: update sample config file
191 * cosmetic: use correct VTY port number constant
192 * vty: simplify endpoint allocation
193 * vty: do not change number_endpoints at runtime
194 * MGCP: Connection Identifiers are hex strings
195 * libosmo-mgcp: Connection Identifiers are allocated by MGW, not CA
196 * client: use osmo_strlcpy instead of strncpy
197 * cosmetic: fix sourcecode formatting
198 * cosmetic: clearly mark endpoint numbers as hex
199 * client: use string as connection identifier
200 * conn: remove assertions
201 * mgcp_test: fix wrong strcmp() parameters
202 * mgcp_test: fix nullpointer dereference
203 * mgcp_test: add returncode check
204 * mgcp_test: fix possible double free
205 * mcgp_client: mgcp_msg_gen(): add checks to verify params
206 * network: use originating RTP packet address for loopback
207 * client: mgcp_response_parse_params: check rtp port
208 * mgcp: allow endpoints beginning from zero
209 * client/common: move constant MGCP_ENDPOINT_MAXLEN
210 * mgcp: make domain name configurable
211 * cosmetic: protocol: remove unnecessary nul termination
212 * client: do not insist on \n\n when parsing MGCP messages
213 * main: display mgcp ip/port
214 * client: make callid in MDCX mandatory
215 * client: add missing mandatory SDP fields
216 * mgcp: permit wildcarded endpoint assignment (CRCX)
217 * mgcp: add prefix to virtual trunk
218 * client: eliminate destructive parameter parsing
219 * client: eliminate destructive head parsing
220 * cosmetic: client: add doxygen comments
221 * protocol: fix problem with line break and OSMUX
222 * protocol: fix missing carriage return
223 * client: fix sdp parameter ordering
224 * protocol: check the packetization in local cx options
225 * cosmetic: remove spaces from pointer symbol
226 * client: Do not accept endpoint ids with wildcards in responses
227 * client: do not accept endpoint ids without @ character in responses
228 * client: prohibit endpoint ids without @ character
229 * protocol: on wildcarded CRCX return endpoint number as hex
230 * msg: fix response code on exhausted endp resources
231 * cosmetic: move mgcp_release_endp() to mgcp_ep.c
232 * client: use heap to store mgcp_response
233 * ep: move endpoint struct and define to mgcp_ep.h
234 * cosmetic: rename mgcp_release_endp to mgcp_endp_release
235 * cosmetic: rename mgcp_ep.c/h to mgcp_endp.c/h
236 * protocol: reject DLCX/CRCX/MDCX on unsupported parameters
237 * protocol: exit cleanly when local cx options check fails
238 * cosmetic: Add missing \n on log line
239 * protocol: check requested connection mode
240 * protocol: fix tagging of wildcarded requests
241 * protocol: prohibit wildcarded requests for MDCX and DLCX
242 * mgcp: fix use-after-free and add callback for endpoint cleanup
243 * client: add an optional FSM interface
244 * mgcp_client_fsm: Add FSM event names
245 * cosmetic: mgcp_client_fsm: rename enums
246 * cosmetic: rename function .._conn_reset() to .._conn_init()
247 * mgcp_conn: do not touch u.rtp in mgcp_conn_alloc()
248 * cosmetic: rename .._codec_reset() to .._codec_init()
249 * mgcp_conn: add function mgcp_rtp_conn_cleanup()
250 * stats: use libosmocore rate counter for in/out_stream.err_ts_counter
251
252 [ Alexander Couzens ]
253 * debian/control: correct library dependency of osmo-mgw against libosmo-mgcp1
254 * debian: include systemd service osmo-mgw.service
255 * Revert "stats: use libosmocore rate counter for in/out_stream.err_ts_counter"
256
257 [ Harald Welte ]
258 * cosmetic: fix whitespaces; we use tabs for indentation
259 * Fix possible buffer overflow in mgcp_conn_dump()
260 * osmo-mgw: Update copyright statement
261 * osmo-mgw: Config file is osmo-mgw.cfg, and not mgcp.cfg
262 * osmo-mgw: Fix copyright notice
263 * strct mgcp_rtp_state: Group + document struct members related to patching
264 * mgcp_rtp_state: grup 'stats' members into sub-structure
265 * mgcp_rtp_end: Group statistics members into 'stats' sub-struct
266 * libosmo-mgcp: Cosmetic spelling fixes in comments
267 * mgcp_msg: We must parse endpoint numbers as hex, not decimal!
268 * mgcp_internal.h: document more struct members with comments
269 * centralize handling of common errors like "endpoint not found"
270 * Return proper MGCP Error codes, as per spec
271 * osmo-mgw: Use libosmocore socket abstraction
272 * osmo-bsc_mgcp: Add LIBOSMONETIF_{CFLAGS,LIBS}
273 * libosmo-mgcp-client is GPLv2+, not AGPLv3+
274 * Turn libosmo-mgcp into local, non-installed library
275
276 [ Stefan Sperling ]
277 * enable osmo_fsm vty commands in libosmo-mgcp-client vty
278
279 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 17:40:35 +0200
280
Harald Weltee7d27ae2017-11-10 11:21:40 +0900281osmo-mgw (1.2.0) unstable; urgency=medium
282
283 [ Neels Hofmeyr ]
284 * jenkins: use osmo-clean-workspace.sh before and after build
285 * vty: skip installing cmds now always installed by default
286 * mgcp-client vty: use name 'mgw' instead of 'mgcpgw'
287 * mgcp client: vty: tweak doc strings
288
289 [ Philipp Maier ]
290 * sdp: refactoring sdp parser/generator
291 * cosmetic: rename bts_codec to codec_str
292 * cosmetic: fix coding style for mgcp_parse_sdp_data()
293 * cosmetic: fix commenting style
294 * cosmetic: correct whitespaces
295 * client: fix stderror logging in unit-test
296 * client: add unified function to generate MGCP messages
297 * client: add ip address parsing to the client
298 * protocol: allow wildcarded DLCX
299 * mgcp: remove port/timeslot calculator functions from mgcp.h
300 * network: add separate log category
301 * cosmetic: make dummy packet handling more explicit
302 * network: autdetect rtp bind ip-address
303 * network: fix rtp packet length
304 * network: remove unused return code
305
306 [ Pau Espin Pedrol ]
307 * mgcp_client_vty.c: Fix VTY compatibility with 'mgcpgw bts-base'
308
309 -- Harald Welte <laforge@gnumonks.org> Fri, 10 Nov 2017 11:10:23 +0900
310
Harald Welte1ae2d5e2017-10-28 12:48:42 +0200311osmo-mgw (1.1.0) unstable; urgency=medium
312
313 * New upstream release
314
315 -- Harald Welte <lafore@gnumonks.org> Sat, 28 Oct 2017 12:48:41 +0200
316
Maxf19acc92017-09-14 18:35:06 +0200317osmo-mgw (1.0.2) unstable; urgency=low
318
319 * First release after major rename.
320
321 -- Max Suraev <msuraev@sysmocom.de> Thu, 14 Sep 2017 18:41:05 +0200
322
323
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000324osmo-mgw (0.1.0) unstable; urgency=low
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200325
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000326 * Initial release.
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200327
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000328 -- Alexander Couzens <lynxis@fe80.eu> Tue, 08 Aug 2017 01:12:53 +0000