blob: e731351b298bc7c4f3dfb879e78e33cb56805adb [file] [log] [blame]
Pau Espin Pedrol304b3eb2018-07-27 19:05:23 +02001osmo-mgw (1.4.0) unstable; urgency=medium
2
3 [ Philipp Maier ]
4 * network: independently initalize state->out_stream
5 * stats: use libosmocore rate counter for in/out_stream.err_ts_counter
6 * mgcp_sdp: correct apidoc of mgcp_parse_sdp_data
7 * vty: clean up rtp port-range command
8 * sdp: remove unused alt_codec field from struct mgcp_rtp_end
9 * sdp: remove circular inclusion
10 * protocol: Try whole port range on port allocation
11 * client: do not start connections in loopback mode
12 * mgcp_network: do not log destination invalid ip/port as error
13 * cosmetic: fix log output
14 * conn: call talloc_free before setting the pointer to NULL
15 * protocol: do not change LCO, when no LCO are present
16 * protocol: reject illegal lco options
17 * cosmetic: fix typo
18 * mgw: clean up codec negotiation (sdp)
19 * client: add features to generate and parse codec information
20 * mgcp_internal: remove unused struct member
21 * stats: replace packet statistic counters with libosmocore rate counters
22 * stat+vty: fix printing of rate counter values
23 * protocol: prevent unnecessary null pointer deref
24
25 [ Pau Espin Pedrol ]
26 * legacy-mgcp: Add jitter buffer on the uplink receiver
27 * legacy-mgcp: switch to new osmux output APIs
28 * mgcp: mgcp_osmux: use conn_bts when forwarding pkts from bsc_nat
29 * mgcp: switch to new osmux output APIs
30 * debian: Package installed example doc files
31 * gitignore: Add m4 scripts from m4 subdir
32
33 [ Neels Hofmeyr ]
34 * api doc: fix parameter name for mgcp_conn_create()
35 * mgcp-client: add mgcp_conn_get_ci()
36 * mgcp_client_fsm: improve error logging
37 * cosmetic: fix doxygen comment markers
38 * cosmetic: mgcp_network.c: merge one LOGPC to its preceding LOGP
39 * IuUP hack: make RTP patching less general
40
41 [ Harald Welte ]
42 * cosmetic: fix typo in log message: 'abrupt' instead of 'aprupt'
43
44 [ Daniel Willmann ]
45 * git-version-gen: Don't check for .git directory
46
47 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 27 Jul 2018 19:05:22 +0200
48
Pau Espin Pedrold761d352018-05-03 17:40:35 +020049osmo-mgw (1.3.0) unstable; urgency=medium
50
51 [ Pau Espin Pedrol ]
52 * contrib: Add osmo-mgw systemd service
53 * legacy: mgcp_protocol: Don't print osmux stats if it is off
54 * mgcp_stat: Don't print osmux stats if it is off
55
56 [ Neels Hofmeyr ]
57 * fix segfault: DLCX for unknown endpoint: dont try to log NULL endpoint
58 * MGCP endpoints: parse as decimal, not hex
59 * add --enable-sanitize config option
60 * legacy_mgcp: mgcp_test: sanitize: free msgb_ctx
61 * mgcp_test: test_packet_error_detection: sanitize: free all conns
62 * mgcp_test: test_no_cycle: sanitize: free endp
63 * mgcp_test: sanitize: free msgb_ctx
64 * mgcp_client: don't configure "bts base"
65 * Revert "mgcp_client: don't configure "bts base"" until osmo-msc is ready
66 * mgcp_client: add transaction cleanup
67 * mgcp_client_test makefile: add update_exp target
68 * cosmetic: mgcp_network: typo in log
69 * osmo-mgw: Add talloc context introspection via VTY
70 * mgcp_client: show failure by MGCP SDP section parsing test
71 * mgcp_client: cosmetic: clean up SDP params parsing
72 * mgcp_client: detect SDP section-start parsing errors
73 * compiler warning: ignore deprecated in mgcp_client_test.c
74 * configure: add --enable-werror
75 * jenkins.sh: add --enable-werror to configure flags
76 * cosmetic: mgcp, legacy_mgcp: drop unused vty.h definitions
77 * use osmo_init_logging2() with proper talloc ctx
78
79 [ Philipp Maier ]
80 * osmux: fix nullpointer dereference
81 * cosmetic: guard dead osmux vty code with ifdef
82 * cosmetic: remove prefix "net" from rtp related vty commands
83 * doc: update sample config file
84 * cosmetic: use correct VTY port number constant
85 * vty: simplify endpoint allocation
86 * vty: do not change number_endpoints at runtime
87 * MGCP: Connection Identifiers are hex strings
88 * libosmo-mgcp: Connection Identifiers are allocated by MGW, not CA
89 * client: use osmo_strlcpy instead of strncpy
90 * cosmetic: fix sourcecode formatting
91 * cosmetic: clearly mark endpoint numbers as hex
92 * client: use string as connection identifier
93 * conn: remove assertions
94 * mgcp_test: fix wrong strcmp() parameters
95 * mgcp_test: fix nullpointer dereference
96 * mgcp_test: add returncode check
97 * mgcp_test: fix possible double free
98 * mcgp_client: mgcp_msg_gen(): add checks to verify params
99 * network: use originating RTP packet address for loopback
100 * client: mgcp_response_parse_params: check rtp port
101 * mgcp: allow endpoints beginning from zero
102 * client/common: move constant MGCP_ENDPOINT_MAXLEN
103 * mgcp: make domain name configurable
104 * cosmetic: protocol: remove unnecessary nul termination
105 * client: do not insist on \n\n when parsing MGCP messages
106 * main: display mgcp ip/port
107 * client: make callid in MDCX mandatory
108 * client: add missing mandatory SDP fields
109 * mgcp: permit wildcarded endpoint assignment (CRCX)
110 * mgcp: add prefix to virtual trunk
111 * client: eliminate destructive parameter parsing
112 * client: eliminate destructive head parsing
113 * cosmetic: client: add doxygen comments
114 * protocol: fix problem with line break and OSMUX
115 * protocol: fix missing carriage return
116 * client: fix sdp parameter ordering
117 * protocol: check the packetization in local cx options
118 * cosmetic: remove spaces from pointer symbol
119 * client: Do not accept endpoint ids with wildcards in responses
120 * client: do not accept endpoint ids without @ character in responses
121 * client: prohibit endpoint ids without @ character
122 * protocol: on wildcarded CRCX return endpoint number as hex
123 * msg: fix response code on exhausted endp resources
124 * cosmetic: move mgcp_release_endp() to mgcp_ep.c
125 * client: use heap to store mgcp_response
126 * ep: move endpoint struct and define to mgcp_ep.h
127 * cosmetic: rename mgcp_release_endp to mgcp_endp_release
128 * cosmetic: rename mgcp_ep.c/h to mgcp_endp.c/h
129 * protocol: reject DLCX/CRCX/MDCX on unsupported parameters
130 * protocol: exit cleanly when local cx options check fails
131 * cosmetic: Add missing \n on log line
132 * protocol: check requested connection mode
133 * protocol: fix tagging of wildcarded requests
134 * protocol: prohibit wildcarded requests for MDCX and DLCX
135 * mgcp: fix use-after-free and add callback for endpoint cleanup
136 * client: add an optional FSM interface
137 * mgcp_client_fsm: Add FSM event names
138 * cosmetic: mgcp_client_fsm: rename enums
139 * cosmetic: rename function .._conn_reset() to .._conn_init()
140 * mgcp_conn: do not touch u.rtp in mgcp_conn_alloc()
141 * cosmetic: rename .._codec_reset() to .._codec_init()
142 * mgcp_conn: add function mgcp_rtp_conn_cleanup()
143 * stats: use libosmocore rate counter for in/out_stream.err_ts_counter
144
145 [ Alexander Couzens ]
146 * debian/control: correct library dependency of osmo-mgw against libosmo-mgcp1
147 * debian: include systemd service osmo-mgw.service
148 * Revert "stats: use libosmocore rate counter for in/out_stream.err_ts_counter"
149
150 [ Harald Welte ]
151 * cosmetic: fix whitespaces; we use tabs for indentation
152 * Fix possible buffer overflow in mgcp_conn_dump()
153 * osmo-mgw: Update copyright statement
154 * osmo-mgw: Config file is osmo-mgw.cfg, and not mgcp.cfg
155 * osmo-mgw: Fix copyright notice
156 * strct mgcp_rtp_state: Group + document struct members related to patching
157 * mgcp_rtp_state: grup 'stats' members into sub-structure
158 * mgcp_rtp_end: Group statistics members into 'stats' sub-struct
159 * libosmo-mgcp: Cosmetic spelling fixes in comments
160 * mgcp_msg: We must parse endpoint numbers as hex, not decimal!
161 * mgcp_internal.h: document more struct members with comments
162 * centralize handling of common errors like "endpoint not found"
163 * Return proper MGCP Error codes, as per spec
164 * osmo-mgw: Use libosmocore socket abstraction
165 * osmo-bsc_mgcp: Add LIBOSMONETIF_{CFLAGS,LIBS}
166 * libosmo-mgcp-client is GPLv2+, not AGPLv3+
167 * Turn libosmo-mgcp into local, non-installed library
168
169 [ Stefan Sperling ]
170 * enable osmo_fsm vty commands in libosmo-mgcp-client vty
171
172 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 17:40:35 +0200
173
Harald Weltee7d27ae2017-11-10 11:21:40 +0900174osmo-mgw (1.2.0) unstable; urgency=medium
175
176 [ Neels Hofmeyr ]
177 * jenkins: use osmo-clean-workspace.sh before and after build
178 * vty: skip installing cmds now always installed by default
179 * mgcp-client vty: use name 'mgw' instead of 'mgcpgw'
180 * mgcp client: vty: tweak doc strings
181
182 [ Philipp Maier ]
183 * sdp: refactoring sdp parser/generator
184 * cosmetic: rename bts_codec to codec_str
185 * cosmetic: fix coding style for mgcp_parse_sdp_data()
186 * cosmetic: fix commenting style
187 * cosmetic: correct whitespaces
188 * client: fix stderror logging in unit-test
189 * client: add unified function to generate MGCP messages
190 * client: add ip address parsing to the client
191 * protocol: allow wildcarded DLCX
192 * mgcp: remove port/timeslot calculator functions from mgcp.h
193 * network: add separate log category
194 * cosmetic: make dummy packet handling more explicit
195 * network: autdetect rtp bind ip-address
196 * network: fix rtp packet length
197 * network: remove unused return code
198
199 [ Pau Espin Pedrol ]
200 * mgcp_client_vty.c: Fix VTY compatibility with 'mgcpgw bts-base'
201
202 -- Harald Welte <laforge@gnumonks.org> Fri, 10 Nov 2017 11:10:23 +0900
203
Harald Welte1ae2d5e2017-10-28 12:48:42 +0200204osmo-mgw (1.1.0) unstable; urgency=medium
205
206 * New upstream release
207
208 -- Harald Welte <lafore@gnumonks.org> Sat, 28 Oct 2017 12:48:41 +0200
209
Maxf19acc92017-09-14 18:35:06 +0200210osmo-mgw (1.0.2) unstable; urgency=low
211
212 * First release after major rename.
213
214 -- Max Suraev <msuraev@sysmocom.de> Thu, 14 Sep 2017 18:41:05 +0200
215
216
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000217osmo-mgw (0.1.0) unstable; urgency=low
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200218
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000219 * Initial release.
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200220
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000221 -- Alexander Couzens <lynxis@fe80.eu> Tue, 08 Aug 2017 01:12:53 +0000