blob: a8a850ae776a76beb3c252254d0c25a72a887929 [file] [log] [blame]
Pau Espin Pedrold761d352018-05-03 17:40:35 +02001osmo-mgw (1.3.0) unstable; urgency=medium
2
3 [ Pau Espin Pedrol ]
4 * contrib: Add osmo-mgw systemd service
5 * legacy: mgcp_protocol: Don't print osmux stats if it is off
6 * mgcp_stat: Don't print osmux stats if it is off
7
8 [ Neels Hofmeyr ]
9 * fix segfault: DLCX for unknown endpoint: dont try to log NULL endpoint
10 * MGCP endpoints: parse as decimal, not hex
11 * add --enable-sanitize config option
12 * legacy_mgcp: mgcp_test: sanitize: free msgb_ctx
13 * mgcp_test: test_packet_error_detection: sanitize: free all conns
14 * mgcp_test: test_no_cycle: sanitize: free endp
15 * mgcp_test: sanitize: free msgb_ctx
16 * mgcp_client: don't configure "bts base"
17 * Revert "mgcp_client: don't configure "bts base"" until osmo-msc is ready
18 * mgcp_client: add transaction cleanup
19 * mgcp_client_test makefile: add update_exp target
20 * cosmetic: mgcp_network: typo in log
21 * osmo-mgw: Add talloc context introspection via VTY
22 * mgcp_client: show failure by MGCP SDP section parsing test
23 * mgcp_client: cosmetic: clean up SDP params parsing
24 * mgcp_client: detect SDP section-start parsing errors
25 * compiler warning: ignore deprecated in mgcp_client_test.c
26 * configure: add --enable-werror
27 * jenkins.sh: add --enable-werror to configure flags
28 * cosmetic: mgcp, legacy_mgcp: drop unused vty.h definitions
29 * use osmo_init_logging2() with proper talloc ctx
30
31 [ Philipp Maier ]
32 * osmux: fix nullpointer dereference
33 * cosmetic: guard dead osmux vty code with ifdef
34 * cosmetic: remove prefix "net" from rtp related vty commands
35 * doc: update sample config file
36 * cosmetic: use correct VTY port number constant
37 * vty: simplify endpoint allocation
38 * vty: do not change number_endpoints at runtime
39 * MGCP: Connection Identifiers are hex strings
40 * libosmo-mgcp: Connection Identifiers are allocated by MGW, not CA
41 * client: use osmo_strlcpy instead of strncpy
42 * cosmetic: fix sourcecode formatting
43 * cosmetic: clearly mark endpoint numbers as hex
44 * client: use string as connection identifier
45 * conn: remove assertions
46 * mgcp_test: fix wrong strcmp() parameters
47 * mgcp_test: fix nullpointer dereference
48 * mgcp_test: add returncode check
49 * mgcp_test: fix possible double free
50 * mcgp_client: mgcp_msg_gen(): add checks to verify params
51 * network: use originating RTP packet address for loopback
52 * client: mgcp_response_parse_params: check rtp port
53 * mgcp: allow endpoints beginning from zero
54 * client/common: move constant MGCP_ENDPOINT_MAXLEN
55 * mgcp: make domain name configurable
56 * cosmetic: protocol: remove unnecessary nul termination
57 * client: do not insist on \n\n when parsing MGCP messages
58 * main: display mgcp ip/port
59 * client: make callid in MDCX mandatory
60 * client: add missing mandatory SDP fields
61 * mgcp: permit wildcarded endpoint assignment (CRCX)
62 * mgcp: add prefix to virtual trunk
63 * client: eliminate destructive parameter parsing
64 * client: eliminate destructive head parsing
65 * cosmetic: client: add doxygen comments
66 * protocol: fix problem with line break and OSMUX
67 * protocol: fix missing carriage return
68 * client: fix sdp parameter ordering
69 * protocol: check the packetization in local cx options
70 * cosmetic: remove spaces from pointer symbol
71 * client: Do not accept endpoint ids with wildcards in responses
72 * client: do not accept endpoint ids without @ character in responses
73 * client: prohibit endpoint ids without @ character
74 * protocol: on wildcarded CRCX return endpoint number as hex
75 * msg: fix response code on exhausted endp resources
76 * cosmetic: move mgcp_release_endp() to mgcp_ep.c
77 * client: use heap to store mgcp_response
78 * ep: move endpoint struct and define to mgcp_ep.h
79 * cosmetic: rename mgcp_release_endp to mgcp_endp_release
80 * cosmetic: rename mgcp_ep.c/h to mgcp_endp.c/h
81 * protocol: reject DLCX/CRCX/MDCX on unsupported parameters
82 * protocol: exit cleanly when local cx options check fails
83 * cosmetic: Add missing \n on log line
84 * protocol: check requested connection mode
85 * protocol: fix tagging of wildcarded requests
86 * protocol: prohibit wildcarded requests for MDCX and DLCX
87 * mgcp: fix use-after-free and add callback for endpoint cleanup
88 * client: add an optional FSM interface
89 * mgcp_client_fsm: Add FSM event names
90 * cosmetic: mgcp_client_fsm: rename enums
91 * cosmetic: rename function .._conn_reset() to .._conn_init()
92 * mgcp_conn: do not touch u.rtp in mgcp_conn_alloc()
93 * cosmetic: rename .._codec_reset() to .._codec_init()
94 * mgcp_conn: add function mgcp_rtp_conn_cleanup()
95 * stats: use libosmocore rate counter for in/out_stream.err_ts_counter
96
97 [ Alexander Couzens ]
98 * debian/control: correct library dependency of osmo-mgw against libosmo-mgcp1
99 * debian: include systemd service osmo-mgw.service
100 * Revert "stats: use libosmocore rate counter for in/out_stream.err_ts_counter"
101
102 [ Harald Welte ]
103 * cosmetic: fix whitespaces; we use tabs for indentation
104 * Fix possible buffer overflow in mgcp_conn_dump()
105 * osmo-mgw: Update copyright statement
106 * osmo-mgw: Config file is osmo-mgw.cfg, and not mgcp.cfg
107 * osmo-mgw: Fix copyright notice
108 * strct mgcp_rtp_state: Group + document struct members related to patching
109 * mgcp_rtp_state: grup 'stats' members into sub-structure
110 * mgcp_rtp_end: Group statistics members into 'stats' sub-struct
111 * libosmo-mgcp: Cosmetic spelling fixes in comments
112 * mgcp_msg: We must parse endpoint numbers as hex, not decimal!
113 * mgcp_internal.h: document more struct members with comments
114 * centralize handling of common errors like "endpoint not found"
115 * Return proper MGCP Error codes, as per spec
116 * osmo-mgw: Use libosmocore socket abstraction
117 * osmo-bsc_mgcp: Add LIBOSMONETIF_{CFLAGS,LIBS}
118 * libosmo-mgcp-client is GPLv2+, not AGPLv3+
119 * Turn libosmo-mgcp into local, non-installed library
120
121 [ Stefan Sperling ]
122 * enable osmo_fsm vty commands in libosmo-mgcp-client vty
123
124 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 17:40:35 +0200
125
Harald Weltee7d27ae2017-11-10 11:21:40 +0900126osmo-mgw (1.2.0) unstable; urgency=medium
127
128 [ Neels Hofmeyr ]
129 * jenkins: use osmo-clean-workspace.sh before and after build
130 * vty: skip installing cmds now always installed by default
131 * mgcp-client vty: use name 'mgw' instead of 'mgcpgw'
132 * mgcp client: vty: tweak doc strings
133
134 [ Philipp Maier ]
135 * sdp: refactoring sdp parser/generator
136 * cosmetic: rename bts_codec to codec_str
137 * cosmetic: fix coding style for mgcp_parse_sdp_data()
138 * cosmetic: fix commenting style
139 * cosmetic: correct whitespaces
140 * client: fix stderror logging in unit-test
141 * client: add unified function to generate MGCP messages
142 * client: add ip address parsing to the client
143 * protocol: allow wildcarded DLCX
144 * mgcp: remove port/timeslot calculator functions from mgcp.h
145 * network: add separate log category
146 * cosmetic: make dummy packet handling more explicit
147 * network: autdetect rtp bind ip-address
148 * network: fix rtp packet length
149 * network: remove unused return code
150
151 [ Pau Espin Pedrol ]
152 * mgcp_client_vty.c: Fix VTY compatibility with 'mgcpgw bts-base'
153
154 -- Harald Welte <laforge@gnumonks.org> Fri, 10 Nov 2017 11:10:23 +0900
155
Harald Welte1ae2d5e2017-10-28 12:48:42 +0200156osmo-mgw (1.1.0) unstable; urgency=medium
157
158 * New upstream release
159
160 -- Harald Welte <lafore@gnumonks.org> Sat, 28 Oct 2017 12:48:41 +0200
161
Maxf19acc92017-09-14 18:35:06 +0200162osmo-mgw (1.0.2) unstable; urgency=low
163
164 * First release after major rename.
165
166 -- Max Suraev <msuraev@sysmocom.de> Thu, 14 Sep 2017 18:41:05 +0200
167
168
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000169osmo-mgw (0.1.0) unstable; urgency=low
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200170
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000171 * Initial release.
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200172
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000173 -- Alexander Couzens <lynxis@fe80.eu> Tue, 08 Aug 2017 01:12:53 +0000