blob: fe317335de8000a02fe0a7d31886e2181fd877f1 [file] [log] [blame]
Pau Espin Pedrolec450682020-01-03 13:35:10 +01001osmo-mgw (1.7.0) unstable; urgency=medium
2
3 [ Neels Hofmeyr ]
4 * rename codecs_cmp() to codecs_same()
5 * mgcp_codec: constify 'param' arg
6 * fix crashes: don't assert on incoming RTP packet size
7 * mgcp_send(): stop looping on conversion error
8 * mgcp_codec: split codec_free() off of codec_init()
9 * fix memleak: actually free strings in mgcp_codec_reset_all()
10 * mgcp_test: extend / rewrite test_mgcp_codec_pt_translate()
11 * test_mgcp_codec_pt_translate(): more tests
12 * differentiate AMR octet-aligned=0 vs =1
13 * ptmap: implicitly match '/8000' and '/8000/1'
14 * mgcp_codec: codec_set(): log about all possible errors
15 * mgcp_codec_add: fix audio_name size check
16 * explicitly free codecs in mgcp_rtp_conn_cleanup()
17 * tweak mgcp_parse_audio_ptime_rtpmap()
18 * SDP: store all ptmap entries
19 * mgcp_client_fsm cleanup: Do not assert on DLCX failure
20 * clear pending requests on MGCP failure
21 * client: endp fsm: add notify struct, prep for cancel-notify
22 * client: endp fsm: clear ci[] before dispatching DLCX success
23 * client: endp fsm: allow cancelling a notify event
24 * client: endp fsm: add osmo_mgcpc_ep_ci_ep()
25 * accept MGCP without SDP
26 * fix use-after-free: require new fsm deferred dealloc, check for term
27
28 [ Pau Espin Pedrol ]
29 * mgcp_test: Correctly release all endpoints allocated
30 * mgw: Allocate mgcp_conn instance under tcfg->endpoints
31
32 [ Harald Welte ]
33 * manual: Fix copy+paste error
34 * mgcp_client: Check for osmo_fsm_register() error return value
35 * Move fsm_mgcp_client regstration to __attribute__((contructor))
36 * exit(2) on unsupported positional arguments on command line
37
38 [ Oliver Smith ]
39 * osmoappdesc.py: switch to python 3
40
41 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 13:35:09 +0100
42
Pau Espin Pedrol50e52e42019-08-07 16:52:58 +020043osmo-mgw (1.6.0) unstable; urgency=medium
44
45 [ Oliver Smith ]
46 * Cosmetic: fix spaces/tabs in mgcp_requests[]
47 * Inactive connection cleanup (disabled by default)
48 * debian: create -doc subpackage with pdf manuals
49 * vty: allow 0 as conn-timeout to disable it
50 * vty: update desc of conn-timeout
51 * manuals: update VTY documentation
52 * "make dist" fix for: no rule to make mgcp_common.h
53 * contrib/jenkins.sh: run "make maintainer-clean"
54
55 [ Philipp Maier ]
56 * Add option to GSM HR frames to RFC5593 representation
57 * mgcp_sdp: cosmetic: correct typo in comment
58 * mgco_client: cosmetic: remove excess whitespace
59 * mgcp_sdp: mgcp_sdp.c does not include own header file
60 * mgcp_sdp: untangle parsing of a= parameters
61 * mgcp_network: use mgcp_rtp_codec in downlink format callback
62 * AMR: Add function to convert between bw-effient and octet aligned mode
63
64 [ Neels Hofmeyr ]
65 * log: don't spam with "can not patch PT" messages
66 * mgcp client: allow setting conn mode for CRCX and MDCX
67 * make codec_table public as osmo_mgcpc_codec_names
68 * move MGW endpoint FSM from osmo-bsc to here
69 * fix: multiple initial CRCX
70 * constify map_codec_to_pt() ptmap arg
71
72 [ Pau Espin Pedrol ]
73 * mgcp-client: whitespace cleanup in mgcp_client.c
74 * mgcp-client: Sanitize implementation of mgcp_client_rtpbridge_wildcard
75 * libosmo-mgcp: Use trunk type during endpoint allocation
76 * cosmetic: Fix typos in comment
77 * cosmetic: tests: mgcp_client_test: clean trailing whitespace
78 * mgcp_msg: Log faulty line on Osmux parsing error
79 * cosmetic: handle_modify_con: Fix indentation level
80 * Introduce log fmt helpers LOGPENDP and LOGPCONN
81 * create_response_with_sdp: Fix inclusion of X-Osmux
82 * osmux: Cleanup of CID alloc pool APIs
83 * mgcp_osmux.c: osmux_enable_endpoint: Fix incorrect return check
84 * osmux: Log osmux socket during osmux_init
85 * mgcp-cli: Change osmo_mgcpc_ep_fsm name to avoid collision with old osmo-bsc
86 * osmux: Document func and return different rc upon osmux init failure
87 * osmux: Fix reception of legacy dummy payloads
88 * osmux: Use LOGPCONN in several log calls
89 * cosmetic: mgcp_udp_send: Document port param is in network byte order
90 * cosmetic: osmux: Document network byte order in port variable
91 * vty: Allow enabling Osmux
92 * osmux: Allocate CID during CRCX
93 * osmux: Introduce mgcp_conn_rtp_is_osmux() helper
94 * osmux: Mark conn_rtp->type as osmux during CRCX
95 * mgcp-cli: Allow submitting X-Osmux on CRCX request
96 * mgcp-cli: Parse X-Osmux on CRCX response
97 * osmux: Handle Osmux MGCP extension in MDCX messages
98 * mgcp-cli: Allow submitting X-Osmux on MDCX request
99 * mgcp-cli: Parse X-Osmux on MDCX response
100 * osmux: Drop unneeded OSMUX_STATE_NEGOTIATING
101 * mgcp-cli: endpoint_fsm: Add API to retrieve Osmux CID from MGW
102 * osmux: Provide correct local port during mgcp resp
103 * osmux: Use remote port to send osmux frames
104 * osmux: Improve logging around osmux enabling events
105 * osmux: Delay osmux enable of conn until remote addr is configured by MDCX
106 * osmux: Redo read/write osmux glue code to have data routed correctly
107 * mgw, mgcp-li: Handle X-Osmux param name as case insensitive
108 * osmux: Use DUMMY ft msg as per Osmux spec
109 * osmux: Fix loopback for Osmux connections
110 * osmux: Fix CID release for non-enabled connections
111 * osmux: Fix hardcoded rtp payload_type 98 in osmux conn
112 * mgcp-cli: Validate osmux cid value during mgcp_msg_gen
113 * mgw: Support uppercase LCO options
114 * mgw: Support lowercase header parameters
115 * mgcp-cli: Support lowercase header parameters
116 * mgw: Support receiving uppercase connection mode
117 * mgw: Support receiving lowercase LCO codec
118 * mgw: Make check of duplicated LCO fields case insensitive
119 * mgw: Allow receiving lowercase MGCP header keyword
120 * mgw: Allow receiving lowercase X-Osmo-Ign Callid field
121 * mgw: Allow receiving uppercase noanswer keyword
122 * doc: X-Osmo-IGN: small formatting and typo fixes
123 * doc: Add Osmux documentation to OsmoMGW User Manual
124 * Catch unsigned integer MGCP parsing errors with strtoul
125 * Fix return variable of strtoul()
126 * Remove undefined param passed to {logging,osmo_stats}_vty_add_cmds
127 * configure.ac: Require libosmo-netif 0.6.0
128
129 [ Alexander Couzens ]
130 * mgcp_internal: LOGPENDP: ensure *endp is not NULL
131
132 [ Harald Welte ]
133 * handle NULL return of rate_ctr_group_alloc()
134 * update .gitignore
135 * mgcp_sdp: Don't check if an unsigned int is below 0
136
137 [ Vadim Yanitskiy ]
138 * configure.ac: drop useless check for -fvisibility=hidden
139
140 [ Daniel Willmann ]
141 * manuals: Add script to regenerate vty/counter documentation
142 * manuals: Update vty/counter documentation
143
144 [ Hoernchen ]
145 * turn -Werror=null-dereference into a warning
146
147 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 16:52:58 +0200
148
Harald Weltee81c1172019-01-20 15:02:19 +0100149osmo-mgw (1.5.0) unstable; urgency=medium
150
151 [ Pau Espin Pedrol ]
152 * gitignore: Filter *.pc
153 * configure: Find correct libgsm's gsm.h header
154 * vty: Fix typo writing bts-jitter-buffer-delay-{min,max}
155 * Remove libosmo-legacy-mgcp and osmo-bsc-mgcp
156 * debian: Remove dangling symlink to osmo-bsc-mgcp.service
157 * Install systemd services with autotools
158 * Install sample cfg file to /etc/osmocom
159 * mgcp: Fix osmux_cid_bitmap static array size calculation
160 * mgcp_osmux: Use define to calculate rtp_ssrc_winlen
161 * osmux: Avoid initing output without enabling osmux
162 * mgcp: Log endpoint nr consistently as hex
163 * osmux_send_dummy: Avoid logging incorrectly and sending if osmux not enabled
164 * osmux: Don't process regular osmux frames if disabled by cfg
165 * osmux: Move parse_cid of legacy dummy frames to own function
166 * osmux: Make func handling dummy frames independent of endp type
167 * osmux: allow enabling osmux only on correct activating state
168 * osmux: Improve checks around activating and using enabled osmux
169 * osmux.h: Document enum osmux_state
170 * osmux: Avoid processing further frames if conn not found
171
172 [ Philipp Maier ]
173 * mgcp_client_fsm: allow ptmap in mgcp_client_fsm as well
174 * mgcp_network: translate payload type numbers in RTP packets
175 * mgcp_client: use IETF source port as for MGCP
176 * mgcp_client: increment local port number when port is in use
177 * mgcp_test: release endpoints after use
178 * network: do not patch PT of RTCP packets
179 * network: check packets before further processing
180 * Cosmetic: remove misplaced line break
181 * mgcp_sdp: restructure mgcp_write_response_sdp() (rtpmap)
182 * mgcp_sdp: restructure mgcp_write_response_sdp() (audio)
183 * mgcp_client: check local port only once
184 * mgcp_client_fsm: switch to MGCP_CONN_RECV_SEND in add_audio()
185 * mgcp_protocol: increase buffer space for codec name in LCO
186 * osmo-mgw: Add vty reference manual
187
188 [ Neels Hofmeyr ]
189 * fix handling of "Wrong domain name" error
190 * interpret domain '*' as 'allow any domain'
191 * cosmetic: log: fix "CallIDs does not match"
192 * fix 3G hack: allow any IP for loopback and 0.0.0.0
193 * cosmetic: drop code dup in mgcp_client_fsm.c CRCX
194 * add X-Osmo-IGN MGCP header to ignore CallID
195 * X-Osmo-IGN: rather parse items by token, not char
196 * mgcp_test: fix log of conn_id presence
197 * mgcp_test: fix get_conn_id_from_response() CI length
198 * mgcp_client_test: cosmetically re-arrange reply_to() args
199 * mgcp_client_test: use "\r\n\r\n" instead of "\n\n"
200 * mgcp_client_test: also verify received conn_id
201 * mgcp_client_test: test long conn_id
202 * mgcp_client: error on too long conn id
203 * mgcp_common: rename to MGCP_CONN_ID_MAXLEN
204 * doc: fix mgcp_verify_ci() return val doc
205 * mgcp_verify_ci(): return meaningful error codes
206 * fix mgcp_verify_ci(): off-by-one in max len check
207 * generate shorter 'I:' conn IDs
208 * mgcp_conn_get(): compare conn Id ('I:') case insensitively
209 * mgcp_conn_get(): match conn Id ('I:') despite leading zeros
210 * cosmetic: mgcp_test: fix get_conn_id_from_response()
211 * comment: indicate struct type for mgcp_endpoint.conns
212 * log: avoid logging early media as error
213 * fix osmo-mgw -s; fixes osmo-mgw.service using -s
214 * Importing history from osmo-gsm-manuals.git
215 * OsmoMGW: update VTY reference
216 * OsmoMGW: document the 'X-Osmo-IGN' MGCP extension
217 * mgw: update vty reference
218 * drop/replace very weird logging in mgcp_client.c
219 * check_rtp: on IP:port errors, log the IP and port
220 * osmo-mgw: err-log: include expected domain name
221 * mgcp_client_vty: fix missing talloc_free
222 * mgcp_client: drop a bunch of dead code
223 * mgcp_client: logging tweaks
224 * mgcp_client: make domain part of endpoint configurable
225 * mgcp_client: tweak some log levels INFO -> {DEBUG,ERROR}
226
227 [ Stefan Sperling ]
228 * add VTY commands which show specific mgcp endpoints
229 * add MGCP CRCX command statistics to osmo-mgw
230 * show RTP TX/RX stats in 'mgcp show stats' output
231 * use local variable for rate counters in handle_create_con()
232 * add more mgcp crxc error counters
233 * add MDCX command statistics to osmo-mgw
234 * add aggregated rtp connection stats to osmo-mgw
235 * add DLCX command statistics to osmo-mgw
236
237 [ Harald Welte ]
238 * debian/rules: Don't overwrite .tarball-version
239 * check_rtp_origin(): Don't memcmp sockadd_in and in_addr
240 * check_rtp_origin(): Avoid using memcmp for comparing integer types
241 * vty-ref: Update URI of docbook 5.0 schema
242
243 [ Daniel Willmann ]
244 * mgw: Add new VTY reference
245 * Add initial OsmoMGW manual
246
247 [ Oliver Smith ]
248 * build manuals moved here from osmo-gsm-manuals.git
249 * jenkins.sh: remove leftover MGCP env variable
250 * Fix DISTCHECK_CONFIGURE_FLAGS override
251 * contrib/jenkins.sh: build and publish manuals
252 * contrib: fix makedistcheck with disabled systemd
253
254 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 15:02:18 +0100
255
Pau Espin Pedrol304b3eb2018-07-27 19:05:23 +0200256osmo-mgw (1.4.0) unstable; urgency=medium
257
258 [ Philipp Maier ]
259 * network: independently initalize state->out_stream
260 * stats: use libosmocore rate counter for in/out_stream.err_ts_counter
261 * mgcp_sdp: correct apidoc of mgcp_parse_sdp_data
262 * vty: clean up rtp port-range command
263 * sdp: remove unused alt_codec field from struct mgcp_rtp_end
264 * sdp: remove circular inclusion
265 * protocol: Try whole port range on port allocation
266 * client: do not start connections in loopback mode
267 * mgcp_network: do not log destination invalid ip/port as error
268 * cosmetic: fix log output
269 * conn: call talloc_free before setting the pointer to NULL
270 * protocol: do not change LCO, when no LCO are present
271 * protocol: reject illegal lco options
272 * cosmetic: fix typo
273 * mgw: clean up codec negotiation (sdp)
274 * client: add features to generate and parse codec information
275 * mgcp_internal: remove unused struct member
276 * stats: replace packet statistic counters with libosmocore rate counters
277 * stat+vty: fix printing of rate counter values
278 * protocol: prevent unnecessary null pointer deref
279
280 [ Pau Espin Pedrol ]
281 * legacy-mgcp: Add jitter buffer on the uplink receiver
282 * legacy-mgcp: switch to new osmux output APIs
283 * mgcp: mgcp_osmux: use conn_bts when forwarding pkts from bsc_nat
284 * mgcp: switch to new osmux output APIs
285 * debian: Package installed example doc files
286 * gitignore: Add m4 scripts from m4 subdir
287
288 [ Neels Hofmeyr ]
289 * api doc: fix parameter name for mgcp_conn_create()
290 * mgcp-client: add mgcp_conn_get_ci()
291 * mgcp_client_fsm: improve error logging
292 * cosmetic: fix doxygen comment markers
293 * cosmetic: mgcp_network.c: merge one LOGPC to its preceding LOGP
294 * IuUP hack: make RTP patching less general
295
296 [ Harald Welte ]
297 * cosmetic: fix typo in log message: 'abrupt' instead of 'aprupt'
298
299 [ Daniel Willmann ]
300 * git-version-gen: Don't check for .git directory
301
302 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 27 Jul 2018 19:05:22 +0200
303
Pau Espin Pedrold761d352018-05-03 17:40:35 +0200304osmo-mgw (1.3.0) unstable; urgency=medium
305
306 [ Pau Espin Pedrol ]
307 * contrib: Add osmo-mgw systemd service
308 * legacy: mgcp_protocol: Don't print osmux stats if it is off
309 * mgcp_stat: Don't print osmux stats if it is off
310
311 [ Neels Hofmeyr ]
312 * fix segfault: DLCX for unknown endpoint: dont try to log NULL endpoint
313 * MGCP endpoints: parse as decimal, not hex
314 * add --enable-sanitize config option
315 * legacy_mgcp: mgcp_test: sanitize: free msgb_ctx
316 * mgcp_test: test_packet_error_detection: sanitize: free all conns
317 * mgcp_test: test_no_cycle: sanitize: free endp
318 * mgcp_test: sanitize: free msgb_ctx
319 * mgcp_client: don't configure "bts base"
320 * Revert "mgcp_client: don't configure "bts base"" until osmo-msc is ready
321 * mgcp_client: add transaction cleanup
322 * mgcp_client_test makefile: add update_exp target
323 * cosmetic: mgcp_network: typo in log
324 * osmo-mgw: Add talloc context introspection via VTY
325 * mgcp_client: show failure by MGCP SDP section parsing test
326 * mgcp_client: cosmetic: clean up SDP params parsing
327 * mgcp_client: detect SDP section-start parsing errors
328 * compiler warning: ignore deprecated in mgcp_client_test.c
329 * configure: add --enable-werror
330 * jenkins.sh: add --enable-werror to configure flags
331 * cosmetic: mgcp, legacy_mgcp: drop unused vty.h definitions
332 * use osmo_init_logging2() with proper talloc ctx
333
334 [ Philipp Maier ]
335 * osmux: fix nullpointer dereference
336 * cosmetic: guard dead osmux vty code with ifdef
337 * cosmetic: remove prefix "net" from rtp related vty commands
338 * doc: update sample config file
339 * cosmetic: use correct VTY port number constant
340 * vty: simplify endpoint allocation
341 * vty: do not change number_endpoints at runtime
342 * MGCP: Connection Identifiers are hex strings
343 * libosmo-mgcp: Connection Identifiers are allocated by MGW, not CA
344 * client: use osmo_strlcpy instead of strncpy
345 * cosmetic: fix sourcecode formatting
346 * cosmetic: clearly mark endpoint numbers as hex
347 * client: use string as connection identifier
348 * conn: remove assertions
349 * mgcp_test: fix wrong strcmp() parameters
350 * mgcp_test: fix nullpointer dereference
351 * mgcp_test: add returncode check
352 * mgcp_test: fix possible double free
353 * mcgp_client: mgcp_msg_gen(): add checks to verify params
354 * network: use originating RTP packet address for loopback
355 * client: mgcp_response_parse_params: check rtp port
356 * mgcp: allow endpoints beginning from zero
357 * client/common: move constant MGCP_ENDPOINT_MAXLEN
358 * mgcp: make domain name configurable
359 * cosmetic: protocol: remove unnecessary nul termination
360 * client: do not insist on \n\n when parsing MGCP messages
361 * main: display mgcp ip/port
362 * client: make callid in MDCX mandatory
363 * client: add missing mandatory SDP fields
364 * mgcp: permit wildcarded endpoint assignment (CRCX)
365 * mgcp: add prefix to virtual trunk
366 * client: eliminate destructive parameter parsing
367 * client: eliminate destructive head parsing
368 * cosmetic: client: add doxygen comments
369 * protocol: fix problem with line break and OSMUX
370 * protocol: fix missing carriage return
371 * client: fix sdp parameter ordering
372 * protocol: check the packetization in local cx options
373 * cosmetic: remove spaces from pointer symbol
374 * client: Do not accept endpoint ids with wildcards in responses
375 * client: do not accept endpoint ids without @ character in responses
376 * client: prohibit endpoint ids without @ character
377 * protocol: on wildcarded CRCX return endpoint number as hex
378 * msg: fix response code on exhausted endp resources
379 * cosmetic: move mgcp_release_endp() to mgcp_ep.c
380 * client: use heap to store mgcp_response
381 * ep: move endpoint struct and define to mgcp_ep.h
382 * cosmetic: rename mgcp_release_endp to mgcp_endp_release
383 * cosmetic: rename mgcp_ep.c/h to mgcp_endp.c/h
384 * protocol: reject DLCX/CRCX/MDCX on unsupported parameters
385 * protocol: exit cleanly when local cx options check fails
386 * cosmetic: Add missing \n on log line
387 * protocol: check requested connection mode
388 * protocol: fix tagging of wildcarded requests
389 * protocol: prohibit wildcarded requests for MDCX and DLCX
390 * mgcp: fix use-after-free and add callback for endpoint cleanup
391 * client: add an optional FSM interface
392 * mgcp_client_fsm: Add FSM event names
393 * cosmetic: mgcp_client_fsm: rename enums
394 * cosmetic: rename function .._conn_reset() to .._conn_init()
395 * mgcp_conn: do not touch u.rtp in mgcp_conn_alloc()
396 * cosmetic: rename .._codec_reset() to .._codec_init()
397 * mgcp_conn: add function mgcp_rtp_conn_cleanup()
398 * stats: use libosmocore rate counter for in/out_stream.err_ts_counter
399
400 [ Alexander Couzens ]
401 * debian/control: correct library dependency of osmo-mgw against libosmo-mgcp1
402 * debian: include systemd service osmo-mgw.service
403 * Revert "stats: use libosmocore rate counter for in/out_stream.err_ts_counter"
404
405 [ Harald Welte ]
406 * cosmetic: fix whitespaces; we use tabs for indentation
407 * Fix possible buffer overflow in mgcp_conn_dump()
408 * osmo-mgw: Update copyright statement
409 * osmo-mgw: Config file is osmo-mgw.cfg, and not mgcp.cfg
410 * osmo-mgw: Fix copyright notice
411 * strct mgcp_rtp_state: Group + document struct members related to patching
412 * mgcp_rtp_state: grup 'stats' members into sub-structure
413 * mgcp_rtp_end: Group statistics members into 'stats' sub-struct
414 * libosmo-mgcp: Cosmetic spelling fixes in comments
415 * mgcp_msg: We must parse endpoint numbers as hex, not decimal!
416 * mgcp_internal.h: document more struct members with comments
417 * centralize handling of common errors like "endpoint not found"
418 * Return proper MGCP Error codes, as per spec
419 * osmo-mgw: Use libosmocore socket abstraction
420 * osmo-bsc_mgcp: Add LIBOSMONETIF_{CFLAGS,LIBS}
421 * libosmo-mgcp-client is GPLv2+, not AGPLv3+
422 * Turn libosmo-mgcp into local, non-installed library
423
424 [ Stefan Sperling ]
425 * enable osmo_fsm vty commands in libosmo-mgcp-client vty
426
427 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 17:40:35 +0200
428
Harald Weltee7d27ae2017-11-10 11:21:40 +0900429osmo-mgw (1.2.0) unstable; urgency=medium
430
431 [ Neels Hofmeyr ]
432 * jenkins: use osmo-clean-workspace.sh before and after build
433 * vty: skip installing cmds now always installed by default
434 * mgcp-client vty: use name 'mgw' instead of 'mgcpgw'
435 * mgcp client: vty: tweak doc strings
436
437 [ Philipp Maier ]
438 * sdp: refactoring sdp parser/generator
439 * cosmetic: rename bts_codec to codec_str
440 * cosmetic: fix coding style for mgcp_parse_sdp_data()
441 * cosmetic: fix commenting style
442 * cosmetic: correct whitespaces
443 * client: fix stderror logging in unit-test
444 * client: add unified function to generate MGCP messages
445 * client: add ip address parsing to the client
446 * protocol: allow wildcarded DLCX
447 * mgcp: remove port/timeslot calculator functions from mgcp.h
448 * network: add separate log category
449 * cosmetic: make dummy packet handling more explicit
450 * network: autdetect rtp bind ip-address
451 * network: fix rtp packet length
452 * network: remove unused return code
453
454 [ Pau Espin Pedrol ]
455 * mgcp_client_vty.c: Fix VTY compatibility with 'mgcpgw bts-base'
456
457 -- Harald Welte <laforge@gnumonks.org> Fri, 10 Nov 2017 11:10:23 +0900
458
Harald Welte1ae2d5e2017-10-28 12:48:42 +0200459osmo-mgw (1.1.0) unstable; urgency=medium
460
461 * New upstream release
462
463 -- Harald Welte <lafore@gnumonks.org> Sat, 28 Oct 2017 12:48:41 +0200
464
Maxf19acc92017-09-14 18:35:06 +0200465osmo-mgw (1.0.2) unstable; urgency=low
466
467 * First release after major rename.
468
469 -- Max Suraev <msuraev@sysmocom.de> Thu, 14 Sep 2017 18:41:05 +0200
470
471
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000472osmo-mgw (0.1.0) unstable; urgency=low
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200473
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000474 * Initial release.
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200475
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000476 -- Alexander Couzens <lynxis@fe80.eu> Tue, 08 Aug 2017 01:12:53 +0000