blob: 2259eacba4c8a68d266f9b33fc81e26fe1892d93 [file] [log] [blame]
Pau Espin Pedrol50e52e42019-08-07 16:52:58 +02001osmo-mgw (1.6.0) unstable; urgency=medium
2
3 [ Oliver Smith ]
4 * Cosmetic: fix spaces/tabs in mgcp_requests[]
5 * Inactive connection cleanup (disabled by default)
6 * debian: create -doc subpackage with pdf manuals
7 * vty: allow 0 as conn-timeout to disable it
8 * vty: update desc of conn-timeout
9 * manuals: update VTY documentation
10 * "make dist" fix for: no rule to make mgcp_common.h
11 * contrib/jenkins.sh: run "make maintainer-clean"
12
13 [ Philipp Maier ]
14 * Add option to GSM HR frames to RFC5593 representation
15 * mgcp_sdp: cosmetic: correct typo in comment
16 * mgco_client: cosmetic: remove excess whitespace
17 * mgcp_sdp: mgcp_sdp.c does not include own header file
18 * mgcp_sdp: untangle parsing of a= parameters
19 * mgcp_network: use mgcp_rtp_codec in downlink format callback
20 * AMR: Add function to convert between bw-effient and octet aligned mode
21
22 [ Neels Hofmeyr ]
23 * log: don't spam with "can not patch PT" messages
24 * mgcp client: allow setting conn mode for CRCX and MDCX
25 * make codec_table public as osmo_mgcpc_codec_names
26 * move MGW endpoint FSM from osmo-bsc to here
27 * fix: multiple initial CRCX
28 * constify map_codec_to_pt() ptmap arg
29
30 [ Pau Espin Pedrol ]
31 * mgcp-client: whitespace cleanup in mgcp_client.c
32 * mgcp-client: Sanitize implementation of mgcp_client_rtpbridge_wildcard
33 * libosmo-mgcp: Use trunk type during endpoint allocation
34 * cosmetic: Fix typos in comment
35 * cosmetic: tests: mgcp_client_test: clean trailing whitespace
36 * mgcp_msg: Log faulty line on Osmux parsing error
37 * cosmetic: handle_modify_con: Fix indentation level
38 * Introduce log fmt helpers LOGPENDP and LOGPCONN
39 * create_response_with_sdp: Fix inclusion of X-Osmux
40 * osmux: Cleanup of CID alloc pool APIs
41 * mgcp_osmux.c: osmux_enable_endpoint: Fix incorrect return check
42 * osmux: Log osmux socket during osmux_init
43 * mgcp-cli: Change osmo_mgcpc_ep_fsm name to avoid collision with old osmo-bsc
44 * osmux: Document func and return different rc upon osmux init failure
45 * osmux: Fix reception of legacy dummy payloads
46 * osmux: Use LOGPCONN in several log calls
47 * cosmetic: mgcp_udp_send: Document port param is in network byte order
48 * cosmetic: osmux: Document network byte order in port variable
49 * vty: Allow enabling Osmux
50 * osmux: Allocate CID during CRCX
51 * osmux: Introduce mgcp_conn_rtp_is_osmux() helper
52 * osmux: Mark conn_rtp->type as osmux during CRCX
53 * mgcp-cli: Allow submitting X-Osmux on CRCX request
54 * mgcp-cli: Parse X-Osmux on CRCX response
55 * osmux: Handle Osmux MGCP extension in MDCX messages
56 * mgcp-cli: Allow submitting X-Osmux on MDCX request
57 * mgcp-cli: Parse X-Osmux on MDCX response
58 * osmux: Drop unneeded OSMUX_STATE_NEGOTIATING
59 * mgcp-cli: endpoint_fsm: Add API to retrieve Osmux CID from MGW
60 * osmux: Provide correct local port during mgcp resp
61 * osmux: Use remote port to send osmux frames
62 * osmux: Improve logging around osmux enabling events
63 * osmux: Delay osmux enable of conn until remote addr is configured by MDCX
64 * osmux: Redo read/write osmux glue code to have data routed correctly
65 * mgw, mgcp-li: Handle X-Osmux param name as case insensitive
66 * osmux: Use DUMMY ft msg as per Osmux spec
67 * osmux: Fix loopback for Osmux connections
68 * osmux: Fix CID release for non-enabled connections
69 * osmux: Fix hardcoded rtp payload_type 98 in osmux conn
70 * mgcp-cli: Validate osmux cid value during mgcp_msg_gen
71 * mgw: Support uppercase LCO options
72 * mgw: Support lowercase header parameters
73 * mgcp-cli: Support lowercase header parameters
74 * mgw: Support receiving uppercase connection mode
75 * mgw: Support receiving lowercase LCO codec
76 * mgw: Make check of duplicated LCO fields case insensitive
77 * mgw: Allow receiving lowercase MGCP header keyword
78 * mgw: Allow receiving lowercase X-Osmo-Ign Callid field
79 * mgw: Allow receiving uppercase noanswer keyword
80 * doc: X-Osmo-IGN: small formatting and typo fixes
81 * doc: Add Osmux documentation to OsmoMGW User Manual
82 * Catch unsigned integer MGCP parsing errors with strtoul
83 * Fix return variable of strtoul()
84 * Remove undefined param passed to {logging,osmo_stats}_vty_add_cmds
85 * configure.ac: Require libosmo-netif 0.6.0
86
87 [ Alexander Couzens ]
88 * mgcp_internal: LOGPENDP: ensure *endp is not NULL
89
90 [ Harald Welte ]
91 * handle NULL return of rate_ctr_group_alloc()
92 * update .gitignore
93 * mgcp_sdp: Don't check if an unsigned int is below 0
94
95 [ Vadim Yanitskiy ]
96 * configure.ac: drop useless check for -fvisibility=hidden
97
98 [ Daniel Willmann ]
99 * manuals: Add script to regenerate vty/counter documentation
100 * manuals: Update vty/counter documentation
101
102 [ Hoernchen ]
103 * turn -Werror=null-dereference into a warning
104
105 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 16:52:58 +0200
106
Harald Weltee81c1172019-01-20 15:02:19 +0100107osmo-mgw (1.5.0) unstable; urgency=medium
108
109 [ Pau Espin Pedrol ]
110 * gitignore: Filter *.pc
111 * configure: Find correct libgsm's gsm.h header
112 * vty: Fix typo writing bts-jitter-buffer-delay-{min,max}
113 * Remove libosmo-legacy-mgcp and osmo-bsc-mgcp
114 * debian: Remove dangling symlink to osmo-bsc-mgcp.service
115 * Install systemd services with autotools
116 * Install sample cfg file to /etc/osmocom
117 * mgcp: Fix osmux_cid_bitmap static array size calculation
118 * mgcp_osmux: Use define to calculate rtp_ssrc_winlen
119 * osmux: Avoid initing output without enabling osmux
120 * mgcp: Log endpoint nr consistently as hex
121 * osmux_send_dummy: Avoid logging incorrectly and sending if osmux not enabled
122 * osmux: Don't process regular osmux frames if disabled by cfg
123 * osmux: Move parse_cid of legacy dummy frames to own function
124 * osmux: Make func handling dummy frames independent of endp type
125 * osmux: allow enabling osmux only on correct activating state
126 * osmux: Improve checks around activating and using enabled osmux
127 * osmux.h: Document enum osmux_state
128 * osmux: Avoid processing further frames if conn not found
129
130 [ Philipp Maier ]
131 * mgcp_client_fsm: allow ptmap in mgcp_client_fsm as well
132 * mgcp_network: translate payload type numbers in RTP packets
133 * mgcp_client: use IETF source port as for MGCP
134 * mgcp_client: increment local port number when port is in use
135 * mgcp_test: release endpoints after use
136 * network: do not patch PT of RTCP packets
137 * network: check packets before further processing
138 * Cosmetic: remove misplaced line break
139 * mgcp_sdp: restructure mgcp_write_response_sdp() (rtpmap)
140 * mgcp_sdp: restructure mgcp_write_response_sdp() (audio)
141 * mgcp_client: check local port only once
142 * mgcp_client_fsm: switch to MGCP_CONN_RECV_SEND in add_audio()
143 * mgcp_protocol: increase buffer space for codec name in LCO
144 * osmo-mgw: Add vty reference manual
145
146 [ Neels Hofmeyr ]
147 * fix handling of "Wrong domain name" error
148 * interpret domain '*' as 'allow any domain'
149 * cosmetic: log: fix "CallIDs does not match"
150 * fix 3G hack: allow any IP for loopback and 0.0.0.0
151 * cosmetic: drop code dup in mgcp_client_fsm.c CRCX
152 * add X-Osmo-IGN MGCP header to ignore CallID
153 * X-Osmo-IGN: rather parse items by token, not char
154 * mgcp_test: fix log of conn_id presence
155 * mgcp_test: fix get_conn_id_from_response() CI length
156 * mgcp_client_test: cosmetically re-arrange reply_to() args
157 * mgcp_client_test: use "\r\n\r\n" instead of "\n\n"
158 * mgcp_client_test: also verify received conn_id
159 * mgcp_client_test: test long conn_id
160 * mgcp_client: error on too long conn id
161 * mgcp_common: rename to MGCP_CONN_ID_MAXLEN
162 * doc: fix mgcp_verify_ci() return val doc
163 * mgcp_verify_ci(): return meaningful error codes
164 * fix mgcp_verify_ci(): off-by-one in max len check
165 * generate shorter 'I:' conn IDs
166 * mgcp_conn_get(): compare conn Id ('I:') case insensitively
167 * mgcp_conn_get(): match conn Id ('I:') despite leading zeros
168 * cosmetic: mgcp_test: fix get_conn_id_from_response()
169 * comment: indicate struct type for mgcp_endpoint.conns
170 * log: avoid logging early media as error
171 * fix osmo-mgw -s; fixes osmo-mgw.service using -s
172 * Importing history from osmo-gsm-manuals.git
173 * OsmoMGW: update VTY reference
174 * OsmoMGW: document the 'X-Osmo-IGN' MGCP extension
175 * mgw: update vty reference
176 * drop/replace very weird logging in mgcp_client.c
177 * check_rtp: on IP:port errors, log the IP and port
178 * osmo-mgw: err-log: include expected domain name
179 * mgcp_client_vty: fix missing talloc_free
180 * mgcp_client: drop a bunch of dead code
181 * mgcp_client: logging tweaks
182 * mgcp_client: make domain part of endpoint configurable
183 * mgcp_client: tweak some log levels INFO -> {DEBUG,ERROR}
184
185 [ Stefan Sperling ]
186 * add VTY commands which show specific mgcp endpoints
187 * add MGCP CRCX command statistics to osmo-mgw
188 * show RTP TX/RX stats in 'mgcp show stats' output
189 * use local variable for rate counters in handle_create_con()
190 * add more mgcp crxc error counters
191 * add MDCX command statistics to osmo-mgw
192 * add aggregated rtp connection stats to osmo-mgw
193 * add DLCX command statistics to osmo-mgw
194
195 [ Harald Welte ]
196 * debian/rules: Don't overwrite .tarball-version
197 * check_rtp_origin(): Don't memcmp sockadd_in and in_addr
198 * check_rtp_origin(): Avoid using memcmp for comparing integer types
199 * vty-ref: Update URI of docbook 5.0 schema
200
201 [ Daniel Willmann ]
202 * mgw: Add new VTY reference
203 * Add initial OsmoMGW manual
204
205 [ Oliver Smith ]
206 * build manuals moved here from osmo-gsm-manuals.git
207 * jenkins.sh: remove leftover MGCP env variable
208 * Fix DISTCHECK_CONFIGURE_FLAGS override
209 * contrib/jenkins.sh: build and publish manuals
210 * contrib: fix makedistcheck with disabled systemd
211
212 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 15:02:18 +0100
213
Pau Espin Pedrol304b3eb2018-07-27 19:05:23 +0200214osmo-mgw (1.4.0) unstable; urgency=medium
215
216 [ Philipp Maier ]
217 * network: independently initalize state->out_stream
218 * stats: use libosmocore rate counter for in/out_stream.err_ts_counter
219 * mgcp_sdp: correct apidoc of mgcp_parse_sdp_data
220 * vty: clean up rtp port-range command
221 * sdp: remove unused alt_codec field from struct mgcp_rtp_end
222 * sdp: remove circular inclusion
223 * protocol: Try whole port range on port allocation
224 * client: do not start connections in loopback mode
225 * mgcp_network: do not log destination invalid ip/port as error
226 * cosmetic: fix log output
227 * conn: call talloc_free before setting the pointer to NULL
228 * protocol: do not change LCO, when no LCO are present
229 * protocol: reject illegal lco options
230 * cosmetic: fix typo
231 * mgw: clean up codec negotiation (sdp)
232 * client: add features to generate and parse codec information
233 * mgcp_internal: remove unused struct member
234 * stats: replace packet statistic counters with libosmocore rate counters
235 * stat+vty: fix printing of rate counter values
236 * protocol: prevent unnecessary null pointer deref
237
238 [ Pau Espin Pedrol ]
239 * legacy-mgcp: Add jitter buffer on the uplink receiver
240 * legacy-mgcp: switch to new osmux output APIs
241 * mgcp: mgcp_osmux: use conn_bts when forwarding pkts from bsc_nat
242 * mgcp: switch to new osmux output APIs
243 * debian: Package installed example doc files
244 * gitignore: Add m4 scripts from m4 subdir
245
246 [ Neels Hofmeyr ]
247 * api doc: fix parameter name for mgcp_conn_create()
248 * mgcp-client: add mgcp_conn_get_ci()
249 * mgcp_client_fsm: improve error logging
250 * cosmetic: fix doxygen comment markers
251 * cosmetic: mgcp_network.c: merge one LOGPC to its preceding LOGP
252 * IuUP hack: make RTP patching less general
253
254 [ Harald Welte ]
255 * cosmetic: fix typo in log message: 'abrupt' instead of 'aprupt'
256
257 [ Daniel Willmann ]
258 * git-version-gen: Don't check for .git directory
259
260 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 27 Jul 2018 19:05:22 +0200
261
Pau Espin Pedrold761d352018-05-03 17:40:35 +0200262osmo-mgw (1.3.0) unstable; urgency=medium
263
264 [ Pau Espin Pedrol ]
265 * contrib: Add osmo-mgw systemd service
266 * legacy: mgcp_protocol: Don't print osmux stats if it is off
267 * mgcp_stat: Don't print osmux stats if it is off
268
269 [ Neels Hofmeyr ]
270 * fix segfault: DLCX for unknown endpoint: dont try to log NULL endpoint
271 * MGCP endpoints: parse as decimal, not hex
272 * add --enable-sanitize config option
273 * legacy_mgcp: mgcp_test: sanitize: free msgb_ctx
274 * mgcp_test: test_packet_error_detection: sanitize: free all conns
275 * mgcp_test: test_no_cycle: sanitize: free endp
276 * mgcp_test: sanitize: free msgb_ctx
277 * mgcp_client: don't configure "bts base"
278 * Revert "mgcp_client: don't configure "bts base"" until osmo-msc is ready
279 * mgcp_client: add transaction cleanup
280 * mgcp_client_test makefile: add update_exp target
281 * cosmetic: mgcp_network: typo in log
282 * osmo-mgw: Add talloc context introspection via VTY
283 * mgcp_client: show failure by MGCP SDP section parsing test
284 * mgcp_client: cosmetic: clean up SDP params parsing
285 * mgcp_client: detect SDP section-start parsing errors
286 * compiler warning: ignore deprecated in mgcp_client_test.c
287 * configure: add --enable-werror
288 * jenkins.sh: add --enable-werror to configure flags
289 * cosmetic: mgcp, legacy_mgcp: drop unused vty.h definitions
290 * use osmo_init_logging2() with proper talloc ctx
291
292 [ Philipp Maier ]
293 * osmux: fix nullpointer dereference
294 * cosmetic: guard dead osmux vty code with ifdef
295 * cosmetic: remove prefix "net" from rtp related vty commands
296 * doc: update sample config file
297 * cosmetic: use correct VTY port number constant
298 * vty: simplify endpoint allocation
299 * vty: do not change number_endpoints at runtime
300 * MGCP: Connection Identifiers are hex strings
301 * libosmo-mgcp: Connection Identifiers are allocated by MGW, not CA
302 * client: use osmo_strlcpy instead of strncpy
303 * cosmetic: fix sourcecode formatting
304 * cosmetic: clearly mark endpoint numbers as hex
305 * client: use string as connection identifier
306 * conn: remove assertions
307 * mgcp_test: fix wrong strcmp() parameters
308 * mgcp_test: fix nullpointer dereference
309 * mgcp_test: add returncode check
310 * mgcp_test: fix possible double free
311 * mcgp_client: mgcp_msg_gen(): add checks to verify params
312 * network: use originating RTP packet address for loopback
313 * client: mgcp_response_parse_params: check rtp port
314 * mgcp: allow endpoints beginning from zero
315 * client/common: move constant MGCP_ENDPOINT_MAXLEN
316 * mgcp: make domain name configurable
317 * cosmetic: protocol: remove unnecessary nul termination
318 * client: do not insist on \n\n when parsing MGCP messages
319 * main: display mgcp ip/port
320 * client: make callid in MDCX mandatory
321 * client: add missing mandatory SDP fields
322 * mgcp: permit wildcarded endpoint assignment (CRCX)
323 * mgcp: add prefix to virtual trunk
324 * client: eliminate destructive parameter parsing
325 * client: eliminate destructive head parsing
326 * cosmetic: client: add doxygen comments
327 * protocol: fix problem with line break and OSMUX
328 * protocol: fix missing carriage return
329 * client: fix sdp parameter ordering
330 * protocol: check the packetization in local cx options
331 * cosmetic: remove spaces from pointer symbol
332 * client: Do not accept endpoint ids with wildcards in responses
333 * client: do not accept endpoint ids without @ character in responses
334 * client: prohibit endpoint ids without @ character
335 * protocol: on wildcarded CRCX return endpoint number as hex
336 * msg: fix response code on exhausted endp resources
337 * cosmetic: move mgcp_release_endp() to mgcp_ep.c
338 * client: use heap to store mgcp_response
339 * ep: move endpoint struct and define to mgcp_ep.h
340 * cosmetic: rename mgcp_release_endp to mgcp_endp_release
341 * cosmetic: rename mgcp_ep.c/h to mgcp_endp.c/h
342 * protocol: reject DLCX/CRCX/MDCX on unsupported parameters
343 * protocol: exit cleanly when local cx options check fails
344 * cosmetic: Add missing \n on log line
345 * protocol: check requested connection mode
346 * protocol: fix tagging of wildcarded requests
347 * protocol: prohibit wildcarded requests for MDCX and DLCX
348 * mgcp: fix use-after-free and add callback for endpoint cleanup
349 * client: add an optional FSM interface
350 * mgcp_client_fsm: Add FSM event names
351 * cosmetic: mgcp_client_fsm: rename enums
352 * cosmetic: rename function .._conn_reset() to .._conn_init()
353 * mgcp_conn: do not touch u.rtp in mgcp_conn_alloc()
354 * cosmetic: rename .._codec_reset() to .._codec_init()
355 * mgcp_conn: add function mgcp_rtp_conn_cleanup()
356 * stats: use libosmocore rate counter for in/out_stream.err_ts_counter
357
358 [ Alexander Couzens ]
359 * debian/control: correct library dependency of osmo-mgw against libosmo-mgcp1
360 * debian: include systemd service osmo-mgw.service
361 * Revert "stats: use libosmocore rate counter for in/out_stream.err_ts_counter"
362
363 [ Harald Welte ]
364 * cosmetic: fix whitespaces; we use tabs for indentation
365 * Fix possible buffer overflow in mgcp_conn_dump()
366 * osmo-mgw: Update copyright statement
367 * osmo-mgw: Config file is osmo-mgw.cfg, and not mgcp.cfg
368 * osmo-mgw: Fix copyright notice
369 * strct mgcp_rtp_state: Group + document struct members related to patching
370 * mgcp_rtp_state: grup 'stats' members into sub-structure
371 * mgcp_rtp_end: Group statistics members into 'stats' sub-struct
372 * libosmo-mgcp: Cosmetic spelling fixes in comments
373 * mgcp_msg: We must parse endpoint numbers as hex, not decimal!
374 * mgcp_internal.h: document more struct members with comments
375 * centralize handling of common errors like "endpoint not found"
376 * Return proper MGCP Error codes, as per spec
377 * osmo-mgw: Use libosmocore socket abstraction
378 * osmo-bsc_mgcp: Add LIBOSMONETIF_{CFLAGS,LIBS}
379 * libosmo-mgcp-client is GPLv2+, not AGPLv3+
380 * Turn libosmo-mgcp into local, non-installed library
381
382 [ Stefan Sperling ]
383 * enable osmo_fsm vty commands in libosmo-mgcp-client vty
384
385 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 17:40:35 +0200
386
Harald Weltee7d27ae2017-11-10 11:21:40 +0900387osmo-mgw (1.2.0) unstable; urgency=medium
388
389 [ Neels Hofmeyr ]
390 * jenkins: use osmo-clean-workspace.sh before and after build
391 * vty: skip installing cmds now always installed by default
392 * mgcp-client vty: use name 'mgw' instead of 'mgcpgw'
393 * mgcp client: vty: tweak doc strings
394
395 [ Philipp Maier ]
396 * sdp: refactoring sdp parser/generator
397 * cosmetic: rename bts_codec to codec_str
398 * cosmetic: fix coding style for mgcp_parse_sdp_data()
399 * cosmetic: fix commenting style
400 * cosmetic: correct whitespaces
401 * client: fix stderror logging in unit-test
402 * client: add unified function to generate MGCP messages
403 * client: add ip address parsing to the client
404 * protocol: allow wildcarded DLCX
405 * mgcp: remove port/timeslot calculator functions from mgcp.h
406 * network: add separate log category
407 * cosmetic: make dummy packet handling more explicit
408 * network: autdetect rtp bind ip-address
409 * network: fix rtp packet length
410 * network: remove unused return code
411
412 [ Pau Espin Pedrol ]
413 * mgcp_client_vty.c: Fix VTY compatibility with 'mgcpgw bts-base'
414
415 -- Harald Welte <laforge@gnumonks.org> Fri, 10 Nov 2017 11:10:23 +0900
416
Harald Welte1ae2d5e2017-10-28 12:48:42 +0200417osmo-mgw (1.1.0) unstable; urgency=medium
418
419 * New upstream release
420
421 -- Harald Welte <lafore@gnumonks.org> Sat, 28 Oct 2017 12:48:41 +0200
422
Maxf19acc92017-09-14 18:35:06 +0200423osmo-mgw (1.0.2) unstable; urgency=low
424
425 * First release after major rename.
426
427 -- Max Suraev <msuraev@sysmocom.de> Thu, 14 Sep 2017 18:41:05 +0200
428
429
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000430osmo-mgw (0.1.0) unstable; urgency=low
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200431
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000432 * Initial release.
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200433
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000434 -- Alexander Couzens <lynxis@fe80.eu> Tue, 08 Aug 2017 01:12:53 +0000