blob: ec3493775e32806e5681a9e1533c10468eb4e7b6 [file] [log] [blame]
Pau Espin Pedrol58dc88b2021-11-16 16:59:21 +01001osmo-mgw (1.9.0) unstable; urgency=medium
2
3 [ Harald Welte ]
4 * TOS bits != DSCP
5 * manual: don't define fig-bsc twice
6 * switch from osmo_sock_set_dscp() to OSMO_SOCK_F_DSCP()
7 * mgw: Add support for setting socket priority from VTY
8 * manual: Include QoS chapter and add osmo-mgw specific example
9
10 [ Keith ]
11 * Add vty command 'show mgcp active'
12 * Log some useful messages at ERROR/INFO instead of DEBUG
13
14 [ Neels Hofmeyr ]
15 * send DLCX only once
16 * tweak termination DLCX log msg
17 * add osmo_mgcpc_ep_ci_get_remote_rtp_info()
18 * check_rtp_destin(): clarify log msg
19 * mgcp_client_fsm delete: set mgcp_client as ctx, not NULL
20 * mgcp_client_endpoint_fsm: on term, still let conns wait for DLCX OK
21 * mgcp_client_fsm: add missing log_subsys
22 * mgcp_client: add logging on received MGCP messages
23
24 [ Philipp Maier ]
25 * mgcp_network: fix implicit address loopback
26 * mgcp_common, mgcp_udp_send: make parameter buf const
27 * mgcp_network: refactor MGCP_DUMMY_LOAD
28 * mgcp_client: drop nunnecessary else statement
29 * mgcp_client: fix error handling in mgcp message generation
30 * mgcp_protocol: fix loop that sends dummy RTP packets
31 * mgw_main: fix loop that resets all endpoints
32 * mgcp_trunk: drop ws line
33 * mgcp_ratectr: drop ws line
34 * mgcp_ratectr: fix sourcecode formatting
35 * mgcp_trunk: add value string for trunk type.
36 * mgcp_ratectr: refactor rate counter and set group name
37 * mgcp_protocol: forward declare mgcp_endpoint
38 * mgcp_endp: make wildcarded detection separate
39 * mgcp_protocol: refactor request handler array
40 * mgcp_trunk: use unsigned int instead of int as trunk_nr
41 * mgcp_protocol: refactor MGCP request handling
42 * mgcp_ratectr: add stats items to monitor trunk usage
43 * mgcp_msg: add trunk parameter to mgcp_check_param for logging
44 * mgcp_protocol: refactor function create_response_with_sdp
45 * mgcp_protocol: add support for wildcarded DLCX
46 * remove struct member wildcarded_req from struct mgcp_endpoint
47 * mgcp_lient: remove unsubstantial FIXME note
48 * mgcp_protocol: assert endp when it becomes mandatory
49 * mgcp_trunk: check MGW domain name earlier
50 * mgcp_ratectr: add stats items to monitor trunk usage
51 * mgcp_client: fix typo Initalize -> Initialize
52 * mgcp_protocol: get rid of policy_cb and change_cb
53 * mgcp_ratectr: do not set talloc destructor on library allocated item
54 * mgcp_client: allow to reset endpoints on startup
55 * mgcp_client_vty: remove unnecessary checks
56 * mgcp_client: do not print (null) when address is ANY
57 * mgcp_client: refactor function init_socket
58 * libosmo-mgcp-client: extend the mgcp_client for MGW pooling
59 * mgcp_client_vty: add missing docstrings
60 * mgcp_client_vty: add OSMO_ASSERT on pool parameter
61 * mgcp_client_vty: fix docstrings for mgw-pool
62 * mgcp_client_vty: cosmetic: doc string should terminated with \n
63 * mgcp_client_vty: fixing docstring
64 * mgcp_ratectr: remove unusued rate counters
65 * mgcp_client: fix typo in doxygen comment
66 * mgcp_client: add MGW name as logging context
67
68 [ Pau Espin Pedrol ]
69 * Use new stat item/ctr getter APIs
70 * constify arg in addr_is_any()
71 * Define patch_ssrc as bool type
72 * constify some function arg pointers
73 * mgcp_network.c: Reorder some functions in file
74 * mgcp_send_dummy: Check RTP destination is available before attempt tx
75 * mgw: rx CRCX: Avoid sending dummy rtp if remote address not provided
76 * Fail rx MDCX sendrecv with invalid remote addr
77 * Take into account Marker bit when patching RTP stream
78 * Use DLMGCP instead of DLGLOBAL in log lines
79 * Fix attribute parsing on gcc 11.1.0
80
81 [ neels ]
82 * Revert "mgcp_ratectr: add stats items to monitor trunk usage"
83
84 [ Daniel Willmann ]
85 * contrib/jenkins: Use ASAN for osmo-mgw
86
87 [ Oliver Smith ]
88 * mgcp_client_vty: add missing NO_STR
89 * Revert "Turn some compiler warnings into errors"
90
91 [ Eric ]
92 * add vscode stuff to gitignore
93 * configure.ac: fix maybe-uninitialized for clang
94 * fix missing includes and forward declarations
95 * rename do_retransmission
96 * mgcp_sdp: fix potential leak
97 * stats: make sanitizers happy
98 * libosmo-mgcp: cleanup audio codex alloc
99 * libosmo-mgcp: atomic rate counter group indexes
100 * libosmo-mgcp: do not use the default msgb talloc context
101 * globally lock the portrange when trying to grab a port to prep for multithreading
102 * embed strings into structs
103 * adjust talloc context
104 * endp: do not cache cfg pointer
105 * add modified .clang-format
106 * rename strip_epname and find_specific_endpoint and make them available
107 * fix mgcp_conn_free_all
108 * fix up some docstrings that lost their dot
109
110 [ Vadim Yanitskiy ]
111 * libosmo-mgcp: use OSMO_STRLCPY_ARRAY in mgcp_codec_add()
112
113 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 16 Nov 2021 16:59:21 +0100
114
Harald Welte9ffaba72021-02-24 10:56:17 +0100115osmo-mgw (1.8.1) unstable; urgency=medium
116
117 * attempt to fix RPM spec file after recent soversion bump
118
119 -- Harald Welte <laforge@osmocom.org> Wed, 24 Feb 2021 10:56:17 +0100
120
Pau Espin Pedrol6ccdaa22021-02-23 18:28:45 +0100121osmo-mgw (1.8.0) unstable; urgency=medium
122
123 [ Harald Welte ]
124 * Fix number of endpoints of default trunk
125 * Add CTRL interface to osmo-mgw
126 * Update per-trunk global packet/byte counters in real-time
127 * remove accidential TODO-RELEASE entry
128 * mgcp_protocol: Avoid code duplication between virtual + other trunks
129 * osmo-mgw.spec.in: Use %config(noreplace) to retain current config file
130 * mgcp_client_init(): consider "talloc returns NULL" case
131 * mgcp_client_pending_add(): Consider "talloc returns NULL" case
132 * libosmo-mgcp-client: fix memleak in case if no response is received
133 * debian/control + SPEC: Add missing build dependency to libosmo-abis
134 * osmo-mgw.spec.in: Fix dependency to libosmoabis
135 * osmo-mgw.spec.in: Add missing dependency to libosmotrau
136 * Add example osmo-mgw configuration file for Abis/E1
137 * use osmo_fd_setup() whenever applicable
138
139 [ Neels Hofmeyr ]
140 * fix vty dump_trunk: start from zero, do not omit first CONN
141 * allow larger MGCP client wqueue: 10 -> 1024
142 * add osmo-mgw --vty-ref-xml: dump VTY ref XML to stdout
143 * manuals: generate vty reference xml at build time
144 * refactor: use msgb to receive, pass and send RTP packets
145 * change timer T2427001 to X2427
146
147 [ Philipp Maier ]
148 * doc: do not bind osmo-mgw to random ip-address
149 * cosmetic: remove excess newlines
150 * mgcp: remove unused callback pointer
151 * mgcp: find better locations for LOGPCONN and LOGPENDP
152 * vty: fix unreachable code (error msg on trunk alloc fail)
153 * mgcp_vty: fix indentation
154 * osmo-mgw: rename struct mgcp_trunk_config and symbol tcfg
155 * mgcp_vty: fix indentation in VTY config write
156 * osmo-mgw: refactor endpoint and trunk handling
157 * mgcp_trunk: remove audio_name and audio_payload
158 * ratectr: move rate counter definitions into mgcp_ratectr.h
159 * cosmetic: fix doxygen
160 * cosmetic: fix doxygen
161 * cosmetic: fix doxygen for mgcp_cleanup_rtp_bridge_cb()
162 * trunk: get rid of virt_trunk pointer
163 * cosmetic: remove excess space
164 * endp: move endpoint name generation into mgcp_endp.c
165 * endp: add name generator function for E1 endpoints
166 * mgcp_client: add docstring for mgcp_client_rtpbridge_wildcard()
167 * mgcp_trunk: fix docstring for mgcp_trunk_alloc()
168 * mgcp_osmux: remove unused define constants
169 * mgcp_trunk: move enum mgcp_trunk_type to mgcp_trunk.h
170 * mgcp_trunk: use enum type for trunk type variable
171 * trunk: parse E1 trunk number
172 * endp: add typeset for e1-endpoints
173 * mgcp_conn: move struct mgcp_conn mgcp_conn.h
174 * mgcp_internal: remove forward declaration struct mgcp_endpoint_type
175 * endp: add E1 endpoint interlocking
176 * endp: require domain name also for E1 endpoints
177 * mgcp_trunk: pick trunk by number and type
178 * mgcp_client: add function to generate e1-endpoint names
179 * mgcp_endp: use define constant to define max number of E1 subslots
180 * mgcp_endp.c: cosmetic: fix sourcecode formatting
181 * mgcp_trunk: remove double check
182 * mgcp_test: do not access endpoint array elements directly
183 * mgcp_vty: fix endpoint number configuration
184 * mgcp_test: remove trunk2 from unit-test
185 * mgcp_trunk: use talloc_zero_array instead of _talloc_zero_array
186 * mgcp_protocol: remove unused variable
187 * mgcp_e1: finish E1 support, add E1 support from libosmoabis
188 * get rid of mgcp_internal.h
189 * mgcp_ratectr: fix comments in header file
190 * mgcp_e1: use return value of e1inp_line_update()
191 * mgcp_protocol: log when endpoint is unavailable
192 * cosmetic: add missing new-line
193 * mgcp_trunk: drop "trunk 0" limitation
194 * mgcp_e1: make E1 ts initalization more debugable
195 * mgcp_e1: remove unused struct member trunk->e1.line
196 * mgcp_endp: use NUM_E1_TS from e1_input.h
197 * mgcp_trunk: increase default number of virtual endpoints
198 * cosmetic: mgcp_client_fsm: change error message.
199 * mgcp_vty: remove remains of loopback functionality
200 * mgcp_vty: deprecate bind early command
201 * mgcp_e1: do not expose function mgcp_e1_init()
202 * mgcp_vty: add user attributes to configuration commands
203 * overview: update section limitations.
204 * overview: fix graph "OsmoMGW used with OsmoBSC"
205 * overview: fix graph "OsmoMGW used with OsmoMSC"
206 * overview: add graph to show E1 integration
207 * configuration: remove hint towards trunk 0 limit
208 * configuration: drop note about lackin E1 support
209 * configuration: add note that changes to trunks need a restart
210 * mgcp_vty: fix config write for trunk 0
211 * mgcp_vty: add missing VTY commands for E1 trunks
212 * mgcp_trunk: get rid of magic numbers for E1 slots
213 * configuration: add section about E1 trunks
214 * usermanual: add chapter about mgcp endpoints
215 * mgcp_client: get rid of magic numbers for E1 slots
216
217 [ Eric ]
218 * tests: dlopen does not imply availability of dlsym..
219 * configure.ac: fix libtool issue with clang and sanitizer
220
221 [ Alexander Chemeris ]
222 * vty: Prepend VTY output of counters for better visual separation.
223 * counters: Implement more useful counters.
224 * mgcp_network: Fix a typo in the comment bahviour -> behaviour
225 * rtp_bridge: Demote a chatty ERROR log message to DEBUG level.
226
227 [ Pau Espin Pedrol ]
228 * Use OSMO_FD_* instead of deprecated BSC_FD_*
229 * Support setting rt-prio and cpu-affinity mask through VTY
230 * cosmetic: Rename main talloc ctx
231 * mgcp-client: Support IPv6 in osmo_mgcpc_ep_ci_get_crcx_info_to_sockaddr() implementation
232 * mgcp-client: Fix trailing whitespace in mgcp_client_fsm.h
233 * mgcp_client: Use INET6_ADDRSTRLEN to store addresses in str format
234 * mgcp_client: Allow submitting and parsing IPv6 addr in SDP
235 * mgcp_client: Allow setting IPv6 addresses
236 * mgcp_client: Make MGCP_CLIENT_LOCAL_ADDR_DEFAULT IPv6 compatible
237 * mgcp_client: Support validating IPv6 addresses in CRCX and MDCX commands
238 * mgcp_client: Deprecate unused IPv4-only API
239 * mgcp_client: copy back Connection Information from MDCX ACK
240 * mgw: Fix mgcp_rtp_end field description comment
241 * mgw: Initial IPv6 support
242 * mgw: Introduce VTY cmd 'rtp bind-ip-v6' command
243 * mgw: Find and store RTP conn local_addr once during CRCX handling
244 * mgw: Announce and rebind new local address if change required during MDCX
245 * mgw: osmux: Avoid sending packets on recvonly connection
246 * mgw: Release endpoint after last conn times out
247 * mgw: osmux: Fix conn watchdog timeout not updated
248 * mgw: Don't be case-sensitive when parsing X-Osmo-IGN param
249 * cosmetic: Fix typo in comment
250 * mgw: Avoid logging notice message each time we receive nt param in LCO
251 * mgw: Fix return value documentation for API mgcp_verify_call_id
252 * cosmetic: Fix typo in comment
253 * contrib/jenkins: Enable parallel make in make distcheck
254 * .gitignore: Ignore new autofoo tmp files
255 * tests: Replace deprecated API log_set_print_filename
256
257 [ Oliver Smith ]
258 * contrib: import RPM spec
259 * contrib: integrate RPM spec
260 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
261 * contrib/jenkins: don't build osmo-gsm-manuals
262 * configure.ac: set -std=gnu11
263
264 [ Vadim Yanitskiy ]
265 * libosmo-mgcp-client: fix use-after-free in mgcp_client_tx()
266 * libosmo-mgcp-client: fix use-after-free in mgcp_msg_gen()
267 * libosmo-mgcp: fix unsigned compared against 0 in mgcp_trunk_by_name()
268 * libosmo-mgcp: fix unused extra argument to printf() in add_fmtp()
269 * libosmo-mgcp: always check result of msgb_printf() in add_fmtp()
270 * libosmo-mgcp-client: mgcp_client_tx(): return rc on error
271 * debian/control: change maintainer to the Osmocom team / mailing list
272 * vty: use install_lib_element() and install_lib_element_ve()
273 * main: add --vty-ref-mode, use vty_dump_xml_ref_mode()
274 * fixup mgcp_trunk: increase default number of virtual endpoints
275
276 [ Alexander Couzens ]
277 * configure.ac: require libosmoabis + libosmotrau >= 1.0.0
278
279 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 23 Feb 2021 18:28:45 +0100
280
Pau Espin Pedrolec450682020-01-03 13:35:10 +0100281osmo-mgw (1.7.0) unstable; urgency=medium
282
283 [ Neels Hofmeyr ]
284 * rename codecs_cmp() to codecs_same()
285 * mgcp_codec: constify 'param' arg
286 * fix crashes: don't assert on incoming RTP packet size
287 * mgcp_send(): stop looping on conversion error
288 * mgcp_codec: split codec_free() off of codec_init()
289 * fix memleak: actually free strings in mgcp_codec_reset_all()
290 * mgcp_test: extend / rewrite test_mgcp_codec_pt_translate()
291 * test_mgcp_codec_pt_translate(): more tests
292 * differentiate AMR octet-aligned=0 vs =1
293 * ptmap: implicitly match '/8000' and '/8000/1'
294 * mgcp_codec: codec_set(): log about all possible errors
295 * mgcp_codec_add: fix audio_name size check
296 * explicitly free codecs in mgcp_rtp_conn_cleanup()
297 * tweak mgcp_parse_audio_ptime_rtpmap()
298 * SDP: store all ptmap entries
299 * mgcp_client_fsm cleanup: Do not assert on DLCX failure
300 * clear pending requests on MGCP failure
301 * client: endp fsm: add notify struct, prep for cancel-notify
302 * client: endp fsm: clear ci[] before dispatching DLCX success
303 * client: endp fsm: allow cancelling a notify event
304 * client: endp fsm: add osmo_mgcpc_ep_ci_ep()
305 * accept MGCP without SDP
306 * fix use-after-free: require new fsm deferred dealloc, check for term
307
308 [ Pau Espin Pedrol ]
309 * mgcp_test: Correctly release all endpoints allocated
310 * mgw: Allocate mgcp_conn instance under tcfg->endpoints
311
312 [ Harald Welte ]
313 * manual: Fix copy+paste error
314 * mgcp_client: Check for osmo_fsm_register() error return value
315 * Move fsm_mgcp_client regstration to __attribute__((contructor))
316 * exit(2) on unsupported positional arguments on command line
317
318 [ Oliver Smith ]
319 * osmoappdesc.py: switch to python 3
320
321 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 13:35:09 +0100
322
Pau Espin Pedrol50e52e42019-08-07 16:52:58 +0200323osmo-mgw (1.6.0) unstable; urgency=medium
324
325 [ Oliver Smith ]
326 * Cosmetic: fix spaces/tabs in mgcp_requests[]
327 * Inactive connection cleanup (disabled by default)
328 * debian: create -doc subpackage with pdf manuals
329 * vty: allow 0 as conn-timeout to disable it
330 * vty: update desc of conn-timeout
331 * manuals: update VTY documentation
332 * "make dist" fix for: no rule to make mgcp_common.h
333 * contrib/jenkins.sh: run "make maintainer-clean"
334
335 [ Philipp Maier ]
336 * Add option to GSM HR frames to RFC5593 representation
337 * mgcp_sdp: cosmetic: correct typo in comment
338 * mgco_client: cosmetic: remove excess whitespace
339 * mgcp_sdp: mgcp_sdp.c does not include own header file
340 * mgcp_sdp: untangle parsing of a= parameters
341 * mgcp_network: use mgcp_rtp_codec in downlink format callback
342 * AMR: Add function to convert between bw-effient and octet aligned mode
343
344 [ Neels Hofmeyr ]
345 * log: don't spam with "can not patch PT" messages
346 * mgcp client: allow setting conn mode for CRCX and MDCX
347 * make codec_table public as osmo_mgcpc_codec_names
348 * move MGW endpoint FSM from osmo-bsc to here
349 * fix: multiple initial CRCX
350 * constify map_codec_to_pt() ptmap arg
351
352 [ Pau Espin Pedrol ]
353 * mgcp-client: whitespace cleanup in mgcp_client.c
354 * mgcp-client: Sanitize implementation of mgcp_client_rtpbridge_wildcard
355 * libosmo-mgcp: Use trunk type during endpoint allocation
356 * cosmetic: Fix typos in comment
357 * cosmetic: tests: mgcp_client_test: clean trailing whitespace
358 * mgcp_msg: Log faulty line on Osmux parsing error
359 * cosmetic: handle_modify_con: Fix indentation level
360 * Introduce log fmt helpers LOGPENDP and LOGPCONN
361 * create_response_with_sdp: Fix inclusion of X-Osmux
362 * osmux: Cleanup of CID alloc pool APIs
363 * mgcp_osmux.c: osmux_enable_endpoint: Fix incorrect return check
364 * osmux: Log osmux socket during osmux_init
365 * mgcp-cli: Change osmo_mgcpc_ep_fsm name to avoid collision with old osmo-bsc
366 * osmux: Document func and return different rc upon osmux init failure
367 * osmux: Fix reception of legacy dummy payloads
368 * osmux: Use LOGPCONN in several log calls
369 * cosmetic: mgcp_udp_send: Document port param is in network byte order
370 * cosmetic: osmux: Document network byte order in port variable
371 * vty: Allow enabling Osmux
372 * osmux: Allocate CID during CRCX
373 * osmux: Introduce mgcp_conn_rtp_is_osmux() helper
374 * osmux: Mark conn_rtp->type as osmux during CRCX
375 * mgcp-cli: Allow submitting X-Osmux on CRCX request
376 * mgcp-cli: Parse X-Osmux on CRCX response
377 * osmux: Handle Osmux MGCP extension in MDCX messages
378 * mgcp-cli: Allow submitting X-Osmux on MDCX request
379 * mgcp-cli: Parse X-Osmux on MDCX response
380 * osmux: Drop unneeded OSMUX_STATE_NEGOTIATING
381 * mgcp-cli: endpoint_fsm: Add API to retrieve Osmux CID from MGW
382 * osmux: Provide correct local port during mgcp resp
383 * osmux: Use remote port to send osmux frames
384 * osmux: Improve logging around osmux enabling events
385 * osmux: Delay osmux enable of conn until remote addr is configured by MDCX
386 * osmux: Redo read/write osmux glue code to have data routed correctly
387 * mgw, mgcp-li: Handle X-Osmux param name as case insensitive
388 * osmux: Use DUMMY ft msg as per Osmux spec
389 * osmux: Fix loopback for Osmux connections
390 * osmux: Fix CID release for non-enabled connections
391 * osmux: Fix hardcoded rtp payload_type 98 in osmux conn
392 * mgcp-cli: Validate osmux cid value during mgcp_msg_gen
393 * mgw: Support uppercase LCO options
394 * mgw: Support lowercase header parameters
395 * mgcp-cli: Support lowercase header parameters
396 * mgw: Support receiving uppercase connection mode
397 * mgw: Support receiving lowercase LCO codec
398 * mgw: Make check of duplicated LCO fields case insensitive
399 * mgw: Allow receiving lowercase MGCP header keyword
400 * mgw: Allow receiving lowercase X-Osmo-Ign Callid field
401 * mgw: Allow receiving uppercase noanswer keyword
402 * doc: X-Osmo-IGN: small formatting and typo fixes
403 * doc: Add Osmux documentation to OsmoMGW User Manual
404 * Catch unsigned integer MGCP parsing errors with strtoul
405 * Fix return variable of strtoul()
406 * Remove undefined param passed to {logging,osmo_stats}_vty_add_cmds
407 * configure.ac: Require libosmo-netif 0.6.0
408
409 [ Alexander Couzens ]
410 * mgcp_internal: LOGPENDP: ensure *endp is not NULL
411
412 [ Harald Welte ]
413 * handle NULL return of rate_ctr_group_alloc()
414 * update .gitignore
415 * mgcp_sdp: Don't check if an unsigned int is below 0
416
417 [ Vadim Yanitskiy ]
418 * configure.ac: drop useless check for -fvisibility=hidden
419
420 [ Daniel Willmann ]
421 * manuals: Add script to regenerate vty/counter documentation
422 * manuals: Update vty/counter documentation
423
424 [ Hoernchen ]
425 * turn -Werror=null-dereference into a warning
426
427 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 16:52:58 +0200
428
Harald Weltee81c1172019-01-20 15:02:19 +0100429osmo-mgw (1.5.0) unstable; urgency=medium
430
431 [ Pau Espin Pedrol ]
432 * gitignore: Filter *.pc
433 * configure: Find correct libgsm's gsm.h header
434 * vty: Fix typo writing bts-jitter-buffer-delay-{min,max}
435 * Remove libosmo-legacy-mgcp and osmo-bsc-mgcp
436 * debian: Remove dangling symlink to osmo-bsc-mgcp.service
437 * Install systemd services with autotools
438 * Install sample cfg file to /etc/osmocom
439 * mgcp: Fix osmux_cid_bitmap static array size calculation
440 * mgcp_osmux: Use define to calculate rtp_ssrc_winlen
441 * osmux: Avoid initing output without enabling osmux
442 * mgcp: Log endpoint nr consistently as hex
443 * osmux_send_dummy: Avoid logging incorrectly and sending if osmux not enabled
444 * osmux: Don't process regular osmux frames if disabled by cfg
445 * osmux: Move parse_cid of legacy dummy frames to own function
446 * osmux: Make func handling dummy frames independent of endp type
447 * osmux: allow enabling osmux only on correct activating state
448 * osmux: Improve checks around activating and using enabled osmux
449 * osmux.h: Document enum osmux_state
450 * osmux: Avoid processing further frames if conn not found
451
452 [ Philipp Maier ]
453 * mgcp_client_fsm: allow ptmap in mgcp_client_fsm as well
454 * mgcp_network: translate payload type numbers in RTP packets
455 * mgcp_client: use IETF source port as for MGCP
456 * mgcp_client: increment local port number when port is in use
457 * mgcp_test: release endpoints after use
458 * network: do not patch PT of RTCP packets
459 * network: check packets before further processing
460 * Cosmetic: remove misplaced line break
461 * mgcp_sdp: restructure mgcp_write_response_sdp() (rtpmap)
462 * mgcp_sdp: restructure mgcp_write_response_sdp() (audio)
463 * mgcp_client: check local port only once
464 * mgcp_client_fsm: switch to MGCP_CONN_RECV_SEND in add_audio()
465 * mgcp_protocol: increase buffer space for codec name in LCO
466 * osmo-mgw: Add vty reference manual
467
468 [ Neels Hofmeyr ]
469 * fix handling of "Wrong domain name" error
470 * interpret domain '*' as 'allow any domain'
471 * cosmetic: log: fix "CallIDs does not match"
472 * fix 3G hack: allow any IP for loopback and 0.0.0.0
473 * cosmetic: drop code dup in mgcp_client_fsm.c CRCX
474 * add X-Osmo-IGN MGCP header to ignore CallID
475 * X-Osmo-IGN: rather parse items by token, not char
476 * mgcp_test: fix log of conn_id presence
477 * mgcp_test: fix get_conn_id_from_response() CI length
478 * mgcp_client_test: cosmetically re-arrange reply_to() args
479 * mgcp_client_test: use "\r\n\r\n" instead of "\n\n"
480 * mgcp_client_test: also verify received conn_id
481 * mgcp_client_test: test long conn_id
482 * mgcp_client: error on too long conn id
483 * mgcp_common: rename to MGCP_CONN_ID_MAXLEN
484 * doc: fix mgcp_verify_ci() return val doc
485 * mgcp_verify_ci(): return meaningful error codes
486 * fix mgcp_verify_ci(): off-by-one in max len check
487 * generate shorter 'I:' conn IDs
488 * mgcp_conn_get(): compare conn Id ('I:') case insensitively
489 * mgcp_conn_get(): match conn Id ('I:') despite leading zeros
490 * cosmetic: mgcp_test: fix get_conn_id_from_response()
491 * comment: indicate struct type for mgcp_endpoint.conns
492 * log: avoid logging early media as error
493 * fix osmo-mgw -s; fixes osmo-mgw.service using -s
494 * Importing history from osmo-gsm-manuals.git
495 * OsmoMGW: update VTY reference
496 * OsmoMGW: document the 'X-Osmo-IGN' MGCP extension
497 * mgw: update vty reference
498 * drop/replace very weird logging in mgcp_client.c
499 * check_rtp: on IP:port errors, log the IP and port
500 * osmo-mgw: err-log: include expected domain name
501 * mgcp_client_vty: fix missing talloc_free
502 * mgcp_client: drop a bunch of dead code
503 * mgcp_client: logging tweaks
504 * mgcp_client: make domain part of endpoint configurable
505 * mgcp_client: tweak some log levels INFO -> {DEBUG,ERROR}
506
507 [ Stefan Sperling ]
508 * add VTY commands which show specific mgcp endpoints
509 * add MGCP CRCX command statistics to osmo-mgw
510 * show RTP TX/RX stats in 'mgcp show stats' output
511 * use local variable for rate counters in handle_create_con()
512 * add more mgcp crxc error counters
513 * add MDCX command statistics to osmo-mgw
514 * add aggregated rtp connection stats to osmo-mgw
515 * add DLCX command statistics to osmo-mgw
516
517 [ Harald Welte ]
518 * debian/rules: Don't overwrite .tarball-version
519 * check_rtp_origin(): Don't memcmp sockadd_in and in_addr
520 * check_rtp_origin(): Avoid using memcmp for comparing integer types
521 * vty-ref: Update URI of docbook 5.0 schema
522
523 [ Daniel Willmann ]
524 * mgw: Add new VTY reference
525 * Add initial OsmoMGW manual
526
527 [ Oliver Smith ]
528 * build manuals moved here from osmo-gsm-manuals.git
529 * jenkins.sh: remove leftover MGCP env variable
530 * Fix DISTCHECK_CONFIGURE_FLAGS override
531 * contrib/jenkins.sh: build and publish manuals
532 * contrib: fix makedistcheck with disabled systemd
533
534 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 15:02:18 +0100
535
Pau Espin Pedrol304b3eb2018-07-27 19:05:23 +0200536osmo-mgw (1.4.0) unstable; urgency=medium
537
538 [ Philipp Maier ]
539 * network: independently initalize state->out_stream
540 * stats: use libosmocore rate counter for in/out_stream.err_ts_counter
541 * mgcp_sdp: correct apidoc of mgcp_parse_sdp_data
542 * vty: clean up rtp port-range command
543 * sdp: remove unused alt_codec field from struct mgcp_rtp_end
544 * sdp: remove circular inclusion
545 * protocol: Try whole port range on port allocation
546 * client: do not start connections in loopback mode
547 * mgcp_network: do not log destination invalid ip/port as error
548 * cosmetic: fix log output
549 * conn: call talloc_free before setting the pointer to NULL
550 * protocol: do not change LCO, when no LCO are present
551 * protocol: reject illegal lco options
552 * cosmetic: fix typo
553 * mgw: clean up codec negotiation (sdp)
554 * client: add features to generate and parse codec information
555 * mgcp_internal: remove unused struct member
556 * stats: replace packet statistic counters with libosmocore rate counters
557 * stat+vty: fix printing of rate counter values
558 * protocol: prevent unnecessary null pointer deref
559
560 [ Pau Espin Pedrol ]
561 * legacy-mgcp: Add jitter buffer on the uplink receiver
562 * legacy-mgcp: switch to new osmux output APIs
563 * mgcp: mgcp_osmux: use conn_bts when forwarding pkts from bsc_nat
564 * mgcp: switch to new osmux output APIs
565 * debian: Package installed example doc files
566 * gitignore: Add m4 scripts from m4 subdir
567
568 [ Neels Hofmeyr ]
569 * api doc: fix parameter name for mgcp_conn_create()
570 * mgcp-client: add mgcp_conn_get_ci()
571 * mgcp_client_fsm: improve error logging
572 * cosmetic: fix doxygen comment markers
573 * cosmetic: mgcp_network.c: merge one LOGPC to its preceding LOGP
574 * IuUP hack: make RTP patching less general
575
576 [ Harald Welte ]
577 * cosmetic: fix typo in log message: 'abrupt' instead of 'aprupt'
578
579 [ Daniel Willmann ]
580 * git-version-gen: Don't check for .git directory
581
582 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 27 Jul 2018 19:05:22 +0200
583
Pau Espin Pedrold761d352018-05-03 17:40:35 +0200584osmo-mgw (1.3.0) unstable; urgency=medium
585
586 [ Pau Espin Pedrol ]
587 * contrib: Add osmo-mgw systemd service
588 * legacy: mgcp_protocol: Don't print osmux stats if it is off
589 * mgcp_stat: Don't print osmux stats if it is off
590
591 [ Neels Hofmeyr ]
592 * fix segfault: DLCX for unknown endpoint: dont try to log NULL endpoint
593 * MGCP endpoints: parse as decimal, not hex
594 * add --enable-sanitize config option
595 * legacy_mgcp: mgcp_test: sanitize: free msgb_ctx
596 * mgcp_test: test_packet_error_detection: sanitize: free all conns
597 * mgcp_test: test_no_cycle: sanitize: free endp
598 * mgcp_test: sanitize: free msgb_ctx
599 * mgcp_client: don't configure "bts base"
600 * Revert "mgcp_client: don't configure "bts base"" until osmo-msc is ready
601 * mgcp_client: add transaction cleanup
602 * mgcp_client_test makefile: add update_exp target
603 * cosmetic: mgcp_network: typo in log
604 * osmo-mgw: Add talloc context introspection via VTY
605 * mgcp_client: show failure by MGCP SDP section parsing test
606 * mgcp_client: cosmetic: clean up SDP params parsing
607 * mgcp_client: detect SDP section-start parsing errors
608 * compiler warning: ignore deprecated in mgcp_client_test.c
609 * configure: add --enable-werror
610 * jenkins.sh: add --enable-werror to configure flags
611 * cosmetic: mgcp, legacy_mgcp: drop unused vty.h definitions
612 * use osmo_init_logging2() with proper talloc ctx
613
614 [ Philipp Maier ]
615 * osmux: fix nullpointer dereference
616 * cosmetic: guard dead osmux vty code with ifdef
617 * cosmetic: remove prefix "net" from rtp related vty commands
618 * doc: update sample config file
619 * cosmetic: use correct VTY port number constant
620 * vty: simplify endpoint allocation
621 * vty: do not change number_endpoints at runtime
622 * MGCP: Connection Identifiers are hex strings
623 * libosmo-mgcp: Connection Identifiers are allocated by MGW, not CA
624 * client: use osmo_strlcpy instead of strncpy
625 * cosmetic: fix sourcecode formatting
626 * cosmetic: clearly mark endpoint numbers as hex
627 * client: use string as connection identifier
628 * conn: remove assertions
629 * mgcp_test: fix wrong strcmp() parameters
630 * mgcp_test: fix nullpointer dereference
631 * mgcp_test: add returncode check
632 * mgcp_test: fix possible double free
633 * mcgp_client: mgcp_msg_gen(): add checks to verify params
634 * network: use originating RTP packet address for loopback
635 * client: mgcp_response_parse_params: check rtp port
636 * mgcp: allow endpoints beginning from zero
637 * client/common: move constant MGCP_ENDPOINT_MAXLEN
638 * mgcp: make domain name configurable
639 * cosmetic: protocol: remove unnecessary nul termination
640 * client: do not insist on \n\n when parsing MGCP messages
641 * main: display mgcp ip/port
642 * client: make callid in MDCX mandatory
643 * client: add missing mandatory SDP fields
644 * mgcp: permit wildcarded endpoint assignment (CRCX)
645 * mgcp: add prefix to virtual trunk
646 * client: eliminate destructive parameter parsing
647 * client: eliminate destructive head parsing
648 * cosmetic: client: add doxygen comments
649 * protocol: fix problem with line break and OSMUX
650 * protocol: fix missing carriage return
651 * client: fix sdp parameter ordering
652 * protocol: check the packetization in local cx options
653 * cosmetic: remove spaces from pointer symbol
654 * client: Do not accept endpoint ids with wildcards in responses
655 * client: do not accept endpoint ids without @ character in responses
656 * client: prohibit endpoint ids without @ character
657 * protocol: on wildcarded CRCX return endpoint number as hex
658 * msg: fix response code on exhausted endp resources
659 * cosmetic: move mgcp_release_endp() to mgcp_ep.c
660 * client: use heap to store mgcp_response
661 * ep: move endpoint struct and define to mgcp_ep.h
662 * cosmetic: rename mgcp_release_endp to mgcp_endp_release
663 * cosmetic: rename mgcp_ep.c/h to mgcp_endp.c/h
664 * protocol: reject DLCX/CRCX/MDCX on unsupported parameters
665 * protocol: exit cleanly when local cx options check fails
666 * cosmetic: Add missing \n on log line
667 * protocol: check requested connection mode
668 * protocol: fix tagging of wildcarded requests
669 * protocol: prohibit wildcarded requests for MDCX and DLCX
670 * mgcp: fix use-after-free and add callback for endpoint cleanup
671 * client: add an optional FSM interface
672 * mgcp_client_fsm: Add FSM event names
673 * cosmetic: mgcp_client_fsm: rename enums
674 * cosmetic: rename function .._conn_reset() to .._conn_init()
675 * mgcp_conn: do not touch u.rtp in mgcp_conn_alloc()
676 * cosmetic: rename .._codec_reset() to .._codec_init()
677 * mgcp_conn: add function mgcp_rtp_conn_cleanup()
678 * stats: use libosmocore rate counter for in/out_stream.err_ts_counter
679
680 [ Alexander Couzens ]
681 * debian/control: correct library dependency of osmo-mgw against libosmo-mgcp1
682 * debian: include systemd service osmo-mgw.service
683 * Revert "stats: use libosmocore rate counter for in/out_stream.err_ts_counter"
684
685 [ Harald Welte ]
686 * cosmetic: fix whitespaces; we use tabs for indentation
687 * Fix possible buffer overflow in mgcp_conn_dump()
688 * osmo-mgw: Update copyright statement
689 * osmo-mgw: Config file is osmo-mgw.cfg, and not mgcp.cfg
690 * osmo-mgw: Fix copyright notice
691 * strct mgcp_rtp_state: Group + document struct members related to patching
692 * mgcp_rtp_state: grup 'stats' members into sub-structure
693 * mgcp_rtp_end: Group statistics members into 'stats' sub-struct
694 * libosmo-mgcp: Cosmetic spelling fixes in comments
695 * mgcp_msg: We must parse endpoint numbers as hex, not decimal!
696 * mgcp_internal.h: document more struct members with comments
697 * centralize handling of common errors like "endpoint not found"
698 * Return proper MGCP Error codes, as per spec
699 * osmo-mgw: Use libosmocore socket abstraction
700 * osmo-bsc_mgcp: Add LIBOSMONETIF_{CFLAGS,LIBS}
701 * libosmo-mgcp-client is GPLv2+, not AGPLv3+
702 * Turn libosmo-mgcp into local, non-installed library
703
704 [ Stefan Sperling ]
705 * enable osmo_fsm vty commands in libosmo-mgcp-client vty
706
707 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 17:40:35 +0200
708
Harald Weltee7d27ae2017-11-10 11:21:40 +0900709osmo-mgw (1.2.0) unstable; urgency=medium
710
711 [ Neels Hofmeyr ]
712 * jenkins: use osmo-clean-workspace.sh before and after build
713 * vty: skip installing cmds now always installed by default
714 * mgcp-client vty: use name 'mgw' instead of 'mgcpgw'
715 * mgcp client: vty: tweak doc strings
716
717 [ Philipp Maier ]
718 * sdp: refactoring sdp parser/generator
719 * cosmetic: rename bts_codec to codec_str
720 * cosmetic: fix coding style for mgcp_parse_sdp_data()
721 * cosmetic: fix commenting style
722 * cosmetic: correct whitespaces
723 * client: fix stderror logging in unit-test
724 * client: add unified function to generate MGCP messages
725 * client: add ip address parsing to the client
726 * protocol: allow wildcarded DLCX
727 * mgcp: remove port/timeslot calculator functions from mgcp.h
728 * network: add separate log category
729 * cosmetic: make dummy packet handling more explicit
730 * network: autdetect rtp bind ip-address
731 * network: fix rtp packet length
732 * network: remove unused return code
733
734 [ Pau Espin Pedrol ]
735 * mgcp_client_vty.c: Fix VTY compatibility with 'mgcpgw bts-base'
736
737 -- Harald Welte <laforge@gnumonks.org> Fri, 10 Nov 2017 11:10:23 +0900
738
Harald Welte1ae2d5e2017-10-28 12:48:42 +0200739osmo-mgw (1.1.0) unstable; urgency=medium
740
741 * New upstream release
742
743 -- Harald Welte <lafore@gnumonks.org> Sat, 28 Oct 2017 12:48:41 +0200
744
Maxf19acc92017-09-14 18:35:06 +0200745osmo-mgw (1.0.2) unstable; urgency=low
746
747 * First release after major rename.
748
749 -- Max Suraev <msuraev@sysmocom.de> Thu, 14 Sep 2017 18:41:05 +0200
750
751
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000752osmo-mgw (0.1.0) unstable; urgency=low
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200753
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000754 * Initial release.
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200755
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000756 -- Alexander Couzens <lynxis@fe80.eu> Tue, 08 Aug 2017 01:12:53 +0000