blob: a2f5c4a3ce26718c7c81914b7b57ccbf723d65ad [file] [log] [blame]
Harald Welte9ffaba72021-02-24 10:56:17 +01001osmo-mgw (1.8.1) unstable; urgency=medium
2
3 * attempt to fix RPM spec file after recent soversion bump
4
5 -- Harald Welte <laforge@osmocom.org> Wed, 24 Feb 2021 10:56:17 +0100
6
Pau Espin Pedrol6ccdaa22021-02-23 18:28:45 +01007osmo-mgw (1.8.0) unstable; urgency=medium
8
9 [ Harald Welte ]
10 * Fix number of endpoints of default trunk
11 * Add CTRL interface to osmo-mgw
12 * Update per-trunk global packet/byte counters in real-time
13 * remove accidential TODO-RELEASE entry
14 * mgcp_protocol: Avoid code duplication between virtual + other trunks
15 * osmo-mgw.spec.in: Use %config(noreplace) to retain current config file
16 * mgcp_client_init(): consider "talloc returns NULL" case
17 * mgcp_client_pending_add(): Consider "talloc returns NULL" case
18 * libosmo-mgcp-client: fix memleak in case if no response is received
19 * debian/control + SPEC: Add missing build dependency to libosmo-abis
20 * osmo-mgw.spec.in: Fix dependency to libosmoabis
21 * osmo-mgw.spec.in: Add missing dependency to libosmotrau
22 * Add example osmo-mgw configuration file for Abis/E1
23 * use osmo_fd_setup() whenever applicable
24
25 [ Neels Hofmeyr ]
26 * fix vty dump_trunk: start from zero, do not omit first CONN
27 * allow larger MGCP client wqueue: 10 -> 1024
28 * add osmo-mgw --vty-ref-xml: dump VTY ref XML to stdout
29 * manuals: generate vty reference xml at build time
30 * refactor: use msgb to receive, pass and send RTP packets
31 * change timer T2427001 to X2427
32
33 [ Philipp Maier ]
34 * doc: do not bind osmo-mgw to random ip-address
35 * cosmetic: remove excess newlines
36 * mgcp: remove unused callback pointer
37 * mgcp: find better locations for LOGPCONN and LOGPENDP
38 * vty: fix unreachable code (error msg on trunk alloc fail)
39 * mgcp_vty: fix indentation
40 * osmo-mgw: rename struct mgcp_trunk_config and symbol tcfg
41 * mgcp_vty: fix indentation in VTY config write
42 * osmo-mgw: refactor endpoint and trunk handling
43 * mgcp_trunk: remove audio_name and audio_payload
44 * ratectr: move rate counter definitions into mgcp_ratectr.h
45 * cosmetic: fix doxygen
46 * cosmetic: fix doxygen
47 * cosmetic: fix doxygen for mgcp_cleanup_rtp_bridge_cb()
48 * trunk: get rid of virt_trunk pointer
49 * cosmetic: remove excess space
50 * endp: move endpoint name generation into mgcp_endp.c
51 * endp: add name generator function for E1 endpoints
52 * mgcp_client: add docstring for mgcp_client_rtpbridge_wildcard()
53 * mgcp_trunk: fix docstring for mgcp_trunk_alloc()
54 * mgcp_osmux: remove unused define constants
55 * mgcp_trunk: move enum mgcp_trunk_type to mgcp_trunk.h
56 * mgcp_trunk: use enum type for trunk type variable
57 * trunk: parse E1 trunk number
58 * endp: add typeset for e1-endpoints
59 * mgcp_conn: move struct mgcp_conn mgcp_conn.h
60 * mgcp_internal: remove forward declaration struct mgcp_endpoint_type
61 * endp: add E1 endpoint interlocking
62 * endp: require domain name also for E1 endpoints
63 * mgcp_trunk: pick trunk by number and type
64 * mgcp_client: add function to generate e1-endpoint names
65 * mgcp_endp: use define constant to define max number of E1 subslots
66 * mgcp_endp.c: cosmetic: fix sourcecode formatting
67 * mgcp_trunk: remove double check
68 * mgcp_test: do not access endpoint array elements directly
69 * mgcp_vty: fix endpoint number configuration
70 * mgcp_test: remove trunk2 from unit-test
71 * mgcp_trunk: use talloc_zero_array instead of _talloc_zero_array
72 * mgcp_protocol: remove unused variable
73 * mgcp_e1: finish E1 support, add E1 support from libosmoabis
74 * get rid of mgcp_internal.h
75 * mgcp_ratectr: fix comments in header file
76 * mgcp_e1: use return value of e1inp_line_update()
77 * mgcp_protocol: log when endpoint is unavailable
78 * cosmetic: add missing new-line
79 * mgcp_trunk: drop "trunk 0" limitation
80 * mgcp_e1: make E1 ts initalization more debugable
81 * mgcp_e1: remove unused struct member trunk->e1.line
82 * mgcp_endp: use NUM_E1_TS from e1_input.h
83 * mgcp_trunk: increase default number of virtual endpoints
84 * cosmetic: mgcp_client_fsm: change error message.
85 * mgcp_vty: remove remains of loopback functionality
86 * mgcp_vty: deprecate bind early command
87 * mgcp_e1: do not expose function mgcp_e1_init()
88 * mgcp_vty: add user attributes to configuration commands
89 * overview: update section limitations.
90 * overview: fix graph "OsmoMGW used with OsmoBSC"
91 * overview: fix graph "OsmoMGW used with OsmoMSC"
92 * overview: add graph to show E1 integration
93 * configuration: remove hint towards trunk 0 limit
94 * configuration: drop note about lackin E1 support
95 * configuration: add note that changes to trunks need a restart
96 * mgcp_vty: fix config write for trunk 0
97 * mgcp_vty: add missing VTY commands for E1 trunks
98 * mgcp_trunk: get rid of magic numbers for E1 slots
99 * configuration: add section about E1 trunks
100 * usermanual: add chapter about mgcp endpoints
101 * mgcp_client: get rid of magic numbers for E1 slots
102
103 [ Eric ]
104 * tests: dlopen does not imply availability of dlsym..
105 * configure.ac: fix libtool issue with clang and sanitizer
106
107 [ Alexander Chemeris ]
108 * vty: Prepend VTY output of counters for better visual separation.
109 * counters: Implement more useful counters.
110 * mgcp_network: Fix a typo in the comment bahviour -> behaviour
111 * rtp_bridge: Demote a chatty ERROR log message to DEBUG level.
112
113 [ Pau Espin Pedrol ]
114 * Use OSMO_FD_* instead of deprecated BSC_FD_*
115 * Support setting rt-prio and cpu-affinity mask through VTY
116 * cosmetic: Rename main talloc ctx
117 * mgcp-client: Support IPv6 in osmo_mgcpc_ep_ci_get_crcx_info_to_sockaddr() implementation
118 * mgcp-client: Fix trailing whitespace in mgcp_client_fsm.h
119 * mgcp_client: Use INET6_ADDRSTRLEN to store addresses in str format
120 * mgcp_client: Allow submitting and parsing IPv6 addr in SDP
121 * mgcp_client: Allow setting IPv6 addresses
122 * mgcp_client: Make MGCP_CLIENT_LOCAL_ADDR_DEFAULT IPv6 compatible
123 * mgcp_client: Support validating IPv6 addresses in CRCX and MDCX commands
124 * mgcp_client: Deprecate unused IPv4-only API
125 * mgcp_client: copy back Connection Information from MDCX ACK
126 * mgw: Fix mgcp_rtp_end field description comment
127 * mgw: Initial IPv6 support
128 * mgw: Introduce VTY cmd 'rtp bind-ip-v6' command
129 * mgw: Find and store RTP conn local_addr once during CRCX handling
130 * mgw: Announce and rebind new local address if change required during MDCX
131 * mgw: osmux: Avoid sending packets on recvonly connection
132 * mgw: Release endpoint after last conn times out
133 * mgw: osmux: Fix conn watchdog timeout not updated
134 * mgw: Don't be case-sensitive when parsing X-Osmo-IGN param
135 * cosmetic: Fix typo in comment
136 * mgw: Avoid logging notice message each time we receive nt param in LCO
137 * mgw: Fix return value documentation for API mgcp_verify_call_id
138 * cosmetic: Fix typo in comment
139 * contrib/jenkins: Enable parallel make in make distcheck
140 * .gitignore: Ignore new autofoo tmp files
141 * tests: Replace deprecated API log_set_print_filename
142
143 [ Oliver Smith ]
144 * contrib: import RPM spec
145 * contrib: integrate RPM spec
146 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
147 * contrib/jenkins: don't build osmo-gsm-manuals
148 * configure.ac: set -std=gnu11
149
150 [ Vadim Yanitskiy ]
151 * libosmo-mgcp-client: fix use-after-free in mgcp_client_tx()
152 * libosmo-mgcp-client: fix use-after-free in mgcp_msg_gen()
153 * libosmo-mgcp: fix unsigned compared against 0 in mgcp_trunk_by_name()
154 * libosmo-mgcp: fix unused extra argument to printf() in add_fmtp()
155 * libosmo-mgcp: always check result of msgb_printf() in add_fmtp()
156 * libosmo-mgcp-client: mgcp_client_tx(): return rc on error
157 * debian/control: change maintainer to the Osmocom team / mailing list
158 * vty: use install_lib_element() and install_lib_element_ve()
159 * main: add --vty-ref-mode, use vty_dump_xml_ref_mode()
160 * fixup mgcp_trunk: increase default number of virtual endpoints
161
162 [ Alexander Couzens ]
163 * configure.ac: require libosmoabis + libosmotrau >= 1.0.0
164
165 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 23 Feb 2021 18:28:45 +0100
166
Pau Espin Pedrolec450682020-01-03 13:35:10 +0100167osmo-mgw (1.7.0) unstable; urgency=medium
168
169 [ Neels Hofmeyr ]
170 * rename codecs_cmp() to codecs_same()
171 * mgcp_codec: constify 'param' arg
172 * fix crashes: don't assert on incoming RTP packet size
173 * mgcp_send(): stop looping on conversion error
174 * mgcp_codec: split codec_free() off of codec_init()
175 * fix memleak: actually free strings in mgcp_codec_reset_all()
176 * mgcp_test: extend / rewrite test_mgcp_codec_pt_translate()
177 * test_mgcp_codec_pt_translate(): more tests
178 * differentiate AMR octet-aligned=0 vs =1
179 * ptmap: implicitly match '/8000' and '/8000/1'
180 * mgcp_codec: codec_set(): log about all possible errors
181 * mgcp_codec_add: fix audio_name size check
182 * explicitly free codecs in mgcp_rtp_conn_cleanup()
183 * tweak mgcp_parse_audio_ptime_rtpmap()
184 * SDP: store all ptmap entries
185 * mgcp_client_fsm cleanup: Do not assert on DLCX failure
186 * clear pending requests on MGCP failure
187 * client: endp fsm: add notify struct, prep for cancel-notify
188 * client: endp fsm: clear ci[] before dispatching DLCX success
189 * client: endp fsm: allow cancelling a notify event
190 * client: endp fsm: add osmo_mgcpc_ep_ci_ep()
191 * accept MGCP without SDP
192 * fix use-after-free: require new fsm deferred dealloc, check for term
193
194 [ Pau Espin Pedrol ]
195 * mgcp_test: Correctly release all endpoints allocated
196 * mgw: Allocate mgcp_conn instance under tcfg->endpoints
197
198 [ Harald Welte ]
199 * manual: Fix copy+paste error
200 * mgcp_client: Check for osmo_fsm_register() error return value
201 * Move fsm_mgcp_client regstration to __attribute__((contructor))
202 * exit(2) on unsupported positional arguments on command line
203
204 [ Oliver Smith ]
205 * osmoappdesc.py: switch to python 3
206
207 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 13:35:09 +0100
208
Pau Espin Pedrol50e52e42019-08-07 16:52:58 +0200209osmo-mgw (1.6.0) unstable; urgency=medium
210
211 [ Oliver Smith ]
212 * Cosmetic: fix spaces/tabs in mgcp_requests[]
213 * Inactive connection cleanup (disabled by default)
214 * debian: create -doc subpackage with pdf manuals
215 * vty: allow 0 as conn-timeout to disable it
216 * vty: update desc of conn-timeout
217 * manuals: update VTY documentation
218 * "make dist" fix for: no rule to make mgcp_common.h
219 * contrib/jenkins.sh: run "make maintainer-clean"
220
221 [ Philipp Maier ]
222 * Add option to GSM HR frames to RFC5593 representation
223 * mgcp_sdp: cosmetic: correct typo in comment
224 * mgco_client: cosmetic: remove excess whitespace
225 * mgcp_sdp: mgcp_sdp.c does not include own header file
226 * mgcp_sdp: untangle parsing of a= parameters
227 * mgcp_network: use mgcp_rtp_codec in downlink format callback
228 * AMR: Add function to convert between bw-effient and octet aligned mode
229
230 [ Neels Hofmeyr ]
231 * log: don't spam with "can not patch PT" messages
232 * mgcp client: allow setting conn mode for CRCX and MDCX
233 * make codec_table public as osmo_mgcpc_codec_names
234 * move MGW endpoint FSM from osmo-bsc to here
235 * fix: multiple initial CRCX
236 * constify map_codec_to_pt() ptmap arg
237
238 [ Pau Espin Pedrol ]
239 * mgcp-client: whitespace cleanup in mgcp_client.c
240 * mgcp-client: Sanitize implementation of mgcp_client_rtpbridge_wildcard
241 * libosmo-mgcp: Use trunk type during endpoint allocation
242 * cosmetic: Fix typos in comment
243 * cosmetic: tests: mgcp_client_test: clean trailing whitespace
244 * mgcp_msg: Log faulty line on Osmux parsing error
245 * cosmetic: handle_modify_con: Fix indentation level
246 * Introduce log fmt helpers LOGPENDP and LOGPCONN
247 * create_response_with_sdp: Fix inclusion of X-Osmux
248 * osmux: Cleanup of CID alloc pool APIs
249 * mgcp_osmux.c: osmux_enable_endpoint: Fix incorrect return check
250 * osmux: Log osmux socket during osmux_init
251 * mgcp-cli: Change osmo_mgcpc_ep_fsm name to avoid collision with old osmo-bsc
252 * osmux: Document func and return different rc upon osmux init failure
253 * osmux: Fix reception of legacy dummy payloads
254 * osmux: Use LOGPCONN in several log calls
255 * cosmetic: mgcp_udp_send: Document port param is in network byte order
256 * cosmetic: osmux: Document network byte order in port variable
257 * vty: Allow enabling Osmux
258 * osmux: Allocate CID during CRCX
259 * osmux: Introduce mgcp_conn_rtp_is_osmux() helper
260 * osmux: Mark conn_rtp->type as osmux during CRCX
261 * mgcp-cli: Allow submitting X-Osmux on CRCX request
262 * mgcp-cli: Parse X-Osmux on CRCX response
263 * osmux: Handle Osmux MGCP extension in MDCX messages
264 * mgcp-cli: Allow submitting X-Osmux on MDCX request
265 * mgcp-cli: Parse X-Osmux on MDCX response
266 * osmux: Drop unneeded OSMUX_STATE_NEGOTIATING
267 * mgcp-cli: endpoint_fsm: Add API to retrieve Osmux CID from MGW
268 * osmux: Provide correct local port during mgcp resp
269 * osmux: Use remote port to send osmux frames
270 * osmux: Improve logging around osmux enabling events
271 * osmux: Delay osmux enable of conn until remote addr is configured by MDCX
272 * osmux: Redo read/write osmux glue code to have data routed correctly
273 * mgw, mgcp-li: Handle X-Osmux param name as case insensitive
274 * osmux: Use DUMMY ft msg as per Osmux spec
275 * osmux: Fix loopback for Osmux connections
276 * osmux: Fix CID release for non-enabled connections
277 * osmux: Fix hardcoded rtp payload_type 98 in osmux conn
278 * mgcp-cli: Validate osmux cid value during mgcp_msg_gen
279 * mgw: Support uppercase LCO options
280 * mgw: Support lowercase header parameters
281 * mgcp-cli: Support lowercase header parameters
282 * mgw: Support receiving uppercase connection mode
283 * mgw: Support receiving lowercase LCO codec
284 * mgw: Make check of duplicated LCO fields case insensitive
285 * mgw: Allow receiving lowercase MGCP header keyword
286 * mgw: Allow receiving lowercase X-Osmo-Ign Callid field
287 * mgw: Allow receiving uppercase noanswer keyword
288 * doc: X-Osmo-IGN: small formatting and typo fixes
289 * doc: Add Osmux documentation to OsmoMGW User Manual
290 * Catch unsigned integer MGCP parsing errors with strtoul
291 * Fix return variable of strtoul()
292 * Remove undefined param passed to {logging,osmo_stats}_vty_add_cmds
293 * configure.ac: Require libosmo-netif 0.6.0
294
295 [ Alexander Couzens ]
296 * mgcp_internal: LOGPENDP: ensure *endp is not NULL
297
298 [ Harald Welte ]
299 * handle NULL return of rate_ctr_group_alloc()
300 * update .gitignore
301 * mgcp_sdp: Don't check if an unsigned int is below 0
302
303 [ Vadim Yanitskiy ]
304 * configure.ac: drop useless check for -fvisibility=hidden
305
306 [ Daniel Willmann ]
307 * manuals: Add script to regenerate vty/counter documentation
308 * manuals: Update vty/counter documentation
309
310 [ Hoernchen ]
311 * turn -Werror=null-dereference into a warning
312
313 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 16:52:58 +0200
314
Harald Weltee81c1172019-01-20 15:02:19 +0100315osmo-mgw (1.5.0) unstable; urgency=medium
316
317 [ Pau Espin Pedrol ]
318 * gitignore: Filter *.pc
319 * configure: Find correct libgsm's gsm.h header
320 * vty: Fix typo writing bts-jitter-buffer-delay-{min,max}
321 * Remove libosmo-legacy-mgcp and osmo-bsc-mgcp
322 * debian: Remove dangling symlink to osmo-bsc-mgcp.service
323 * Install systemd services with autotools
324 * Install sample cfg file to /etc/osmocom
325 * mgcp: Fix osmux_cid_bitmap static array size calculation
326 * mgcp_osmux: Use define to calculate rtp_ssrc_winlen
327 * osmux: Avoid initing output without enabling osmux
328 * mgcp: Log endpoint nr consistently as hex
329 * osmux_send_dummy: Avoid logging incorrectly and sending if osmux not enabled
330 * osmux: Don't process regular osmux frames if disabled by cfg
331 * osmux: Move parse_cid of legacy dummy frames to own function
332 * osmux: Make func handling dummy frames independent of endp type
333 * osmux: allow enabling osmux only on correct activating state
334 * osmux: Improve checks around activating and using enabled osmux
335 * osmux.h: Document enum osmux_state
336 * osmux: Avoid processing further frames if conn not found
337
338 [ Philipp Maier ]
339 * mgcp_client_fsm: allow ptmap in mgcp_client_fsm as well
340 * mgcp_network: translate payload type numbers in RTP packets
341 * mgcp_client: use IETF source port as for MGCP
342 * mgcp_client: increment local port number when port is in use
343 * mgcp_test: release endpoints after use
344 * network: do not patch PT of RTCP packets
345 * network: check packets before further processing
346 * Cosmetic: remove misplaced line break
347 * mgcp_sdp: restructure mgcp_write_response_sdp() (rtpmap)
348 * mgcp_sdp: restructure mgcp_write_response_sdp() (audio)
349 * mgcp_client: check local port only once
350 * mgcp_client_fsm: switch to MGCP_CONN_RECV_SEND in add_audio()
351 * mgcp_protocol: increase buffer space for codec name in LCO
352 * osmo-mgw: Add vty reference manual
353
354 [ Neels Hofmeyr ]
355 * fix handling of "Wrong domain name" error
356 * interpret domain '*' as 'allow any domain'
357 * cosmetic: log: fix "CallIDs does not match"
358 * fix 3G hack: allow any IP for loopback and 0.0.0.0
359 * cosmetic: drop code dup in mgcp_client_fsm.c CRCX
360 * add X-Osmo-IGN MGCP header to ignore CallID
361 * X-Osmo-IGN: rather parse items by token, not char
362 * mgcp_test: fix log of conn_id presence
363 * mgcp_test: fix get_conn_id_from_response() CI length
364 * mgcp_client_test: cosmetically re-arrange reply_to() args
365 * mgcp_client_test: use "\r\n\r\n" instead of "\n\n"
366 * mgcp_client_test: also verify received conn_id
367 * mgcp_client_test: test long conn_id
368 * mgcp_client: error on too long conn id
369 * mgcp_common: rename to MGCP_CONN_ID_MAXLEN
370 * doc: fix mgcp_verify_ci() return val doc
371 * mgcp_verify_ci(): return meaningful error codes
372 * fix mgcp_verify_ci(): off-by-one in max len check
373 * generate shorter 'I:' conn IDs
374 * mgcp_conn_get(): compare conn Id ('I:') case insensitively
375 * mgcp_conn_get(): match conn Id ('I:') despite leading zeros
376 * cosmetic: mgcp_test: fix get_conn_id_from_response()
377 * comment: indicate struct type for mgcp_endpoint.conns
378 * log: avoid logging early media as error
379 * fix osmo-mgw -s; fixes osmo-mgw.service using -s
380 * Importing history from osmo-gsm-manuals.git
381 * OsmoMGW: update VTY reference
382 * OsmoMGW: document the 'X-Osmo-IGN' MGCP extension
383 * mgw: update vty reference
384 * drop/replace very weird logging in mgcp_client.c
385 * check_rtp: on IP:port errors, log the IP and port
386 * osmo-mgw: err-log: include expected domain name
387 * mgcp_client_vty: fix missing talloc_free
388 * mgcp_client: drop a bunch of dead code
389 * mgcp_client: logging tweaks
390 * mgcp_client: make domain part of endpoint configurable
391 * mgcp_client: tweak some log levels INFO -> {DEBUG,ERROR}
392
393 [ Stefan Sperling ]
394 * add VTY commands which show specific mgcp endpoints
395 * add MGCP CRCX command statistics to osmo-mgw
396 * show RTP TX/RX stats in 'mgcp show stats' output
397 * use local variable for rate counters in handle_create_con()
398 * add more mgcp crxc error counters
399 * add MDCX command statistics to osmo-mgw
400 * add aggregated rtp connection stats to osmo-mgw
401 * add DLCX command statistics to osmo-mgw
402
403 [ Harald Welte ]
404 * debian/rules: Don't overwrite .tarball-version
405 * check_rtp_origin(): Don't memcmp sockadd_in and in_addr
406 * check_rtp_origin(): Avoid using memcmp for comparing integer types
407 * vty-ref: Update URI of docbook 5.0 schema
408
409 [ Daniel Willmann ]
410 * mgw: Add new VTY reference
411 * Add initial OsmoMGW manual
412
413 [ Oliver Smith ]
414 * build manuals moved here from osmo-gsm-manuals.git
415 * jenkins.sh: remove leftover MGCP env variable
416 * Fix DISTCHECK_CONFIGURE_FLAGS override
417 * contrib/jenkins.sh: build and publish manuals
418 * contrib: fix makedistcheck with disabled systemd
419
420 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 15:02:18 +0100
421
Pau Espin Pedrol304b3eb2018-07-27 19:05:23 +0200422osmo-mgw (1.4.0) unstable; urgency=medium
423
424 [ Philipp Maier ]
425 * network: independently initalize state->out_stream
426 * stats: use libosmocore rate counter for in/out_stream.err_ts_counter
427 * mgcp_sdp: correct apidoc of mgcp_parse_sdp_data
428 * vty: clean up rtp port-range command
429 * sdp: remove unused alt_codec field from struct mgcp_rtp_end
430 * sdp: remove circular inclusion
431 * protocol: Try whole port range on port allocation
432 * client: do not start connections in loopback mode
433 * mgcp_network: do not log destination invalid ip/port as error
434 * cosmetic: fix log output
435 * conn: call talloc_free before setting the pointer to NULL
436 * protocol: do not change LCO, when no LCO are present
437 * protocol: reject illegal lco options
438 * cosmetic: fix typo
439 * mgw: clean up codec negotiation (sdp)
440 * client: add features to generate and parse codec information
441 * mgcp_internal: remove unused struct member
442 * stats: replace packet statistic counters with libosmocore rate counters
443 * stat+vty: fix printing of rate counter values
444 * protocol: prevent unnecessary null pointer deref
445
446 [ Pau Espin Pedrol ]
447 * legacy-mgcp: Add jitter buffer on the uplink receiver
448 * legacy-mgcp: switch to new osmux output APIs
449 * mgcp: mgcp_osmux: use conn_bts when forwarding pkts from bsc_nat
450 * mgcp: switch to new osmux output APIs
451 * debian: Package installed example doc files
452 * gitignore: Add m4 scripts from m4 subdir
453
454 [ Neels Hofmeyr ]
455 * api doc: fix parameter name for mgcp_conn_create()
456 * mgcp-client: add mgcp_conn_get_ci()
457 * mgcp_client_fsm: improve error logging
458 * cosmetic: fix doxygen comment markers
459 * cosmetic: mgcp_network.c: merge one LOGPC to its preceding LOGP
460 * IuUP hack: make RTP patching less general
461
462 [ Harald Welte ]
463 * cosmetic: fix typo in log message: 'abrupt' instead of 'aprupt'
464
465 [ Daniel Willmann ]
466 * git-version-gen: Don't check for .git directory
467
468 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 27 Jul 2018 19:05:22 +0200
469
Pau Espin Pedrold761d352018-05-03 17:40:35 +0200470osmo-mgw (1.3.0) unstable; urgency=medium
471
472 [ Pau Espin Pedrol ]
473 * contrib: Add osmo-mgw systemd service
474 * legacy: mgcp_protocol: Don't print osmux stats if it is off
475 * mgcp_stat: Don't print osmux stats if it is off
476
477 [ Neels Hofmeyr ]
478 * fix segfault: DLCX for unknown endpoint: dont try to log NULL endpoint
479 * MGCP endpoints: parse as decimal, not hex
480 * add --enable-sanitize config option
481 * legacy_mgcp: mgcp_test: sanitize: free msgb_ctx
482 * mgcp_test: test_packet_error_detection: sanitize: free all conns
483 * mgcp_test: test_no_cycle: sanitize: free endp
484 * mgcp_test: sanitize: free msgb_ctx
485 * mgcp_client: don't configure "bts base"
486 * Revert "mgcp_client: don't configure "bts base"" until osmo-msc is ready
487 * mgcp_client: add transaction cleanup
488 * mgcp_client_test makefile: add update_exp target
489 * cosmetic: mgcp_network: typo in log
490 * osmo-mgw: Add talloc context introspection via VTY
491 * mgcp_client: show failure by MGCP SDP section parsing test
492 * mgcp_client: cosmetic: clean up SDP params parsing
493 * mgcp_client: detect SDP section-start parsing errors
494 * compiler warning: ignore deprecated in mgcp_client_test.c
495 * configure: add --enable-werror
496 * jenkins.sh: add --enable-werror to configure flags
497 * cosmetic: mgcp, legacy_mgcp: drop unused vty.h definitions
498 * use osmo_init_logging2() with proper talloc ctx
499
500 [ Philipp Maier ]
501 * osmux: fix nullpointer dereference
502 * cosmetic: guard dead osmux vty code with ifdef
503 * cosmetic: remove prefix "net" from rtp related vty commands
504 * doc: update sample config file
505 * cosmetic: use correct VTY port number constant
506 * vty: simplify endpoint allocation
507 * vty: do not change number_endpoints at runtime
508 * MGCP: Connection Identifiers are hex strings
509 * libosmo-mgcp: Connection Identifiers are allocated by MGW, not CA
510 * client: use osmo_strlcpy instead of strncpy
511 * cosmetic: fix sourcecode formatting
512 * cosmetic: clearly mark endpoint numbers as hex
513 * client: use string as connection identifier
514 * conn: remove assertions
515 * mgcp_test: fix wrong strcmp() parameters
516 * mgcp_test: fix nullpointer dereference
517 * mgcp_test: add returncode check
518 * mgcp_test: fix possible double free
519 * mcgp_client: mgcp_msg_gen(): add checks to verify params
520 * network: use originating RTP packet address for loopback
521 * client: mgcp_response_parse_params: check rtp port
522 * mgcp: allow endpoints beginning from zero
523 * client/common: move constant MGCP_ENDPOINT_MAXLEN
524 * mgcp: make domain name configurable
525 * cosmetic: protocol: remove unnecessary nul termination
526 * client: do not insist on \n\n when parsing MGCP messages
527 * main: display mgcp ip/port
528 * client: make callid in MDCX mandatory
529 * client: add missing mandatory SDP fields
530 * mgcp: permit wildcarded endpoint assignment (CRCX)
531 * mgcp: add prefix to virtual trunk
532 * client: eliminate destructive parameter parsing
533 * client: eliminate destructive head parsing
534 * cosmetic: client: add doxygen comments
535 * protocol: fix problem with line break and OSMUX
536 * protocol: fix missing carriage return
537 * client: fix sdp parameter ordering
538 * protocol: check the packetization in local cx options
539 * cosmetic: remove spaces from pointer symbol
540 * client: Do not accept endpoint ids with wildcards in responses
541 * client: do not accept endpoint ids without @ character in responses
542 * client: prohibit endpoint ids without @ character
543 * protocol: on wildcarded CRCX return endpoint number as hex
544 * msg: fix response code on exhausted endp resources
545 * cosmetic: move mgcp_release_endp() to mgcp_ep.c
546 * client: use heap to store mgcp_response
547 * ep: move endpoint struct and define to mgcp_ep.h
548 * cosmetic: rename mgcp_release_endp to mgcp_endp_release
549 * cosmetic: rename mgcp_ep.c/h to mgcp_endp.c/h
550 * protocol: reject DLCX/CRCX/MDCX on unsupported parameters
551 * protocol: exit cleanly when local cx options check fails
552 * cosmetic: Add missing \n on log line
553 * protocol: check requested connection mode
554 * protocol: fix tagging of wildcarded requests
555 * protocol: prohibit wildcarded requests for MDCX and DLCX
556 * mgcp: fix use-after-free and add callback for endpoint cleanup
557 * client: add an optional FSM interface
558 * mgcp_client_fsm: Add FSM event names
559 * cosmetic: mgcp_client_fsm: rename enums
560 * cosmetic: rename function .._conn_reset() to .._conn_init()
561 * mgcp_conn: do not touch u.rtp in mgcp_conn_alloc()
562 * cosmetic: rename .._codec_reset() to .._codec_init()
563 * mgcp_conn: add function mgcp_rtp_conn_cleanup()
564 * stats: use libosmocore rate counter for in/out_stream.err_ts_counter
565
566 [ Alexander Couzens ]
567 * debian/control: correct library dependency of osmo-mgw against libosmo-mgcp1
568 * debian: include systemd service osmo-mgw.service
569 * Revert "stats: use libosmocore rate counter for in/out_stream.err_ts_counter"
570
571 [ Harald Welte ]
572 * cosmetic: fix whitespaces; we use tabs for indentation
573 * Fix possible buffer overflow in mgcp_conn_dump()
574 * osmo-mgw: Update copyright statement
575 * osmo-mgw: Config file is osmo-mgw.cfg, and not mgcp.cfg
576 * osmo-mgw: Fix copyright notice
577 * strct mgcp_rtp_state: Group + document struct members related to patching
578 * mgcp_rtp_state: grup 'stats' members into sub-structure
579 * mgcp_rtp_end: Group statistics members into 'stats' sub-struct
580 * libosmo-mgcp: Cosmetic spelling fixes in comments
581 * mgcp_msg: We must parse endpoint numbers as hex, not decimal!
582 * mgcp_internal.h: document more struct members with comments
583 * centralize handling of common errors like "endpoint not found"
584 * Return proper MGCP Error codes, as per spec
585 * osmo-mgw: Use libosmocore socket abstraction
586 * osmo-bsc_mgcp: Add LIBOSMONETIF_{CFLAGS,LIBS}
587 * libosmo-mgcp-client is GPLv2+, not AGPLv3+
588 * Turn libosmo-mgcp into local, non-installed library
589
590 [ Stefan Sperling ]
591 * enable osmo_fsm vty commands in libosmo-mgcp-client vty
592
593 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 17:40:35 +0200
594
Harald Weltee7d27ae2017-11-10 11:21:40 +0900595osmo-mgw (1.2.0) unstable; urgency=medium
596
597 [ Neels Hofmeyr ]
598 * jenkins: use osmo-clean-workspace.sh before and after build
599 * vty: skip installing cmds now always installed by default
600 * mgcp-client vty: use name 'mgw' instead of 'mgcpgw'
601 * mgcp client: vty: tweak doc strings
602
603 [ Philipp Maier ]
604 * sdp: refactoring sdp parser/generator
605 * cosmetic: rename bts_codec to codec_str
606 * cosmetic: fix coding style for mgcp_parse_sdp_data()
607 * cosmetic: fix commenting style
608 * cosmetic: correct whitespaces
609 * client: fix stderror logging in unit-test
610 * client: add unified function to generate MGCP messages
611 * client: add ip address parsing to the client
612 * protocol: allow wildcarded DLCX
613 * mgcp: remove port/timeslot calculator functions from mgcp.h
614 * network: add separate log category
615 * cosmetic: make dummy packet handling more explicit
616 * network: autdetect rtp bind ip-address
617 * network: fix rtp packet length
618 * network: remove unused return code
619
620 [ Pau Espin Pedrol ]
621 * mgcp_client_vty.c: Fix VTY compatibility with 'mgcpgw bts-base'
622
623 -- Harald Welte <laforge@gnumonks.org> Fri, 10 Nov 2017 11:10:23 +0900
624
Harald Welte1ae2d5e2017-10-28 12:48:42 +0200625osmo-mgw (1.1.0) unstable; urgency=medium
626
627 * New upstream release
628
629 -- Harald Welte <lafore@gnumonks.org> Sat, 28 Oct 2017 12:48:41 +0200
630
Maxf19acc92017-09-14 18:35:06 +0200631osmo-mgw (1.0.2) unstable; urgency=low
632
633 * First release after major rename.
634
635 -- Max Suraev <msuraev@sysmocom.de> Thu, 14 Sep 2017 18:41:05 +0200
636
637
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000638osmo-mgw (0.1.0) unstable; urgency=low
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200639
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000640 * Initial release.
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200641
Alexander Couzensbf0ab742017-08-07 07:55:28 +0000642 -- Alexander Couzens <lynxis@fe80.eu> Tue, 08 Aug 2017 01:12:53 +0000