blob: a6a2cfc95598b891cc4d0d5880d39a0368adb5ff [file] [log] [blame]
Harald Welted4bb7ab2010-08-24 15:17:13 +02001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10#export DH_VERBOSE=1
11
Eric Butlerb5372ab2012-08-14 20:43:47 -070012DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
13DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
14VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
15
Holger Hans Peter Freythere7c18dd2016-01-18 13:30:28 +010016# Our tests want to override symbols, make it possible on Ubuntu
17export LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS | sed -e 's/-Wl,-Bsymbolic-functions//')
18
Holger Hans Peter Freyther6308c292013-12-12 12:31:18 +010019export DEB_BUILD_HARDENING=1
20
Harald Welted4bb7ab2010-08-24 15:17:13 +020021%:
Holger Hans Peter Freyther9a935e22013-08-12 11:47:12 +020022 dh $@ --with autoreconf --fail-missing
Harald Welted4bb7ab2010-08-24 15:17:13 +020023
Holger Hans Peter Freythera5007db2013-02-13 19:27:42 +010024override_dh_strip:
25 dh_strip --dbg-package=libosmocore-dbg
Harald Welted4bb7ab2010-08-24 15:17:13 +020026
Holger Hans Peter Freyther9a935e22013-08-12 11:47:12 +020027override_dh_install:
28 sed -i "/dependency_libs/ s/'.*'/''/" `find . -name '*.la'`
29 dh_install
30
Holger Hans Peter Freyther4cb8b942013-10-10 15:20:23 +020031# Print test results in case of a failure
32override_dh_auto_test:
33 dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
34
Eric Butlerb5372ab2012-08-14 20:43:47 -070035override_dh_autoreconf:
36 echo $(VERSION) > .tarball-version
37 dh_autoreconf