blob: 430babce5fe90e7613de34fb55e4d1d357b800b3 [file] [log] [blame]
Harald Welted4bb7ab2010-08-24 15:17:13 +02001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10#export DH_VERBOSE=1
11
Eric Butlerb5372ab2012-08-14 20:43:47 -070012DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
13DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
14VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
15
Harald Welted4bb7ab2010-08-24 15:17:13 +020016CFLAGS = -Wall -g
17
18%:
Eric Butlerb5372ab2012-08-14 20:43:47 -070019 dh --with autoreconf $@ --fail-missing
Harald Welted4bb7ab2010-08-24 15:17:13 +020020
21#override_dh_strip:
22# dh_strip --dbg-package=libosmocore-dbg
23
Eric Butlerb5372ab2012-08-14 20:43:47 -070024override_dh_autoreconf:
25 echo $(VERSION) > .tarball-version
26 dh_autoreconf
27
Eric Butler8dbdc4f2012-08-14 18:07:00 -070028override_dh_auto_test:
29# tests are broken...
30