add debian packaging related information

Using the debian directory in this commit, it is possible to generate
libosmocore and libosmocore-dev packages (dpkgs).
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..a81850a
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+CFLAGS = -Wall -g
+
+%:
+	dh $@ 
+
+#override_dh_strip:
+#	dh_strip --dbg-package=libosmocore-dbg
+