blob: 89abad9113a6c7134eb4380f29f75c633d02cd89 [file] [log] [blame]
Harald Welted4bb7ab2010-08-24 15:17:13 +02001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10#export DH_VERBOSE=1
11
Eric Butlerb5372ab2012-08-14 20:43:47 -070012DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
13DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
14VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
15
Harald Welted4bb7ab2010-08-24 15:17:13 +020016%:
Holger Hans Peter Freyther9a935e22013-08-12 11:47:12 +020017 dh $@ --with autoreconf --fail-missing
Harald Welted4bb7ab2010-08-24 15:17:13 +020018
Holger Hans Peter Freythera5007db2013-02-13 19:27:42 +010019override_dh_strip:
20 dh_strip --dbg-package=libosmocore-dbg
Harald Welted4bb7ab2010-08-24 15:17:13 +020021
Holger Hans Peter Freyther9a935e22013-08-12 11:47:12 +020022override_dh_install:
23 sed -i "/dependency_libs/ s/'.*'/''/" `find . -name '*.la'`
24 dh_install
25
Eric Butlerb5372ab2012-08-14 20:43:47 -070026override_dh_autoreconf:
27 echo $(VERSION) > .tarball-version
28 dh_autoreconf