blob: e1f61242dc6a27c6cbf77a09a8a50d3d1f6ba17d [file] [log] [blame]
Alexander Couzense485cdd2017-08-06 21:52:02 +00001#!/usr/bin/make -f
2
3DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
4DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
5VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
6
7# main packaging script based on dh7 syntax
8%:
9 dh $@ --with autoreconf
10
Harald Welte3f70fcd2021-01-07 10:09:40 +010011CONFIGURE_FLAGS += --with-systemdsystemunitdir=/lib/systemd/system --enable-manuals
12override_dh_auto_configure:
13 dh_auto_configure -- $(CONFIGURE_FLAGS)
14
Alexander Couzense485cdd2017-08-06 21:52:02 +000015# See https://www.debian.org/doc/manuals/developers-reference/best-pkging-practices.html#bpp-dbg
16override_dh_strip:
Pau Espin Pedrol67d32a02020-01-03 17:04:15 +010017 dh_strip -plibosmo-ranap3 --dbg-package=libosmo-ranap-dbg
Pau Espin Pedrold5d3efb2020-01-03 14:43:59 +010018 dh_strip -plibosmo-sabp0 --dbg-package=libosmo-sabp-dbg
Pau Espin Pedrold48430d2020-01-03 14:35:17 +010019 dh_strip -posmo-hnbgw --dbg-package=osmo-hnbgw-dbg
Alexander Couzens51640382017-10-11 07:11:34 +020020
21# Print test results in case of a failure
22override_dh_auto_test:
23 dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
Pau Espin Pedrola68b6822018-09-10 12:09:47 +020024
Harald Welte3f70fcd2021-01-07 10:09:40 +010025# Don't create .pdf.gz files (barely saves space and they can't be opened directly by most pdf readers)
26override_dh_compress:
27 dh_compress -X.pdf