debian: Actually build manuals; add osmo-hnbgw-doc package

for some strange reason we didn't yet build the manual in the debian
package build.

Change-Id: Id53956494144b46e78fc25a176a9b8917788d86e
diff --git a/debian/rules b/debian/rules
index c3bdf50..e1f6124 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,6 +8,10 @@
 %:
 	dh $@ --with autoreconf
 
+CONFIGURE_FLAGS += --with-systemdsystemunitdir=/lib/systemd/system --enable-manuals
+override_dh_auto_configure:
+	dh_auto_configure -- $(CONFIGURE_FLAGS)
+
 # See https://www.debian.org/doc/manuals/developers-reference/best-pkging-practices.html#bpp-dbg
 override_dh_strip:
 	dh_strip -plibosmo-ranap3 --dbg-package=libosmo-ranap-dbg
@@ -18,5 +22,6 @@
 override_dh_auto_test:
 	dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
 
-override_dh_auto_configure:
-	dh_auto_configure -- --with-systemdsystemunitdir=/lib/systemd/system
+# Don't create .pdf.gz files (barely saves space and they can't be opened directly by most pdf readers)
+override_dh_compress:
+	dh_compress -X.pdf