blob: 03432e6aadf90993b34aaec0162961312c2bece7 [file] [log] [blame]
Alexander Couzense485cdd2017-08-06 21:52:02 +00001#!/usr/bin/make -f
2
3DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
4DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
5VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
6
7# main packaging script based on dh7 syntax
8%:
9 dh $@ --with autoreconf
10
11override_dh_autoreconf:
12 echo $(VERSION) > .tarball-version
13 dh_autoreconf
14
15# See https://www.debian.org/doc/manuals/developers-reference/best-pkging-practices.html#bpp-dbg
16override_dh_strip:
17 dh_strip --dbg-package=libosmo-ranap-dbg
18 dh_strip --dbg-package=osmo-hnbgw