add /debian package support

Change-Id: I985805aea0e48fe70619de8b81206098e4e37613
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..03432e6
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+DEBIAN  := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
+DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
+VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
+
+# main packaging script based on dh7 syntax
+%:
+	dh $@ --with autoreconf
+
+override_dh_autoreconf:
+	echo $(VERSION) > .tarball-version
+	dh_autoreconf
+
+# See https://www.debian.org/doc/manuals/developers-reference/best-pkging-practices.html#bpp-dbg
+override_dh_strip:
+	dh_strip --dbg-package=libosmo-ranap-dbg
+	dh_strip --dbg-package=osmo-hnbgw