blob: 6f20b3e2156e4ece1a82b8cbd6769c15fd1a83f1 [file] [log] [blame]
Alexander Couzense485cdd2017-08-06 21:52:02 +00001#!/usr/bin/make -f
2
3DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
4DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
5VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
6
7# main packaging script based on dh7 syntax
8%:
9 dh $@ --with autoreconf
10
Alexander Couzense485cdd2017-08-06 21:52:02 +000011# See https://www.debian.org/doc/manuals/developers-reference/best-pkging-practices.html#bpp-dbg
12override_dh_strip:
13 dh_strip --dbg-package=libosmo-ranap-dbg
14 dh_strip --dbg-package=osmo-hnbgw
Alexander Couzens51640382017-10-11 07:11:34 +020015
16# Print test results in case of a failure
17override_dh_auto_test:
18 dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
Pau Espin Pedrola68b6822018-09-10 12:09:47 +020019
20override_dh_auto_configure:
21 dh_auto_configure -- --with-systemdsystemunitdir=/lib/systemd/system