blob: e821a571f80d00b9af84c1a64ff2e68850bd813e [file] [log] [blame]
Alexander Couzense485cdd2017-08-06 21:52:02 +00001#!/usr/bin/make -f
2
3DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
4DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
5VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
6
7# main packaging script based on dh7 syntax
8%:
9 dh $@ --with autoreconf
10
Alexander Couzense485cdd2017-08-06 21:52:02 +000011# See https://www.debian.org/doc/manuals/developers-reference/best-pkging-practices.html#bpp-dbg
12override_dh_strip:
Pau Espin Pedrold48430d2020-01-03 14:35:17 +010013 dh_strip -plibosmo-ranap2 --dbg-package=libosmo-ranap-dbg
Pau Espin Pedrold5d3efb2020-01-03 14:43:59 +010014 dh_strip -plibosmo-sabp0 --dbg-package=libosmo-sabp-dbg
Pau Espin Pedrold48430d2020-01-03 14:35:17 +010015 dh_strip -posmo-hnbgw --dbg-package=osmo-hnbgw-dbg
Alexander Couzens51640382017-10-11 07:11:34 +020016
17# Print test results in case of a failure
18override_dh_auto_test:
19 dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
Pau Espin Pedrola68b6822018-09-10 12:09:47 +020020
21override_dh_auto_configure:
22 dh_auto_configure -- --with-systemdsystemunitdir=/lib/systemd/system