blob: 9297d8d5f48bf249d63f47a90697c3d48f20588d [file] [log] [blame]
Oliver Smithc9b80362023-02-23 10:23:04 +01001osmo-hlr (1.6.1) unstable; urgency=medium
2
3 * Run struct_endianness.py
4 * tests: adjust to XOR-3G rename in libosmocore
5
6 -- Oliver Smith <osmith@sysmocom.de> Thu, 23 Feb 2023 10:23:04 +0100
7
Pau Espin Pedroled939152023-02-07 16:49:14 +01008osmo-hlr (1.6.0) unstable; urgency=medium
9
10 [ Vadim Yanitskiy ]
11 * db_auc: hexparse_stmt(): check value returned by osmo_hexparse()
12
13 [ Max ]
14 * Set working directory in systemd service file
15 * Ignore .deb build byproducts
16 * Debian: bump copyright year to match current
17 * Debian: reformat package description
18 * systemd: enable basic hardening
19 * Debian: install osmo-hlr-dgsm.cfg as example config
20 * hlr_vty.c: fix typo
21 * ctrl: take both address and port from vty config
22
23 [ Harald Welte ]
24 * Support building with -Werror=strict-prototypes / -Werror=old-style-definition
25 * Add -Werror=implicit-int -Werror=int-conversion -Werror=old-style-definition
26
27 [ arehbein ]
28 * osmo-hlr: Transition to use of 'telnet_init_default'
29
30 [ Oliver Smith ]
31 * osmo_mdns_rfc_record_decode: check ret of talloc
32 * osmo_mdns_rfc_record_decode: proper free on err
33 * mslookup: use apn functions from libosmocore
34 * osmo_mdns_rfc_record/question_encode: remove ctx
35
36 [ Keith ]
37 * Vty: Fixup config shown/written from vty
38
39 [ Neels Hofmeyr ]
40 * fix memleak of proxy_subscr_listentry
41
42 [ Alexander Couzens ]
43 * Add vty `reject-cause` to set the reject cause
44
45 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 07 Feb 2023 16:49:14 +0100
46
Pau Espin Pedrol65f51532022-06-28 18:38:31 +020047osmo-hlr (1.5.0) unstable; urgency=medium
48
49 [ Oliver Smith ]
50 * treewide: remove FSF address
51
52 [ Vadim Yanitskiy ]
53 * fixup: debian: remove unneeded dependency libdbd-sqlite3
54 * debian: add new 'osmo-mslookup-utils' package
55 * tests: use 'check_PROGRAMS' instead of 'noinst_PROGRAMS'
56
57 [ Pau Espin Pedrol ]
58 * ctrl: Mark function as static
59 * tests: Allow specyfing specific ctrl test to run
60 * tests/ctrl: Move ERROR test scenario to proper file
61 * Fix db_subscr_create() not returning -EEXIST expected by VTY subscriber create cmd
62 * ctrl: Introduce cmd SET subscriber.create <imsi>
63 * ctrl: Introduce CTRL command subscriber.by-*.msisdn
64 * cosmetic: hlr_vty_subscr.c: Fix trailing whitespace
65 * ctrl: Introduce cmd SET subscriber.delete <imsi>
66 * ctrl: Introduce CTRL command subscriber.by-*.aud2g <algo[,ki]>
67 * ctrl: Introduce CTRL command subscriber.by-*.aud3g <algo[,KI,(op|opc),OP_C[,ind_bitlen]]>
68 * doc: Document new subscriber CTRL commands
69
70 [ Harald Welte ]
71 * update git URLs (git -> https; gitea)
72
73 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 28 Jun 2022 18:38:31 +0200
74
Pau Espin Pedrol4d7cbfc2021-11-16 14:56:41 +010075osmo-hlr (1.4.0) unstable; urgency=medium
76
77 [ Keith ]
78 * Correct configuration written from vty
79 * vty: enable show subscribers filtered by IMEI
80
81 [ Harald Welte ]
82 * add README.md file as customary for cgit, github, gitlab, etc.
83
84 [ Oliver Smith ]
85 * Add post-upgrade script for automatic db upgrade
86 * debian/control: remove dh-systemd build-depend
87
88 [ Pau Espin Pedrol ]
89 * db: Avoid use uninitialized rc if running 0 statements
90
91 [ Neels Hofmeyr ]
92 * db v6: determine 3G AUC IND from VLR name
93
94 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 16 Nov 2021 14:56:41 +0100
95
Pau Espin Pedrol62404652021-02-23 18:13:53 +010096osmo-hlr (1.3.0) unstable; urgency=medium
97
98 [ Alexander Couzens ]
99 * hlr: respect the num_auth_vectors requested
100 * hlr: remove unused internal USSD list
101
102 [ Oliver Smith ]
103 * add libosmo-mslookup abstract client
104 * add mDNS lookup method to libosmo-mslookup
105 * Makefile.am: fix pkgconfig_DATA
106 * add mDNS lookup method to libosmo-mslookup (#2)
107 * contrib/dgsm/ add example esme and dialplan
108 * mslookup_client.c: fix dereferencing null pointer
109 * mdns_msg.c: always call va_end
110 * mslookup_client_mdns.c: fix dereferencing null
111 * osmo-mslookup-client.c: fix dereferencing null
112 * osmo-mslookup-client: fix dereferencing null
113 * mdns_sock.c: fix resource leak of sock
114 * mdns_rfc.c: fix possible access of uninit. mem
115 * mslookup_client_mdns_test: disable by default
116 * mslookup_client_mdns_test: no automatic skip
117 * Cosmetic: mention OS#4491 in location cancel code
118 * hlr_vty_subscr: prettier output for last LU seen
119 * contrib: import RPM spec
120 * contrib: integrate RPM spec
121 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
122 * contrib/jenkins: don't build osmo-gsm-manuals
123 * configure.ac: set -std=gnu11
124
125 [ Neels Hofmeyr ]
126 * add osmo-mslookup-client program
127 * add osmo-mslookup-client program (#2)
128 * fix missing braces in LOGP_GSUP_FWD
129 * gsup_client.c: fix deprecation for client create func
130 * 1/2: refactor: add and use lu_fsm, osmo_gsup_req, osmo_ipa_name
131 * 2/2: wrap ipa_name in osmo_cni_peer_id with type enum and union
132 * gsup client: add up_down_cb(), add osmo_gsup_client_create3()
133 * db v5: prep for D-GSM: add vlr_via_proxy and sgsn_via_proxy
134 * enlarge the GSUP message headroom
135 * test_nodes.vty: remove cruft
136 * D-GSM 1/n: add mslookup server in osmo-hlr
137 * D-GSM 2/n: implement mDNS method of mslookup server
138 * D-GSM 3/n: implement roaming by mslookup in osmo-hlr
139 * gsup_server: send routing error back to the correct peer
140 * adoc: add D-GSM chapter to osmohlr-usermanual
141 * drop error log for when a subscriber does not exist
142 * vty: show subscriber: change format of 'last LU seen'
143 * vty: show subscriber: show lu d,h,m,s ago, not just seconds
144 * auc3g: officially wrap IND around IND_bitlen space
145 * make osmo_cni_peer_id_cmp() NULL safe
146 * osmo_gsup_req_new(): require from_peer != NULL
147 * gsup_server.c: properly handle negative rc from osmo_gsup_conn_ccm_get()
148 * osmo_mslookup_server_mdns_rx(): handle read() rc == 0
149 * hlr_subscr_nam(): fix condition to fix nam=false notifications
150 * esme_dgsm.py: add --always-fail option for debugging SMPP
151 * osmo-mslookup-client: fix segfault for respond_error() caller
152 * manual: describe subscriber import by SQL
153
154 [ Harald Welte ]
155 * Revert "add osmo-mslookup-client program"
156 * Revert "add mDNS lookup method to libosmo-mslookup"
157 * Use OSMO_FD_* instead of deprecated BSC_FD_*
158 * support the XOR algorithm for UMTS AKA
159 * auc_test.c: Add some comments on what the test cases actually do
160 * main: add --vty-ref-mode, use vty_dump_xml_ref_mode()
161 * manuals: generate vty reference xml at build time
162
163 [ Vadim Yanitskiy ]
164 * db: fix possible SQLite3 allocated memory leak in db_open()
165 * gsup_server: fix typo: s/omso_gsup_message/osmo_gsup_message/
166 * debian/control: change maintainer to the Osmocom team / mailing list
167 * cosmetic: fix spelling in logging message: existAnt -> existEnt
168 * doc/manuals: fix s/There/The/ in 'USSD Configuration'
169 * doc/manuals: re-organize description of internal USSD handlers
170 * USSD: fix handle_ussd(): do not free() unconditionally
171 * USSD: add special 'idle' handler to IUSE for testing
172
173 [ Eric ]
174 * configure.ac: fix libtool issue with clang and sanitizer
175
176 [ Philipp Maier ]
177 * doc: do not use loglevel info for log category ss
178
179 [ Pau Espin Pedrol ]
180 * configure.ac: Fix trailing whitespace
181 * doc: Update VTY reference xml file
182 * Support setting rt-prio and cpu-affinity mask through VTY
183 * Set TCP NODELAY sockopt to GSUP cli and srv connections
184 * contrib/jenkins: Enable parallel make in make distcheck
185 * .gitignore: Ignore new autofoo tmp files
186 * tests: Replace deprecated API log_set_print_filename
187
188 [ Keith ]
189 * osmo-hlr-db-tool: Make import from osmo-nitb less "lossy"
190 * Correct vty inline help for show subscriber
191 * Add vty command to show summary of all or filtered subscribers
192 * Fix Coverity Warnings
193
194 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 23 Feb 2021 18:13:53 +0100
195
Pau Espin Pedrol3a666982020-01-03 12:37:35 +0100196osmo-hlr (1.2.0) unstable; urgency=medium
197
198 [ Ruben Undheim ]
199 * Fix test for return codes on mipsel and alpha archs
200
201 [ Thorsten Alteholz ]
202 * fix spelling errors detected by lintian
203
204 [ Pau Espin Pedrol ]
205 * tests: Fix db_test err file to expect error code name instead of value
206
207 [ Oliver Smith ]
208 * tests/test_nodes.vty: check less libosmocore cmds
209 * tests/db_upgrade: disable for old sqlite versions
210 * gitignore: add tests/db_upgrade/*.dump
211 * gsup_client.h: fix license header: GPLv2+
212 * tests/auc: change back to python3
213
214 [ Neels Hofmeyr ]
215 * fix double free in osmo_gsup_client_enc_send()
216 * db upgrade to v2: log version 2, not 1
217 * fix upgrade to version 2: imei column default value
218 * add --db-check option
219 * hlr.sql: move comment
220 * add db_upgrade test
221 * hlr db schema 3: hlr_number -> msc_number
222 * db.c: code dup: add db_run_statements() for arrays of statements
223 * move headers to include/osmocom/hlr
224 * fix upgrade test in presence of ~/.sqliterc
225 * db upgrade: remove some code dup
226 * add osmo_gsup_msgb_alloc()
227 * Makefile convenience: add VTY_TEST var to run only one test
228 * remove gsup_test
229 * test_nodes.vty: tweak: add some '?' checks
230 * db v4: add column last_lu_seen_ps
231
232 [ Harald Welte ]
233 * AUC: Add support for setting the AMF separation bit to '1' for EUTRAN
234 * hlr: exit(2) on unsupported positional arguments on command line
235
236 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 12:37:35 +0100
237
Pau Espin Pedrol9cf00302019-08-07 16:14:23 +0200238osmo-hlr (1.1.0) unstable; urgency=medium
239
240 [ Oliver Smith ]
241 * docs: running: document --db-upgrade
242 * Add IMEI column to subscriber table
243 * Optionally store IMEI in subscriber table
244 * VTY tests: fill DB before running test
245 * VTY: integrate IMEI
246 * hlr.c: replace deprecated osmo_gsup_get_err_msg_type()
247 * hlr.c: move hlr_ctx to the top
248 * tests: use -no-install libtool flag to avoid ./lt-* scripts
249 * Cosmetic: gsup_route_find: comment addr, addrlen
250 * USSD: save MO USSD's originating MSC's vlr_number
251 * USSD: don't use gsm0480_msgb_alloc_name()
252 * hlr.c: forward GSUP messages between clients
253 * db_hlr.c: db_subscr_create(): add flags argument
254 * db_hlr.c: add db_subscr_exists_by_imsi()
255 * Create subscribers on demand
256 * Document subscribers create on demand feature
257 * debian: create -doc subpackage with pdf manuals
258 * db_test: set timezone to work around mktime bug
259 * db_hlr: zero-initialize "struct tm"
260 * rx_check_imei_req(): fix IMEI bounds checking
261 * contrib/jenkins.sh: run "make maintainer-clean"
262 * VTY: add subscriber update network-access-mode
263 * manuals: improve subscribers create on demand
264 * gitignore: ignore everything generated in db_test
265 * db_auc.c: verify hex key sizes read from DB
266
267 [ Max ]
268 * Log ip:port when adding GSUP routes
269 * Add link to project wiki to .service file
270 * Enable statsd support
271
272 [ Vadim Yanitskiy ]
273 * hlr.c: properly terminate the process on SIGTERM
274 * hlr.c: fix: also store the session state in read_cb_forward()
275 * hlr.c: fix: properly print the original message type in read_cb_forward()
276 * hlr.c: check the presence of msgb->l2h in read_cb()
277 * hlr.c: fix possible msgb memleaks in read_cb()
278 * db_hlr.c: add db_subscr_exists_by_msisdn()
279 * src/db.h: use GSM23003_MSISDN_MAX_DIGITS for MSISDN buffer size
280 * src/hlr.c: fix deprecation warning: use gsm48_decode_bcd_number2()
281 * hlr_ussd.c: fix: properly pass invokeID in handle_ussd_own_msisdn()
282 * hlr_ussd.c: rx_proc_ss_req(): fix NULL pointer dereference
283 * build: fix mess with 'db_test_SOURCES' and 'db_test_LDADD'
284 * tests/db_test: close the database when test is finished
285 * src/db.c: integrate SQLite3 with talloc allocator
286
287 [ Neels Hofmeyr ]
288 * USSD: fix routing to multiple MSC
289 * fix error logging for GSUP route
290 * add missing error log: invalid IMSI
291 * osmo-hlr: allow configuring db path from cfg file
292 * use new OSMO_IMSI_BUF_SIZE
293
294 [ Daniel Willmann ]
295 * manuals: Add script to update vty/counter documentation from docker
296 * manuals: Update vty documentation
297
298 [ Pau Espin Pedrol ]
299 * Remove undefined param passed to logging_vty_add_cmds
300 * configure.ac: Require libosmocore 1.2.0
301
302 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 16:14:23 +0200
303
Harald Weltee0c6fe52019-01-20 19:29:59 +0100304osmo-hlr (1.0.0) unstable; urgency=medium
305
306 [ Stefan Sperling ]
307 * move creation of insert subscriber data messages to a common function
308
309 [ Harald Welte ]
310 * Return proper GSUP error in case of too short IMSI
311 * disable blind subscriber insertion into every VLR/SGSN
312 * gsup_server: Add "priv" pointer and make it point to 'struct hlr'
313 * move osmo_gsup_addr_send() declaration from luop.h to gsup_router.h
314 * gsup_router: Use "#pragma once" and add missing #includes
315 * Add "show gsup-connections" VTY command
316 * import gsup_client.c as new libosmo-gsup-client
317 * gsup_client: rename gsup_client_* to osmo_gsup_client_*
318 * GSUP: Log GSUP route add/remove
319 * hlr: Export + Declare global g_hlr symbol
320 * USSD: Add Core USSD handling + VTY routing config to HLR
321 * USSD: Add basic dispatch + decode of GSUP-encapsulated SS/USSD
322 * hlr_ussd: Introduce LOGPSS() macro
323 * USSD: Send ReturnError component if USSD Code unknown / EUSE disconnected
324 * USSD: Further unification of log output; Use LOGPSS when possible
325 * osmo-hlr.cfg: Don't enable DEBUG logging by default
326 * USSD: Add new "DSS" logging category and use it appropriately
327 * USSD: fix null-pointer deref in "default-route" vty/config cmd
328 * Add osmo-euse-demo as minimalistic test of a External USSD (EUSE) handler
329 * USSD: Add support for internal USSD handlers
330 * debian: Add sub-package for libosmo-gsup-client
331 * pkg-config: Fix libosmo-gsup-client pkg-config file
332 * gitignore: Add .tarball-version
333 * debian: Make libosmo-gsup-client-dev depend on libosmo-gsup-client0
334 * USSD: Fix "ussd default-route"
335 * libosmo-gsup-client: License is GPLv2-or-later
336 * osmo-hlr.cfg: Ensure well-formed config file example
337 * test_nodes.vty: Since libosmocore 1.0.0, we only have one space
338
339 [ Martin Hauke ]
340 * sql/Makefile.am: Make docsdir completely configurable
341 * debian: Fix typo in package description
342
343 [ Pau Espin Pedrol ]
344 * debian: Avoid installing duplicate cfg file in /etc
345 * sql/Makefile: Install hlr_data.sql as example together with hlr.sql
346 * sql/Makefile: Install sql files under doc/.../sql subdir
347 * sql/Makefile: Create empty /var/lib/osmocom directory at install time
348 * Install systemd services with autotools
349 * Move doc/Makefile.am to doc/examples/Makefile.am
350 * Install sample cfg file to /etc/osmocom
351
352 [ Vadim Yanitskiy ]
353 * hlr.c: move deinitialization code from SIGINT handler
354 * hlr.c: free root talloc context on exit
355 * hlr.c: track the use of talloc NULL memory contexts
356 * src/db.c: fix: make sure the database is properly closed
357 * src/db.c: don't ignore the result of db_bootstrap()
358 * hlr_vty_subscr.c: fix subscriber creation command help
359 * Update .gitignore: add missing build products
360 * tests/Makefile.am: also remove temporary sqlite files
361 * hlr_ussd.h: add #pragma once include guard
362 * hlr_ussd.h: use proper libc headers
363 * Update .gitignore: ignore osmo-euse-demo
364 * hlr_ussd.h: drop meaningless forward declaration
365 * USSD/hlr_vty.c: print error if EUSE is not found
366 * hlr_ussd.c: fix: properly print a EUSE / IUSE name
367 * hlr_ussd.c: avoid using CR and NL in IUSE responses
368
369 [ Neels Hofmeyr ]
370 * fix build: adjust test_nodes.vty to logging change
371 * tweak example config
372 * make: always allow running python tests manually
373
374 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 19:29:58 +0100
375
Pau Espin Pedrol78f43012018-05-04 18:41:35 +0200376osmo-hlr (0.2.1) unstable; urgency=medium
377
378 [ Neels Hofmeyr ]
379 * fix luop crash: use buffer for APN that remains valid
380 * add gsup_test to catch OS#3231
381 * add error handling to osmo_gsup_configure_wildcard_apn()
382
383 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 04 May 2018 18:41:35 +0200
384
Pau Espin Pedrolcb360f02018-05-03 16:27:14 +0200385osmo-hlr (0.2.0) unstable; urgency=medium
386
387 [ Neels Hofmeyr ]
388 * vty: skip installing cmds now always installed by default
389 * hlr_db_tool: fix error log strerror invocation
390 * cosmetic: add comment on ignored return value
391 * db-tool: add command 'create'
392 * db-tool: cosmetic: tweak printf output
393 * db-tool: error-exit on too many arguments
394 * add --enable-sanitize config option
395 * db_test: don't verify SQLite issued error messages, they might change
396 * cosmetic: rx_send_auth_info(): decide error cause with switch()
397 * return GMM_CAUSE_IMSI_UNKNOWN if there is no auth data
398 * db_get_auth_data / db_get_auc: clarify return values
399 * osmo-hlr: log details for unknown IMSI / no auth data / db error
400 * db_test: also test db_get_auc() return values
401 * fix test_subscriber_errors.ctrl after libosmocore change
402 * fix debug log: put 'deriving 2G from 3G' in proper place
403 * ctrl test: fix: adjust expectations after stricter ctrl parsing
404 * fix build: db_test: missing LIBOSMOABIS_CFLAGS and _LIBS
405 * configure: add --enable-werror
406 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
407
408 [ Harald Welte ]
409 * hlr.c: Avoid overflow of lu_operation.subscr.imsi
410 * Fix expected test output after new 'logging print file 1' vty command
411 * osmo-hlr: Add talloc context introspection via VTY
412 * vty: Don't print error if removing auth data while none present
413 * Fix responses to PURGE MS
414
415 [ Alexander Couzens ]
416 * debian: include systemd service osmo-hlr.service
417 * doc: install example .cfg files to $(docdir)/examples/
418 * debian: install osmo-hlr.cfg to /etc/osmocom
419
420 [ Max ]
421 * Remove unused check
422 * Remove unused ipa.py
423 * Enable sanitize for CI tests
424
425 [ Pau Espin Pedrol ]
426 * luop.c: Transform FIXME from warning to pragma message
427 * contrib:jenkins.sh: Enable Werror
428 * use osmo_init_logging2
429 * Remove unused src/db_test.c
430
431 [ Alexander Huemer ]
432 * Add missing build products in .gitignore
433
434 [ Stefan Sperling ]
435 * more robust usage of osmo_timer API for osmo-hlr luop timer
436 * notify GSUP clients when HLR subscriber information changes
437 * rewrite subscriber_update_notify() without calls into luop
438 * don't forget to mark luop as a packet switched connection
439
440 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:27:13 +0200
441
Harald Welte0dcbd472017-10-28 20:37:34 +0200442osmo-hlr (0.1.0) unstable; urgency=medium
443
444 [ Neels Hofmeyr ]
445 * build with autoconf/automake, add jenkins.sh script
446 * fix build on FreeBSD: eliminate implicitly declared functions
447 * fix various compiler warnings
448 * fix DLGSUP logging cat after change in libosmocore
449 * build: recoin db_test as non-installable program
450 * build: actually make sqlite mandatory
451 * bump required libosmocore version to 0.9.5
452 * gsup: send subscriber MSISDN
453 * debug log: log computed vector kinds
454 * log: move a log from info to debug level
455 * hlr.sql: typo in comment
456 * auc.c: typo in comment
457 * main: add and use root talloc ctx
458 * main: add option parsing with db file and default options
459 * main: add VTY and '-c config-file' option
460 * sql: fix 3g_auc's column K data type
461 * cosmetic: sql: indicate VARCHAR size of key columns as 32
462 * sql: auc_3g: set sqn NOT NULL DEFAULT 0
463 * comment: sql: describe auc_2g and auc_3g columns
464 * Add test suite skeleton with empty test (auc_3g_test)
465 * tests: auc_3g_test: implement vector generation test
466 * auth: verify test sets from 3GPP TS 55.205
467 * sql: add unique constraints to IMSI and MSISDN
468 * UMTS AKA resync: fix argument ordering
469 * auc_3g_test: add AUTS resync test
470 * auc_gen_vectors(): ensure sane arguments, test
471 * auc_3g_test: allow to inc fake rand bytes upon rand request
472 * auc_3g_test: add AUTS test with N vectors, to show bug
473 * cosmetic: refactor auc_compute_vectors(), add debug log
474 * auc_compute_vectors(): fix AUTS resync for multiple vectors
475 * cosmetic: auc_3g_test: improve test debugging tools
476 * cosmetic: rename auc_3g_test.c to auc_test.c
477 * fix: properly handle error rc by osmo_gsup_conn_ccm_get()
478 * auc tests: adjust cosmetically to prepare for SQN changes
479 * auc tests: fix after SQN scheme changes from libosmocore
480 * fix debug log: adjust to new SQN increment scheme
481 * UMTS AKA: implement SQN increment according to SEQ and IND
482 * debug log: output ind slot, previous sqn, and sqn db update
483 * jenkins: add value_string termination check
484 * fix db_subscr_ps error handling
485 * add config example (mostly empty)
486 * install hlr.sql in prefix/doc/osmo-hlr/
487 * use OSMO_GSUP_PORT == 4222 instead of hardcoded 2222
488 * add basic CTRL interface tests
489 * add CTRL tests for enable-/disable-/status-ps
490 * cosmetic: prepend DB_STMT_ to enum stmt_idx entries
491 * cosmetic: rename db_subscr_get() to db_subscr_get_by_imsi()
492 * cosmetic: refactor db_bind_imsi() as db_bind_text()
493 * cosmetic: multi-line DB_STMT_AUC_BY_IMSI
494 * cosmetic: log IMSI='<imsi>', log "no such subscriber"
495 * cosmetic: log: "SQLite" with capital L
496 * cosmetic: db_hlr: SL3_TXT: clarify indenting
497 * ctrl_test_runner.py: use proper constant as test db path
498 * gitignore: tests/package.m4
499 * cosmetic: don't log about missing SQLite log cb
500 * add db_bind_int() and db_bind_int64()
501 * add db_subscr_create(), db_subscr_delete(), db_subscr_update_msisdn_by_imsi()
502 * add initial db_test: creating and deleting subscribers
503 * less noise: simplify db_remove_reset()
504 * db: use int64_t as subscriber id
505 * add db_subscr_get_by_msisdn() and db_subscr_get_by_id()
506 * refactor db_subscr_ps() to db_subscr_nam()
507 * refactor db_subscr_lu()
508 * refactor db_subscr_purge
509 * add db_subscr_update_aud_by_id(), complete db_subscr_delete_by_id()
510 * refactor db_get_auth_data return val
511 * code undup: use db_remove_reset() in db_auc.c
512 * fix db_update_sqn(): reset stmt in all error cases
513 * code undup: use db_bind_text() in db_get_auth_data()
514 * debian: 'make check' needs sqlite3, add to Build-Depends
515 * fix db_subscr_get_by_*(): clear output data; test in db_test.c
516 * implement subscriber vty interface, tests
517 * add test_nodes.vty
518 * replace ctrl_test_runner.py with transcript test_subscriber.ctrl
519 * add lu_op_free(), use in luop.c
520 * luop: fix mem leak upon error in lu_op_alloc_conn()
521 * fix mem leak in handle_cmd_ps(): free luop
522 * api doc: say that lu_op_tx_del_subscr_data() doesn't free
523 * add hlr_subsrc_nam to put GSUP client notification in proper API
524 * vty: fix output of empty IMSI
525 * db api: fix/add API docs
526 * cosmetic: tweak params of hlr_controlif_setup()
527 * ctrl: completely replace all CTRL commands
528 * test_subscriber.ctrl: test against octal/hex interpretation of id
529 * jenkins: use osmo-clean-workspace.sh before and after build
530 * tests/Makefile: use test db var instead of repeating the path
531 * db_test: fix *FLAGS
532 * automatically create db tables on osmo-hlr invocation
533 * cosmetic: sql/hlr.sql: move comments
534 * cosmetic: rename SL3_TXT macro, use osmo_strlcpy()
535 * fix default logging levels to NOTICE, not DEBUG
536 * add osmo-hlr-db-tool, program to migrate from osmo-nitb db
537
538 [ Max ]
539 * Add gerrit settings
540 * Add hardcoded APN
541 * Log error cause as a string
542 * Move GSUP msg init into separate function
543 * Use strings for GSUP message type
544 * Move lu_operation into separate file
545 * db: move duplicated code into helper functions
546 * Fix compiler's warning about printf security
547 * Add routines to update nam_ps
548 * Add global HLR struct
549 * Make subscr parameter to db_subscr_get() optional
550 * Add CTRL interface
551 * CTRL: add enable/disable packet service cmds
552 * Add .deb packaging
553 * deb: fix OBS build
554 * debian: remove obsolete dependency
555 * Attempt to fix .deb package
556 * deb: use python in shebang
557 * Another attempt at fixing .deb
558 * Use release helper from libosmocore
559 * Use value string check from osmo-ci
560
561 [ Daniel Willmann ]
562 * Add systemd service file
563 * hlr_data.sql: Insert ki and opc instead of op to example data
564 * tests/auc: Don't require python3
565
566 [ Pau Espin Pedrol ]
567 * VTY: Add hlr node and bind ip field
568 * debian: remove unneeded dependency libdbd-sqlite3
569
570 [ Harald Welte ]
571 * jenkins.sh: Proper error message if local environment isn't set up
572
573 [ Alexander Couzens ]
574 * debian/rules: show testsuite.log when tests are failing
575
576 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 20:37:33 +0200
577
Maxe9d37db2017-03-13 16:08:11 +0100578osmo-hlr (0.0.1) UNRELEASED; urgency=low
579
580 * Initial release (Closes: OS#1948)
581
582 -- Max Suraev <msuraev@sysmocom.de> Mon, 13 Mar 2017 16:26:41 +0200