blob: 0b89abe45ca4dfd72ee9d3eabd5c63161b3401c3 [file] [log] [blame]
Pau Espin Pedrol9cf00302019-08-07 16:14:23 +02001osmo-hlr (1.1.0) unstable; urgency=medium
2
3 [ Oliver Smith ]
4 * docs: running: document --db-upgrade
5 * Add IMEI column to subscriber table
6 * Optionally store IMEI in subscriber table
7 * VTY tests: fill DB before running test
8 * VTY: integrate IMEI
9 * hlr.c: replace deprecated osmo_gsup_get_err_msg_type()
10 * hlr.c: move hlr_ctx to the top
11 * tests: use -no-install libtool flag to avoid ./lt-* scripts
12 * Cosmetic: gsup_route_find: comment addr, addrlen
13 * USSD: save MO USSD's originating MSC's vlr_number
14 * USSD: don't use gsm0480_msgb_alloc_name()
15 * hlr.c: forward GSUP messages between clients
16 * db_hlr.c: db_subscr_create(): add flags argument
17 * db_hlr.c: add db_subscr_exists_by_imsi()
18 * Create subscribers on demand
19 * Document subscribers create on demand feature
20 * debian: create -doc subpackage with pdf manuals
21 * db_test: set timezone to work around mktime bug
22 * db_hlr: zero-initialize "struct tm"
23 * rx_check_imei_req(): fix IMEI bounds checking
24 * contrib/jenkins.sh: run "make maintainer-clean"
25 * VTY: add subscriber update network-access-mode
26 * manuals: improve subscribers create on demand
27 * gitignore: ignore everything generated in db_test
28 * db_auc.c: verify hex key sizes read from DB
29
30 [ Max ]
31 * Log ip:port when adding GSUP routes
32 * Add link to project wiki to .service file
33 * Enable statsd support
34
35 [ Vadim Yanitskiy ]
36 * hlr.c: properly terminate the process on SIGTERM
37 * hlr.c: fix: also store the session state in read_cb_forward()
38 * hlr.c: fix: properly print the original message type in read_cb_forward()
39 * hlr.c: check the presence of msgb->l2h in read_cb()
40 * hlr.c: fix possible msgb memleaks in read_cb()
41 * db_hlr.c: add db_subscr_exists_by_msisdn()
42 * src/db.h: use GSM23003_MSISDN_MAX_DIGITS for MSISDN buffer size
43 * src/hlr.c: fix deprecation warning: use gsm48_decode_bcd_number2()
44 * hlr_ussd.c: fix: properly pass invokeID in handle_ussd_own_msisdn()
45 * hlr_ussd.c: rx_proc_ss_req(): fix NULL pointer dereference
46 * build: fix mess with 'db_test_SOURCES' and 'db_test_LDADD'
47 * tests/db_test: close the database when test is finished
48 * src/db.c: integrate SQLite3 with talloc allocator
49
50 [ Neels Hofmeyr ]
51 * USSD: fix routing to multiple MSC
52 * fix error logging for GSUP route
53 * add missing error log: invalid IMSI
54 * osmo-hlr: allow configuring db path from cfg file
55 * use new OSMO_IMSI_BUF_SIZE
56
57 [ Daniel Willmann ]
58 * manuals: Add script to update vty/counter documentation from docker
59 * manuals: Update vty documentation
60
61 [ Pau Espin Pedrol ]
62 * Remove undefined param passed to logging_vty_add_cmds
63 * configure.ac: Require libosmocore 1.2.0
64
65 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 16:14:23 +0200
66
Harald Weltee0c6fe52019-01-20 19:29:59 +010067osmo-hlr (1.0.0) unstable; urgency=medium
68
69 [ Stefan Sperling ]
70 * move creation of insert subscriber data messages to a common function
71
72 [ Harald Welte ]
73 * Return proper GSUP error in case of too short IMSI
74 * disable blind subscriber insertion into every VLR/SGSN
75 * gsup_server: Add "priv" pointer and make it point to 'struct hlr'
76 * move osmo_gsup_addr_send() declaration from luop.h to gsup_router.h
77 * gsup_router: Use "#pragma once" and add missing #includes
78 * Add "show gsup-connections" VTY command
79 * import gsup_client.c as new libosmo-gsup-client
80 * gsup_client: rename gsup_client_* to osmo_gsup_client_*
81 * GSUP: Log GSUP route add/remove
82 * hlr: Export + Declare global g_hlr symbol
83 * USSD: Add Core USSD handling + VTY routing config to HLR
84 * USSD: Add basic dispatch + decode of GSUP-encapsulated SS/USSD
85 * hlr_ussd: Introduce LOGPSS() macro
86 * USSD: Send ReturnError component if USSD Code unknown / EUSE disconnected
87 * USSD: Further unification of log output; Use LOGPSS when possible
88 * osmo-hlr.cfg: Don't enable DEBUG logging by default
89 * USSD: Add new "DSS" logging category and use it appropriately
90 * USSD: fix null-pointer deref in "default-route" vty/config cmd
91 * Add osmo-euse-demo as minimalistic test of a External USSD (EUSE) handler
92 * USSD: Add support for internal USSD handlers
93 * debian: Add sub-package for libosmo-gsup-client
94 * pkg-config: Fix libosmo-gsup-client pkg-config file
95 * gitignore: Add .tarball-version
96 * debian: Make libosmo-gsup-client-dev depend on libosmo-gsup-client0
97 * USSD: Fix "ussd default-route"
98 * libosmo-gsup-client: License is GPLv2-or-later
99 * osmo-hlr.cfg: Ensure well-formed config file example
100 * test_nodes.vty: Since libosmocore 1.0.0, we only have one space
101
102 [ Martin Hauke ]
103 * sql/Makefile.am: Make docsdir completely configurable
104 * debian: Fix typo in package description
105
106 [ Pau Espin Pedrol ]
107 * debian: Avoid installing duplicate cfg file in /etc
108 * sql/Makefile: Install hlr_data.sql as example together with hlr.sql
109 * sql/Makefile: Install sql files under doc/.../sql subdir
110 * sql/Makefile: Create empty /var/lib/osmocom directory at install time
111 * Install systemd services with autotools
112 * Move doc/Makefile.am to doc/examples/Makefile.am
113 * Install sample cfg file to /etc/osmocom
114
115 [ Vadim Yanitskiy ]
116 * hlr.c: move deinitialization code from SIGINT handler
117 * hlr.c: free root talloc context on exit
118 * hlr.c: track the use of talloc NULL memory contexts
119 * src/db.c: fix: make sure the database is properly closed
120 * src/db.c: don't ignore the result of db_bootstrap()
121 * hlr_vty_subscr.c: fix subscriber creation command help
122 * Update .gitignore: add missing build products
123 * tests/Makefile.am: also remove temporary sqlite files
124 * hlr_ussd.h: add #pragma once include guard
125 * hlr_ussd.h: use proper libc headers
126 * Update .gitignore: ignore osmo-euse-demo
127 * hlr_ussd.h: drop meaningless forward declaration
128 * USSD/hlr_vty.c: print error if EUSE is not found
129 * hlr_ussd.c: fix: properly print a EUSE / IUSE name
130 * hlr_ussd.c: avoid using CR and NL in IUSE responses
131
132 [ Neels Hofmeyr ]
133 * fix build: adjust test_nodes.vty to logging change
134 * tweak example config
135 * make: always allow running python tests manually
136
137 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 19:29:58 +0100
138
Pau Espin Pedrol78f43012018-05-04 18:41:35 +0200139osmo-hlr (0.2.1) unstable; urgency=medium
140
141 [ Neels Hofmeyr ]
142 * fix luop crash: use buffer for APN that remains valid
143 * add gsup_test to catch OS#3231
144 * add error handling to osmo_gsup_configure_wildcard_apn()
145
146 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 04 May 2018 18:41:35 +0200
147
Pau Espin Pedrolcb360f02018-05-03 16:27:14 +0200148osmo-hlr (0.2.0) unstable; urgency=medium
149
150 [ Neels Hofmeyr ]
151 * vty: skip installing cmds now always installed by default
152 * hlr_db_tool: fix error log strerror invocation
153 * cosmetic: add comment on ignored return value
154 * db-tool: add command 'create'
155 * db-tool: cosmetic: tweak printf output
156 * db-tool: error-exit on too many arguments
157 * add --enable-sanitize config option
158 * db_test: don't verify SQLite issued error messages, they might change
159 * cosmetic: rx_send_auth_info(): decide error cause with switch()
160 * return GMM_CAUSE_IMSI_UNKNOWN if there is no auth data
161 * db_get_auth_data / db_get_auc: clarify return values
162 * osmo-hlr: log details for unknown IMSI / no auth data / db error
163 * db_test: also test db_get_auc() return values
164 * fix test_subscriber_errors.ctrl after libosmocore change
165 * fix debug log: put 'deriving 2G from 3G' in proper place
166 * ctrl test: fix: adjust expectations after stricter ctrl parsing
167 * fix build: db_test: missing LIBOSMOABIS_CFLAGS and _LIBS
168 * configure: add --enable-werror
169 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
170
171 [ Harald Welte ]
172 * hlr.c: Avoid overflow of lu_operation.subscr.imsi
173 * Fix expected test output after new 'logging print file 1' vty command
174 * osmo-hlr: Add talloc context introspection via VTY
175 * vty: Don't print error if removing auth data while none present
176 * Fix responses to PURGE MS
177
178 [ Alexander Couzens ]
179 * debian: include systemd service osmo-hlr.service
180 * doc: install example .cfg files to $(docdir)/examples/
181 * debian: install osmo-hlr.cfg to /etc/osmocom
182
183 [ Max ]
184 * Remove unused check
185 * Remove unused ipa.py
186 * Enable sanitize for CI tests
187
188 [ Pau Espin Pedrol ]
189 * luop.c: Transform FIXME from warning to pragma message
190 * contrib:jenkins.sh: Enable Werror
191 * use osmo_init_logging2
192 * Remove unused src/db_test.c
193
194 [ Alexander Huemer ]
195 * Add missing build products in .gitignore
196
197 [ Stefan Sperling ]
198 * more robust usage of osmo_timer API for osmo-hlr luop timer
199 * notify GSUP clients when HLR subscriber information changes
200 * rewrite subscriber_update_notify() without calls into luop
201 * don't forget to mark luop as a packet switched connection
202
203 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:27:13 +0200
204
Harald Welte0dcbd472017-10-28 20:37:34 +0200205osmo-hlr (0.1.0) unstable; urgency=medium
206
207 [ Neels Hofmeyr ]
208 * build with autoconf/automake, add jenkins.sh script
209 * fix build on FreeBSD: eliminate implicitly declared functions
210 * fix various compiler warnings
211 * fix DLGSUP logging cat after change in libosmocore
212 * build: recoin db_test as non-installable program
213 * build: actually make sqlite mandatory
214 * bump required libosmocore version to 0.9.5
215 * gsup: send subscriber MSISDN
216 * debug log: log computed vector kinds
217 * log: move a log from info to debug level
218 * hlr.sql: typo in comment
219 * auc.c: typo in comment
220 * main: add and use root talloc ctx
221 * main: add option parsing with db file and default options
222 * main: add VTY and '-c config-file' option
223 * sql: fix 3g_auc's column K data type
224 * cosmetic: sql: indicate VARCHAR size of key columns as 32
225 * sql: auc_3g: set sqn NOT NULL DEFAULT 0
226 * comment: sql: describe auc_2g and auc_3g columns
227 * Add test suite skeleton with empty test (auc_3g_test)
228 * tests: auc_3g_test: implement vector generation test
229 * auth: verify test sets from 3GPP TS 55.205
230 * sql: add unique constraints to IMSI and MSISDN
231 * UMTS AKA resync: fix argument ordering
232 * auc_3g_test: add AUTS resync test
233 * auc_gen_vectors(): ensure sane arguments, test
234 * auc_3g_test: allow to inc fake rand bytes upon rand request
235 * auc_3g_test: add AUTS test with N vectors, to show bug
236 * cosmetic: refactor auc_compute_vectors(), add debug log
237 * auc_compute_vectors(): fix AUTS resync for multiple vectors
238 * cosmetic: auc_3g_test: improve test debugging tools
239 * cosmetic: rename auc_3g_test.c to auc_test.c
240 * fix: properly handle error rc by osmo_gsup_conn_ccm_get()
241 * auc tests: adjust cosmetically to prepare for SQN changes
242 * auc tests: fix after SQN scheme changes from libosmocore
243 * fix debug log: adjust to new SQN increment scheme
244 * UMTS AKA: implement SQN increment according to SEQ and IND
245 * debug log: output ind slot, previous sqn, and sqn db update
246 * jenkins: add value_string termination check
247 * fix db_subscr_ps error handling
248 * add config example (mostly empty)
249 * install hlr.sql in prefix/doc/osmo-hlr/
250 * use OSMO_GSUP_PORT == 4222 instead of hardcoded 2222
251 * add basic CTRL interface tests
252 * add CTRL tests for enable-/disable-/status-ps
253 * cosmetic: prepend DB_STMT_ to enum stmt_idx entries
254 * cosmetic: rename db_subscr_get() to db_subscr_get_by_imsi()
255 * cosmetic: refactor db_bind_imsi() as db_bind_text()
256 * cosmetic: multi-line DB_STMT_AUC_BY_IMSI
257 * cosmetic: log IMSI='<imsi>', log "no such subscriber"
258 * cosmetic: log: "SQLite" with capital L
259 * cosmetic: db_hlr: SL3_TXT: clarify indenting
260 * ctrl_test_runner.py: use proper constant as test db path
261 * gitignore: tests/package.m4
262 * cosmetic: don't log about missing SQLite log cb
263 * add db_bind_int() and db_bind_int64()
264 * add db_subscr_create(), db_subscr_delete(), db_subscr_update_msisdn_by_imsi()
265 * add initial db_test: creating and deleting subscribers
266 * less noise: simplify db_remove_reset()
267 * db: use int64_t as subscriber id
268 * add db_subscr_get_by_msisdn() and db_subscr_get_by_id()
269 * refactor db_subscr_ps() to db_subscr_nam()
270 * refactor db_subscr_lu()
271 * refactor db_subscr_purge
272 * add db_subscr_update_aud_by_id(), complete db_subscr_delete_by_id()
273 * refactor db_get_auth_data return val
274 * code undup: use db_remove_reset() in db_auc.c
275 * fix db_update_sqn(): reset stmt in all error cases
276 * code undup: use db_bind_text() in db_get_auth_data()
277 * debian: 'make check' needs sqlite3, add to Build-Depends
278 * fix db_subscr_get_by_*(): clear output data; test in db_test.c
279 * implement subscriber vty interface, tests
280 * add test_nodes.vty
281 * replace ctrl_test_runner.py with transcript test_subscriber.ctrl
282 * add lu_op_free(), use in luop.c
283 * luop: fix mem leak upon error in lu_op_alloc_conn()
284 * fix mem leak in handle_cmd_ps(): free luop
285 * api doc: say that lu_op_tx_del_subscr_data() doesn't free
286 * add hlr_subsrc_nam to put GSUP client notification in proper API
287 * vty: fix output of empty IMSI
288 * db api: fix/add API docs
289 * cosmetic: tweak params of hlr_controlif_setup()
290 * ctrl: completely replace all CTRL commands
291 * test_subscriber.ctrl: test against octal/hex interpretation of id
292 * jenkins: use osmo-clean-workspace.sh before and after build
293 * tests/Makefile: use test db var instead of repeating the path
294 * db_test: fix *FLAGS
295 * automatically create db tables on osmo-hlr invocation
296 * cosmetic: sql/hlr.sql: move comments
297 * cosmetic: rename SL3_TXT macro, use osmo_strlcpy()
298 * fix default logging levels to NOTICE, not DEBUG
299 * add osmo-hlr-db-tool, program to migrate from osmo-nitb db
300
301 [ Max ]
302 * Add gerrit settings
303 * Add hardcoded APN
304 * Log error cause as a string
305 * Move GSUP msg init into separate function
306 * Use strings for GSUP message type
307 * Move lu_operation into separate file
308 * db: move duplicated code into helper functions
309 * Fix compiler's warning about printf security
310 * Add routines to update nam_ps
311 * Add global HLR struct
312 * Make subscr parameter to db_subscr_get() optional
313 * Add CTRL interface
314 * CTRL: add enable/disable packet service cmds
315 * Add .deb packaging
316 * deb: fix OBS build
317 * debian: remove obsolete dependency
318 * Attempt to fix .deb package
319 * deb: use python in shebang
320 * Another attempt at fixing .deb
321 * Use release helper from libosmocore
322 * Use value string check from osmo-ci
323
324 [ Daniel Willmann ]
325 * Add systemd service file
326 * hlr_data.sql: Insert ki and opc instead of op to example data
327 * tests/auc: Don't require python3
328
329 [ Pau Espin Pedrol ]
330 * VTY: Add hlr node and bind ip field
331 * debian: remove unneeded dependency libdbd-sqlite3
332
333 [ Harald Welte ]
334 * jenkins.sh: Proper error message if local environment isn't set up
335
336 [ Alexander Couzens ]
337 * debian/rules: show testsuite.log when tests are failing
338
339 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 20:37:33 +0200
340
Maxe9d37db2017-03-13 16:08:11 +0100341osmo-hlr (0.0.1) UNRELEASED; urgency=low
342
343 * Initial release (Closes: OS#1948)
344
345 -- Max Suraev <msuraev@sysmocom.de> Mon, 13 Mar 2017 16:26:41 +0200