blob: dce4dd4f92faf4c8cfb53a5ca0a27e6a765726b6 [file] [log] [blame]
Pau Espin Pedrolcb360f02018-05-03 16:27:14 +02001osmo-hlr (0.2.0) unstable; urgency=medium
2
3 [ Neels Hofmeyr ]
4 * vty: skip installing cmds now always installed by default
5 * hlr_db_tool: fix error log strerror invocation
6 * cosmetic: add comment on ignored return value
7 * db-tool: add command 'create'
8 * db-tool: cosmetic: tweak printf output
9 * db-tool: error-exit on too many arguments
10 * add --enable-sanitize config option
11 * db_test: don't verify SQLite issued error messages, they might change
12 * cosmetic: rx_send_auth_info(): decide error cause with switch()
13 * return GMM_CAUSE_IMSI_UNKNOWN if there is no auth data
14 * db_get_auth_data / db_get_auc: clarify return values
15 * osmo-hlr: log details for unknown IMSI / no auth data / db error
16 * db_test: also test db_get_auc() return values
17 * fix test_subscriber_errors.ctrl after libosmocore change
18 * fix debug log: put 'deriving 2G from 3G' in proper place
19 * ctrl test: fix: adjust expectations after stricter ctrl parsing
20 * fix build: db_test: missing LIBOSMOABIS_CFLAGS and _LIBS
21 * configure: add --enable-werror
22 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
23
24 [ Harald Welte ]
25 * hlr.c: Avoid overflow of lu_operation.subscr.imsi
26 * Fix expected test output after new 'logging print file 1' vty command
27 * osmo-hlr: Add talloc context introspection via VTY
28 * vty: Don't print error if removing auth data while none present
29 * Fix responses to PURGE MS
30
31 [ Alexander Couzens ]
32 * debian: include systemd service osmo-hlr.service
33 * doc: install example .cfg files to $(docdir)/examples/
34 * debian: install osmo-hlr.cfg to /etc/osmocom
35
36 [ Max ]
37 * Remove unused check
38 * Remove unused ipa.py
39 * Enable sanitize for CI tests
40
41 [ Pau Espin Pedrol ]
42 * luop.c: Transform FIXME from warning to pragma message
43 * contrib:jenkins.sh: Enable Werror
44 * use osmo_init_logging2
45 * Remove unused src/db_test.c
46
47 [ Alexander Huemer ]
48 * Add missing build products in .gitignore
49
50 [ Stefan Sperling ]
51 * more robust usage of osmo_timer API for osmo-hlr luop timer
52 * notify GSUP clients when HLR subscriber information changes
53 * rewrite subscriber_update_notify() without calls into luop
54 * don't forget to mark luop as a packet switched connection
55
56 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:27:13 +0200
57
Harald Welte0dcbd472017-10-28 20:37:34 +020058osmo-hlr (0.1.0) unstable; urgency=medium
59
60 [ Neels Hofmeyr ]
61 * build with autoconf/automake, add jenkins.sh script
62 * fix build on FreeBSD: eliminate implicitly declared functions
63 * fix various compiler warnings
64 * fix DLGSUP logging cat after change in libosmocore
65 * build: recoin db_test as non-installable program
66 * build: actually make sqlite mandatory
67 * bump required libosmocore version to 0.9.5
68 * gsup: send subscriber MSISDN
69 * debug log: log computed vector kinds
70 * log: move a log from info to debug level
71 * hlr.sql: typo in comment
72 * auc.c: typo in comment
73 * main: add and use root talloc ctx
74 * main: add option parsing with db file and default options
75 * main: add VTY and '-c config-file' option
76 * sql: fix 3g_auc's column K data type
77 * cosmetic: sql: indicate VARCHAR size of key columns as 32
78 * sql: auc_3g: set sqn NOT NULL DEFAULT 0
79 * comment: sql: describe auc_2g and auc_3g columns
80 * Add test suite skeleton with empty test (auc_3g_test)
81 * tests: auc_3g_test: implement vector generation test
82 * auth: verify test sets from 3GPP TS 55.205
83 * sql: add unique constraints to IMSI and MSISDN
84 * UMTS AKA resync: fix argument ordering
85 * auc_3g_test: add AUTS resync test
86 * auc_gen_vectors(): ensure sane arguments, test
87 * auc_3g_test: allow to inc fake rand bytes upon rand request
88 * auc_3g_test: add AUTS test with N vectors, to show bug
89 * cosmetic: refactor auc_compute_vectors(), add debug log
90 * auc_compute_vectors(): fix AUTS resync for multiple vectors
91 * cosmetic: auc_3g_test: improve test debugging tools
92 * cosmetic: rename auc_3g_test.c to auc_test.c
93 * fix: properly handle error rc by osmo_gsup_conn_ccm_get()
94 * auc tests: adjust cosmetically to prepare for SQN changes
95 * auc tests: fix after SQN scheme changes from libosmocore
96 * fix debug log: adjust to new SQN increment scheme
97 * UMTS AKA: implement SQN increment according to SEQ and IND
98 * debug log: output ind slot, previous sqn, and sqn db update
99 * jenkins: add value_string termination check
100 * fix db_subscr_ps error handling
101 * add config example (mostly empty)
102 * install hlr.sql in prefix/doc/osmo-hlr/
103 * use OSMO_GSUP_PORT == 4222 instead of hardcoded 2222
104 * add basic CTRL interface tests
105 * add CTRL tests for enable-/disable-/status-ps
106 * cosmetic: prepend DB_STMT_ to enum stmt_idx entries
107 * cosmetic: rename db_subscr_get() to db_subscr_get_by_imsi()
108 * cosmetic: refactor db_bind_imsi() as db_bind_text()
109 * cosmetic: multi-line DB_STMT_AUC_BY_IMSI
110 * cosmetic: log IMSI='<imsi>', log "no such subscriber"
111 * cosmetic: log: "SQLite" with capital L
112 * cosmetic: db_hlr: SL3_TXT: clarify indenting
113 * ctrl_test_runner.py: use proper constant as test db path
114 * gitignore: tests/package.m4
115 * cosmetic: don't log about missing SQLite log cb
116 * add db_bind_int() and db_bind_int64()
117 * add db_subscr_create(), db_subscr_delete(), db_subscr_update_msisdn_by_imsi()
118 * add initial db_test: creating and deleting subscribers
119 * less noise: simplify db_remove_reset()
120 * db: use int64_t as subscriber id
121 * add db_subscr_get_by_msisdn() and db_subscr_get_by_id()
122 * refactor db_subscr_ps() to db_subscr_nam()
123 * refactor db_subscr_lu()
124 * refactor db_subscr_purge
125 * add db_subscr_update_aud_by_id(), complete db_subscr_delete_by_id()
126 * refactor db_get_auth_data return val
127 * code undup: use db_remove_reset() in db_auc.c
128 * fix db_update_sqn(): reset stmt in all error cases
129 * code undup: use db_bind_text() in db_get_auth_data()
130 * debian: 'make check' needs sqlite3, add to Build-Depends
131 * fix db_subscr_get_by_*(): clear output data; test in db_test.c
132 * implement subscriber vty interface, tests
133 * add test_nodes.vty
134 * replace ctrl_test_runner.py with transcript test_subscriber.ctrl
135 * add lu_op_free(), use in luop.c
136 * luop: fix mem leak upon error in lu_op_alloc_conn()
137 * fix mem leak in handle_cmd_ps(): free luop
138 * api doc: say that lu_op_tx_del_subscr_data() doesn't free
139 * add hlr_subsrc_nam to put GSUP client notification in proper API
140 * vty: fix output of empty IMSI
141 * db api: fix/add API docs
142 * cosmetic: tweak params of hlr_controlif_setup()
143 * ctrl: completely replace all CTRL commands
144 * test_subscriber.ctrl: test against octal/hex interpretation of id
145 * jenkins: use osmo-clean-workspace.sh before and after build
146 * tests/Makefile: use test db var instead of repeating the path
147 * db_test: fix *FLAGS
148 * automatically create db tables on osmo-hlr invocation
149 * cosmetic: sql/hlr.sql: move comments
150 * cosmetic: rename SL3_TXT macro, use osmo_strlcpy()
151 * fix default logging levels to NOTICE, not DEBUG
152 * add osmo-hlr-db-tool, program to migrate from osmo-nitb db
153
154 [ Max ]
155 * Add gerrit settings
156 * Add hardcoded APN
157 * Log error cause as a string
158 * Move GSUP msg init into separate function
159 * Use strings for GSUP message type
160 * Move lu_operation into separate file
161 * db: move duplicated code into helper functions
162 * Fix compiler's warning about printf security
163 * Add routines to update nam_ps
164 * Add global HLR struct
165 * Make subscr parameter to db_subscr_get() optional
166 * Add CTRL interface
167 * CTRL: add enable/disable packet service cmds
168 * Add .deb packaging
169 * deb: fix OBS build
170 * debian: remove obsolete dependency
171 * Attempt to fix .deb package
172 * deb: use python in shebang
173 * Another attempt at fixing .deb
174 * Use release helper from libosmocore
175 * Use value string check from osmo-ci
176
177 [ Daniel Willmann ]
178 * Add systemd service file
179 * hlr_data.sql: Insert ki and opc instead of op to example data
180 * tests/auc: Don't require python3
181
182 [ Pau Espin Pedrol ]
183 * VTY: Add hlr node and bind ip field
184 * debian: remove unneeded dependency libdbd-sqlite3
185
186 [ Harald Welte ]
187 * jenkins.sh: Proper error message if local environment isn't set up
188
189 [ Alexander Couzens ]
190 * debian/rules: show testsuite.log when tests are failing
191
192 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 20:37:33 +0200
193
Maxe9d37db2017-03-13 16:08:11 +0100194osmo-hlr (0.0.1) UNRELEASED; urgency=low
195
196 * Initial release (Closes: OS#1948)
197
198 -- Max Suraev <msuraev@sysmocom.de> Mon, 13 Mar 2017 16:26:41 +0200