blob: 7d8b208d735a2d29385b09477caf725a4aedc251 [file] [log] [blame]
Harald Welte0dcbd472017-10-28 20:37:34 +02001osmo-hlr (0.1.0) unstable; urgency=medium
2
3 [ Neels Hofmeyr ]
4 * build with autoconf/automake, add jenkins.sh script
5 * fix build on FreeBSD: eliminate implicitly declared functions
6 * fix various compiler warnings
7 * fix DLGSUP logging cat after change in libosmocore
8 * build: recoin db_test as non-installable program
9 * build: actually make sqlite mandatory
10 * bump required libosmocore version to 0.9.5
11 * gsup: send subscriber MSISDN
12 * debug log: log computed vector kinds
13 * log: move a log from info to debug level
14 * hlr.sql: typo in comment
15 * auc.c: typo in comment
16 * main: add and use root talloc ctx
17 * main: add option parsing with db file and default options
18 * main: add VTY and '-c config-file' option
19 * sql: fix 3g_auc's column K data type
20 * cosmetic: sql: indicate VARCHAR size of key columns as 32
21 * sql: auc_3g: set sqn NOT NULL DEFAULT 0
22 * comment: sql: describe auc_2g and auc_3g columns
23 * Add test suite skeleton with empty test (auc_3g_test)
24 * tests: auc_3g_test: implement vector generation test
25 * auth: verify test sets from 3GPP TS 55.205
26 * sql: add unique constraints to IMSI and MSISDN
27 * UMTS AKA resync: fix argument ordering
28 * auc_3g_test: add AUTS resync test
29 * auc_gen_vectors(): ensure sane arguments, test
30 * auc_3g_test: allow to inc fake rand bytes upon rand request
31 * auc_3g_test: add AUTS test with N vectors, to show bug
32 * cosmetic: refactor auc_compute_vectors(), add debug log
33 * auc_compute_vectors(): fix AUTS resync for multiple vectors
34 * cosmetic: auc_3g_test: improve test debugging tools
35 * cosmetic: rename auc_3g_test.c to auc_test.c
36 * fix: properly handle error rc by osmo_gsup_conn_ccm_get()
37 * auc tests: adjust cosmetically to prepare for SQN changes
38 * auc tests: fix after SQN scheme changes from libosmocore
39 * fix debug log: adjust to new SQN increment scheme
40 * UMTS AKA: implement SQN increment according to SEQ and IND
41 * debug log: output ind slot, previous sqn, and sqn db update
42 * jenkins: add value_string termination check
43 * fix db_subscr_ps error handling
44 * add config example (mostly empty)
45 * install hlr.sql in prefix/doc/osmo-hlr/
46 * use OSMO_GSUP_PORT == 4222 instead of hardcoded 2222
47 * add basic CTRL interface tests
48 * add CTRL tests for enable-/disable-/status-ps
49 * cosmetic: prepend DB_STMT_ to enum stmt_idx entries
50 * cosmetic: rename db_subscr_get() to db_subscr_get_by_imsi()
51 * cosmetic: refactor db_bind_imsi() as db_bind_text()
52 * cosmetic: multi-line DB_STMT_AUC_BY_IMSI
53 * cosmetic: log IMSI='<imsi>', log "no such subscriber"
54 * cosmetic: log: "SQLite" with capital L
55 * cosmetic: db_hlr: SL3_TXT: clarify indenting
56 * ctrl_test_runner.py: use proper constant as test db path
57 * gitignore: tests/package.m4
58 * cosmetic: don't log about missing SQLite log cb
59 * add db_bind_int() and db_bind_int64()
60 * add db_subscr_create(), db_subscr_delete(), db_subscr_update_msisdn_by_imsi()
61 * add initial db_test: creating and deleting subscribers
62 * less noise: simplify db_remove_reset()
63 * db: use int64_t as subscriber id
64 * add db_subscr_get_by_msisdn() and db_subscr_get_by_id()
65 * refactor db_subscr_ps() to db_subscr_nam()
66 * refactor db_subscr_lu()
67 * refactor db_subscr_purge
68 * add db_subscr_update_aud_by_id(), complete db_subscr_delete_by_id()
69 * refactor db_get_auth_data return val
70 * code undup: use db_remove_reset() in db_auc.c
71 * fix db_update_sqn(): reset stmt in all error cases
72 * code undup: use db_bind_text() in db_get_auth_data()
73 * debian: 'make check' needs sqlite3, add to Build-Depends
74 * fix db_subscr_get_by_*(): clear output data; test in db_test.c
75 * implement subscriber vty interface, tests
76 * add test_nodes.vty
77 * replace ctrl_test_runner.py with transcript test_subscriber.ctrl
78 * add lu_op_free(), use in luop.c
79 * luop: fix mem leak upon error in lu_op_alloc_conn()
80 * fix mem leak in handle_cmd_ps(): free luop
81 * api doc: say that lu_op_tx_del_subscr_data() doesn't free
82 * add hlr_subsrc_nam to put GSUP client notification in proper API
83 * vty: fix output of empty IMSI
84 * db api: fix/add API docs
85 * cosmetic: tweak params of hlr_controlif_setup()
86 * ctrl: completely replace all CTRL commands
87 * test_subscriber.ctrl: test against octal/hex interpretation of id
88 * jenkins: use osmo-clean-workspace.sh before and after build
89 * tests/Makefile: use test db var instead of repeating the path
90 * db_test: fix *FLAGS
91 * automatically create db tables on osmo-hlr invocation
92 * cosmetic: sql/hlr.sql: move comments
93 * cosmetic: rename SL3_TXT macro, use osmo_strlcpy()
94 * fix default logging levels to NOTICE, not DEBUG
95 * add osmo-hlr-db-tool, program to migrate from osmo-nitb db
96
97 [ Max ]
98 * Add gerrit settings
99 * Add hardcoded APN
100 * Log error cause as a string
101 * Move GSUP msg init into separate function
102 * Use strings for GSUP message type
103 * Move lu_operation into separate file
104 * db: move duplicated code into helper functions
105 * Fix compiler's warning about printf security
106 * Add routines to update nam_ps
107 * Add global HLR struct
108 * Make subscr parameter to db_subscr_get() optional
109 * Add CTRL interface
110 * CTRL: add enable/disable packet service cmds
111 * Add .deb packaging
112 * deb: fix OBS build
113 * debian: remove obsolete dependency
114 * Attempt to fix .deb package
115 * deb: use python in shebang
116 * Another attempt at fixing .deb
117 * Use release helper from libosmocore
118 * Use value string check from osmo-ci
119
120 [ Daniel Willmann ]
121 * Add systemd service file
122 * hlr_data.sql: Insert ki and opc instead of op to example data
123 * tests/auc: Don't require python3
124
125 [ Pau Espin Pedrol ]
126 * VTY: Add hlr node and bind ip field
127 * debian: remove unneeded dependency libdbd-sqlite3
128
129 [ Harald Welte ]
130 * jenkins.sh: Proper error message if local environment isn't set up
131
132 [ Alexander Couzens ]
133 * debian/rules: show testsuite.log when tests are failing
134
135 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 20:37:33 +0200
136
Maxe9d37db2017-03-13 16:08:11 +0100137osmo-hlr (0.0.1) UNRELEASED; urgency=low
138
139 * Initial release (Closes: OS#1948)
140
141 -- Max Suraev <msuraev@sysmocom.de> Mon, 13 Mar 2017 16:26:41 +0200