blob: 0ac618d4b353fc12de060c8340d28067ff68ba87 [file] [log] [blame]
Pau Espin Pedrol62404652021-02-23 18:13:53 +01001osmo-hlr (1.3.0) unstable; urgency=medium
2
3 [ Alexander Couzens ]
4 * hlr: respect the num_auth_vectors requested
5 * hlr: remove unused internal USSD list
6
7 [ Oliver Smith ]
8 * add libosmo-mslookup abstract client
9 * add mDNS lookup method to libosmo-mslookup
10 * Makefile.am: fix pkgconfig_DATA
11 * add mDNS lookup method to libosmo-mslookup (#2)
12 * contrib/dgsm/ add example esme and dialplan
13 * mslookup_client.c: fix dereferencing null pointer
14 * mdns_msg.c: always call va_end
15 * mslookup_client_mdns.c: fix dereferencing null
16 * osmo-mslookup-client.c: fix dereferencing null
17 * osmo-mslookup-client: fix dereferencing null
18 * mdns_sock.c: fix resource leak of sock
19 * mdns_rfc.c: fix possible access of uninit. mem
20 * mslookup_client_mdns_test: disable by default
21 * mslookup_client_mdns_test: no automatic skip
22 * Cosmetic: mention OS#4491 in location cancel code
23 * hlr_vty_subscr: prettier output for last LU seen
24 * contrib: import RPM spec
25 * contrib: integrate RPM spec
26 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
27 * contrib/jenkins: don't build osmo-gsm-manuals
28 * configure.ac: set -std=gnu11
29
30 [ Neels Hofmeyr ]
31 * add osmo-mslookup-client program
32 * add osmo-mslookup-client program (#2)
33 * fix missing braces in LOGP_GSUP_FWD
34 * gsup_client.c: fix deprecation for client create func
35 * 1/2: refactor: add and use lu_fsm, osmo_gsup_req, osmo_ipa_name
36 * 2/2: wrap ipa_name in osmo_cni_peer_id with type enum and union
37 * gsup client: add up_down_cb(), add osmo_gsup_client_create3()
38 * db v5: prep for D-GSM: add vlr_via_proxy and sgsn_via_proxy
39 * enlarge the GSUP message headroom
40 * test_nodes.vty: remove cruft
41 * D-GSM 1/n: add mslookup server in osmo-hlr
42 * D-GSM 2/n: implement mDNS method of mslookup server
43 * D-GSM 3/n: implement roaming by mslookup in osmo-hlr
44 * gsup_server: send routing error back to the correct peer
45 * adoc: add D-GSM chapter to osmohlr-usermanual
46 * drop error log for when a subscriber does not exist
47 * vty: show subscriber: change format of 'last LU seen'
48 * vty: show subscriber: show lu d,h,m,s ago, not just seconds
49 * auc3g: officially wrap IND around IND_bitlen space
50 * make osmo_cni_peer_id_cmp() NULL safe
51 * osmo_gsup_req_new(): require from_peer != NULL
52 * gsup_server.c: properly handle negative rc from osmo_gsup_conn_ccm_get()
53 * osmo_mslookup_server_mdns_rx(): handle read() rc == 0
54 * hlr_subscr_nam(): fix condition to fix nam=false notifications
55 * esme_dgsm.py: add --always-fail option for debugging SMPP
56 * osmo-mslookup-client: fix segfault for respond_error() caller
57 * manual: describe subscriber import by SQL
58
59 [ Harald Welte ]
60 * Revert "add osmo-mslookup-client program"
61 * Revert "add mDNS lookup method to libosmo-mslookup"
62 * Use OSMO_FD_* instead of deprecated BSC_FD_*
63 * support the XOR algorithm for UMTS AKA
64 * auc_test.c: Add some comments on what the test cases actually do
65 * main: add --vty-ref-mode, use vty_dump_xml_ref_mode()
66 * manuals: generate vty reference xml at build time
67
68 [ Vadim Yanitskiy ]
69 * db: fix possible SQLite3 allocated memory leak in db_open()
70 * gsup_server: fix typo: s/omso_gsup_message/osmo_gsup_message/
71 * debian/control: change maintainer to the Osmocom team / mailing list
72 * cosmetic: fix spelling in logging message: existAnt -> existEnt
73 * doc/manuals: fix s/There/The/ in 'USSD Configuration'
74 * doc/manuals: re-organize description of internal USSD handlers
75 * USSD: fix handle_ussd(): do not free() unconditionally
76 * USSD: add special 'idle' handler to IUSE for testing
77
78 [ Eric ]
79 * configure.ac: fix libtool issue with clang and sanitizer
80
81 [ Philipp Maier ]
82 * doc: do not use loglevel info for log category ss
83
84 [ Pau Espin Pedrol ]
85 * configure.ac: Fix trailing whitespace
86 * doc: Update VTY reference xml file
87 * Support setting rt-prio and cpu-affinity mask through VTY
88 * Set TCP NODELAY sockopt to GSUP cli and srv connections
89 * contrib/jenkins: Enable parallel make in make distcheck
90 * .gitignore: Ignore new autofoo tmp files
91 * tests: Replace deprecated API log_set_print_filename
92
93 [ Keith ]
94 * osmo-hlr-db-tool: Make import from osmo-nitb less "lossy"
95 * Correct vty inline help for show subscriber
96 * Add vty command to show summary of all or filtered subscribers
97 * Fix Coverity Warnings
98
99 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 23 Feb 2021 18:13:53 +0100
100
Pau Espin Pedrol3a666982020-01-03 12:37:35 +0100101osmo-hlr (1.2.0) unstable; urgency=medium
102
103 [ Ruben Undheim ]
104 * Fix test for return codes on mipsel and alpha archs
105
106 [ Thorsten Alteholz ]
107 * fix spelling errors detected by lintian
108
109 [ Pau Espin Pedrol ]
110 * tests: Fix db_test err file to expect error code name instead of value
111
112 [ Oliver Smith ]
113 * tests/test_nodes.vty: check less libosmocore cmds
114 * tests/db_upgrade: disable for old sqlite versions
115 * gitignore: add tests/db_upgrade/*.dump
116 * gsup_client.h: fix license header: GPLv2+
117 * tests/auc: change back to python3
118
119 [ Neels Hofmeyr ]
120 * fix double free in osmo_gsup_client_enc_send()
121 * db upgrade to v2: log version 2, not 1
122 * fix upgrade to version 2: imei column default value
123 * add --db-check option
124 * hlr.sql: move comment
125 * add db_upgrade test
126 * hlr db schema 3: hlr_number -> msc_number
127 * db.c: code dup: add db_run_statements() for arrays of statements
128 * move headers to include/osmocom/hlr
129 * fix upgrade test in presence of ~/.sqliterc
130 * db upgrade: remove some code dup
131 * add osmo_gsup_msgb_alloc()
132 * Makefile convenience: add VTY_TEST var to run only one test
133 * remove gsup_test
134 * test_nodes.vty: tweak: add some '?' checks
135 * db v4: add column last_lu_seen_ps
136
137 [ Harald Welte ]
138 * AUC: Add support for setting the AMF separation bit to '1' for EUTRAN
139 * hlr: exit(2) on unsupported positional arguments on command line
140
141 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 12:37:35 +0100
142
Pau Espin Pedrol9cf00302019-08-07 16:14:23 +0200143osmo-hlr (1.1.0) unstable; urgency=medium
144
145 [ Oliver Smith ]
146 * docs: running: document --db-upgrade
147 * Add IMEI column to subscriber table
148 * Optionally store IMEI in subscriber table
149 * VTY tests: fill DB before running test
150 * VTY: integrate IMEI
151 * hlr.c: replace deprecated osmo_gsup_get_err_msg_type()
152 * hlr.c: move hlr_ctx to the top
153 * tests: use -no-install libtool flag to avoid ./lt-* scripts
154 * Cosmetic: gsup_route_find: comment addr, addrlen
155 * USSD: save MO USSD's originating MSC's vlr_number
156 * USSD: don't use gsm0480_msgb_alloc_name()
157 * hlr.c: forward GSUP messages between clients
158 * db_hlr.c: db_subscr_create(): add flags argument
159 * db_hlr.c: add db_subscr_exists_by_imsi()
160 * Create subscribers on demand
161 * Document subscribers create on demand feature
162 * debian: create -doc subpackage with pdf manuals
163 * db_test: set timezone to work around mktime bug
164 * db_hlr: zero-initialize "struct tm"
165 * rx_check_imei_req(): fix IMEI bounds checking
166 * contrib/jenkins.sh: run "make maintainer-clean"
167 * VTY: add subscriber update network-access-mode
168 * manuals: improve subscribers create on demand
169 * gitignore: ignore everything generated in db_test
170 * db_auc.c: verify hex key sizes read from DB
171
172 [ Max ]
173 * Log ip:port when adding GSUP routes
174 * Add link to project wiki to .service file
175 * Enable statsd support
176
177 [ Vadim Yanitskiy ]
178 * hlr.c: properly terminate the process on SIGTERM
179 * hlr.c: fix: also store the session state in read_cb_forward()
180 * hlr.c: fix: properly print the original message type in read_cb_forward()
181 * hlr.c: check the presence of msgb->l2h in read_cb()
182 * hlr.c: fix possible msgb memleaks in read_cb()
183 * db_hlr.c: add db_subscr_exists_by_msisdn()
184 * src/db.h: use GSM23003_MSISDN_MAX_DIGITS for MSISDN buffer size
185 * src/hlr.c: fix deprecation warning: use gsm48_decode_bcd_number2()
186 * hlr_ussd.c: fix: properly pass invokeID in handle_ussd_own_msisdn()
187 * hlr_ussd.c: rx_proc_ss_req(): fix NULL pointer dereference
188 * build: fix mess with 'db_test_SOURCES' and 'db_test_LDADD'
189 * tests/db_test: close the database when test is finished
190 * src/db.c: integrate SQLite3 with talloc allocator
191
192 [ Neels Hofmeyr ]
193 * USSD: fix routing to multiple MSC
194 * fix error logging for GSUP route
195 * add missing error log: invalid IMSI
196 * osmo-hlr: allow configuring db path from cfg file
197 * use new OSMO_IMSI_BUF_SIZE
198
199 [ Daniel Willmann ]
200 * manuals: Add script to update vty/counter documentation from docker
201 * manuals: Update vty documentation
202
203 [ Pau Espin Pedrol ]
204 * Remove undefined param passed to logging_vty_add_cmds
205 * configure.ac: Require libosmocore 1.2.0
206
207 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 16:14:23 +0200
208
Harald Weltee0c6fe52019-01-20 19:29:59 +0100209osmo-hlr (1.0.0) unstable; urgency=medium
210
211 [ Stefan Sperling ]
212 * move creation of insert subscriber data messages to a common function
213
214 [ Harald Welte ]
215 * Return proper GSUP error in case of too short IMSI
216 * disable blind subscriber insertion into every VLR/SGSN
217 * gsup_server: Add "priv" pointer and make it point to 'struct hlr'
218 * move osmo_gsup_addr_send() declaration from luop.h to gsup_router.h
219 * gsup_router: Use "#pragma once" and add missing #includes
220 * Add "show gsup-connections" VTY command
221 * import gsup_client.c as new libosmo-gsup-client
222 * gsup_client: rename gsup_client_* to osmo_gsup_client_*
223 * GSUP: Log GSUP route add/remove
224 * hlr: Export + Declare global g_hlr symbol
225 * USSD: Add Core USSD handling + VTY routing config to HLR
226 * USSD: Add basic dispatch + decode of GSUP-encapsulated SS/USSD
227 * hlr_ussd: Introduce LOGPSS() macro
228 * USSD: Send ReturnError component if USSD Code unknown / EUSE disconnected
229 * USSD: Further unification of log output; Use LOGPSS when possible
230 * osmo-hlr.cfg: Don't enable DEBUG logging by default
231 * USSD: Add new "DSS" logging category and use it appropriately
232 * USSD: fix null-pointer deref in "default-route" vty/config cmd
233 * Add osmo-euse-demo as minimalistic test of a External USSD (EUSE) handler
234 * USSD: Add support for internal USSD handlers
235 * debian: Add sub-package for libosmo-gsup-client
236 * pkg-config: Fix libosmo-gsup-client pkg-config file
237 * gitignore: Add .tarball-version
238 * debian: Make libosmo-gsup-client-dev depend on libosmo-gsup-client0
239 * USSD: Fix "ussd default-route"
240 * libosmo-gsup-client: License is GPLv2-or-later
241 * osmo-hlr.cfg: Ensure well-formed config file example
242 * test_nodes.vty: Since libosmocore 1.0.0, we only have one space
243
244 [ Martin Hauke ]
245 * sql/Makefile.am: Make docsdir completely configurable
246 * debian: Fix typo in package description
247
248 [ Pau Espin Pedrol ]
249 * debian: Avoid installing duplicate cfg file in /etc
250 * sql/Makefile: Install hlr_data.sql as example together with hlr.sql
251 * sql/Makefile: Install sql files under doc/.../sql subdir
252 * sql/Makefile: Create empty /var/lib/osmocom directory at install time
253 * Install systemd services with autotools
254 * Move doc/Makefile.am to doc/examples/Makefile.am
255 * Install sample cfg file to /etc/osmocom
256
257 [ Vadim Yanitskiy ]
258 * hlr.c: move deinitialization code from SIGINT handler
259 * hlr.c: free root talloc context on exit
260 * hlr.c: track the use of talloc NULL memory contexts
261 * src/db.c: fix: make sure the database is properly closed
262 * src/db.c: don't ignore the result of db_bootstrap()
263 * hlr_vty_subscr.c: fix subscriber creation command help
264 * Update .gitignore: add missing build products
265 * tests/Makefile.am: also remove temporary sqlite files
266 * hlr_ussd.h: add #pragma once include guard
267 * hlr_ussd.h: use proper libc headers
268 * Update .gitignore: ignore osmo-euse-demo
269 * hlr_ussd.h: drop meaningless forward declaration
270 * USSD/hlr_vty.c: print error if EUSE is not found
271 * hlr_ussd.c: fix: properly print a EUSE / IUSE name
272 * hlr_ussd.c: avoid using CR and NL in IUSE responses
273
274 [ Neels Hofmeyr ]
275 * fix build: adjust test_nodes.vty to logging change
276 * tweak example config
277 * make: always allow running python tests manually
278
279 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 19:29:58 +0100
280
Pau Espin Pedrol78f43012018-05-04 18:41:35 +0200281osmo-hlr (0.2.1) unstable; urgency=medium
282
283 [ Neels Hofmeyr ]
284 * fix luop crash: use buffer for APN that remains valid
285 * add gsup_test to catch OS#3231
286 * add error handling to osmo_gsup_configure_wildcard_apn()
287
288 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 04 May 2018 18:41:35 +0200
289
Pau Espin Pedrolcb360f02018-05-03 16:27:14 +0200290osmo-hlr (0.2.0) unstable; urgency=medium
291
292 [ Neels Hofmeyr ]
293 * vty: skip installing cmds now always installed by default
294 * hlr_db_tool: fix error log strerror invocation
295 * cosmetic: add comment on ignored return value
296 * db-tool: add command 'create'
297 * db-tool: cosmetic: tweak printf output
298 * db-tool: error-exit on too many arguments
299 * add --enable-sanitize config option
300 * db_test: don't verify SQLite issued error messages, they might change
301 * cosmetic: rx_send_auth_info(): decide error cause with switch()
302 * return GMM_CAUSE_IMSI_UNKNOWN if there is no auth data
303 * db_get_auth_data / db_get_auc: clarify return values
304 * osmo-hlr: log details for unknown IMSI / no auth data / db error
305 * db_test: also test db_get_auc() return values
306 * fix test_subscriber_errors.ctrl after libosmocore change
307 * fix debug log: put 'deriving 2G from 3G' in proper place
308 * ctrl test: fix: adjust expectations after stricter ctrl parsing
309 * fix build: db_test: missing LIBOSMOABIS_CFLAGS and _LIBS
310 * configure: add --enable-werror
311 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
312
313 [ Harald Welte ]
314 * hlr.c: Avoid overflow of lu_operation.subscr.imsi
315 * Fix expected test output after new 'logging print file 1' vty command
316 * osmo-hlr: Add talloc context introspection via VTY
317 * vty: Don't print error if removing auth data while none present
318 * Fix responses to PURGE MS
319
320 [ Alexander Couzens ]
321 * debian: include systemd service osmo-hlr.service
322 * doc: install example .cfg files to $(docdir)/examples/
323 * debian: install osmo-hlr.cfg to /etc/osmocom
324
325 [ Max ]
326 * Remove unused check
327 * Remove unused ipa.py
328 * Enable sanitize for CI tests
329
330 [ Pau Espin Pedrol ]
331 * luop.c: Transform FIXME from warning to pragma message
332 * contrib:jenkins.sh: Enable Werror
333 * use osmo_init_logging2
334 * Remove unused src/db_test.c
335
336 [ Alexander Huemer ]
337 * Add missing build products in .gitignore
338
339 [ Stefan Sperling ]
340 * more robust usage of osmo_timer API for osmo-hlr luop timer
341 * notify GSUP clients when HLR subscriber information changes
342 * rewrite subscriber_update_notify() without calls into luop
343 * don't forget to mark luop as a packet switched connection
344
345 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:27:13 +0200
346
Harald Welte0dcbd472017-10-28 20:37:34 +0200347osmo-hlr (0.1.0) unstable; urgency=medium
348
349 [ Neels Hofmeyr ]
350 * build with autoconf/automake, add jenkins.sh script
351 * fix build on FreeBSD: eliminate implicitly declared functions
352 * fix various compiler warnings
353 * fix DLGSUP logging cat after change in libosmocore
354 * build: recoin db_test as non-installable program
355 * build: actually make sqlite mandatory
356 * bump required libosmocore version to 0.9.5
357 * gsup: send subscriber MSISDN
358 * debug log: log computed vector kinds
359 * log: move a log from info to debug level
360 * hlr.sql: typo in comment
361 * auc.c: typo in comment
362 * main: add and use root talloc ctx
363 * main: add option parsing with db file and default options
364 * main: add VTY and '-c config-file' option
365 * sql: fix 3g_auc's column K data type
366 * cosmetic: sql: indicate VARCHAR size of key columns as 32
367 * sql: auc_3g: set sqn NOT NULL DEFAULT 0
368 * comment: sql: describe auc_2g and auc_3g columns
369 * Add test suite skeleton with empty test (auc_3g_test)
370 * tests: auc_3g_test: implement vector generation test
371 * auth: verify test sets from 3GPP TS 55.205
372 * sql: add unique constraints to IMSI and MSISDN
373 * UMTS AKA resync: fix argument ordering
374 * auc_3g_test: add AUTS resync test
375 * auc_gen_vectors(): ensure sane arguments, test
376 * auc_3g_test: allow to inc fake rand bytes upon rand request
377 * auc_3g_test: add AUTS test with N vectors, to show bug
378 * cosmetic: refactor auc_compute_vectors(), add debug log
379 * auc_compute_vectors(): fix AUTS resync for multiple vectors
380 * cosmetic: auc_3g_test: improve test debugging tools
381 * cosmetic: rename auc_3g_test.c to auc_test.c
382 * fix: properly handle error rc by osmo_gsup_conn_ccm_get()
383 * auc tests: adjust cosmetically to prepare for SQN changes
384 * auc tests: fix after SQN scheme changes from libosmocore
385 * fix debug log: adjust to new SQN increment scheme
386 * UMTS AKA: implement SQN increment according to SEQ and IND
387 * debug log: output ind slot, previous sqn, and sqn db update
388 * jenkins: add value_string termination check
389 * fix db_subscr_ps error handling
390 * add config example (mostly empty)
391 * install hlr.sql in prefix/doc/osmo-hlr/
392 * use OSMO_GSUP_PORT == 4222 instead of hardcoded 2222
393 * add basic CTRL interface tests
394 * add CTRL tests for enable-/disable-/status-ps
395 * cosmetic: prepend DB_STMT_ to enum stmt_idx entries
396 * cosmetic: rename db_subscr_get() to db_subscr_get_by_imsi()
397 * cosmetic: refactor db_bind_imsi() as db_bind_text()
398 * cosmetic: multi-line DB_STMT_AUC_BY_IMSI
399 * cosmetic: log IMSI='<imsi>', log "no such subscriber"
400 * cosmetic: log: "SQLite" with capital L
401 * cosmetic: db_hlr: SL3_TXT: clarify indenting
402 * ctrl_test_runner.py: use proper constant as test db path
403 * gitignore: tests/package.m4
404 * cosmetic: don't log about missing SQLite log cb
405 * add db_bind_int() and db_bind_int64()
406 * add db_subscr_create(), db_subscr_delete(), db_subscr_update_msisdn_by_imsi()
407 * add initial db_test: creating and deleting subscribers
408 * less noise: simplify db_remove_reset()
409 * db: use int64_t as subscriber id
410 * add db_subscr_get_by_msisdn() and db_subscr_get_by_id()
411 * refactor db_subscr_ps() to db_subscr_nam()
412 * refactor db_subscr_lu()
413 * refactor db_subscr_purge
414 * add db_subscr_update_aud_by_id(), complete db_subscr_delete_by_id()
415 * refactor db_get_auth_data return val
416 * code undup: use db_remove_reset() in db_auc.c
417 * fix db_update_sqn(): reset stmt in all error cases
418 * code undup: use db_bind_text() in db_get_auth_data()
419 * debian: 'make check' needs sqlite3, add to Build-Depends
420 * fix db_subscr_get_by_*(): clear output data; test in db_test.c
421 * implement subscriber vty interface, tests
422 * add test_nodes.vty
423 * replace ctrl_test_runner.py with transcript test_subscriber.ctrl
424 * add lu_op_free(), use in luop.c
425 * luop: fix mem leak upon error in lu_op_alloc_conn()
426 * fix mem leak in handle_cmd_ps(): free luop
427 * api doc: say that lu_op_tx_del_subscr_data() doesn't free
428 * add hlr_subsrc_nam to put GSUP client notification in proper API
429 * vty: fix output of empty IMSI
430 * db api: fix/add API docs
431 * cosmetic: tweak params of hlr_controlif_setup()
432 * ctrl: completely replace all CTRL commands
433 * test_subscriber.ctrl: test against octal/hex interpretation of id
434 * jenkins: use osmo-clean-workspace.sh before and after build
435 * tests/Makefile: use test db var instead of repeating the path
436 * db_test: fix *FLAGS
437 * automatically create db tables on osmo-hlr invocation
438 * cosmetic: sql/hlr.sql: move comments
439 * cosmetic: rename SL3_TXT macro, use osmo_strlcpy()
440 * fix default logging levels to NOTICE, not DEBUG
441 * add osmo-hlr-db-tool, program to migrate from osmo-nitb db
442
443 [ Max ]
444 * Add gerrit settings
445 * Add hardcoded APN
446 * Log error cause as a string
447 * Move GSUP msg init into separate function
448 * Use strings for GSUP message type
449 * Move lu_operation into separate file
450 * db: move duplicated code into helper functions
451 * Fix compiler's warning about printf security
452 * Add routines to update nam_ps
453 * Add global HLR struct
454 * Make subscr parameter to db_subscr_get() optional
455 * Add CTRL interface
456 * CTRL: add enable/disable packet service cmds
457 * Add .deb packaging
458 * deb: fix OBS build
459 * debian: remove obsolete dependency
460 * Attempt to fix .deb package
461 * deb: use python in shebang
462 * Another attempt at fixing .deb
463 * Use release helper from libosmocore
464 * Use value string check from osmo-ci
465
466 [ Daniel Willmann ]
467 * Add systemd service file
468 * hlr_data.sql: Insert ki and opc instead of op to example data
469 * tests/auc: Don't require python3
470
471 [ Pau Espin Pedrol ]
472 * VTY: Add hlr node and bind ip field
473 * debian: remove unneeded dependency libdbd-sqlite3
474
475 [ Harald Welte ]
476 * jenkins.sh: Proper error message if local environment isn't set up
477
478 [ Alexander Couzens ]
479 * debian/rules: show testsuite.log when tests are failing
480
481 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 20:37:33 +0200
482
Maxe9d37db2017-03-13 16:08:11 +0100483osmo-hlr (0.0.1) UNRELEASED; urgency=low
484
485 * Initial release (Closes: OS#1948)
486
487 -- Max Suraev <msuraev@sysmocom.de> Mon, 13 Mar 2017 16:26:41 +0200