blob: 10683c9b548a6a16e166a29fd243fd76036f244c [file] [log] [blame]
Pau Espin Pedrol65f51532022-06-28 18:38:31 +02001osmo-hlr (1.5.0) unstable; urgency=medium
2
3 [ Oliver Smith ]
4 * treewide: remove FSF address
5
6 [ Vadim Yanitskiy ]
7 * fixup: debian: remove unneeded dependency libdbd-sqlite3
8 * debian: add new 'osmo-mslookup-utils' package
9 * tests: use 'check_PROGRAMS' instead of 'noinst_PROGRAMS'
10
11 [ Pau Espin Pedrol ]
12 * ctrl: Mark function as static
13 * tests: Allow specyfing specific ctrl test to run
14 * tests/ctrl: Move ERROR test scenario to proper file
15 * Fix db_subscr_create() not returning -EEXIST expected by VTY subscriber create cmd
16 * ctrl: Introduce cmd SET subscriber.create <imsi>
17 * ctrl: Introduce CTRL command subscriber.by-*.msisdn
18 * cosmetic: hlr_vty_subscr.c: Fix trailing whitespace
19 * ctrl: Introduce cmd SET subscriber.delete <imsi>
20 * ctrl: Introduce CTRL command subscriber.by-*.aud2g <algo[,ki]>
21 * ctrl: Introduce CTRL command subscriber.by-*.aud3g <algo[,KI,(op|opc),OP_C[,ind_bitlen]]>
22 * doc: Document new subscriber CTRL commands
23
24 [ Harald Welte ]
25 * update git URLs (git -> https; gitea)
26
27 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 28 Jun 2022 18:38:31 +0200
28
Pau Espin Pedrol4d7cbfc2021-11-16 14:56:41 +010029osmo-hlr (1.4.0) unstable; urgency=medium
30
31 [ Keith ]
32 * Correct configuration written from vty
33 * vty: enable show subscribers filtered by IMEI
34
35 [ Harald Welte ]
36 * add README.md file as customary for cgit, github, gitlab, etc.
37
38 [ Oliver Smith ]
39 * Add post-upgrade script for automatic db upgrade
40 * debian/control: remove dh-systemd build-depend
41
42 [ Pau Espin Pedrol ]
43 * db: Avoid use uninitialized rc if running 0 statements
44
45 [ Neels Hofmeyr ]
46 * db v6: determine 3G AUC IND from VLR name
47
48 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 16 Nov 2021 14:56:41 +0100
49
Pau Espin Pedrol62404652021-02-23 18:13:53 +010050osmo-hlr (1.3.0) unstable; urgency=medium
51
52 [ Alexander Couzens ]
53 * hlr: respect the num_auth_vectors requested
54 * hlr: remove unused internal USSD list
55
56 [ Oliver Smith ]
57 * add libosmo-mslookup abstract client
58 * add mDNS lookup method to libosmo-mslookup
59 * Makefile.am: fix pkgconfig_DATA
60 * add mDNS lookup method to libosmo-mslookup (#2)
61 * contrib/dgsm/ add example esme and dialplan
62 * mslookup_client.c: fix dereferencing null pointer
63 * mdns_msg.c: always call va_end
64 * mslookup_client_mdns.c: fix dereferencing null
65 * osmo-mslookup-client.c: fix dereferencing null
66 * osmo-mslookup-client: fix dereferencing null
67 * mdns_sock.c: fix resource leak of sock
68 * mdns_rfc.c: fix possible access of uninit. mem
69 * mslookup_client_mdns_test: disable by default
70 * mslookup_client_mdns_test: no automatic skip
71 * Cosmetic: mention OS#4491 in location cancel code
72 * hlr_vty_subscr: prettier output for last LU seen
73 * contrib: import RPM spec
74 * contrib: integrate RPM spec
75 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
76 * contrib/jenkins: don't build osmo-gsm-manuals
77 * configure.ac: set -std=gnu11
78
79 [ Neels Hofmeyr ]
80 * add osmo-mslookup-client program
81 * add osmo-mslookup-client program (#2)
82 * fix missing braces in LOGP_GSUP_FWD
83 * gsup_client.c: fix deprecation for client create func
84 * 1/2: refactor: add and use lu_fsm, osmo_gsup_req, osmo_ipa_name
85 * 2/2: wrap ipa_name in osmo_cni_peer_id with type enum and union
86 * gsup client: add up_down_cb(), add osmo_gsup_client_create3()
87 * db v5: prep for D-GSM: add vlr_via_proxy and sgsn_via_proxy
88 * enlarge the GSUP message headroom
89 * test_nodes.vty: remove cruft
90 * D-GSM 1/n: add mslookup server in osmo-hlr
91 * D-GSM 2/n: implement mDNS method of mslookup server
92 * D-GSM 3/n: implement roaming by mslookup in osmo-hlr
93 * gsup_server: send routing error back to the correct peer
94 * adoc: add D-GSM chapter to osmohlr-usermanual
95 * drop error log for when a subscriber does not exist
96 * vty: show subscriber: change format of 'last LU seen'
97 * vty: show subscriber: show lu d,h,m,s ago, not just seconds
98 * auc3g: officially wrap IND around IND_bitlen space
99 * make osmo_cni_peer_id_cmp() NULL safe
100 * osmo_gsup_req_new(): require from_peer != NULL
101 * gsup_server.c: properly handle negative rc from osmo_gsup_conn_ccm_get()
102 * osmo_mslookup_server_mdns_rx(): handle read() rc == 0
103 * hlr_subscr_nam(): fix condition to fix nam=false notifications
104 * esme_dgsm.py: add --always-fail option for debugging SMPP
105 * osmo-mslookup-client: fix segfault for respond_error() caller
106 * manual: describe subscriber import by SQL
107
108 [ Harald Welte ]
109 * Revert "add osmo-mslookup-client program"
110 * Revert "add mDNS lookup method to libosmo-mslookup"
111 * Use OSMO_FD_* instead of deprecated BSC_FD_*
112 * support the XOR algorithm for UMTS AKA
113 * auc_test.c: Add some comments on what the test cases actually do
114 * main: add --vty-ref-mode, use vty_dump_xml_ref_mode()
115 * manuals: generate vty reference xml at build time
116
117 [ Vadim Yanitskiy ]
118 * db: fix possible SQLite3 allocated memory leak in db_open()
119 * gsup_server: fix typo: s/omso_gsup_message/osmo_gsup_message/
120 * debian/control: change maintainer to the Osmocom team / mailing list
121 * cosmetic: fix spelling in logging message: existAnt -> existEnt
122 * doc/manuals: fix s/There/The/ in 'USSD Configuration'
123 * doc/manuals: re-organize description of internal USSD handlers
124 * USSD: fix handle_ussd(): do not free() unconditionally
125 * USSD: add special 'idle' handler to IUSE for testing
126
127 [ Eric ]
128 * configure.ac: fix libtool issue with clang and sanitizer
129
130 [ Philipp Maier ]
131 * doc: do not use loglevel info for log category ss
132
133 [ Pau Espin Pedrol ]
134 * configure.ac: Fix trailing whitespace
135 * doc: Update VTY reference xml file
136 * Support setting rt-prio and cpu-affinity mask through VTY
137 * Set TCP NODELAY sockopt to GSUP cli and srv connections
138 * contrib/jenkins: Enable parallel make in make distcheck
139 * .gitignore: Ignore new autofoo tmp files
140 * tests: Replace deprecated API log_set_print_filename
141
142 [ Keith ]
143 * osmo-hlr-db-tool: Make import from osmo-nitb less "lossy"
144 * Correct vty inline help for show subscriber
145 * Add vty command to show summary of all or filtered subscribers
146 * Fix Coverity Warnings
147
148 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 23 Feb 2021 18:13:53 +0100
149
Pau Espin Pedrol3a666982020-01-03 12:37:35 +0100150osmo-hlr (1.2.0) unstable; urgency=medium
151
152 [ Ruben Undheim ]
153 * Fix test for return codes on mipsel and alpha archs
154
155 [ Thorsten Alteholz ]
156 * fix spelling errors detected by lintian
157
158 [ Pau Espin Pedrol ]
159 * tests: Fix db_test err file to expect error code name instead of value
160
161 [ Oliver Smith ]
162 * tests/test_nodes.vty: check less libosmocore cmds
163 * tests/db_upgrade: disable for old sqlite versions
164 * gitignore: add tests/db_upgrade/*.dump
165 * gsup_client.h: fix license header: GPLv2+
166 * tests/auc: change back to python3
167
168 [ Neels Hofmeyr ]
169 * fix double free in osmo_gsup_client_enc_send()
170 * db upgrade to v2: log version 2, not 1
171 * fix upgrade to version 2: imei column default value
172 * add --db-check option
173 * hlr.sql: move comment
174 * add db_upgrade test
175 * hlr db schema 3: hlr_number -> msc_number
176 * db.c: code dup: add db_run_statements() for arrays of statements
177 * move headers to include/osmocom/hlr
178 * fix upgrade test in presence of ~/.sqliterc
179 * db upgrade: remove some code dup
180 * add osmo_gsup_msgb_alloc()
181 * Makefile convenience: add VTY_TEST var to run only one test
182 * remove gsup_test
183 * test_nodes.vty: tweak: add some '?' checks
184 * db v4: add column last_lu_seen_ps
185
186 [ Harald Welte ]
187 * AUC: Add support for setting the AMF separation bit to '1' for EUTRAN
188 * hlr: exit(2) on unsupported positional arguments on command line
189
190 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 12:37:35 +0100
191
Pau Espin Pedrol9cf00302019-08-07 16:14:23 +0200192osmo-hlr (1.1.0) unstable; urgency=medium
193
194 [ Oliver Smith ]
195 * docs: running: document --db-upgrade
196 * Add IMEI column to subscriber table
197 * Optionally store IMEI in subscriber table
198 * VTY tests: fill DB before running test
199 * VTY: integrate IMEI
200 * hlr.c: replace deprecated osmo_gsup_get_err_msg_type()
201 * hlr.c: move hlr_ctx to the top
202 * tests: use -no-install libtool flag to avoid ./lt-* scripts
203 * Cosmetic: gsup_route_find: comment addr, addrlen
204 * USSD: save MO USSD's originating MSC's vlr_number
205 * USSD: don't use gsm0480_msgb_alloc_name()
206 * hlr.c: forward GSUP messages between clients
207 * db_hlr.c: db_subscr_create(): add flags argument
208 * db_hlr.c: add db_subscr_exists_by_imsi()
209 * Create subscribers on demand
210 * Document subscribers create on demand feature
211 * debian: create -doc subpackage with pdf manuals
212 * db_test: set timezone to work around mktime bug
213 * db_hlr: zero-initialize "struct tm"
214 * rx_check_imei_req(): fix IMEI bounds checking
215 * contrib/jenkins.sh: run "make maintainer-clean"
216 * VTY: add subscriber update network-access-mode
217 * manuals: improve subscribers create on demand
218 * gitignore: ignore everything generated in db_test
219 * db_auc.c: verify hex key sizes read from DB
220
221 [ Max ]
222 * Log ip:port when adding GSUP routes
223 * Add link to project wiki to .service file
224 * Enable statsd support
225
226 [ Vadim Yanitskiy ]
227 * hlr.c: properly terminate the process on SIGTERM
228 * hlr.c: fix: also store the session state in read_cb_forward()
229 * hlr.c: fix: properly print the original message type in read_cb_forward()
230 * hlr.c: check the presence of msgb->l2h in read_cb()
231 * hlr.c: fix possible msgb memleaks in read_cb()
232 * db_hlr.c: add db_subscr_exists_by_msisdn()
233 * src/db.h: use GSM23003_MSISDN_MAX_DIGITS for MSISDN buffer size
234 * src/hlr.c: fix deprecation warning: use gsm48_decode_bcd_number2()
235 * hlr_ussd.c: fix: properly pass invokeID in handle_ussd_own_msisdn()
236 * hlr_ussd.c: rx_proc_ss_req(): fix NULL pointer dereference
237 * build: fix mess with 'db_test_SOURCES' and 'db_test_LDADD'
238 * tests/db_test: close the database when test is finished
239 * src/db.c: integrate SQLite3 with talloc allocator
240
241 [ Neels Hofmeyr ]
242 * USSD: fix routing to multiple MSC
243 * fix error logging for GSUP route
244 * add missing error log: invalid IMSI
245 * osmo-hlr: allow configuring db path from cfg file
246 * use new OSMO_IMSI_BUF_SIZE
247
248 [ Daniel Willmann ]
249 * manuals: Add script to update vty/counter documentation from docker
250 * manuals: Update vty documentation
251
252 [ Pau Espin Pedrol ]
253 * Remove undefined param passed to logging_vty_add_cmds
254 * configure.ac: Require libosmocore 1.2.0
255
256 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 16:14:23 +0200
257
Harald Weltee0c6fe52019-01-20 19:29:59 +0100258osmo-hlr (1.0.0) unstable; urgency=medium
259
260 [ Stefan Sperling ]
261 * move creation of insert subscriber data messages to a common function
262
263 [ Harald Welte ]
264 * Return proper GSUP error in case of too short IMSI
265 * disable blind subscriber insertion into every VLR/SGSN
266 * gsup_server: Add "priv" pointer and make it point to 'struct hlr'
267 * move osmo_gsup_addr_send() declaration from luop.h to gsup_router.h
268 * gsup_router: Use "#pragma once" and add missing #includes
269 * Add "show gsup-connections" VTY command
270 * import gsup_client.c as new libosmo-gsup-client
271 * gsup_client: rename gsup_client_* to osmo_gsup_client_*
272 * GSUP: Log GSUP route add/remove
273 * hlr: Export + Declare global g_hlr symbol
274 * USSD: Add Core USSD handling + VTY routing config to HLR
275 * USSD: Add basic dispatch + decode of GSUP-encapsulated SS/USSD
276 * hlr_ussd: Introduce LOGPSS() macro
277 * USSD: Send ReturnError component if USSD Code unknown / EUSE disconnected
278 * USSD: Further unification of log output; Use LOGPSS when possible
279 * osmo-hlr.cfg: Don't enable DEBUG logging by default
280 * USSD: Add new "DSS" logging category and use it appropriately
281 * USSD: fix null-pointer deref in "default-route" vty/config cmd
282 * Add osmo-euse-demo as minimalistic test of a External USSD (EUSE) handler
283 * USSD: Add support for internal USSD handlers
284 * debian: Add sub-package for libosmo-gsup-client
285 * pkg-config: Fix libosmo-gsup-client pkg-config file
286 * gitignore: Add .tarball-version
287 * debian: Make libosmo-gsup-client-dev depend on libosmo-gsup-client0
288 * USSD: Fix "ussd default-route"
289 * libosmo-gsup-client: License is GPLv2-or-later
290 * osmo-hlr.cfg: Ensure well-formed config file example
291 * test_nodes.vty: Since libosmocore 1.0.0, we only have one space
292
293 [ Martin Hauke ]
294 * sql/Makefile.am: Make docsdir completely configurable
295 * debian: Fix typo in package description
296
297 [ Pau Espin Pedrol ]
298 * debian: Avoid installing duplicate cfg file in /etc
299 * sql/Makefile: Install hlr_data.sql as example together with hlr.sql
300 * sql/Makefile: Install sql files under doc/.../sql subdir
301 * sql/Makefile: Create empty /var/lib/osmocom directory at install time
302 * Install systemd services with autotools
303 * Move doc/Makefile.am to doc/examples/Makefile.am
304 * Install sample cfg file to /etc/osmocom
305
306 [ Vadim Yanitskiy ]
307 * hlr.c: move deinitialization code from SIGINT handler
308 * hlr.c: free root talloc context on exit
309 * hlr.c: track the use of talloc NULL memory contexts
310 * src/db.c: fix: make sure the database is properly closed
311 * src/db.c: don't ignore the result of db_bootstrap()
312 * hlr_vty_subscr.c: fix subscriber creation command help
313 * Update .gitignore: add missing build products
314 * tests/Makefile.am: also remove temporary sqlite files
315 * hlr_ussd.h: add #pragma once include guard
316 * hlr_ussd.h: use proper libc headers
317 * Update .gitignore: ignore osmo-euse-demo
318 * hlr_ussd.h: drop meaningless forward declaration
319 * USSD/hlr_vty.c: print error if EUSE is not found
320 * hlr_ussd.c: fix: properly print a EUSE / IUSE name
321 * hlr_ussd.c: avoid using CR and NL in IUSE responses
322
323 [ Neels Hofmeyr ]
324 * fix build: adjust test_nodes.vty to logging change
325 * tweak example config
326 * make: always allow running python tests manually
327
328 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 19:29:58 +0100
329
Pau Espin Pedrol78f43012018-05-04 18:41:35 +0200330osmo-hlr (0.2.1) unstable; urgency=medium
331
332 [ Neels Hofmeyr ]
333 * fix luop crash: use buffer for APN that remains valid
334 * add gsup_test to catch OS#3231
335 * add error handling to osmo_gsup_configure_wildcard_apn()
336
337 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 04 May 2018 18:41:35 +0200
338
Pau Espin Pedrolcb360f02018-05-03 16:27:14 +0200339osmo-hlr (0.2.0) unstable; urgency=medium
340
341 [ Neels Hofmeyr ]
342 * vty: skip installing cmds now always installed by default
343 * hlr_db_tool: fix error log strerror invocation
344 * cosmetic: add comment on ignored return value
345 * db-tool: add command 'create'
346 * db-tool: cosmetic: tweak printf output
347 * db-tool: error-exit on too many arguments
348 * add --enable-sanitize config option
349 * db_test: don't verify SQLite issued error messages, they might change
350 * cosmetic: rx_send_auth_info(): decide error cause with switch()
351 * return GMM_CAUSE_IMSI_UNKNOWN if there is no auth data
352 * db_get_auth_data / db_get_auc: clarify return values
353 * osmo-hlr: log details for unknown IMSI / no auth data / db error
354 * db_test: also test db_get_auc() return values
355 * fix test_subscriber_errors.ctrl after libosmocore change
356 * fix debug log: put 'deriving 2G from 3G' in proper place
357 * ctrl test: fix: adjust expectations after stricter ctrl parsing
358 * fix build: db_test: missing LIBOSMOABIS_CFLAGS and _LIBS
359 * configure: add --enable-werror
360 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
361
362 [ Harald Welte ]
363 * hlr.c: Avoid overflow of lu_operation.subscr.imsi
364 * Fix expected test output after new 'logging print file 1' vty command
365 * osmo-hlr: Add talloc context introspection via VTY
366 * vty: Don't print error if removing auth data while none present
367 * Fix responses to PURGE MS
368
369 [ Alexander Couzens ]
370 * debian: include systemd service osmo-hlr.service
371 * doc: install example .cfg files to $(docdir)/examples/
372 * debian: install osmo-hlr.cfg to /etc/osmocom
373
374 [ Max ]
375 * Remove unused check
376 * Remove unused ipa.py
377 * Enable sanitize for CI tests
378
379 [ Pau Espin Pedrol ]
380 * luop.c: Transform FIXME from warning to pragma message
381 * contrib:jenkins.sh: Enable Werror
382 * use osmo_init_logging2
383 * Remove unused src/db_test.c
384
385 [ Alexander Huemer ]
386 * Add missing build products in .gitignore
387
388 [ Stefan Sperling ]
389 * more robust usage of osmo_timer API for osmo-hlr luop timer
390 * notify GSUP clients when HLR subscriber information changes
391 * rewrite subscriber_update_notify() without calls into luop
392 * don't forget to mark luop as a packet switched connection
393
394 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:27:13 +0200
395
Harald Welte0dcbd472017-10-28 20:37:34 +0200396osmo-hlr (0.1.0) unstable; urgency=medium
397
398 [ Neels Hofmeyr ]
399 * build with autoconf/automake, add jenkins.sh script
400 * fix build on FreeBSD: eliminate implicitly declared functions
401 * fix various compiler warnings
402 * fix DLGSUP logging cat after change in libosmocore
403 * build: recoin db_test as non-installable program
404 * build: actually make sqlite mandatory
405 * bump required libosmocore version to 0.9.5
406 * gsup: send subscriber MSISDN
407 * debug log: log computed vector kinds
408 * log: move a log from info to debug level
409 * hlr.sql: typo in comment
410 * auc.c: typo in comment
411 * main: add and use root talloc ctx
412 * main: add option parsing with db file and default options
413 * main: add VTY and '-c config-file' option
414 * sql: fix 3g_auc's column K data type
415 * cosmetic: sql: indicate VARCHAR size of key columns as 32
416 * sql: auc_3g: set sqn NOT NULL DEFAULT 0
417 * comment: sql: describe auc_2g and auc_3g columns
418 * Add test suite skeleton with empty test (auc_3g_test)
419 * tests: auc_3g_test: implement vector generation test
420 * auth: verify test sets from 3GPP TS 55.205
421 * sql: add unique constraints to IMSI and MSISDN
422 * UMTS AKA resync: fix argument ordering
423 * auc_3g_test: add AUTS resync test
424 * auc_gen_vectors(): ensure sane arguments, test
425 * auc_3g_test: allow to inc fake rand bytes upon rand request
426 * auc_3g_test: add AUTS test with N vectors, to show bug
427 * cosmetic: refactor auc_compute_vectors(), add debug log
428 * auc_compute_vectors(): fix AUTS resync for multiple vectors
429 * cosmetic: auc_3g_test: improve test debugging tools
430 * cosmetic: rename auc_3g_test.c to auc_test.c
431 * fix: properly handle error rc by osmo_gsup_conn_ccm_get()
432 * auc tests: adjust cosmetically to prepare for SQN changes
433 * auc tests: fix after SQN scheme changes from libosmocore
434 * fix debug log: adjust to new SQN increment scheme
435 * UMTS AKA: implement SQN increment according to SEQ and IND
436 * debug log: output ind slot, previous sqn, and sqn db update
437 * jenkins: add value_string termination check
438 * fix db_subscr_ps error handling
439 * add config example (mostly empty)
440 * install hlr.sql in prefix/doc/osmo-hlr/
441 * use OSMO_GSUP_PORT == 4222 instead of hardcoded 2222
442 * add basic CTRL interface tests
443 * add CTRL tests for enable-/disable-/status-ps
444 * cosmetic: prepend DB_STMT_ to enum stmt_idx entries
445 * cosmetic: rename db_subscr_get() to db_subscr_get_by_imsi()
446 * cosmetic: refactor db_bind_imsi() as db_bind_text()
447 * cosmetic: multi-line DB_STMT_AUC_BY_IMSI
448 * cosmetic: log IMSI='<imsi>', log "no such subscriber"
449 * cosmetic: log: "SQLite" with capital L
450 * cosmetic: db_hlr: SL3_TXT: clarify indenting
451 * ctrl_test_runner.py: use proper constant as test db path
452 * gitignore: tests/package.m4
453 * cosmetic: don't log about missing SQLite log cb
454 * add db_bind_int() and db_bind_int64()
455 * add db_subscr_create(), db_subscr_delete(), db_subscr_update_msisdn_by_imsi()
456 * add initial db_test: creating and deleting subscribers
457 * less noise: simplify db_remove_reset()
458 * db: use int64_t as subscriber id
459 * add db_subscr_get_by_msisdn() and db_subscr_get_by_id()
460 * refactor db_subscr_ps() to db_subscr_nam()
461 * refactor db_subscr_lu()
462 * refactor db_subscr_purge
463 * add db_subscr_update_aud_by_id(), complete db_subscr_delete_by_id()
464 * refactor db_get_auth_data return val
465 * code undup: use db_remove_reset() in db_auc.c
466 * fix db_update_sqn(): reset stmt in all error cases
467 * code undup: use db_bind_text() in db_get_auth_data()
468 * debian: 'make check' needs sqlite3, add to Build-Depends
469 * fix db_subscr_get_by_*(): clear output data; test in db_test.c
470 * implement subscriber vty interface, tests
471 * add test_nodes.vty
472 * replace ctrl_test_runner.py with transcript test_subscriber.ctrl
473 * add lu_op_free(), use in luop.c
474 * luop: fix mem leak upon error in lu_op_alloc_conn()
475 * fix mem leak in handle_cmd_ps(): free luop
476 * api doc: say that lu_op_tx_del_subscr_data() doesn't free
477 * add hlr_subsrc_nam to put GSUP client notification in proper API
478 * vty: fix output of empty IMSI
479 * db api: fix/add API docs
480 * cosmetic: tweak params of hlr_controlif_setup()
481 * ctrl: completely replace all CTRL commands
482 * test_subscriber.ctrl: test against octal/hex interpretation of id
483 * jenkins: use osmo-clean-workspace.sh before and after build
484 * tests/Makefile: use test db var instead of repeating the path
485 * db_test: fix *FLAGS
486 * automatically create db tables on osmo-hlr invocation
487 * cosmetic: sql/hlr.sql: move comments
488 * cosmetic: rename SL3_TXT macro, use osmo_strlcpy()
489 * fix default logging levels to NOTICE, not DEBUG
490 * add osmo-hlr-db-tool, program to migrate from osmo-nitb db
491
492 [ Max ]
493 * Add gerrit settings
494 * Add hardcoded APN
495 * Log error cause as a string
496 * Move GSUP msg init into separate function
497 * Use strings for GSUP message type
498 * Move lu_operation into separate file
499 * db: move duplicated code into helper functions
500 * Fix compiler's warning about printf security
501 * Add routines to update nam_ps
502 * Add global HLR struct
503 * Make subscr parameter to db_subscr_get() optional
504 * Add CTRL interface
505 * CTRL: add enable/disable packet service cmds
506 * Add .deb packaging
507 * deb: fix OBS build
508 * debian: remove obsolete dependency
509 * Attempt to fix .deb package
510 * deb: use python in shebang
511 * Another attempt at fixing .deb
512 * Use release helper from libosmocore
513 * Use value string check from osmo-ci
514
515 [ Daniel Willmann ]
516 * Add systemd service file
517 * hlr_data.sql: Insert ki and opc instead of op to example data
518 * tests/auc: Don't require python3
519
520 [ Pau Espin Pedrol ]
521 * VTY: Add hlr node and bind ip field
522 * debian: remove unneeded dependency libdbd-sqlite3
523
524 [ Harald Welte ]
525 * jenkins.sh: Proper error message if local environment isn't set up
526
527 [ Alexander Couzens ]
528 * debian/rules: show testsuite.log when tests are failing
529
530 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 20:37:33 +0200
531
Maxe9d37db2017-03-13 16:08:11 +0100532osmo-hlr (0.0.1) UNRELEASED; urgency=low
533
534 * Initial release (Closes: OS#1948)
535
536 -- Max Suraev <msuraev@sysmocom.de> Mon, 13 Mar 2017 16:26:41 +0200