blob: 1344fa86f8918ff5c452e2bc71e33ba4e816d486 [file] [log] [blame]
Pau Espin Pedrold052f072023-09-12 14:41:33 +02001osmo-hlr (1.7.0) unstable; urgency=medium
2
3 [ Oliver Smith ]
4 * Run struct_endianness.py
5 * tests/db/db_test.err: adjust to XOR-3G rename
6 * debian: set compat level to 10
7 * systemd: depend on networking-online.target
8
9 [ Pau Espin Pedrol ]
10 * mslookup: Call osmo_fd_unregister() before closing and changing bfd->fd
11
12 [ Vadim Yanitskiy ]
13 * tests/auc/Makefile.am: put object files to LDADD
14 * tests/*/Makefile.am: move -I to AM_CPPFLAGS
15 * lu_fsm: fix memleak in lu_fsm_wait_insert_data_result()
16 * ussd: fix GSUP memleaks in rx_proc_ss_{req,error}()
17 * gsup_server: fix msgb memleak in osmo_gsup_server_read_cb()
18 * USSD: fix handling of ussd-DataCodingScheme != 0x0f
19
20 [ Alexander Couzens ]
21 * hlr: use talloc for memory allocation in osmo_gsup_create_insert_subscriber_data_msg
22 * Add support for multiple APN profiles for subscriber data
23
24 [ Harald Welte ]
25 * Introduce support for XOR-2G algorithm
26 * cosmetic: gen_ts_55_205_test_sets/func_template.c: Use tab-indent
27 * cosmetic: gen_ts_55_205_test_sets/main_template tabs istead of spaces
28 * Port to new libosmogsm 'struct osmo_sub_auth_data2'
29 * src/db.c: Switch from "const char *statements" to "const char * const"
30 * db: extend database schema to support 256bit K and/or OP[c] values
31 * Add VTY support for TUAK algorithm
32
33 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 12 Sep 2023 14:41:33 +0200
34
Pau Espin Pedroled939152023-02-07 16:49:14 +010035osmo-hlr (1.6.0) unstable; urgency=medium
36
37 [ Vadim Yanitskiy ]
38 * db_auc: hexparse_stmt(): check value returned by osmo_hexparse()
39
40 [ Max ]
41 * Set working directory in systemd service file
42 * Ignore .deb build byproducts
43 * Debian: bump copyright year to match current
44 * Debian: reformat package description
45 * systemd: enable basic hardening
46 * Debian: install osmo-hlr-dgsm.cfg as example config
47 * hlr_vty.c: fix typo
48 * ctrl: take both address and port from vty config
49
50 [ Harald Welte ]
51 * Support building with -Werror=strict-prototypes / -Werror=old-style-definition
52 * Add -Werror=implicit-int -Werror=int-conversion -Werror=old-style-definition
53
54 [ arehbein ]
55 * osmo-hlr: Transition to use of 'telnet_init_default'
56
57 [ Oliver Smith ]
58 * osmo_mdns_rfc_record_decode: check ret of talloc
59 * osmo_mdns_rfc_record_decode: proper free on err
60 * mslookup: use apn functions from libosmocore
61 * osmo_mdns_rfc_record/question_encode: remove ctx
62
63 [ Keith ]
64 * Vty: Fixup config shown/written from vty
65
66 [ Neels Hofmeyr ]
67 * fix memleak of proxy_subscr_listentry
68
69 [ Alexander Couzens ]
70 * Add vty `reject-cause` to set the reject cause
71
72 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 07 Feb 2023 16:49:14 +0100
73
Pau Espin Pedrol65f51532022-06-28 18:38:31 +020074osmo-hlr (1.5.0) unstable; urgency=medium
75
76 [ Oliver Smith ]
77 * treewide: remove FSF address
78
79 [ Vadim Yanitskiy ]
80 * fixup: debian: remove unneeded dependency libdbd-sqlite3
81 * debian: add new 'osmo-mslookup-utils' package
82 * tests: use 'check_PROGRAMS' instead of 'noinst_PROGRAMS'
83
84 [ Pau Espin Pedrol ]
85 * ctrl: Mark function as static
86 * tests: Allow specyfing specific ctrl test to run
87 * tests/ctrl: Move ERROR test scenario to proper file
88 * Fix db_subscr_create() not returning -EEXIST expected by VTY subscriber create cmd
89 * ctrl: Introduce cmd SET subscriber.create <imsi>
90 * ctrl: Introduce CTRL command subscriber.by-*.msisdn
91 * cosmetic: hlr_vty_subscr.c: Fix trailing whitespace
92 * ctrl: Introduce cmd SET subscriber.delete <imsi>
93 * ctrl: Introduce CTRL command subscriber.by-*.aud2g <algo[,ki]>
94 * ctrl: Introduce CTRL command subscriber.by-*.aud3g <algo[,KI,(op|opc),OP_C[,ind_bitlen]]>
95 * doc: Document new subscriber CTRL commands
96
97 [ Harald Welte ]
98 * update git URLs (git -> https; gitea)
99
100 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 28 Jun 2022 18:38:31 +0200
101
Pau Espin Pedrol4d7cbfc2021-11-16 14:56:41 +0100102osmo-hlr (1.4.0) unstable; urgency=medium
103
104 [ Keith ]
105 * Correct configuration written from vty
106 * vty: enable show subscribers filtered by IMEI
107
108 [ Harald Welte ]
109 * add README.md file as customary for cgit, github, gitlab, etc.
110
111 [ Oliver Smith ]
112 * Add post-upgrade script for automatic db upgrade
113 * debian/control: remove dh-systemd build-depend
114
115 [ Pau Espin Pedrol ]
116 * db: Avoid use uninitialized rc if running 0 statements
117
118 [ Neels Hofmeyr ]
119 * db v6: determine 3G AUC IND from VLR name
120
121 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 16 Nov 2021 14:56:41 +0100
122
Pau Espin Pedrol62404652021-02-23 18:13:53 +0100123osmo-hlr (1.3.0) unstable; urgency=medium
124
125 [ Alexander Couzens ]
126 * hlr: respect the num_auth_vectors requested
127 * hlr: remove unused internal USSD list
128
129 [ Oliver Smith ]
130 * add libosmo-mslookup abstract client
131 * add mDNS lookup method to libosmo-mslookup
132 * Makefile.am: fix pkgconfig_DATA
133 * add mDNS lookup method to libosmo-mslookup (#2)
134 * contrib/dgsm/ add example esme and dialplan
135 * mslookup_client.c: fix dereferencing null pointer
136 * mdns_msg.c: always call va_end
137 * mslookup_client_mdns.c: fix dereferencing null
138 * osmo-mslookup-client.c: fix dereferencing null
139 * osmo-mslookup-client: fix dereferencing null
140 * mdns_sock.c: fix resource leak of sock
141 * mdns_rfc.c: fix possible access of uninit. mem
142 * mslookup_client_mdns_test: disable by default
143 * mslookup_client_mdns_test: no automatic skip
144 * Cosmetic: mention OS#4491 in location cancel code
145 * hlr_vty_subscr: prettier output for last LU seen
146 * contrib: import RPM spec
147 * contrib: integrate RPM spec
148 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
149 * contrib/jenkins: don't build osmo-gsm-manuals
150 * configure.ac: set -std=gnu11
151
152 [ Neels Hofmeyr ]
153 * add osmo-mslookup-client program
154 * add osmo-mslookup-client program (#2)
155 * fix missing braces in LOGP_GSUP_FWD
156 * gsup_client.c: fix deprecation for client create func
157 * 1/2: refactor: add and use lu_fsm, osmo_gsup_req, osmo_ipa_name
158 * 2/2: wrap ipa_name in osmo_cni_peer_id with type enum and union
159 * gsup client: add up_down_cb(), add osmo_gsup_client_create3()
160 * db v5: prep for D-GSM: add vlr_via_proxy and sgsn_via_proxy
161 * enlarge the GSUP message headroom
162 * test_nodes.vty: remove cruft
163 * D-GSM 1/n: add mslookup server in osmo-hlr
164 * D-GSM 2/n: implement mDNS method of mslookup server
165 * D-GSM 3/n: implement roaming by mslookup in osmo-hlr
166 * gsup_server: send routing error back to the correct peer
167 * adoc: add D-GSM chapter to osmohlr-usermanual
168 * drop error log for when a subscriber does not exist
169 * vty: show subscriber: change format of 'last LU seen'
170 * vty: show subscriber: show lu d,h,m,s ago, not just seconds
171 * auc3g: officially wrap IND around IND_bitlen space
172 * make osmo_cni_peer_id_cmp() NULL safe
173 * osmo_gsup_req_new(): require from_peer != NULL
174 * gsup_server.c: properly handle negative rc from osmo_gsup_conn_ccm_get()
175 * osmo_mslookup_server_mdns_rx(): handle read() rc == 0
176 * hlr_subscr_nam(): fix condition to fix nam=false notifications
177 * esme_dgsm.py: add --always-fail option for debugging SMPP
178 * osmo-mslookup-client: fix segfault for respond_error() caller
179 * manual: describe subscriber import by SQL
180
181 [ Harald Welte ]
182 * Revert "add osmo-mslookup-client program"
183 * Revert "add mDNS lookup method to libosmo-mslookup"
184 * Use OSMO_FD_* instead of deprecated BSC_FD_*
185 * support the XOR algorithm for UMTS AKA
186 * auc_test.c: Add some comments on what the test cases actually do
187 * main: add --vty-ref-mode, use vty_dump_xml_ref_mode()
188 * manuals: generate vty reference xml at build time
189
190 [ Vadim Yanitskiy ]
191 * db: fix possible SQLite3 allocated memory leak in db_open()
192 * gsup_server: fix typo: s/omso_gsup_message/osmo_gsup_message/
193 * debian/control: change maintainer to the Osmocom team / mailing list
194 * cosmetic: fix spelling in logging message: existAnt -> existEnt
195 * doc/manuals: fix s/There/The/ in 'USSD Configuration'
196 * doc/manuals: re-organize description of internal USSD handlers
197 * USSD: fix handle_ussd(): do not free() unconditionally
198 * USSD: add special 'idle' handler to IUSE for testing
199
200 [ Eric ]
201 * configure.ac: fix libtool issue with clang and sanitizer
202
203 [ Philipp Maier ]
204 * doc: do not use loglevel info for log category ss
205
206 [ Pau Espin Pedrol ]
207 * configure.ac: Fix trailing whitespace
208 * doc: Update VTY reference xml file
209 * Support setting rt-prio and cpu-affinity mask through VTY
210 * Set TCP NODELAY sockopt to GSUP cli and srv connections
211 * contrib/jenkins: Enable parallel make in make distcheck
212 * .gitignore: Ignore new autofoo tmp files
213 * tests: Replace deprecated API log_set_print_filename
214
215 [ Keith ]
216 * osmo-hlr-db-tool: Make import from osmo-nitb less "lossy"
217 * Correct vty inline help for show subscriber
218 * Add vty command to show summary of all or filtered subscribers
219 * Fix Coverity Warnings
220
221 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 23 Feb 2021 18:13:53 +0100
222
Pau Espin Pedrol3a666982020-01-03 12:37:35 +0100223osmo-hlr (1.2.0) unstable; urgency=medium
224
225 [ Ruben Undheim ]
226 * Fix test for return codes on mipsel and alpha archs
227
228 [ Thorsten Alteholz ]
229 * fix spelling errors detected by lintian
230
231 [ Pau Espin Pedrol ]
232 * tests: Fix db_test err file to expect error code name instead of value
233
234 [ Oliver Smith ]
235 * tests/test_nodes.vty: check less libosmocore cmds
236 * tests/db_upgrade: disable for old sqlite versions
237 * gitignore: add tests/db_upgrade/*.dump
238 * gsup_client.h: fix license header: GPLv2+
239 * tests/auc: change back to python3
240
241 [ Neels Hofmeyr ]
242 * fix double free in osmo_gsup_client_enc_send()
243 * db upgrade to v2: log version 2, not 1
244 * fix upgrade to version 2: imei column default value
245 * add --db-check option
246 * hlr.sql: move comment
247 * add db_upgrade test
248 * hlr db schema 3: hlr_number -> msc_number
249 * db.c: code dup: add db_run_statements() for arrays of statements
250 * move headers to include/osmocom/hlr
251 * fix upgrade test in presence of ~/.sqliterc
252 * db upgrade: remove some code dup
253 * add osmo_gsup_msgb_alloc()
254 * Makefile convenience: add VTY_TEST var to run only one test
255 * remove gsup_test
256 * test_nodes.vty: tweak: add some '?' checks
257 * db v4: add column last_lu_seen_ps
258
259 [ Harald Welte ]
260 * AUC: Add support for setting the AMF separation bit to '1' for EUTRAN
261 * hlr: exit(2) on unsupported positional arguments on command line
262
263 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 12:37:35 +0100
264
Pau Espin Pedrol9cf00302019-08-07 16:14:23 +0200265osmo-hlr (1.1.0) unstable; urgency=medium
266
267 [ Oliver Smith ]
268 * docs: running: document --db-upgrade
269 * Add IMEI column to subscriber table
270 * Optionally store IMEI in subscriber table
271 * VTY tests: fill DB before running test
272 * VTY: integrate IMEI
273 * hlr.c: replace deprecated osmo_gsup_get_err_msg_type()
274 * hlr.c: move hlr_ctx to the top
275 * tests: use -no-install libtool flag to avoid ./lt-* scripts
276 * Cosmetic: gsup_route_find: comment addr, addrlen
277 * USSD: save MO USSD's originating MSC's vlr_number
278 * USSD: don't use gsm0480_msgb_alloc_name()
279 * hlr.c: forward GSUP messages between clients
280 * db_hlr.c: db_subscr_create(): add flags argument
281 * db_hlr.c: add db_subscr_exists_by_imsi()
282 * Create subscribers on demand
283 * Document subscribers create on demand feature
284 * debian: create -doc subpackage with pdf manuals
285 * db_test: set timezone to work around mktime bug
286 * db_hlr: zero-initialize "struct tm"
287 * rx_check_imei_req(): fix IMEI bounds checking
288 * contrib/jenkins.sh: run "make maintainer-clean"
289 * VTY: add subscriber update network-access-mode
290 * manuals: improve subscribers create on demand
291 * gitignore: ignore everything generated in db_test
292 * db_auc.c: verify hex key sizes read from DB
293
294 [ Max ]
295 * Log ip:port when adding GSUP routes
296 * Add link to project wiki to .service file
297 * Enable statsd support
298
299 [ Vadim Yanitskiy ]
300 * hlr.c: properly terminate the process on SIGTERM
301 * hlr.c: fix: also store the session state in read_cb_forward()
302 * hlr.c: fix: properly print the original message type in read_cb_forward()
303 * hlr.c: check the presence of msgb->l2h in read_cb()
304 * hlr.c: fix possible msgb memleaks in read_cb()
305 * db_hlr.c: add db_subscr_exists_by_msisdn()
306 * src/db.h: use GSM23003_MSISDN_MAX_DIGITS for MSISDN buffer size
307 * src/hlr.c: fix deprecation warning: use gsm48_decode_bcd_number2()
308 * hlr_ussd.c: fix: properly pass invokeID in handle_ussd_own_msisdn()
309 * hlr_ussd.c: rx_proc_ss_req(): fix NULL pointer dereference
310 * build: fix mess with 'db_test_SOURCES' and 'db_test_LDADD'
311 * tests/db_test: close the database when test is finished
312 * src/db.c: integrate SQLite3 with talloc allocator
313
314 [ Neels Hofmeyr ]
315 * USSD: fix routing to multiple MSC
316 * fix error logging for GSUP route
317 * add missing error log: invalid IMSI
318 * osmo-hlr: allow configuring db path from cfg file
319 * use new OSMO_IMSI_BUF_SIZE
320
321 [ Daniel Willmann ]
322 * manuals: Add script to update vty/counter documentation from docker
323 * manuals: Update vty documentation
324
325 [ Pau Espin Pedrol ]
326 * Remove undefined param passed to logging_vty_add_cmds
327 * configure.ac: Require libosmocore 1.2.0
328
329 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 16:14:23 +0200
330
Harald Weltee0c6fe52019-01-20 19:29:59 +0100331osmo-hlr (1.0.0) unstable; urgency=medium
332
333 [ Stefan Sperling ]
334 * move creation of insert subscriber data messages to a common function
335
336 [ Harald Welte ]
337 * Return proper GSUP error in case of too short IMSI
338 * disable blind subscriber insertion into every VLR/SGSN
339 * gsup_server: Add "priv" pointer and make it point to 'struct hlr'
340 * move osmo_gsup_addr_send() declaration from luop.h to gsup_router.h
341 * gsup_router: Use "#pragma once" and add missing #includes
342 * Add "show gsup-connections" VTY command
343 * import gsup_client.c as new libosmo-gsup-client
344 * gsup_client: rename gsup_client_* to osmo_gsup_client_*
345 * GSUP: Log GSUP route add/remove
346 * hlr: Export + Declare global g_hlr symbol
347 * USSD: Add Core USSD handling + VTY routing config to HLR
348 * USSD: Add basic dispatch + decode of GSUP-encapsulated SS/USSD
349 * hlr_ussd: Introduce LOGPSS() macro
350 * USSD: Send ReturnError component if USSD Code unknown / EUSE disconnected
351 * USSD: Further unification of log output; Use LOGPSS when possible
352 * osmo-hlr.cfg: Don't enable DEBUG logging by default
353 * USSD: Add new "DSS" logging category and use it appropriately
354 * USSD: fix null-pointer deref in "default-route" vty/config cmd
355 * Add osmo-euse-demo as minimalistic test of a External USSD (EUSE) handler
356 * USSD: Add support for internal USSD handlers
357 * debian: Add sub-package for libosmo-gsup-client
358 * pkg-config: Fix libosmo-gsup-client pkg-config file
359 * gitignore: Add .tarball-version
360 * debian: Make libosmo-gsup-client-dev depend on libosmo-gsup-client0
361 * USSD: Fix "ussd default-route"
362 * libosmo-gsup-client: License is GPLv2-or-later
363 * osmo-hlr.cfg: Ensure well-formed config file example
364 * test_nodes.vty: Since libosmocore 1.0.0, we only have one space
365
366 [ Martin Hauke ]
367 * sql/Makefile.am: Make docsdir completely configurable
368 * debian: Fix typo in package description
369
370 [ Pau Espin Pedrol ]
371 * debian: Avoid installing duplicate cfg file in /etc
372 * sql/Makefile: Install hlr_data.sql as example together with hlr.sql
373 * sql/Makefile: Install sql files under doc/.../sql subdir
374 * sql/Makefile: Create empty /var/lib/osmocom directory at install time
375 * Install systemd services with autotools
376 * Move doc/Makefile.am to doc/examples/Makefile.am
377 * Install sample cfg file to /etc/osmocom
378
379 [ Vadim Yanitskiy ]
380 * hlr.c: move deinitialization code from SIGINT handler
381 * hlr.c: free root talloc context on exit
382 * hlr.c: track the use of talloc NULL memory contexts
383 * src/db.c: fix: make sure the database is properly closed
384 * src/db.c: don't ignore the result of db_bootstrap()
385 * hlr_vty_subscr.c: fix subscriber creation command help
386 * Update .gitignore: add missing build products
387 * tests/Makefile.am: also remove temporary sqlite files
388 * hlr_ussd.h: add #pragma once include guard
389 * hlr_ussd.h: use proper libc headers
390 * Update .gitignore: ignore osmo-euse-demo
391 * hlr_ussd.h: drop meaningless forward declaration
392 * USSD/hlr_vty.c: print error if EUSE is not found
393 * hlr_ussd.c: fix: properly print a EUSE / IUSE name
394 * hlr_ussd.c: avoid using CR and NL in IUSE responses
395
396 [ Neels Hofmeyr ]
397 * fix build: adjust test_nodes.vty to logging change
398 * tweak example config
399 * make: always allow running python tests manually
400
401 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 19:29:58 +0100
402
Pau Espin Pedrol78f43012018-05-04 18:41:35 +0200403osmo-hlr (0.2.1) unstable; urgency=medium
404
405 [ Neels Hofmeyr ]
406 * fix luop crash: use buffer for APN that remains valid
407 * add gsup_test to catch OS#3231
408 * add error handling to osmo_gsup_configure_wildcard_apn()
409
410 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 04 May 2018 18:41:35 +0200
411
Pau Espin Pedrolcb360f02018-05-03 16:27:14 +0200412osmo-hlr (0.2.0) unstable; urgency=medium
413
414 [ Neels Hofmeyr ]
415 * vty: skip installing cmds now always installed by default
416 * hlr_db_tool: fix error log strerror invocation
417 * cosmetic: add comment on ignored return value
418 * db-tool: add command 'create'
419 * db-tool: cosmetic: tweak printf output
420 * db-tool: error-exit on too many arguments
421 * add --enable-sanitize config option
422 * db_test: don't verify SQLite issued error messages, they might change
423 * cosmetic: rx_send_auth_info(): decide error cause with switch()
424 * return GMM_CAUSE_IMSI_UNKNOWN if there is no auth data
425 * db_get_auth_data / db_get_auc: clarify return values
426 * osmo-hlr: log details for unknown IMSI / no auth data / db error
427 * db_test: also test db_get_auc() return values
428 * fix test_subscriber_errors.ctrl after libosmocore change
429 * fix debug log: put 'deriving 2G from 3G' in proper place
430 * ctrl test: fix: adjust expectations after stricter ctrl parsing
431 * fix build: db_test: missing LIBOSMOABIS_CFLAGS and _LIBS
432 * configure: add --enable-werror
433 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
434
435 [ Harald Welte ]
436 * hlr.c: Avoid overflow of lu_operation.subscr.imsi
437 * Fix expected test output after new 'logging print file 1' vty command
438 * osmo-hlr: Add talloc context introspection via VTY
439 * vty: Don't print error if removing auth data while none present
440 * Fix responses to PURGE MS
441
442 [ Alexander Couzens ]
443 * debian: include systemd service osmo-hlr.service
444 * doc: install example .cfg files to $(docdir)/examples/
445 * debian: install osmo-hlr.cfg to /etc/osmocom
446
447 [ Max ]
448 * Remove unused check
449 * Remove unused ipa.py
450 * Enable sanitize for CI tests
451
452 [ Pau Espin Pedrol ]
453 * luop.c: Transform FIXME from warning to pragma message
454 * contrib:jenkins.sh: Enable Werror
455 * use osmo_init_logging2
456 * Remove unused src/db_test.c
457
458 [ Alexander Huemer ]
459 * Add missing build products in .gitignore
460
461 [ Stefan Sperling ]
462 * more robust usage of osmo_timer API for osmo-hlr luop timer
463 * notify GSUP clients when HLR subscriber information changes
464 * rewrite subscriber_update_notify() without calls into luop
465 * don't forget to mark luop as a packet switched connection
466
467 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:27:13 +0200
468
Harald Welte0dcbd472017-10-28 20:37:34 +0200469osmo-hlr (0.1.0) unstable; urgency=medium
470
471 [ Neels Hofmeyr ]
472 * build with autoconf/automake, add jenkins.sh script
473 * fix build on FreeBSD: eliminate implicitly declared functions
474 * fix various compiler warnings
475 * fix DLGSUP logging cat after change in libosmocore
476 * build: recoin db_test as non-installable program
477 * build: actually make sqlite mandatory
478 * bump required libosmocore version to 0.9.5
479 * gsup: send subscriber MSISDN
480 * debug log: log computed vector kinds
481 * log: move a log from info to debug level
482 * hlr.sql: typo in comment
483 * auc.c: typo in comment
484 * main: add and use root talloc ctx
485 * main: add option parsing with db file and default options
486 * main: add VTY and '-c config-file' option
487 * sql: fix 3g_auc's column K data type
488 * cosmetic: sql: indicate VARCHAR size of key columns as 32
489 * sql: auc_3g: set sqn NOT NULL DEFAULT 0
490 * comment: sql: describe auc_2g and auc_3g columns
491 * Add test suite skeleton with empty test (auc_3g_test)
492 * tests: auc_3g_test: implement vector generation test
493 * auth: verify test sets from 3GPP TS 55.205
494 * sql: add unique constraints to IMSI and MSISDN
495 * UMTS AKA resync: fix argument ordering
496 * auc_3g_test: add AUTS resync test
497 * auc_gen_vectors(): ensure sane arguments, test
498 * auc_3g_test: allow to inc fake rand bytes upon rand request
499 * auc_3g_test: add AUTS test with N vectors, to show bug
500 * cosmetic: refactor auc_compute_vectors(), add debug log
501 * auc_compute_vectors(): fix AUTS resync for multiple vectors
502 * cosmetic: auc_3g_test: improve test debugging tools
503 * cosmetic: rename auc_3g_test.c to auc_test.c
504 * fix: properly handle error rc by osmo_gsup_conn_ccm_get()
505 * auc tests: adjust cosmetically to prepare for SQN changes
506 * auc tests: fix after SQN scheme changes from libosmocore
507 * fix debug log: adjust to new SQN increment scheme
508 * UMTS AKA: implement SQN increment according to SEQ and IND
509 * debug log: output ind slot, previous sqn, and sqn db update
510 * jenkins: add value_string termination check
511 * fix db_subscr_ps error handling
512 * add config example (mostly empty)
513 * install hlr.sql in prefix/doc/osmo-hlr/
514 * use OSMO_GSUP_PORT == 4222 instead of hardcoded 2222
515 * add basic CTRL interface tests
516 * add CTRL tests for enable-/disable-/status-ps
517 * cosmetic: prepend DB_STMT_ to enum stmt_idx entries
518 * cosmetic: rename db_subscr_get() to db_subscr_get_by_imsi()
519 * cosmetic: refactor db_bind_imsi() as db_bind_text()
520 * cosmetic: multi-line DB_STMT_AUC_BY_IMSI
521 * cosmetic: log IMSI='<imsi>', log "no such subscriber"
522 * cosmetic: log: "SQLite" with capital L
523 * cosmetic: db_hlr: SL3_TXT: clarify indenting
524 * ctrl_test_runner.py: use proper constant as test db path
525 * gitignore: tests/package.m4
526 * cosmetic: don't log about missing SQLite log cb
527 * add db_bind_int() and db_bind_int64()
528 * add db_subscr_create(), db_subscr_delete(), db_subscr_update_msisdn_by_imsi()
529 * add initial db_test: creating and deleting subscribers
530 * less noise: simplify db_remove_reset()
531 * db: use int64_t as subscriber id
532 * add db_subscr_get_by_msisdn() and db_subscr_get_by_id()
533 * refactor db_subscr_ps() to db_subscr_nam()
534 * refactor db_subscr_lu()
535 * refactor db_subscr_purge
536 * add db_subscr_update_aud_by_id(), complete db_subscr_delete_by_id()
537 * refactor db_get_auth_data return val
538 * code undup: use db_remove_reset() in db_auc.c
539 * fix db_update_sqn(): reset stmt in all error cases
540 * code undup: use db_bind_text() in db_get_auth_data()
541 * debian: 'make check' needs sqlite3, add to Build-Depends
542 * fix db_subscr_get_by_*(): clear output data; test in db_test.c
543 * implement subscriber vty interface, tests
544 * add test_nodes.vty
545 * replace ctrl_test_runner.py with transcript test_subscriber.ctrl
546 * add lu_op_free(), use in luop.c
547 * luop: fix mem leak upon error in lu_op_alloc_conn()
548 * fix mem leak in handle_cmd_ps(): free luop
549 * api doc: say that lu_op_tx_del_subscr_data() doesn't free
550 * add hlr_subsrc_nam to put GSUP client notification in proper API
551 * vty: fix output of empty IMSI
552 * db api: fix/add API docs
553 * cosmetic: tweak params of hlr_controlif_setup()
554 * ctrl: completely replace all CTRL commands
555 * test_subscriber.ctrl: test against octal/hex interpretation of id
556 * jenkins: use osmo-clean-workspace.sh before and after build
557 * tests/Makefile: use test db var instead of repeating the path
558 * db_test: fix *FLAGS
559 * automatically create db tables on osmo-hlr invocation
560 * cosmetic: sql/hlr.sql: move comments
561 * cosmetic: rename SL3_TXT macro, use osmo_strlcpy()
562 * fix default logging levels to NOTICE, not DEBUG
563 * add osmo-hlr-db-tool, program to migrate from osmo-nitb db
564
565 [ Max ]
566 * Add gerrit settings
567 * Add hardcoded APN
568 * Log error cause as a string
569 * Move GSUP msg init into separate function
570 * Use strings for GSUP message type
571 * Move lu_operation into separate file
572 * db: move duplicated code into helper functions
573 * Fix compiler's warning about printf security
574 * Add routines to update nam_ps
575 * Add global HLR struct
576 * Make subscr parameter to db_subscr_get() optional
577 * Add CTRL interface
578 * CTRL: add enable/disable packet service cmds
579 * Add .deb packaging
580 * deb: fix OBS build
581 * debian: remove obsolete dependency
582 * Attempt to fix .deb package
583 * deb: use python in shebang
584 * Another attempt at fixing .deb
585 * Use release helper from libosmocore
586 * Use value string check from osmo-ci
587
588 [ Daniel Willmann ]
589 * Add systemd service file
590 * hlr_data.sql: Insert ki and opc instead of op to example data
591 * tests/auc: Don't require python3
592
593 [ Pau Espin Pedrol ]
594 * VTY: Add hlr node and bind ip field
595 * debian: remove unneeded dependency libdbd-sqlite3
596
597 [ Harald Welte ]
598 * jenkins.sh: Proper error message if local environment isn't set up
599
600 [ Alexander Couzens ]
601 * debian/rules: show testsuite.log when tests are failing
602
603 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 20:37:33 +0200
604
Maxe9d37db2017-03-13 16:08:11 +0100605osmo-hlr (0.0.1) UNRELEASED; urgency=low
606
607 * Initial release (Closes: OS#1948)
608
609 -- Max Suraev <msuraev@sysmocom.de> Mon, 13 Mar 2017 16:26:41 +0200