blob: ecfc4c508dda9744cb8093567f33f5813baf2adb [file] [log] [blame]
Oliver Smith4de6dad2021-09-06 15:48:52 +02001osmo-hlr (1.3.1) unstable; urgency=medium
2
3 * debian/control: remove dh-systemd build-depend
4
5 -- Oliver Smith <osmith@sysmocom.de> Mon, 06 Sep 2021 15:48:52 +0200
6
Pau Espin Pedrol62404652021-02-23 18:13:53 +01007osmo-hlr (1.3.0) unstable; urgency=medium
8
9 [ Alexander Couzens ]
10 * hlr: respect the num_auth_vectors requested
11 * hlr: remove unused internal USSD list
12
13 [ Oliver Smith ]
14 * add libosmo-mslookup abstract client
15 * add mDNS lookup method to libosmo-mslookup
16 * Makefile.am: fix pkgconfig_DATA
17 * add mDNS lookup method to libosmo-mslookup (#2)
18 * contrib/dgsm/ add example esme and dialplan
19 * mslookup_client.c: fix dereferencing null pointer
20 * mdns_msg.c: always call va_end
21 * mslookup_client_mdns.c: fix dereferencing null
22 * osmo-mslookup-client.c: fix dereferencing null
23 * osmo-mslookup-client: fix dereferencing null
24 * mdns_sock.c: fix resource leak of sock
25 * mdns_rfc.c: fix possible access of uninit. mem
26 * mslookup_client_mdns_test: disable by default
27 * mslookup_client_mdns_test: no automatic skip
28 * Cosmetic: mention OS#4491 in location cancel code
29 * hlr_vty_subscr: prettier output for last LU seen
30 * contrib: import RPM spec
31 * contrib: integrate RPM spec
32 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
33 * contrib/jenkins: don't build osmo-gsm-manuals
34 * configure.ac: set -std=gnu11
35
36 [ Neels Hofmeyr ]
37 * add osmo-mslookup-client program
38 * add osmo-mslookup-client program (#2)
39 * fix missing braces in LOGP_GSUP_FWD
40 * gsup_client.c: fix deprecation for client create func
41 * 1/2: refactor: add and use lu_fsm, osmo_gsup_req, osmo_ipa_name
42 * 2/2: wrap ipa_name in osmo_cni_peer_id with type enum and union
43 * gsup client: add up_down_cb(), add osmo_gsup_client_create3()
44 * db v5: prep for D-GSM: add vlr_via_proxy and sgsn_via_proxy
45 * enlarge the GSUP message headroom
46 * test_nodes.vty: remove cruft
47 * D-GSM 1/n: add mslookup server in osmo-hlr
48 * D-GSM 2/n: implement mDNS method of mslookup server
49 * D-GSM 3/n: implement roaming by mslookup in osmo-hlr
50 * gsup_server: send routing error back to the correct peer
51 * adoc: add D-GSM chapter to osmohlr-usermanual
52 * drop error log for when a subscriber does not exist
53 * vty: show subscriber: change format of 'last LU seen'
54 * vty: show subscriber: show lu d,h,m,s ago, not just seconds
55 * auc3g: officially wrap IND around IND_bitlen space
56 * make osmo_cni_peer_id_cmp() NULL safe
57 * osmo_gsup_req_new(): require from_peer != NULL
58 * gsup_server.c: properly handle negative rc from osmo_gsup_conn_ccm_get()
59 * osmo_mslookup_server_mdns_rx(): handle read() rc == 0
60 * hlr_subscr_nam(): fix condition to fix nam=false notifications
61 * esme_dgsm.py: add --always-fail option for debugging SMPP
62 * osmo-mslookup-client: fix segfault for respond_error() caller
63 * manual: describe subscriber import by SQL
64
65 [ Harald Welte ]
66 * Revert "add osmo-mslookup-client program"
67 * Revert "add mDNS lookup method to libosmo-mslookup"
68 * Use OSMO_FD_* instead of deprecated BSC_FD_*
69 * support the XOR algorithm for UMTS AKA
70 * auc_test.c: Add some comments on what the test cases actually do
71 * main: add --vty-ref-mode, use vty_dump_xml_ref_mode()
72 * manuals: generate vty reference xml at build time
73
74 [ Vadim Yanitskiy ]
75 * db: fix possible SQLite3 allocated memory leak in db_open()
76 * gsup_server: fix typo: s/omso_gsup_message/osmo_gsup_message/
77 * debian/control: change maintainer to the Osmocom team / mailing list
78 * cosmetic: fix spelling in logging message: existAnt -> existEnt
79 * doc/manuals: fix s/There/The/ in 'USSD Configuration'
80 * doc/manuals: re-organize description of internal USSD handlers
81 * USSD: fix handle_ussd(): do not free() unconditionally
82 * USSD: add special 'idle' handler to IUSE for testing
83
84 [ Eric ]
85 * configure.ac: fix libtool issue with clang and sanitizer
86
87 [ Philipp Maier ]
88 * doc: do not use loglevel info for log category ss
89
90 [ Pau Espin Pedrol ]
91 * configure.ac: Fix trailing whitespace
92 * doc: Update VTY reference xml file
93 * Support setting rt-prio and cpu-affinity mask through VTY
94 * Set TCP NODELAY sockopt to GSUP cli and srv connections
95 * contrib/jenkins: Enable parallel make in make distcheck
96 * .gitignore: Ignore new autofoo tmp files
97 * tests: Replace deprecated API log_set_print_filename
98
99 [ Keith ]
100 * osmo-hlr-db-tool: Make import from osmo-nitb less "lossy"
101 * Correct vty inline help for show subscriber
102 * Add vty command to show summary of all or filtered subscribers
103 * Fix Coverity Warnings
104
105 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 23 Feb 2021 18:13:53 +0100
106
Pau Espin Pedrol3a666982020-01-03 12:37:35 +0100107osmo-hlr (1.2.0) unstable; urgency=medium
108
109 [ Ruben Undheim ]
110 * Fix test for return codes on mipsel and alpha archs
111
112 [ Thorsten Alteholz ]
113 * fix spelling errors detected by lintian
114
115 [ Pau Espin Pedrol ]
116 * tests: Fix db_test err file to expect error code name instead of value
117
118 [ Oliver Smith ]
119 * tests/test_nodes.vty: check less libosmocore cmds
120 * tests/db_upgrade: disable for old sqlite versions
121 * gitignore: add tests/db_upgrade/*.dump
122 * gsup_client.h: fix license header: GPLv2+
123 * tests/auc: change back to python3
124
125 [ Neels Hofmeyr ]
126 * fix double free in osmo_gsup_client_enc_send()
127 * db upgrade to v2: log version 2, not 1
128 * fix upgrade to version 2: imei column default value
129 * add --db-check option
130 * hlr.sql: move comment
131 * add db_upgrade test
132 * hlr db schema 3: hlr_number -> msc_number
133 * db.c: code dup: add db_run_statements() for arrays of statements
134 * move headers to include/osmocom/hlr
135 * fix upgrade test in presence of ~/.sqliterc
136 * db upgrade: remove some code dup
137 * add osmo_gsup_msgb_alloc()
138 * Makefile convenience: add VTY_TEST var to run only one test
139 * remove gsup_test
140 * test_nodes.vty: tweak: add some '?' checks
141 * db v4: add column last_lu_seen_ps
142
143 [ Harald Welte ]
144 * AUC: Add support for setting the AMF separation bit to '1' for EUTRAN
145 * hlr: exit(2) on unsupported positional arguments on command line
146
147 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 12:37:35 +0100
148
Pau Espin Pedrol9cf00302019-08-07 16:14:23 +0200149osmo-hlr (1.1.0) unstable; urgency=medium
150
151 [ Oliver Smith ]
152 * docs: running: document --db-upgrade
153 * Add IMEI column to subscriber table
154 * Optionally store IMEI in subscriber table
155 * VTY tests: fill DB before running test
156 * VTY: integrate IMEI
157 * hlr.c: replace deprecated osmo_gsup_get_err_msg_type()
158 * hlr.c: move hlr_ctx to the top
159 * tests: use -no-install libtool flag to avoid ./lt-* scripts
160 * Cosmetic: gsup_route_find: comment addr, addrlen
161 * USSD: save MO USSD's originating MSC's vlr_number
162 * USSD: don't use gsm0480_msgb_alloc_name()
163 * hlr.c: forward GSUP messages between clients
164 * db_hlr.c: db_subscr_create(): add flags argument
165 * db_hlr.c: add db_subscr_exists_by_imsi()
166 * Create subscribers on demand
167 * Document subscribers create on demand feature
168 * debian: create -doc subpackage with pdf manuals
169 * db_test: set timezone to work around mktime bug
170 * db_hlr: zero-initialize "struct tm"
171 * rx_check_imei_req(): fix IMEI bounds checking
172 * contrib/jenkins.sh: run "make maintainer-clean"
173 * VTY: add subscriber update network-access-mode
174 * manuals: improve subscribers create on demand
175 * gitignore: ignore everything generated in db_test
176 * db_auc.c: verify hex key sizes read from DB
177
178 [ Max ]
179 * Log ip:port when adding GSUP routes
180 * Add link to project wiki to .service file
181 * Enable statsd support
182
183 [ Vadim Yanitskiy ]
184 * hlr.c: properly terminate the process on SIGTERM
185 * hlr.c: fix: also store the session state in read_cb_forward()
186 * hlr.c: fix: properly print the original message type in read_cb_forward()
187 * hlr.c: check the presence of msgb->l2h in read_cb()
188 * hlr.c: fix possible msgb memleaks in read_cb()
189 * db_hlr.c: add db_subscr_exists_by_msisdn()
190 * src/db.h: use GSM23003_MSISDN_MAX_DIGITS for MSISDN buffer size
191 * src/hlr.c: fix deprecation warning: use gsm48_decode_bcd_number2()
192 * hlr_ussd.c: fix: properly pass invokeID in handle_ussd_own_msisdn()
193 * hlr_ussd.c: rx_proc_ss_req(): fix NULL pointer dereference
194 * build: fix mess with 'db_test_SOURCES' and 'db_test_LDADD'
195 * tests/db_test: close the database when test is finished
196 * src/db.c: integrate SQLite3 with talloc allocator
197
198 [ Neels Hofmeyr ]
199 * USSD: fix routing to multiple MSC
200 * fix error logging for GSUP route
201 * add missing error log: invalid IMSI
202 * osmo-hlr: allow configuring db path from cfg file
203 * use new OSMO_IMSI_BUF_SIZE
204
205 [ Daniel Willmann ]
206 * manuals: Add script to update vty/counter documentation from docker
207 * manuals: Update vty documentation
208
209 [ Pau Espin Pedrol ]
210 * Remove undefined param passed to logging_vty_add_cmds
211 * configure.ac: Require libosmocore 1.2.0
212
213 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 16:14:23 +0200
214
Harald Weltee0c6fe52019-01-20 19:29:59 +0100215osmo-hlr (1.0.0) unstable; urgency=medium
216
217 [ Stefan Sperling ]
218 * move creation of insert subscriber data messages to a common function
219
220 [ Harald Welte ]
221 * Return proper GSUP error in case of too short IMSI
222 * disable blind subscriber insertion into every VLR/SGSN
223 * gsup_server: Add "priv" pointer and make it point to 'struct hlr'
224 * move osmo_gsup_addr_send() declaration from luop.h to gsup_router.h
225 * gsup_router: Use "#pragma once" and add missing #includes
226 * Add "show gsup-connections" VTY command
227 * import gsup_client.c as new libosmo-gsup-client
228 * gsup_client: rename gsup_client_* to osmo_gsup_client_*
229 * GSUP: Log GSUP route add/remove
230 * hlr: Export + Declare global g_hlr symbol
231 * USSD: Add Core USSD handling + VTY routing config to HLR
232 * USSD: Add basic dispatch + decode of GSUP-encapsulated SS/USSD
233 * hlr_ussd: Introduce LOGPSS() macro
234 * USSD: Send ReturnError component if USSD Code unknown / EUSE disconnected
235 * USSD: Further unification of log output; Use LOGPSS when possible
236 * osmo-hlr.cfg: Don't enable DEBUG logging by default
237 * USSD: Add new "DSS" logging category and use it appropriately
238 * USSD: fix null-pointer deref in "default-route" vty/config cmd
239 * Add osmo-euse-demo as minimalistic test of a External USSD (EUSE) handler
240 * USSD: Add support for internal USSD handlers
241 * debian: Add sub-package for libosmo-gsup-client
242 * pkg-config: Fix libosmo-gsup-client pkg-config file
243 * gitignore: Add .tarball-version
244 * debian: Make libosmo-gsup-client-dev depend on libosmo-gsup-client0
245 * USSD: Fix "ussd default-route"
246 * libosmo-gsup-client: License is GPLv2-or-later
247 * osmo-hlr.cfg: Ensure well-formed config file example
248 * test_nodes.vty: Since libosmocore 1.0.0, we only have one space
249
250 [ Martin Hauke ]
251 * sql/Makefile.am: Make docsdir completely configurable
252 * debian: Fix typo in package description
253
254 [ Pau Espin Pedrol ]
255 * debian: Avoid installing duplicate cfg file in /etc
256 * sql/Makefile: Install hlr_data.sql as example together with hlr.sql
257 * sql/Makefile: Install sql files under doc/.../sql subdir
258 * sql/Makefile: Create empty /var/lib/osmocom directory at install time
259 * Install systemd services with autotools
260 * Move doc/Makefile.am to doc/examples/Makefile.am
261 * Install sample cfg file to /etc/osmocom
262
263 [ Vadim Yanitskiy ]
264 * hlr.c: move deinitialization code from SIGINT handler
265 * hlr.c: free root talloc context on exit
266 * hlr.c: track the use of talloc NULL memory contexts
267 * src/db.c: fix: make sure the database is properly closed
268 * src/db.c: don't ignore the result of db_bootstrap()
269 * hlr_vty_subscr.c: fix subscriber creation command help
270 * Update .gitignore: add missing build products
271 * tests/Makefile.am: also remove temporary sqlite files
272 * hlr_ussd.h: add #pragma once include guard
273 * hlr_ussd.h: use proper libc headers
274 * Update .gitignore: ignore osmo-euse-demo
275 * hlr_ussd.h: drop meaningless forward declaration
276 * USSD/hlr_vty.c: print error if EUSE is not found
277 * hlr_ussd.c: fix: properly print a EUSE / IUSE name
278 * hlr_ussd.c: avoid using CR and NL in IUSE responses
279
280 [ Neels Hofmeyr ]
281 * fix build: adjust test_nodes.vty to logging change
282 * tweak example config
283 * make: always allow running python tests manually
284
285 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 19:29:58 +0100
286
Pau Espin Pedrol78f43012018-05-04 18:41:35 +0200287osmo-hlr (0.2.1) unstable; urgency=medium
288
289 [ Neels Hofmeyr ]
290 * fix luop crash: use buffer for APN that remains valid
291 * add gsup_test to catch OS#3231
292 * add error handling to osmo_gsup_configure_wildcard_apn()
293
294 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 04 May 2018 18:41:35 +0200
295
Pau Espin Pedrolcb360f02018-05-03 16:27:14 +0200296osmo-hlr (0.2.0) unstable; urgency=medium
297
298 [ Neels Hofmeyr ]
299 * vty: skip installing cmds now always installed by default
300 * hlr_db_tool: fix error log strerror invocation
301 * cosmetic: add comment on ignored return value
302 * db-tool: add command 'create'
303 * db-tool: cosmetic: tweak printf output
304 * db-tool: error-exit on too many arguments
305 * add --enable-sanitize config option
306 * db_test: don't verify SQLite issued error messages, they might change
307 * cosmetic: rx_send_auth_info(): decide error cause with switch()
308 * return GMM_CAUSE_IMSI_UNKNOWN if there is no auth data
309 * db_get_auth_data / db_get_auc: clarify return values
310 * osmo-hlr: log details for unknown IMSI / no auth data / db error
311 * db_test: also test db_get_auc() return values
312 * fix test_subscriber_errors.ctrl after libosmocore change
313 * fix debug log: put 'deriving 2G from 3G' in proper place
314 * ctrl test: fix: adjust expectations after stricter ctrl parsing
315 * fix build: db_test: missing LIBOSMOABIS_CFLAGS and _LIBS
316 * configure: add --enable-werror
317 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
318
319 [ Harald Welte ]
320 * hlr.c: Avoid overflow of lu_operation.subscr.imsi
321 * Fix expected test output after new 'logging print file 1' vty command
322 * osmo-hlr: Add talloc context introspection via VTY
323 * vty: Don't print error if removing auth data while none present
324 * Fix responses to PURGE MS
325
326 [ Alexander Couzens ]
327 * debian: include systemd service osmo-hlr.service
328 * doc: install example .cfg files to $(docdir)/examples/
329 * debian: install osmo-hlr.cfg to /etc/osmocom
330
331 [ Max ]
332 * Remove unused check
333 * Remove unused ipa.py
334 * Enable sanitize for CI tests
335
336 [ Pau Espin Pedrol ]
337 * luop.c: Transform FIXME from warning to pragma message
338 * contrib:jenkins.sh: Enable Werror
339 * use osmo_init_logging2
340 * Remove unused src/db_test.c
341
342 [ Alexander Huemer ]
343 * Add missing build products in .gitignore
344
345 [ Stefan Sperling ]
346 * more robust usage of osmo_timer API for osmo-hlr luop timer
347 * notify GSUP clients when HLR subscriber information changes
348 * rewrite subscriber_update_notify() without calls into luop
349 * don't forget to mark luop as a packet switched connection
350
351 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:27:13 +0200
352
Harald Welte0dcbd472017-10-28 20:37:34 +0200353osmo-hlr (0.1.0) unstable; urgency=medium
354
355 [ Neels Hofmeyr ]
356 * build with autoconf/automake, add jenkins.sh script
357 * fix build on FreeBSD: eliminate implicitly declared functions
358 * fix various compiler warnings
359 * fix DLGSUP logging cat after change in libosmocore
360 * build: recoin db_test as non-installable program
361 * build: actually make sqlite mandatory
362 * bump required libosmocore version to 0.9.5
363 * gsup: send subscriber MSISDN
364 * debug log: log computed vector kinds
365 * log: move a log from info to debug level
366 * hlr.sql: typo in comment
367 * auc.c: typo in comment
368 * main: add and use root talloc ctx
369 * main: add option parsing with db file and default options
370 * main: add VTY and '-c config-file' option
371 * sql: fix 3g_auc's column K data type
372 * cosmetic: sql: indicate VARCHAR size of key columns as 32
373 * sql: auc_3g: set sqn NOT NULL DEFAULT 0
374 * comment: sql: describe auc_2g and auc_3g columns
375 * Add test suite skeleton with empty test (auc_3g_test)
376 * tests: auc_3g_test: implement vector generation test
377 * auth: verify test sets from 3GPP TS 55.205
378 * sql: add unique constraints to IMSI and MSISDN
379 * UMTS AKA resync: fix argument ordering
380 * auc_3g_test: add AUTS resync test
381 * auc_gen_vectors(): ensure sane arguments, test
382 * auc_3g_test: allow to inc fake rand bytes upon rand request
383 * auc_3g_test: add AUTS test with N vectors, to show bug
384 * cosmetic: refactor auc_compute_vectors(), add debug log
385 * auc_compute_vectors(): fix AUTS resync for multiple vectors
386 * cosmetic: auc_3g_test: improve test debugging tools
387 * cosmetic: rename auc_3g_test.c to auc_test.c
388 * fix: properly handle error rc by osmo_gsup_conn_ccm_get()
389 * auc tests: adjust cosmetically to prepare for SQN changes
390 * auc tests: fix after SQN scheme changes from libosmocore
391 * fix debug log: adjust to new SQN increment scheme
392 * UMTS AKA: implement SQN increment according to SEQ and IND
393 * debug log: output ind slot, previous sqn, and sqn db update
394 * jenkins: add value_string termination check
395 * fix db_subscr_ps error handling
396 * add config example (mostly empty)
397 * install hlr.sql in prefix/doc/osmo-hlr/
398 * use OSMO_GSUP_PORT == 4222 instead of hardcoded 2222
399 * add basic CTRL interface tests
400 * add CTRL tests for enable-/disable-/status-ps
401 * cosmetic: prepend DB_STMT_ to enum stmt_idx entries
402 * cosmetic: rename db_subscr_get() to db_subscr_get_by_imsi()
403 * cosmetic: refactor db_bind_imsi() as db_bind_text()
404 * cosmetic: multi-line DB_STMT_AUC_BY_IMSI
405 * cosmetic: log IMSI='<imsi>', log "no such subscriber"
406 * cosmetic: log: "SQLite" with capital L
407 * cosmetic: db_hlr: SL3_TXT: clarify indenting
408 * ctrl_test_runner.py: use proper constant as test db path
409 * gitignore: tests/package.m4
410 * cosmetic: don't log about missing SQLite log cb
411 * add db_bind_int() and db_bind_int64()
412 * add db_subscr_create(), db_subscr_delete(), db_subscr_update_msisdn_by_imsi()
413 * add initial db_test: creating and deleting subscribers
414 * less noise: simplify db_remove_reset()
415 * db: use int64_t as subscriber id
416 * add db_subscr_get_by_msisdn() and db_subscr_get_by_id()
417 * refactor db_subscr_ps() to db_subscr_nam()
418 * refactor db_subscr_lu()
419 * refactor db_subscr_purge
420 * add db_subscr_update_aud_by_id(), complete db_subscr_delete_by_id()
421 * refactor db_get_auth_data return val
422 * code undup: use db_remove_reset() in db_auc.c
423 * fix db_update_sqn(): reset stmt in all error cases
424 * code undup: use db_bind_text() in db_get_auth_data()
425 * debian: 'make check' needs sqlite3, add to Build-Depends
426 * fix db_subscr_get_by_*(): clear output data; test in db_test.c
427 * implement subscriber vty interface, tests
428 * add test_nodes.vty
429 * replace ctrl_test_runner.py with transcript test_subscriber.ctrl
430 * add lu_op_free(), use in luop.c
431 * luop: fix mem leak upon error in lu_op_alloc_conn()
432 * fix mem leak in handle_cmd_ps(): free luop
433 * api doc: say that lu_op_tx_del_subscr_data() doesn't free
434 * add hlr_subsrc_nam to put GSUP client notification in proper API
435 * vty: fix output of empty IMSI
436 * db api: fix/add API docs
437 * cosmetic: tweak params of hlr_controlif_setup()
438 * ctrl: completely replace all CTRL commands
439 * test_subscriber.ctrl: test against octal/hex interpretation of id
440 * jenkins: use osmo-clean-workspace.sh before and after build
441 * tests/Makefile: use test db var instead of repeating the path
442 * db_test: fix *FLAGS
443 * automatically create db tables on osmo-hlr invocation
444 * cosmetic: sql/hlr.sql: move comments
445 * cosmetic: rename SL3_TXT macro, use osmo_strlcpy()
446 * fix default logging levels to NOTICE, not DEBUG
447 * add osmo-hlr-db-tool, program to migrate from osmo-nitb db
448
449 [ Max ]
450 * Add gerrit settings
451 * Add hardcoded APN
452 * Log error cause as a string
453 * Move GSUP msg init into separate function
454 * Use strings for GSUP message type
455 * Move lu_operation into separate file
456 * db: move duplicated code into helper functions
457 * Fix compiler's warning about printf security
458 * Add routines to update nam_ps
459 * Add global HLR struct
460 * Make subscr parameter to db_subscr_get() optional
461 * Add CTRL interface
462 * CTRL: add enable/disable packet service cmds
463 * Add .deb packaging
464 * deb: fix OBS build
465 * debian: remove obsolete dependency
466 * Attempt to fix .deb package
467 * deb: use python in shebang
468 * Another attempt at fixing .deb
469 * Use release helper from libosmocore
470 * Use value string check from osmo-ci
471
472 [ Daniel Willmann ]
473 * Add systemd service file
474 * hlr_data.sql: Insert ki and opc instead of op to example data
475 * tests/auc: Don't require python3
476
477 [ Pau Espin Pedrol ]
478 * VTY: Add hlr node and bind ip field
479 * debian: remove unneeded dependency libdbd-sqlite3
480
481 [ Harald Welte ]
482 * jenkins.sh: Proper error message if local environment isn't set up
483
484 [ Alexander Couzens ]
485 * debian/rules: show testsuite.log when tests are failing
486
487 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 20:37:33 +0200
488
Maxe9d37db2017-03-13 16:08:11 +0100489osmo-hlr (0.0.1) UNRELEASED; urgency=low
490
491 * Initial release (Closes: OS#1948)
492
493 -- Max Suraev <msuraev@sysmocom.de> Mon, 13 Mar 2017 16:26:41 +0200