blob: 9a6ef84ef49ce7e0e8d0d3f8a4da06f00a803478 [file] [log] [blame]
Harald Welte9f092da2020-12-29 20:39:53 +01001osmo-hlr (1.2.1) unstable; urgency=medium
2
3 [ Neels Hofmeyr ]
4 * test_nodes.vty: remove cruft
5
6 [ Harald Welte ]
7 * support the XOR algorithm for UMTS AKA
8
9 -- Harald Welte <laforge@osmocom.org> Tue, 29 Dec 2020 20:39:53 +0100
10
Pau Espin Pedrol3a666982020-01-03 12:37:35 +010011osmo-hlr (1.2.0) unstable; urgency=medium
12
13 [ Ruben Undheim ]
14 * Fix test for return codes on mipsel and alpha archs
15
16 [ Thorsten Alteholz ]
17 * fix spelling errors detected by lintian
18
19 [ Pau Espin Pedrol ]
20 * tests: Fix db_test err file to expect error code name instead of value
21
22 [ Oliver Smith ]
23 * tests/test_nodes.vty: check less libosmocore cmds
24 * tests/db_upgrade: disable for old sqlite versions
25 * gitignore: add tests/db_upgrade/*.dump
26 * gsup_client.h: fix license header: GPLv2+
27 * tests/auc: change back to python3
28
29 [ Neels Hofmeyr ]
30 * fix double free in osmo_gsup_client_enc_send()
31 * db upgrade to v2: log version 2, not 1
32 * fix upgrade to version 2: imei column default value
33 * add --db-check option
34 * hlr.sql: move comment
35 * add db_upgrade test
36 * hlr db schema 3: hlr_number -> msc_number
37 * db.c: code dup: add db_run_statements() for arrays of statements
38 * move headers to include/osmocom/hlr
39 * fix upgrade test in presence of ~/.sqliterc
40 * db upgrade: remove some code dup
41 * add osmo_gsup_msgb_alloc()
42 * Makefile convenience: add VTY_TEST var to run only one test
43 * remove gsup_test
44 * test_nodes.vty: tweak: add some '?' checks
45 * db v4: add column last_lu_seen_ps
46
47 [ Harald Welte ]
48 * AUC: Add support for setting the AMF separation bit to '1' for EUTRAN
49 * hlr: exit(2) on unsupported positional arguments on command line
50
51 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 12:37:35 +0100
52
Pau Espin Pedrol9cf00302019-08-07 16:14:23 +020053osmo-hlr (1.1.0) unstable; urgency=medium
54
55 [ Oliver Smith ]
56 * docs: running: document --db-upgrade
57 * Add IMEI column to subscriber table
58 * Optionally store IMEI in subscriber table
59 * VTY tests: fill DB before running test
60 * VTY: integrate IMEI
61 * hlr.c: replace deprecated osmo_gsup_get_err_msg_type()
62 * hlr.c: move hlr_ctx to the top
63 * tests: use -no-install libtool flag to avoid ./lt-* scripts
64 * Cosmetic: gsup_route_find: comment addr, addrlen
65 * USSD: save MO USSD's originating MSC's vlr_number
66 * USSD: don't use gsm0480_msgb_alloc_name()
67 * hlr.c: forward GSUP messages between clients
68 * db_hlr.c: db_subscr_create(): add flags argument
69 * db_hlr.c: add db_subscr_exists_by_imsi()
70 * Create subscribers on demand
71 * Document subscribers create on demand feature
72 * debian: create -doc subpackage with pdf manuals
73 * db_test: set timezone to work around mktime bug
74 * db_hlr: zero-initialize "struct tm"
75 * rx_check_imei_req(): fix IMEI bounds checking
76 * contrib/jenkins.sh: run "make maintainer-clean"
77 * VTY: add subscriber update network-access-mode
78 * manuals: improve subscribers create on demand
79 * gitignore: ignore everything generated in db_test
80 * db_auc.c: verify hex key sizes read from DB
81
82 [ Max ]
83 * Log ip:port when adding GSUP routes
84 * Add link to project wiki to .service file
85 * Enable statsd support
86
87 [ Vadim Yanitskiy ]
88 * hlr.c: properly terminate the process on SIGTERM
89 * hlr.c: fix: also store the session state in read_cb_forward()
90 * hlr.c: fix: properly print the original message type in read_cb_forward()
91 * hlr.c: check the presence of msgb->l2h in read_cb()
92 * hlr.c: fix possible msgb memleaks in read_cb()
93 * db_hlr.c: add db_subscr_exists_by_msisdn()
94 * src/db.h: use GSM23003_MSISDN_MAX_DIGITS for MSISDN buffer size
95 * src/hlr.c: fix deprecation warning: use gsm48_decode_bcd_number2()
96 * hlr_ussd.c: fix: properly pass invokeID in handle_ussd_own_msisdn()
97 * hlr_ussd.c: rx_proc_ss_req(): fix NULL pointer dereference
98 * build: fix mess with 'db_test_SOURCES' and 'db_test_LDADD'
99 * tests/db_test: close the database when test is finished
100 * src/db.c: integrate SQLite3 with talloc allocator
101
102 [ Neels Hofmeyr ]
103 * USSD: fix routing to multiple MSC
104 * fix error logging for GSUP route
105 * add missing error log: invalid IMSI
106 * osmo-hlr: allow configuring db path from cfg file
107 * use new OSMO_IMSI_BUF_SIZE
108
109 [ Daniel Willmann ]
110 * manuals: Add script to update vty/counter documentation from docker
111 * manuals: Update vty documentation
112
113 [ Pau Espin Pedrol ]
114 * Remove undefined param passed to logging_vty_add_cmds
115 * configure.ac: Require libosmocore 1.2.0
116
117 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 16:14:23 +0200
118
Harald Weltee0c6fe52019-01-20 19:29:59 +0100119osmo-hlr (1.0.0) unstable; urgency=medium
120
121 [ Stefan Sperling ]
122 * move creation of insert subscriber data messages to a common function
123
124 [ Harald Welte ]
125 * Return proper GSUP error in case of too short IMSI
126 * disable blind subscriber insertion into every VLR/SGSN
127 * gsup_server: Add "priv" pointer and make it point to 'struct hlr'
128 * move osmo_gsup_addr_send() declaration from luop.h to gsup_router.h
129 * gsup_router: Use "#pragma once" and add missing #includes
130 * Add "show gsup-connections" VTY command
131 * import gsup_client.c as new libosmo-gsup-client
132 * gsup_client: rename gsup_client_* to osmo_gsup_client_*
133 * GSUP: Log GSUP route add/remove
134 * hlr: Export + Declare global g_hlr symbol
135 * USSD: Add Core USSD handling + VTY routing config to HLR
136 * USSD: Add basic dispatch + decode of GSUP-encapsulated SS/USSD
137 * hlr_ussd: Introduce LOGPSS() macro
138 * USSD: Send ReturnError component if USSD Code unknown / EUSE disconnected
139 * USSD: Further unification of log output; Use LOGPSS when possible
140 * osmo-hlr.cfg: Don't enable DEBUG logging by default
141 * USSD: Add new "DSS" logging category and use it appropriately
142 * USSD: fix null-pointer deref in "default-route" vty/config cmd
143 * Add osmo-euse-demo as minimalistic test of a External USSD (EUSE) handler
144 * USSD: Add support for internal USSD handlers
145 * debian: Add sub-package for libosmo-gsup-client
146 * pkg-config: Fix libosmo-gsup-client pkg-config file
147 * gitignore: Add .tarball-version
148 * debian: Make libosmo-gsup-client-dev depend on libosmo-gsup-client0
149 * USSD: Fix "ussd default-route"
150 * libosmo-gsup-client: License is GPLv2-or-later
151 * osmo-hlr.cfg: Ensure well-formed config file example
152 * test_nodes.vty: Since libosmocore 1.0.0, we only have one space
153
154 [ Martin Hauke ]
155 * sql/Makefile.am: Make docsdir completely configurable
156 * debian: Fix typo in package description
157
158 [ Pau Espin Pedrol ]
159 * debian: Avoid installing duplicate cfg file in /etc
160 * sql/Makefile: Install hlr_data.sql as example together with hlr.sql
161 * sql/Makefile: Install sql files under doc/.../sql subdir
162 * sql/Makefile: Create empty /var/lib/osmocom directory at install time
163 * Install systemd services with autotools
164 * Move doc/Makefile.am to doc/examples/Makefile.am
165 * Install sample cfg file to /etc/osmocom
166
167 [ Vadim Yanitskiy ]
168 * hlr.c: move deinitialization code from SIGINT handler
169 * hlr.c: free root talloc context on exit
170 * hlr.c: track the use of talloc NULL memory contexts
171 * src/db.c: fix: make sure the database is properly closed
172 * src/db.c: don't ignore the result of db_bootstrap()
173 * hlr_vty_subscr.c: fix subscriber creation command help
174 * Update .gitignore: add missing build products
175 * tests/Makefile.am: also remove temporary sqlite files
176 * hlr_ussd.h: add #pragma once include guard
177 * hlr_ussd.h: use proper libc headers
178 * Update .gitignore: ignore osmo-euse-demo
179 * hlr_ussd.h: drop meaningless forward declaration
180 * USSD/hlr_vty.c: print error if EUSE is not found
181 * hlr_ussd.c: fix: properly print a EUSE / IUSE name
182 * hlr_ussd.c: avoid using CR and NL in IUSE responses
183
184 [ Neels Hofmeyr ]
185 * fix build: adjust test_nodes.vty to logging change
186 * tweak example config
187 * make: always allow running python tests manually
188
189 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 19:29:58 +0100
190
Pau Espin Pedrol78f43012018-05-04 18:41:35 +0200191osmo-hlr (0.2.1) unstable; urgency=medium
192
193 [ Neels Hofmeyr ]
194 * fix luop crash: use buffer for APN that remains valid
195 * add gsup_test to catch OS#3231
196 * add error handling to osmo_gsup_configure_wildcard_apn()
197
198 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 04 May 2018 18:41:35 +0200
199
Pau Espin Pedrolcb360f02018-05-03 16:27:14 +0200200osmo-hlr (0.2.0) unstable; urgency=medium
201
202 [ Neels Hofmeyr ]
203 * vty: skip installing cmds now always installed by default
204 * hlr_db_tool: fix error log strerror invocation
205 * cosmetic: add comment on ignored return value
206 * db-tool: add command 'create'
207 * db-tool: cosmetic: tweak printf output
208 * db-tool: error-exit on too many arguments
209 * add --enable-sanitize config option
210 * db_test: don't verify SQLite issued error messages, they might change
211 * cosmetic: rx_send_auth_info(): decide error cause with switch()
212 * return GMM_CAUSE_IMSI_UNKNOWN if there is no auth data
213 * db_get_auth_data / db_get_auc: clarify return values
214 * osmo-hlr: log details for unknown IMSI / no auth data / db error
215 * db_test: also test db_get_auc() return values
216 * fix test_subscriber_errors.ctrl after libosmocore change
217 * fix debug log: put 'deriving 2G from 3G' in proper place
218 * ctrl test: fix: adjust expectations after stricter ctrl parsing
219 * fix build: db_test: missing LIBOSMOABIS_CFLAGS and _LIBS
220 * configure: add --enable-werror
221 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
222
223 [ Harald Welte ]
224 * hlr.c: Avoid overflow of lu_operation.subscr.imsi
225 * Fix expected test output after new 'logging print file 1' vty command
226 * osmo-hlr: Add talloc context introspection via VTY
227 * vty: Don't print error if removing auth data while none present
228 * Fix responses to PURGE MS
229
230 [ Alexander Couzens ]
231 * debian: include systemd service osmo-hlr.service
232 * doc: install example .cfg files to $(docdir)/examples/
233 * debian: install osmo-hlr.cfg to /etc/osmocom
234
235 [ Max ]
236 * Remove unused check
237 * Remove unused ipa.py
238 * Enable sanitize for CI tests
239
240 [ Pau Espin Pedrol ]
241 * luop.c: Transform FIXME from warning to pragma message
242 * contrib:jenkins.sh: Enable Werror
243 * use osmo_init_logging2
244 * Remove unused src/db_test.c
245
246 [ Alexander Huemer ]
247 * Add missing build products in .gitignore
248
249 [ Stefan Sperling ]
250 * more robust usage of osmo_timer API for osmo-hlr luop timer
251 * notify GSUP clients when HLR subscriber information changes
252 * rewrite subscriber_update_notify() without calls into luop
253 * don't forget to mark luop as a packet switched connection
254
255 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:27:13 +0200
256
Harald Welte0dcbd472017-10-28 20:37:34 +0200257osmo-hlr (0.1.0) unstable; urgency=medium
258
259 [ Neels Hofmeyr ]
260 * build with autoconf/automake, add jenkins.sh script
261 * fix build on FreeBSD: eliminate implicitly declared functions
262 * fix various compiler warnings
263 * fix DLGSUP logging cat after change in libosmocore
264 * build: recoin db_test as non-installable program
265 * build: actually make sqlite mandatory
266 * bump required libosmocore version to 0.9.5
267 * gsup: send subscriber MSISDN
268 * debug log: log computed vector kinds
269 * log: move a log from info to debug level
270 * hlr.sql: typo in comment
271 * auc.c: typo in comment
272 * main: add and use root talloc ctx
273 * main: add option parsing with db file and default options
274 * main: add VTY and '-c config-file' option
275 * sql: fix 3g_auc's column K data type
276 * cosmetic: sql: indicate VARCHAR size of key columns as 32
277 * sql: auc_3g: set sqn NOT NULL DEFAULT 0
278 * comment: sql: describe auc_2g and auc_3g columns
279 * Add test suite skeleton with empty test (auc_3g_test)
280 * tests: auc_3g_test: implement vector generation test
281 * auth: verify test sets from 3GPP TS 55.205
282 * sql: add unique constraints to IMSI and MSISDN
283 * UMTS AKA resync: fix argument ordering
284 * auc_3g_test: add AUTS resync test
285 * auc_gen_vectors(): ensure sane arguments, test
286 * auc_3g_test: allow to inc fake rand bytes upon rand request
287 * auc_3g_test: add AUTS test with N vectors, to show bug
288 * cosmetic: refactor auc_compute_vectors(), add debug log
289 * auc_compute_vectors(): fix AUTS resync for multiple vectors
290 * cosmetic: auc_3g_test: improve test debugging tools
291 * cosmetic: rename auc_3g_test.c to auc_test.c
292 * fix: properly handle error rc by osmo_gsup_conn_ccm_get()
293 * auc tests: adjust cosmetically to prepare for SQN changes
294 * auc tests: fix after SQN scheme changes from libosmocore
295 * fix debug log: adjust to new SQN increment scheme
296 * UMTS AKA: implement SQN increment according to SEQ and IND
297 * debug log: output ind slot, previous sqn, and sqn db update
298 * jenkins: add value_string termination check
299 * fix db_subscr_ps error handling
300 * add config example (mostly empty)
301 * install hlr.sql in prefix/doc/osmo-hlr/
302 * use OSMO_GSUP_PORT == 4222 instead of hardcoded 2222
303 * add basic CTRL interface tests
304 * add CTRL tests for enable-/disable-/status-ps
305 * cosmetic: prepend DB_STMT_ to enum stmt_idx entries
306 * cosmetic: rename db_subscr_get() to db_subscr_get_by_imsi()
307 * cosmetic: refactor db_bind_imsi() as db_bind_text()
308 * cosmetic: multi-line DB_STMT_AUC_BY_IMSI
309 * cosmetic: log IMSI='<imsi>', log "no such subscriber"
310 * cosmetic: log: "SQLite" with capital L
311 * cosmetic: db_hlr: SL3_TXT: clarify indenting
312 * ctrl_test_runner.py: use proper constant as test db path
313 * gitignore: tests/package.m4
314 * cosmetic: don't log about missing SQLite log cb
315 * add db_bind_int() and db_bind_int64()
316 * add db_subscr_create(), db_subscr_delete(), db_subscr_update_msisdn_by_imsi()
317 * add initial db_test: creating and deleting subscribers
318 * less noise: simplify db_remove_reset()
319 * db: use int64_t as subscriber id
320 * add db_subscr_get_by_msisdn() and db_subscr_get_by_id()
321 * refactor db_subscr_ps() to db_subscr_nam()
322 * refactor db_subscr_lu()
323 * refactor db_subscr_purge
324 * add db_subscr_update_aud_by_id(), complete db_subscr_delete_by_id()
325 * refactor db_get_auth_data return val
326 * code undup: use db_remove_reset() in db_auc.c
327 * fix db_update_sqn(): reset stmt in all error cases
328 * code undup: use db_bind_text() in db_get_auth_data()
329 * debian: 'make check' needs sqlite3, add to Build-Depends
330 * fix db_subscr_get_by_*(): clear output data; test in db_test.c
331 * implement subscriber vty interface, tests
332 * add test_nodes.vty
333 * replace ctrl_test_runner.py with transcript test_subscriber.ctrl
334 * add lu_op_free(), use in luop.c
335 * luop: fix mem leak upon error in lu_op_alloc_conn()
336 * fix mem leak in handle_cmd_ps(): free luop
337 * api doc: say that lu_op_tx_del_subscr_data() doesn't free
338 * add hlr_subsrc_nam to put GSUP client notification in proper API
339 * vty: fix output of empty IMSI
340 * db api: fix/add API docs
341 * cosmetic: tweak params of hlr_controlif_setup()
342 * ctrl: completely replace all CTRL commands
343 * test_subscriber.ctrl: test against octal/hex interpretation of id
344 * jenkins: use osmo-clean-workspace.sh before and after build
345 * tests/Makefile: use test db var instead of repeating the path
346 * db_test: fix *FLAGS
347 * automatically create db tables on osmo-hlr invocation
348 * cosmetic: sql/hlr.sql: move comments
349 * cosmetic: rename SL3_TXT macro, use osmo_strlcpy()
350 * fix default logging levels to NOTICE, not DEBUG
351 * add osmo-hlr-db-tool, program to migrate from osmo-nitb db
352
353 [ Max ]
354 * Add gerrit settings
355 * Add hardcoded APN
356 * Log error cause as a string
357 * Move GSUP msg init into separate function
358 * Use strings for GSUP message type
359 * Move lu_operation into separate file
360 * db: move duplicated code into helper functions
361 * Fix compiler's warning about printf security
362 * Add routines to update nam_ps
363 * Add global HLR struct
364 * Make subscr parameter to db_subscr_get() optional
365 * Add CTRL interface
366 * CTRL: add enable/disable packet service cmds
367 * Add .deb packaging
368 * deb: fix OBS build
369 * debian: remove obsolete dependency
370 * Attempt to fix .deb package
371 * deb: use python in shebang
372 * Another attempt at fixing .deb
373 * Use release helper from libosmocore
374 * Use value string check from osmo-ci
375
376 [ Daniel Willmann ]
377 * Add systemd service file
378 * hlr_data.sql: Insert ki and opc instead of op to example data
379 * tests/auc: Don't require python3
380
381 [ Pau Espin Pedrol ]
382 * VTY: Add hlr node and bind ip field
383 * debian: remove unneeded dependency libdbd-sqlite3
384
385 [ Harald Welte ]
386 * jenkins.sh: Proper error message if local environment isn't set up
387
388 [ Alexander Couzens ]
389 * debian/rules: show testsuite.log when tests are failing
390
391 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 20:37:33 +0200
392
Maxe9d37db2017-03-13 16:08:11 +0100393osmo-hlr (0.0.1) UNRELEASED; urgency=low
394
395 * Initial release (Closes: OS#1948)
396
397 -- Max Suraev <msuraev@sysmocom.de> Mon, 13 Mar 2017 16:26:41 +0200