blob: 1b02a2079163ac2d68ab3dc8ee1e8f173cc820cd [file] [log] [blame]
Pau Espin Pedrol3a666982020-01-03 12:37:35 +01001osmo-hlr (1.2.0) unstable; urgency=medium
2
3 [ Ruben Undheim ]
4 * Fix test for return codes on mipsel and alpha archs
5
6 [ Thorsten Alteholz ]
7 * fix spelling errors detected by lintian
8
9 [ Pau Espin Pedrol ]
10 * tests: Fix db_test err file to expect error code name instead of value
11
12 [ Oliver Smith ]
13 * tests/test_nodes.vty: check less libosmocore cmds
14 * tests/db_upgrade: disable for old sqlite versions
15 * gitignore: add tests/db_upgrade/*.dump
16 * gsup_client.h: fix license header: GPLv2+
17 * tests/auc: change back to python3
18
19 [ Neels Hofmeyr ]
20 * fix double free in osmo_gsup_client_enc_send()
21 * db upgrade to v2: log version 2, not 1
22 * fix upgrade to version 2: imei column default value
23 * add --db-check option
24 * hlr.sql: move comment
25 * add db_upgrade test
26 * hlr db schema 3: hlr_number -> msc_number
27 * db.c: code dup: add db_run_statements() for arrays of statements
28 * move headers to include/osmocom/hlr
29 * fix upgrade test in presence of ~/.sqliterc
30 * db upgrade: remove some code dup
31 * add osmo_gsup_msgb_alloc()
32 * Makefile convenience: add VTY_TEST var to run only one test
33 * remove gsup_test
34 * test_nodes.vty: tweak: add some '?' checks
35 * db v4: add column last_lu_seen_ps
36
37 [ Harald Welte ]
38 * AUC: Add support for setting the AMF separation bit to '1' for EUTRAN
39 * hlr: exit(2) on unsupported positional arguments on command line
40
41 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 12:37:35 +0100
42
Pau Espin Pedrol9cf00302019-08-07 16:14:23 +020043osmo-hlr (1.1.0) unstable; urgency=medium
44
45 [ Oliver Smith ]
46 * docs: running: document --db-upgrade
47 * Add IMEI column to subscriber table
48 * Optionally store IMEI in subscriber table
49 * VTY tests: fill DB before running test
50 * VTY: integrate IMEI
51 * hlr.c: replace deprecated osmo_gsup_get_err_msg_type()
52 * hlr.c: move hlr_ctx to the top
53 * tests: use -no-install libtool flag to avoid ./lt-* scripts
54 * Cosmetic: gsup_route_find: comment addr, addrlen
55 * USSD: save MO USSD's originating MSC's vlr_number
56 * USSD: don't use gsm0480_msgb_alloc_name()
57 * hlr.c: forward GSUP messages between clients
58 * db_hlr.c: db_subscr_create(): add flags argument
59 * db_hlr.c: add db_subscr_exists_by_imsi()
60 * Create subscribers on demand
61 * Document subscribers create on demand feature
62 * debian: create -doc subpackage with pdf manuals
63 * db_test: set timezone to work around mktime bug
64 * db_hlr: zero-initialize "struct tm"
65 * rx_check_imei_req(): fix IMEI bounds checking
66 * contrib/jenkins.sh: run "make maintainer-clean"
67 * VTY: add subscriber update network-access-mode
68 * manuals: improve subscribers create on demand
69 * gitignore: ignore everything generated in db_test
70 * db_auc.c: verify hex key sizes read from DB
71
72 [ Max ]
73 * Log ip:port when adding GSUP routes
74 * Add link to project wiki to .service file
75 * Enable statsd support
76
77 [ Vadim Yanitskiy ]
78 * hlr.c: properly terminate the process on SIGTERM
79 * hlr.c: fix: also store the session state in read_cb_forward()
80 * hlr.c: fix: properly print the original message type in read_cb_forward()
81 * hlr.c: check the presence of msgb->l2h in read_cb()
82 * hlr.c: fix possible msgb memleaks in read_cb()
83 * db_hlr.c: add db_subscr_exists_by_msisdn()
84 * src/db.h: use GSM23003_MSISDN_MAX_DIGITS for MSISDN buffer size
85 * src/hlr.c: fix deprecation warning: use gsm48_decode_bcd_number2()
86 * hlr_ussd.c: fix: properly pass invokeID in handle_ussd_own_msisdn()
87 * hlr_ussd.c: rx_proc_ss_req(): fix NULL pointer dereference
88 * build: fix mess with 'db_test_SOURCES' and 'db_test_LDADD'
89 * tests/db_test: close the database when test is finished
90 * src/db.c: integrate SQLite3 with talloc allocator
91
92 [ Neels Hofmeyr ]
93 * USSD: fix routing to multiple MSC
94 * fix error logging for GSUP route
95 * add missing error log: invalid IMSI
96 * osmo-hlr: allow configuring db path from cfg file
97 * use new OSMO_IMSI_BUF_SIZE
98
99 [ Daniel Willmann ]
100 * manuals: Add script to update vty/counter documentation from docker
101 * manuals: Update vty documentation
102
103 [ Pau Espin Pedrol ]
104 * Remove undefined param passed to logging_vty_add_cmds
105 * configure.ac: Require libosmocore 1.2.0
106
107 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 16:14:23 +0200
108
Harald Weltee0c6fe52019-01-20 19:29:59 +0100109osmo-hlr (1.0.0) unstable; urgency=medium
110
111 [ Stefan Sperling ]
112 * move creation of insert subscriber data messages to a common function
113
114 [ Harald Welte ]
115 * Return proper GSUP error in case of too short IMSI
116 * disable blind subscriber insertion into every VLR/SGSN
117 * gsup_server: Add "priv" pointer and make it point to 'struct hlr'
118 * move osmo_gsup_addr_send() declaration from luop.h to gsup_router.h
119 * gsup_router: Use "#pragma once" and add missing #includes
120 * Add "show gsup-connections" VTY command
121 * import gsup_client.c as new libosmo-gsup-client
122 * gsup_client: rename gsup_client_* to osmo_gsup_client_*
123 * GSUP: Log GSUP route add/remove
124 * hlr: Export + Declare global g_hlr symbol
125 * USSD: Add Core USSD handling + VTY routing config to HLR
126 * USSD: Add basic dispatch + decode of GSUP-encapsulated SS/USSD
127 * hlr_ussd: Introduce LOGPSS() macro
128 * USSD: Send ReturnError component if USSD Code unknown / EUSE disconnected
129 * USSD: Further unification of log output; Use LOGPSS when possible
130 * osmo-hlr.cfg: Don't enable DEBUG logging by default
131 * USSD: Add new "DSS" logging category and use it appropriately
132 * USSD: fix null-pointer deref in "default-route" vty/config cmd
133 * Add osmo-euse-demo as minimalistic test of a External USSD (EUSE) handler
134 * USSD: Add support for internal USSD handlers
135 * debian: Add sub-package for libosmo-gsup-client
136 * pkg-config: Fix libosmo-gsup-client pkg-config file
137 * gitignore: Add .tarball-version
138 * debian: Make libosmo-gsup-client-dev depend on libosmo-gsup-client0
139 * USSD: Fix "ussd default-route"
140 * libosmo-gsup-client: License is GPLv2-or-later
141 * osmo-hlr.cfg: Ensure well-formed config file example
142 * test_nodes.vty: Since libosmocore 1.0.0, we only have one space
143
144 [ Martin Hauke ]
145 * sql/Makefile.am: Make docsdir completely configurable
146 * debian: Fix typo in package description
147
148 [ Pau Espin Pedrol ]
149 * debian: Avoid installing duplicate cfg file in /etc
150 * sql/Makefile: Install hlr_data.sql as example together with hlr.sql
151 * sql/Makefile: Install sql files under doc/.../sql subdir
152 * sql/Makefile: Create empty /var/lib/osmocom directory at install time
153 * Install systemd services with autotools
154 * Move doc/Makefile.am to doc/examples/Makefile.am
155 * Install sample cfg file to /etc/osmocom
156
157 [ Vadim Yanitskiy ]
158 * hlr.c: move deinitialization code from SIGINT handler
159 * hlr.c: free root talloc context on exit
160 * hlr.c: track the use of talloc NULL memory contexts
161 * src/db.c: fix: make sure the database is properly closed
162 * src/db.c: don't ignore the result of db_bootstrap()
163 * hlr_vty_subscr.c: fix subscriber creation command help
164 * Update .gitignore: add missing build products
165 * tests/Makefile.am: also remove temporary sqlite files
166 * hlr_ussd.h: add #pragma once include guard
167 * hlr_ussd.h: use proper libc headers
168 * Update .gitignore: ignore osmo-euse-demo
169 * hlr_ussd.h: drop meaningless forward declaration
170 * USSD/hlr_vty.c: print error if EUSE is not found
171 * hlr_ussd.c: fix: properly print a EUSE / IUSE name
172 * hlr_ussd.c: avoid using CR and NL in IUSE responses
173
174 [ Neels Hofmeyr ]
175 * fix build: adjust test_nodes.vty to logging change
176 * tweak example config
177 * make: always allow running python tests manually
178
179 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 19:29:58 +0100
180
Pau Espin Pedrol78f43012018-05-04 18:41:35 +0200181osmo-hlr (0.2.1) unstable; urgency=medium
182
183 [ Neels Hofmeyr ]
184 * fix luop crash: use buffer for APN that remains valid
185 * add gsup_test to catch OS#3231
186 * add error handling to osmo_gsup_configure_wildcard_apn()
187
188 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 04 May 2018 18:41:35 +0200
189
Pau Espin Pedrolcb360f02018-05-03 16:27:14 +0200190osmo-hlr (0.2.0) unstable; urgency=medium
191
192 [ Neels Hofmeyr ]
193 * vty: skip installing cmds now always installed by default
194 * hlr_db_tool: fix error log strerror invocation
195 * cosmetic: add comment on ignored return value
196 * db-tool: add command 'create'
197 * db-tool: cosmetic: tweak printf output
198 * db-tool: error-exit on too many arguments
199 * add --enable-sanitize config option
200 * db_test: don't verify SQLite issued error messages, they might change
201 * cosmetic: rx_send_auth_info(): decide error cause with switch()
202 * return GMM_CAUSE_IMSI_UNKNOWN if there is no auth data
203 * db_get_auth_data / db_get_auc: clarify return values
204 * osmo-hlr: log details for unknown IMSI / no auth data / db error
205 * db_test: also test db_get_auc() return values
206 * fix test_subscriber_errors.ctrl after libosmocore change
207 * fix debug log: put 'deriving 2G from 3G' in proper place
208 * ctrl test: fix: adjust expectations after stricter ctrl parsing
209 * fix build: db_test: missing LIBOSMOABIS_CFLAGS and _LIBS
210 * configure: add --enable-werror
211 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
212
213 [ Harald Welte ]
214 * hlr.c: Avoid overflow of lu_operation.subscr.imsi
215 * Fix expected test output after new 'logging print file 1' vty command
216 * osmo-hlr: Add talloc context introspection via VTY
217 * vty: Don't print error if removing auth data while none present
218 * Fix responses to PURGE MS
219
220 [ Alexander Couzens ]
221 * debian: include systemd service osmo-hlr.service
222 * doc: install example .cfg files to $(docdir)/examples/
223 * debian: install osmo-hlr.cfg to /etc/osmocom
224
225 [ Max ]
226 * Remove unused check
227 * Remove unused ipa.py
228 * Enable sanitize for CI tests
229
230 [ Pau Espin Pedrol ]
231 * luop.c: Transform FIXME from warning to pragma message
232 * contrib:jenkins.sh: Enable Werror
233 * use osmo_init_logging2
234 * Remove unused src/db_test.c
235
236 [ Alexander Huemer ]
237 * Add missing build products in .gitignore
238
239 [ Stefan Sperling ]
240 * more robust usage of osmo_timer API for osmo-hlr luop timer
241 * notify GSUP clients when HLR subscriber information changes
242 * rewrite subscriber_update_notify() without calls into luop
243 * don't forget to mark luop as a packet switched connection
244
245 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:27:13 +0200
246
Harald Welte0dcbd472017-10-28 20:37:34 +0200247osmo-hlr (0.1.0) unstable; urgency=medium
248
249 [ Neels Hofmeyr ]
250 * build with autoconf/automake, add jenkins.sh script
251 * fix build on FreeBSD: eliminate implicitly declared functions
252 * fix various compiler warnings
253 * fix DLGSUP logging cat after change in libosmocore
254 * build: recoin db_test as non-installable program
255 * build: actually make sqlite mandatory
256 * bump required libosmocore version to 0.9.5
257 * gsup: send subscriber MSISDN
258 * debug log: log computed vector kinds
259 * log: move a log from info to debug level
260 * hlr.sql: typo in comment
261 * auc.c: typo in comment
262 * main: add and use root talloc ctx
263 * main: add option parsing with db file and default options
264 * main: add VTY and '-c config-file' option
265 * sql: fix 3g_auc's column K data type
266 * cosmetic: sql: indicate VARCHAR size of key columns as 32
267 * sql: auc_3g: set sqn NOT NULL DEFAULT 0
268 * comment: sql: describe auc_2g and auc_3g columns
269 * Add test suite skeleton with empty test (auc_3g_test)
270 * tests: auc_3g_test: implement vector generation test
271 * auth: verify test sets from 3GPP TS 55.205
272 * sql: add unique constraints to IMSI and MSISDN
273 * UMTS AKA resync: fix argument ordering
274 * auc_3g_test: add AUTS resync test
275 * auc_gen_vectors(): ensure sane arguments, test
276 * auc_3g_test: allow to inc fake rand bytes upon rand request
277 * auc_3g_test: add AUTS test with N vectors, to show bug
278 * cosmetic: refactor auc_compute_vectors(), add debug log
279 * auc_compute_vectors(): fix AUTS resync for multiple vectors
280 * cosmetic: auc_3g_test: improve test debugging tools
281 * cosmetic: rename auc_3g_test.c to auc_test.c
282 * fix: properly handle error rc by osmo_gsup_conn_ccm_get()
283 * auc tests: adjust cosmetically to prepare for SQN changes
284 * auc tests: fix after SQN scheme changes from libosmocore
285 * fix debug log: adjust to new SQN increment scheme
286 * UMTS AKA: implement SQN increment according to SEQ and IND
287 * debug log: output ind slot, previous sqn, and sqn db update
288 * jenkins: add value_string termination check
289 * fix db_subscr_ps error handling
290 * add config example (mostly empty)
291 * install hlr.sql in prefix/doc/osmo-hlr/
292 * use OSMO_GSUP_PORT == 4222 instead of hardcoded 2222
293 * add basic CTRL interface tests
294 * add CTRL tests for enable-/disable-/status-ps
295 * cosmetic: prepend DB_STMT_ to enum stmt_idx entries
296 * cosmetic: rename db_subscr_get() to db_subscr_get_by_imsi()
297 * cosmetic: refactor db_bind_imsi() as db_bind_text()
298 * cosmetic: multi-line DB_STMT_AUC_BY_IMSI
299 * cosmetic: log IMSI='<imsi>', log "no such subscriber"
300 * cosmetic: log: "SQLite" with capital L
301 * cosmetic: db_hlr: SL3_TXT: clarify indenting
302 * ctrl_test_runner.py: use proper constant as test db path
303 * gitignore: tests/package.m4
304 * cosmetic: don't log about missing SQLite log cb
305 * add db_bind_int() and db_bind_int64()
306 * add db_subscr_create(), db_subscr_delete(), db_subscr_update_msisdn_by_imsi()
307 * add initial db_test: creating and deleting subscribers
308 * less noise: simplify db_remove_reset()
309 * db: use int64_t as subscriber id
310 * add db_subscr_get_by_msisdn() and db_subscr_get_by_id()
311 * refactor db_subscr_ps() to db_subscr_nam()
312 * refactor db_subscr_lu()
313 * refactor db_subscr_purge
314 * add db_subscr_update_aud_by_id(), complete db_subscr_delete_by_id()
315 * refactor db_get_auth_data return val
316 * code undup: use db_remove_reset() in db_auc.c
317 * fix db_update_sqn(): reset stmt in all error cases
318 * code undup: use db_bind_text() in db_get_auth_data()
319 * debian: 'make check' needs sqlite3, add to Build-Depends
320 * fix db_subscr_get_by_*(): clear output data; test in db_test.c
321 * implement subscriber vty interface, tests
322 * add test_nodes.vty
323 * replace ctrl_test_runner.py with transcript test_subscriber.ctrl
324 * add lu_op_free(), use in luop.c
325 * luop: fix mem leak upon error in lu_op_alloc_conn()
326 * fix mem leak in handle_cmd_ps(): free luop
327 * api doc: say that lu_op_tx_del_subscr_data() doesn't free
328 * add hlr_subsrc_nam to put GSUP client notification in proper API
329 * vty: fix output of empty IMSI
330 * db api: fix/add API docs
331 * cosmetic: tweak params of hlr_controlif_setup()
332 * ctrl: completely replace all CTRL commands
333 * test_subscriber.ctrl: test against octal/hex interpretation of id
334 * jenkins: use osmo-clean-workspace.sh before and after build
335 * tests/Makefile: use test db var instead of repeating the path
336 * db_test: fix *FLAGS
337 * automatically create db tables on osmo-hlr invocation
338 * cosmetic: sql/hlr.sql: move comments
339 * cosmetic: rename SL3_TXT macro, use osmo_strlcpy()
340 * fix default logging levels to NOTICE, not DEBUG
341 * add osmo-hlr-db-tool, program to migrate from osmo-nitb db
342
343 [ Max ]
344 * Add gerrit settings
345 * Add hardcoded APN
346 * Log error cause as a string
347 * Move GSUP msg init into separate function
348 * Use strings for GSUP message type
349 * Move lu_operation into separate file
350 * db: move duplicated code into helper functions
351 * Fix compiler's warning about printf security
352 * Add routines to update nam_ps
353 * Add global HLR struct
354 * Make subscr parameter to db_subscr_get() optional
355 * Add CTRL interface
356 * CTRL: add enable/disable packet service cmds
357 * Add .deb packaging
358 * deb: fix OBS build
359 * debian: remove obsolete dependency
360 * Attempt to fix .deb package
361 * deb: use python in shebang
362 * Another attempt at fixing .deb
363 * Use release helper from libosmocore
364 * Use value string check from osmo-ci
365
366 [ Daniel Willmann ]
367 * Add systemd service file
368 * hlr_data.sql: Insert ki and opc instead of op to example data
369 * tests/auc: Don't require python3
370
371 [ Pau Espin Pedrol ]
372 * VTY: Add hlr node and bind ip field
373 * debian: remove unneeded dependency libdbd-sqlite3
374
375 [ Harald Welte ]
376 * jenkins.sh: Proper error message if local environment isn't set up
377
378 [ Alexander Couzens ]
379 * debian/rules: show testsuite.log when tests are failing
380
381 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 20:37:33 +0200
382
Maxe9d37db2017-03-13 16:08:11 +0100383osmo-hlr (0.0.1) UNRELEASED; urgency=low
384
385 * Initial release (Closes: OS#1948)
386
387 -- Max Suraev <msuraev@sysmocom.de> Mon, 13 Mar 2017 16:26:41 +0200