blob: b6952509f9582dbb02b55262c51468fd698568b7 [file] [log] [blame]
Pau Espin Pedrol328ed942022-06-29 11:45:09 +02001osmo-sgsn (1.9.0) unstable; urgency=medium
2
3 [ Oliver Smith ]
4 * llme_free: clean up related sndcp
5 * treewide: remove FSF address
6
7 [ Pau Espin Pedrol ]
8 * Drop unneeded ax_check_compile_flag.m4
9 * Revert "sgsn: Handle different levels of QoS"
10
11 [ Neels Hofmeyr ]
12 * s/cipher_support_mask/gea_encryption_mask
13 * Iu: add UEA encryption
14
15 [ Vadim Yanitskiy ]
16 * tests: use 'check_PROGRAMS' instead of 'noinst_PROGRAMS'
17
18 [ Harald Welte ]
19 * update git URLs (git -> https; gitea)
20 * README: Major update
21
22 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 29 Jun 2022 11:45:08 +0200
23
Pau Espin Pedrol0f9966e2021-11-16 17:57:50 +010024osmo-sgsn (1.8.0) unstable; urgency=medium
25
26 [ Harald Welte ]
27 * Remove bogus DNS log category
28
29 [ Daniel Willmann ]
30 * manuals: Regenerate counters/VTY through docker
31
32 [ Vadim Yanitskiy ]
33 * main: resurrect removed 'ns' logging category as deprecated
34 * doc/manuals: update configuration.adoc to use new command syntax
35 * tests/Makefile.am: do not try removing non-existing files
36
37 [ Pau Espin Pedrol ]
38 * ranap: log ranap iu event type name instead of number
39 * gmm: log GMM msg type name instead of number
40 * gmm: Expect E_VLR_ANSWERED when in ST_IU_SECURITY_CMD
41 * gmm_fsm: Expect E_GMM_COMMON_PROC_INIT_REQ when in ST_GMM_COMMON_PROC_INIT
42 * mm_iu: Send event E_PMM_PS_CONN_ESTABLISH upon rx GMM SERVICE REQUEST
43 * mm_iu: Expect E_PMM_PS_ATTACH when in ST_PMM_IDLE
44 * gprs_gmm.c: State proper GMM prefix logging rx/tx of GMM messages
45 * mm_state_iu_fsm: T3314 expiry must lead to PMM IDLE, not PMM DETACHED
46 * Iu: Drop timer X3314
47 * gprs_ranap.c: Clean up code path releasing IU conn
48 * mm_state_{gb,iu}_fsm: Add missing license block, improve spec references
49 * mm_state_{gb,iu}_fsm: Improve naming for detach event
50 * Drop unused GBRPOXY enum field
51 * gtp: Delete ctx upon receive UpdateCtxResp with cause Non-existent
52 * Support forwarding RIM messages over GTPCv1 EUTRAN<->GERAN
53 * Use new stat item/ctr getter APIs
54
55 [ Keith ]
56 * vty: Fix optional display of pdp with mm-context
57 * VTY: Don't display 'PDP Address: invalid' for IPv4v6
58
59 [ Eric ]
60 * add support for multiple encryption algorithms and a5/4
61
62 [ Oliver Smith ]
63 * gtphub: remove llist_first, llist_last macros
64 * vty: add "page imsi"
65 * debian/control: remove dh-systemd build-depend
66 * Revert "Turn some compiler warnings into errors"
67
68 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 16 Nov 2021 17:57:50 +0100
69
Pau Espin Pedrol80adb302021-02-23 20:29:33 +010070osmo-sgsn (1.7.0) unstable; urgency=medium
71
72 [ Daniel Willmann ]
73 * gprs_gmm: Check for RAT change and ensure this only happens for RAU/ATT
74 * gbproxy-usermanual: Explain BSSGP/BVC handling
75 * gbproxy: Whitespace fixes
76 * gbproxy: Add todo for BVC RESET logic
77 * gbproxy: Get the peer if paging by BVCI on SIG_BVC
78 * Let libosmocore handle VTY parent node tracking
79 * osmo-gbproxy: Free msgb in ns2 prim callback
80 * configure.ac: Require python3 for ext_tests
81 * osmo-gbproxy: Implement nsvc-state ctrl command
82 * gbproxy: Remove test testing NSVCI change
83 * gbproxy: Add NSE peer that can have multiple gbproxy_peers
84 * gbproxy: Ensure BVC0 is reset before handling PtP BVCs
85 * gbproxy: Only send paging to each matching NSE once
86 * gbproxy: Separate function to move gbproxy_peer to different nse
87 * gbproxy: Add logging macros for NSE and BVC
88 * gbproxy: Use LOG macros for NSE/BVC
89 * gbproxy: Change generic LOG messages so BVCI/NSEI fmt is consistent
90 * gbproxy: Add todos encountered while going through the code
91 * gbproxy: Add BVC log filters
92 * gbproxy: Add newline to log message
93 * gbproxy: Allow gbproxy_nse_free(NULL)
94 * gbproxy: Delete gbproxy_nse in delete-gbproxy-peer VTY command
95 * mm_state_gb_fsm: Handle implicit detach from mm_standby
96 * gbproxy: Fix bvci check in gbprox_rx_ptp_from_*
97 * osmo-gbproxy: Initialize all hash_maps
98 * gbproxy: Fix confusing log message in gbprox_relay2nse
99 * gbproxy: Add SGSN NRI configuration
100 * gbproxy: Add SGSN pooling support
101 * gbproxy: Add comments to sgsn functions
102 * gbproxy: Add config option to name an SGSN
103 * gbproxy: Add VTY command to override the node selection function
104 * Fix gbproxy_sgsn_by_tlli wraparound
105 * gbproxy: Implement TLLI cache and use it for SUSPEND/RESUME
106 * gbproxy: Increase TLLI cache timeout to 10s
107 * gbproxy: Implement IMSI cache
108 * gbproxy: Use IMSI cache to handle PAGING_PS_REJECT
109 * gbproxy: Use C-style comments
110 * gbproxy: Move helper function to a more logical place
111 * gbproxy: Remove unused variable assignment
112 * gbproxy: Fix VTY cmd name
113 * gbproxy: Define and use help string for gbproxy
114 * gbproxy: Add VTY commands to query the TLLI/IMSI cache
115 * gbproxy: Use IMSI cache for PTP paging and implement DUMMY_PAGING_PS
116 * gbproxy: Print the correct message type for dummy paging/paging reject
117 * gbproxy: Improve log messages in gbproxy_select_sgsn
118 * gbproxy: Fix radio status routing by TMSI
119 * manual/gbproxy: Update overview chapter
120 * Rename OsmoGbPROXY -> *Proxy
121 * manuals/gbproxy: Update configuration chapter
122 * manuals/gbproxy: Add osmo-bsc MSC pooling chapter from Neels as a base
123 * manuals/gbproxy: MSC -> SGSN for pooling chapter
124 * manuals/gbproxy: Move pooling to separate chapter
125
126 [ Alexander Couzens ]
127 * gprs_gmm_fsm.c: Implement RAT change between 2g and 3g
128 * gtphub: rename sgsn's oww osmo_sockaddr into sgsn_sockaddr
129 * gprs_llc: _bssgp_tx_dl_ud: ensure the LLME is valid before using it
130 * gmm: on invalid RA id reject the MS with an implicit detach
131 * gtphub_test: fix compilation error on gcc 10.2.0
132 * gtphub: fix compilation with gcc 10.2.0
133 * Port gbproxy to NS2
134 * sgsn: check for NULL of gprs_subscr_get_or_create()
135 * sgsn: Use the new NS2 api
136 * gbproxy: use ns2 vty2
137 * configure.ac: define a c standard instead of using the compilers default
138 * follow libosmocore/gprs_ns2 API changes of GPRS enums
139 * gbproxy: follow gprs_ns2 API vty changes
140 * sgsn: migrate to the new gprs_ns2_vty configuration
141 * follow libosmocore/gprs_ns2 API changes (gprs_ns2_dynamic_create_nse)
142
143 [ Neels Hofmeyr ]
144 * manual: explain IuPS, add SCCP/M3UA section from common chapters
145 * fix nullpointer: in gsm48_rx_gmm_ra_upd_req()
146 * gsup: send RAT type on LU
147 * gbproxy_test.c: fix mobile identity test data
148 * use new osmo_mobile_identity API everywhere
149
150 [ Eric ]
151 * tests: dlopen does not imply availability of dlsym..
152 * configure.ac: fix libtool issue with clang and sanitizer
153
154 [ Harald Welte ]
155 * gtphub_test: Fix compilation with gcc-10
156 * Fix memory leak when SNDCP de-fragmentation is used
157 * Treat RAU as implicit RESUME if GMM is suspended
158 * *.spec.in: Use %config(noreplace) to retain current config file
159 * Send a BVC-RESET to all persistent Gb interfaces at start-up
160 * Use osmo_fd_setup() whenever applicable
161 * Use osmo_fd_*_{disable,enable}
162 * gbproxy: Properly implement paging to LAC/RAC
163 * gbproxy: Implement paging to entire BSS area
164 * gprs_gb_parse: Add function to determine TLLI from encoded BSSGP
165 * gbproxy: Pass TLLI as LSP towards NS to facilitate load sharing
166 * gb_proxy_peer: Add some FIXMEs regarding invalid assumptions
167 * gb_proxy: More precise + readable log messages
168 * gb_proxy: Broadcast SGSN-INVOKE-TRACE and OVERLOAD
169 * gbproxy: Move BSS-side BVC-RESET processing to its own function
170 * gb_proxy: Slightly restructure processing of BSS-originated BVC-RESET
171 * gbproxy: Cosmetics: use longer lines
172 * gbproxy: Send BVC-STATUS if BSS sends us BVC-RESET without mandatory IEs
173 * gb_proxy: Use TLVP_PRES_LEN instead of TLVP_PRESENT
174 * gb_proxy: Rename gbproxy_peer to gbproxy_bvc
175 * gbproxy: Rename gbproxy_cfg.nses to gbproxy_cfg.bss_nses
176 * gbproxy: convert bss_nses from llist_head to hashtable
177 * gbproxy: convert nse->bvcs from llist_head to hashtable
178 * gbproxy: Remove patching, TLLI-tracking and SGSN2 support
179 * gb_proxy: cosmetic: Use function rather than open-coding is_sgsn
180 * gbproxy: Delete gbproxy_test
181 * gb_proxy: Introduce more validation / constraint checks
182 * gbproxy: use gbprox_relay2peer() whenever possible
183 * gb_proxy: Use osmo_tlv_prot_parse() to validate mandatory IEs
184 * gbproxy: Log FSM timeouts
185 * migrate to DLBSSGP as log sub-system for BSSGP
186 * gbproxy major rewrite for SGSN pool support
187 * gbproxy: Use "(nsei << 16) | bvci" as rate_ctr_group index
188 * gbproxy: Introduce new DOBJ log category; log object allocation/release
189 * gbproxy: Don't create an extra msgb copy for SGSN DL SIG
190 * gbproxy: Implement handling of BVC Flow Control
191 * gbproxy: Copy RA-ID from BSS side BVC to CELL and SGSN-side BVC
192 * gbproxy: (Re)allocate SGSN-side PTP BVC even if CELL already exists
193 * gbproxy: Fix segfault when receiving PAGING for unknown destination
194 * gbproxy: Add FSM related VTY commands
195 * gbproxy: Implement scaling of BVC flow control in SGSN pool
196 * gbproxy: Improve VTY state introspection
197 * gbproxy: rename vty command "show gbproxy ..." to "show gbproxy bvc ..."
198 * gbproxy: Add "show gbproxy cell ..." VTY command
199 * gbproxy: Fix build on Deiban 8
200 * gb_proxy: Don't use orphan log subsystem DPCU
201 * gbproxy: Avoid depending on any of the SGSN code
202 * main: add --vty-ref-mode, use vty_dump_xml_ref_mode()
203 * manuals: generate vty reference xml at build time
204
205 [ Pau Espin Pedrol ]
206 * Use OSMO_FD_* instead of deprecated BSC_FD_*
207 * sgsn_libgtp: Improve ps-paging logging
208 * gprs_gmm_fsm.c: Add missing license header
209 * sgsn_libgtp: Avoid ps-paging MS on GMM Suspended state
210 * configure.ac: Fix trailing whitespace
211 * doc: Update VTY reference xml file
212 * Support setting rt-prio and cpu-affinity mask through VTY
213 * Change default SCTP conn NULL->127.0.0.1 to localhost->localhost
214 * contrib/jenkins: Enable parallel make in make distcheck
215 * Log error if pdp ctx is freed while holding an active timer
216 * Fix crash rx DeactPdpReq while waiting for DeactPdpAck after gtp side is freed
217 * sgsn_delete_pdp_ctx: Add documentation and assert assumptions
218 * process_ms_ctx_status: refactor to avoid code duplication
219 * process_ms_ctx_status: Fix crash deleting PDP Ctx if GTP side was already released
220 * gbproxy: generate coredump and exit upon SIGABRT received
221 * gtphub: generate coredump and exit upon SIGABRT received
222 * sgsn: generate coredump and exit upon SIGABRT received
223 * gmm: fix build without define PTMSI_ALLOC
224 * gmm: Introduce comment to ease addition of Network feature support IE later
225 * .gitignore: Ignore new autofoo tmp files
226 * sndcp: Fix struct bit fields on big endian
227 * Fix nsei+bvci not updated on rx UL SNDCP data
228
229 [ Oliver Smith ]
230 * contrib: import RPM spec
231 * contrib: integrate RPM spec
232 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
233 * contrib/jenkins: don't build osmo-gsm-manuals
234 * gbproxy: remove (moved to own repository)
235
236 [ Vadim Yanitskiy ]
237 * debian/control: change maintainer to the Osmocom team / mailing list
238 * gb_proxy_peer: sgsn can never be NULL in gbproxy_sgsn_by_nri()
239 * gb_proxy_peer: fix NULL pointer dereference in gbproxy_sgsn_alloc()
240
241 [ Keith ]
242 * Fix Radio Priority in MM Attach and PDP Context Activation
243 * VTY: Add gtp state-dir command
244
245 [ Philipp Maier ]
246 * gprs_sndcp: fix use after free
247 * sgsn_rim: Add routing for (GERAN) BSSGP RIM messages
248
249 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 23 Feb 2021 20:29:33 +0100
250
Pau Espin Pedrol394aa532020-01-03 19:17:56 +0100251osmo-sgsn (1.6.0) unstable; urgency=medium
252
253 [ Pau Espin Pedrol ]
254 * gprs_gmm: Introduce macros to access msgb's associated IU UE ctx
255 * gprs_llc.h: Improve documentation of some structs
256 * gprs_gmm.c: Improve doc on nullable parameters
257 * gprs_gmm.c: Drop unneeded brackets
258 * Introduce define TLLI_UNASSIGNED
259 * gprs_sgsn.c: Warn upon llme free unexpected scenarios
260 * gprs_gmm: Clarify comment during TLLI assignment
261 * gprs_sgsn.c: Remove recently introduced assert
262 * gprs_gmm: Introduce assert to guard against unexpected condition
263 * gprs_gmm.c: Use correct function to set MM_IDLE state during cleanup
264 * gprs_sgsn.h: Flag MM_CTX_T_GERAN_Iu as not supported
265 * gprs_gmm.c: Flag mmctx_set_(p)mm_state() functions static
266 * sgsn: use sccp_simple_client API to setup ss7 id 0 instead of 1
267 * gprs_gmm.c: Fix typo in log message
268 * gprs_gmm.c: Call mmctx_set_(p)mm_state only on related ran_type
269 * Introduce and use log macros when no mm ctx available
270 * gprs_gmm: Avoid spaces in fsm events and enum strings
271 * tests: Verify that timers can be set over VTY
272 * Replace own timer infra with libosmocore osmo_tdef
273 * tests: Introduce vty-transcript-test tests
274 * gprs_gmm.c: Use osmo_rai_name() in log line
275 * examples: Add osmo-sgsn_custom-sccp.cfg
276 * vty: Introduce cs7-instance-iu
277 * gprs_gmm.c: Print value_string of reject cause
278 * gprs_gmm.c: Add spec document to function documentation
279 * gtp: make echo_interval unsigned
280 * gtp: cb_delete_context(): Clarify why pdp->lib is set to NULL
281 * Introduce log helper LOGGGSN and log category DGTP
282 * sgsn: gtp: Drop related pdp contexts on echo timeout against GGSN
283 * Move lots of Iu/ranap specific code into its own file
284 * Move llc->MM/SM Gb specific glue code to its own file
285 * Split enum gprs_pmm_state into Iu and Gb counterparts
286 * Merge common allocation steps for Gb and Iu ctx
287 * gprs_gmm.c: Replace inet_ntoa with inet_ntop
288 * sgsn_cdr.c: Fix ip addr string buffer size
289 * sgsn_vty: Fix mmctx rate_ctr output indentation
290 * sgsn_vty: Print correct Iu mmctx id in 'show mm-context'
291 * Introduce FSM mm_state_gb_fsm
292 * Introduce FSM mm_state_iu_fsm
293 * vty: Print MM state and RAN type in show mm-context
294 * src/gprs/Makefile.am: Move build of shared .c files to an internal lib
295 * Move out gbproxy to its own subdir
296 * Move out gtphub to its own subdir
297 * Move out sgsn to its own subdir
298 * gmm: Move code handling GMM Attach Complete to its own function
299 * gmm: Move code handling GMM Routing Area Update Complete to its own function
300 * gmm: Move code handling GMM PTMSI Realloc Complete to its own function
301 * enum gprs_gmm_state: Fix spec reference
302 * Implement GMM State using osmocom FSM
303 * Split out GPRS SM layer into its own file
304 * sgsn: Reject PdpActReq if no GTP pdp ctx exists
305 * Introduce TODO-RELEASE file
306 * sgsn_libgtp.c: Drop use of deprecated libgtp APIs gtp_retrans*()
307 * gmm: Fix assertion hit during RA UPD REQ before completting gmm attach
308 * Improve logging in gprs_llc.c code
309 * gprs_llc.c: Use enum instead of hardcoded value
310 * gprs_gmm.c: Send XID reset with received TLLI
311
312 [ Alexander Couzens ]
313 * gprs/gprs_gmm: implement T3314. Timeout to reset MM state READY->STANDBY
314 * gprs_gmm: only update gb/iu cell information when Iu/Gb present
315 * gprs_gmm: clarify comment of Iu follow-on request
316 * gprs_gmm: gsm48_rx_gmm_att_req(): refactor duplicated code
317 * sgsn_pdp_ctx_terminate: check llme before accessing
318 * gprs_ranap: send CommonId after receiving Security Mode Complete
319 * mm_gb_fsm: unassign the llme when entering MM_IDLE
320 * gprs_ranap: refactor REQUIRE_MM define
321 * sgsn: when receiving data PDU notify the Gb GMM fsm
322 * Avoid compiling unneeded files when building without Iu
323 * gprs_ranap: release Iu UE Context when exiting PMM Connected
324 * Iu: implement a user inactivity timer
325 * gprs_ranap: on Iu release, stop the attach fsm if running
326 * gprs_mm_state_gb_fsm: ensure T3350 is not running when entering IDLE
327 * gprs_ranap: add missing rc = 0
328 * gprs_sgsn: always allocate Gb/Iu mm fsm
329 * sgsn: MM Gb Fsm: fix event handling for implicit detach
330 * ranap: add non-spec X1001
331 * gprs_gmm: release Iu connection on RAU failures
332 * sgsn_mm_ctx_alloc(): check for unallocated fsms
333 * sgsn_libgtp: refactor ps paging into gprs_gb
334 * sgsn: Gb: implementing PS Paging when MS is MM_STANDBY
335
336 [ Vadim Yanitskiy ]
337 * gprs_mm_state_iu_fsm.c: fix: assign timer_cb to mm_state_iu_fsm
338
339 [ Max ]
340 * Use libosmocore constant for IMSI length in ACL entry
341
342 [ Harald Welte ]
343 * LLC: Don't use hard-coded N201-U / N201-I values in XID
344 * Initial OsmoGbPROXY user manual
345 * check for osmo_fsm_register() error return values
346 * check for osmo_ss7_init() error return value
347 * manual: Fix copy+paste error
348 * exit(2) on unsupported positional arguments on command line
349
350 [ Oliver Smith ]
351 * gitignore: fix paths to binaries
352 * doc: add OsmoGbProxy VTY reference
353 * regen_doc.sh: support gbproxy, run without docker
354 * osmoappdesc.py, tests: switch to python 3
355
356 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 19:17:56 +0100
357
Pau Espin Pedrold7ef94c2019-08-08 16:46:31 +0200358osmo-sgsn (1.5.0) unstable; urgency=medium
359
360 [ Max ]
361 * Improve 'show subscriber cache' vty command
362 * GMM: permit VLR_ANSWERED event in attach FSM
363 * Fix IMSI padding in imsi-acl
364
365 [ Harald Welte ]
366 * gbproxy_test: Fix test expectations of gprs_ns_rcvmsg()
367 * LLC XID: Fix string representation of N201_U
368 * LLC: Don't blindly assume all LLC frames have data payload
369 * LLC: Avoid NOTICE message on LLC NULL
370 * gprs_llc: Correctly refuse any ABM command (SABM, DISC) with DM
371 * LLC: Store the XID inside the LLC Entity, not LLC Mgmg Entity
372 * gb_proxy.h: Add missing comments; improve comments
373 * gb_proxy: cosmetic: Use 'bool' in data structures where applicable
374
375 [ efistokl ]
376 * gsm0408_rcv_gmm: send Iu-ReleaseCommand upon receiving Attach Complete.
377 * gprs_gmm: send Service Reject when no PDP ctxs are available.
378
379 [ Alexander Couzens ]
380 * gprs_gmm: reintroduce calling gsm48_gmm_authorize when not handling GMM Attach Requests
381 * gbproxy: parse dtap GSM48_MT_GSM_DEACT_PDP_REQ|ACK
382
383 [ Pau Espin Pedrol ]
384 * gprs_sndcp_comp_free: Replace ifelse with switch and better handling of error
385 * sgsn: vty: Improve log warning content with spec section
386 * Document max retransmit times for T3395
387 * sgsn: Fix echo timer not started upon first pdp ctx created
388 * sgsn_libgtp: Use new per-GSN libgtp API instead of deprecated API
389 * sgsn: Have authentication required on by default
390 * Remove undefined param passed to {logging,osmo_stats}_vty_add_cmds
391 * Require newer versions of dependencies
392
393 [ Keith ]
394 * Echo zero byte XID-Field of Type L3_PAR
395
396 [ Oliver Smith ]
397 * debian: create -doc subpackage with pdf manuals
398 * contrib/jenkins.sh: run "make maintainer-clean"
399 * osmo-gtphub.cfg: fix conflict with osmo-sgsn.cfg
400 * osmo-gbproxy.cfg: fix conflict with osmo-sgsn.cfg
401
402 [ Vadim Yanitskiy ]
403 * doc/manuals/vty: regenerate sgsn_vty_reference.xml
404 * osmo-sgsn: add VTY parameter to toggle authentication
405 * sgsn_mm_ctx_find_ggsn_ctx(): fix: always set gsm_cause
406
407 [ Eric Wild ]
408 * replace magic tmsi constant with define
409 * turn -Werror=null-dereference into a warning
410
411 [ Daniel Willmann ]
412 * manuals: Add script to regenerate vty/counter documentation
413 * manuals: Update vty/counter documentation
414 * Add/fix help string for version option
415 * osmo-sgsn: Fix outdated information in usermanual
416 * configuration.adoc: Small fixes
417 * configuration.adoc: Add a section about encryption
418
419 [ Ruben Undheim ]
420 * Spelling fixes
421
422 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 08 Aug 2019 16:46:31 +0200
423
Harald Welte319a52b2019-01-23 18:32:41 +0100424osmo-sgsn (1.4.0) unstable; urgency=medium
425
426 [ Alexander Couzens ]
427 * gprs_subscriber: gsup_auth_error: reject MS in all cases
428 * gprs_gmm: make functions relating to GMM Attach Request public
429 * gprs_gmm: make extract_subscr_msisdn extract_subscr_hlr public
430 * gprs_gmm: Cancel Location: use detach type IMSI
431 * vty: add cmd "reset sgsn state"
432 * tests: remove gmm unit tests
433 * gprs_gmm: introduce a GMM Attach Request FSM
434 * debian: add missing build dependencies
435 * sgsn: use gtp_clear_queues() when reset sgsn state
436 * vty: restart sgsn state: improve output message
437 * sgsn_ggsn_ctx_drop_pdp: protect against nullpointer when MM is gone
438 * gprs_sgsn.h: fix wrong type of re-attempts
439 * GTP: refactor the echo timer
440 * gprs_gmm: dont answer unknown IMSI/TMSI on Service Requests NET_FAIL
441 * gprs_gmm: Fix missing Security Command for 3G when attaching
442 * sgsn_libgtp: fix a potential memleak when the GGSN is not reachable
443 * gprs_llc: remove the FCS from the msgb by trim'ing the msgb
444 * OsmoSGSN: add rate counter documentation
445
446 [ Daniel Willmann ]
447 * gb_proxy: tallocate memory for gbproxy cfg so it can be a talloc ctx
448 * gb_proxy: Add ctrl interface and nsvc-state, gbproxy-state commands
449 * git-version-gen: Don't check for .git directory
450
451 [ Stefan Sperling ]
452 * add a test for OS#3178 (invalid unitdata message)
453 * finish gbproxy_parse_bssgp_unitdata test
454 * fix bogus assertion in encode_comp_field()
455 * fix bogus error check in gprs_sndcp_comp_create()
456 * use enums consistently instead of falling back to int
457 * update gbproxy test expected output
458 * consistently check the result of osmo_shift_v_fixed()
459 * remove pointless declaration of struct gsm_network
460 * make gsup ipa name configurable in osmo-sgsn.cfg
461
462 [ Pau Espin Pedrol ]
463 * jenkins.sh: Use --enable-werror only when iu support is disabled
464 * jenkins.sh: Remove non-existent configure options
465 * Drop all references of unused SMPP
466 * Drop all references of unused MGCP
467 * Drop unused common_vty.c
468 * sgsn_libgtp.c: Log pointer of deleted context
469 * Maintain per ggsn pdp ctx list
470 * osmo-sgsn: ping GGSN periodically and check for restart counter
471 * Disarm T3395 when dettaching mmctx from pdpctx
472 * examples: Enable by default echo req towards active GGSNs
473 * vty: Add cmd to disable echo loop explictly
474 * Add optional TearDownInd IE in PDP DEACT REQ towards PCU
475 * sgsn: Don't attempt to delete GTP pdp ctx if GGSN was restarted
476 * Forward GGSN originated DEACT PDP CTX REQ
477 * sgsn: Fix T3395 firing forever
478 * sgsn: subscriber: Avoid calling memcpy with NULL src
479 * sgsn: cdr: Fix uninitialized string access if ggsn is detached
480 * sgsn: gtp: Use new API to send PDP DEL CTX REQ without freeing ctx locally
481 * sgsn: Fix crash using new libgtp cb_recovery2 API
482 * gbproxy: Replace '.' in counter names with ':'
483 * Drop gprs_msgb_copy with libosmocore replacement
484 * Drop gprs_msgb_resize_area with libosmocore replacement
485 * Use osmo_clock_gettime from libosmocore
486 * gbproxy: Add VTY parameter: link stored-msgs-max-length
487 * gbproxy: Add new VTY-managed timer: link-list clean-stale-timer
488 * gbproxy: Replace '.' in counter names with ':'
489 * Add osmo-gtphub systemd service file
490 * debian: Fix typo in rules preventing build with IU support
491 * Install systemd services with autotools
492 * Install sample cfg file to /etc/osmocom
493 * Update wrong references to bsc in sgsn code
494 * Allocate sgsn_instance with talloc
495 * gbproxy: flag gbproxy_assign_imsi as static
496 * gbproxy: Fix abort during APN patch
497 * gbproxy: Remove unneeded parse_ctx param
498 * gbproxy: flush_stored_messages: Move comment to func description
499 * gbproxy: flush_stored_messages: Log and route using stored_msg info
500 * gbproxy: flush_stored_messages: Get rid of msg param
501 * Allow easily disabling GFDL references
502 * OsmoSGSN: configuration: Move pdp ctx specific CDR fields to its own table
503 * OsmoSGSN: configuration: Add missing pdp-periodic event
504 * OsmoSGSN: configuration: Document CDR CTRL interface
505 * OsmoSGSN: overview: Fix typo and reference OpenGGSN->OsmoGGSN
506
507 [ Harald Welte ]
508 * migrate to oap_client in libosmogsm
509 * remove libcommon
510 * gbproxy-legacy: Ensure well-formed config file
511 * Remove local libgsupclient; Use libosmo-gsup-client from osmo-hlr
512 * initial checkin of manuals to public repo
513 * Add link to Asciidoc source code of manual
514 * OsmoSGSN: Fix formatting/cross reference in CDR section
515 * Update GSUP chapter regarding UMTS AKA and other recent changes
516 * GSUP: Add ladder diagrams for protocol transactions / procedures
517 * share chapters/gsup.adoc from OsmoSGSN to OsmoMSC + OsmoHLR
518 * vty-ref: Update URI of docbook 5.0 schema
519
520 [ Neels Hofmeyr ]
521 * use __FILE__, not __BASE_FILE__
522 * vty: fix doc str for 'reset sgsn state'
523 * vty: add SCCP related vty commands
524 * fix build: remove unused variable
525 * Importing history from osmo-gsm-manuals.git
526 * add 'make check' target
527 * fix 'make clean': shell glob, ignore failure
528 * refactor Makefile build rules, don't use the FORCE
529 * OsmoSGSN: update VTY reference
530 * sgsn: update vty reference
531
532 [ Oliver Smith ]
533 * gtphub: Add --version cmdline option
534 * build manuals moved here from osmo-gsm-manuals.git
535 * Fix DISTCHECK_CONFIGURE_FLAGS override
536 * contrib/jenkins.sh: build and publish manuals
537 * contrib: fix makedistcheck with disabled systemd
538
539 [ Max ]
540 * Cleanup non-existent files from debian/copyright
541 * Use safer functions for IMSI ACL
542 * gbproxy: fix formatting in gbproxy-state command
543 * gbproxy: add number-of-peers ctrl command
544 * Revert "gbproxy: fix formatting in gbproxy-state command"
545 * Add OsmoSGSN control interface description
546 * Remove misleading comment
547 * Constify sgsn_acl_lookup() parameter
548 * Drop unused osmo-sgsn.pc
549 * Use explicit length check
550 * Use explicit parameter for sgsn_auth_init()
551
552 [ Jonathan Brielmaier ]
553 * fix various typos across all manuals
554
555 [ ikostov ]
556 * SGSN: add Auth. policy, NS Statistics and BSSGP state examples, tweaks
557 * GSUP, OAP: fix AUTS length to 14, not 16
558
559 [ Philipp Maier ]
560 * osmo-sgsn: Update VTY command reference
561 * osmo-sgsn: improve auth-policy explaination
562 * osmo-sgsn: Explain TCP/IP header compression
563 * osmo-sgsn: fix arrow tips in flow diagrams
564
565 [ Holger Hans Peter Freyther ]
566 * sgsn: Fix numbering of QoS and add basic description for APN
567 * sgsn: Add charging characteristics to GSUP
568
569 -- Harald Welte <laforge@gnumonks.org> Wed, 23 Jan 2019 18:32:41 +0100
570
Pau Espin Pedrol39c67e22018-05-03 19:01:44 +0200571osmo-sgsn (1.3.0) unstable; urgency=medium
572
573 [ Neels Hofmeyr ]
574 * drop osmo_sgsn.cfg from src/gprs dir
575 * change default config filename to osmo-sgsn.cfg, not osmo_sgsn.cfg
576 * vty: skip installing cmds now always installed by default
577 * add --enable-sanitize config option
578 * use default point-code as listed on Point_Codes wiki page
579 * gprs_gmm: segfault: gracefully handle failure to alloc context
580 * gsm48_rx_gmm_att_req: fix error handling: don't clean up NULL llme
581 * gprs_llc: tx dl ud: make mismatching LLE not crash osmo-sgsn
582 * fix build: missing LIBGTP_CFLAGS in sgsn_test
583 * sgsn_test: guard against struct gprs_ra_id changing
584 * vty: absorb command explanations from osmo-gsm-manuals
585 * configure: add --enable-werror
586 * implement support for 3-digit MNC with leading zeros
587 * osmo-gbproxy: use 'osmo-gbproxy.cfg' as default config name
588 * compiler warnings: use enum ranap_nsap_addr_enc, constify local var
589 * use osmo_init_logging2(), fix regression test memleaks
590 * auth+ciph: log is_r99 and auth types
591 * log two RA Update Request failure causes
592 * GERAN: allow GSM SRES on UMTS AKA challenge
593
594 [ Alexander Couzens ]
595 * .gitignore: remove unneeded ignores of bsc/msc/nitb files
596 * tests/ctrl_test_runner.py: remove BSC/NAT TestRunner
597 * debian: remove doublicated project name in example files
598 * .gitignore: remove non-existent /src/utils exludes
599 * configure.ac: remove pcap check
600 * configure.ac: remove unused libcdk check
601 * .service: remove OpenBSC from service desription
602 * mandatory depend on libc-ares and libgtp
603 * GMM: dont reply to GMM_DETACH_REQ with POWER OFF when MS is unknown
604
605 [ Harald Welte ]
606 * Replace '.' in counter names with ':'
607 * Add talloc context introspection via VTY
608
609 [ Pau Espin Pedrol ]
610 * Replace '.' in counter names with ':'
611 * tests: Fix selection of python version
612 * sgsn_cdr: Split log formatting into a snprintf function
613 * Add vty cmd 'cdr trap' to send CDR through CTRL iface
614 * tests: sgsn_test: Define wrap APIs with correct parameters
615 * cosmetic: tests: sgsn_test: Use proper formatting and remove uneeded semicolons
616 * gprs_gmm: Remove unused variable
617 * cosmetic: gprs_gmm: Remove trailing whitespace
618 * gprs_gmm: Convert warning message to pragma message
619 * configure.ac: Enable Wall in CFLAGS
620 * .gitignore: Add m4 files
621 * sgsn_libgtp.c: Fix typos and whitespace
622
623 [ Max ]
624 * Fix display of GTP addresses
625 * Show GTP version for PDP context in vty
626 * Remove unneeded .py scripts
627 * Replace '.' in counter names with ':'
628 * Remove dead code
629 * Enable sanitize for CI tests
630 * cosmetic: use macro for gtphub plane iteration
631 * Use connection id when allocating rate counters
632 * Migrate from OpenSSL to osmo_get_rand_id()
633 * Remove obsolete ./configure option
634 * Fix RAI construction
635 * gtphub: make rate_ctr unique
636 * Remove unused bsc_version.c
637 * Use gsm48_encode_ra() for RAI encoding
638 * gtphub: check for gsn_addr_from_sockaddr() errors
639 * gtphub: check for gsn_addr_from_sockaddr() error
640
641 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 19:01:44 +0200
642
Harald Welte467cfeb2017-10-28 19:07:48 +0200643osmo-sgsn (1.2.0) unstable; urgency=medium
644
645 [ Neels Hofmeyr ]
646 * jenkins: fix build: remove unused dependencies
647 * debian: fix osmo-sgsn.install, tweak VCS link and descriptions
648 * drop files unrelated to osmo-sgsn
649 * rewrite README
650 * configure.ac: set name to osmo-sgsn, fix ML addr
651 * move openbsc.pc to osmo-sgsn.pc
652 * move include/openbsc to include/osmocom/sgsn
653 * jenkins.sh: fix echo string to say osmo-sgsn, not msc
654 * jenkins: use osmo-clean-workspace.sh before and after build
655
656 [ Alexander Couzens ]
657 * debian: fix paths of examples
658 * debian/rules: show testsuite.log when tests are failing
659
660 [ Max ]
661 * Remove rest_octets.h
662 * gbproxy: ensure peer allocation result
663 * jenkins: use osmo-ggsn for tests
664 * Cleanup configure checks
665 * Use extended logging for PDP contexts
666 * deb: fix copyright file issues
667 * Move P-TMSI alloc/update into separate function
668 * Check for correct P-TMSI allocation
669 * Use new FSF address in license header
670 * SGSN: uncomment BSSGP vty tests
671 * SGSN: print additional GTP-related info
672 * SGSN: check that GSN is created in proper mode
673 * Fix APN printing
674 * Fix build after recent rate_ctr patches
675 * gbproxy: don't link unnecessary
676 * Fix libosmo-sigtran dependency
677 * jenkins: check for IU properly
678 * Log GTP-U endpoints update
679 * Log address on GTP creation
680
681 [ Pau Espin Pedrol ]
682 * Remove unneeded dep libdbi
683
684 [ Philipp Maier ]
685 * log: fix default loglevels
686 * non-iu-build: guard vty libosmo-sigtran function calls.
687 * configure: fix libosmo-sigtran dependency
688
689 [ Harald Welte ]
690 * Debian: Add systemd service files for osmo-sgsn and osmo-gbproxy
691 * Debian: fix dh_strip rules for creating one -dbg per program
692
693 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 19:07:48 +0200
694
Alexander Couzens508c7632017-08-07 09:48:18 +0000695osmo-sgsn (0.1.0) unstable; urgency=low
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200696
Alexander Couzens508c7632017-08-07 09:48:18 +0000697 * Initial release.
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200698
Alexander Couzens508c7632017-08-07 09:48:18 +0000699 -- Alexander Couzens <lynxis@fe80.eu> Tue, 08 Aug 2017 01:13:05 +0000